Pianificazione delle regioni rigide e flessibili - Modalità avanzata

A colpo d'occhio

Questo articolo spiega come pianificare e posizionare le regioni rigide e flessibili di una scheda in Altium Designer utilizzando la modalità Rigid-Flex avanzata, con un chiaro confronto con la modalità standard per capire quando è necessario ricorrere al flusso di lavoro avanzato. Illustra come vengono definite le regioni della scheda, come identificare la modalità rigid-flex utilizzata da un PCB, come lavorare nella modalità di pianificazione della scheda e come posizionare, denominare e modificare con precisione le regioni, assegnando loro gli stack di layer. Evidenzia inoltre i principali comportamenti di posizionamento, le scorciatoie e le proprietà delle regioni rilevanti per la realizzazione di layout rigid-flex più complessi. Se cerchi una guida pratica per configurare e gestire con maggiore sicurezza le regioni di una scheda rigid-flex in modalità avanzata, continua a leggere.

- Imparerai la differenza tra la modalità Rigid-Flex standard e la modalità Rigid-Flex avanzata e scoprirai come cambia il modo in cui vengono create e definite le regioni della scheda.
- Vedrai come posizionare e modificare le regioni nella modalità di pianificazione della scheda, assegnando nomi e stack di layer e utilizzando guide e aggancio per lavorare con precisione.
- Scoprirai scorciatoie, modalità di posizionamento e impostazioni delle proprietà utili per lavorare in modo più efficiente con layout PCB rigid-flex complessi.
Approfondisci con l'IA:

Nel software di progettazione PCB di Altium sono disponibili due modalità di progettazione rigido-flessibile. La modalità originale, o standard, denominata Rigid-Flex, supporta progetti rigido-flessibili semplici. Se il progetto presenta requisiti rigido-flessibili più complessi, come regioni flessibili sovrapposte, è necessaria la modalità Advanced Rigid-Flex (nota anche come rigid-flex 2.0). La modalità si seleziona nel menu Tools del Gestore dello stack di layer.

La differenza fondamentale tra le modalità è che, nella modalità originale, la forma della scheda viene suddivisa in regioni separate posizionando una linea di divisione, che rimane come oggetto a definire dove termina una regione della scheda e ne inizia un'altra. Nella modalità avanzata, ogni regione della scheda viene posizionata separatamente oppure, se si taglia una regione più grande, questa diventa due oggetti regione separati. Nella modalità avanzata, sono i bordi delle regioni adiacenti a definire dove queste si incontrano, non la presenza di una linea di divisione. Per questo motivo, quando la scheda è in modalità Advanced Rigid-Flex non è presente alcun oggetto linea di divisione.

► Scopri di più sulla progettazione di un PCB rigido-flessibile

Il menu View offre tre modalità operative dell'editor PCB con scorciatoie facili da ricordare, che consentono di passare rapidamente da una modalità all'altra:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Per impostazione predefinita, passando tra le modalità di visualizzazione 2D e 3D vengono mantenute impostazioni separate di zoom e orientamento per ciascuna modalità. Se desideri mantenere la stessa posizione e lo stesso orientamento della scheda durante il passaggio, premi Ctrl+Alt+2 o Ctrl+Alt+3, anziché 2 o 3.

Hai appena aperto un PCB e ti stai chiedendo se utilizza la modalità rigido-flessibile standard o quella avanzata?

Puoi aprire il Gestore dello stack di layer per verificarlo. In alternativa, passa alla modalità di pianificazione della scheda (scorciatoia 1) e osserva la barra attiva:

Modalità Rigid-Flex standard
Modalità Advanced Rigid-Flex

Posizionamento di una regione della scheda

Una regione della scheda è un oggetto poligonale che viene posizionato utilizzando le tecniche standard di posizionamento degli oggetti poligonali. La forma della scheda deve essere definita con precisione, quindi è importante che le regioni che la compongono vengano create esattamente come richiesto. Il video seguente mostra come creare le regioni della scheda allineandone i bordi alle guide dell'area di progettazione posizionate in precedenza. Il vantaggio di questa tecnica è che la posizione delle guide dell'area di progettazione può essere definita con precisione modificandone le coordinate nel pannello Properties.

Le guide predefinite dell'area di lavoro vengono utilizzate come riferimenti per il posizionamento delle regioni della scheda.

Le regioni della scheda vengono posizionate e modificate in Board Planning Mode:

  1. Seleziona View » Board Planning Mode (oppure premi la scorciatoia 1) per accedere a Board Planning Mode. La regione della scheda predefinita esistente verrà visualizzata come un rettangolo verde.
  2. Seleziona Place » Board Region per posizionare una nuova regione (oppure fai clic sul pulsante nella Active Bar).
  3. Posiziona il cursore e fai clic per fissare il vertice iniziale della regione della scheda. La regione della scheda è un oggetto poligonale, come una regione o un poligono, e segue la stessa procedura di posizionamento e modifica.
  4. Sposta il cursore per prepararti a posizionare il secondo vertice. Per impostazione predefinita, a ogni clic vengono posizionati 2 bordi, con una forma dell'angolo definita dall'utente tra di essi; premi Spacebar per invertire la direzione dell'angolo. Consulta la sezione Placement Modes di seguito per ulteriori dettagli sulla modifica delle modalità degli angoli.
  5. Continua a spostare il mouse e a fare clic per posizionare i vertici, creando i bordi necessari a definire la forma complessiva della regione della scheda.
  6. Dopo aver posizionato l'ultimo vertice, fai clic con il pulsante destro del mouse o premi Esc per chiudere e completare la definizione della forma della scheda. Non è necessario chiudere manualmente la forma della scheda, poiché il software la completerà automaticamente collegando l'ultimo punto posizionato al punto iniziale.
  7. A ogni regione della scheda viene assegnato un nome che la identifica in modo univoco. Inserisci un nome appropriato nel campo Name nella modalità Regione della scheda del pannello Proprietà (la regione della scheda deve essere selezionata nell'area di progettazione per visualizzarne le proprietà nel pannello).
  8. A ogni regione della scheda deve essere assegnato uno stack di layer. Quando viene creata una nuova regione della scheda, le viene assegnato lo stack di layer predefinito, denominato Board Layer Stack. Assegna lo stack di layer richiesto nella modalità Board Region del pannello Properties. Gli stack di layer vengono definiti e denominati nel Gestore dello stack di layer.
  9. Se il PCB finale richiede più regioni della scheda, continua a definire altre regioni.
  • Ogni regione visualizza un'etichetta che mostra il nome della regione e il nome dello stack di layer a essa assegnato nel formato Region Name - Layer Stack Name. Il nome della regione della scheda viene assegnato nella modalità Board Region del pannello Properties, mentre il nome dello stack di layer viene assegnato nel Gestore dello stack di layer.
  • È possibile posizionare un numero qualsiasi di regioni della scheda per ottenere la forma della scheda richiesta. Le regioni della scheda possono sovrapporsi; tieni presente che ciò non definisce la distanza di penetrazione di una regione in quella adiacente, che viene invece definita nell'ambito della configurazione dello stack di layer nel Gestore dello stack di layer.
  • Una regione della scheda è un oggetto poligonale: per modificarne la forma, fai clic una volta per selezionarla, quindi fai clic e trascina un bordo o una maniglia di modifica. Scopri di più sulla modifica di un oggetto poligonale. Nota che, nella modalità avanzata, poiché le regioni della scheda vengono modificate in modo interattivo, nel menu Design della modalità di pianificazione della scheda non sono più presenti comandi di modifica.
  • Per rimuovere una regione della scheda, selezionala e premi il tasto Canc sulla tastiera. Deve sempre essere presente almeno una regione della scheda, quindi non è possibile eliminare l'ultima.
  • Oltre a disegnarle, è possibile creare le regioni della scheda anche a partire da primitive : scopri di più nella sezione Conversione tra primitive di disegno 2D e oggetti di definizione della scheda di questa pagina.
  • Durante il posizionamento o la modifica di una regione della scheda, il cursore è vincolato dalle impostazioni di aggancio, che includono: la griglia di aggancio corrente, gli oggetti disponibili per l'aggancio, la presenza di guide dell'area di lavoro e le impostazioni di aggancio agli assi. Utilizza queste funzionalità per ottenere la forma richiesta.

    ► Scopri di più sul funzionamento dell'aggancio.

Inoltre, puoi premere il tasto Tab per sospendere il posizionamento e accedere alla modalità Regione della scheda del Properties pannello, da cui puoi modificarne le proprietà al volo. Fai clic sul pulsante di pausa sovrapposto all'area di progettazione () per riprendere il posizionamento.

Placement Modes

Durante la ridefinizione della forma della scheda sono disponibili cinque modalità degli angoli, quattro delle quali dispongono anche di sottomodalità per la direzione dell'angolo. Durante la ridefinizione:

  • Premi Shift+Spacebar per scorrere le cinque modalità degli angoli disponibili.
  • Premi Spacebar per passare da una sottomodalità di direzione dell'angolo all'altra.
  • Quando è attiva una delle modalità con angoli ad arco, tieni premuto  tasto per ridurre l'arco oppure il tasto per ingrandirlo. Tieni premuto il tasto Shift durante l'operazione per accelerare il ridimensionamento dell'arco.
  • Premi il tasto di scelta rapida 1 per alternare tra il posizionamento di due bordi per clic e quello di un bordo per clic. Nella seconda modalità, il bordo tratteggiato viene chiamato segmento di anteprima (come mostrato nell'ultima immagine della serie qui sotto).
  • Premi il tasto Backspace per rimuovere l'ultimo vertice.

Premi Shift+Spacebar per scorrere le cinque modalità disponibili per gli angoli; premi il tasto di scelta rapida 1 per alternare il posizionamento di due bordi o di un solo bordo. 
 
 
Premi Shift+Spacebar per scorrere le cinque modalità disponibili per gli angoli; premi il tasto di scelta rapida 1 per alternare il posizionamento di due bordi o di un solo bordo.

Creare una regione della scheda da un corpo 3D

Le regioni della scheda possono essere create anche a partire da oggetti corpo 3D utilizzando il comando Create Board Region from 3D Body in modalità 3D. La procedura è la seguente:

  1. Assicurati di visualizzare la scheda in 3D (in caso contrario, usa la scorciatoia da tastiera 3 per passare rapidamente a questa modalità).
  2. Scegli il comando Design » Board Shape » Create Board Region from 3D body dai menu principali.
  3. Posiziona il cursore sul modello 3D che desideri utilizzare per generare la regione della scheda del PCB e fai clic oppure premi Enter. Il modello diventerà trasparente.
  4. Sposta il cursore sul modello 3D per individuare una faccia. Quando viene rilevata una superficie piana sotto il cursore, questa diventa opaca e presenta un sottile bordo blu.
  5. Una volta individuata la faccia appropriata, fai clic oppure premi Enter : verrà creata la nuova regione della scheda, che sostituirà quella precedentemente definita nell'area di progettazione.
  6. Verrà visualizzata la finestra di dialogo Board Outline Creation Successful, che conferma l'avvenuta creazione. Questa finestra consente di nascondere la parte del modello ed escluderla dai controlli DRC. Offre inoltre opzioni per modificare l'altezza del modello in modo da allineare la faccia alla superficie superiore o inferiore, oppure per lasciare invariata la posizione.
Il contorno della faccia selezionata deve essere allineato alla scheda PCB per poter definire la regione della scheda. 

Creare una regione di ritaglio della scheda

Per creare un ritaglio interno nella scheda, posiziona una regione di ritaglio della scheda (Place » Define Board Cutout, oppure fai clic sul pulsante in Active Bar). Anche il ritaglio della scheda è un oggetto poligonale, quindi la procedura di posizionamento è la stessa utilizzata per la regione della scheda. Le immagini seguenti mostrano una regione della scheda con due ritagli, che diventano fori nella scheda durante la fabbricazione.

Un ritaglio posizionato su una regione della scheda diventa un foro nella scheda finita. Un ritaglio posizionato su una regione della scheda diventa un foro nella scheda finita.

Suddividere il contorno della scheda in regioni

Puoi dividere una regione della scheda esistente in due regioni mediante un taglio. Questa operazione si esegue quando l'editor PCB è in Board Planning Mode.

La scheda è stata suddivisa in tre regioni della scheda utilizzando il comando Slice Region.

Per suddividere una regione della scheda:

  1. Selezionare View » Board Planning Mode (oppure premere la scorciatoia 1) per accedere a Board Planning Mode.
  2. Selezionare Design » Slice Board Region (oppure fare clic sul pulsante  nella barra attiva) per accedere alla modalità Slice Board Region.
  3. Quando si seleziona il comando, si entra nella modalità di suddivisione, simile alla modalità di posizionamento delle piste. Partendo dall'esterno della regione da suddividere, fare clic per fissare una serie di vertici che definiscono la linea di suddivisione. Durante la definizione della linea, premere Shift+Spacebar per scorrere le modalità degli angoli; premere Spacebar per alternare le modalità dell'angolo iniziale e finale e utilizzare il tasto Backspace per rimuovere l'ultimo angolo posizionato. Posizionare l'estremità della linea di suddivisione oltre il bordo della regione della scheda. Una volta completata la definizione della linea, fare clic con il pulsante destro del mouse oppure premere Esc per terminare il comando.
  4. Si apre una finestra di dialogo di conferma che indica il numero di poligoni (regioni) che verranno suddivisi dall'operazione e il numero di poligoni (regioni) che verranno creati. Fare clic su Yes per confermarne la creazione.

Ogni nuova regione creata può ereditare uno o più componenti contenuti nella regione originale. Se tali componenti appartengono a una classe di componenti, verrà creata una nuova classe per ogni nuova regione e l'appartenenza dei componenti verrà aggiornata di conseguenza.

Creazione di regioni della scheda dagli oggetti selezionati

A seconda della forma della scheda, può essere più efficiente costruirla creando più regioni della scheda. Come accennato sopra, le regioni possono essere posizionate in modo interattivo oppure create ricalcando un contorno definito da oggetti pista e arco. Il video seguente mostra come definire tre regioni della scheda a partire da oggetti selezionati. Nel video si può notare che lo stesso oggetto viene utilizzato per definire i bordi adiacenti nei punti di contatto tra le regioni, garantendone il posizionamento esatto.

Un approccio comune consiste nel definire il contorno delle regioni utilizzando piste e archi, per poi creare le regioni della scheda dai contorni selezionati.

Conversione tra primitive di disegno 2D e oggetti di definizione della scheda

Un approccio comune per definire la forma della scheda e le regioni necessarie al suo interno consiste nell'importare un disegno da un software CAD meccanico. Ad esempio, è possibile importare i dettagli meccanici da un file DWG, ottenendo una serie di linee (piste) su un layer meccanico che definiscono la forma della scheda, le regioni al suo interno e, per un progetto rigido-flessibile, la posizione delle linee di piegatura nelle regioni flessibili.

Il software include diversi comandi per creare oggetti di definizione della scheda (regione, ritaglio, linea di piegatura) a partire da primitive di disegno 2D, oltre ai corrispondenti comandi per riconvertire gli oggetti di definizione della scheda in primitive di disegno.

Oggetto Da primitive di disegno 2D selezionate Da oggetti di progettazione della scheda
Regione della scheda Create Board Region from Selected Objects
( sottomenu Design » Board Shape)
Explode Region to Free Primitives
Ritaglio della scheda Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Linea di piegatura Convert Selected Line to Bend Line Explode Bend Line

Note:

  • I comandi per entrambe le direzioni sono disponibili nel sottomenu Tools » Convert della modalità View pertinente (ad eccezione del comando Create Board Region from Selected Objects, che si trova nel sottomenu Design » Board Shape).
  • Per convertire le primitive di disegno 2D in oggetti di definizione della scheda, passare alla vista 2D Layout Mode.
    • Le primitive devono essere selezionate prima di eseguire il comando.
    • Le primitive devono formare una sagoma chiusa per creare una regione o un ritaglio. Consultare il riquadro di avvertenza qui sotto per ulteriori informazioni sui requisiti di questa sagoma.
  • Per convertire gli oggetti di definizione della scheda in oggetti di disegno 2D, passare alla vista Board Planning Mode.
    • Questi comandi non richiedono la selezione preventiva degli oggetti, ma agiscono sull'oggetto selezionato se ne è già stato selezionato uno.
    • Se sono presenti più regioni della scheda, la regione scompare quando viene scomposta in primitive. Se è presente una sola regione della scheda, le primitive vengono create e la regione scelta viene mantenuta (deve sempre essere presente almeno una regione della scheda).
    • Gli oggetti di disegno 2D vengono creati sul layer meccanico di tipo Board Shape. Se nella scheda non esiste un layer di questo tipo, verrà aggiunto un layer meccanico con il tipo di layer impostato su Board Shape. Ulteriori informazioni su layer meccanici e tipi di layer.
    • Sebbene non esista un comando specifico per ricomporre un oggetto scomposto, è possibile utilizzare il comando Undo per ottenere questo risultato.
Tutti i comandi che creano una forma poligonale a partire da un contorno composto da linee (piste) e archi tentano di individuare la forma seguendo la linea centrale degli oggetti selezionati. Se le coordinate dell'estremità di un segmento di pista/arco non corrispondono esattamente a quelle del segmento successivo, l'algoritmo di identificazione del contorno non riesce a completare l'operazione e viene visualizzato un messaggio che indica il punto in cui si è verificato il problema. Verrà quindi proposto di utilizzare un algoritmo di tracciamento alternativo. Si noti che questo algoritmo segue il bordo esterno degli oggetti pista/arco, perciò la forma sarà leggermente diversa da quella creata a partire dalle linee centrali. Scegliere questa opzione solo se il progetto può accettare le conseguenze di tale differenza.

Modifica delle regioni della scheda

Quando il PCB è configurato per utilizzare la modalità rigido-flessibile standard, il punto di incontro tra due regioni adiacenti è definito da una linea di separazione blu mobile. Questo approccio non viene utilizzato nella modalità rigido-flessibile avanzata: ogni regione è invece una forma poligonale chiusa e indipendente. Essendo una forma poligonale, ogni regione può essere modificata secondo necessità utilizzando le tecniche standard di modifica delle forme poligonali. Si noti che non tutti i comandi di modifica dei poligoni sono disponibili per modificare una regione della scheda, inclusi i comandi di aggiunta e sottrazione di poligoni.

Se si modifica la forma di una regione della scheda e questa si sovrappone a una regione adiacente, il software considererà presente nell'area di sovrapposizione la regione con il maggior numero di layer.

Aspetti da ricordare durante la modifica di un oggetto poligonale:

  • Quando si fa clic e si trascina un vertice o un bordo del poligono, sono disponibili tre modalità di modifica della forma: scorrimento, spezzatura e incurvamento. Premere Shift+Spacebar per scorrere le modalità durante il trascinamento. La modalità corrente viene visualizzata nella barra di stato e nel display Heads-Up.
  • Il comportamento di aggancio del cursore è controllato dalle impostazioni correnti, che includono la griglia di aggancio attuale, gli oggetti disponibili per l'aggancio, la presenza di guide nell'area di lavoro e le impostazioni di aggancio agli assi. Utilizzare queste funzionalità per ottenere la forma desiderata. Ulteriori informazioni su come funziona l'aggancio.

Assegnazione di uno stack di layer e modifica del nome della regione della scheda

Related page: Definizione dello stack di layer

Quando viene creata una nuova scheda, questa contiene una sola regione, denominata Default Layer Stack Region. A questa regione viene assegnato lo stack di layer predefinito denominato Board Layer Stack.

Quando si suddivide la forma di una scheda in più regioni, a ogni nuova regione viene assegnato anche lo stack di layer predefinito. Una volta definiti gli stack di layer necessari nel Layer Stack Manager, è possibile assegnare a ciascuna regione il relativo stack e attribuirle un nome significativo.

Ogni regione visualizza un'etichetta che ne indica il nome e quello dello stack di layer assegnato nel formato Region Name - Layer Stack Name. Se lo stack di layer selezionato è abilitato per il flex, ciò viene indicato anche da (flex). L'impostazione flex per uno stack si abilita nel Layer Stack Manager.

Per assegnare uno stack di layer e attribuire un nome a una regione:

  1. Selezionare View » Board Planning Mode o premere la scorciatoia da tastiera 1 per accedere a Board Planning Mode.
  2. Fare clic sulla scheda Multi-Layer nella parte inferiore dell'area di lavoro per renderla il layer attivo (se la scheda del layer non è visibile, premere L per aprire il pannello View Configuration e abilitarla).
  3. Fare doppio clic sulla regione della scheda per aprire la finestra di dialogo Board Region, oppure fare clic una sola volta sulla regione della scheda e aprire il pannello Properties. Se la regione non viene selezionata e la finestra di dialogo non si apre, assicurarsi che il filtro di selezione non escluda le regioni.
  4. Assegnare lo stack di layer selezionando quello desiderato dal menu a discesa Layer stack.
  5. Modificare il Name secondo necessità.

Il nome della regione della scheda e lo stack di layer assegnato vengono visualizzati al centro geometrico della regione. Viene visualizzata anche l'indicazione (Flex) quando lo stack assegnato è configurato come flessibile.
Il nome della regione della scheda e lo stack di layer assegnato vengono visualizzati al centro geometrico della regione. Viene visualizzata anche l'indicazione (Flex) quando lo stack assegnato è configurato come flessibile.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents