Definizione delle linee di piegatura - Modalità standard

A colpo d'occhio

Questo articolo spiega come definire, posizionare, spostare, rimuovere e configurare le linee di piegatura per le regioni flessibili quando si lavora in modalità Rigid-Flex standard in Altium Designer. Chiarisce inoltre le differenze tra la modalità Rigid-Flex standard e quella avanzata, come verificare quale modalità è utilizzata dalla scheda e quali viste e pannelli dell'editor consentono di gestire con precisione le piegature. Se cerchi una guida pratica per impostare posizione, angolo e raggio di piegatura, larghezza dell'area interessata e ordine di piegatura nella modalità corretta, questo articolo ti aiuterà a lavorare con maggiore sicurezza. Continua a leggere e applica questi passaggi al tuo prossimo progetto.

- Scopri quando è possibile utilizzare le linee di piegatura in modalità Rigid-Flex standard e in che modo questa modalità differisce da quella Rigid-Flex avanzata nella definizione delle regioni della scheda.
- Segui i passaggi esatti per posizionare, riposizionare, eliminare e allineare con precisione le linee di piegatura nella modalità di pianificazione della scheda.
- Scopri quali proprietà delle linee di piegatura puoi configurare, tra cui angolo e raggio di piegatura, larghezza dell'area interessata e sequenza di piegatura per le verifiche di piegatura in 3D.
Approfondisci con l'IA:

Nel software di progettazione PCB di Altium sono disponibili due modalità di progettazione rigido-flessibile. La modalità originale, o standard, denominata Rigid-Flex, supporta progetti rigido-flessibili semplici. Se il progetto presenta requisiti rigido-flessibili più complessi, come regioni flessibili sovrapposte, è necessario utilizzare la modalità Advanced Rigid-Flex (nota anche come rigid-flex 2.0). La modalità viene selezionata nel menu Tools del gestore dello stack dei layer.

La differenza fondamentale tra le modalità è che, nella modalità originale, la sagoma della scheda viene suddivisa in regioni separate posizionando una linea di divisione, che rimane come oggetto a definire dove termina una regione della scheda e ne inizia un'altra. Nella modalità avanzata, ogni regione della scheda viene posizionata separatamente oppure, se una regione più grande viene tagliata, diventa due oggetti regione distinti. Nella modalità avanzata, sono i bordi delle regioni adiacenti della scheda a definire dove le due regioni si incontrano, non la presenza di una linea di divisione. Per questa differenza, quando la scheda è in modalità Advanced Rigid-Flex non esiste alcun oggetto linea di divisione.

► Scopri di più sulla progettazione di un PCB rigido-flessibile

Il menu View offre tre modalità di lavoro dell'editor PCB con scorciatoie facili da ricordare, che consentono di passare rapidamente da una modalità all'altra:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Per impostazione predefinita, passando tra le modalità di visualizzazione 2D e 3D vengono mantenute impostazioni di zoom e orientamento separate per ciascuna modalità. Se desideri mantenere la stessa posizione e lo stesso orientamento della scheda durante il passaggio, premi Ctrl+Alt+2 o Ctrl+Alt+3, anziché 2 o 3.

Hai appena aperto un PCB e ti stai chiedendo se utilizzi la modalità rigido-flessibile standard o quella avanzata?

Puoi aprire il gestore dello stack dei layer per verificarlo. In alternativa, passa alla modalità di pianificazione della scheda (scorciatoia 1) e osserva la barra attiva:

Modalità Rigid-Flex standard
Modalità Advanced Rigid-Flex

Per definire come deve piegarsi una scheda flessibile, posiziona una o più linee di piegatura. La linea di piegatura definisce il punto della superficie della regione flessibile in cui deve avvenire la piegatura. Definisce inoltre l'angolo e il raggio di piegatura, oltre alla larghezza della striscia di superficie della scheda che viene piegata. Le linee di piegatura vengono posizionate e modificate con l'editor PCB in Board Planning Mode (View » Board Planning Mode, oppure premi la scorciatoia 1).

Una linea di piegatura può essere posizionata solo su una regione configurata come regione Flex nel Layer Stack Manager.


Una linea di piegatura viene posizionata sulla regione flessibile e configurata in modo che la scheda possa piegarsi di 180 gradi. Questo video mostra il posizionamento di una linea di piegatura nella modalità Rigid-Flex standard.

Posizionamento di una linea di piegatura

Per posizionare una linea di piegatura:

  1. Seleziona View » Board Planning Mode o premi la scorciatoia 1 per accedere a Board Planning Mode.

  2. Le linee di piegatura vengono posizionate sul Multi-Layer. Se la scheda Mutli-Layer non è visibile nella parte inferiore dell'area di modifica, abilita il layer nel pannello View Configuration (scorciatoia L per visualizzare il pannello).

  3. Seleziona il comando Design » Define Bending Line.

  4. Fai clic all'interno della regione della scheda in cui deve essere posizionata la linea di piegatura: un'estremità della linea si aggancerà al bordo della regione più vicino al punto in cui hai fatto clic, mentre l'altra estremità si aggancerà al cursore.

  5. Porta la seconda estremità nella posizione desiderata, quindi fai clic una volta per posizionarla.

  6. Rimani nella modalità di posizionamento delle linee di piegatura, pronto a posizionarne un'altra, se necessario. In caso contrario, fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento delle linee di piegatura.

Il pannello PCB in modalità Layer Stack Regions visualizza i dati Bending Lines. Fai doppio clic su una voce per aprire la finestra di dialogo della linea di piegatura. 

In questa regione flessibile della scheda sono state posizionate tre linee di piegatura. La larghezza della striscia arancione corrisponde alla larghezza dell'area interessata.
In questa regione flessibile della scheda sono state posizionate tre linee di piegatura. La larghezza della striscia arancione corrisponde alla larghezza dell'area interessata.

Quando una regione della scheda viene impostata per utilizzare uno stack di layer flessibile, viene aggiunta automaticamente una linea di piegatura verticale lungo il suo centro geometrico. Rimuovi questa linea di piegatura oppure riposizionala e configurala secondo necessità.

Spostamento di una linea di piegatura

Per modificare la posizione di una linea di piegatura esistente:

  1. Seleziona View » Board Planning Mode (oppure premi la scorciatoia  1) per accedere a Board Planning Mode.
  2. Fai clic una volta per selezionare la regione della scheda che contiene la linea di piegatura. Verranno visualizzate le maniglie di tutte le linee di piegatura presenti nella regione.
  3. Per spostare l'estremità di una linea, fai clic sul nodo e, tenendo premuto il pulsante del mouse, trascinalo nella posizione desiderata sul perimetro della regione della scheda. Il cursore sarà vincolato alla griglia di aggancio corrente e/o agli oggetti di progetto esistenti.
  4. La posizione della piegatura verrà ridefinita dalla nuova posizione della linea di piegatura.

Seleziona e trascina un nodo terminale di una linea di piegatura per modificare la posizione della piegatura sulla scheda.
Seleziona e trascina un nodo terminale di una linea di piegatura per modificare la posizione della piegatura sulla scheda.

Posizionamento preciso di una linea di piegatura

Quando una linea di piegatura viene spostata, la maniglia si aggancia ai punti della griglia di aggancio corrente. Durante lo spostamento, può anche agganciarsi a oggetti di progetto esistenti, come le linee su un layer meccanico. L'immagine seguente mostra una maniglia di una linea di piegatura posizionata all'estremità di una linea sul layer Mechanical 2 (evidenziata dal numero 1). Nota che, affinché l'aggancio funzioni, il layer meccanico deve essere il layer di progetto attivo.

Il numero 1 indica una maniglia di una linea di piegatura agganciata a una linea su Mechanical 2; nota che questo layer è quello attivo.
Il numero 1 indica una maniglia di una linea di piegatura agganciata a una linea su Mechanical 2; nota che questo layer è quello attivo.

Per illustrare più in dettaglio il processo descritto sopra, le immagini seguenti mostrano le linee di costruzione posizionate su Mechanical 2 in 2D Layout Mode, che definiscono con precisione i punti di riferimento superiori e inferiori utilizzabili per posizionare una linea di piegatura a 45 gradi.

La scheda in modalità layout 2D con le linee di costruzione che aiutano a posizionare con precisione le linee di piegatura diagonali.La scheda in modalità layout 2D con le linee di costruzione che aiutano a posizionare con precisione le linee di piegatura diagonali.

La scheda in modalità di pianificazione della scheda con le linee di piegatura diagonali agganciate alle linee di costruzione su Mechanical 2.La scheda in modalità di pianificazione della scheda con le linee di piegatura diagonali agganciate alle linee di costruzione su Mechanical 2.

Rimozione di una linea di piegatura

Per rimuovere una linea di piegatura:

  1. Seleziona View » Board Planning Mode (oppure premi la scorciatoia 1) per accedere a Board Planning Mode.
  2. Fai clic su uno dei suoi punti terminali e tieni premuto il pulsante del mouse, quindi premi il tasto Delete. In alternativa, seleziona ed elimina la voce relativa a una linea di piegatura nella sezione Bending Lines del pannello PCB .

Quando una regione della scheda viene impostata per utilizzare uno stack di layer flessibile, viene aggiunta automaticamente una linea di piegatura verticale lungo il suo centro geometrico. Rimuovi questa linea di piegatura oppure riposizionala e configurala secondo necessità.

Configurazione delle proprietà della linea di piegatura

Le regioni della scheda, le linee di divisione e le linee di piegatura vengono esaminate e modificate in Board Planning Mode (premi 1). Le linee di piegatura possono essere modificate in modo interattivo nell'area di progettazione oppure tramite PCB pannello quando è impostato sulla modalità Layer Stack Regions. Per visualizzare il pannello, fai clic sul pulsante Panels in basso a destra in Altium Designer, quindi seleziona PCB dal menu. Nel pannello, seleziona Layer Stack Regions dal menu a discesa nella parte superiore. In questa modalità, il pannello mostra:

  • Gli stack di layer della scheda disponibili nell'area Layer Stacks.
  • Le regioni assegnate a tali stack nell'area Stackup Regions.
  • Le linee di piegatura definite nella regione selezionata nell'area Bending Lines.

Quando si accede a Board Planning Mode, il pannello PCB viene configurato automaticamente sulla modalità Layer Stack Regions.

Per modificare le proprietà di una linea di piegatura nel pannello PCB:

  1. Le linee di piegatura possono essere modificate sia in 2D Layout Mode (premi 2) sia in Board Planning Mode (premi 1).
  2. Seleziona la casella Select nella parte superiore del pannello.
  3. Seleziona la regione della scheda che contiene la linea di piegatura nell'area Stackup Regions del pannello PCB .
  4. Seleziona la linea di piegatura dall'elenco nell'area Bending Lines del pannello. La linea di piegatura verrà evidenziata (selezionata) sulla scheda se l'opzione Select del pannello PCB è abilitata. È anche possibile eliminare una voce relativa a una linea di piegatura dall'area Bending Lines.
  5. Fai doppio clic sulla voce relativa alla linea di piegatura nell'area Bending Lines per aprire la finestra di dialogo Bending Line, come mostrato nell'immagine seguente.

  6. Nella finestra di dialogo Bending Line, modifica due delle prime tre proprietà, ad esempio Radius (la distanza del centro di piegatura dalla superficie di piegatura) e Bending Angle (l'angolo di piegatura della superficie della regione flessibile). La terza proprietà, Affected area width (la larghezza della superficie che verrà piegata per i valori specificati di Radius e Bending Angle), verrà calcolata automaticamente (maggiori dettagli di seguito). Tieni presente che Affected area width di ciascuna linea di piegatura viene visualizzato come un'area ombreggiata in arancione.
  7. Nella finestra di dialogo Bending Line, imposta Fold Index secondo necessità per definire la sequenza con cui vengono eseguite le piegature quando si utilizza il cursore Fold State nel pannello PCB o il comando View » Fold/Unfold, che consentono di piegare la scheda in modalità 3D. La piegatura con il valore più basso viene applicata per prima, fino a quella con il valore più alto.

Per una delle regioni della scheda deve essere selezionata la casella 3D Locked nella finestra di dialogo Board Region, in modo da definire il piano di riferimento fisico per la modalità di visualizzazione 3D (dove Z = 0). In caso contrario, Affected area width di ciascuna linea di piegatura definita non verrà visualizzato.

È possibile accedere alla finestra di dialogo Bending Line anche premendo Tab durante il posizionamento o lo spostamento di una maniglia di una linea di piegatura, oppure facendo doppio clic su una maniglia della linea.

Riepilogo della definizione delle piegature

Una linea di piegatura è un oggetto lineare che viene posizionato trasversalmente a una regione per definire la posizione, il raggio e l'angolo della piegatura da applicare a quella regione flessibile della scheda.

Definizione di una linea di piegatura:

  • Le linee di piegatura vengono posizionate in modalità di pianificazione della scheda (scorciatoia 1).
  • Per posizionare una linea di piegatura, esegui il comando Design » Define Bending Line.
  • Posiziona la linea di piegatura trasversalmente alla regione flessibile della scheda. Non è necessario che l'inizio e la fine della linea di piegatura tocchino esattamente i bordi della regione: il software la estenderà automaticamente (se troppo corta) o la accorcerà (se troppo lunga). Almeno un'estremità della linea di piegatura deve toccare o oltrepassare il bordo della regione.
  • Per modificare le proprietà di una linea di piegatura, fai clic in un punto qualsiasi della regione per visualizzare i vertici di tutte le linee di piegatura al suo interno, quindi:
    • Fai doppio clic sul vertice di una linea di piegatura per aprire la finestra di dialogo Linea di piegatura, oppure
    • Visualizza il pannello PCB e impostalo sulla modalità Layer Stack Regions, in cui puoi esaminare e modificare le regioni e le linee di piegatura.
    • Imposta Bending Angle e Radius della piegatura secondo necessità.
    • Le piegature vengono eseguite nell'ordine definito da Fold Index; utilizza questa funzione quando è importante verificare l'ordine di piegatura.
  • Per spostare una linea di piegatura, fai clic su ciascun vertice e trascinalo.
  • Per rimuovere una linea di piegatura, fai clic su uno dei vertici e tieni premuto il pulsante del mouse, quindi premi Delete sulla tastiera.
  • Le linee di piegatura non possono essere applicate al bordo di un ritaglio della scheda. Se la scheda lo richiede, passa alla modalità Rigid-Flex avanzata.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents