Altium Designer Documentation

Defining the Board Shape

Modified by Phil Loughhead on Dec 11, 2020

Rigid-Flex is under active development. Use of the new rigid-flex features requires the following change in the Advanced Settings:

  • Disable the Legacy.PCB.RigidFlex option to access the new Board Shape, Region Object and Bending Line features.
  • The documentation on this page is for the new Board Shape, Region Object and Bending Line features. If you have not disabled the Legacy.PCB.RigidFlex option, the documentation for the previous version should be used.

Parent page: The Board

Javascript

The Board Shape defines the overall shape of the finished board. Click through the slides to see the three Board Regions that make up the rigid-flex shape, and the finished board in 3D.

Summary

The Board Shape, also referred to as the board outline, is a closed polygonal shape that defines the overall extents of the board. The Board Shape can be made up of a single Board Region (for a traditional rigid PCB), or multiple board regions (for a rigid-flex PCB). As well as providing a visual guide of the extents of the space available for the placement and routing of the design, the Board Shape is also used by the software for:

  • Power plane edge pullback, and edge references for splitting a power plane into separate voltage zones. Learn more about Defining and Managing Copper Areas.
  • Calculating the board edge when outputting design data to other tools.

Availability

The Board Shape is only available in the PCB editor. When a new PCB file is created, it opens with a rectangular Board Shape created from a single Board Region.

The overall Board Shape can be created by:

  • Placing one or more Board Regions to build up the overall Board Shape, or
  • Slicing an existing Board Region into two smaller Board Regions and repeating this process as required to achieve the required number and shapes of Board Regions, or
  • Creating the Board Shape from objects selected in the workspace, that form a closed boundary. Alternatively, if the board requires multiple Board Regions then the Board Regions can be created from objects selected in the workspace.
The default Board Shape in a new PCB document is a rectangular shape (6 inch x 4 inch, or 6000mil x 4000mil, or 152.4mm x 101.6mm). For specific project templates that can be used when creating a new PCB project, the associated PCB document in each case has a specific Board Shape according to the form factor of the board.
The current viewing mode for the PCB document can be changed using the corresponding commands from the main View menu. Alternatively, change views quickly using the 1 (Board Planning Mode), 2 (2D) and 3 (3D) keyboard shortcuts.

Interactively Defining and Editing the Board Shape

The Board Shape is created from one or more Board Regions. For designers working on a single-region board design, the following commands can be used to define the Board Shape:

  • Board Planning Mode:
    • Place » Board Region - use this command to interactively define the Board Region (for a single-region board, the Board Region defines the Board Shape). Learn more about the Board Region object.
  • 2D Layout Mode:
    • Design » Board Shape » Define Board Shape from Selected Objects - select a set of line and/or arc primitives that define a closed shape then use this command to redefine the Board Shape to match the shape.
    • Design » Board Shape » Create Primitives from Board Shape - create a set of primitives along the Board Shape boundary, in accordance with the settings configured in the Line/Arc Primitives from Board Shape dialog.
  • 3D Layout Mode:
    • Design » Board Shape » Define Board Shape from 3D body - use this command to define the Board Shape by selecting the desired surface of a 3D model.

The difference between the Define Board Shape from Selected Objects command and the Create Board Region from Selected Objects command is that the first command replaces all existing Board Regions with the new region that is created when the command is run, whereas the second command creates an additional Board Region, without removing any existing Board Region(s).

Defining the Board Shape from Selected Objects

The Board Shape can also be defined from selected objects (in 2D Layout Mode). Typically this will be a set of lines and/or arcs placed on the Keepout layer or a mechanical layer.

Use the following sequence of steps:

  1. Set the View mode to 2D Layout Mode (View menu).
  2. Select the objects. The Edit » Select » All on Layer command is ideal for this, the selection set must only include the tracks and arcs that form the shape of the board outline.
  3. Once all the objects are selected, run the Design » Board Shape » Define Board Shape from Selected Objects command. The Board Shape will update to follow the path defined by the selected lines. A warning dialog will appear if the software is unable to follow the centerline of the selected objects. The View mode will change to Board Planning Mode.
  4. Open the View Configuration panel and double-click to edit the mechanical layer that holds the board shape. The Edit Layer dialog will open, where you can set the Layer Type to Board, as shown in the animation below.

This Board Shape has been defined from a set of selected lines and arcs placed on the Keepout layer.

The software will attempt to find the shape based on the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment, the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects, so the Board Shape will be slightly different than the one created from the centerlines. Only choose this option if your design can accept the impact of this difference.

Importing an Outline to Use for the Board Shape

The Board Shape can be defined from a closed outline imported as DXF/DWG data.

By combining the ability to import DXF / DWG data into a mechanical layer and then defining the board shape from selected objects, a shape defined in a mechanical CAD package can be transferred into the PCB editor.

To prepare the new board for import:

  1. Select File » New » PCB. A new blank PCB will open, the black region represents the current Board Shape.
  2. Before importing a new shape, set the following as required to suit the requirements of your design and the shape being imported:
  • The Units - set the units as required in the Other section of the Properties panel in Board mode. ( show image )
  • The Grid - double-click on the Global Board Snap Grid and set it as required in the Grid Manager section of the Properties panel in Board mode. ( show image )?
  • The Origin - For a new PCB the default location for the user-definable origin is at the absolute origin, the bottom left of the workspace. Select Edit » Origin » Set from the main menus then click to define the location of the user-definable origin, for example, the bottom left corner of the current board shape. It helps to set this to suit the location of the origin in the incoming outline.

The next step is to import the board's shape as a .DXF or .DWG file. Note that the shape to be imported must be a closed shape and internal cutouts are not automatically created (but can be defined later from imported objects).

  1. Select File » Import » DXF/DWG to open the Import File dialog, ensure the File Type on the bottom right of the dialog is AutoCAD Files (*.DXF,*DWG) then browse to find the required file. 
  2. When the Open button is clicked the Import from AutoCAD dialog will open. ( show image )
  3. Set the Scale, Default Line Width and Layer Mappings as required then click OK.
  4. Each DXF/DWG object will be mapped to an object and will be displayed in the workspace. 
  5. Make the mechanical layer that holds the board shape objects the active layer, then select all objects on that layer (Edit » Select » All on Layer).
  6. To update the Board Shape to match the selected outline, run the Design » Board Shape » Define from Selected Objects command.
  7. If the board includes board cutouts, these can be created by selecting the outline of the cutout and running the Tools » Convert » Create Board Cutout from Selected Primitives command.

The software will attempt to find the shape based on the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment then the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects so the board shape will be slightly different than the one created from the centerlines. Only choose this option if your design can accept the impact of this difference.

Defining the Board Shape from a 3D Body

This feature redefines the board shape based on a surface (face) of an imported 3D model. Supported model formats includes: STEP (*.Stp or *.STEP), Parasolid (*.x_t or *x_b), or a SOLIDWORKS Part File (*.SldPrt). It can be used to quickly create a complex board shape and helps integration between electronic and mechanical design areas. This is a two-stage process: first the STEP model is imported, then the required shape is selected from the STEP model. 

To do this:

  1. Switch to View » 3D Layout Mode.
  2. To import the 3D model, place a 3D body (Place » 3D Body).
  3. In the Choose Model dialog, locate and select the model file. The 3D model will be imported into the PCB editor and stored inside a 3D Body object. Note that this model can be deleted from the PCB once the board shape has been redefined, if required.
  4. Select Design » Board Shape » Define Board Shape from 3D body.
  5. The Status bar will prompt you to Pick a 3D body. Click the imported 3D body to select it.
  6. The cursor will change to a crosshair and the Status bar will prompt you to Choose Face. As you hover the cursor over each face, it will be outlined. Click to select the correct face.
  7. The Board Outline Creation Successful dialog will appear, displaying options for: which PCB surface should align with the selected surface (typically the top layer), and if the 3D model should be hidden from view and design rule checking. The hide and disable behavior can be changed later if required, in the 3D Models mode of the PCB panel.

Note that if you keep the STEP model embedded in or linked to the PCB file, you will be notified whenever the STEP file changes. You will also be prompted to update the shape, which helps if the shape is still under development and updates are expected.

Only surfaces aligned with the X-Y plane can be used to create the board shape. If you select a model surface that requires alignment in the X-Y plane, you will be asked in a Confirmation dialog to align the surface before you can continue. This dialog also allows you to place the model using the selected face in relation to either the top or bottom surface of the board. This means that the vertical position of the model can also be set at the same time. After alignment, you will need to select Design » Board Shape » Define from 3D Body again. After the board shape has been redefined, you will be given the option to hide the 3D body.

Creating Primitives from the Board Shape

As well as defining the Board Shape from selected primitives, it also is possible to create primitives from the Board Shape using the Design » Board Shape » Create Primitives from Board Shape command. This command will open the Line/Arc Primitives from Board dialog. Use this command when the Board Shape exists but there are currently no objects along the boundary. Situations where this command can be useful include:

  • When you want to modify the Board Shape (or board cutouts) by modifying track and arc primitives first.
  • When you need a keepout boundary for the board or keepout boundaries for board cutouts. This is discussed in more detail below in the Important Design Considerations When Using Board Cutouts section.

Cutting a Hole in the Board Shape

A board cutout can be placed anywhere in the Board Shape. To place a cutout, switch to view the board in 2D Layout Mode then use the Design » Board Shape » Define Board Cutout command from the main menus (alternatively, you can also use the Place » Define Board Cutout command in Board Planning Mode). Note that the cutout is actually a Region object configured to be a negative object.

A Board Cutout has been placed on the Board Shape.

If the board cutout is an unusual shape, such as a circle, it can be easier to create an outline of the cutout shape using tracks and arcs (for example, Place » Arc » Full Circle), select the shape, and then convert it to a Board Cutout (Tools » Convert » Create Board Cutout from Selected Primitives).

Important Design Considerations When Using Board Cutouts

Keep the following points in mind when creating a board cutout.

Keeping a Polygon Back from the Edge of a Board Cutout

Polygons that overlay a solid region board cutout will pour as close to the edge of the cutout as allowed by the applicable Clearance design rule. A specific Clearance design rule can be created if required, which could, for example, be scoped to apply between IsBoardCutoutRegion and InPolygon.

Defining a Route Tool Path Around the Edge of the Board and Cutouts

A common approach used to cut the finished board from the fabrication panel is to mill or route the board out of the panel. Board cutouts can also be routed out. A Route Tool path is defined by placing Line and/or Arc objects on a mechanical layer. This can be done manually or automatically by the software.

To define a Route Tool path for the board and any board cutouts:

  1. With the board in 2D Layout Mode, run the Design » Board Shape » Create Primitives From Board Shape command. The Line/Arc Primitives From Board Shape dialog will open.
  2. Define a suitable Width for the objects that will define the Rout Tool path. Consult with your fabricator if you are unsure of this.
  3. Select an available mechanical layer. This layer should be reserved for just the Rout Tool path definition.
  4. Enable the Include Cutouts option if the board has cutouts in it.
  5. Enable the Route Tool Outline option. When this option is enabled the line/arc objects are placed so their edge touches the edge of the Board Shape and the edge of the cutout.
  6. Click OK to create the Route Tool objects on the chosen mechanical layer. 
  7. The mechanical layer used must be set as the Route Tool layer. To do this, access the Layers & Colors tab of the View Configuration panel. Right-click within a layers grid and choose the Add Mechanical Layer command. In the Edit Layer dialog that appears, set the Layer Type to Route Tool Path.  This layer type is used to indicate the layer that contains the mechanical routing information. Note that a user-defined name is not permitted when the Layer Type is set to Route Tool Path. The reason for this is that older versions of the software use the name of the Route Tool Path layer to identify the layer that contains the route information (also referred to as rout information). Fixing the naming of this layer ensures that the design will continue to function correctly in an older version.

The images below show the Route Tool path defined on a mechanical layer.

A Board Cutout shown on the left, with a Route Tool path defined in the image on the right.

Keepouts and the Board Shape

As well as the Board Shape, you also should define a placement and routing boundary around the edge of the board. This can be created automatically from the Board Shape itself using the Design » Board Shape » Create Primitives From Board Shape command (in 2D Layout Mode), and setting the Layer in the Line/Arc Primitives from Board dialog to the Keep-Out Layer.

Alternatively, this can be done manually by placing objects on the keepout layer. Objects placed on this layer define a no-crossing-allowed boundary for components and routing. Typically you want objects such as components and routing to be a certain distance from the edge of the board; this distance can be controlled by setting the applicable routing and component placement design rules. You can also define other routing and component keepouts areas for mechanical objects, such as screw heads or other mounting requirements.

A keepout boundary defined by placing standard line objects on the keepout layer.

Keepout boundaries can be defined by placing any standard design objects, such as lines, arcs, fills, and regions on the Keepout layer. Objects placed on the Keepout layer create a keepout on all signal layers.

You also can define layer-specific keepouts on any copper layer. To do this:

  1. Click on the layer tab of the required layer.
  2. Define the boundary or area of the keepout area by placing layer-specific keepout objects (Place » Keepout submenu). Layer specific keepouts are standard objects with the Keepout attribute enabled. They are displayed in the same color as the layer with a keepout colored edge. Note that layer-specific keepout objects are not included in Gerber or ODB++ output files.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。