押し出し、球体、円筒3Dボディの操作
概略
- 押し出し形状、円柱形状、球形状の3Dボディオブジェクトの違いと、それぞれの定義方法および配置方法を学びます。
- Propertiesパネルとコマンド実行中のショートカットを使って、形状の寸法、外観、配置時の動作を制御する方法を紹介します。
- Component Body Managerを使用して、既存のフットプリント形状から3Dボディを生成・管理する方法を理解します。個々のコンポーネントに対する処理や一括更新のオプションも説明します。
3D Bodyオブジェクトの使用方法としては、PCB上で部品を正確かつ詳細に表現でき、PCBエディターでの3D干渉チェックの精度も向上するため、汎用3Dモデルの配置が推奨されます。ただし、3D Bodyオブジェクトは、押し出し形状、球形、円柱形の3D Bodyを配置するためにも使用できます。配置できる単純な3D Bodyオブジェクトには、次の3種類があります。
| Extruded | X-Y平面(上面図)では、PCBエディターで他の多角形オブジェクトを定義するのと同じ方法で、押し出しオブジェクトを対話的に定義します。その後、Propertiesパネルの3D Bodyモードで定義したOverall HeightおよびStandoff Heightプロパティと、Body Projectionオプションに基づいて、オブジェクトをZ方向に上向き(または下向き)に押し出します。押し出し形状の3D Bodyオブジェクトの表面には、ロゴなどのテクスチャファイルを適用することもできます。 |
| Cylindrical | この形状のプロパティは、Propertiesパネルの3D Bodyモードで定義します。 |
| Spherical | この形状のプロパティは、Propertiesパネルの3D Bodyモードで定義します。 |
押し出し形状、球形、円柱形の3D Bodyオブジェクトの配置
直接配置
PCBエディターとPCBフットプリントエディターのどちらでも、次の方法で押し出し形状、球形、円柱形の3D Bodyオブジェクトを配置できます。
- メインメニューからPlace » Extruded 3D Bodyコマンドを選択します。
-
Active Barで押し出し3D Bodyコマンド(
)を見つけて使用します。
押し出し形状、球形、円柱形の3D Bodyオブジェクトを配置するには、次の手順を実行します。
- コマンドを実行すると、カーソルが十字カーソルに変わり、デフォルトの配置モードで押し出し形状の3D Bodyオブジェクトを配置できる状態になります。
-
Tabを押して配置を一時停止し、3D BodyモードのPropertiesパネルを表示します。設計スペースに一時停止ボタンのオーバーレイ(
)が表示され、Propertiesパネルの各フィールドを操作できることを示します。
- PropertiesパネルのIdentifierフィールドに3D Bodyの名前を入力します。これは任意です。識別子は、複数の3D Bodyを配置する際の区別に役立ち、必要に応じて設計ルールでこの3D Bodyを対象に指定するためにも使用できます。
-
必要なBoard Sideを選択します。通常は
Topに設定します。PCBライブラリエディターでは、フットプリントは基板の上面用に作成されます。必要に応じて、PCB設計中に下面に反転できます。 - 3D Bodyを配置するメカニカルLayerを選択します。コンポーネントタイプのメカニカルレイヤーは、別のメカニカルレイヤーとペアにする必要があります。これにより、部品を基板の上面から下面に反転したときに、3D Bodyなどのメカニカル情報もペアのメカニカルレイヤーに移動します。メカニカルレイヤーのペア設定は、View ConfigurationパネルのLayers and Colorsタブで行います。詳細については、このパネルの説明ページを参照してください。
- 使用可能な形状(Extruded、Cylinder、Sphere)から3D Model Typeを選択します。
-
各形状は、配置する前にサイズを定義する必要があります。選択した形状に応じて、次のように設定します。
- Extruded – Overall Heightを定義します。
- Cylinder – HeightとRadiusを定義します。
- Sphere – Radiusを定義します。
- パネルのDisplay領域で、Colorボタンをクリックして色を設定し、必要に応じてOpacityを調整します。
-
編集が完了したら、一時停止ボタンのオーバーレイをクリックして設計スペースに戻ります。
-
形状がCylinderまたはSphereの場合:
- 設計スペース内でカーソルに長方形が付いた状態になります。クリックして3D Bodyを配置します。
- 右クリックするかEscを押して、3D Bodyオブジェクトの配置を終了します。
-
形状がExtrudedの場合、押し出し形状の3D Bodyの多角形の底面を定義できる状態でカーソルが表示されます。
- クリックして最初の頂点を定義します。
- カーソルを移動し、2つ目の頂点を配置する位置に合わせます。デフォルトでは、クリックするたびに2つの辺が配置され、その間にはユーザーが指定した形状のコーナーが作成されます。詳細については、以下の押し出し3D Bodyの配置モードセクションを参照してください。
- 引き続きマウスを移動してクリックし、頂点を配置します。
- 最後の頂点を配置したら、右クリックするか Esc を押して形状を閉じ、3D Bodyの配置を完了します。ソフトウェアが始点と最後に配置した点を自動的に接続して形状を完成させるため、3D Bodyを手動で閉じる必要はありません。
-
形状がCylinderまたはSphereの場合:
押し出し3D Bodyの配置モード
押し出し形状の3D Bodyを配置する際には、5つのコーナーモードを使用できます。そのうち4つには、コーナーの方向を指定するサブモードもあります。配置中は、次の操作が可能です。
- Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。
- Spacebarを押すと、2つのコーナー方向サブモードが切り替わります。
-
いずれかの円弧コーナーモードでは、
または
キーを押し続けると、円弧を縮小または拡大できます。Shiftキーを押しながら操作すると、円弧のサイズ変更が速くなります。
- 1ショートカットキーを押すと、 1回のクリックで2つの辺を配置するモードと、 1回のクリックで1つの辺を配置するモードが切り替わります。後者のモードでは、破線の辺をlook-ahead segmentと呼びます。
- Backspaceキーを押すと、最後の頂点が削除されます。

押し出し形状の3D Bodyオブジェクト。2Dビューと3Dビューに表示されている基準点に注目してください。
閉じた形状からの作成
3D Bodyを組み合わせてコンポーネントの形状を作成する作業を効率化するため、ソフトウェアでは、フットプリント内で検出された閉じた形状を基に、一連の押し出し3D Bodyオブジェクトを作成できます。この機能は、コンポーネントが特殊な形状をしており、その形状がフットプリントのコンポーネントオーバーレイにすでに定義されている場合に役立ちます。また、フットプリントのメカニカルレイヤーにオブジェクトを追加し、それらを基に追加の3D Bodyオブジェクトを作成することもできます。 たとえば、ピンの作成に利用できます。
以下の画像は、TO-92トランジスタのフットプリントを示しています。Top Overlayレイヤーに描かれた輪郭を使用して、選択した3D Bodyレイヤーペア(ダイアログではRegistration Layerと呼ばれます)上にトランジスタ本体を定義しています。また、メカニカルレイヤー上には3つの小さな正方形(それぞれ4本の線で構成)が作成されており、選択した3D Bodyレイヤーペア上でコンポーネントのピンを定義するために使用されています。 設定は、以下のダイアログ画像に示されています。

フットプリント内の既存オブジェクトを使用して、新しい3D Bodyオブジェクトを作成できます。
フットプリント内の形状から3D Bodyオブジェクトを作成するには、Tools » Manage 3D Bodies for Current Componentコマンドを実行します。Component Body Managerダイアログが開きます。 このダイアログでは、コンポーネントで現在使用されている3Dボディと、使用されていない3Dボディを確認できます。必要に応じて、コンポーネントにボディを追加したり、コンポーネントからボディを削除したりできます。ボディには、次の3種類があります。
- 意図的に配置された3D Body(説明では Component Body と呼ばれます)。
- 外接矩形からソフトウェアによって自動作成された矩形形状。
- 設計プリミティブからソフトウェアによって自動作成された閉じた多角形。
高さ、ボディの投影方向、基準レイヤー、色、不透明度など、ボディのその他のプロパティも変更できます。 Body State列には、3D Bodyオブジェクトの作成に使用される4つの形状が表示されていることに注目してください。
コンポーネントの3Dボディを必要に応じて定義したら、 Close ボタンをクリックして変更を適用します。

ソフトウェアでは、既存オブジェクトの形状を基に3D Bodyオブジェクトを作成できます。
このダイアログの使用に関する注意事項:
- 検出アルゴリズムは、外接矩形から作成した矩形形状、またはプリミティブが形成する形状の輪郭に沿った多角形のいずれかを提示します(トラック/円弧の端点が一致している場合は、その中心線に沿ってトレースされます)。
- 既存オブジェクトから3D Bodyを作成するには、Body State列の青いテキストをクリックします。
- Overall Heightのデフォルト値は、フットプリントのPropertiesパネルで定義されたHeightです。
- 基板を下方向に貫通するコンポーネントのピンについては、Body ProjectionをBottom Sideに設定します。
- ダイアログのCloseボタンをクリックすると、3D Bodyオブジェクトが作成されます。表示がすでに3Dモードに設定されている場合、新しいオブジェクトを表示するには、表示を更新する(Endショートカット)、2Dに切り替えてから3Dに戻す、またはView ConfigurationsパネルのView OptionsタブでShow 3D BodiesオプションをOffとOnに切り替える必要がある場合があります。
- PCBフットプリントエディターで現在開いているアクティブなPCBフットプリントライブラリ内のすべてのコンポーネントの3D Bodyを編集するには、メインメニューから Tools » Manage 3D Bodies for Library コマンドを選択します。
- PCBエディターでこのダイアログを使用して3D Bodyを編集するには、メインメニューからTools » Manage 3D Bodies for Components on Boardコマンドを選択するか、コンポーネントを右クリックしてコンテキストメニューから コンポーネント操作 » 3D Bodyの管理 を選択します。
-
Tools » Manage 3D Bodies for Components on Board コマンド(PCBエディター)または Tools » Manage 3D Bodies for Library コマンド(PCBフットプリントエディター)を使用してダイアログを開くと、ダイアログ上部にComponents領域が表示されます。この領域には、アクティブなライブラリ内の各コンポーネントフットプリントが一覧表示されます(実際の設計では、基板上のすべてのコンポーネントが一覧表示されます)。各項目には、デジグネーター(設計側でのみ表示)、フットプリント名、高さ、およびソースライブラリ情報が表示されます。
また、追加の Batch Update タブも使用できるようになります。 このタブでは、すべてのコンポーネント、または選択したコンポーネントに3Dボディオブジェクトをすばやく一括追加できます。3Dボディの検出と作成のための検索条件、および3Dボディのプロパティを定義する条件を指定できます。バッチ処理のすべてのオプションを必要に応じて設定したら、 Execute Batch Update ボタンをクリックします。処理対象の各コンポーネントに対して検索が実行され、3Dボディ形状が検出されて作成されると、指定したプロパティ条件に従って、そのボディがコンポーネントに追加されます。このモードでは、バッチ更新の実行時に変更が適用されます。
- このダイアログでは、コンポーネントの3Dボディを1か所でまとめて管理できるため、3D Bodyごとに Propertiesパネルを開く必要がありません。
Component Body Managerダイアログのオプションとコントロール

Component Body Managerダイアログ(背面)とComponent Body Manager for Componentダイアログ(前面)
コンポーネント
ダイアログの上部領域には、アクティブなライブラリ内の各コンポーネントフットプリントが一覧表示されます(実際の設計では、基板上のすべてのコンポーネントが一覧表示されます)。各項目には、デジグネーター(設計側でのみ表示)、フットプリント名、高さ、およびソースライブラリ情報が表示されます。
インタラクティブタブ

Component Body ManagerダイアログのInteractive タブ
ダイアログのComponent Body Manager バージョンには、InteractiveタブとBatch Updateタブの2つがあります。Interactive タブでは、コンポーネントのボディや選択したボディのプレビューなど、選択したコンポーネントに関する情報を簡単に確認できます。
既存および候補のコンポーネントボディ
-
Existing and Potential Component Bodies - この領域には、コンポーネントで使用されている、または使用できる可能性のあるすべての既存コンポーネントボディ(3D Body)が一覧表示されます。各コンポーネントボディには、以下の情報が表示されます。
-
Description - ボディの作成方法に関する説明です。意図的に配置された3D Body(説明ではComponent Bodyと呼ばれます)、外接矩形から作成された矩形形状、または設計プリミティブから作成された閉じた多角形のいずれかになります。各ボディの説明には、配置されたものか自動作成されたものかにかかわらず、そのボディが存在するメカニカルレイヤー(または作成元のオブジェクトが存在するメカニカルレイヤー)と面積も含まれます。矩形ボディと多角形ボディは、
と
によって区別されます。それぞれのアイコンです。
- Body State - ボディがコンポーネントで使用されているか(In Component <ComponentDesignator>)、使用されていないか(Not In Component <ComponentDesignator>)を示します。必要に応じて項目をクリックし、状態を切り替えます。
- Standoff Height - 基板表面から押し出しボディの下面までの距離です。PCBを下方向に貫通する押し出しボディには、負の値を使用します。
- Overall Height - 基板表面から押し出しボディの上面までの距離です。
- Body Projection - 3Dボディが突出する基板の面です。フィールドのドロップダウンから、Top SideまたはBottom Side(上方向または下方向に突出)を選択します。コンポーネントの反転に伴って3Dボディオブジェクトが基板の反対側に反転されると、この設定は自動的に変更されます。
- Registration Layer - 3Dボディが配置されているメカニカルレイヤーです。フィールドのドロップダウンから、現在有効なすべてのメカニカルレイヤーの中から選択します。選択したメカニカルレイヤーがペアになっている場合、コンポーネントの反転に伴ってボディが基板の反対側に反転されると、ペアのメカニカルレイヤーにも移動します。
- Body 3D Color - 3Dボディに現在使用されている色です。カラースウォッチをクリックして標準のChoose Colorダイアログを開き、必要に応じて別の色を割り当てます。
- Body 3D Opacity - 3Dボディの現在の透明度です。フィールドのドロップダウンから、Solid (完全に不透明)、Hide (ボディを非表示にする)、25% Opacity、50% Opacity、75% Opacityを選択します。
-
Description - ボディの作成方法に関する説明です。意図的に配置された3D Body(説明ではComponent Bodyと呼ばれます)、外接矩形から作成された矩形形状、または設計プリミティブから作成された閉じた多角形のいずれかになります。各ボディの説明には、配置されたものか自動作成されたものかにかかわらず、そのボディが存在するメカニカルレイヤー(または作成元のオブジェクトが存在するメカニカルレイヤー)と面積も含まれます。矩形ボディと多角形ボディは、
- Component bodies in: <ComponentDesignator> - コンポーネントの2Dフットプリントと、現在Body StateがIn Component <ComponentDesignator>に設定されている3Dボディを重ねて表示します。プレビューは動的で、ボディを含めるか除外するかに応じて変化します。
- Selected Body - 上のリストで現在選択されているボディを表示します。ウィンドウのタイトル領域にも、ボディの説明が表示されます。
一括更新タブ

Component Body ManagerダイアログのBatch Updateタブ
Batch Updateタブでは、ライブラリ内のすべてのフットプリントまたは選択したフットプリント、あるいは設計内に配置されたすべてのフットプリントまたは選択したフットプリントに、3Dボディオブジェクトをすばやく追加できます。
グリッド領域
この領域では、3Dボディを検出・作成するための検索条件と、Projection side(ボディの突出方向とも呼ばれます)、Registration Layer、Standoff Height、Overall Height、3D Body Colorなどの3Dボディのプロパティを定義します。
リストの各項目は、3Dボディになり得る形状を検出・作成する際に検索するレイヤーの範囲をそれぞれ指定します。各検索は、Enabled列のオプションで個別に有効にします。複数の検索を有効にできますが、検索が成功するたびに3Dボディが追加される点に注意してください。通常は、フットプリントのプリミティブやコンポーネントの外形情報を配置する場所に応じて、特定の1つのレイヤーまたはレイヤーセットでの検索を有効にします。デフォルトでは、All Layersの検索が実行されます。
Detection Method フィールドでは、各3Dボディの形状をどのように定義するかを指定できます。
- Bounding Rectangle - フットプリントの外接矩形を使用します。
- Closed Shapes - コンポーネントのフットプリントのプリミティブから作成された、多角形の閉じた形状を使用します。
- Both (Prefer Closed Shapes) - フットプリントのプリミティブに基づいて、外接矩形または多角形の閉じた形状を検出します。両方が検出された場合は、多角形の閉じた形状を使用します。
Prefer component height if not 0オプション列では、コンポーネントのフットプリントに定義された高さ属性を3DボディのOverall Heightとして使用するかどうかを指定できます。このオプションを有効にすると、0より大きい高さ属性が定義されている各コンポーネントについて、その高さが追加する3Dボディの Overall Heightに設定され、Standoff Heightは0に設定されます。
Body 3-D Colorは、3Dボディの描画に使用する色を指定します。色をクリックすると、Choose Colorダイアログで変更できます。
オプション
- Apply Only To Selected Components - 選択したフットプリントのグループにのみ3Dボディの条件を適用する場合は、このオプションを有効にします。対象のコンポーネントがダイアログ上部の領域で選択されていることを確認してください(標準のCtrl+ClickおよびShift+Click の機能を使用して複数選択します)。このオプションを無効にすると、一括追加処理はライブラリ内のすべてのフットプリント(または基板上のすべてのコンポーネント)に適用されます。
- Delete Existing Bodies In Components - 一括処理の対象となるフットプリントに現在定義されている3Dボディを削除するには、このオプションを有効にします。タブの右下にあるプレビューウィンドウでは、現在選択されているコンポーネントのフットプリントと、現在選択されている有効な検索項目に基づいて、追加される3Dボディの外観を確認できます。一括処理のすべてのオプションを必要に応じて設定したら、Execute Batch Updateボタンをクリックします。処理対象の各フットプリントに対して検索が実行され、3Dボディの形状が検出・作成されると、定義したプロパティ条件に従ってそのボディがフットプリントに追加されます。
一括処理のプレビュー
各レイヤーに定義された3Dボディをプレビューするために使用します。
その他のコントロール
- Execute Batch Update - クリックすると、処理対象の各フットプリントの更新が実行されます。3Dボディの形状が検出・作成されると、定義したプロパティ条件に従ってそのボディがフットプリントに追加されます。
選択したプリミティブからの作成
3Dボディは、対話形式で配置するだけでなく、閉じた形状を定義する既存のトラック、円弧、ソリッドリージョンオブジェクトのセットから作成することもできます。モデルが単純な場合に適した方法です。既存の閉じた形状から3Dボディを定義するには、次の手順を実行します。
- 閉じた形状を構成するすべてのプリミティブを選択します。
- Tools » Convert » Create 3D Body From selected primitivesをクリックします。
選択したトラックが配置されているレイヤーに関係なく、プリミティブで形成された閉じた境界から、Top Layer上に3Dボディが作成されます。つまり、形状をメカニカルレイヤー上で定義することもできます。リージョンの作成後も、元の選択したプリミティブはそのまま残り、選択状態も維持されます。3Dボディの境界は、境界を形成するトラックオブジェクトの中心線に沿って作成され、3Dボディ自体は選択されません。
Create 3D Body From selected primitivesアルゴリズムは選択したオブジェクトの中心線を使用するため、接するオブジェクトの終点と始点が完全に一致している(同じX、Y座標にある)必要があります。一致していない場合は、Confirmダイアログが表示され、アルゴリズムが失敗した位置が示されます。また、代わりにオブジェクトのエッジから3Dボディの定義を試みるよう、アルゴリズムに指示することもできます。選択したオブジェクトがわずかに重なっていれば、このオプションによって、選択したオブジェクトの外側のエッジに沿った境界を持つ3Dボディを作成できるはずです。
グラフィカル編集
グラフィカルな編集方法では、デザインスペースに配置された3Dボディオブジェクトを直接選択し、そのサイズ、形状、位置をグラフィカルに変更できます。
押し出し3Dボディの場合、オブジェクトを1回クリックして選択すると、編集モードになります。3Dボディオブジェクトの外形は一連の辺で定義されます。各辺の両端には、白い塗りつぶしの四角(下図のA)で示される端点頂点があり、中央には、白い中空の四角(下図のB)で示される中央頂点があります。各端点頂点は、2つの辺が交わる位置を表します。
形状の編集には、標準的な多角形の編集手法を使用できます。
多角形オブジェクトを編集する際には、Slide/Miter、Incurvate(円弧)、Moveの3つの編集モードを使用できます。Shift+Spacebarを押して3つのモードを順に切り替えることで、現在のモードをwhile dragging a vertex or an edge変更できます。
- Slide/Miter – 辺または中央頂点をクリックしたままドラッグすると、その辺をスライドできます。端点頂点をクリックしたままドラッグすると、角を面取りできます。
- Incurvate – 辺または中央頂点をクリックしたままドラッグすると、その辺を湾曲させることができます。端点頂点をクリックしたままドラッグすると、角を円弧状に丸めることができます。
- Move – 辺または中央頂点をクリックしたままドラッグすると、その辺を2つの辺に分割できます。端点頂点をクリックしたままドラッグすると、その角を自由に移動できます。
編集中は、次の操作も可能です。
- Ctrl+click and hold編集ハンドルから離れた辺上の任意の位置で
- 新しい頂点を挿入します。 頂点を削除するには、頂点をクリックしたまま Deleteキーを押します。
-
編集ハンドルから離れた3Dボディ上の任意の位置をクリックし、 ドラッグして位置を変更します。ドラッグ中に、3Dボディを回転または反転できます。
- Spacebarを押すと3Dボディが反時計回りに回転し、Shift+Spacebarを押すと時計回りに回転します。Rotation Stepの大きさは、PreferencesダイアログのPCB Editor – Generalページで定義します。
- XまたはYキーを押すと、3DボディをX軸またはY軸に沿って反転できます。
STEPへの変換
選択した押し出し形状、円筒形、球形の3Dボディオブジェクトを STEPモデルに変換できます。STEPモデルはデザインファイルに自動的に埋め込まれます。独立した3Dボディオブジェクトを変換するには、デザインスペースで選択してから右クリックし、コンテキストメニューからConvert To STEPコマンドを選択します。オブジェクトが選択されていない場合や、複数のオブジェクトが選択されている場合、このコマンドは使用できません。STEPに変換したオブジェクトは、デザインスペースでサイズを変更できなくなります。

X軸またはY軸を中心に回転させる必要がある場合は、押し出し形状をSTEPに変換してください。
押し出し形状、球形、円筒形の3Dボディオブジェクトの基準点
押し出し形状、球形、円筒形の3Dボディオブジェクトには、基準点 または原点があります。
- 円筒形および球形の場合、基準点はX-Y平面上の オブジェクトの円形部分の中心点です。
- 押し出しオブジェクトの場合、基準点は上から見たときの X方向の長さ/2、Y方向の長さ/2 の位置に設定されます。
- PropertiesパネルのX/Y Locationに表示されるのは、デザインスペース内におけるこの基準点の位置です。

押し出し形状、球形、円筒形の3Dボディオブジェクトには、図に示すように基準点があります。基準点を示す線は短いため、 オブジェクトの外側には表示されない場合があります。
押し出し3Dボディへのテクスチャの追加
押し出しオブジェクトの最上面には画像を重ねて表示することもでき、 3D表示で基板をよりリアルに表現できます。Texture Fileを追加すると、下図のように、3Dボディの上面全体を覆うように自動的に引き伸ばされます。 テクスチャファイルは、ライブラリファイルまたは基板ファイルにリンクされます。
サポートされているテクスチャファイル形式は、*.bmp、*.dds、*.dib、*.hdr、*.jpg、*.pfm、*.png、*.ppm、および *.tgaです。

押し出し3Dボディオブジェクトには、テクスチャやロゴを追加できます。
これは、Propertiesパネルの3D Bodyモードで、Centerの位置、Size、Rotationの設定を変更することで調整できます。
エディターが3Dレイアウトモードに設定されている場合は、 メインメニューから Tools » 3D Body Placement » Move Texture Location コマンドを選択して、 選択した押し出し3Dモデルに関連付けられたテクスチャオブジェクトの位置を変更することもできます。 コマンドを実行すると、カーソルが 青い円錐(3D選択モードを示す)に変わり、テクスチャが関連付けられた押し出し3Dボディを選択するよう求められます。目的の3Dボディにカーソルを合わせてクリックするか、 Enterを押します。もう一度クリックするか、 Enter を押して、最も近い角を基準にテクスチャを「つかみます」。テクスチャを目的の位置に移動し、クリックするか、 Enter を押して配置を確定します。テクスチャがカーソルに追従している間は、オブジェクト移動時の標準的な追加操作(Spacebar/Shift+Spacebarで回転、XまたはY で反転、矢印キーでテクスチャを少しずつ移動)を実行できます。
また、選択した押し出し3Dボディ内のテクスチャは、マウスでクリックしてドラッグすることでも移動できます。