配置済みコンポーネントの操作
概略
- コンポーネントの取得元、パーツやマルチパートコンポーネントの扱い方、回路図に配置する主な方法を学びます。
- コンポーネントを効率よく検索し、配置中や配置後にグラフィカルな編集をすばやく行う方法を確認します。
- 回路図コンポーネントとPCBコンポーネントの関係、および配置後に確認・編集できる主要なプロパティを理解します。
ライブラリ内のコンポーネントは、実際のプリント基板に配置される物理デバイスを表します。回路図シート上では、コンポーネントは回路図シンボルモデルで表されます。各コンポーネントには、1つ以上のパートを含めることができます。
パート
概要
パートは、電気設計のプリミティブです。抵抗、スイッチ、オペアンプ、電圧レギュレーターなどの電子デバイスを表す回路図シンボルです。パートは、回路図コンポーネントライブラリのコンポーネント内に保存されます。各コンポーネントには、1つ以上のパートを含めることができます。パートには、コンポーネントのシンボル表現に加えて、PCBフットプリントなどのモデルへのリンクや、コンポーネントのパラメーター、サプライヤー情報などの詳細を記録するためのパラメーターも含まれます。モデルへのリンクとパラメーターをパートに追加する方法は、使用するライブラリの保存形式によって異なります。
使用できる場所
パートは、回路図エディターと回路図ライブラリエディターの両方で配置できます。
- 回路図エディターで、Place » Partをクリックします。
- デザインスペース内で右クリックし、コンテキストメニューからPlace » Partを選択します。
- Componentsパネルでコンポーネントを右クリックし、Place <ComponentName>を選択します。
- Componentsパネルで、プレースホルダーとして汎用コンポーネントを選択します。
- Componentsパネルからコンポーネントをドラッグ&ドロップします。
- ComponentsパネルのDetailsペインでPlaceボタンを選択するか、Enterホットキーを使用します。
- 回路図ライブラリエディターで、SCH Libraryパネルからコンポーネントを選択し、Placeをクリックします。
Componentsパネルからの配置
回路図エディターでは、Componentsパネルからパートを選択して配置できます。
- パネルには、現在選択されているライブラリの内容が表示されます。別のライブラリを選択するには、ライブラリ名の横にあるドロップダウンを使用します。
- 現在選択されているライブラリのフィールドの下にあるマスクフィールドを使用すると、リストを絞り込んで検索を効率化できます。または、スクロールして必要なパートを選択します。
- Placeをクリックするか、ダブルクリックするか、クリックしてドラッグすると、選択したコンポーネントをアクティブな回路図シートに配置できます。パートがカーソルに追従している間は、配置前に回転(Spacebarを押す)、軸に沿った反転(XまたはYを押す)、編集(Tabを押す)を行えます。
- 現在選択されているライブラリのコンポーネントリストに表示される列は、並べ替え(クリックしてドラッグ)や再設定(右クリックしてSelect Columnsを選択)が可能です。
-
汎用コンポーネントのタイル内にある
ボタンをクリックすると、コンポーネントがカーソルに追従し、アクティブな回路図ドキュメントに配置できるようになります。タイル自体を選択すると、Componentsパネルでそのコンポーネントタイプのカテゴリが開きます。
コンポーネントの検索
Workspace以外のライブラリのメニューオプションでは、環境設定、検索、データベースおよびファイルベースのライブラリコンテンツの移行を行えます。これらのオプションにアクセスするには、Componentsパネルの右上にあるライブラリメニューの
ボタンを選択します。
File-based Libraries Preferencesを選択すると、Available File-based Librariesダイアログが開きます。このダイアログでは、ライブラリの追加や削除、ライブラリのインストール、ライブラリの検索パスの指定を行うためのコントロールを利用できます。
現在のデータベースおよびファイルベースのライブラリのコンポーネントリストは、ComponentsパネルのSearchフィールドに検索語句を入力して絞り込めます。コンポーネントライブラリの高度な検索機能を利用するには、パネル右上の
メニューからFile-based Libraries Searchオプションを選択し、File-based Libraries Searchダイアログを開きます。このダイアログでは、クエリベースのフィルター条件など、柔軟な検索オプションを利用できます。また、利用可能なすべてのデータベースおよびファイルベースのライブラリ、または指定したパス内のライブラリを検索できます。
- デフォルトの検索Scopeでは、Available File-based Libraries内のComponentsを検索します。
- また、このダイアログでは、ドライブ上のフォルダーに保存されているLibraries on pathも検索できます。これを行うには、Libraries on pathオプションを有効にし、必要に応じてPathオプションを設定します。
- Filtersは「AND」を使用するため、まずは単純なフィルターから始め、結果が多い場合はRefine last searchモードで結果内を検索することをお勧めします。
- Helperを選択すると、クエリの検索結果がFile-based Libraries Searchダイアログに表示されます。
回路図ライブラリエディターからの配置
回路図ライブラリエディターで開いているライブラリから、SCH Libraryパネルを使用してパートを直接配置することもできます。次の点に注意してください。
- パネルのPlaceボタンをクリックすると、選択したパート(コンポーネント)が最後にアクティブだった回路図シートに配置されます。
- パートがカーソルに追従している間は、配置前に回転(Spacebarを押す)、軸に沿った反転(XまたはYを押す)、編集(Tabを押す)を行えます。この操作は、オブジェクトのドラッグ中にも行えます。回転は90°単位です。
-
ライブラリからパートを直接配置する場合、そのライブラリをあらかじめAvailable File-based Librariesダイアログに追加する必要はありません。
グラフィカル編集
パートのグラフィカル編集で行える操作は、移動、回転、反転に限られます。デザインスペースでパートを選択すると、その周囲に破線の選択ボックスが表示されます。選択したコンポーネントをグラフィカルに操作するには、次のようにします。
- Deleteを押すと、選択したパートがデザインから削除されます。
- クリックしたままにすると、選択したパートを移動できます。カーソルは、最も近い電気的ホットスポット(最も近いピンの配線接続端)にジャンプします。
- Spacebarを押すと円弧が反時計回りに、Shift+Spacebarを押すと時計回りに回転します。この操作は、オブジェクトのドラッグ中にも行えます。回転は90°単位です。
- パートがカーソルに追従して移動している間に、XキーまたはYキーを押すと、対応する軸に沿って反転します。
回路図コンポーネントとPCB コンポーネント間の連携
このソフトウェアには、回路図上のコンポーネントとPCB上の同じコンポーネント間での作業を支援するツールが用意されています。これには、クロスプローブ、クロスセレクト、回路図からのPCBコンポーネントの選択が含まれます。
クロスプローブ
クロスプローブでは、その名のとおり、一方のエディターでコンポーネントをクリックすると、もう一方のエディターでそのコンポーネントにジャンプできます。クロスプローブを行うには、次の手順に従います。
- 回路図エディターまたはPCBエディターのToolsメニューにあるCross Probeをクリックします。
- 回路図エディターでコンポーネントをクリックすると、PCBエディターでそのコンポーネントが中央に表示され、拡大されます。ズームレベルは、PreferencesダイアログのSystem – Navigationページで設定します。
- デフォルトでは、同じエディターにとどまり、別のコンポーネントをクロスプローブできる状態になります。クロスプローブ時にもう一方のエディターに切り替えるには、Ctrlキーを押しながら操作します。
クロスセレクトモード
クロスセレクトモードでは、もう一方のエディターで同じコンポーネントが選択されます。ただし、ズームや中央への表示は行われません。クロスセレクトは、オンまたはオフに設定できます。Tools » Cross Select Modeをクリックして、モードのオン/オフを切り替えます。 複数のコンポーネントを選択するには、Shiftキーを押しながらクリックします。
PCBコンポーネントの選択
この機能では、回路図上の複数のコンポーネントを特定の順序で選択し、PCBエディターで同じコンポーネントを同じ順序で配置できます。この機能を使用するには、次の手順に従います。
- 回路図上のコンポーネントを1つずつ選択します(複数のコンポーネントを選択するには、Shiftを押しながらクリックします)。
- PCBエディターに切り替え、I, Cショートカットを押してReposition Selected Componentsコマンドを実行します。Reposition Selected Componentsコマンドは、Iショートカットを押した後の右クリックメニューからも使用できます。
パーツのプロパティ
Generalタブ
全般
-
Reuse Block – コンポーネントが再利用ブロックの一部である場合、このフィールドには親の再利用ブロック名が表示されます。 Reuse Blockハイパーリンクをクリックすると、この再利用ブロックのプロパティを確認できます。
-
Designator – デジグネーターを入力します。目のアイコンで、デジグネーターの表示/非表示を切り替えます。ロックアイコンで、デジグネーターのロック/ロック解除を切り替えます。詳細については、デジグネーターを参照してください。
-
Comment – 名前またはコメントを入力します。目のアイコンで、名前の表示/非表示を切り替えます。ロックアイコンで、名前のロック/ロック解除を切り替えます。Commentフィールドは、ユーザー定義パラメーターやシステムパラメーターの値を表示するためにも使用できます。詳細については、コメントを参照してください。
-
Part <x> of Parts – 選択したパーツの番号とパーツの総数が表示されます。
をクリックしてフィールドのロック/ロック解除を切り替え、ドロップダウンから該当するパーツの番号を選択します。
-
Description – コンポーネント/パーツの説明です。
-
Type – コンポーネントのフットプリントに対して、以下のコンポーネントタイプのいずれかを選択します。使用できるタイプは次のとおりです。
-
Standard– 標準的な電気的特性を持ち、回路図とPCB間で常に同期され(フットプリント、ピン/パッド、ネットの割り当てがすべて一致する必要があります)、BOMに含まれるコンポーネントです。抵抗などの標準的な電気部品が該当します。 -
Mechanical– 電気的特性を持たず、同期されず(両方のエディターで手動配置が必要)、BOMに含まれるコンポーネントです。ヒートシンクなどが該当します。 -
Graphical– 電気的特性を持たず、同期されず(両方のエディターで手動配置が必要)、BOMにはnot 含まれないコンポーネントです。会社のロゴなどが該当します。 -
Net Tie (In BOM)– 2つ以上の異なるネットを短絡するために使用され、回路図とPCB間で常に同期され(フットプリント、ピン/パッド、ネットの割り当てがすべて一致する必要があります)、BOMに含まれるコンポーネントです。Standardコンポーネントとは異なり、フットプリント内の銅箔による接続はチェックされません。この銅箔によって、ネットを短絡できます。注:コンポーネント内に未接続の銅箔がないことを確認するには、Design Rule CheckerダイアログのVerify Shorting Copperオプションを有効にしてください。 -
Net Tie (No BOM)– 2つ以上の異なるネットを短絡するために使用され、回路図とPCB間で常に同期され(フットプリント、ピン/パッド、ネットの割り当てがすべて一致する必要があります)、BOMにはnot 含まれないコンポーネントです。Standardコンポーネントとは異なり、フットプリント内の銅箔による接続はチェックされません。この銅箔によって、ネットを短絡できます。注:コンポーネント内に未接続の銅箔がないことを確認するには、Design Rule CheckerダイアログのVerify Shorting Copperオプションを有効にしてください。 -
Standard (No BOM)– 標準的な電気的特性を持ち、回路図とPCB間で常に同期され(フットプリント、ピン/パッド、ネットの割り当てがすべて一致する必要があります)、BOMにはnot 含まれないコンポーネントです。BOMから除外したいテストポイントコンポーネントなどが該当します。 -
Jumper– 1層ではすべての配線を完了できない片面PCBなど、PCB設計にジャンパー線を組み込むために使用するコンポーネントです。このコンポーネントタイプでは、コンポーネントのフットプリントとピンは回路図とPCB間で同期されますが、ネットの割り当ては同期されません。また、コンポーネントはBOMに含まれます。コンポーネントレベルでこのオプションを選択するだけでなく、コンポーネント内の両方のパッドのJumperIDを、同じゼロ以外の値に設定する必要があります。Jumperタイプのコンポーネントは、回路図上で配線する必要はありません。BOMに含める必要がある場合にのみ、回路図に追加します。BOMに含める必要がない場合は、PCB上に直接配置し、Component Typeを設定し、JumperIDsを設定して、パッドにNetsを手動で割り当てることができます。
-
-
Design Item ID – このフィールドには、選択したコンポーネントの名前(Workspaceコンポーネントの場合)、またはField Settingsで定義された選択済みのキーフィールドが表示されます。 DbLib/SVNDbLibファイルの領域(データベースライブラリコンポーネントの場合)、またはコンポーネントシンボルに定義されたDesign Item ID パラメーター(ファイルベースのライブラリコンポーネントの場合)。
をクリックすると、コンポーネントの置換ダイアログが開きます。このダイアログでは、選択したコンポーネントの詳細情報(パラメーター、モデル、部品候補、サプライヤーデータなど)の確認、コンポーネントの比較、現在のコンポーネントの別のコンポーネントへの置換などを行えます。置換先として別のコンポーネントを選択すると、 このフィールドには、新しく選択したコンポーネントの完全な Design Item IDが表示されます。Validateボタン(
)をクリックすると、コンポーネントの保存場所に関する情報が表示されます。Workspace以外のコンポーネントの場合は、コンピューター上の保存先ファイルパスが表示されます。Workspaceコンポーネントの場合は、コンポーネントが見つかったことのみが表示されます。
-
Source – コンポーネントのソースライブラリ名を表示します。
をクリックして、目的のライブラリを検索し、選択します。
-
Revision state – このフィールドには、選択したコンポーネントリビジョンの現在のライフサイクル状態が、リビジョン状態のカラーアイコンと名前で表示されます。
-
Revision status – 選択したコンポーネントリビジョンが使用可能な状態(設計での使用が許可されている状態)の場合、そのリビジョンが最新であるか(
Up to date)、そうでないか(Out of date)が表示されます。リビジョンが使用不可の状態(設計での使用が許可されていない状態)の場合は、Not applicableが表示されます。
ボタンをクリックすると、コンポーネントが最新のリビジョンに更新されます。
-
Component issues(Propertiesパネルのみ)– 接続先のAltium 365 Workspaceから取得した選択中のコンポーネントに健全性の問題がある場合、
(エラー)または
(致命的なエラー)アイコンで示されます。アイコンの右側の数字は、検出された問題の数を示します。数字の右側にある下矢印をクリックすると、問題の簡単な説明が表示されます。

検出されたライブラリの健全性の問題の例。 -
Supply Chain Data(Propertiesパネルのみ)– 関連する部品候補のサプライチェーン情報を表示します。
- 単価の中央値。価格情報がない場合、または価格が0の場合、この項目は赤色で表示されます。
- 在庫。この項目には、WorkspaceのAltium Parts Providerソースで有効になっているサプライヤーから入手可能な在庫の合計が表示されます。
-
メーカーのライフサイクルバー。バーにカーソルを合わせると、情報を示すツールチップが表示されます。次の4つの状態のいずれかで表示されます。
- 白/グレー = デフォルト、不明、または情報なし
- 緑 = 新製品または量産中
- オレンジ = 新規設計には非推奨
- 赤 = 廃止または生産終了(EOL)
位置
-
(X/Y)
- X (最初のフィールド)– 現在の設計スペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
- Y (2番目のフィールド)– 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
-
Rotation – ドロップダウンを使用して回転角度を選択します。選択肢は、
0 Degrees、90 Degrees、180 Degrees、270 Degreesです。
パラメーター
-
Grid – 現在選択されているコンポーネントに関連付けられたパラメーターのNameとValueを一覧表示します。
を使用すると、一覧内のパラメーターをロック/ロック解除し、更新されないようにできます。パラメーター値は手動で入力するか、そのタイプの利用可能なすべてのコンポーネントから取得した値を含むドロップダウンリストから選択できます。目のアイコンを切り替えると、パラメーターを表示/非表示にできます。
-
Favorites – お気に入りに設定されたパラメーターはパラメーターリストに表示され、設定されていないものは非表示になります。パラメーターフィルター名の右側にマウスポインターを合わせ、
アイコンをクリックすると、そのフィルターをお気に入りに設定できます。パラメーターをお気に入りから削除するには、アイコンをもう一度クリックします。
非表示のパラメーターをすべて表示するには、リストの下部にあるShow Moreコントロールをクリックします。お気に入りのパラメーターのみを表示するには、Show Lessコントロールをクリックします。
-
Font – 表示されているフォントをクリックして、フォントスタイルを変更します。
-
Other – クリックするとドロップダウンが開き、追加のオプションを変更できます。
- Show Parameter Name – 有効にすると、パラメーター名が表示されます。
- Allow Synchronization with Database – 有効にすると、データベースと同期します。このオプションは、コメントを更新できるかどうかを制御します。デフォルトでは、これらのオプションは有効になっており、ソースのライブラリ/データベースとの同期が常に許可されます。このオプションを無効にすると、そのコメントを更新処理の対象から除外できます。
- (X/Y) – X座標とY座標を入力します。
-
Rotation – ドロップダウンを使用して回転角度を選択します。選択肢は、
0°、90°、180°、270°です。 - Autoposition – チェックすると自動配置が有効になり、関連付けられたコンポーネントを回転するたびにパラメーターが自動的に配置されます。このオプションを無効にすると、コンポーネントを回転したときに、関連付けられたコンポーネントに対するパラメーターの位置が維持されます。
-
Add – クリックすると、フットプリント、モデル、ルールなどのパラメーターを追加できます。
をクリックすると、グリッドで選択したエントリを削除できます。
をクリックすると、各パラメーターに対応するダイアログでパラメーターを編集できます。
グラフィカル
-
Mode – ドロップダウンを使用して目的のモードを選択します。Normal以外に使用できるモードがない場合、このドロップダウンはグレー表示になります。
- Mirrored – 有効にすると、パートを反転します。
- Local Colors – ローカルカラーオプションを有効にすると、回路図コンポーネントの塗りつぶし、線、ピンの色が、それぞれFill、Lines、Pinsのカラーボックスの色で上書きされます。このオプションを無効にすると、ライブラリで事前定義された色が使用されます。
部品候補
この領域には、選択したコンポーネントに割り当てられた部品候補とサプライヤーリンクに関する情報が表示されます。このセクションの各エントリに表示される情報の詳細については、コンポーネントへのサプライチェーン情報の追加ページを参照してください。
ピンタブ
-
Grid – この領域には、選択したコンポーネントのすべてのピンのPinsとNamesが一覧表示されます。目のアイコンを使用して、ピンを表示/非表示にできます。ロックアイコンを使用して、ピンをロック/ロック解除できます。
多機能ピン(PropertiesパネルのPinsモードのFunctionsフィールドで機能が指定されているピン)の場合、Name列にあるピンのセルをクリックし、表示されるドロップダウンでピンの機能を選択します。選択した機能は、回路図シート上でピン名として表示されます。
- Show Full/Show Short - Show Full では、リスト内のすべてのピンの完全な拡張ピン名が表示されます。Show Shortモードでは、現在のピン名が表示されます。
-
– ボタンが有効な場合(閉じた鍵のアイコン)、回路図エディターではコンポーネントのピンを編集できません(回路図ライブラリエディターでは編集できます)。回路図シート上でコンポーネントのピンを編集するには、このオプションを無効にします。
-
– クリックすると、コンポーネントピンエディターでShowプロパティが無効になっているピンも含め、すべての非表示ピンとピンのプロパティ(名前と番号)が表示されます。回路図ライブラリエディターで作業している場合、ライブラリエディターで非表示ピンを表示するには、View » Show Hidden Pinsオプションも有効にする必要があります。
-
– クリックしてコンポーネントにピンを追加します。Propertiesパネルでピンを設定し、クリックしてドラッグすることで配置位置を調整します。
-
– クリックして、選択したピンをコンポーネントから削除します。
-
– クリックしてコンポーネントピンエディターダイアログを開きます。このダイアログでは、回路図ライブラリエディターで現在開いているコンポーネント、または回路図エディターで選択したコンポーネント(またはその一部)のすべてのピンを簡単に表示、編集できます。
汎用コンポーネントのプロパティ
汎用コンポーネント
Altium DesignerがWorkspaceに接続されている場合、利用可能な汎用コンポーネントにはComponentsパネルからアクセスできます。汎用コンポーネントは、CategoriesペインでAllオプションを選択すると表示されます。パネルがコンパクトモードの場合は、上部のドロップダウンメニューから選択できます。汎用コンポーネントのタイル内にある
ボタンをクリックすると、コンポーネントがカーソルに接続され、アクティブな回路図に配置できます。タイル自体を選択すると、Componentsパネルでそのコンポーネントタイプのカテゴリが開きます。
汎用コンポーネントのプロパティ
一般
- Designator – デジグネーターを入力します。目のアイコンを切り替えて、デジグネーターの表示と非表示を切り替えます。鍵のアイコンをクリックして、デジグネーターをロックまたはロック解除します。
- Comment – 名前を入力します。目のアイコンを切り替えて、名前の表示と非表示を切り替えます。
-
Description – 汎用コンポーネント/パーツの説明です。
- Replace – 設計が進み、汎用コンポーネントを特定の物理コンポーネントに置き換えられる段階になったら、Replaceボタンを選択し、コンポーネントの置換ダイアログを使用します。
位置
-
(X/Y)
- X(1番目のフィールド)– 現在の設計スペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集してオブジェクトのX位置を変更します。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位も指定してください。
- Y(2番目のフィールド)– 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集してオブジェクトのY位置を変更します。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位も指定してください。
- Rotation – ドロップダウンで回転角度を選択します。
パラメーター
- Grid – 現在選択されているコンポーネントに関連付けられたパラメーターのNameとValueが一覧表示されます。鍵のアイコンを使用して、リスト内のパラメーターをロックまたはロック解除します。パラメーター値は手動で入力するか、そのタイプの利用可能なすべてのコンポーネントから取得した値を含むドロップダウンメニューのリストから選択できます。目のアイコンでパラメーターの表示と非表示を切り替えることができます。
- Font – 表示されているフォントをクリックして、フォントスタイルを変更します。
-
Other – クリックしてドロップダウンを開き、追加のオプションを変更します。
- Show Parameter Name – 有効にすると、パラメーター名が表示されます。
- Allow Synchronization with Database – 有効にすると、データベースと同期します。このオプションは、コメントを更新できるかどうかを制御するために使用します。デフォルトでは、これらのオプションは有効になっており、ソースライブラリ/データベースとの同期が常に許可されます。このオプションを無効にすると、そのコメントを更新処理の対象から除外できます。
- (X/Y) – X座標とY座標を入力します。
- Rotation – ドロップダウンで回転角度を選択します。
- Autoposition – チェックを入れると自動配置が有効になり、関連付けられたコンポーネントが回転するたびにパラメーターが自動的に配置されます。このオプションを無効にすると、コンポーネントが回転しても、関連付けられたコンポーネントに対するパラメーターの位置が維持されます。
デジグネーター
デジグネーターは、設計内の各コンポーネントを一意に識別します。
概要
デジグネーターフィールドは、回路図コンポーネント(パーツ)の子パラメーターオブジェクトです。配置された各パーツを一意に識別し、プロジェクト内のすべての回路図シートに配置されているほかのすべてのパーツと区別するために使用します。
利用と配置
デジグネーターは、親のコンポーネントパーツオブジェクトが配置されると自動的に配置されます。直接配置できる設計オブジェクトではありません。
グラフィカル編集
デジグネーターの文字列は、in-place編集と呼ばれる方法でグラフィカルに編集できます。デジグネーターの文字列をその場で編集するには、カーソルをドラッグしてデジグネーターを囲んで選択し、Enterキーを押します。

インプレース編集の例
編集が完了したら、Enterを押すか、文字列以外の場所をクリックして、インプレース編集モードを終了します。
非グラフィカル編集
デジグネーターの編集では、デジグネーターの値の編集と、デジグネーターの表示プロパティの編集という2つの側面を考慮する必要があります。
デジグネータ(およびコメント)の文字列は、回路図ライブラリエディタに表示でき、ダブルクリックしてプロパティを編集できます。Properties パネルのフィールドに対応する
アイコンを使用して、デジグネータの表示と非表示を切り替えます。
回路図エディタでのデジグネータ値の編集
デジグネータは、回路図エディタでコンポーネントを配置する際、または回路図シートにコンポーネントを配置した後に、 Properties panelで定義できます。
-
コンポーネントの配置中にデジグネータを編集するには、コンポーネントがカーソルに追従している状態で Tab キーを押します。Properties パネルが開くので、必要なデジグネータ文字列を入力します。 設計スペースにオーバーレイ表示される一時停止ボタン(
)をクリックすると、配置を再開できます。
- 引き続きコンポーネントを配置するか、Esc を押して配置を終了します。
- Spacebar を押すと円弧が反時計回りに、Shift+Spacebar を押すと時計回りに回転します。この操作は、オブジェクトのドラッグ中にも実行できます。回転は90°単位です。
- 配置後にデジグネータを編集するには、配置済みのコンポーネントをダブルクリックして プロパティ パネルを開き、デジグネータを編集します。
デジグネータの表示プロパティの編集
デジグネータ文字列の外観(フォントの種類、サイズ、色)は、Preferences ダイアログの 回路図 - デフォルト ページで設定できます。 これらの設定は、回路図ライブラリエディタでコンポーネントシンボルに定義された設定によって上書きされない限り適用されます。
デジグネータ文字列の位置の固定
デジグネータはデフォルトで、配置中にコンポーネントを回転させると自動的に位置が調整されます。この動作が不要な場合は、シンボルの作成時、または回路図シートにコンポーネントを配置した後に、Preferences ダイアログ(前の画像を参照)の Autoposition オプションをオフにします。この操作により、このパラメータは manual parameter(手動で配置されたパラメータ)として分類されます。手動配置パラメータは、選択ボックスの左下隅にあるドットで識別できます。
注意事項
-
回路図エディタには、同じ部品を複数配置する際に使用できる、デジグネータの簡単な自動インクリメント機能があります。この機能を使用するには、最初のコンポーネントがカーソルに追従している状態で Tab を押し、適切なデジグネータ(例:
R1)を入力します。以降のコンポーネントには、R2、R3などのデジグネータが割り当てられます。異なる種類のコンポーネントの配置に切り替える場合は、再度 Tab を押して、適切なデジグネータの接頭辞を入力する必要があります。 -
マルチパートコンポーネントを配置する際に、上記の方法で最初のデジグネータを割り当てると、
U3A、U3Bなどのパート接尾辞が自動的に割り当てられます。 最初のデジグネータを割り当てない場合、すべてのパートに同じ接尾辞が付きます。これは、回路図エディタの Annotation コマンドで解決できます。パート接尾辞には英字または数字を使用できます。Preferences ダイアログの 回路図 - 全般 ページにある Alpha Numeric Suffix オプションで設定します。
デジグネータのプロパティ
位置
-
(X/Y)
- X (最初のフィールド)- 現在のワークスペース原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位も指定してください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位も指定してください。
- Rotation - ドロップダウンで回転角度を選択します。
プロパティ
- Object - 関連付けられたオブジェクトを表示します。
-
名前 - 表示アイコン(
)をクリックしてこのフィールドを有効にすると、デジグネータ値の前に「Designator:」という接頭辞が追加されます。これにより、そのテキスト値が回路図ドキュメント内のデジグネータであることを視覚的に識別し、確認できます。
-
Value - デジグネータ名そのものを表示します。 目のアイコン
を切り替えると、値の表示と非表示を切り替えられます。
- 自動配置 - チェックすると自動配置が有効になり、コンポーネントを移動または回転しても、テキストが選択した位置に維持されます。
- パラメータをロック - チェックするとパラメータがロックされ、Properties パネルや回路図ドキュメントから値を編集できなくなります。
- データベースとの同期を許可 - 有効にするとデータベースと同期します。このオプションは、コメントを更新できるかどうかを制御します。デフォルトではこれらのオプションが有効になっており、ソースライブラリ/データベースとの同期が常に許可されます。このオプションを無効にすると、そのコメントを更新処理の対象から除外できます。
- フォント - 各コントロールを使用して、フォント、フォントサイズ、フォントの色を選択し、太字、斜体、下線などの装飾を追加します。
- 文字揃え - 矢印をクリックしてテキストの揃え方を設定するか、円をクリックして中央揃えにします。
- Override Library Primitive(Preferences ダイアログのみ)- このチェックボックスを有効にすると、ライブラリ内のデジグネータオブジェクトに定義されたプリミティブ設定を上書きします。これにより、コンポーネントの配置時には、ライブラリ内でそのコンポーネントに定義された設定ではなく、環境設定ダイアログで定義したプリミティブ設定が適用されます。
コメント
コメントを使用すると、コンポーネントの追加情報を表示できます。
概要
コメントフィールドは、回路図コンポーネント(部品)に属する子パラメータオブジェクトです。コンポーネントに関する追加情報を表示します。
利用と配置
コメントは、親となるコンポーネントのパートオブジェクトを配置する際に設定します。 直接配置できる設計オブジェクトではありません。
グラフィカル編集
コメントは、in-place編集と呼ばれる方法でグラフィカルに編集できます。コメントをその場で編集するには、1回クリックして選択し、少し待ってからもう一度クリックして編集モードに入ります。
編集が完了したら、Enterを押すか、文字列以外の場所をクリックして、その場での編集モードを終了します。
非グラフィカル編集
コメントの編集では、コメントの値の編集と、コメントの表示プロパティの編集という2つの側面を考慮する必要があります。
回路図エディターでのコメントの編集
コメントは、回路図エディターで部品を配置する際、または回路図シートに部品を配置した後に、PropertiesパネルのComment フィールドで定義できます。
-
部品の配置中にコメントを編集するには、部品がカーソルに追従している状態でTabキーを押します。Properties パネルが開くので、必要なコメントを入力します。設計スペースにオーバーレイ表示される一時停止ボタン(
)をクリックすると、部品の配置を再開できます。
- 引き続き部品を配置するか、Escを押して配置を終了します。
- 配置後にコメントを編集するには、配置済みの部品をダブルクリックしてプロパティパネルを開き、コメントを編集します。
コメントの表示プロパティの編集
フォントの種類、サイズ、色など、コメントの外観は、Preferences ダイアログの回路図 - デフォルトページで設定できます。
コメントの位置の固定
デフォルトでは、配置中に部品を回転すると、コメントの位置が自動的に調整されます。この動作が不要な場合は、シンボルの作成中、または回路図シートへの部品の配置後に、Preferencesダイアログ(前の画像を参照)のAutopositionオプションを無効にします。これにより、このパラメーターはmanual parameter(手動で配置されたパラメーター)として分類されることに注意してください。手動パラメーターは、選択ボックスの左下隅にあるドットで識別できます。
コメントのプロパティ
位置
-
(X/Y)
- X (1つ目のフィールド)- 現在の設計スペースの原点を基準とする、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も入力してください。
- Y (2つ目のフィールド)- 現在の原点を基準とする、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も入力してください。
- Rotation - ドロップダウンから回転角度を選択します。選択肢は、0 Degrees、90 Degrees、180 Degrees、270 Degreesです。
プロパティ
- 部品 - 関連付けられた部品の名前が表示されます。Component リンクをクリックすると、部品プロパティパネルが開きます。このパネルでは、部品のオプションに加えて、 コメント自体も編集できます。コメントは、このパネルのComment フィールドで定義します。
-
名前 - 表示アイコン(
)をクリックしてこのフィールドを有効にすると、コメントの値の先頭に「Comment:」が追加されます。これにより、そのテキスト値が回路図ドキュメント内のコメントであることを視覚的に区別し、確認できます。
-
値 - コメント名そのものが表示されます。(
)を切り替えると、値の表示/非表示を変更できます。
- 自動配置 - チェックを入れると自動配置が有効になり、部品を移動または回転しても、テキストは選択した位置に維持されます。
- パラメーターをロック - チェックを入れるとパラメーターがロックされ、Properties パネルや回路図ドキュメントから値を編集できなくなります。
- データベースとの同期を許可 - 有効にすると、データベースと同期します。このオプションは、コメントを更新できるかどうかを制御します。デフォルトでは有効になっており、ソースライブラリ/データベースとの同期が常に許可されます。コメントを更新処理の対象から除外するには、このオプションを無効にします。
- フォント - 各コントロールを使用して、フォント、フォントサイズ、フォントの色を選択し、必要に応じて太字、斜体、下線などの装飾を追加します。
- 文字揃え - 矢印をクリックしてテキストの配置を設定するか、円をクリックして中央揃えにします。
- Override Library Primitive(Preferences ダイアログのみ)- このチェックボックスを有効にすると、ライブラリ内のコメントオブジェクトに定義されているプリミティブ設定が上書きされます。そのため、部品を配置すると、ライブラリ内の部品に定義されている設定ではなく、Preferencesダイアログで定義したプリミティブ設定が適用されます。
ライブラリからの部品の更新と置換
基板設計の回路図シートに部品を配置した後は、該当するWorkspace内のリンク元部品に加えられた変更を、それらの部品インスタンスに反映する方法が必要になります。つまり、設計を、その設計で使用しているWorkspaceのエンティティと同期させるための手段が必要です。
たとえば、子モデルへの変更を反映するために、部品がWorkspaceに再保存されたとします。これにより、その部品の新しいリビジョンが作成されます。配置済みの部品インスタンスは古いリビジョンを使用しているため、最新のリビジョンを使用するよう更新したい場合があります。また、まったく別の部品を使用することにして、設計内の既存の部品を代替部品に変更するだけの場合もあります。
コンポーネントを設計に初めて配置した後、そのコンポーネントを管理するにはさまざまな方法があります。
単一のコンポーネントインスタンスの変更
配置された各コンポーネントには、Workspace内のコンポーネントリビジョンへのリンクがあります。この情報は、選択したコンポーネントのプロパティを参照する際に、Propertiesパネルで確認できます。
配置されたコンポーネントの各インスタンスには、Workspace内のそのコンポーネントの特定のリビジョンへのリンクがあります。
この最も基本的な個々のコンポーネントのレベルでは、配置済みのインスタンスに対して次の操作を行えます。
-
ボタンをクリックして、既存のコンポーネントの最新リビジョンに更新します。
同じコンポーネントを最新リビジョンに更新する例 – 画像にカーソルを合わせると、結果が表示されます。
-
Design Item IDフィールドの右側にある
ボタンをクリックして、別の(置換用の)Workspaceコンポーネントの最新リビジョン、またはファイルベースのライブラリコンポーネントに置き換えます。Replace Componentダイアログが開き、接続中のWorkspaceおよび使用可能なファイルベースのライブラリ内のコンポーネントが表示されます。現在のコンポーネントはリストの先頭に表示されます。必要な置換用コンポーネントを検索して選択し、OKをクリックします。
既存のコンポーネントを別のコンポーネント(代替品)に置き換える例
Replace Component ダイアログでは、使用可能なすべてのWorkspaceライブラリコンポーネントおよびファイルベースのライブラリコンポーネントに直接アクセスできます。 このダイアログでは、選択したコンポーネントの詳細情報(パラメーター、モデル、部品候補、サプライヤーデータなど)やコンポーネントの比較機能が提供されます。また、Workspaceライブラリコンポーネントについては、目的のコンポーネントのパラメーターを指定できる、フィルターベースのパラメトリック検索機能も利用できます。
Replace Componentダイアログのオプションとコントロール
- Search - 検索テキストボックスを使用して、特定のコンポーネントを手動で検索します。
-
- クリックしてCategoriesペインを展開または折りたたみ、特定の種類のコンポーネント、または使用可能なすべてのコンポーネントを表示します。Categoriesペインの下にある検索バーを使用すると、特定のコンポーネントカテゴリや、使用可能なファイルベースのコンポーネントライブラリを手動で検索できます。
-
- クリックしてメニューを開き、次の項目から選択します。
- File-based Libraries Preferences - クリックしてAvailable File-based Librariesダイアログを開き、ライブラリを追加または削除します。
- File-based Libraries Search - クリックしてFile-based Libraries Searchダイアログを開き、ライブラリを検索します。
- Refresh - クリックしてダイアログを更新します。
-
- クリックしてダイアログのDetails 領域 (後述)を開いたり閉じたりします。
フィルター
Workspaceコンポーネントのカテゴリを選択した状態で、Filtersアイコン(
)をクリックすると、Filters領域が開き、Components リストで選択したカテゴリをさらに絞り込むことができます。特定のパラメーターの種類をFavoritesとして選択することで、パネルのFilters オプションをニーズに合わせて調整できます。選択した項目は、現在のコンポーネントカテゴリのリストの先頭に移動します。パラメーターフィルター名の右側にカーソルを合わせ、(
)アイコンをクリックすると、そのフィルターをお気に入りに設定できます。お気に入りのフィルター設定は、コンポーネントのCategoriesごとに適用、保存されます。
コンポーネント
- Name - コンポーネントの名前。
- Description - 各コンポーネントの説明。
- Footprint - コンポーネントのフットプリント。
- Results - 検索で見つかった、またはリストに表示されているコンポーネントの総数を表示します。
詳細
- Component Revision ID - コンポーネントのリビジョンIDと価格を表示します。リビジョンIDをクリックすると、Explorerパネルが開き、コンポーネントの詳細情報を確認できます。
- References - クリックすると、コンポーネントの参考情報がWebブラウザーで開きます。ドロップダウンを使用して、Manufacturer URLまたはDatasheetにアクセスします。
- Place - クリックして、選択したコンポーネントを回路図ドキュメントに配置します。
- Component information - メーカー、リリース日、説明など、コンポーネントに関する情報を表示します。Show More リンクをクリックするとすべての情報が表示され、Show Less をクリックすると情報が折りたたまれます。
- Models - 展開して、提供されているモデルを表示します。利用可能なリンクを使用すると、1つのモデルのさまざまな部分を表示できます。
- References - 展開して、Manufacturer URL、Datasheet、およびPackage Specificationにアクセスします。
- Part Choices - 展開して部品候補を表示します。名前、価格、説明が表示されます。コンポーネントのデータシートも表示されます。
- Where Used - 展開して、そのコンポーネントを使用しているプロジェクトを表示します。
右クリックメニュー
- Find Similar Components - クリックしてFind Similar Componentsダイアログを開き、類似した特性を持つほかのコンポーネントを検索します。
- Place <component> - クリックして、適切なドキュメントにコンポーネントを配置します。
- Edit - クリックして、選択したコンポーネントのコンポーネントライブラリドキュメントを開きます。
- Navigate to <revision> - クリックして、選択したコンポーネントをExplorerパネルで開きます。
- Operations - カーソルを合わせると、Submit Request、Create、Download、Clone、Change Component Type、Create / Edit PCL、およびFull Item Historyの操作にアクセスできます。
- Refresh- クリックして表示を更新し、最新の更新や編集内容を確認します。F5ショートカットを使用して更新することもできます。
- Library Report - Categoriesペインでファイルベースのライブラリを選択している場合、クリックするとLibrary Report Settingsダイアログが開きます。このダイアログのコントロールを使用して、ライブラリレポートを設定できます。
コンポーネントの一括変更 – Item Manager
Related page: Item Managerによるコンテンツの管理
コンポーネントを個別に変更する方法は便利ですが、扱うコンポーネントの数が増えると、すぐに手間がかかるようになります。そのため、複数の変更を一括で行える、一元化された管理場所が必要になります。そこで役立つのが、Item Manager(Tools » Item Manager)です。
Item Managerは、回路図シートに配置されたWorkspaceの設計エンティティを、Workspace内のリンク先ソースコンテンツと同期するための「コマンドセンター」です。すべてのコンポーネントを自動的に検出して一覧表示し、Workspaceのエンティティかどうかを示したうえで、回路図上の各Workspaceコンポーネントのアイテムリビジョンを、Workspace内で利用可能なそのコンポーネントのリビジョンと比較します。各エンティティについて、現在リンクされているアイテムのリビジョン、ライフサイクル状態、およびそのアイテムが格納されているソースWorkspaceの情報が表示されます。
どのWorkspaceエンティティをどのように更新するかは、自由に指定できます。例えば、次のような操作が可能です。
- 個々のエントリを選択し、リンク先アイテムの最新リビジョンを使用するように更新するか、まったく別のアイテムの最新リビジョンを使用するように変更します。
- 同じアイテムにリンクしている複数のエントリを選択し、そのアイテムの最新リビジョンに更新するか、まったく別のアイテムの最新リビジョンを使用するように変更します。
予定されている変更はすべてマネージャーに反映されます。
必要な変更を設定したら、設計変更指示(ECO)を生成し、変更を適用するために実行されるアクションを確認します。必要に応じて任意のアクションを無効にできるため、常にユーザーが操作を制御できます。準備ができたらECOを実行すると、変更が適用されます。配置済みのWorkspaceコンテンツを、すばやく効率的かつ簡単に管理できます。
以下の例では、Item Managerの使用方法を示します。
- 複数のコンポーネントを更新し、既存のWorkspaceコンポーネントの最新リビジョンを使用するようにします。

古くなった複数のコンポーネントを最新リビジョンに更新します。
- いくつかのコンポーネントを、Replace Componentダイアログで選択した別のWorkspaceコンポーネントの最新リビジョンに変更します。

1つ以上のコンポーネントを別のWorkspaceコンポーネントに置き換えます。
Item Managerは、設計内のコンポーネントを接続先Workspaceのソースコンテンツの変更と同期させるだけでなく、既存の基板設計をローカルの設計アイテムの使用からWorkspaceの設計コンテンツの使用へ移行する際にも役立つ強力なツールです。設計コンポーネントと回路図シート(デバイスシート)をWorkspaceに移行したら、Item Managerを使用して、既存のコンポーネントとシートシンボルを、新たに移行したWorkspace上の対応するエンティティに「置き換え」ます。つまり、設計上はコンポーネントは同じままで、そのコンポーネントのソースが変わります。
BomDocからのコンポーネントの変更
部品発注に向けてBomDocを確認・準備している際に、コンポーネントの問題が見つかることは珍しくありません。例えば、設計者がコンポーネントの選定を確定し忘れていたり、コンポーネントが生産終了(EOL)となり、代替候補の価格や入手性を調べたい場合があります。回路図に戻ってコンポーネントを編集し、適切な部品を選択してからBomDocを更新することでも対処できますが、ActiveBOMでは、BomDoc内で直接この操作を行い、その変更を設計変更指示(ECO)を介して回路図に反映できます。
BomDoc内で選択したコンポーネントを右クリックし、Operations » Change <ComponentName>コマンドを選択します。Replace Componentダイアログが開き、置換用コンポーネントを検索できます。目的の置換用コンポーネントが見つかったら選択し、OKをクリックします。Engineering Change Orderダイアログが開き、回路図をBomDocと同期するために必要な変更の詳細が表示されます。
汎用コンポーネントの置き換え
設計が進み、汎用コンポーネントを具体的な実部品に置き換えられる段階になったら、Propertiesパネルの
ボタンを選択して、Replace Componentダイアログを開きます。この操作は、Item ManagerまたはプロジェクトのActiveBOMドキュメントからも実行できます。
汎用コンポーネントに設定されているパラメーター値(ここでは電力と抵抗値)が、Replace Generic Componentダイアログの検索条件として自動的に使用されるため、絞り込まれた結果から適切な置換用コンポーネントを選択できます。ここに示す例では、2件のコンポーネントが検索条件に一致しています。
|
Propertiesパネルからの汎用コンポーネントの置き換え。 Propertiesパネルからの汎用コンポーネントの置き換え。 |
設計全体のフットプリントの管理
Altium Designerの回路図エディターには、強力なFootprint Managerが搭載されています。回路図エディターのToolsメニュー(Tools » Footprint Manager)から起動するFootprint Managerでは、プロジェクト全体のすべてのコンポーネントに関連付けられているフットプリントを確認できます。複数選択に対応しているため、複数のコンポーネントのフットプリント割り当ての編集、フットプリントのリンク方法の変更、複数のフットプリントが割り当てられているコンポーネントの現在のフットプリント割り当ての変更を簡単に行えます。 Footprint Manager を使用すると、設計全体のフットプリント割り当ての確認や問題の検出が容易になります。特に、過去の設計や他の組織から引き継いだ設計を扱う場合に便利です。設計変更はECOシステムを介して適用され、必要に応じて回路図とPCBの両方が更新されます。
Footprint Manager ダイアログには、アクティブなプロジェクトのすべてのソース設計回路図に含まれる全コンポーネントの一覧が表示されます。ダイアログの右側にあるコントロールを使用して、設計内のコンポーネントで利用可能なフットプリントと、現在使用されているフットプリントを管理します。次の機能を備えています。
- 選択した1つ以上のコンポーネントのフットプリントモデルの追加、編集、削除。
- コンポーネント間でのフットプリントのコピー。
- 現在のフットプリント割り当ての変更(コンポーネントで利用可能な複数のフットプリントの中から、PCB上でそのコンポーネントを表すために現在使用するフットプリントを変更)。
- フットプリントの検証。フットプリントモデル、特に現在のモデルとして設定されているものが、実際に利用可能であることを確認します。
フットプリントモデルの割り当てに必要な変更をすべて行ったら、標準の設計変更指示(ECO)を通じて変更を反映します。これを行うには、Footprint Manager ダイアログの右下にある Accept Changes (Create ECO) ボタンをクリックします。
Footprint Managerダイアログのオプションとコントロール
コンポーネント一覧
現在アクティブなPCB設計プロジェクトの回路図シートにある、すべてのコンポーネントの一覧です。次の情報が含まれます。
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
フットプリントの表示と編集
Component List で選択したコンポーネントに関連付けられているフットプリントの一覧です。領域の下部にあるコントロール、または右クリックメニューのコマンドを使用して、一覧内のフットプリントを操作します。
右クリックメニュー
-
Add - クリックすると、PCB Modelダイアログが開き、ハイライト表示された回路図コンポーネントに追加する新しいフットプリントモデルを選択できます。管理対象コンポーネントを選択している場合は使用できません。
-
Remove - クリックすると、選択したフットプリントを削除します。管理対象コンポーネントを選択している場合は使用できません。
-
Edit Footprint - クリックすると、PCB Modelダイアログが開きます。PCB Model ダイアログでは、回路図コンポーネントにリンクするフットプリントモデルと、回路図エディターがフットプリントを検索するライブラリを定義します。管理対象コンポーネントを選択している場合は使用できません。
-
Validate Footprint Paths - クリックすると、ハイライト表示されたフットプリントが指定された場所で見つかるかどうかを確認します。フットプリントが見つからない場合、Found In フィールドに Not Validated が表示されます。 フットプリントが確認できた場合は、そのフットプリントへのフルパスが表示されます。
-
Change PCB Library - クリックすると、Edit PCB Library ダイアログが開き、選択したフットプリントのPCBライブラリを変更できます。このダイアログは PCB Model ダイアログの簡易版であり、ソフトウェアがフットプリントモデルを検索する場所を定義する PCB Library オプションにアクセスできます。

Edit PCB Library ダイアログ- Any - 利用可能なすべてのライブラリから、一致するモデルを検索します。
- Library name - この名前の利用可能なライブラリのみを対象に、一致するモデルを検索します。
- Library path - この場所にある、この名前のライブラリのみを対象に、一致するモデルを検索します。パスとライブラリ名を手動で入力するか、Choose ボタンをクリックしてWindowsの Open ダイアログを開き、必要なライブラリを参照して選択します。
- Use footprint from source integrated library, database library, or server - コンポーネントの配置元である統合ライブラリ/データベースライブラリ/サーバー内でのみ、モデルを検索します。統合ライブラリまたはデータベースライブラリが利用可能である必要があります。サーバーの場合は、そのサーバーに接続している必要があります。
-
Copy - クリックすると、現在選択されているフットプリントの詳細情報をコピーします。
-
Paste - クリックすると、コピーしたフットプリントの詳細情報を、現在選択されている回路図コンポーネントに貼り付け(追加)します。
-
Select All - クリックすると、View and Edit Footprints 一覧に現在表示されているすべてのフットプリントを選択します。
-
Set As Current - クリックすると、選択したフットプリントを現在のフットプリントに設定します(Current 列の
で示されます)。
-
Add to All Parts - クリックすると、選択したフットプリントを、同じ回路図コンポーネント内のほかのすべてのパートに追加します(このコマンドは、選択したコンポーネントがマルチパートコンポーネントで、そのコンポーネント内の1つ以上のパートにこのフットプリントが指定されていない場合にのみ使用できます)。
追加のコントロール
-
Menu - クリックすると、上記の右クリックメニューと同じコントロールを含むメニューが表示されます。
-
Add, Remove, Edit, Validate - これらのボタンは、上記のメニュー項目と同じ機能を実行します。
-
Accept Changes (Create ECO) - クリックすると、回路図コンポーネントとそれにリンクされたフットプリントモデルへの変更を確定し、Engineering Change Order ダイアログを開きます。ECOダイアログでは、対応する回路図コンポーネントのフットプリント値に加えた変更を確認した後、変更を検証して実行できます。
















