데이터베이스 및 파일기반 라이브러리에서 Footprint 업데이트

개요

이 문서에서는 Altium Designer의 Update From PCB Libraries 도구를 사용하여 PCB에 이미 배치된 풋프린트를 라이브러리의 원본 풋프린트와 비교하고, 차이점을 파악하여 상세히 검토한 다음, ECO를 통해 업데이트를 적용하는 방법을 설명합니다. 또한 파일 기반 및 데이터베이스 라이브러리 소스처럼 이 명령을 사용할 수 있는 경우와, 특정 워크스페이스 리비전 업데이트처럼 사용할 수 없는 경우를 명확히 안내합니다. 비교 옵션을 설정하고, 일치 및 불일치 결과를 해석하고, 비교 보고서를 생성하는 방법뿐 아니라 PCB Library Editor에서 배치된 풋프린트를 직접 업데이트하는 방법도 살펴봅니다. PCB 풋프린트를 승인된 라이브러리와 일치하도록 유지하는 더 명확하고 체계적인 방법을 찾고 있다면 계속 읽어보세요.

- Update From PCB Libraries를 사용해야 하는 경우와 다른 업데이트 방식이 필요한 경우를 알아봅니다.
- 배치된 PCB 풋프린트를 원본 라이브러리 풋프린트와 비교하고, 상세한 차이점을 검토하며, 업데이트할 항목을 선택하는 방법을 배웁니다.
- 풋프린트 비교 보고서를 생성하고, 설계 변경 지시(ECO) 프로세스를 통해 승인된 변경 사항을 적용하는 방법을 살펴봅니다.
AI로 더 깊이 알아보기:

여기에 설명된 Update From Libraries 및 Update Selected From Libraries 명령은 Schematic 시트에 배치된 컴포넌트를 업데이트하는 용도로만 사용됩니다. 이 업데이트에 모델을 포함할 수는 있지만, 이때 업데이트되는 것은 모델 링크이며 연결된 모델의 실제 그래픽 속성은 아닙니다. 소스 PCB 풋프린트 라이브러리에서 변경한 PCB 풋프린트의 그래픽 속성을 반영하려면 Altium Designer의 또 다른 업데이트 도구인 Update From PCB Libraries을 사용해야 합니다. 이 업데이트 도구는 각 풋프린트의 프리미티브를 물리적으로 비교하여 보드의 컴포넌트 풋프린트를 소스 PCB 풋프린트 라이브러리의 해당 풋프린트와 대조하고, 필요에 따라 선택한 컴포넌트를 업데이트합니다. 이를 통해 설계의 모든 풋프린트가 승인된 풋프린트 라이브러리를 따르도록 할 수 있습니다.

이 명령은 파일 기반 라이브러리와 데이터베이스 라이브러리, 즉 PCB 풋프린트 라이브러리(*.PcbLib), 통합 라이브러리(*.IntLib), 데이터베이스 라이브러리(*.DbLib, *.SVNDbLib)에서 가져온 PCB 컴포넌트에 적용됩니다. 데이터베이스 라이브러리의 경우, 연결된 외부 데이터베이스의 해당 레코드에서 참조하는 라이브러리가 업데이트에 사용됩니다. 풋프린트의 출처인 원본 라이브러리에 대한 참조는 해당 Schematic이 있으면 그곳에서 가져오고, 없으면 PCB 풋프린트 자체에서 가져옵니다. 모든 소스 라이브러리는 사용 가능한 라이브러리 집합에 포함되어 있어야 합니다.

PCB 설계에 사용된 PCB 풋프린트를 워크스페이스 라이브러리에서 가져왔으며 해당 라이브러리에서 풋프린트가 업데이트된 경우(그리고 관련 컴포넌트도 풋프린트의 새 리비전을 사용하도록 업데이트된 경우), Update From PCB Libraries 명령은 적용되지 않습니다. PCB 풋프린트를 워크스페이스에 저장하면 새 리비전이 생성되지만, PCB 설계의 풋프린트는 여전히 이전 리비전(이제는 최신이 아닌 리비전)을 참조하기 때문입니다. 이 경우 PCB의 풋프린트를 업데이트하려면 먼저 Schematic에서 관련 컴포넌트를 업데이트한 다음(자세히 알아보기), Schematic 편집기의 Design » Update PCB Document 명령과 이어지는 ECO 프로세스를 사용하여 PCB를 업데이트해야 합니다. 그러면 PCB 설계의 풋프린트가 최신 리비전으로 업데이트됩니다.

워크스페이스 라이브러리 컴포넌트에서 가져와 배치한 풋프린트에 PCB 설계 내의 "로컬" 변경 사항이 있는 경우(예: 패드 속성을 변경했거나 풋프린트 프리미티브의 잠금을 해제하고 수정한 경우), Update From PCB Libraries 명령을 사용하여 배치된 풋프린트와 라이브러리의 풋프린트 간 차이를 감지하고 배치된 풋프린트를 업데이트할 수 있습니다. 즉, "로컬" 변경 사항을 제거할 수 있습니다.

이 도구의 사용 방법을 설명하기 위해 아래의 컴포넌트 풋프린트를 살펴보겠습니다. 이 풋프린트들은 PCB 문서에 배치되어 있는 기존 풋프린트입니다. 오른쪽은 소스 PCB 풋프린트 라이브러리(*.PcbLib)에 있는 수정된 풋프린트입니다. 위쪽 풋프린트는 "기호의 위치가 이동"했고 아래쪽 풋프린트는 "기호와 호의 너비가 증가"했습니다. 미세한 변경이지만 예시로 설명하기에는 충분합니다.

PCB 문서의 기존 풋프린트(왼쪽 이미지)와 소스 PCB 풋프린트 라이브러리의 수정된 풋프린트(오른쪽 이미지)
PCB 문서의 기존 풋프린트(왼쪽 이미지)와 소스 PCB 풋프린트 라이브러리의 수정된 풋프린트(오른쪽 이미지)

업데이트 옵션 설정

업데이트는 PCB 문서에서 기본 Tools 메뉴의 Update From PCB Libraries 명령을 사용하여 수행합니다. 이 명령을 실행하면 Update From PCB Libraries - Options 대화 상자가 열립니다. 이 대화 상자에서 Layers To Include 영역의 Include 체크박스 또는 Include All 버튼 드롭다운의 명령을 사용하여 PCB 풋프린트와 라이브러리 풋프린트의 어떤 레이어를 비교할지 선택합니다. 일부 설계에서는 풋프린트의 특정 레이어를 사용하지 않을 수 있으며, 불필요한 비교는 처리 시간을 늘리므로 이 설정은 중요합니다.

활성 PCB 문서에서 커서 아래의 컴포넌트 풋프린트 또는 현재 선택한 컴포넌트를 확인하려면, 선택되지 않은 배치된 컴포넌트를 마우스 오른쪽 버튼으로 클릭하거나 선택한 컴포넌트(또는 선택한 컴포넌트 그룹에 속한 컴포넌트)를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Component Actions » Update Current Components From PCB Libraries 명령을 선택합니다.

Update From PCB Libraries - Options 대화 상자
Update From PCB Libraries - Options 대화 상자

이 단계에서 모든 풋프린트를 소스 라이브러리의 풋프린트와 일치하도록 업데이트하려면 Update All Footprints (Create ECO) 버튼을 클릭한 다음, 이어지는 설계 변경 지시(ECO)를 통해 변경 사항을 설계에 적용하면 됩니다. 하지만 ECO를 생성하기 전에 감지된 차이를 자세히 살펴보고 업데이트에 포함할 풋프린트를 결정하려면 OK 을 클릭하여 Update From PCB Libraries 대화 상자를 여십시오. 아래 내용을 참조하십시오.

비교 결과 보기

Update From PCB Libraries - Options 대화 상자에서 필요에 따라 옵션을 설정한 후 OK을 클릭합니다. 비교가 진행되고, 이어서 열리는 Update From PCB Libraries 대화 상자에 결과가 표시됩니다.

Update From PCB Libraries 대화 상자
Update From PCB Libraries 대화 상자

소스 PCB 라이브러리는 소스 Schematic의 해당 컴포넌트에 연결된 PCB 모델 링크에서 식별됩니다. 소스 라이브러리는 사용 가능한 파일 기반 라이브러리에 포함되어 있어야 합니다. 풋프린트의 소스를 찾을 수 없으면 해당 풋프린트는 일치하지 않는 것으로 표시됩니다.

대화 상자는 두 개의 주요 섹션으로 나뉩니다. 위쪽 Part List 영역에는 비교 결과가 표시됩니다. PCB에 있는 각 컴포넌트의 풋프린트를 지정된 소스 라이브러리의 해당 풋프린트와 비교합니다. 맨 위의 헤더 행에는 일치하는 항목의 요약이 표시됩니다. 풋프린트의 각 프리미티브에 대한 비교 결과가 지정된 허용 오차 이내이면 풋프린트가 일치하는 것으로 간주되며, Match 열에 녹색 체크 아이콘()이 나타납니다. 일치하는 경우에는 업데이트가 필요하지 않습니다.

반면 풋프린트 내 하나 이상의 프리미티브 위치가 허용 오차를 벗어나면 풋프린트가 일치하지 않는 것으로 표시됩니다. Match 열에 빨간색 X 아이콘()이 표시됩니다. 배치된 컴포넌트의 풋프린트와 소스 라이브러리의 풋프린트를 다시 동기화하려면 업데이트가 필요합니다.

소스 라이브러리에서 풋프린트를 찾을 수 없으면 비교 대상 라이브러리 컴포넌트의 Path  필드에 <Footprint not found> 항목이 표시됩니다. 이 경우 해당 컴포넌트는 비교할 수 없습니다.

풋프린트가 일치하지 않는 각 컴포넌트에는 Update 옵션이 제공됩니다. 기본적으로 일치하지 않는 모든 컴포넌트가 자동으로 업데이트에 포함됩니다. Altium Designer에서는 언제나 사용자가 제어할 수 있으므로, 체크박스를 선택 해제하거나 Include All 버튼 드롭다운의 명령을 사용하여 일치하지 않는 컴포넌트를 업데이트 프로세스에서 제외할 수 있습니다.

대화 상자 하단의 Difference Details 영역에는 위쪽 영역에서 현재 선택된 일치하지 않는 컴포넌트 Entry의 프리미티브 간 차이점이 나열됩니다. 일치하지 않는 풋프린트의 경우, 차이를 유발하는 컴포넌트 프리미티브가 비교 대상으로 활성화된 레이어별로 나열됩니다. 영역 상단의 탭을 사용하여 모든 레이어 또는 특정 레이어의 차이점을 살펴볼 수 있습니다.  Component Primitives causing Differences for 영역은 왼쪽에 차이를 유발한 컴포넌트 프리미티브를 나열하고 오른쪽에 해당 데이터를 표시합니다. 다음 정보가 포함됩니다.

  • Object Type - 객체 유형입니다.
  • Identifier - 특수한 Designator 정보를 나열합니다.
  • Detail - 컴포넌트 프리미티브의 세부 정보를 표시합니다.

풋프린트를 셀로 나누어 그래픽으로 비교한 결과가 표시됩니다.  Highlight Cell Density 슬라이더 막대를 사용하여 표시 영역의 셀 크기를 늘리거나(오른쪽으로 이동) 줄일 수 있습니다(왼쪽으로 이동). 차이가 있는 셀은 원래 색상으로 표시되며, 차이점이 강조 표시됩니다. 현재 PCB의 프리미티브 객체는 원래 색상으로 표시되고, 라이브러리에서 업데이트된 컴포넌트 프리미티브는 그 위에 "고스트" 이미지로 겹쳐 표시됩니다.

  • 선택한 PCB 컴포넌트 풋프린트와 라이브러리 풋프린트 간에 풋프린트 파라미터 차이가 있으면 대화 상자의  Difference Details 영역에 파라미터 차이를 나열하는 Parameters 탭이 포함됩니다.

  • 선택한 PCB 컴포넌트 풋프린트와 라이브러리 풋프린트 간에 Pad Designator 또는 3D 바디의 차이가 있으면(PCB에서 풋프린트가 미러링된 경우 발생할 수 있음), 대화 상자의  Difference Details 영역에 파라미터 차이를 나열하는 Properties 탭이 포함됩니다.

  • 선택한 PCB 컴포넌트 풋프린트와 라이브러리 풋프린트 간에 차이가 없으면 영역 제목이  No Difference For [Designator name (Footprint Name)]로 표시되고, 선택한 레이어 탭에 해당하는 선택된 컴포넌트가 표시됩니다.

  •  Part List 의  Path 열이  <Footprint not found>로 표시되면  Difference Details 영역의 헤더에 풋프린트를 찾을 수 없다는 메시지가 표시됩니다.

비교 보고서 생성

풋프린트 비교 보고서(Footprint Comparison - PCBDocumentName.html)를 생성하려면 Update From PCB Libraries 대화 상자 왼쪽 하단의 Create Report 버튼을 클릭합니다. 보고서에는 다음 내용이 포함됩니다.

  • 일치하지 않는 컴포넌트 목록
  • 일치하는 컴포넌트 목록
  • 일치하지 않는 컴포넌트 목록에 있는 각 컴포넌트의 프리미티브 차이에 대한 세부 정보

풋프린트 비교 보고서
풋프린트 비교 보고서

비교 보고서를 생성하면 Update From PCB Libraries 대화 상자가 닫힙니다. 명령을 다시 실행해야 합니다.

풋프린트 비교 보고서는 Output Job Configuration 파일에서 검증 출력 세트의 일부로 추가할 수도 있습니다.

업데이트 진행

업데이트 방안이 만족스러우면 Accept Changes (Create ECO) 버튼을 클릭합니다. 열리는 Engineering Change Order 대화 상자에서 업데이트를 검증한 다음 실행합니다. 적용하지 않을 변경 사항은 비활성화합니다. 변경 사항이 적용되고, 업데이트에 포함된 컴포넌트의 풋프린트가 소스 라이브러리의 풋프린트로 업데이트됩니다.

풋프린트 업데이트를 검증하고 실행할 준비가 된 Engineering Change Order 대화 상자
풋프린트 업데이트를 검증하고 실행할 준비가 된 Engineering Change Order 대화 상자

ECO를 통해 의도치 않은 풋프린트 미러링을 수정하면 배치된 풋프린트 인스턴스의 미러링이 제거되어 소스 라이브러리에 정의된 것과 동일해집니다. 수정 사항을 적용할 때는 미러링 관련 요소(핀, 오버레이 및 3D 바디)만 고려됩니다. 회전과 같이 배치된 컴포넌트 풋프린트에 적용된 다른 변경 사항은 그대로 유지됩니다.

PCB 라이브러리 Editor에서 직접 변경 사항 적용

소스 PCB 라이브러리 내에서 배치된 PCB 풋프린트를 직접 업데이트할 수 있습니다. 이 업데이트 방식은 개별 PCB 풋프린트 라이브러리(*.PcbLib)에서 배치한 컴포넌트를 업데이트할 때, 그리고 해당 라이브러리가 프로젝트에서 사용 가능한 파일 기반 라이브러리에 포함되어 있을 때 특히 적합합니다.

소스 PCB 라이브러리에서 하나 이상의 컴포넌트 풋프린트에 적용한 변경 사항을 PCB에 배치된 해당 풋프린트 인스턴스에 직접 전달할 수 있습니다. PCB 라이브러리 Editor의 기본 Tools 메뉴에는 현재 풋프린트만 업데이트하는 명령(Update PCB With Current Footprint)과 모든 풋프린트를 업데이트하는 명령(Update PCB With All Footprints)이 있습니다. 이러한 명령은 PCB 라이브러리 Panel의 마우스 오른쪽 버튼 클릭 메뉴에서도 사용할 수 있습니다.

소스 PCB 라이브러리에서 PCB Library Panel의 마우스 오른쪽 버튼 클릭 메뉴를 사용하여 변경 사항을 적용할 수 있습니다.
소스 PCB 라이브러리에서 PCB Library Panel의 마우스 오른쪽 버튼 클릭 메뉴를 사용하여 변경 사항을 적용할 수 있습니다.

Parent 프로젝트와 관계없이 열려 있는 모든 PCB 문서에서 배치된 컴포넌트 풋프린트의 모든 인스턴스가 업데이트됩니다. 즉, 배치된 컴포넌트 풋프린트의 이름이 라이브러리 컴포넌트의 이름과 같으면 업데이트됩니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents