굽힘선 정의 - 표준 모드

개요

이 문서에서는 Altium Designer의 Standard Rigid-Flex 모드에서 작업할 때 Flex 영역의 벤딩 라인을 정의, 배치, 이동, 제거하고 구성하는 방법을 설명합니다. 또한 Standard Rigid-Flex 모드와 Advanced Rigid-Flex 모드의 차이점, 보드에서 사용 중인 모드를 확인하는 방법, 벤딩을 정확하게 관리하는 데 사용하는 Editor 보기와 패널도 알아봅니다. 적절한 모드에서 벤딩 위치, 각도, 반경, 영향 영역 너비 및 접기 순서를 설정하는 실용적인 단계별 안내가 필요하다면 이 가이드를 참고하세요. 내용을 계속 읽고 다음 설계에 적용하여 더욱 자신 있게 작업해 보세요.

- Standard Rigid-Flex 모드에서 벤딩 라인을 사용할 수 있는 조건과 보드 영역을 정의할 때 이 모드가 Advanced Rigid-Flex와 어떻게 다른지 알아봅니다.
- Board Planning Mode에서 벤딩 라인을 배치하고, 위치를 변경하고, 삭제하고, 정밀하게 정렬하는 구체적인 절차를 살펴봅니다.
- 벤딩 각도, 반경, 영향 영역 너비, 3D 접기 검증을 위한 접기 순서 등 설정 가능한 벤딩 라인 속성을 알아봅니다.
AI로 더 깊이 알아보기:

Altium의 PCB 설계 소프트웨어에서는 두 가지 리지드 플렉스 설계 모드를 사용할 수 있습니다. Rigid-Flex라고 하는 기존의 표준 모드는 단순한 리지드 플렉스 설계를 지원합니다. Flex 영역이 겹치는 경우처럼 설계에 더 복잡한 리지드 플렉스 요구 사항이 있다면 Advanced Rigid-Flex 모드(리지드 플렉스 2.0이라고도 함)가 필요합니다. 모드는 Layer Stack Manager의 Tools 메뉴에서 선택합니다.

두 모드의 근본적인 차이점은 기존 모드에서는 Split 라인을 배치하여 보드 형상을 별도의 보드 영역으로 나누며, 이 Split 라인이 한 보드 영역이 끝나고 다른 보드 영역이 시작되는 위치를 정의하는 객체로 남는다는 점입니다. Advanced 모드에서는 각 보드 영역을 개별적으로 배치하거나, 큰 영역을 분할하면 두 개의 별도 영역 객체가 됩니다. Advanced 모드에서는 Split 라인의 존재 여부가 아니라 인접한 보드 영역의 가장자리가 두 영역이 만나는 위치를 정의합니다. 이러한 차이로 인해 보드가 Advanced Rigid-Flex 모드일 때는 Split 라인 객체가 없습니다.

► Rigid-Flex PCB 설계에 대해 자세히 알아보기

View 메뉴에는 기억하기 쉬운 단축키가 지정된 세 가지 PCB 편집기 작업 모드가 있어 다음 모드 간에 빠르게 전환할 수 있습니다.

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

2D 및 3D 보기 모드 간에 전환할 때는 기본적으로 각 보기 모드의 확대/축소 및 방향 설정이 개별적으로 유지됩니다. 전환 시 보드의 동일한 위치와 방향을 보려면 2 또는 3 대신 Ctrl+Alt+2 또는 Ctrl+Alt+3을 누르세요.

방금 PCB를 열었는데 표준 리지드 플렉스 모드인지 고급 리지드 플렉스 모드인지 궁금하신가요?

Layer Stack Manager를 열어 확인할 수 있습니다. 또는 Board Planning Mode(1 단축키)로 전환한 후 Active Bar를 확인하세요.

표준 Rigid-Flex 모드
Advanced Rigid-Flex 모드

Flex 보드를 어떻게 구부릴지 정의하려면 하나 이상의 굽힘선을 배치합니다. 굽힘선은 Flex 영역 표면에서 굽힘이 발생할 위치를 정의합니다. 또한 굽힘 각도와 반경뿐 아니라 구부러지는 보드 표면 띠의 너비도 정의합니다. 굽힘선은 PCB 편집기가 Board Planning Mode 상태일 때 배치하고 편집합니다(View » Board Planning Mode 또는 1 단축키를 누름).

굽힘선은 Layer Stack Manager에서 Flex 영역으로 구성된 영역에만 배치할 수 있습니다.


유연한 영역 위에 굽힘선을 배치하고 보드가 180도 접히도록 구성합니다. 이 동영상에서는 표준 Rigid-Flex 모드에서 굽힘선을 배치하는 방법을 보여줍니다.

굽힘선 배치

굽힘선을 배치하려면:

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 전환합니다.

  2. 굽힘선은 Multi-Layer에 배치됩니다. 편집 공간 하단에 Mutli-Layer 탭이 표시되지 않으면 View Configuration 패널에서 해당 레이어를 활성화합니다(L 단축키로 패널 표시).

  3. Design » Define Bending Line 명령을 선택합니다.

  4. 굽힘선을 배치할 보드 영역 내부를 클릭합니다. 선의 한쪽 끝은 클릭한 위치에서 가장 가까운 영역 가장자리에 연결되고, 다른 쪽 끝은 커서에 연결됩니다.

  5. 두 번째 끝을 원하는 위치로 이동한 다음 한 번 클릭하여 배치합니다.

  6. 굽힘선 배치 모드가 유지되므로 필요한 경우 다른 굽힘선을 배치할 수 있습니다. 더 이상 배치하지 않으려면 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 굽힘선 배치 모드를 종료합니다.

Layer Stack Regions 모드의 PCB 패널에는 Bending Lines 데이터가 표시됩니다. 항목을 두 번 클릭하면 굽힘선 대화 상자가 열립니다. 

이 Flex 보드 영역에는 세 개의 굽힘선이 배치되어 있습니다. 주황색 띠의 너비는 영향 영역 너비입니다.
이 Flex 보드 영역에는 세 개의 굽힘선이 배치되어 있습니다. 주황색 띠의 너비는 영향 영역 너비입니다.

보드 영역이 Flex 레이어 스택을 사용하도록 설정되면 기하학적 중심을 따라 수직으로 굽힘선이 자동 추가됩니다. 필요에 따라 이 굽힘선을 제거하거나 위치를 변경하고 구성하세요.

굽힘선 이동

기존 굽힘선의 위치를 변경하려면:

  1. View » Board Planning Mode 을 선택하거나( 1 단축키를 눌러) Board Planning Mode로 전환합니다.
  2. 굽힘선이 포함된 Board Region을 한 번 클릭하여 선택합니다. 해당 영역 내 모든 굽힘선의 핸들이 표시됩니다.
  3. 선 끝의 위치를 변경하려면 노드를 클릭한 채 보드 영역 외곽선 둘레의 원하는 위치로 드래그합니다. 커서 이동은 현재 스냅 그리드 및/또는 기존 설계 객체에 맞춰 제한됩니다.
  4. 굽힘 위치는 굽힘선의 새 위치에 따라 다시 정의됩니다.

굽힘선의 끝 노드를 선택하고 드래그하여 보드의 굽힘 위치를 변경합니다.
굽힘선의 끝 노드를 선택하고 드래그하여 보드의 굽힘 위치를 변경합니다.

굽힘선의 정확한 위치 지정

굽힘선을 이동하면 핸들이 현재 Snap Grid의 위치에 스냅됩니다. 이동 중에는 기계 레이어의 선과 같은 기존 설계 객체에도 스냅할 수 있습니다. 아래 이미지는 Mechanical 2 레이어에 있는 선의 끝에 굽힘선 핸들을 배치하는 모습을 보여줍니다(숫자 1로 표시). 스냅 동작이 작동하려면 해당 기계 레이어가 활성 설계 레이어여야 합니다.

숫자 1은 Mechanical 2의 선에 스냅된 굽힘선 핸들을 가리킵니다. 이 레이어가 활성 레이어라는 점에 유의하세요.
숫자 1은 Mechanical 2의 선에 스냅된 굽힘선 핸들을 가리킵니다. 이 레이어가 활성 레이어라는 점에 유의하세요.

위 과정을 더 자세히 보여주기 위해 아래 이미지에는 2D Layout Mode에서 Mechanical 2에 배치한 보조선이 표시되어 있습니다. 이 보조선은 45도 굽힘선을 배치하는 데 사용할 상단 및 하단 기준점을 정확하게 정의합니다.

대각선 굽힘선을 정확하게 배치하는 데 도움이 되는 보조선이 표시된 2D 레이아웃 모드의 보드입니다.대각선 굽힘선을 정확하게 배치하는 데 도움이 되는 보조선이 표시된 2D 레이아웃 모드의 보드입니다.

Mechanical 2의 보조선에 스냅된 대각선 굽힘선이 표시된 보드 계획 모드의 보드입니다.Mechanical 2의 보조선에 스냅된 대각선 굽힘선이 표시된 보드 계획 모드의 보드입니다.

굽힘선 제거

굽힘선을 제거하려면:

  1. View » Board Planning Mode을 선택하거나( 1 단축키를 눌러) Board Planning Mode로 전환합니다.
  2. 끝점 중 하나를 클릭한 채 Delete 키를 누릅니다. 또는 PCB 패널의 Bending Lines 영역에서 굽힘선 항목을 선택하여 삭제합니다.

보드 영역이 Flex 레이어 스택을 사용하도록 설정되면 기하학적 중심을 따라 수직으로 굽힘선이 자동 추가됩니다. 필요에 따라 이 굽힘선을 제거하거나 위치를 변경하고 구성하세요.

굽힘선 속성 구성

보드 영역, Split 라인 및 굽힘선은 Board Planning Mode에서 확인하고 편집합니다(1 누름). 굽힘선은 설계 공간에서 대화형으로 편집하거나 PCB을 통해 편집할 수 있습니다. Layer Stack Regions 모드로 설정된 패널입니다. 패널을 표시하려면 Altium Designer 오른쪽 하단의 Panels 버튼을 클릭한 다음 메뉴에서 PCB을 선택합니다. 패널 상단의 드롭다운에서 Layer Stack Regions을 선택합니다. 이 모드에서는 패널에 다음 항목이 표시됩니다.

  • Layer Stacks 영역에 사용 가능한 보드 레이어 스택이 표시됩니다.
  • Stackup Regions 영역에 해당 스택에 할당된 Region이 표시됩니다.
  • Bending Lines 영역에 선택한 Region에 정의된 굽힘선이 표시됩니다.

Board Planning Mode에 진입하면 PCB 패널이 자동으로 Layer Stack Regions 모드로 설정됩니다.

PCB 패널에서 굽힘선의 속성을 편집하려면:

  1. 굽힘선은 2D Layout Mode(2 누름) 또는 Board Planning Mode(1 누름)에서 편집할 수 있습니다.
  2. 패널 상단의 Select 체크박스를 선택합니다.
  3. PCB 패널의 Stackup Regions 영역에서 굽힘선이 포함된 Board Region을 선택합니다.
  4. 패널의 Bending Lines 영역에 있는 목록에서 굽힘선을 선택합니다. PCB 패널의 Select 옵션이 활성화되어 있으면 보드에서 해당 굽힘선이 강조 표시됩니다(선택됨). Bending Lines 영역에서 굽힘선 항목을 삭제할 수도 있습니다.
  5. Bending Lines 영역에서 굽힘선 항목을 두 번 클릭하면 아래 이미지와 같이 Bending Line 대화 상자가 열립니다.

  6. Bending Line 대화 상자에서 처음 세 속성 중 두 가지를 편집합니다. 예를 들어 Radius (굽힘 표면에서 굽힘 중심점까지의 거리) 및 Bending Angle (Flex 영역의 표면이 굽혀지는 각도)를 편집합니다. 세 번째 속성인 Affected area width(지정된 Radius 및 Bending Angle에 따라 굽혀지는 표면 영역의 너비)는 자동으로 계산됩니다(자세한 내용은 아래 참조). 각 굽힘선의 Affected area width은 주황색 음영 영역으로 표시됩니다.
  7. Bending Line 대화 상자에서 필요에 따라 Fold Index을 설정하여 굽힘이 접히는 순서를 정의합니다. 이 순서는 PCB 패널의 Fold State 슬라이더 또는 View » Fold/Unfold 명령을 사용하여 3D 모드에서 보드를 접을 때 적용됩니다. 값이 가장 낮은 굽힘부터 가장 높은 굽힘 순으로 적용됩니다.

3D 표시 모드의 물리적 기준면(Z = 0)을 정의하려면 보드 영역 중 하나의 Board Region 대화 상자에서 3D Locked 체크박스를 선택해야 합니다. 이렇게 하지 않으면 정의된 각 굽힘선의 Affected area width이 표시되지 않습니다.

굽힘선 핸들을 배치하거나 이동하는 동안 Tab을 누르거나 굽힘선 핸들을 두 번 클릭하여 Bending Line 대화 상자를 열 수도 있습니다.

굽힘 정의 요약

굽힘선은 보드의 해당 Flex 영역에 적용할 굽힘의 위치, 반경 및 각도를 정의하기 위해 영역을 가로질러 배치하는 선형 객체입니다.

굽힘선 정의:

  • 굽힘선은 보드 계획 모드에서 배치합니다(1 단축키).
  • 굽힘선을 배치하려면 Design » Define Bending Line 명령을 실행합니다.
  • 유연한 보드 Region을 가로질러 굽힘선을 배치합니다. 굽힘선의 시작점과 끝점이 영역의 각 가장자리에 정확히 닿을 필요는 없습니다. 소프트웨어가 자동으로 길이를 늘리거나(너무 짧은 경우) 줄입니다(너무 긴 경우). 굽힘선의 한쪽 끝 이상이 Region의 가장자리에 닿거나 가장자리를 넘어야 합니다.
  • 굽힘선의 속성을 편집하려면 영역 내부의 아무 곳이나 클릭하여 해당 영역 내 모든 굽힘선의 꼭짓점을 표시한 다음, 아래 작업을 수행합니다.
    • 굽힘선의 꼭짓점을 두 번 클릭하여 굽힘선 대화 상자를 열거나,
    • PCB 패널을 표시하고 Layer Stack Regions 모드로 설정하여 Region과 굽힘선을 확인하고 편집합니다.
    • 필요에 따라 Bending Angle 및 굽힘 Radius을 설정합니다.
    • 굽힘은 Fold Index 순서대로 접힙니다. 접히는 순서를 확인하는 것이 중요할 때 이 기능을 사용합니다.
  • 굽힘선을 이동하려면 각 꼭짓점을 클릭하여 드래그합니다.
  • 굽힘선의 꼭짓점 중 하나를 클릭한 상태에서 키보드의 Delete을 누르면 굽힘선을 제거할 수 있습니다.
  • 굽힘선은 보드 컷아웃의 가장자리에 적용할 수 없습니다. 보드에 이러한 구성이 필요한 경우 Rigid-Flex 고급 모드로 전환합니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents