Searching for & Placing Components

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

W skrócie

W tym artykule wyjaśniamy, jak panel Components w Altium Designer pomaga wyszukiwać, przeglądać i umieszczać komponenty z przestrzeni roboczej oraz bibliotek bazodanowych i plikowych, a także nimi zarządzać. Omawiamy dostępne opcje wyszukiwania, w tym przeglądanie kategorii, wyszukiwanie za pomocą zapytań oraz filtrowanie parametryczne komponentów z przestrzeni roboczej. Pokazujemy również, jak panel współpracuje z powiązanymi narzędziami, takimi jak panel Manufacturer Part Search, edytor komponentów i panel Explorer. Dowiesz się też, jak otworzyć panel z poziomu dokumentów schematów i PCB, w jaki sposób określane są kategorie komponentów oraz jakie operacje i opcje wyświetlania pozwalają usprawnić pracę. Jeśli chcesz łatwiej znajdować odpowiednie komponenty i sprawnie umieszczać je w swoich projektach, czytaj dalej.

- Dowiedz się, jak wyszukiwać komponenty w panelu Components za pomocą kategorii, zapytań i filtrów opartych na parametrach.
- Poznaj źródła komponentów, w tym przestrzeń roboczą, biblioteki plikowe, biblioteki bazodanowe oraz wyniki wyszukiwania w panelu Manufacturer Part Search.
- Zobacz, jak umieszczać komponenty i korzystać z kluczowych funkcji panelu do przeglądania szczegółów, edytowania komponentów, zarządzania bibliotekami i porządkowania listy komponentów.
Zagłęb się w temat dzięki AI:

Sercem każdego projektu elektronicznego są komponenty. Komponent, który ostatecznie zostanie przylutowany do płytki, musi mieć swoją reprezentację, czyli model, w każdej dziedzinie projektowania: jako symbol na schemacie, model SPICE w symulatorze, footprint na płytce oraz model 3D STEP w pliku przekazywanym projektantowi mechaniki.

Dowiedz się więcej o tworzeniu i utrzymywaniu komponentów oraz bibliotek.

Panel Components w Altium Designer zapewnia rozbudowany interfejs do pracy ze wszystkimi komponentami — zarówno z przestrzeni roboczej, jak i spoza niej. Wymagany komponent można wyszukać, określając kategorię i korzystając z prostego trybu wyszukiwania przez wpisanie zapytania (pełnej lub częściowej nazwy komponentu, wartości itp.) w polu wyszukiwania. Ponadto panel umożliwia parametryczne wyszukiwanie fasetowe oparte na filtrach, pozwalające określić docelowe parametry komponentów z przestrzeni roboczej. Panel oferuje również opcje edycji komponentu z przestrzeni roboczej za pomocą edytora komponentów w trybie edycji pojedynczego komponentu, wyświetlania komponentu w jego źródłowej przestrzeni roboczej oraz wykonywania operacji zarządzania komponentami, takich jak ich tworzenie i klonowanie czy edycja wybranych części i typu zaznaczonego komponentu. Komponent można umieścić na schemacie, przeciągając go lub używając polecenia Place z menu kontekstowego komponentu.

Choć można oczywiście tworzyć własne komponenty, Altium Designer udostępnia rozbudowany panel Manufacturer Part Search, który umożliwia wyszukiwanie rzeczywiście produkowanych części. Jeśli masz przestrzeń roboczą, możesz zapisać w niej te części, a następnie uzyskiwać do nich dostęp przez panel Components. Proces ten obejmuje utworzenie nowego komponentu przestrzeni roboczej — za pomocą edytora komponentów w trybie edycji pojedynczego komponentu — i zapisanie go w przestrzeni roboczej.

Panel Components zapewnia bezpośredni dostęp do dostępnych komponentów przestrzeni roboczej oraz komponentów z bibliotek bazodanowych i plikowych w Altium Designer.

Panel pobiera komponenty z połączonej przestrzeni roboczej oraz wszystkich otwartych lub zainstalowanych bibliotek. Udostępnia pełne informacje o wybranym komponencie (parametry, modele, wybrane części, dane dostawców itp.), porównywanie komponentów, a w przypadku komponentów przestrzeni roboczej — parametryczne wyszukiwanie oparte na filtrach, pozwalające określić docelowe parametry komponentów.

Panel Components w trybie normalnym

Panel Components w trybie kompaktowym

 

Panel Components korzysta z podstawowych funkcji wyszukiwarki i widoku stosowanych w panelu Manufacturer Part Search. Podczas gdy panel Manufacturer Part Search wykorzystuje usługę Altium Parts Provider i koncentruje się na wyszukiwaniu danych producentów i dostawców komponentów, panel Components zawiera gotowe do umieszczenia komponenty z połączonej przestrzeni roboczej oraz bibliotek bazodanowych i plikowych.

W przypadku komponentów przestrzeni roboczej panel wyświetla tylko najnowszą rewizję każdego komponentu.
Choć wiele funkcji pracy z komponentami jest dostępnych w panelu Components, można również korzystać z panelu Explorer — zasadniczo pierwszy z nich udostępnia podzbiór funkcji drugiego, ukierunkowany na zarządzanie komponentami. Niektóre operacje dotyczące samych komponentów nadal można wykonywać wyłącznie w panelu Explorer (dodawanie kart katalogowych bez edycji, zmiana stanów, zbiorcze usuwanie komponentów i modeli itp.), jednak dotyczą one raczej nietypowych, skrajnych przypadków lub działań administracyjnych i związanych z organizacją przestrzeni roboczej. Pamiętaj, że komponent to tylko jeden z typów zawartości — panel Explorer pokazuje pełnię swoich możliwości przy obsłudze całego zakresu typów zawartości obsługiwanych przez przestrzeń roboczą. Na przykład tworzenie szablonów komponentów i zarządzanie nimi — a więc elementami ściśle związanymi z komponentami — jest możliwe wyłącznie w panelu Explorer (chyba że szablony są tworzone podczas importowania biblioteki za pomocą importera bibliotek).

Dostęp do panelu Components

Aby otworzyć panel Components, wybierz View » Panels » Components z menu głównego lub opcję Components z menu przycisku w prawym dolnym rogu ekranu głównego. Dzięki responsywnej konfiguracji układ panelu dynamicznie dostosowuje się, przełączając między pełnoekranowym trybem normalnym () a trybem kompaktowym (), w którym opcje kategorii i filtrów są zwijane do menu.

W dokumencie schematu użyj skrótu klawiaturowego P, P, aby otworzyć panel Components. Możesz również użyć polecenia Place » Part z menu głównego, polecenia Place » Part z menu kontekstowego obszaru projektowego edytora schematów lub przycisku Part () na Active Bar.

W dokumencie PCB użyj skrótu klawiaturowego P, C, aby otworzyć panel Components. Możesz również użyć polecenia Place » Component z menu głównego, polecenia Place » Component z menu kontekstowego obszaru projektowego edytora PCB lub polecenia Component () na Active Bar.

Przy pierwszym uruchomieniu panelu Components w bieżącej sesji Altium Designer, po połączeniu z przestrzenią roboczą dostępne są następujące elementy sterujące:

  • Use Existing Components – kliknij, aby przeglądać typ komponentu aktualnie wybrany na górnej liście rozwijanej panelu.

  • Delete Existing Components – kliknij, aby otworzyć okno dialogowe Delete Existing Components, a następnie stronę Data Cleanup w Settings przestrzeni roboczej, gdzie można wybrać typy zawartości do usunięcia.

  • Import Library – kliknij, aby otworzyć standardowe okno dialogowe Windows Open, a następnie wybierz bibliotekę bazodanową lub plikową zapisaną w folderze lokalnym lub sieciowym. Po otwarciu pliku biblioteki zostanie uruchomiony importer bibliotek w trybie prostym z wczytaną wybraną biblioteką.

  • Create Component – kliknij, aby otworzyć okno dialogowe Create New Component, a następnie edytor komponentów w trybie edycji pojedynczego komponentu, gotowy do zdefiniowania nowego komponentu.

Obszar Categories panelu (lub menu rozwijane w trybie kompaktowym) zawiera listę wszystkich dostępnych komponentów przestrzeni roboczej w kategorii All oraz wszystkich dostępnych bibliotek. Gdy panel jest w trybie normalnym, kliknij ikonę listy Categories lub ikonę «, aby zwinąć lub rozwinąć kolumnę, i użyj przycisku (w prawym górnym rogu), aby przełączać widoczność obszaru Details komponentu. Podczas przeglądania obszaru Categories można używać skrótów klawiaturowych Up/Down i PgUp/PgDn do poruszania się po liście. Skróty klawiaturowe Left/Right umożliwiają rozwijanie i zwijanie poszczególnych gałęzi.

Grupowanie Categories komponentów w przestrzeni roboczej wynika z parametrów Component Type przypisanych do poszczególnych komponentów. Na przykład, jeśli dla komponentu parametr Component Type ma wartość Resistor, komponent ten będzie widoczny w kategorii Resistor w panelu Components (niezależnie od folderu przestrzeni roboczej, w którym się znajduje).

Aby określić lub zmienić typ komponentu na bieżąco, kliknij jego pozycję prawym przyciskiem myszy, a następnie wybierz z menu kontekstowego opcję Operations » Change Component Type, aby otworzyć okno dialogowe Wybierz typ komponentu.

Parametr Type komponentu jest określany:

Typami komponentów można zarządzać (tworzyć je, edytować i usuwać) na stronie Zarządzanie danymi – Typy komponentów w oknie dialogowym Preferences. Przycisk Templates w tym oknie otwiera okno dialogowe Edit Templates, w którym można określić lub zmienić szablon komponentu powiązany z każdym typem komponentu.

NOTE: O tym, w której Category znajduje się komponent, decyduje jego parametr Component Type, a nie folder przestrzeni roboczej, w którym jest przechowywany. Dlatego przeniesienie komponentu do innego folderu za pomocą panelu Explorer nie będzie odzwierciedlone w panelu Components.

Menu operacji

Opcje menu operacji umożliwiają ustawianie preferencji bibliotek plikowych, wyszukiwanie oraz określanie widoczności kolekcji modeli komponentów. Aby uzyskać dostęp do tych opcji, kliknij przycisk menu operacji w prawym górnym rogu panelu.

  • Create Component – wybierz, aby otworzyć okno dialogowe Create new component, a następnie edytor komponentów w trybie edycji pojedynczego komponentu, gotowy do zdefiniowania nowego komponentu.
  • Import Library – wybierz, aby otworzyć standardowe okno dialogowe systemu Windows Open i wybrać bibliotekę bazodanową lub plikową zapisaną w folderze lokalnym lub sieciowym. Po otwarciu pliku biblioteki uruchomi się Library Importer w trybie prostym z załadowaną wybraną biblioteką.
  • Clean-up Library – wybierz, aby otworzyć okno dialogowe Delete Existing Components, a następnie stronę Data Cleanup w Settings przestrzeni roboczej, gdzie można wybrać typy zawartości do usunięcia.
  • Models – wybierz, aby uwzględnić pozycje kolekcji modeli bibliotecznych na liście Categories. Dodatkowe pozycje w tym trybie przeglądania obejmują kolekcje symboli, obudów PCB i modeli symulacyjnych z połączonej przestrzeni roboczej, a także zainstalowane biblioteki obudów PCB (*.PcbLib).
  • File-based Libraries Preferences – wybierz, aby otworzyć okno dialogowe Available File-based Libraries, w którym dostępne są elementy sterujące umożliwiające dodawanie bibliotek bazodanowych i plikowych do bieżącego projektu lub ich usuwanie, instalowanie bibliotek oraz określanie ścieżek wyszukiwania bibliotek. Więcej informacji znajdziesz w sekcji Zarządzanie dostępnymi bibliotekami bazodanowymi i plikowymi na stronie Wyszukiwanie komponentów w bibliotekach plikowych i bazodanowych.
  • File-based Library Search – wybierz, aby otworzyć okno dialogowe File-based Libraries Search, w którym można wyszukać komponent, gdy nie wiadomo, w której bibliotece bazodanowej lub plikowej się znajduje ani czy w ogóle jest dostępny. Więcej informacji znajdziesz w sekcji Wyszukiwanie komponentów w bibliotekach bazodanowych i plikowych na stronie Wyszukiwanie komponentów w bibliotekach plikowych i bazodanowych.
  • Refresh – kliknij, aby szybko odświeżyć panel. Bieżące zaznaczenie komponentów zostanie zachowane.

Lista komponentów

W samej tabeli listy komponentów można zarządzać jej zawartością w następujący sposób:

  • Ustawianie kolejności sortowania listy komponentów – kliknij nagłówek kolumny, aby posortować listę komponentów według danych w tej kolumnie. Kliknij nagłówek ponownie, aby odwrócić kolejność sortowania.

  • Ustawianie kolejności wyświetlanych kolumn – przeciągnij nagłówek kolumny i upuść go w nowym miejscu.

  • Określanie widocznych kolumn parametrów – kliknij prawym przyciskiem myszy nagłówek kolumny i wybierz Select Columns, aby otworzyć okno dialogowe Select Columns, w którym można sterować widocznością kolumny parametru i zmieniać jej położenie.

    Okno dialogowe Select columns
    Okno dialogowe Select columns

    • W oknie dialogowym wymienione są wszystkie kolumny, które mogą być wyświetlane w panelu Components. Jeśli przy pozycji widnieje , dana kolumna będzie wyświetlana w panelu Components . Jeśli przy pozycji widnieje , dana kolumna not będzie wyświetlana w panelu Components. Klikaj symbole, aby przełączać widoczność kolumn.

    • Możesz również sterować wyświetlaniem wszystkich kolumn, klikając ikonę / na pasku nagłówków kolumn. Gdy niektóre kolumny są widoczne, a inne ukryte, wyświetlana jest ikona .

    • Najedź kursorem na pasek nagłówka drugiej kolumny i kliknij ikonę , aby otworzyć listę rozwijaną, z której można wybrać kolumnę do wyświetlenia.

    • Użyj przycisków  / , aby przesunąć wybraną pozycję w górę lub w dół listy. Przesuwać można tylko pozycje ustawione jako widoczne (). Określa to kolejność kolumn w panelu Components.

  • Grupowanie listy według danych w kolumnie – kliknij prawym przyciskiem myszy nagłówek kolumny, wybierz opcję Enable Columns Grouping, a następnie przeciągnij nagłówek kolumny (np. Footprint) do obszaru grupowania nad listą. Pozycje listy zostaną pogrupowane według poszczególnych unikatowych wartości parametru (np. typu obudowy PCB) z wybranej kolumny grupowania.

    Podczas korzystania z Grouping do grupowania komponentów na liście obowiązuje limit 10 000 pozycji.

  • Filtrowanie listy według określonej wartości w kolumnie – wybierz w nagłówku kolumny, aby wyświetlić listę unikatowych wartości jej parametru, a następnie wybierz wartość, aby ograniczyć listę komponentów do tych, które zawierają wskazany parametr (np. kod typu obudowy PCB). Wybierz opcję All, aby zresetować filtr. Wybierz (Custom), aby otworzyć okno dialogowe Filter Editor i dokładniej określić filtrowanie w wybranej kolumnie.

Wyświetlanie kolumn

Zawartość panelu Components można wyświetlać na różne sposoby. Po kliknięciu prawym przyciskiem myszy nazwy dowolnej kolumny (Nazwa, Opis, Obudowa PCB) można wybrać jedną z poniższych opcji, zależnie od preferowanego sposobu wyświetlania komponentów:

  • Best Fit – dopasowuje zawartość kolumn Name i Descriptions tak, aby znajdowały się blisko siebie, bez nadmiernych odstępów między kolumnami.

  • Best Fit All Columns – dopasowuje zawartość wszystkich kolumn tak, aby znajdowały się blisko siebie, bez nadmiernych odstępów między kolumnami.

  • Clear Sorting – służy do cofania sortowania kolumn.

  • Enable Columns Grouping – umożliwia przeciąganie nagłówków kolumn względem określonej kolumny, co pozwala zmieniać kolejność kolumn Name, Description i Footprint.

  • Select Columns – otwiera okno dialogowe Select Columns, w którym można wybrać inne kolumny do wyświetlenia w tej sekcji.

  • Apply Column Visibility to Child Categories – jeśli wybrana kategoria ma kategorię podrzędną, użyj tego polecenia, aby umożliwić przenoszenie ustawień widoczności kolumn z kategorii nadrzędnych do podrzędnych. To polecenie jest dostępne tylko wtedy, gdy istnieje kategoria podrzędna.

Wyszukiwanie komponentów i funkcje

Wyszukiwanie komponentów

Aby wyszukać dostępne komponenty w panelu Components, wpisz frazę w polu Search lub użyj opcji Categories i Filters w panelu, aby zawęzić listę komponentów do swoich potrzeb. Filtry są obsługiwane wyłącznie w przypadku komponentów Workspace, a podobnie jak panel Manufacturer Part Search, panel Components obsługuje filtry wyszukiwania uwzględniające jednostki (z konwersją tekstu na liczby). Funkcja wyszukiwania ustala priorytet wyników zgodnie z wprowadzonymi kryteriami.

Funkcja Search umożliwia wybranie, a następnie edycję lub uzupełnienie aktywnego ciągu Search.

Kliknij „aktywny” ciąg wyszukiwania, aby wprowadzić go do pola Search. W polu Search możesz ponownie użyć tego zapytania lub je edytować.

Pole Search obsługuje również wyszukiwanie z użyciem symboli wieloznacznych, oznaczanych w ciągu gwiazdką (*).

Okno dialogowe Find Similar Components, dostępne po kliknięciu prawym przyciskiem myszy komponentu na liście i wybraniu opcji Find Similar Components, umożliwia określenie preferencji wyszukiwania na podstawie wybranego komponentu.

Końcowe wyniki wyszukiwania zależą od wybranego typu komponentu — komponentów Workspace lub spoza Workspace — oraz od stanu połączenia z Workspace. Na przykład w przypadku komponentów Workspace często wyświetlanych jest więcej parametrów niż w przypadku komponentów spoza Workspace. Aby wyszukać komponenty i parametry takie same jak w wybranym komponencie lub różniące się od nich, można użyć list rozwijanych i wybrać opcje Same, Any lub Different.

Umieszczanie komponentów

Wybrany komponent można umieścić na schemacie, przeciągając go i upuszczając, wybierając opcję Place z jego menu kontekstowego dostępnego pod prawym przyciskiem myszy, używając przycisku w obszarze Details, klikając dwukrotnie pozycję żądanego komponentu lub używając skrótu klawiaturowego Enter.

Aby umieścić komponent z panelu, możesz:

  • Kliknąć przycisk Place w obszarze Component Details – kursor automatycznie przesunie się w obręb arkusza schematu, a komponent pojawi się przy kursorze; ustaw go w odpowiednim miejscu i kliknij, aby go umieścić. Po umieszczeniu komponentu przy kursorze pojawi się kolejna instancja tego samego komponentu; kliknij prawym przyciskiem myszy, aby zakończyć tryb umieszczania.

    Components panel, placing from component details pane

  • Kliknąć komponent prawym przyciskiem myszy i wybrać opcję Place z menu kontekstowego. Komponent pojawi się przy kursorze; ustaw go w odpowiednim miejscu i kliknij, aby go umieścić. Pamiętaj, że jeśli panel jest pływający i zasłania obszar projektowania, stanie się przezroczysty, umożliwiając podgląd schematu i umieszczenie komponentu. Po umieszczeniu komponentu przy kursorze pojawi się kolejna instancja tego samego komponentu; kliknij prawym przyciskiem myszy, aby zakończyć tryb umieszczania.

  • Click, Hold&Drag – kliknij i przeciągnij komponent z obszaru tabeli panelu na arkusz schematu. W tym trybie należy przytrzymać przycisk myszy; komponent zostanie umieszczony po zwolnieniu przycisku. Po umieszczeniu komponentu możesz wybrać inny komponent lub inne polecenie.

    Przeciąganie i upuszczanie pozwala umieścić pojedynczą instancję komponentu. Jeśli chcesz umieścić wiele instancji, użyj polecenia/przycisku Place lub kliknij dwukrotnie pozycję komponentu.

Umieszczanie komponentu jest naprawdę proste. Zanim jednak zaczniesz, upewnij się, że arkusz schematu (lub dokument PCB), w którym ma zostać umieszczony komponent, jest otwarty w Altium Designer i jest aktywnym dokumentem. Jeśli dokumenty są otwarte w wielu oknach, upewnij się również, że okno zawierające aktywny dokument schematu ma fokus.

Podczas pracy z Altium Designer w wielu oknach, jeśli panel Components lub panel Explorer jest zadokowany w dowolnym trybie w oknie niezawierającym docelowego schematu, polecenie Place pozostaje wyszarzone. Dzieje się tak, ponieważ kliknięcie wewnątrz zadokowanego panelu przenosi fokus na okno, do którego panel jest dołączony. Jeśli jednak panel jest pływający, można ustawić fokus na odpowiednim oknie Altium (tym z aktywnym schematem docelowym), a okno to zachowa fokus podczas pracy w panelu.

Umieszczanie komponentu wieloczęściowego

Jeśli umieszczany komponent składa się z wielu części, jako pierwsza zostanie umieszczona część wybrana pod podglądem symbolu w obszarze Models panelu.

Po umieszczeniu części komponentu wieloczęściowego można ją zmienić na inną część tego komponentu za pomocą listy rozwijanej Part w panelu Properties, gdy część jest zaznaczona. Można też przełączyć ją na następną dostępną część za pomocą polecenia Edit » Increment Part Number z menu głównego lub polecenia Part Actions » Increment Part Number z menu kontekstowego części dostępnego pod prawym przyciskiem myszy.

Altium Designer umożliwia przedstawienie komponentu wieloczęściowego jako pojedynczego symbolu (wszystkie części składowe) lub wielu symboli (po jednym dla każdej części składowej) przy użyciu tylko jednego komponentu dzięki zdefiniowanym trybom wyświetlania Normal i Alternate (Pokaż przykład).

  • Jeśli komponent wieloczęściowy ma puste części składowe w danym trybie wyświetlania (normalnym lub alternatywnym), są one pomijane podczas umieszczania (Pokaż przykład).

  • Jeśli komponent wieloczęściowy ma obiekty podstawowe zdefiniowane tylko w jednej części składowej, sufiks oznaczenia jest ukrywany po umieszczeniu tej części na arkuszu schematu (Pokaż przykład).

  • Jeśli część składowa nie zawiera obiektów podstawowych dla aktualnie wybranego trybu wyświetlania lub tryb wyświetlania nie zawiera obiektów podstawowych dla aktualnie wybranej części składowej, odpowiednia pozycja na liście rozwijanej Part w Mode w panelu Properties komponentu jest wyszarzona (). Po wybraniu takiej pozycji na liście rozwijanej zostaną wyświetlone ikony ostrzegawcze ().

  • Naruszenie Nieużywana część składowa komponentu nie zostanie zgłoszone podczas walidacji projektu, jeśli komponent ma części składowe bez obiektów podstawowych i nie są one umieszczone na schemacie.

Filtrowanie komponentów

Podczas przeglądania komponentów w Workspace sekcja Filters jest wypełniana wybranymi opcjami filtrowania na podstawie bieżącego wyszukiwania i dostępnych parametrów. Filtrowanie parametryczne komponentów na liście zapewnia dodatkowe możliwości wyszukania określonego komponentu lub typu komponentu. Otwórz sekcję Filters za pomocą przycisku nad sekcją Categories. W kompaktowym trybie panelu kliknij przycisk , aby wysunąć Filters jako rozszerzenie panelu.

Pamiętaj, że filtry są obsługiwane tylko w przypadku komponentów w Workspace. Użyj pola Filter Search w tej sekcji, aby znaleźć filtr określonego parametru.

Javascript ID: Pnl_Components_Filter
  • Funkcja wyszukiwania parametrycznego w Filters panelu opiera się na odpowiednich danych parametrów komponentów przekazywanych z Workspace, w którym przechowywane są te komponenty. W związku z tym funkcja Filter może być wyłączona, gdy oprogramowanie jest połączone ze starszym produktem serwerowym Altium. Aby włączyć funkcję Filter dla wcześniejszych wersji serwera, włącz opcję ComponentSearch.LegacyAFS.Filters w oknie dialogowym Advanced Settings.

  • Aby parametr pojawił się w sekcji Filters, komponenty w wybranej kategorii muszą używać co najmniej dwóch różnych wartości tego parametru. Pamiętaj również, że w sekcji Filters wyświetlanych jest maksymalnie 100 najpopularniejszych parametrów (używanych przez największą liczbę komponentów w połączonym Workspace, we wszystkich typach komponentów). Następujące parametry (lub parametry, których nazwy zaczynają się od poniższych nazw) są zawsze wyświetlane na górze sekcji: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Opcje Filters panelu można dostosować do swoich potrzeb, wybierając określone typy parametrów jako Favorites. Zostaną one wówczas przeniesione na początek listy dla bieżącej kategorii komponentów. Najedź kursorem na obszar po prawej stronie nazwy filtra parametru i kliknij ikonę , aby oznaczyć filtr jako ulubiony. Ustawienia ulubionych filtrów są stosowane i zapisywane osobno dla poszczególnych kategorii komponentów.

W przypadku komponentów w Workspace menu dostępne po kliknięciu prawym przyciskiem myszy oferuje opcje edycji komponentu w edytorze komponentów (Edit) oraz funkcje zarządzania komponentami, takie jak tworzenie i klonowanie komponentów lub edycja wyborów części i typu wybranego komponentu (Operations).

 
 
 
 
 

Dodatkowe opcje informacyjne w sekcji Details komponentu obejmują: wyświetlanie obrazu modelu, przeglądanie kart katalogowych online (References), dostęp do aktualnych informacji od dostawców (Part Choices), sprawdzanie, gdzie dana część została użyta w projektach Workspace, zarządzanych arkuszach i blokach do ponownego użycia (Where Used), a także — za pośrednictwem menu dostępnego po kliknięciu prawym przyciskiem myszy — możliwość kopiowania wybranych lub wszystkich danych parametrów komponentu (szczegółów technicznych) w formacie rozdzielanym tabulatorami oraz przywracania zestawu parametrów oznaczonych jako ulubione do pięciu parametrów domyślnych.

Podczas przeglądania komponentów w połączonym obszarze roboczym Altium 365, jeśli zostaną wykryte problemy ze stanem wybranego komponentu, zostaną one zasygnalizowane ikoną (w przypadku błędów) lub (w przypadku błędów krytycznych) w wierszu Component issues nad listą parametrów komponentu. Liczba po prawej stronie ikony wskazuje liczbę wykrytych problemów. Kliknij strzałkę w dół po prawej stronie liczby, aby wyświetlić krótkie opisy problemów.

Przykład wykrytych problemów ze stanem biblioteki.
Przykład wykrytych problemów ze stanem biblioteki.

Stan biblioteki obszaru roboczego można dokładniej przeanalizować na stronie pulpitu stanu biblioteki, dostępnej z poziomu interfejsu przeglądarkowego obszaru roboczego Altium 365. Więcej informacji znajdziesz w sekcji Pulpit stanu biblioteki.

Aby dokładniej filtrować zawartość panelu Components, możesz skorzystać z funkcji filtrowania niestandardowego. ​​​​​​

Aby skorzystać z tej funkcji:

  1. kliknij ikonę filtra () w nagłówku, aby wyświetlić menu rozwijane filtra,

  2. które umożliwia filtrowanie przez wybranie Filter Value (opcja domyślna) lub skonfigurowanie zdefiniowanego przez użytkownika Filter Rule. Jeśli wybierzesz wartość z listy, zostanie ona automatycznie przekształcona w wyrażenie (które można następnie edytować).

  3. Jeśli wybierzesz Filter Rules, aby zdefiniować własny filtr, wybierz operator z pierwszej listy rozwijanej,

  4. a następnie wybierz lub wpisz wartość filtra na drugiej liście rozwijanej.

  5. Bieżący filtr jest wyświetlany pod listą wyników. Kliknij przycisk , aby otworzyć okno dialogowe Filter Editor i edytować filtr.

Gdzie użyto

Wybierz komponent obszaru roboczego w panelu Components, aby w sekcji Where Used wyświetlić informacje o tym, gdzie jest obecnie używana jego najnowsza rewizja. Sekcja udostępnia informacje z szybkim filtrowaniem dotyczące:

  • Projects — projektów obszaru roboczego, w których użyto komponentu. Informacje są only wyświetlane po zapisaniu projektu w obszarze roboczym.

  • Managed Sheets — zarządzanych arkuszy schematów, na których użyto komponentu. 

  • Reuse Blocks — bloków wielokrotnego użytku przechowywanych w bibliotece połączonego obszaru roboczego.

Pamiętaj, że karty będą wyświetlane tylko wtedy, gdy w obszarze roboczym istnieje element wykorzystujący wybrany komponent.

Jeśli komponent nie jest używany we wszystkich wariantach projektu w obszarze roboczym, wpis projektu w sekcji Where Used będzie zawierać liczbę wariantów, w których komponent jest używany, całkowitą liczbę wariantów tego projektu oraz listę wariantów, w których komponent jest używany ().

Buforowanie danych komponentów

Podczas korzystania z panelu Components dane komponentów obszaru roboczego są zapisywane w pamięci podręcznej na komputerze lokalnym. Zapewnia to dostęp do komponentów obszaru roboczego w trybie offline, gdy Altium Designer nie jest połączony z obszarem roboczym, umożliwiając tym samym normalne przeglądanie i umieszczanie komponentów itp.

Przy pierwszym uruchomieniu panelu Components w bieżącej sesji Altium Designer w trybie offline w panelu zostanie wyświetlone ostrzeżenie wraz z opcjami dalszego korzystania z danych komponentów zapisanych w pamięci podręcznej lub wyczyszczenia tej pamięci.

Kliknij Use Cached Data, aby używać komponentów z pamięci podręcznej. Ten stan będzie sygnalizowany tekstem ostrzeżenia Offline mode – cached data is being used na dolnym pasku obszaru listy komponentów w panelu. Pamiętaj, że w tym trybie Filters nie są włączone.

Pamięć podręczna stopniowo gromadzi dane komponentów i można ją w dowolnym momencie wyczyścić (dla wszystkich obszarów roboczych) za pomocą opcji Clear Cache, dostępnej w sekcji Known Servers na stronie Zarządzanie danymi — Serwery okna dialogowego Preferences.

Z pamięci podręcznej wyświetlane są tylko komponenty z aktualnie połączonych obszarów roboczych, takich jak obszar roboczy Altium 365, co oznacza, że niektóre zapisane w niej dane mogą być niedostępne. Tym zachowaniem można zarządzać na stronie Data Management – Servers okna dialogowego Preferences.

Lista doboru części

Aby edytować listę doboru części powiązaną z komponentem obszaru roboczego, wybierz opcję Operations » Create/Edit Part Choices z menu kontekstowego danego wpisu.

W wyświetlonym następnie oknie dialogowym Edit Part Choices użyj przycisku , aby otworzyć okno dialogowe Add Part Choices, które automatycznie wyszuka części producentów na podstawie parametru Name wybranego komponentu. Usuń zaznaczenie wstępnie zdefiniowanego kryterium wyszukiwania, aby ręcznie wyszukać alternatywy. Funkcjonalnie okno to jest modalną wersją panelu wyszukiwania części producentów.

Pozycjom na liście doboru części można nadawać oceny, wybierając odpowiednią liczbę gwiazdek. Lista zostanie automatycznie uporządkowana tak, aby najwyżej oceniona część producenta znajdowała się na górze.

Dobór części jest przenoszony wraz z komponentem wszędzie tam, gdzie wykorzystywane są jego dane, np. w projekcie schematu, dokumencie BOM, raporcie wyjściowym itd.

Po wybraniu komponentu w panelu Components jego listę doboru części można zobaczyć w sekcji Part Choices obszaru Details. Podstawowe informacje (stan magazynowy, mediana ceny jednostkowej i etap cyklu życia u producenta) dotyczące powiązanej wybranej części są również dostępne u góry obszaru Details. Powiązany kolorowy pasek wskazuje ogólną przydatność części do użycia na podstawie ustalonego etapu jej cyklu życia — na przykład komponent oznaczony jako Obsolete (czerwony) jest mniej zalecany niż komponent oznaczony jako Volume Production (zielony). Najedź kursorem na kolorowy pasek, aby zobaczyć etap cyklu życia określony przez producenta.

Jeśli korzystasz z funkcji integracji z SiliconExpert lub Z2Data, w górnej części panelu Details mogą być dostępne dodatkowe dane i elementy sterujące. Więcej informacji znajdziesz na stronach Pobieranie danych części z SiliconExpert i Pobieranie danych części z Z2Data.

Jeśli w Twoim obszarze roboczym włączona jest funkcja Kontrola rewizji wyborów części, wybranie opcji Operations » Create/Edit Part Choices spowoduje otwarcie Edytora komponentów (w trybie Edycja pojedynczego komponentu lub Edycja wielu komponentów) zamiast okna dialogowego Edit Part Choices. Wprowadź wymagane zmiany w wyborach części i zapisz komponenty z powrotem w obszarze roboczym jako ich kolejne rewizje.

Menu kontekstowe panelu Komponenty

Menu kontekstowe panelu, wyświetlane po kliknięciu prawym przyciskiem myszy, udostępnia następujące polecenia:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – umożliwia umieszczenie aktualnie wybranego komponentu lub modelu symulacyjnego w aktywnym dokumencie schematu albo aktualnie wybranej obudowy w aktywnym dokumencie PCB.

  • Find Similar Components – otwiera okno dialogowe Znajdź podobne komponenty, w którym można określić kryteria wyszukiwania komponentów podobnych do wybranego komponentu.

  • Navigate to [ComponentName] – otwiera wybrany komponent z obszaru roboczego w panelu Eksplorator, w którym można między innymi uzyskać dostęp do szczegółowych informacji o elementach, zarządzać ich rewizjami i ustawieniami cyklu życia oraz przeglądać miejsca ich użycia i szczegóły łańcucha dostaw.

  • Edit – kliknij, aby edytować wybrane komponenty z obszaru roboczego w Edytorze komponentów (w trybie Edycja pojedynczego komponentu lub Edycja wielu komponentów) albo wybrany model dziedzinowy (symbol, obudowę lub model symulacyjny) w odpowiednim edytorze. Jeśli bieżący typ komponentu różni się od typu określonego w aktualnie używanym szablonie, otworzy się okno dialogowe Change component type (). Użyj tego okna, aby zmienić typ wybranego komponentu.

  • Create – kliknij, aby otworzyć okno dialogowe Create new component i wybrać typ dodawanego komponentu.

  • Delete – kliknij, aby usunąć wybrane komponenty z połączonego obszaru roboczego.

  • Operations – udostępnia menu rozwijane z dodatkowymi funkcjami dla komponentów z obszaru roboczego, opisanymi poniżej.

    • Submit Request – zapewnia dostęp do aktywnych definicji procesów zgłaszania zapotrzebowania na części. Jeśli dla kategorii procesów Zgłoszenia zapotrzebowania na części nie ma dostępnych aktywnych definicji procesów, przycisk Submit Request będzie wyszarzony (niedostępny). Aby odświeżyć te dane, może być konieczne wylogowanie się z obszaru roboczego i ponowne zalogowanie lub ponowne uruchomienie Altium Designer.

    • Download – umożliwia pobranie wybranych komponentów w postaci skompilowanej Biblioteki zintegrowanej (*.IntLib) spakowanej do archiwum ZIP, wraz z jej źródłowym pakietem bibliotecznym (*.LibPkg) i plikami bibliotek. Zaznacz wiele pozycji komponentów, aby pobrać je w ramach jednej sesji.

    • Make a copy – kliknij, aby skopiować wybrany komponent. Edytor komponentów otworzy się w trybie Single Component Editor.

    • Change Component Type – otwiera okno dialogowe Choose component type (), w którym można zmienić typ bieżącego komponentu na jeden z pozostałych typów zdefiniowanych na liście. Okno dialogowe wyświetla informacje o szablonie komponentu powiązanym z danym typem oraz o folderze w połączonym obszarze roboczym, w którym znajdują się lub mogą być zapisywane komponenty tego typu. Kliknij przycisk , aby zarządzać listą dostępnych typów komponentów na stronie Zarządzanie danymi – Typy komponentów w oknie dialogowym Preferences.

    • Change State – umożliwia zmianę stanu rewizji wybranych komponentów. Po użyciu tego polecenia otwiera się okno dialogowe Zbiorcza zmiana stanu, w którym można zmienić stan rewizji komponentów.

    • Create/Edit Part Choices – otwiera okno dialogowe Edit Part Choices, w którym można utworzyć lub edytować listę wyborów części powiązaną z komponentem z obszaru roboczego.

      Jeśli w Twoim obszarze roboczym włączona jest funkcja Kontrola rewizji wyborów części, wybranie tego polecenia spowoduje otwarcie Edytora komponentów w trybie Edycja pojedynczego komponentu lub Edycja wielu komponentów.
    • Full Item History – otwiera szczegółowy widok aktualnie wybranego komponentu jako nową kartę w Altium Designer. Widok elementu zawiera bardzo szczegółową historię rewizji i cyklu życia konkretnego elementu, a także pokazuje wszystkie jego składowe. Widok zawiera również oś czasu. Użyj osi czasu, aby sprawdzić dokładną datę i godzinę każdej zmiany na poziomie rewizji lub stanu cyklu życia danego elementu oraz ustalić, kto jej dokonał.

  • Refresh – kliknij, aby szybko odświeżyć panel. Bieżące zaznaczenie komponentów zostanie zachowane.

Funkcja porównywania komponentów

Funkcja Compare umożliwia porównanie parametrów dwóch wybranych komponentów (części). Aby z niej skorzystać, zaznacz dwa komponenty w obszarze tabeli przy włączonej (niebieskiej) ikonie . Obszar Selected Component Details otworzy się po prawej stronie tabeli. Górny obszar (obszar 1 na poniższej ilustracji) wyświetla obok siebie obrazy, nazwy, opisy i ceny wybranych komponentów. Kliknij przycisk Datasheet, aby otworzyć kartę katalogową producenta dla danego komponentu (jeśli jest dostępna). Kliknij przycisk Place, aby umieścić komponent w obszarze projektowym. Komponent pojawi się jako element podążający za kursorem w obszarze projektowym; kliknij, aby umieścić go w żądanym miejscu. Możesz kontynuować umieszczanie kolejnych komponentów albo kliknąć prawym przyciskiem myszy lub nacisnąć Esc, aby wyjść z trybu umieszczania i wrócić do panelu Components.

Dolny obszar (obszar 2 na poniższej ilustracji) wyświetla obok siebie parametry komponentów, a różnice są wyróżnione czerwonym tekstem, co ułatwia porównanie.

Funkcja Compare jest dostępna również wtedy, gdy panel Components działa w trybie kompaktowym, choć jej działanie jest nieco inne. Aby z niej skorzystać, zaznacz dwa komponenty w obszarze tabeli. Obszar Selected Component Details otworzy się poniżej tabeli. Górny obszar wyświetla nazwy, ceny oraz parametry komponentów, a różnice są wyróżnione czerwonym tekstem, co ułatwia porównanie. Dolny obszar wyświetla obok siebie Symbols i Models komponentów.

Funkcja Compare i jej możliwości są również dostępne w panelu Manufacturer Part Search.

Edycja symboli i footprintów komponentów

Symbol i footprint danego komponentu można ukryć w sekcji Models obszaru Details, do którego można uzyskać dostęp, klikając Info button w prawym górnym rogu. Po ukryciu symbol i footprint zostaną zastąpione klikalnymi łączami, które przywracają ich pierwotny widok. Dostępna jest również możliwość skalowania wyświetlanych modeli. Zarówno w przypadku symboli, jak i footprintów kliknij i przeciągnij dolną krawędź obszaru modelu, aby zmienić rozmiar obrazu.

Możliwość ukrywania i skalowania widoków modeli jest również dostępna w obszarze Details panelu Manufacturer Part Search.

W przypadku pliku biblioteki schematów (*.SchLib) przeglądanego w panelu Components symbol i footprint wybranego komponentu można edytować za pomocą przycisku w prawym dolnym rogu podglądu modelu.

Możliwość edycji footprintu jest dostępna po otwarciu Components, pod warunkiem że istnieją już prawidłowe i powiązane footprinty.

Okna dialogowe wyboru komponentów

Wyszukiwarka i widok używane w panelu Components są również stosowane w innych aplikacjach Altium Designer, w których dokonuje się wyboru komponentu. Funkcja wyszukiwania komponentów jest dostępna w tych (modalnych) oknach dialogowych wraz z przyciskiem potwierdzenia OK i niewielkimi różnicami w dostępnych poleceniach. Okno to nosi zazwyczaj nazwę Component Search.

Dostęp do komponentów ogólnych i ich umieszczanie

Ta funkcja jest w fazie otwartej bety i jest dostępna po włączeniu opcji ComponentSearch.GenericComponents w oknie dialogowym Ustawienia zaawansowane.

Aby przyspieszyć tworzenie projektu na jego wczesnych etapach, udostępniono koncepcję standardowych, podstawowych Generic Components. Komponenty ogólne można szybko umieszczać w projekcie bez konieczności wyszukiwania i wybierania konkretnej części producenta z dostępnych źródeł komponentów. Komponenty ogólne pełnią funkcję elementów zastępczych, które na późniejszym etapie projektowania można łatwo zastąpić odpowiednim komponentem – można je również traktować jako komponenty wirtualne lub parametryczne.

Więcej informacji o tworzeniu komponentów ogólnych można znaleźć na stronie Tworzenie komponentów ogólnych.

Gdy Altium Designer jest połączony z przestrzenią roboczą, dostępne komponenty ogólne można znaleźć w panelu, w którym są wyświetlane po wybraniu opcji All w sekcji Categories – lub z górnego menu rozwijanego, gdy panel jest w trybie kompaktowym. Kliknij przycisk na kafelku komponentu ogólnego, aby dołączyć komponent do kursora i umieścić go w aktywnym dokumencie schematu. Po umieszczeniu komponentu na schemacie elementy podstawowe symbolu, takie jak piny, linie i obramowanie – czyli w praktyce jego zarys – są wyświetlane na czerwono, aby wskazać użycie komponentu ogólnego. Wybranie samego kafelka w panelu Components spowoduje otwarcie w panelu kategorii danego typu komponentu.

Umieszczanie komponentu ogólnego z panelu Components
Umieszczanie komponentu ogólnego z panelu Components

Ponieważ komponentów ogólnych nie wolno używać w końcowym projekcie, ich umieszczenie na schemacie powoduje naruszenie reguł ERC – Komponent ogólny. Poziom tego naruszenia – domyślnie Fatal Error – jest określany w sekcji Naruszenia związane z komponentami w ustawieniach raportowania błędów w oknie dialogowym Project Options (Project » Project Options).

Wybierz umieszczony komponent ogólny, aby uzyskać dostęp do jego właściwości w panelu Właściwości, który udostępnia tylko ustawienia i parametry istotne dla tego typu komponentu. Dostępne parametry są określane przez powiązany szablon komponentu (Resistors w pokazanym przykładzie). Wartości parametrów można wprowadzać ręcznie lub wybierać z listy rozwijanej zawierającej wartości pochodzące ze wszystkich dostępnych komponentów danego typu.

Określanie parametrów komponentu ogólnego – wybieranie wartości parametrów z list rozwijanych.

Określanie parametrów komponentu ogólnego – wynik.

 

Obsługa komponentów zworek

Zworki, nazywane również mostkami drutowymi, pozwalają zastępować ścieżki komponentami zworek, co często jest niezbędne do pomyślnego zaprojektowania płytki jednostronnej. Altium Designer obsługuje komponenty zworek za pomocą specjalnego typu komponentu Jumper.

Chociaż można zacząć od umieszczenia footprintów zworek bezpośrednio na PCB, zalecany proces rozpoczyna się od schematu. Więcej informacji można znaleźć na stronie Praca z komponentami zworek.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents