Работа с дорожками и дугами
Краткий обзор
- Научитесь размещать, редактировать, перемещать и перетрассировать сегменты дорожек в редакторе печатных плат с помощью основных команд и сочетаний клавиш.
- Узнайте, как интерактивная трассировка учитывает цепи, слои, режимы формирования углов, способы разрешения конфликтов и применимые правила проектирования.
- Разберитесь, как определяется и изменяется ширина дорожек и как настройки и правила влияют на доступные значения ширины.
Работа с дорожками
Сегмент дорожки — это прямая линия заданной ширины. Дорожки используются для создания прямых линий в рабочей области проектирования печатной платы. На сигнальном слое дорожки формируют электрические соединения между контактными площадками компонентов, то есть трассировку. Дорожки, размещенные на неэлектрическом слое, называются линиями и используются как универсальные графические элементы для создания контуров компонентов, пояснений, границ запрещенных областей и т. д. Дорожки также используются в составных объектах проекта, таких как размеры и координаты.

Объекты дорожек используются для трассировки и построения графических линий общего назначения. На изображении выше показаны четыре размещенных сегмента дорожки и еще один сегмент в процессе размещения.
Хотя дорожки и линии фактически являются одним и тем же объектом, поведение программы при их размещении различается, поэтому для них предусмотрены разные команды. При запуске команды размещения дорожки, например Interactive Routing, программа отслеживает место щелчка и автоматически присваивает дорожке имя цепи существующего объекта (например, контактной площадки), расположенного в этом месте. Программа также отслеживает и соблюдает все применимые правила проектирования. При запуске команды размещения линии (Place » Line) такое отслеживание не выполняется.
Дорожки можно размещать как в редакторе печатных плат, так и в редакторе библиотек печатных плат. Независимо от используемой команды (трассировка/размещение дорожки или размещение линии), основной порядок размещения одинаков. После запуска команды курсор примет вид перекрестия, и вы перейдете в режим размещения дорожки. Размещение выполняется в следующей последовательности:
- Щелкните мышью или нажмите Enter, чтобы зафиксировать начальную точку первого сегмента дорожки. Если запущена команда размещения для трассировки и вы начинаете размещение щелчком по существующему объекту, дорожке будет присвоено имя цепи этого объекта. При трассировке ширина определяется применимым правилом проектирования Ширина трассировки; ее можно переопределить с помощью некоторых параметров интерактивной трассировки, которые подробнее описаны ниже.
- Переместите курсор, чтобы задать сегмент дорожки, затем щелкните мышью или нажмите Enter , чтобы зафиксировать конечную точку первого сегмента, которая также является начальной точкой следующего соединенного с ним сегмента.
- Продолжайте перемещать курсор, затем щелкать мышью или нажимать Enter , чтобы зафиксировать последовательность вершин, определяющих соединенные сегменты дорожки.
- Щелкните правой кнопкой мыши или нажмите Esc, чтобы завершить текущую последовательность соединенных сегментов дорожки.
Во время размещения также доступны следующие действия:
- Нажимайте клавишу * на цифровой клавиатуре для циклического переключения между доступными сигнальными слоями. Также можно использовать сочетание Shift+Ctrl+Wheel Roll для переключения между слоями трассировки: каждый шаг прокрутки колесика мыши переключает на следующий (или предыдущий) доступный сигнальный слой.
- Нажимайте клавиши + и - на цифровой клавиатуре для циклического переключения вперед и назад между всеми слоями, видимыми в текущем проекте.
При размещении сегментов дорожки доступны пять режимов построения углов, четыре из которых также имеют подрежимы направления угла. Во время размещения:
- Нажимайте Shift+Spacebar для циклического переключения между доступными режимами построения углов.
- Нажимайте Spacebar для переключения между двумя подрежимами направления угла.
- В любом из режимов построения углов с дугой удерживайте клавишу , или . для уменьшения или увеличения дуги. Дополнительно удерживайте клавишу Shift, чтобы ускорить изменение размера дуги.
- Нажмите сочетание клавиш 1, чтобы переключиться между размещением одного сегмента за щелчок (показано на первых пяти изображениях ниже) и двух сегментов за щелчок (показано на последнем изображении ниже). В первом режиме сегмент дорожки, отображаемый только контуром, называется сегментом предварительного просмотра.
- Нажмите клавишу Backspace, чтобы удалить последнюю вершину.



Нажимайте Shift+Spacebar для циклического переключения между пятью доступными режимами построения углов, Spacebar — для изменения направления угла, а сочетание клавиш 1 — для переключения между размещением одного и двух сегментов.
Графический способ редактирования позволяет выбрать размещенную дорожку непосредственно в рабочей области проектирования и изменить ее размер, форму или положение графически.
При выборе дорожки становятся доступны следующие маркеры редактирования:
- Перетащите A мышью, чтобы изменить положение конечных точек дорожки.
- Перетащите B мышью, чтобы изменить форму дорожки.
Редактор печатных плат включает развитые алгоритмы перемещения сегментов дорожек на плате, позволяющие сохранять структуру трассировки. Такое сдвигание сегментов дорожки можно выполнять интерактивно двумя способами: сначала щелкнуть по сегменту, чтобы выбрать его, а затем, когда появится специальный курсор, нажать и удерживать кнопку мыши для сдвигания сегмента; либо сразу нажать и удерживать кнопку мыши на сегменте дорожки и сдвинуть его. Поведение при сдвигании можно настроить с помощью параметров Dragging на странице PCB Editor - Interactive Routing диалогового окна Preferences. Эти параметры позволяют назначить дорожке действие перемещения, что удобно, если требуется свободно перемещать отдельный сегмент дорожки.

Поведение при сдвигании дорожек задается параметрами перетаскивания в общих настройках.
Если с помощью этих параметров назначено действие Move, сегмент дорожки можно поворачивать или зеркально отражать во время перемещения.
Интерактивная трассировка и применимые правила проектирования
При интерактивной трассировке программа по умолчанию обеспечивает размещение сегментов дорожки в соответствии с применимыми электрическими правилами и правилами трассировки. Это означает, что программа не позволит разместить новый сегмент дорожки с нарушением требований относительно существующего сегмента другой цепи; вместо этого она ограничит длину нового сегмента, чтобы соблюсти правила проектирования. Такое поведение интерактивной трассировки называется режимом Routing Conflict Resolution. По умолчанию используется режим Stop at First Obstacle (текущий режим отображается в строке состояния). Нажимайте Shift+R для циклического переключения между доступными режимами.
Термин applicable design rules означает все правила, которые распространяются на размещаемый объект. Система проверки правил проектирования позволяет точно задать, к каким объектам должно применяться каждое правило. Во время размещения система определяет правило с наивысшим приоритетом, применимое в текущей ситуации. При интерактивной трассировке применяются следующие правила:
- Электрический зазор
- Ширина трассировки
- Параметры переходных отверстий при трассировке
Анимация ниже демонстрирует процесс трассировки. Цепь GND трассируется в соответствии с заданным и применимым правилом проектирования «Ширина трассировки». Обратите внимание: когда курсор перемещается на переходное отверстие, относящееся к цепи +12V, длина трассы автоматически ограничивается, чтобы обеспечить соблюдение применимого правила проектирования Ограничение электрического зазора.

При интерактивной трассировке автоматически соблюдаются применимые правила ширины трассировки и зазоров.
Как определяется ширина трассировки
Если механизм проверки правил не отключен, программа всегда в первую очередь следит за тем, чтобы ширина трассировки находилась в диапазоне, допустимом согласно применимому правилу проектирования Routing Width. Обычно для цепи задают диапазон допустимых значений ширины, чтобы обеспечить гибкость при прокладке трассы и при этом соблюсти требования к допустимому току этой цепи. Для этого правило проектирования Routing Width содержит настройки Min, Preferred и Max в редакторе правил и ограничений печатной платы. Их можно настроить так, чтобы разрешить диапазон значений ширины, или задать одинаковые значения, чтобы требовать определенную ширину. Ширину также можно настроить на основе импеданса и задать отдельный диапазон для каждого сигнального слоя.

Для новой печатной платы правило проектирования Routing Width по умолчанию применяется ко всем цепям.
В вашем распоряжении есть несколько параметров, которые помогают выбрать наиболее подходящую ширину при начале трассировки. Они настраиваются на странице PCB Editor — Interactive Routing диалогового окна Preferences, как показано ниже.

Параметры Interactive Routing Width Sources определяют, какой размер используется при начале трассировки.
Обратите внимание: на изображении для Track Width Mode задано значение Rule Preferred. Это означает, что при начале трассировки с существующего объекта цепи, например контактной площадки, будет использоваться именно эта ширина. Однако если трассировка начинается с существующей дорожки, параметр Pickup Track Width From Existing Routes переопределяет Track Width Mode и задает новую ширину, равную ширине существующей дорожки.
Во время трассировки вы также можете нажать сочетание клавиш Shift+W, чтобы открыть диалоговое окно и выбрать другую ширину, либо нажать Tab, чтобы открыть Properties panel и ввести новое значение Width . Выбранное или введенное значение должно находиться между значениями Min и Max, заданными в применимом правиле. В противном случае оно автоматически ограничивается ближайшим из этих значений.
Сочетания клавиш для интерактивной трассировки
Во время трассировки доступен ряд сочетаний клавиш. Например, можно нажать Shift+R, чтобы переключаться между доступными режимами разрешения конфликтов, или Backspace, чтобы удалить последнюю размещенную вершину (угол). Чтобы вывести список сочетаний клавиш во время трассировки, нажмите Shift+F1. Появится меню доступных интерактивных сочетаний клавиш; выберите нужное сочетание клавиш или нажмите Esc, чтобы закрыть меню и воспользоваться соответствующей комбинацией клавиш.

Во время интерактивной трассировки нажмите Shift+F1, чтобы открыть меню доступных интерактивных сочетаний клавиш
Перемещение дорожки
Подменю Edit » Move и меню команд перемещения в Active Bar содержат ряд команд, позволяющих изменить положение или форму дорожки.
Повторная трассировка
Эта команда позволяет вручную перетрассировать существующую дорожку на плате. После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать дорожку. Наведите курсор на нужную дорожку, затем щелкните или нажмите Enter. Поведение этой функции зависит от того, включен ли параметр Preserve Angle When Dragging на странице PCB Editor - Interactive Routing диалогового окна Preferences:
- Preserve Angle Dragging enabled — дорожка будет разделена, и для сохранения ортогональных/диагональных соединений будет добавлен новый сегмент. Перемещайте курсор, чтобы сдвинуть этот сегмент в нужное положение, затем щелкните для его размещения. На этом этапе щелкните правой кнопкой мыши или нажмите Esc , иначе новый сегмент будет разделен с добавлением еще одного сегмента. Используйте сочетание клавиш Shift+R для переключения между режимами обработки препятствий при перетаскивании (Ignore Obstacles, Avoid Obstacles или Avoid Obstacles (Snap Grid)). Если включен один из режимов Avoid Obstacles, при перетаскивании будут соблюдаться правила, не позволяя переместить сегмент в положение, вызывающее нарушение.
- Preserve Angle Dragging disabled — оба конца сегмента дорожки будут закреплены, и вы сможете проложить между ними новые сегменты. Щелкните или нажмите Enter, чтобы разместить новый сегмент дорожки. Продолжайте размещать новые сегменты для повторной трассировки либо щелкните правой кнопкой мыши или нажмите Esc, чтобы остановиться.
Продолжайте перетрассировку других дорожек либо щелкните правой кнопкой мыши или нажмите Esc для выхода.
Разделение дорожки
Эта команда позволяет создать вершину (точку разделения) в сегменте дорожки. После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать дорожку. Наведите курсор на нужный сегмент дорожки в точке, где требуется вставить точку разделения, затем щелкните или нажмите Enter. Будет вставлена вершина, разделяющая исходный сегмент на два.
Переместите вершину в нужное положение, затем щелкните или нажмите Enter для размещения. Поведение присоединенных сегментов дорожки зависит от настройки параметра Preserve Angle When Dragging на странице PCB Editor - Interactive Routing диалогового окна Preferences:
- Preserve Angle When Dragging включен — углы относительно соседних сегментов дорожки сохраняются, что обеспечивает сохранение стиля трассировки.
- Preserve Angle When Dragging отключен — два отдельных сегмента дорожки будут растягиваться при перемещении, не сохраняя существующий стиль трассировки.
Продолжайте разделять другие сегменты дорожек либо щелкните правой кнопкой мыши или нажмите Esc для выхода.
Перетаскивание конца дорожки
Эта команда позволяет вручную изменить положение или перетащить конец проложенного сегмента дорожки. После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать объект. Наведите курсор на дорожку, затем щелкните или нажмите Enter. Курсор переместится к ближайшему концу сегмента дорожки, и этот конец будет прикреплен к курсору. Переместите конец дорожки в нужное положение, затем щелкните или нажмите Enter для размещения.
- Если конец выбранного сегмента дорожки является вершиной, к которой не подключены другие сегменты дорожек, переместите вершину в нужное положение.
- Если конец выбранного сегмента дорожки является вершиной, к которой подключены два сегмента дорожек, при перемещении вершины подключенные сегменты будут растягиваться.
- Если конец сегмента дорожки подключен к контактной площадке компонента, перемещение конца отсоединит его от площадки. После перемещения конца из него к площадке будет отображаться линия логической связи, если параметр Smart Track Ends включен на странице PCB Editor – General диалогового окна Preferences.
- Если конец сегмента дорожки подключен к свободной контактной площадке, площадка будет привязана к курсору для перемещения. Все дорожки, подключенные к площадке, будут соответственно растягиваться.
- Если конец сегмента дорожки подключен к переходному отверстию, переходное отверстие будет привязано к курсору для перемещения. Все дорожки, подключенные к переходному отверстию, будут соответственно растягиваться.
Продолжайте перетаскивать другие концы дорожек или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти.
Перемещение / изменение длины дорожек
Эта команда используется для перемещения конечных точек нескольких выбранных сегментов дорожек, фактически изменяя длину сегментов. После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать конечную точку дорожки. Чтобы переместить дорожки или изменить их длину:
- Наведите курсор на конечную точку одного из выбранных сегментов, затем щелкните или нажмите Enter.
- Перемещайте курсор; длина всех выбранных сегментов дорожек будет динамически изменяться с сохранением исходных расстояний и углов между ними. Другой конец каждого сегмента будет растягиваться, сохраняя существующее подключение или положение.
- Когда сегменты окажутся в нужном положении, щелкните или нажмите Enter , чтобы зафиксировать размещение и выйти из режима перемещения.
- Чтобы отменить операцию, щелкните правой кнопкой мыши или нажмите Esc.
При перемещении сегментов доступны следующие дополнительные действия:
- Нажимайте клавишу Tab , чтобы последовательно перемещать курсор между конечными точками всех выбранных сегментов дорожек.
- Удерживайте клавишу Alt при перемещении, чтобы ограничить перемещение определенным направлением, зависящим от первоначального направления движения. Возможны горизонтальное и вертикальное направления, а также направление под углом 45 градусов.
- Нажмите Spacebar дважды, чтобы быстро выровнять все конечные точки сегментов дорожек по горизонтали или вертикали. Снова дважды быстро нажмите Spacebar, чтобы вернуть прежние размеры.
Разрезание дорожек
Инструмент разрезания дорожек позволяет легко разделить один или несколько сегментов дорожек на две части и может разрезать дорожки на текущем сигнальном слое или на всех видимых сигнальных слоях. Чтобы открыть инструмент, выберите команду Edit » Slice Tracks в главном меню.
После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать начальную точку разреза. Кроме того, применяется фильтрация, при которой в рабочей области отображаются только дорожки. В зависимости от текущих настроек инструмента разрезания это будут либо все дорожки на всех видимых сигнальных слоях, либо только дорожки на текущем сигнальном слое. Чтобы разрезать одну или несколько дорожек:
- Установите курсор в нужное положение, затем щелкните или нажмите Enter, чтобы зафиксировать начальную точку разреза.
- Переместите курсор через точку дорожки или дорожек, где требуется выполнить разрез. Траектория инструмента отображается линией, а предполагаемые разрезы показаны визуально.
- Щелкните или нажмите Enter, чтобы зафиксировать конечную точку траектории инструмента.
- Продолжайте разрезать другие сегменты дорожек или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти из режима разрезания.
После выбора начальной точки разреза и во время перемещения «линии разреза» доступны следующие дополнительные действия:
- Нажимайте клавишу B, чтобы переключаться между разрезанием дорожек только на текущем сигнальном слое и на всех видимых сигнальных слоях.
- Нажмите Spacebar, чтобы переключить угол разрезания между шагом 45 градусов и произвольным углом.
- Нажимайте клавишу N, чтобы переключать положение лезвия инструмента: слева, справа или по центру.
- Нажмите клавишу /, чтобы выбрать все разрезанные дорожки.
- Нажмите клавишу «,», чтобы выбрать разрезанные дорожки слева от инструмента.
- Нажмите клавишу «.», чтобы выбрать разрезанные дорожки справа от инструмента.
- Нажмите клавишу M, чтобы снять выделение со всех разрезанных дорожек.
-
Нажмите клавишу Tab, чтобы открыть диалоговое окно Slicer Properties, в котором можно изменять свойства инструмента разрезания непосредственно во время работы.

Диалоговое окно Slicer Properties
Преобразование дорожек в трассу со скошенными углами
Скашивание углов трассировки 90 градусов — это метод уменьшения отражений, возникающих на углах трасс в СВЧ-диапазоне. Можно использовать дуги, но их радиус должен быть не менее чем в 3 раза больше ширины трассы. Альтернативой является скашивание, при котором срезается внешняя вершина угла. Поскольку объекты дорожек в Altium Designer имеют закругленные концы, их нельзя использовать для создания скошенного угла. Для создания скошенного угла выбранные сегменты дорожек заменяются объектами-областями.
Выберите все сегменты дорожек, углы которых необходимо скосить, затем выберите команду Tools » Convert » Convert Selected Tracks to Chamfered Path в главном меню. Откроется диалоговое окно Convert Tracks to Chamfered Path. Настройте в нем параметры скашивания и нажмите OK. В каждой выбранной паре сегментов дорожек с нежелательным углом 90 градусов угол будет скошен, а исходные сегменты каждой пары будут преобразованы в единый объект сплошной (медной) области.

У каждого прямоугольного изгиба выбранных дорожек будет выполнен скос на указанную величину.
Для настройки скоса используйте следующие параметры диалогового окна:
- Chamfer - величина срезаемой, или скашиваемой, части внешнего угла в процентах от исходной длины диагонали угла.
- Inside Chamfer - количество материала, добавляемого к внутреннему углу, в процентах от исходной длины диагонали угла.
How big should the Chamfer be?
Процент скоса — это доля срезаемой части диагонали между внутренним и внешним углами исходного изгиба без скоса.
Оптимальная величина скоса для широкого диапазона геометрий микрополосковых линий была определена экспериментально Дувиллем и Джеймсом. Они установили, что оптимальный процент скоса хорошо аппроксимируется выражением
При условии
и диэлектрической проницаемости подложки
.
Эта формула совершенно не зависит от
. Фактический диапазон параметров, для которого Дувилль и Джеймс приводят экспериментальные данные, составляет
и
. Они сообщают о КСВН менее 1,1 (то есть уровне отражения ниже −26 дБ) для любого процента скоса, отличающегося от рассчитанного по формуле не более чем на 4% (от исходного При минимальном значении
равном 0,25 процент скоса составляет 98,4%, так что полоска оказывается почти полностью перерезанной.
Свойства дорожки

Режим Track панели Properties.
Информация о цепи
В этом разделе представлена информация о цепи, к которой принадлежит дорожка, а также о дифференциальной паре и/или xSignal, если цепь входит в их состав. При наличии также отображается информация о классах. Кроме того, приводятся значения Delay, Length, Max Current и Resistance.
Подробнее об информации о цепи см. на странице Методы размещения и редактирования объектов печатной платы.
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки дорожки относительно текущего начала координат рабочего пространства проекта. Измените значение, чтобы изменить положение дорожки по оси X. Значение можно вводить в метрических или имперских единицах; при вводе значения в единицах, отличных от текущих единиц по умолчанию, укажите единицы измерения.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки дорожки относительно текущего начала координат. Измените значение, чтобы изменить положение дорожки по оси Y. Значение можно вводить в метрических или имперских единицах; при вводе значения в единицах, отличных от текущих единиц по умолчанию, укажите единицы измерения.
Свойства
- Component — это поле отображается в редакторе печатных плат только тогда, когда выбранная дорожка является частью компонента печатной платы, и содержит позиционное обозначение родительского компонента. Нажмите ссылку Component, чтобы открыть режим Component панели Properties для родительского компонента.
- Net — используется для выбора цепи дорожки. В раскрывающемся списке представлены все цепи активного проекта платы. Обратите внимание: если размещение объекта начинается в той же точке, где находится существующий объект, уже подключенный к цепи, свойству Net нового объекта автоматически присваивается эта цепь. Выберите No Net, чтобы указать, что дорожка не подключена ни к одной цепи. Свойство Net примитива используется средством проверки правил проектирования, чтобы определить, допустимо ли размещение объекта на печатной плате. Также можно нажать значок Assign Net и выбрать объект в рабочем пространстве проекта — цепь этого объекта будет назначена выбранным дорожкам.
- Layer — используйте раскрывающийся список, чтобы выбрать слой, на котором расположена дорожка.
- Width — отображает текущую ширину дорожки. Измените это поле, чтобы задать ширину дорожки в диапазоне от 0,001 до 10000 мил.
- Start (X/Y) — отображает текущие координаты X/Y начальной точки дорожки относительно текущего начала координат.
- End (X/Y) — отображает текущие координаты X/Y конечной точки дорожки относительно текущего начала координат.
-
Length — отображает текущую длину дорожки. Измените это поле, чтобы задать длину дорожки в диапазоне от 0,001 до 10000 мил.
Расширение маски паяльной пасты
- Rule/Manual – выберите нужный режим расширения маски паяльной пасты. Выберите Rule, чтобы расширение маски паяльной пасты для дорожки соответствовало значению, заданному в применимом правиле проектирования Paste Mask Expansion. Выберите Manual, чтобы переопределить применимое правило проектирования и задать значение расширения маски паяльной пасты для дорожки. Затем можно активировать поле и ввести нужное значение.
Расширение паяльной маски
- Rule/Manual – выберите нужный режим расширения паяльной маски. Выберите Rule, чтобы расширение паяльной маски для дорожки соответствовало значению, заданному в применимом правиле проектирования Solder Mask Expansion. Выберите Manual, чтобы переопределить применимое правило проектирования и задать значение расширения паяльной маски для дорожки. Затем можно активировать поле и ввести нужное значение.
Работа с дугами
Дуга — это примитивный объект проекта. По сути, это сегмент дорожки в форме дуги окружности, который можно разместить на любом слое. Дуги находят различные применения при проектировании печатных плат. Например, их можно использовать для обозначения контуров компонентов на слоях шелкографии или контура платы, краев вырезов и т. п. на механическом слое. Их также можно использовать для создания криволинейных участков при интерактивной трассировке. Дуги могут быть незамкнутыми или замкнутыми, образующими окружность (такой объект часто называют полной круговой дугой).

Две размещенные дуги: слева — полная круговая дуга, справа — дуга, выбранная для редактирования.
Дуги доступны для размещения как в редакторе печатных плат, так и в редакторе библиотек печатных плат. Доступны четыре режима размещения дуг: по центру, по краю, с произвольным углом и полная окружность. Порядок размещения дуги зависит от выбранного способа:
-
Place arc by center – этот способ позволяет разместить дугу, используя ее центр в качестве начальной точки.
После запуска команды курсор примет вид перекрестия, и вы перейдете в режим размещения дуги. Для размещения выполните следующие действия:
- Щелкните мышью или нажмите Enter, чтобы зафиксировать центр дуги.
- Переместите курсор, чтобы задать радиус дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать его.
- Переместите курсор, чтобы задать начальную точку дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать ее.
- Переместите курсор, чтобы изменить положение конечной точки дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать ее и завершить размещение дуги.
- Продолжайте размещать дуги или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти из режима размещения.
-
Place arc by edge – этот способ позволяет разместить дугу, используя ее край в качестве начальной точки. Угол дуги фиксирован и составляет 90°.
После запуска команды курсор примет вид перекрестия, и вы перейдете в режим размещения дуги. Для размещения выполните следующие действия:
- Щелкните мышью или нажмите Enter, чтобы зафиксировать начальную точку дуги.
- Переместите курсор, чтобы изменить положение конечной точки дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать ее и завершить размещение дуги.
- Продолжайте размещать дуги или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти из режима размещения.
-
Place arc by edge (any angle) – этот способ позволяет разместить дугу, используя ее край в качестве начальной точки. Угол дуги может быть произвольным.
После запуска команды курсор примет вид перекрестия, и вы перейдете в режим размещения дуги. Для размещения выполните следующие действия:
- Щелкните мышью или нажмите Enter, чтобы зафиксировать начальную точку дуги.
- Переместите курсор, чтобы задать радиус дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать ее центр.
- Переместите курсор, чтобы изменить положение конечной точки дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать ее и завершить размещение дуги.
- Продолжайте размещать дуги или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти из режима размещения.
-
Place full circle arc – этот способ позволяет разместить дугу с углом 360° (полную окружность).
После запуска команды курсор примет вид перекрестия, и вы перейдете в режим размещения дуги. Для размещения выполните следующие действия:
- Щелкните мышью или нажмите Enter, чтобы зафиксировать центр дуги.
- Переместите курсор, чтобы задать радиус дуги, затем щелкните мышью или нажмите Enter, чтобы зафиксировать его и завершить размещение дуги.
- Продолжайте размещать дуги или щелкните правой кнопкой мыши либо нажмите Esc, чтобы выйти из режима размещения.
Во время размещения можно выполнять следующие дополнительные действия:
- При любом способе размещения (кроме полной окружности) нажмите Spacebar перед заданием конечной точки дуги, чтобы построить дугу в противоположном направлении.
- Нажмите клавишу L, чтобы перенести дугу на другую сторону платы. Обратите внимание: это возможно только до фиксации начальной точки или центра дуги.
- Нажимайте клавиши + и - (на цифровой клавиатуре) или используйте сочетания клавиш Shift+Ctrl+Wheelroll, чтобы последовательно переключаться между всеми видимыми слоями проекта в прямом и обратном порядке и быстро менять слой размещения.
Графический способ редактирования позволяет выбрать размещенную дугу непосредственно в рабочей области и графически изменить ее размер, форму или положение.
При выборе дуги становятся доступны следующие маркеры редактирования:

Выбранная дуга
- Щелкните и перетащите A, чтобы изменить радиус.
- Щелкните и перетащите B, чтобы изменить положение конечных точек (начальный и конечный углы).
-
Щелкните в любом месте дуги вне маркеров редактирования и перетащите ее, чтобы изменить положение. Также можно щелкнуть центральную точку дуги и перетащить ее. Во время перетаскивания дугу можно поворачивать или зеркально отражать:
- Нажмите Spacebar, чтобы повернуть дугу против часовой стрелки, или Shift+Spacebar, чтобы повернуть её по часовой стрелке. Поворот выполняется в соответствии со значением Rotation Step, заданным на странице Редактор PCB — Общие диалогового окна Preferences.
- Нажмите клавишу X или Y, чтобы зеркально отразить дугу относительно оси X или Y.
Свойства дуги
Информация о цепи
В этой области отображается информация о цепи, к которой принадлежит дуга, а также о дифференциальной паре и/или xSignal, если цепь входит в их состав. При наличии отображается информация о классах. Также приводятся значения Delay, Length, Max Current и Resistance.
Подробнее об информации о цепях см. на странице Приёмы размещения и редактирования объектов PCB.
Расположение
-
(X/Y)
- X (первое поле) — в этом поле отображается текущая координата X центра дуги относительно текущего начала координат. Измените значение в поле, чтобы изменить положение дуги относительно текущего начала координат. Значение можно вводить в метрических или дюймовых единицах; если единицы вводимого значения отличаются от используемых по умолчанию, укажите их при вводе. Единицы по умолчанию (метрические или дюймовые) определяются настройкой Units в области Other панели Properties в режиме Board (доступен, когда в рабочей области не выбраны объекты) и используются, если единицы не указаны.
- Y (второе поле) — в этом поле отображается текущая координата Y центра дуги относительно текущего начала координат. Измените значение в поле, чтобы изменить положение дуги относительно текущего начала координат. Значение можно вводить в метрических или дюймовых единицах; если единицы вводимого значения отличаются от используемых по умолчанию, укажите их при вводе. Единицы по умолчанию (метрические или дюймовые) определяются настройкой Units в области Other панели Properties в режиме Board (доступен, когда в рабочей области не выбраны объекты) и используются, если единицы не указаны.
Свойства
- Component — это поле отображается в редакторе PCB только в том случае, если выбранная дуга является частью компонента PCB, и содержит позиционное обозначение родительского компонента PCB. Нажмите ссылку Component, чтобы открыть режим «Компонент» панели «Свойства» для родительского компонента.
- Net — используется для выбора цепи для дуги. В раскрывающемся списке перечислены все цепи активного проекта платы. Обратите внимание: если размещение объекта начинается в точке, где уже находится объект, подключённый к цепи, свойству Net нового объекта автоматически присваивается эта цепь. Выберите No Net, чтобы указать, что дуга не подключена ни к одной цепи. Свойство Net примитива используется средством проверки правил проектирования для определения допустимости размещения объекта PCB. Кроме того, можно нажать значок Assign Net , чтобы выбрать объект в рабочей области: цепь этого объекта будет назначена выбранной дуге или дугам.
- Layer — в этом поле отображается слой, которому в данный момент назначена дуга. Дуги можно назначать любому доступному слою. Чтобы изменить назначенный слой, нажмите поле и выберите слой в раскрывающемся списке.
- Width — в этом поле отображается ширина линии дуги. При необходимости введите другое значение ширины.
- Radius — в этом поле отображается радиус дуги, измеряемый от центральной точки до середины линии дуги. При необходимости введите другое значение радиуса.
- Start Angle — в этом поле отображается начальный угол дуги, отсчитываемый от оси X в первом квадранте (планиметрия). При необходимости введите другое значение начального угла.
- End Angle — в этом поле отображается конечный угол дуги. При необходимости введите другое значение конечного угла.
- Propagation Delay — в этом поле отображается время распространения сигнала по данному маршруту.
Расширение окна маски паяльной пасты
- Rule — выберите этот параметр, чтобы расширение окна маски паяльной пасты для дуги соответствовало значению, заданному в применимом правиле проектирования «Расширение окна маски паяльной пасты». При выборе этого параметра соответствующее значение расширения будет недоступно для редактирования.
- Manual — выберите этот параметр, чтобы переопределить применимое правило проектирования и задать значение расширения окна маски паяльной пасты для дуги в поле ниже.
Расширение окна паяльной маски
- Rule — установите флажок, чтобы расширение окна паяльной маски для дуги соответствовало значению, заданному в применимом правиле проектирования «Расширение окна паяльной маски». При выборе этого параметра соответствующее значение расширения будет недоступно для редактирования.
- Manual — установите флажок, чтобы переопределить применимое правило проектирования и задать значение расширения окна паяльной маски для дуги в поле ниже.
Создание контура вокруг выбранных объектов с помощью дорожек и дуг
Команду Tools » Outline Selected Objects из главного меню можно использовать для размещения контура из дорожек и дуг вокруг выбранных свободных примитивов в проекте. Эта функция особенно полезна, если требуется электрически изолировать критически важные цепи, подключив контур к земле. После запуска команды вокруг объектов будет создан контур из дорожек и/или дуг. Дорожки и дуги контура размещаются с шириной 8 мил, а свойству Net присваивается значение No Net.
При этом учитываются правила проектирования «Зазор», «Ширина» и «Короткое замыкание», поэтому нарушения зазоров будут отмечены средством проверки правил проектирования.
Работа с прямоугольниками
Прямоугольник можно разместить на любом слое. Прямоугольники разных размеров можно объединять для покрытия областей неправильной формы, а также сочетать с сегментами дорожек или дуг.
Прямоугольники также можно размещать на неэлектрических слоях. Например, разместите прямоугольник на слое Keep-Out, чтобы обозначить область, запрещённую для автоматической трассировки. Разместите прямоугольник на слое питания, паяльной маски или маски паяльной пасты, чтобы создать вырез на этом слое.

Размещённый прямоугольник
Прямоугольники можно размещать в редакторе PCB и редакторе библиотек PCB следующими способами:
- Редактор печатных плат — доступны следующие способы вызова:
- Выберите Place » Rectangle в главном меню.
- Нажмите кнопку Rectangle в раскрывающемся меню на Active Bar в верхней части рабочей области. (Нажмите и удерживайте кнопку Active Bar, чтобы получить доступ к другим связанным командам. После использования команды она станет первым пунктом в соответствующем разделе Active Bar.)
- Щёлкните правой кнопкой мыши в рабочей области, затем выберите Place » Rectangle в контекстном меню.
-
Редактор библиотек печатных плат — доступны следующие способы вызова:
- Выберите Place » Rectangle в главном меню.
- Нажмите кнопку Rectangle в раскрывающемся меню на Active Bar в верхней части рабочей области. (Нажмите и удерживайте кнопку Active Bar, чтобы получить доступ к другим связанным командам. После использования команды она станет первым пунктом в соответствующем разделе Active Bar.)
- Щёлкните правой кнопкой мыши в рабочей области, затем выберите Place » Rectangle в контекстном меню.
После запуска команды курсор примет вид перекрестия и включится режим размещения прямоугольника. Для размещения выполните следующие действия:
- Щёлкните мышью или нажмите Enter, чтобы зафиксировать первый угол прямоугольника.
- Переместите курсор, чтобы задать размер прямоугольника, затем щёлкните мышью или нажмите Enter, чтобы зафиксировать диагонально противоположный угол и завершить размещение прямоугольника.
- Продолжайте размещать прямоугольники либо щёлкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения.
Во время размещения доступны следующие дополнительные действия:
- Нажмите клавишу Tab, чтобы приостановить размещение и перейти в режим «Прямоугольник» панели Properties , где можно изменять свойства на лету. Чтобы возобновить размещение, нажмите кнопку паузы, отображаемую поверх рабочей области
- Нажимайте Пробел для переключения между режимами углов. Выберите Rectangle для прямых углов, Fillet для скруглённых углов или Chamfer для скошенных углов.
- Нажимайте клавиши + и - (на цифровой клавиатуре), чтобы последовательно переключаться между всеми видимыми слоями проекта в прямом и обратном направлении и быстро менять слой размещения.
- Нажмите и удерживайте клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от начального направления движения.
Графический способ редактирования позволяет выбрать размещённый прямоугольник непосредственно в рабочей области и изменить его размер, форму или положение графически.
При выборе прямоугольника доступны следующие маркеры редактирования.
Выбранный прямоугольник
- Перетаскивайте углы (A), чтобы одновременно изменять размер прямоугольника по вертикали и горизонтали.
- Перетаскивайте середины сторон (B), чтобы изменять размер прямоугольника отдельно по вертикали или горизонтали.
-
Щёлкните в любом месте прямоугольника вне маркеров редактирования и перетащите его в другое положение. Во время перетаскивания прямоугольник можно поворачивать или зеркально отражать:
- Нажмите Spacebar, чтобы повернуть прямоугольник против часовой стрелки, или Shift+Spacebar для поворота по часовой стрелке. Поворот выполняется в соответствии со значением Rotation Step, заданным на странице Редактор печатных плат — Общие диалогового окна Preferences.
- Нажмите клавишу X или Y, чтобы зеркально отразить прямоугольник относительно оси X или Y.
Свойства прямоугольника

Режим Rectangle панели Properties.
Положение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки прямоугольника относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение прямоугольника по оси X. Значение можно вводить в метрических или британских единицах; если единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки прямоугольника относительно текущего начала координат. Измените значение, чтобы изменить положение заливки по оси Y. Значение можно вводить в метрических или британских единицах; если единицы отличаются от текущих единиц по умолчанию, укажите их при вводе.
- Rotation — угол поворота прямоугольника (в градусах), отсчитываемый против часовой стрелки от нулевого положения (горизонталь 3 o'clock). Измените значение, чтобы повернуть прямоугольник. Минимальный шаг изменения угла составляет 0,001°.
Свойства
-
Corner Mode — выберите нужный тип углов прямоугольника в раскрывающемся списке:
- Rectangle — размещаемый прямоугольник будет иметь прямые углы.
- Fillet — размещаемый прямоугольник будет иметь скруглённые углы.
- Chamfer — размещаемый прямоугольник будет иметь скошенные углы.
- Track Width — показывает текущую ширину дорожки. Измените это поле, чтобы задать ширину дорожки в диапазоне от 0,001 mil до 10000 mil.
- Fillet/Chamfer Size — доступно только при выборе Fillet или Chamfer в раскрывающемся списке Corner Mode либо если во время размещения был выбран режим скругления или фаски.
- Layer — слой, которому в данный момент назначен прямоугольник. Прямоугольники можно назначать любому доступному слою. Чтобы выбрать другой слой, используйте раскрывающийся список.
- Width — показывает ширину выбранного прямоугольника (по оси X).
- Height — показывает высоту выбранного прямоугольника (по оси Y).
-
- нажмите этот значок, чтобы сохранить текущее соотношение сторон прямоугольника по осям X и Y.

