3D-MID Design
Auf einen Blick
- Verstehen Sie, was 3D-MID ist, wie dabei die LDS-Fertigung eingesetzt wird und wie es das 3D-Schaltungsdesign in Altium Designer ermöglicht.
- Erfahren Sie, wie Sie ein 3D-MID-Dokument erstellen, ein Substrat importieren oder ändern und mit unterstützten STEP- oder IGES-Dateien arbeiten.
- Machen Sie sich mit den Grundlagen des 3D-Editors vertraut, einschließlich Kamerasteuerung, Ansichtsoptionen, Farbkonfiguration und Ausrichtungswerkzeugen.
Unser 3D-MID-Tool ermöglicht erstmals echtes 3D-Schaltungsdesign in Altium Designer, sodass Sie elektrische und mechanische Funktionen in einem einzigen Bauteil kombinieren können.
Ein 3D-MID-Dokument wird genauso wie eine Standardleiterplatte in Ihr Altium Designer-Projekt integriert – seine Bauteile und Verbindungen werden durch Ihren Schaltplan vorgegeben, und es verwendet Standard-SMT-Footprints aus Ihrer gewohnten Bauteilbibliothek.
Was ist 3D-MID?
3D-MID steht für Three-Dimensional Mechatronic Integrated Devices (dreidimensionale mechatronische integrierte Bauteile).
Beim 3D-MID-Fertigungsverfahren wird das Schaltungsmuster mit einem Laser direkt in die Oberfläche eines 3D-Substrats eingraviert. Anschließend wird es durch ein standardmäßiges Metallisierungsverfahren zu leitfähigen Bahnen aufgebaut. Dieses als Laser-Direktstrukturierung (LDS) bezeichnete Verfahren ermöglicht es, die Schaltung in die Struktur des Endprodukts zu integrieren.
Das Entwerfen von Leiterbahnen auf der Oberfläche einer 3D-Struktur bringt besondere Herausforderungen mit sich. Die Bearbeitungsumgebung muss die Platzierung von Bauteilen und den Verbindungen zwischen ihnen unterstützen, die die jeweilige Schaltung definieren. Dieser Editor muss außerdem das 3D-Substrat importieren können, auf dem die elektronische Schaltung erstellt wird – es muss sich also um einen echten dreidimensionalen Editor für das Elektronikdesign handeln.
Der Entwickler muss die Bauteile auf jeder beliebigen Oberfläche des importierten 3D-Substrats positionieren können. Anschließend muss er die Leiterbahnen zwischen den Bauteilanschlüssen definieren können – ein Vorgang, der üblicherweise als Routen der Verbindungen bezeichnet wird. Auch diese Leiterbahnen müssen über die Oberfläche des Substrats verlaufen können, unabhängig von der jeweiligen Ausrichtung der Substratoberfläche an jedem Punkt entlang ihres Verlaufs.
Schließlich muss der Entwickler die Fertigungsdaten in dem Format erzeugen können, das für die Laser-Direktstrukturierung (LDS) erforderlich ist.
Das neue 3D-MID-Designtool stellt diese Funktionen erstmals in Altium Designer bereit.
Erstellen eines 3D-MID-Dokuments
Genau wie ein Standard-Leiterplattendokument (PcbDoc) kann ein 3D-MID-Dokument (PcbDoc3D) entweder innerhalb eines Projekts oder als freies Dokument erstellt werden.
-
Um ein neues 3D-MID-Dokument innerhalb eines Projekts zu erstellen, klicken Sie im Projects-Panel mit der rechten Maustaste auf den Projektnamen und wählen Sie dann Add New to Project » PCB3D.
-
Um ein 3D-MID-Dokument als freies Dokument zu erstellen, wählen Sie File » New » PCB3D in den Menüs.
-
Während der Erstellung wird ein Dialogfeld angezeigt, in dem Sie aufgefordert werden, eine Datei auszuwählen, die das Substrat des 3D-MID-Dokuments bilden soll. Die ausgewählte Datei muss im STEP- oder IGES-Format vorliegen. Der Vorteil des IGES-Formats besteht darin, dass es eingebettete Skizzen enthalten kann.
Nach der Auswahl wird die Substratdatei im 3D-MID-Bearbeitungsfenster angezeigt. Wenn Sie das Fenster zur Substratauswahl abbrechen, wird das Standardsubstrat angezeigt, wie unten dargestellt.
Ein standardmäßiges 3D-Substrat wird erstellt, wenn Sie kein eigenes öffnen.
Ändern des Substrats
Bei Bedarf können Sie das 3D-Substrat ändern, indem Sie den Befehl File » Change Substrate in den Hauptmenüs auswählen.
Wenn sich das Substratdesign geändert hat, kann es aktualisiert werden.
Umgang mit vorhandenen Objekten beim Ändern des Substrats
|
Wenn ein neues Substrat ausgewählt wird, vergleicht die Software dieses mit dem vorhandenen Substrat. Dazu vergleicht sie die Position jeder vorhandenen Oberfläche mit der Position dieser Oberfläche im neuen Substrat. Liegt die neue Oberfläche innerhalb eines festgelegten Schwellenabstands zu einer vorhandenen Oberfläche, wird sie als dieselbe Oberfläche an einer neuen Position betrachtet, und alle vorhandenen Layoutobjekte werden auf sie verschoben. Ist der Abstand größer, wird die neue Oberfläche als andere Oberfläche betrachtet, und die Layoutobjekte werden gelöscht. Der Schwellenwert wird durch die erweiterte Option |
Arbeiten im 3D-MID-Dokumenteditor
Die Kamerasteuerung funktioniert wie folgt:
- Zum Verschieben der Ansicht ziehen Sie mit gedrückter rechter Maustaste.
- Zum Zoomen verwenden Sie das Mausrad.
- Zum Drehen halten Sie die Umschalttaste gedrückt und ziehen mit gedrückter rechter Maustaste. Der Drehpunkt wird durch die Position des Mauszeigers beim Starten des Befehls festgelegt.
Ändern der Substratansicht
Unten links im Designbereich befindet sich eine rot-grün-blaue Achsenmarkierung, die als Ansichtsausrichtung Gizmo bezeichnet wird.
Klicken Sie im Gizmo auf eine farbige Ebene oder Achse, um die Ansicht des Substrats an dieser Ebene bzw. Achse auszurichten.
Das Gizmo
Mit dem Gizmo ändern Sie die Ausrichtung Ihrer Ansicht des Substrats. Jeder Achse des Arbeitsbereichs und der zugehörigen Ebene ist eine Farbe zugewiesen. Wenn Sie den Mauszeiger über ein farbiges Gizmo-Element bewegen, wird es vergrößert dargestellt und damit als aktiv gekennzeichnet. Wenn Sie auf dieses farbige Element klicken, wird die Ansicht so ausgerichtet, dass Sie down dieser Achse auf das Substrat blicken. Ein zweiter Klick kehrt die Ansicht um, sodass Sie entlang derselben Achse aus der entgegengesetzten Richtung blicken.
- Blue – Z-Achse, Blick auf die X-Y-Ebene.
- Red – X-Achse, Blick auf die Y-Z-Ebene.
- Green – Y-Achse, Blick auf die X-Z-Ebene.
Steuerung der 3D-Ansicht
Die Ansicht des Substrats kann auch über das Untermenü 3D View Control gesteuert werden.
- Verwenden Sie die obere Befehlsgruppe, um das Substrat entlang der angegebenen Achse zu betrachten.
- Verwenden Sie die untere Befehlsgruppe, um das Substrat in der gewählten Richtung zu Rotate oder zu Roll. Jeder dieser Befehle lässt sich auch über das in der folgenden Abbildung angegebene Tastenkürzel aufrufen. Bei Auswahl eines Rotate- oder Roll-Befehls wird außerdem die Zoomstufe angepasst, um das Substrat in der Bildschirmmitte zu zentrieren.
Ändern des Ansichtstyps
Sie können die Ansicht durch Umschalten des Befehls View » Switch Perspective/Orthographic view ändern. Die perspektivische Ansicht bietet eine realistischere 3D-Darstellung des 3D-MID. Die orthografische Ansicht entfernt perspektivische Verzerrungen und stellt sicher, dass parallele Strukturen auch parallel dargestellt werden.
Konfigurieren der Farben
Die Oberflächen- und Umrissfarbe des Substrats sowie die Farbe des aktuell ausgewählten Objekts und des Kupfers können im Panel View Configuration konfiguriert werden, wie unten gezeigt. Aktivieren Sie das Panel über die Schaltfläche Panels unten rechts in der Software.
|
Die Oberflächen- und Umrissfarbe des Substrats sowie die Farbe des aktuell ausgewählten Objekts können im Abschnitt System Colors des Panels konfiguriert werden. Die Farbe des Kupfers kann im Abschnitt Layers des Panels konfiguriert werden. Das Grafikfenster zeigt die neue Kupferfarbe erst an, nachdem die Sichtbarkeit der Bauteile mit den Tastenkürzeln 2 und 3 umgeschaltet wurde. |
Ausrichtungswerkzeuge
Es stehen zwei Werkzeuge zur Verfügung, die beim Positionieren von Elementen auf der Substratoberfläche helfen. Sie können eine Skizze aus MCAD importieren oder die Funktion zum Erzeugen eines Ausrichtungsrasters im 3D-MID-Editor verwenden. Sobald die Skizzenelemente angezeigt werden, können sie als Hilfe beim Platzieren von Bauteilen, Kupferleiterbahnen und Regionen dienen.
- Beim Ziehen eines Bauteils rastet der Mauszeiger in der Mitte des Footprints ein. Der Mauszeiger (und damit die Bauteilmitte) rastet anschließend an den Skizzenelementen ein.
- Wenn ein Bauteil ausgewählt ist, wird außerdem ein Drehgriff angezeigt. Klicken Sie auf diesen Griff und ziehen Sie daran, um das Bauteil zu drehen. Der Griff rastet an den Skizzenelementen ein. Erfahren Sie mehr über das interaktive Drehen von Bauteilen.
- Beim Routen rasten die Anfangs- und Endpunkte der Kupferleiterbahn an allen Schnittpunkten von Skizzenelementen ein. Befindet sich der Mauszeiger nicht in der Nähe eines Schnittpunkts, rastet er an den Skizzenlinien ein. Wird der Mauszeiger während des Routens entlang einer Skizzenlinie bewegt (auch entlang gekrümmter Linien), folgt die Leiterbahn dieser Linie.
- Die Eckpunkte und Kanten einer Region können ebenfalls am Raster oder an importierten Skizzen ausgerichtet werden.
- Die beiden nachfolgend beschriebenen Werkzeuge können unabhängig voneinander gleichzeitig auf demselben Substrat verwendet werden.
Skizzenimport
- Beim Entwerfen des Substrats in MCAD können 3D-Kurven auf der Oberfläche des Teils platziert und in die exportierte IGES-Datei aufgenommen werden.
- In Solidworks können Sie beispielsweise mit dem Befehl Project Curve eine 2D-Skizze auf einer 3D-Oberfläche platzieren.
- Diese „Kurven“ lassen sich anschließend mit der Option Export 3D Curve features in den IGES-Export aufnehmen.
- Wenn die IGES-Datei in Altium Designer importiert wird, um das Substrat für ein 3D-MID zu bilden, können diese Elemente durch Auswahl des Befehls View » Show Sketches angezeigt werden.
In MCAD definierte Skizzen werden rot dargestellt.
- Die Skizzenelemente können dann als Orientierungshilfe beim Platzieren von Bauteilen und Regionen sowie beim Routen verwendet werden.
Ausrichtungsraster
- Im 3D-MID-Dokument kann auf einer der drei Bezugsebenen ein Raster erzeugt werden. Verwenden Sie dazu den Abschnitt Alignment Grid des Panels Properties, während im 3D-Designbereich keine Objekte ausgewählt sind. Dieses Raster wird anschließend von der angegebenen Ebene auf die Oberflächen des Teils projiziert. Beachten Sie, dass dieses Raster unabhängig von Skizzen ist, die als Teil des Substrats importiert wurden.
-
Die Eigenschaften des Rasters können vom Benutzer festgelegt werden. Beachten Sie, dass der Substratursprung aus dem importierten STEP-/IGES-Modell übernommen wird.
- Enable Grid - Das Einrasten am Raster erfolgt nur, wenn das Raster sichtbar ist.
-
Plane Kind - die XY-, XZ- oder YZ-Ebene, von der aus das Ausrichtungsraster projiziert wird. Wird vom STEP/IGES-Modell übernommen, das zur Erstellung des Substrats importiert wurde.
Alternativ können Sie den Ebenentyp UV auswählen, der ein Raster auf Grundlage der Substratoberflächen erzeugt. Dadurch entstehen natürlichere Rasterlinien, die den Krümmungen des Substrats folgen (Bild anzeigen). Der Ebenentyp UV ermöglicht das Routing entlang „natürlicherer“ Linien auf der Oberfläche des 3D-Substrats. - Horizontal/Vertical Size - Rasterabstand.
- Horizontal/Vertical Offset - Rasterversatz relativ zum Substratursprung.
- Rotation - Drehwinkel des Rasters parallel zu dieser Ebene (gilt nur für die Ebenentypen XY, XZ und YZ).
Cursor-Einrastverhalten
Im 3D-MID-Dokumenteditor können Sie die Einrastpriorität überschreiben. Die Steuerelemente für die Einrastpriorität erreichen Sie über die Schaltfläche Objects for snapping auf der Active Bar.
Für das Einrasten des Cursors stehen zwei Ebenen zur Verfügung: Raster und Objekte. Wenn das Einrasten an Objekten aktiviert ist, hat es Vorrang vor dem Einrasten am Raster. So können Sie beispielsweise beim Routen zu oder von einer vorhandenen Leiterbahn am Raster statt an der Mittellinie dieser Leiterbahn einrasten, indem Sie das Einrasten an Grids aktivieren, das Einrasten an Track Lines jedoch deaktivieren (vorausgesetzt, das Raster selbst ist im Panel Properties aktiviert), wie im folgenden Video gezeigt.
Arbeiten mit Bauteilen
- Wenn das 3D-MID-Dokument Teil eines Projekts ist, können Bauteile mithilfe der Standardbefehle aus Schaltplanblättern damit synchronisiert werden: Design » Update PCB, wenn Sie im Schaltplaneditor arbeiten, bzw. Design » Import Changes from xxx.PrjPcb, wenn Sie im 3D-MID-Dokumenteditor arbeiten. Dabei werden auch die Netzzuweisungen der Schaltplan-Pins auf die Pads der 3D-MID-Bauteile übertragen. Beachten Sie, dass bei diesem Vorgang standardmäßige Designregeln erstellt werden. Weitere Informationen finden Sie im Abschnitt Standard-Projektoptionen und Designregeln auf dieser Seite.
- Nach der Synchronisierung mit dem 3D-MID-Dokument erscheinen die Bauteile zunächst frei im 3D-Raum neben dem Substratkörper und können einzeln auf die Substratoberfläche gezogen werden. Standardmäßig hängt die anfängliche Ausrichtung eines Bauteils auf der Substratoberfläche davon ab, welchen Weg Sie beim Ziehen mit der Maus nehmen.
|
Nach der Synchronisierung der Bauteile und Netze aus dem Schaltplan erscheinen die Bauteile neben dem Substrat und schweben auf dessen X-Y-Ebene. Beachten Sie, dass Pad 1 abgerundete Ecken hat. Die Ausrichtung des verschobenen Bauteils nach der Annäherung an das Substrat von vorne. Die Ausrichtung des verschobenen Bauteils nach der Annäherung an das Substrat von der Seite. |
-
Alternativ können Bauteile direkt aus dem Panel Components auf das Substrat gezogen werden. Wenn Sie ein Bauteil aus dem Panel Components platzieren, erhält es einen Standard-Bezeichner, und alle Pads des Bauteils werden als
No Netbezeichnet. - Wenn Sie ein Bauteil ziehen, rastet der Mauszeiger (durch ein grünes Kreuz gekennzeichnet) am Mittelpunkt des Footprints ein. Der Cursor (und der daran angehängte Footprint-Mittelpunkt) rastet anschließend an einem sichtbaren Ausrichtungsraster ein. Weitere Informationen finden Sie unter Ausrichtungsraster und Ausrichtungswerkzeuge.
- Bauteile können auch bei ausgeblendeten 3D-Körpern gezogen werden. Um das Bauteil auszuwählen, klicken Sie auf eines seiner Pads und halten Sie die Maustaste gedrückt. Sobald die Maus bewegt wird, rastet der Bauteilmittelpunkt am Cursor ein.
-
Wenn Sie ein Bauteil in einem 3D-MID-Dokument ziehen und die Bauteilkörper ausgeblendet sind (View » Component Bodies » Hide; Tastenkürzel: 2), wird eine vereinfachte Darstellung (grüne Pyramiden) angezeigt, sofern die Pin-Anzahl den in der erweiterten Einstellung
3DLayout.ComponentDrag.DrawShapesPinsLimitfestgelegten Grenzwert überschreitet (standardmäßig 15). Dieses Verhalten dient der Leistungssteigerung. Der Einstellungswert kann an die Leistungsfähigkeit Ihres PCs angepasst werden. - Während ein Bauteil gezogen wird, dreht Spacebar es in Schritten, die durch den Winkel Rotation Step auf der Seite PCB Editor - General des Dialogs Preferences festgelegt sind (Bild anzeigen). Der standardmäßige Drehschritt beträgt 90 Grad.
-
Das Ausrichtungsverhalten eines Bauteils beim Ziehen über verschiedene Oberflächen des Substrats wird durch die erweiterte Einstellung
3DLayout.ComponentDrag.KeepOrientationgesteuert.
|
Wenn der Wert Wenn der Wert der erweiterten Einstellung |
- Die Ausrichtung eines Bauteils kann mithilfe des Drehgriffs festgelegt werden. Gehen Sie dazu wie folgt vor:
|
Klicken Sie einmal auf das Bauteil, um es auszuwählen. Um das Bauteil wird ein Rahmen angezeigt, und der Griff wird sichtbar. Damit können Sie die Ausrichtung des Bauteils interaktiv festlegen. Klicken Sie auf diesen Griff, halten Sie die Maustaste gedrückt und ziehen Sie ihn an die gewünschte Position. Der Griff rastet am Ausrichtungsraster ein. |
- Sie können auch mehrere Bauteile gleichzeitig ziehen. Wählen Sie mehrere Bauteile aus (mit dem Tastenkürzel Shift+Click oder anderen Auswahlmethoden) und wenden Sie dann Click, Hold&Drag auf die Auswahl an, um alle ausgewählten Bauteile gleichzeitig zu verschieben. Wie beim Ziehen eines einzelnen Bauteils wird die Bewegung durch die aktuellen Einrastoptionen eingeschränkt.
- Pads, Füllflächen und ausgefüllte Regionen innerhalb eines Bauteil-Footprints sind Kupferobjekte, deren Platzierung im 3D-MID-Dokument unterstützt wird. Dadurch können Sie Bauteile mit komplex geformten Footprints auf Ihren Substraten platzieren, einschließlich HF-Strukturen (z. B. Antennen).
- Wenn ein Bauteil über die Substratoberfläche gezogen wird, entsteht die Form seiner Pads, indem ihre Form aus der Ebene des 2D-Footprints auf die Substratoberfläche übertragen und an diese angepasst wird. Ist diese Oberfläche nicht eben, wird die resultierende Padform verzerrt. Das tolerierbare Ausmaß der Verzerrung ist begrenzt. Sobald dieser Grenzwert erreicht ist, wird das Pad nicht erstellt.
- Um auf die Eigenschaften eines Bauteils zuzugreifen, klicken Sie mit der linken Maustaste auf den Bauteilkörper. Um das Bauteil wird ein Drahtgitterrahmen angezeigt. Anschließend können Sie über das Panel Properties auf seine Eigenschaften zugreifen.
- Sobald ein Bauteil ausgewählt wurde, können Sie durch einen weiteren Linksklick direkt auf ein Pad dieses auswählen. Die Eigenschaften des Pads können anschließend über das Panel Properties bearbeitet werden.
- Wenn die Eigenschaften des Pads nicht bearbeitet werden können, ist die globale Option Protect Locked Primitives in Component auf der Seite PCB Editor - General des Dialogs Preferences aktiviert (Bild anzeigen). Um diese Einstellung lokal außer Kraft zu setzen und das Pad dieses Bauteils zu bearbeiten, wählen Sie das Bauteil statt des Pads aus (der Drahtmodellrahmen wird angezeigt) und klicken Sie dann auf die Sperrschaltfläche Primitives (Bild anzeigen), um die Grundelemente dieses Bauteils zu entsperren. Denken Sie daran, die Grundelemente des Bauteils nach der Bearbeitung der Pad-Eigenschaften wieder zu sperren.
Routing
Beim Routing werden die Kupferverbindungen zwischen den miteinander verbundenen Bauteilpins festgelegt. Sie routen das Design, indem Sie jede Netzverbindungslinie durch Leiterbahnobjekte auf einer Kupferlage ersetzen.
Anzeigen der Verbindungslinien
Zur Unterstützung beim Routing können die Netzverbindungslinien (View » Connections » Show All) angezeigt werden. Verbindungslinien werden zwischen nicht verbundenen Leiterbahnen/Pads desselben Netzes angezeigt und spiegeln die in den Schaltplandokumenten des Projekts definierte Konnektivität wider. Standardmäßig berechnet der Algorithmus für jedes Netz eine Anordnung der Linien, die deren Gesamtlänge minimiert.
Farbcodierung der Verbindungslinien
- Die Verbindungslinien eines Netzes können wie unten gezeigt farbcodiert werden:
|
Um einem bestimmten Netz eine Farbe zuzuweisen, wählen Sie zunächst ... ein Pad aus, das zu diesem Netz gehört (klicken Sie einmal, um das Bauteil auszuwählen, warten Sie kurz und klicken Sie dann ein zweites Mal, um das Pad auszuwählen), und klicken Sie anschließend auf den Hyperlink Netz im Panel Properties. Klicken Sie auf das Farbsymbol und wählen Sie in der angezeigten Palette eine neue Farbe für die Verbindungslinien dieses Netzes aus. Alternativ können Sie im Panel PCB im Modus Nets das Netz in der Liste suchen und mit der rechten Maustaste auf seinen Namen klicken, um das Kontextmenü anzuzeigen. Wählen Sie den Befehl Change Net Color, um den Dialog Choose Color zu öffnen, und wählen Sie eine neue Farbe aus. |
Netzfarbüberschreibung – Anzeigen der Netzfarbe bei gerouteten Netzen
Sie können die Netzfarbe auch für geroutete Netze verwenden, indem Sie die Funktion zur Netzfarbüberschreibung aktivieren. Mit dieser Funktion können Sie die Hervorhebung gerouteter Netze in Ihren 3D-MID-Dokumenten mit einem eigenen, übergeordneten Farbschema steuern. Statt ein Netzobjekt ausschließlich in der Lagenfarbe darzustellen, können Sie ihm eine bestimmte alternative Farbe zuweisen.
So verwenden Sie die Funktion zur Netzfarbüberschreibung:
- Apply the required color to the net(s) – Verwenden Sie die im obigen Abschnitt Farbcodierung der Verbindungslinien beschriebenen Verfahren.
-
Enable Color Override for the net(s) – Die Farbüberschreibung wird für jedes Netz über das Kontrollkästchen neben seinem Namen im Panel PCB (im Modus Nets) aktiviert, wie für das Netz
NetR2_1in der folgenden Abbildung gezeigt. Die Kontrollkästchen mehrerer ausgewählter Netze können über die Befehle Right-click » Display Override » Selected On/Off umgeschaltet werden.
Vorbereitung des Routings
- Sobald eine Verbindung zwischen zwei Pads desselben Netzes geroutet ist, verschwindet die zugehörige Verbindungslinie. Dadurch lassen sich die Verbindungslinien als visuelle Kontrolle verwenden, um sicherzustellen, dass alle Netze vollständig geroutet sind. Bei einem vollständig gerouteten Design sind keine Verbindungslinien mehr vorhanden (außer zwischen zwei Via-Pads). Bei Bedarf können die Verbindungslinien mit dem Befehl View » Connections » Hide All ausgeblendet werden.
- Es wird nur manuelles interaktives Routing unterstützt (automatisches Routing wird derzeit nicht unterstützt).
-
Es stehen zwei interaktive Routing-Modi zur Verfügung:
- Ignore Obstacles – Eine Verbindung mit Kupfer eines anderen Netzes muss manuell vermieden werden. Kurzschlüsse sind möglich. In diesem Modus arbeitet die Software schnell und reaktionsschnell.
-
Walkaround Obstacles – Der Routing-Algorithmus verhindert Kurzschlüsse, indem er einen Mindestabstand zwischen der Leiterbahn und Kupferobjekten eines anderen Netzes einhält. Dieser Vorgang ist rechenintensiv, sodass es eine Verzögerung geben kann, bevor die Software die Kollision erkennt und die Leiterbahn um das Hindernis herumführt. Der Algorithmus erfordert, dass sich der Cursor außerhalb des Objekts befindet, das zum anderen Netz gehört.
Festlegen des Objektabstands und der Leiterbahnbreite
Der 3D-MID-Editor verwendet Designregeln, um die Leiterbahnbreite und den zulässigen Mindestabstand zwischen Objekten unterschiedlicher Netze festzulegen.
- Um die Anforderungen an den Mindestabstand und die Leiterbahnbreite festzulegen, öffnen Sie PCB Rules and Constraints Editor (Design » Rules).
Konfigurieren der Abstandsregel
- Erweitern Sie die Baumstruktur auf der linken Seite des Designregel-Dialogs und wählen Sie die Standardregel Clearance aus.
- Nur die drei in der folgenden Abbildung hervorgehobenen Werte beeinflussen den Algorithmus:
- Beachten Sie, dass TH-Pads (Durchkontaktierungspads) im 3D-MID-Dokument als solche erkannt werden, die Bohrung selbst jedoch nicht berücksichtigt wird.
Konfigurieren der Leiterbahnbreite
- Die Breite neu platzierter Leiterbahnen wird durch die zutreffende Routing-Designregel Width festgelegt. Der 3D-Router unterstützt nur den Wert Preferred Width für die oberste Lage (Top Layer). Dieser kann im übergeordneten Feld Preferred Width (in der folgenden Abbildung hervorgehoben) oder im lagenspezifischen Breitenfeld konfiguriert werden.
Standardmäßige Projektoptionen und Designregeln
Jedes neue Projekt enthält Standardeinstellungen für die Regelerstellung, und jedes neue PcbDoc3D-Dokument enthält Standardregeln. Beispielsweise führen die standardmäßigen Projekteinstellungen dazu, dass eine oder mehrere Designregeln vom Typ Placement erstellt werden, wenn das Design zwischen dem Schaltplaneditor und dem PCB3D-Editor synchronisiert wird. Diese standardmäßige Platzierungsregel hat zur Folge, dass die Online-DRC erkennt, dass sich die Bauteile nicht innerhalb des Raums befinden, und sie daher (grün) als Regelverletzungen hervorhebt.
- Die standardmäßige Platzierungsregel kann gelöscht werden. Klicken Sie dazu mit der rechten Maustaste auf die Regel im PCB Rules and Constraints Editor, um das Kontextmenü aufzurufen, und löschen Sie sie wie unten gezeigt. Erfahren Sie mehr über Designregeln.
- Um zu verhindern, dass die Software beim Synchronisieren eines Designs zwischen dem Schaltplan- und dem 3DPCB-Editor für jedes Schaltplanblatt im Projekt eine Platzierungsregel erstellt, öffnen Sie den Dialog Options for PCB Project (Project » Project Options), wechseln Sie zur Registerkarte Class Generation und deaktivieren Sie die Option Generate Rooms, wie unten gezeigt. Erfahren Sie mehr über die Projektoptionen.
Routing mit Ausrichtungsraster und Skizzen
Da Sie Verbindungen über die unregelmäßigen Oberflächen von 3D-Objekten verlegen, ist das herkömmliche XY-Raster aus dem Leiterplattendesign hier nicht sinnvoll. Stattdessen unterstützt der 3D-MID-Editor zwei Arten von Skizzenelementen: das Ausrichtungsraster und importierte Skizzen.
-
Das Alignment Grid des 3D-MID-Editors wird im Panel Properties aktiviert und konfiguriert, wenn im Designbereich keine Objekte ausgewählt sind. Konfigurieren Sie die Eigenschaften unter „Configure the Alignment Grid“ passend zum erforderlichen Routing-Rastermaß. Dazu gehören:
- Plane Kind (die Ebene, von der aus das Ausrichtungsraster projiziert wird);
- Size (Rastermaß) und
- Rotation (Drehwinkel parallel zu dieser Ebene). Wenn sich der Mauszeiger beim Routing dem Ausrichtungsraster nähert, rastet er an der nächstgelegenen Rasterlinie ein.
- Wenn das Substrat aus einer IGES-Datei importiert wird, können auch alle in dieser IGES-Datei enthaltenen Skizzenelemente (Linien und Bögen) als Orientierung beim Verlegen von Leiterbahnen verwendet werden. Wird der Mauszeiger beim Routing auf einen Schnittpunkt von Skizzenlinien zubewegt, rastet er an diesem Schnittpunkt ein. Andernfalls rastet er an einer nahe gelegenen Skizzenlinie ein. Beachten Sie, dass die Skizzen nur dann zur Platzierung verwendet werden können, wenn sie sichtbar sind. Um ihre Sichtbarkeit umzuschalten, wählen Sie View » Show Sketches (beachten Sie, dass dieser Befehl nicht für die Anzeige des Alignment Grid gilt; diese wird im Panel Properties konfiguriert).
Aktivieren Sie das Ausrichtungsraster, damit Leiterbahnen am Raster einrasten.
Eine Verbindung routen
Um mit dem Routing zu beginnen, wählen Sie den Menübefehl Route » Interactive Routing, klicken Sie auf die unten gezeigte Schaltfläche im Active Bar oder drücken Sie die Tastenkombination Ctrl+W.
Beim Routing werden Kupferleiterbahnen zwischen den miteinander verbundenen Bauteilpins definiert.
Tipps zum Routing
-
Starten Sie den Befehl Interactive Routing. Der Cursor wird zu einem grünen Kreuz, um anzuzeigen, dass der interaktive Routing-Befehl aktiv ist. Beachten Sie, dass beim ersten Aufruf des Befehls in einer Bearbeitungssitzung eine kurze Verzögerung zwischen der Auswahl des Befehls und dem Beginn des Routings auftreten kann.
-
Klicken Sie auf eine beliebige Stelle des gewünschten Pads (oder einer vorhandenen Leiterbahn), um mit dem Routing zu beginnen. Ein Leiterbahnsegment erscheint. Sein festes Ende wird automatisch am Mittelpunkt des Pads (oder am Ende der vorhandenen Leiterbahn) befestigt, während das andere Ende dem Cursor folgt. Die mit jedem Mausklick platzierten Leiterbahnsegmente werden automatisch dem Netz dieses Pads bzw. der vorhandenen Leiterbahn zugewiesen.
-
Am beweglichen Ende der Leiterbahn ist eine grüne interaktive Verbindungslinie angehängt. Die Software verbindet das andere Ende dieser Verbindungslinie automatisch mit dem nächstgelegenen Objekt desselben Netzes. Sie können die Verbindung zu jedem beliebigen Objekt in diesem Netz routen und müssen dabei nicht dem Verlauf der Verbindungslinien folgen. Die Software aktualisiert die Verbindungslinien automatisch, sobald Sie den interaktiven Routing-Modus verlassen. Das folgende Bild zeigt die blass dargestellte ursprüngliche Verbindungslinie und die grüne interaktive Verbindungslinie, während sich die Leiterbahn dem Zielpad nähert. Bewegen Sie den Cursor über das Bild, um die fertiggestellte Verbindung anzuzeigen.
-
Klicken Sie mit der linken Maustaste, um das Leiterbahnsegment zu platzieren und einen Fixpunkt im Leiterbahnverlauf festzulegen. Bewegen Sie anschließend den Cursor weiter und klicken Sie, um weitere Leiterbahnsegmente zu platzieren.
-
Sobald sich der Cursor beim Annähern an das Zielobjekt innerhalb dessen Kontur befindet, rastet er am Mittelpunkt des Pads oder an der Mittellinie des vorhandenen Leiterbahnsegments ein (bzw. am Leiterbahnendpunkt, falls dieser näher liegt).
-
Während Sie eine Verbindung routen, können Sie auf das Panel Properties zugreifen, das Raster aktivieren bzw. deaktivieren und bei Bedarf dessen Einstellungen anpassen. Dies wird im Video am Anfang dieses Abschnitts gezeigt.
-
Wenn das Routing dieser Verbindung abgeschlossen ist, right-click (oder drücken Sie Esc auf der Tastatur), um den interaktiven Routing-Modus zu verlassen. Beachten Sie, dass Sie dadurch den interaktiven Routing-Modus beenden. Um mit dem Routing fortzufahren, müssen Sie den Befehl erneut aufrufen.
-
Sie können eine Leiterbahn unvollständig lassen und später daran weiterarbeiten. Right-click mit der Maus, um das Routing zu beenden.
-
Sie können das Routing auch an einer beliebigen Stelle auf der Substratoberfläche beginnen. In diesem Fall erhält die Leiterbahn für Net die Zuweisung
No Net. Wenn Sie anschließend zu einem Pad routen, dem ein Netz zugewiesen ist, entsteht eine Abstandsverletzung. Daher empfiehlt es sich, das Routing an einem vorhandenen Netzobjekt zu beginnen. -
Bei Bedarf können Sie im Panel Properties die Netzzuweisung bereits platzierter Leiterbahnsegmente ändern.
-
Wenn Sie im Modus „Walkaround Obstacle“ routen, kann es beim Annähern an ein vorhandenes Objekt eines anderen Netzes zu einer Verzögerung kommen, bevor die Leiterbahnsegmente angezeigt werden. Beachten Sie, dass sich der Cursor außerhalb von Objekten anderer Netze befinden muss, damit der Walkaround-Algorithmus einen Leiterbahnverlauf berechnen kann. Auch zwischen einem Mausklick und dem Erscheinen einer Leiterbahn kann eine Verzögerung auftreten.
-
Wenn der interaktive Router scheinbar nicht mehr reagiert, bewegen Sie die Maus nicht weiter und warten Sie, bis die Software die erforderlichen Objektpositionen berechnet hat. Dies ist besonders wichtig beim Wechsel von einer Substratoberfläche zu einer anderen.
-
Sie können eine Leiterbahn durch Klicken und Ziehen bearbeiten.
- Klicken Sie auf eine Leiterbahn und ziehen Sie sie, um einen neuen Scheitelpunkt hinzuzufügen.
- Klicken Sie auf einen Scheitelpunkt und ziehen Sie ihn, um ihn zu verschieben.
-
Um die Breite eines bereits platzierten Leiterbahnsegments zu ändern, wählen Sie es aus und bearbeiten Sie die Einstellung Width im Panel Properties.
-
Um die Breite mehrerer Segmente zu ändern, halten Sie die Taste Shift gedrückt und klicken Sie auf die einzelnen Segmente, um sie auszuwählen. Die Breite aller ausgewählten Segmente kann anschließend im Panel Properties bearbeitet werden.
-
Um alle Leiterbahnsegmente, Regionen und Pads eines Netzes auszuwählen, wählen Sie ein Objekt aus und drücken Sie anschließend die Taste Tab.
-
Wählen Sie die Leiterbahnsegmente aus und drücken Sie die Taste Delete auf der Tastatur, um bereits platzierte Leiterbahnen zu entfernen.
-
Um sämtliche Leiterbahnen eines Netzes zu entfernen, öffnen Sie das Panel PCB, stellen Sie es auf den Modus Nets ein, aktivieren Sie das Kontrollkästchen Select und wählen Sie anschließend im Bereich Nets des Panels das gewünschte Netz (oder die gewünschten Netze) aus. Wenn das Panel das aktive Element der Software ist, klicken Sie einmal auf die Dokumentregisterkarte PcbDoc3D oberhalb des grafischen Designbereichs, um diesen zum aktiven Element der Software zu machen. Drücken Sie anschließend die Taste Delete. Ausgewählte Pads werden nicht gelöscht, da sie untergeordnete Objekte ihrer jeweiligen Bauteile sind und daher nur zusammen mit diesen Bauteilen gelöscht werden können.
Eine gefüllte Region platzieren
Das Platzieren einer massiven Region wird unterstützt. Mit dem Regionsobjekt lassen sich beliebige Kupferformen erstellen, die bei Bedarf über Kanten der Struktur hinweg verlaufen. Das Video zeigt, wie eine massive Region auf einer 3D-Struktur platziert wird.
Hinweise zum Platzieren einer massiven Region:
- Verwenden Sie die Tastenkombinationen 2 (Bauteile ausblenden) und 3 (Bauteile einblenden), um die Sichtbarkeit der Bauteile umzuschalten.
- Der Cursor rastet sowohl am Ausrichtungsraster als auch an einer mit dem Substrat importierten Skizze ein. Aktivieren und konfigurieren Sie Alignment Grid (Panel Properties) und/oder die Skizzen (View » Show Sketches).
- Klicken Sie auf die Schaltfläche Place Solid Region auf der Active Bar, um mit dem Platzieren einer massiven Region zu beginnen.
- Die Software erkennt die massive Form als die kleinere Fläche, die von den durch Ihre Mausklicks definierten Eckpunkten umschlossen wird. Wenn sich die von Ihnen definierte Fläche über mehrere Oberflächen des 3D-Substrats erstreckt, kann die Software möglicherweise nicht korrekt ermitteln, welche Bereiche innerhalb und außerhalb der Region liegen. Bei Bedarf können Sie die Region während der Platzierung durch Drücken von Spacebar zwischen inside und outside und der von Ihnen definierten Fläche umschalten.
- Wenn Sie fertig sind, klicken Sie mit der rechten Maustaste, um die Platzierung der Region zu beenden. Die Software definiert automatisch die letzte Kante zwischen der letzten und der ersten Klickposition.
- Nach der Platzierung kann die Form einer Region nicht interaktiv bearbeitet werden.
-
Klicken Sie einmal auf eine platzierte Region, um sie auszuwählen. Nach der Auswahl:
- Der Netzname kann im Panel Properties festgelegt werden, wenn die Region mit einem Netz verbunden werden soll.
- Drücken Sie die Taste Delete, um die ausgewählte(n) Region(en) zu entfernen.
- Gekrümmte Regionen können durch Nachzeichnen einer importierten gekrümmten Skizze erstellt werden, wie im folgenden Video gezeigt. Erfahren Sie mehr über das Importieren einer Skizze.
- Beim Export werden mehrere überlappende Regionen desselben Netzes zu einer einzigen Region zusammengeführt. Dadurch entstehen Regionen mit Aussparungen, wie im folgenden Video gezeigt.
Durchkontaktierungen in einem 3D-MID-Design
Durchkontaktierungen können während des 3D-MID-Fertigungsprozesses unter bestimmten Einschränkungen hergestellt werden. Es wird empfohlen, sich direkt mit dem Hersteller abzustimmen, um die Fertigungsmöglichkeiten in diesem Bereich zu klären. Eine vollständige Unterstützung für Durchkontaktierungen ist im 3D-MID-Werkzeug noch nicht implementiert. Mit dem folgenden Arbeitsablauf lassen sie sich dennoch in ein Design integrieren.
- Anders als bei einer herkömmlichen Leiterplatte muss jedes Durchkontaktierungspad als Bauteil behandelt werden. Es muss ein Bauteil für das Durchkontaktierungspad erstellt werden, das einen einzelnen Pin im Symbol und ein entsprechendes einzelnes Pad im Footprint enthält.
- Das Einfügen von Durchkontaktierungen erfolgt durch manuelles Platzieren, Zuweisen der Netznamen und Routen. Die folgende Diashow veranschaulicht diesen Vorgang.
|
In diesem Beispiel sollen die beiden Bauteilpads entsprechend der gelben Verbindungslinie verbunden werden, jedoch mit drei Leiterbahnen und zwei Durchkontaktierungen, wie in Blau dargestellt. Anders als bei einer herkömmlichen Leiterplatte muss jedes Durchkontaktierungspad als Bauteil behandelt werden. Es muss ein Bauteil für das Durchkontaktierungspad erstellt werden, das einen einzelnen Pin im Symbol und ein entsprechendes einzelnes Pad im Footprint enthält. Ziehen Sie zwei Bauteile für Durchkontaktierungspads aus dem Panel Components auf eine Oberfläche des Substrats. Ziehen Sie zwei weitere Bauteile für Durchkontaktierungspads auf die gegenüberliegende Seite des Substrats und richten Sie sie mithilfe des Rasters an den ersten beiden aus. Wählen Sie eines der Bauteilpads aus, um den zugehörigen Netznamen zu ermitteln; in diesem Beispiel Verwenden Sie den Modus Components im Panel PCB, um per Doppelklick jede Durchkontaktierung zu bearbeiten und ihr eine eindeutige Designator zuzuweisen, in diesem Beispiel
Um die Netzeigenschaft für alle diese 3dVia-Pads in einem einzigen Bearbeitungsschritt festzulegen, wählen Sie sie zunächst im Abschnitt „Bauteile“ von PCB Panel (beachten Sie, dass das Kontrollkästchen Select aktiviert ist), und wählen Sie dann die vier Pads im Bereich „Component Primitives“ des Panels aus. Wechseln Sie nun zum Panel Properties, in dem Sie diesen vier Pads den Netznamen zuweisen können (beachten Sie, dass unten im Panel angezeigt wird, wie viele Objekte zur Bearbeitung ausgewählt sind). Die Verbindungslinien werden aktualisiert und zeigen nun an, dass die Via-Pads demselben Netz wie die Bauteil-Pads angehören. Routen Sie die Verbindungen auf der sichtbaren Oberfläche des Substrats. Drehen Sie das Substrat um und routen Sie die Verbindung auf der anderen Oberfläche des Substrats. Die einzigen verbleibenden Verbindungslinien stellen nun die Vias selbst dar. Diese Verbindungen können im Designwerkzeug nicht fertiggestellt werden. Der Entwickler muss dem Hersteller mitteilen, welche Pads durchbohrt und metallisiert werden sollen, um die Vias zu bilden. Wenn die Konnektivität im 3D-MID-Dokument durch ein Schaltplandokument vorgegeben wird, müssen die Via-Pad-Bauteile auch zum Schaltplan hinzugefügt und demselben Netz wie im Layout zugeordnet werden, damit die beiden Dokumente konsistent bleiben. Anstatt das Bauteil aus dem Panel zu ziehen, klicken Sie mit der rechten Maustaste und wählen Sie Place aus dem Kontextmenü, platzieren Sie jedoch noch nichts. Während das Bauteil am Cursor hängt, drücken Sie die Taste Tab auf der Tastatur, um den Bauteilbezeichner before vor der Platzierung zu bearbeiten. Wenn Sie dies tun, werden die Bauteilbezeichner beim anschließenden Platzieren der drei verbleibenden Bauteile durch weitere Klicks automatisch hochgezählt. Verdrahten Sie die Via-Bauteile wie erforderlich. Um den Schaltplan und das Layout zu synchronisieren, wählen Sie Design » Update PCB 3D Document in den Menüs des Schaltplaneditors. Daraufhin wird das Dialogfeld Component Links angezeigt. Verwenden Sie die Schaltfläche, um jedes neue Schaltplanbauteil automatisch mit dem entsprechenden 3D-MID-Bauteil zu verknüpfen. Nachdem Sie auf OK geklickt haben, um die Aktualisierungen der Verknüpfungen zu übernehmen, wird das Dialogfeld ECO angezeigt. Darin werden alle Änderungen aufgeführt, die zur Synchronisierung der Schaltplan- und Layoutdokumente erforderlich sind. Klicken Sie auf Execute, um diese Änderungen anzuwenden. Um zu überprüfen, ob die Synchronisierung erfolgreich war, wählen Sie Design » Import Changes in den Menüs des 3D-MID-Editors. |
Designregelprüfung (DRC) eines 3D-MID-Designs
Der 3D-MID-Dokumenteditor ermöglicht eine Batch-Designregelprüfung (DRC) der gerouteten Leiterbahnen auf Ihrem 3D-Substrat auf Verstöße gegen die folgenden Regeln:
Die Konfiguration der Designregelprüfung erfolgt im Dialogfeld Design Rule Checker, das über den Befehl Tools » Design Rule Check in den Hauptmenüs aufgerufen wird.
Weitere Informationen zum Einrichten und Ausführen einer DRC finden Sie auf der Seite Einrichten und Ausführen einer DRC.
Exportieren der 3D-Leiterplatte
Nach Abschluss des Designs kann das 3D-MID-Design mit dem Befehl File » Export » 3D-MID exportiert werden. Die exportierten Daten werden im lokalen Projektordner gespeichert.
|
Das fertige Design im Altium 3D-MID-Editor; die in MCAD geöffneten exportierten Daten; und das in MCAD gerenderte Produkt. Beachten Sie, dass Bauteile beim Export mit dem Befehl Export » 3D-MID nicht enthalten sind. |
Die unten aufgeführten Standard-Exporteinstellungen eignen sich in der Regel für das Laserdirektstrukturierungsverfahren. Bei Bedarf können jedoch über die entsprechenden erweiterten Einstellungen andere Optionen konfiguriert werden.
| Option | Standardausgabe | Optionen in den erweiterten Einstellungen |
|---|---|---|
| Formate | STEP IGES Parasolid |
Wählen Sie das gewünschte Format im Dialogfeld Export File aus |
| Inhalt | Substrat und Leiterstruktur
|
Nur Leiterstruktur
|
| Struktur | Substrat und Leiterstruktur als separate Teile in einer einzigen Baugruppe
|
Substrat und Leiterstruktur als separate Features/Körper in einem einzigen Teil
|
| Dicke der Leiterstruktur | 0
|
Beliebiger Wert für die Extrusion in das Substrat hinein und/oder aus dem Substrat heraus
|
Sie können auch steuern, wie die Übergänge zwischen den leitfähigen Flächen (Zusammenführungen) in der exportierten Datei behandelt werden, indem Sie die Werte von zwei Optionen in den erweiterten Einstellungen ändern. Suchen Sie im Dialogfeld Advanced Settings nach merge, um die Einstellungen schnell zu finden, wie in der Abbildung unten gezeigt.
Die Auswirkungen dieser Einstellungen auf die Exportdaten sind in der folgenden Tabelle dargestellt:
| TrackToTrackMergeMode=0 | TrackToTrackMergeMode=1 | TrackToTrackMergeMode=2 | |
|---|---|---|---|
| PadToTrackMergeMode=0 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=1 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=2 | ![]() |
![]() |
![]() |
Weitere Projektausgabedaten
-
Projektausgaben, die Daten aus den Schaltplandokumenten beziehen, beispielsweise die Stückliste, sind wie gewohnt verfügbar.
-
Projektausgaben, die ein PCB-Dokument voraussetzen, beispielsweise eine Draftsman-Bestückungszeichnung, sind für ein 3D-MID-Dokument derzeit nicht verfügbar.
-
Beim Exportieren eines 3D-MID-Designs (File » Export » 3D-MID) wird eine
txtPick-and-Place-Datei im selben Ordner wie die exportierte 3D-MID-Datei (STEP, IGES oder Parasolid) erzeugt. Diese Datei enthält Informationen zur Position jedes Bauteils im Design: die X-, Y- und Z-Koordinaten des Bauteilmittelpunkts sowie die Rotationsvektoren des Bauteils. Die Rotationsvektoren hängen vom Drehgriff des Bauteils ab (sichtbar, wenn das Bauteil ausgewählt ist):- Rotationsvektor 1 ist ein Vektor, der in die entgegengesetzte Richtung des Drehgriffs zeigt.
- Rotationsvektor 2 ist ein Normalenvektor zur Oberfläche am Platzierungspunkt des Bauteils.
- Rotationsvektor 3 zeigt relativ zu Rotationsvektor 1 nach rechts, wenn man von oben darauf blickt (entgegen der Richtung von Rotationsvektor 2).

Beispiel einer erzeugten Pick-and-Place-Datei für eine 3D-Leiterplatte
Anordnung der für die Pick-and-Place-Datei verwendeten Rotationsvektoren











































