Définition de la forme de la carte

Altium Training

Altium Essentials: PCB Configuration

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

En un coup d'œil

Cet article explique le fonctionnement de la forme de la carte dans Altium Designer, ce qu’elle détermine dans une conception de PCB ou de circuit rigide-flexible, ainsi que les différentes façons de la définir, de la créer et de la modifier dans les modes rigide-flexible standard et avancé. Il décrit comment la forme de la carte est constituée d’une ou de plusieurs régions de carte, où elle est disponible, quelle est la forme par défaut dans un nouveau document PCB et quelles commandes utiliser dans les modes de planification de carte, 2D et 3D pour ajuster le contour final de la carte. Si vous souhaitez mieux comprendre comment définir et affiner les limites physiques de votre carte dans l’éditeur PCB, ce guide vous sera utile.

- Découvrez ce que définit la forme de la carte, comment le logiciel l’utilise et en quoi elle diffère entre les conceptions à une seule région et les conceptions rigides-flexibles.
- Explorez les méthodes disponibles pour créer et modifier le contour de la carte, notamment les outils interactifs, les objets sélectionnés et la définition à partir d’un corps 3D.
- Comprenez quelles commandes sont disponibles dans les modes rigide-flexible standard et avancé, et comment les modes d’affichage influencent le processus de modification.
Approfondissez avec l'IA :

Deux modes de conception rigide-flexible sont disponibles dans le logiciel de conception de PCB d'Altium. Le mode d'origine, ou mode standard, appelé Rigide-flexible, prend en charge les conceptions rigides-flexibles simples. Si votre conception présente des exigences rigides-flexibles plus complexes, telles que des zones flexibles qui se chevauchent, vous devez utiliser le mode Rigide-flexible avancé (également appelé rigide-flexible 2.0). Le mode se sélectionne dans le menu Tools du Gestionnaire d'empilage des couches.

► En savoir plus sur la conception rigide-flexible

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

La forme de la carte définit la forme globale de la carte finie. Parcourez les diapositives pour voir les trois régions de carte qui composent la forme rigide-flexible, ainsi que la carte finie en 3D.

 

Résumé

La forme de la carte, également appelée contour de la carte, est une forme polygonale fermée qui définit les limites globales de la carte. Elle peut être constituée d'une seule région de carte (pour un PCB rigide classique) ou de plusieurs régions de carte (pour un PCB rigide-flexible). Le logiciel utilise la forme de la carte pour :

  • Fournir un repère visuel des limites de l'espace disponible pour le placement et le routage de la conception.
  • Définir le retrait des plans d'alimentation par rapport au bord de la carte et les références de bord pour diviser un plan d'alimentation en zones de tension distinctes. En savoir plus sur la définition et la gestion des zones de cuivre.
  • Calculer le bord de la carte lors de l'exportation des données de conception vers d'autres outils.
Pour un projet PCB vierge ou pour des documents PCB supplémentaires ajoutés à un projet existant, la forme de carte par défaut est un rectangle (6 pouces x 4 pouces, soit 6000 mil x 4000 mil ou 152,4 mm x 101,6 mm). Pour les modèles de projet spécifiques utilisables lors de la création d'un nouveau projet PCB, le document PCB associé possède dans chaque cas une forme de carte particulière, adaptée au facteur de forme de la carte.

Disponibilité

La forme de la carte est uniquement disponible dans l'éditeur PCB. Lorsqu'un nouveau fichier PCB est créé, il s'ouvre avec une forme de carte rectangulaire constituée d'une seule région de carte.

La forme globale de la carte peut être créée de différentes manières :

  • En définissant la forme de la carte de manière interactive en mode Planification de carte.
  • En créant la forme de la carte à partir d'objets piste/arc sélectionnés formant un contour fermé. Si vous travaillez en mode Rigide-flexible avancé, plusieurs régions de carte peuvent être créées à partir d'objets sélectionnés dans l'espace de conception.
  • Pour une conception rigide-flexible (mode standard ou avancé), la forme de la carte peut être découpée en différentes régions de carte nécessaires à la conception.
  • En plaçant une ou plusieurs régions de carte pour constituer la forme globale de la carte (mode Rigide-flexible avancé).
La forme de carte par défaut dans un nouveau document PCB est un rectangle (6 pouces x 4 pouces, soit 6000 mil x 4000 mil ou 152,4 mm x 101,6 mm). Pour les modèles de projet spécifiques utilisables lors de la création d'un nouveau projet PCB, le document PCB associé possède dans chaque cas une forme de carte particulière, adaptée au facteur de forme de la carte.
Le mode d'affichage actuel du document PCB peut être modifié à l'aide des commandes correspondantes du menu principal View . Vous pouvez également changer rapidement de vue à l'aide des raccourcis clavier 1 (mode Planification de carte), 2 (2D) et 3 (3D).

Définition et modification interactives de la forme de la carte

La forme de la carte est créée à partir d'une ou plusieurs régions de carte. Pour les concepteurs travaillant sur une carte à région unique, les commandes suivantes permettent de définir la forme de la carte :

  • Board Planning Mode (standard Rigid-Flex mode - the Active Bar at the top of the graphical editing space has two buttons):
    • Design » Redefine Board Shape - utilisez cette commande pour redessiner de manière interactive le contour de la carte actuel. Notez que cette commande n’est pas disponible si le mode Rigid-Flex avancé a été activé dans Layer Stack Manager. Si la carte est en mode Rigid-Flex avancé, cliquez simplement pour sélectionner le contour et modifiez-le à l’aide des techniques standard de modification des objets polygonaux.

    • Design » Edit Board Shape - utilisez cette commande pour déplacer et remodeler les segments du contour de la carte à l’aide des techniques standard de modification des objets polygonaux.

      • Notez que cette commande n’est pas disponible si le mode Rigid-Flex avancé a été activé dans Layer Stack Manager. Si la carte est en mode Rigid-Flex avancé, cliquez simplement pour sélectionner le contour et modifiez-le à l’aide des techniques standard de modification des objets polygonaux.

      • Avant de sélectionner la commande, assurez-vous que l’option Other est activée dans le filtre de sélection afin de pouvoir utiliser la commande ().

  • Board Planning Mode (Advanced Rigid-Flex mode - the Active Bar at the top of the graphical editing space has six buttons):
    • Place » Board Region - utilisez cette commande pour définir de manière interactive la région de carte (pour une carte à région unique, la région de carte définit le contour de la carte). Pour en savoir plus, consultez Placement d’une région de carte.
  • 2D Layout Mode:
    • Design » Board Shape » Define Board Shape from Selected Objects - sélectionnez un ensemble de primitives de ligne et/ou d’arc qui définissent une forme fermée, puis utilisez cette commande pour redéfinir le contour de la carte afin qu’il corresponde à cette forme.

    • Design » Board Shape » Create Primitives from Board Shape - créez un ensemble de primitives le long du contour de la carte, conformément aux paramètres configurés dans la boîte de dialogue Primitives de ligne/arc à partir du contour de la carte.

  • 3D Layout Mode:
    • Design » Board Shape » Define Board Shape from 3D body - utilisez cette commande pour définir le contour de la carte en sélectionnant la surface souhaitée d’un modèle 3D.

Vous pouvez également utiliser les commandes suivantes en mode de planification de la carte :

  • Design » Modify Board Shape - utilisez cette commande pour modifier le contour existant de la carte en plaçant des sommets supplémentaires, afin d’affiner la forme du contour.

  • Design » Move Board Shape - utilisez cette commande pour déplacer la forme de la carte vers une autre position dans le document actif. Cette commande déplace uniquement la forme de la carte. La conception elle-même et les objets qui la composent restent à leur place.

    Après le lancement de la commande, une copie du contour de la forme est attachée au curseur par son coin inférieur gauche. Déplacez la forme vers le nouvel emplacement souhaité dans l’espace de travail, puis cliquez ou appuyez sur Enter pour la placer. Pendant le déplacement, appuyez sur Spacebar pour faire pivoter la forme de la carte dans le sens antihoraire ou sur Shift+Spacebar pour la faire pivoter dans le sens horaire (la valeur de Rotation Step est définie sur la page PCB Editor – General de la boîte de dialogue Preferences), ou appuyez sur les touches X ou Y pour appliquer une symétrie à la forme de la carte selon l’axe X ou l’axe Y, respectivement. Pour annuler sans déplacer la forme, faites un clic droit ou appuyez sur Esc.

  • Design » Move Board - utilisez cette commande pour déplacer la carte entière — la forme de la carte et tous les objets de conception qu’elle contient — vers une autre position dans le document actif.

    Après le lancement de la commande, une copie du contour de la forme de la carte est attachée au curseur par son coin inférieur gauche. Déplacez la forme vers le nouvel emplacement souhaité dans l’espace de conception, puis cliquez ou appuyez sur Enter pour la placer. Tous les objets de conception qui la composent sont également déplacés afin de conserver leur position dans la forme de la carte. Pour annuler sans déplacer la carte, faites un clic droit ou appuyez sur Esc.

La différence entre la commande Define Board Shape from Selected Objects et la commande Create Board Region from Selected Objects est que la première remplace toutes les régions de carte existantes par la nouvelle région créée lors de son exécution, tandis que la seconde crée une région de carte supplémentaire sans supprimer les régions de carte existantes.

Définition de la forme de la carte à partir d’objets sélectionnés

La forme de la carte peut également être définie à partir d’objets sélectionnés (en mode de disposition 2D). Il s’agit généralement d’un ensemble de lignes et/ou d’arcs placés sur la couche Keepout ou sur une couche mécanique.

Suivez les étapes ci-dessous :

  1. Réglez le mode d’affichage sur 2D Layout Mode (menu View).
  2. Ouvrez le panneau View Configuration et double-cliquez sur la couche mécanique contenant la forme de la carte pour la modifier. La boîte de dialogue Edit Layer s’ouvre ; vous pouvez y définir Layer Type sur Board Shape, comme illustré dans la vidéo ci-dessous.
  3. Activez la couche mécanique contenant la forme et sélectionnez les objets. La commande Edit » Select » All on Layer est idéale pour cela ; la sélection doit uniquement inclure les pistes et les arcs qui constituent le contour de la carte.
  4. Une fois tous les objets sélectionnés, exécutez la commande Design » Board Shape » Define Board Shape from Selected Objects. La forme de la carte est mise à jour pour suivre le tracé défini par les lignes sélectionnées. Une boîte de dialogue d’avertissement s’affiche si le logiciel ne parvient pas à suivre la ligne médiane des objets sélectionnés. Le mode d’affichage passe à Board Planning Mode.

Démonstration de la forme de la carte en mode rigide-flexible standard

La vidéo montre comment créer la forme de la carte à partir d’objets sélectionnés, puis placer des lignes de séparation pour créer les trois régions nécessaires.

Démonstration de la forme de la carte en mode rigide-flexible avancé

La vidéo montre d’abord comment créer la forme de la carte à partir d’objets sélectionnés, puis la découper pour créer les trois régions nécessaires. Elle présente ensuite une autre approche, dans laquelle
les trois régions de carte sont définies à partir d’objets sélectionnés. Notez que ces démonstrations utilisent les fonctionnalités Rigid-Flex 2.0, comme indiqué au début de cette page.

Le logiciel tente de déterminer la forme à partir de la ligne médiane des objets sélectionnés. Si les coordonnées de l’extrémité d’un segment de piste ou d’arc ne correspondent pas exactement à celles du segment suivant, l’algorithme d’identification du contour échoue et un message s’affiche pour indiquer l’emplacement du problème. Le logiciel propose alors d’utiliser un algorithme de traçage à la place. Notez que cet algorithme suit le bord extérieur des pistes et des arcs : la forme de la carte sera donc légèrement différente de celle créée à partir des lignes médianes. Ne choisissez cette option que si votre conception peut accepter les conséquences de cette différence.

Importation d’un contour pour définir la forme de la carte

La forme de la carte peut être définie à partir d’un contour fermé importé sous forme de données DXF/DWG.

En combinant l’importation de données DXF/DWG sur une couche mécanique avec la définition de la forme de la carte à partir d’objets sélectionnés, vous pouvez transférer dans l’éditeur PCB une forme définie dans un logiciel de CAO mécanique.

Pour préparer la nouvelle carte à l’importation :

  1. Sélectionnez File » New » PCB. Un nouveau PCB vierge s’ouvre ; la région noire représente la forme actuelle de la carte.
  2. Avant d’importer une nouvelle forme, configurez les paramètres suivants selon les exigences de votre conception et de la forme à importer :
  • Les unités - définissez les unités requises dans la Other section du Properties panneau en mode Board (voir l’image).
  • La grille - double-cliquez sur la grille d’accrochage globale de la carte et configurez-la selon vos besoins dans la Grid Manager section du Properties panneau en mode Board (voir l’image).
  • L’origine - Sur un nouveau PCB, l’origine définissable par l’utilisateur est placée par défaut à l’origine absolue, en bas à gauche de l’espace de conception. Sélectionnez Edit » Origin » Set dans les menus principaux, puis cliquez pour définir l’emplacement de l’origine utilisateur, par exemple au coin inférieur gauche de la forme actuelle de la carte. Il est utile de choisir cet emplacement en fonction de la position de l’origine du contour à importer.

L’étape suivante consiste à importer la forme de la carte sous la forme d’un fichier .DXF ou .DWG. Notez que la forme à importer doit être fermée et que les découpes internes ne sont pas créées automatiquement (mais peuvent être définies ultérieurement à partir des objets importés).

  1. Sélectionnez File » Import » DXF/DWG pour ouvrir la boîte de dialogue Import File, puis vérifiez que le File Type situé en bas à droite de la boîte de dialogue est AutoCAD Files (*.DXF, *.DWG) et recherchez le fichier souhaité. 
  2. Lorsque vous cliquez sur le bouton Open, la boîte de dialogue Import from AutoCAD s’ouvre (voir l’image).
  3. Définissez les paramètres Scale, Default Line Width et Layer Mappings selon vos besoins, puis cliquez sur OK.
  4. Chaque objet DXF/DWG sera converti en un objet et affiché dans l’espace de conception. 
  5. Activez la couche mécanique contenant les objets qui définissent la forme de la carte, puis sélectionnez tous les objets de cette couche (Edit » Select » All on Layer).
  6. Pour que la forme de la carte corresponde au contour sélectionné, exécutez la commande Design » Board Shape » Define from Selected Objects.
  7. Si la carte comporte des découpes, vous pouvez les créer en sélectionnant le contour de la découpe et en exécutant la commande Tools » Convert » Create Board Cutout from Selected Primitives.

Le logiciel tente de déterminer la forme à partir de la ligne médiane des objets sélectionnés. Si les coordonnées de l’extrémité d’un segment de piste ou d’arc ne correspondent pas exactement à celles du segment suivant, l’algorithme d’identification du contour échoue et un message indique l’emplacement du problème. Le logiciel propose alors d’utiliser un algorithme de traçage. Notez que cet algorithme suit le bord extérieur des objets de type piste ou arc : la forme de la carte sera donc légèrement différente de celle créée à partir des lignes médianes. Ne choisissez cette option que si votre conception peut accepter les conséquences de cette différence.

Définition de la forme de la carte à partir d’un corps 3D

Cette fonctionnalité redéfinit la forme de la carte à partir d’une surface (face) d’un modèle 3D importé. Les formats de modèle pris en charge sont les suivants : STEP (*.Stp ou *.STEP), Parasolid (*.x_t ou *x_b) et fichier de pièce SOLIDWORKS (*.SldPrt). Elle permet de créer rapidement une forme de carte complexe et facilite l’intégration entre les domaines de conception électronique et mécanique. Le processus se déroule en deux étapes : le modèle STEP est d’abord importé, puis la forme souhaitée est sélectionnée dans ce modèle. 

Seule une surface plane peut être utilisée pour définir la forme de la carte.

Pour ce faire :

  1. Passez en View » 3D Layout Mode (raccourci : 3).
  2. Pour importer le modèle 3D, placez un corps 3D (Place » 3D Body).
  3. Dans la boîte de dialogue Choose Model, recherchez et sélectionnez le fichier du modèle. Le modèle 3D est importé dans l’éditeur de PCB et stocké dans un objet de type corps 3D. Notez que ce modèle peut être supprimé du PCB une fois la forme de la carte redéfinie, si nécessaire.
  4. Sélectionnez Design » Board Shape » Define Board Shape from 3D body.
  5. La barre d’état vous invite à Pick a 3D body. Cliquez sur le corps 3D importé pour le sélectionner. Le modèle devient transparent.
  6. Le curseur prend la forme d’un réticule et la barre d’état vous invite à Choose Face. Chaque face est mise en évidence lorsque vous la survolez avec le curseur. Lorsqu’une surface plane est détectée sous le curseur, elle devient opaque et s’entoure d’une fine bordure bleue. Cliquez pour sélectionner la face souhaitée.
  7. La boîte de dialogue Board Outline Creation Successful apparaît. Elle propose des options permettant de choisir la surface du PCB à aligner sur la surface sélectionnée (généralement la couche supérieure) et de masquer le modèle 3D à l’affichage tout en l’excluant de la vérification des règles de conception. Ces paramètres de masquage et d’exclusion peuvent être modifiés ultérieurement, si nécessaire, dans le mode Modèles 3D du panneau PCB.

Notez que si vous conservez le modèle STEP intégré au fichier PCB ou lié à celui-ci, vous serez averti à chaque modification du fichier STEP. Vous serez également invité à mettre à jour la forme, ce qui est utile si celle-ci est encore en cours de développement et que des mises à jour sont prévues.

Seules les surfaces alignées sur le plan X-Y peuvent être utilisées pour créer la forme de la carte. Si vous sélectionnez une surface de modèle qui nécessite un alignement sur le plan X-Y, une boîte de dialogue de confirmation vous demande d’aligner la surface avant de continuer. Cette boîte de dialogue vous permet également de positionner le modèle à l’aide de la face sélectionnée par rapport à la surface supérieure ou inférieure de la carte. La position verticale du modèle peut ainsi être définie simultanément. Après l’alignement, vous devez sélectionner à nouveau Design » Board Shape » Define from 3D Body . Une fois la forme de la carte redéfinie, vous avez la possibilité de masquer le corps 3D.

Création de primitives à partir de la forme de la carte

Outre la définition de la forme de la carte à partir de primitives sélectionnées, il est également possible de créer des primitives à partir de la forme de la carte à l’aide de la commande Design » Board Shape » Create Primitives from Board Shape. Cette commande ouvre la boîte de dialogue Line/Arc Primitives from Board.

La boîte de dialogue Line/Arc Primitives From Board Shape
La boîte de dialogue Line/Arc Primitives From Board Shape

Utilisez cette commande lorsque la forme de la carte existe, mais qu’aucun objet ne se trouve actuellement le long de son contour. Cette commande peut notamment être utile dans les situations suivantes :

  • Lorsque vous souhaitez modifier la forme de la carte (ou ses découpes) en modifiant d’abord les primitives de piste et d’arc.
  • Lorsque vous avez besoin d’un contour de zone d’exclusion pour la carte ou pour ses découpes sur la couche Keep-Out. Ce point est abordé plus en détail ci-dessous dans la section Considérations importantes de conception lors de l’utilisation de découpes de carte .

    Si la couche cible est la couche Keep-Out, des objets d’exclusion spécifiques sont placés directement sur cette couche (pistes et arcs d’exclusion).

Création d’un trou dans la forme de la carte

Une découpe peut être placée n’importe où dans le contour de la carte. Pour placer une découpe, affichez la carte en mode de conception 2D puis utilisez la commande Design » Board Shape » Define Board Cutout dans les menus principaux (vous pouvez également utiliser la commande Place » Define Board Cutout en mode de planification de la carte). Notez que la découpe est en réalité un objet Region configuré comme un objet négatif.

Une découpe a été placée dans le contour de la carte.Une découpe a été placée dans le contour de la carte.

Si la découpe présente une forme inhabituelle, par exemple un cercle, il peut être plus facile d’en dessiner le contour à l’aide de pistes et d’arcs (par exemple, Place » Arc » Full Circle), de sélectionner cette forme, puis de la convertir en découpe de carte (Tools » Convert » Create Board Cutout from Selected Primitives).

Points importants à prendre en compte lors de l’utilisation de découpes de carte

Maintenir un polygone à distance du bord d’une découpe de carte

Les polygones qui recouvrent une découpe de carte définie par une région pleine sont remplis aussi près du bord de la découpe que le permet la règle de conception Clearance applicable. Si nécessaire, une règle de conception Clearance spécifique peut être créée et son champ d’application peut, par exemple, être défini entre IsBoardCutoutRegion et InPolygon.

Définir une trajectoire d’outil de fraisage autour du bord de la carte et des découpes

Une méthode courante pour séparer la carte finie du panneau de fabrication consiste à la détourer par fraisage. Les découpes de carte peuvent également être réalisées par fraisage. La trajectoire de l’outil de fraisage est définie en plaçant des objets ligne et/ou arc sur une couche mécanique. Cette opération peut être effectuée manuellement ou automatiquement par le logiciel.

Pour définir une trajectoire d’outil de fraisage pour la carte et ses éventuelles découpes :

  1. Lorsque la carte est affichée en mode de conception 2D, exécutez la commande Design » Board Shape » Create Primitives From Board Shape. La boîte de dialogue Line/Arc Primitives From Board Shape s’ouvre.

  2. Définissez une valeur Width appropriée pour les objets qui définiront la trajectoire de l’outil de fraisage. En cas de doute, consultez votre fabricant.

  3. Sélectionnez une couche mécanique disponible. Cette couche doit être réservée exclusivement à la définition de la trajectoire de l’outil de fraisage.

  4. Activez l’option Include Cutouts si la carte comporte des découpes.

  5. Activez l’option Route Tool Outline. Lorsque cette option est activée, les objets ligne/arc sont placés de manière à ce que leur bord touche le bord du contour de la carte et celui de la découpe.

  6. Cliquez sur OK pour créer les objets de trajectoire d’outil de fraisage sur la couche mécanique choisie. 

  7. La couche mécanique utilisée doit être définie comme couche d’outil de fraisage. Pour ce faire, accédez à l’onglet Layers & Colors du panneau View Configuration. Cliquez avec le bouton droit dans une grille de couches et choisissez la commande Add Mechanical Layer. Dans la boîte de dialogue Edit Layer qui s’ouvre, définissez Layer Type sur Route Tool Path.  Ce type de couche permet d’identifier la couche contenant les informations de détourage mécanique.

    Notez qu’un nom personnalisé n’est pas autorisé lorsque Layer Type est défini sur Route Tool Path. En effet, les anciennes versions du logiciel utilisent le nom de la couche de trajectoire d’outil de fraisage pour identifier la couche contenant les informations de détourage. Imposer le nom de cette couche garantit que la conception continuera à fonctionner correctement dans une ancienne version.

Les images ci-dessous montrent la trajectoire de l’outil de fraisage définie sur une couche mécanique.

La première image montre une découpe de carte ; la seconde montre la trajectoire de l’outil de fraisage définie autour de celle-ci. La première image montre une découpe de carte ; la seconde montre la trajectoire de l’outil de fraisage définie autour de celle-ci.

Zones d’exclusion et contour de la carte

En plus du contour de la carte, vous devez définir une limite de placement et de routage le long du bord de la carte. Cette limite peut être créée automatiquement à partir du contour de la carte à l’aide de la commande Design » Board Shape » Create Primitives From Board Shape (en mode de conception 2D), en définissant Layer sur Keep-Out Layer dans la boîte de dialogue Line/Arc Primitives from Board.

Vous pouvez également procéder manuellement en plaçant des objets sur la couche d’exclusion. Les objets placés sur cette couche définissent une limite no-crossing-allowed pour les composants et le routage. En général, les composants et les pistes doivent rester à une certaine distance du bord de la carte ; cette distance peut être contrôlée en définissant les règles de conception applicables au routage et au placement des composants. Vous pouvez également définir d’autres zones d’exclusion pour le routage et les composants afin de tenir compte d’éléments mécaniques, tels que des têtes de vis ou d’autres contraintes de montage.

Une limite d’exclusion définie en plaçant des objets ligne standard sur la couche d’exclusion (violette).Une limite d’exclusion définie en plaçant des objets ligne standard sur la couche d’exclusion (violette).

  • Les limites d’exclusion peuvent être définies en plaçant des objets de conception standard, tels que des lignes, des arcs, des remplissages et des régions, sur la couche d’exclusion. Les objets placés sur cette couche créent une zone d’exclusion sur toutes les couches de signal.
  • Vous pouvez également définir des zones d’exclusion propres à une couche sur n’importe quelle couche de cuivre. Pour ce faire :
  1. Cliquez sur l’onglet de la couche souhaitée.
  2. Définissez le contour ou la surface de la zone d’exclusion en plaçant des objets d’exclusion propres à la couche (sous-menu Place » Keepout). Ces objets sont des objets standard dont l’attribut Keepout est activé. Ils sont affichés dans la même couleur que la couche, avec un bord de la couleur des zones d’exclusion. Notez que les objets d’exclusion propres à une couche ne sont pas inclus dans les fichiers de sortie Gerber ou ODB++.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents