Travailler avec des composants placés
En un coup d'œil
- Découvrez d’où proviennent les composants, comment les éléments et les composants à plusieurs éléments sont gérés, et les principales méthodes pour les placer sur un schéma.
- Apprenez à rechercher des composants plus efficacement et à effectuer rapidement des modifications graphiques pendant ou après leur placement.
- Comprenez le lien entre les composants du schéma et ceux du PCB, ainsi que les principales propriétés que vous pouvez consulter ou modifier après leur placement.
Un composant dans une bibliothèque représente le dispositif physique placé sur le circuit imprimé réel. Sur une feuille de schéma, un composant est représenté par son modèle de symbole schématique. Chaque composant peut contenir une ou plusieurs parties.
Partie

La partie représente le composant électronique physique réel.
Résumé
Une partie est une primitive de conception électrique. Il s’agit d’un symbole schématique qui représente un dispositif électronique, tel qu’une résistance, un interrupteur, un amplificateur opérationnel, un régulateur de tension, etc. Les parties sont stockées au sein des composants dans les bibliothèques de composants schématiques. Notez que chaque composant peut contenir une ou plusieurs parties. Outre une représentation symbolique du composant, la partie comprend également des liens vers des modèles, tels que l’empreinte PCB, ainsi que des paramètres utilisés pour documenter des détails comme les caractéristiques du composant et les informations sur les fournisseurs. La manière dont les liens vers les modèles et les paramètres sont ajoutés à la partie dépend du type de stockage de bibliothèque utilisé.
Disponibilité
Les parties peuvent être placées dans l’éditeur de schémas et dans l’éditeur de bibliothèques schématiques.
- Dans l’éditeur de schémas, cliquez sur Place » Part.
- Faites un clic droit dans l’espace de conception, puis choisissez Place » Part dans le menu contextuel.
- Dans le panneau Components, faites un clic droit sur un composant et sélectionnez Place <ComponentName>.
- Dans le panneau Components, sélectionnez un composant générique comme élément provisoire.
- Faites glisser un composant depuis le panneau Components et déposez-le.
- Sélectionnez le bouton Place dans le volet Details du panneau Components, ou utilisez le raccourci clavier Enter.
- Dans le panneau SCH Library de l’éditeur de bibliothèques schématiques, sélectionnez un composant, puis cliquez sur Place.
Placement depuis le panneau Components
Dans l’éditeur de schémas, la sélection et le placement des parties peuvent être effectués depuis le panneau Components.
- Le panneau affiche le contenu de la bibliothèque actuellement sélectionnée. Utilisez la liste déroulante à côté du nom de la bibliothèque pour choisir une autre bibliothèque.
- Utilisez le champ de masque situé sous le champ de la bibliothèque actuellement sélectionnée pour filtrer la liste et accélérer la recherche, ou faites défiler la liste et sélectionnez la partie souhaitée.
- Cliquez sur Place, double-cliquez, ou cliquez et faites glisser pour placer le composant sélectionné sur la feuille de schéma active. Tant que la partie est attachée au curseur, vous pouvez la faire pivoter (appuyez sur Spacebar), lui appliquer une symétrie suivant un axe (appuyez sur X ou Y) ou la modifier (appuyez sur Tab) avant de la placer.
- Les colonnes affichées dans la liste des composants de la bibliothèque actuellement sélectionnée peuvent être réorganisées (par cliquer-glisser) ou reconfigurées (faites un clic droit, puis choisissez Select Columns).
-
Cliquez sur le bouton
dans une vignette de composant générique pour attacher le composant au curseur et le placer dans le document schématique actif. La sélection de la vignette elle-même ouvre la catégorie correspondant à ce type de composant dans le panneau Components.
Recherche d’un composant
Les options du menu des bibliothèques hors Workspace vous permettent de définir des préférences, d’effectuer des recherches et de migrer le contenu des bibliothèques basées sur des bases de données ou des fichiers. Pour accéder à ces options, sélectionnez le bouton du menu des bibliothèques
en haut à droite du panneau Components.
Sélectionnez File-based Libraries Preferences pour ouvrir la boîte de dialogue Available File-based Libraries, qui propose des commandes permettant d’ajouter ou de supprimer des bibliothèques, d’installer des bibliothèques et de spécifier les chemins de recherche des bibliothèques.
La liste actuelle des composants des bibliothèques basées sur des bases de données ou des fichiers peut être filtrée en saisissant une expression de recherche dans le champ Search du panneau Components. Pour accéder à des fonctions de recherche plus avancées dans les bibliothèques de composants, sélectionnez l’option File-based Libraries Search dans le menu
du panneau (en haut à droite), ce qui ouvre la boîte de dialogue File-based Libraries Search. Cette boîte de dialogue offre des options de recherche flexibles, notamment des contraintes de filtrage basées sur des requêtes, ainsi que la possibilité de rechercher dans toutes les bibliothèques disponibles basées sur des bases de données ou des fichiers, ou dans celles situées dans un chemin spécifié.
- Le paramètre de recherche par défaut Scope consiste à rechercher Components dans Available File-based Libraries.
- La boîte de dialogue permet également de rechercher dans les Libraries on path stockés dans des dossiers sur un lecteur. Pour cela, activez l’option Libraries on path, puis configurez les options Path selon vos besoins.
- Les Filters utilisent l’opérateur « AND » ; il est donc préférable de commencer par un filtre simple et, si les résultats sont nombreux, d’utiliser le mode Refine last search pour effectuer une recherche parmi ces résultats.
- Les résultats de la requête de recherche sont présentés dans la boîte de dialogue File-based Libraries Search lorsque vous sélectionnez Helper.
Placement depuis l’éditeur de bibliothèques schématiques
Une partie peut également être placée directement depuis une bibliothèque ouverte dans l’éditeur de bibliothèques schématiques, à partir du panneau SCH Library. Notez que :
- Cliquer sur le bouton Place du panneau place la partie (le composant) sélectionnée sur la dernière feuille de schéma active.
- Tant que la partie est attachée au curseur, vous pouvez la faire pivoter (appuyez sur Spacebar), lui appliquer une symétrie suivant un axe (appuyez sur X ou Y) ou la modifier (appuyez sur Tab) avant de la placer. Ces opérations peuvent également être effectuées pendant que vous faites glisser l’objet. La rotation s’effectue par incréments de 90°.
-
Si une partie est placée directement depuis une bibliothèque, il n’est pas nécessaire d’ajouter préalablement cette bibliothèque dans la boîte de dialogue Available File-based Libraries.
Modification graphique
La modification graphique d’une partie se limite au déplacement, à la rotation et à la symétrie. Lorsqu’une partie est sélectionnée dans l’espace de conception, un cadre de sélection en pointillés apparaît autour d’elle. Pour manipuler graphiquement un composant sélectionné :
- Appuyez sur Delete pour supprimer la partie sélectionnée de la conception.
- Cliquez et maintenez le bouton enfoncé pour déplacer la partie sélectionnée. Le curseur se positionne sur le point de connexion électrique le plus proche (l’extrémité de raccordement de la broche la plus proche).
- Appuyez sur Spacebar pour faire pivoter l’arc dans le sens antihoraire, ou sur Shift+Spacebar pour une rotation dans le sens horaire. Cette opération peut également être effectuée pendant que vous faites glisser l’objet. La rotation s’effectue par incréments de 90°.
- Lorsqu’une partie se déplace avec le curseur, appuyez sur la touche X ou Y pour lui appliquer une symétrie suivant l’axe correspondant.
Travailler entre le composant du schéma et le composant du PCB
Le logiciel comprend des outils facilitant le travail entre le composant du schéma et ce même composant sur le PCB. Ces outils comprennent le repérage croisé, la sélection croisée et la sélection des composants du PCB depuis le schéma.
Repérage croisé
Comme son nom l’indique, le repérage croisé vous permet de cliquer sur un composant dans un éditeur et d’accéder à ce composant dans l’autre éditeur. Pour effectuer un repérage croisé :
- Cliquez sur Cross Probe dans le menu Tools de l’éditeur de schéma ou de PCB.
- Lorsque vous cliquez sur le composant dans l’éditeur de schéma, la vue de l’éditeur de PCB est centrée et agrandie sur ce composant. Le niveau de zoom est défini sur la page Système – Navigation de la boîte de dialogue Preferences.
- Par défaut, vous restez dans le même éditeur, prêt à effectuer un repérage croisé sur un autre composant. Pour passer à l’autre éditeur lors du repérage croisé, maintenez la touche Ctrl enfoncée.
Mode de sélection croisée
Le mode de sélection croisée sélectionne le même composant dans l’autre éditeur. Notez qu’il n’effectue ni zoom ni centrage. La sélection croisée est soit activée, soit désactivée. Cliquez sur Tools » Cross Select Mode pour activer ou désactiver ce mode. Sélectionnez plusieurs composants en maintenant la touche Shift enfoncée lorsque vous cliquez pour les sélectionner.
Sélection des composants du PCB
Cette fonction vous permet de sélectionner plusieurs composants du schéma dans un ordre précis, puis de placer ces mêmes composants dans l’éditeur de PCB dans le même ordre. Pour utiliser cette fonction :
- Sélectionnez les composants du schéma un par un (maintenez la touche Shift enfoncée lorsque vous cliquez pour sélectionner plusieurs composants).
- Passez à l’éditeur de PCB, puis utilisez le raccourci I, C pour lancer la commande Reposition Selected Components. La commande Reposition Selected Components est également disponible dans le menu contextuel après avoir utilisé le raccourci I.
Propriétés de la partie
Onglet Général
Général
-
Reuse Block – lorsque le composant fait partie d’un bloc de réutilisation, ce champ affiche le nom du bloc de réutilisation parent. Cliquez sur le lien hypertexte Reuse Block pour consulter les propriétés de ce bloc de réutilisation.
-
Designator – saisissez le repère. Cliquez sur l’icône en forme d’œil pour afficher ou masquer le repère. Utilisez l’icône de cadenas pour verrouiller ou déverrouiller le repère. En savoir plus sur le repère.
-
Comment – saisissez un nom ou un commentaire. Cliquez sur l’icône en forme d’œil pour afficher ou masquer le nom. Utilisez l’icône de cadenas pour verrouiller ou déverrouiller le nom. Le champ Commentaire peut également servir à afficher la valeur d’un paramètre système ou défini par l’utilisateur. En savoir plus sur le commentaire.
-
Part <x> of Parts – affiche le numéro de la partie sélectionnée et le nombre total de parties. Cliquez sur
pour verrouiller ou déverrouiller les champs, puis utilisez la liste déroulante pour sélectionner le numéro de la partie associée.
-
Description – la description du composant ou de la partie.
-
Type – sélectionnez ici l’un des types de composants suivants pour l’empreinte du composant. Les types disponibles sont :
-
Standard– composants qui possèdent des propriétés électriques standard, sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et sont inclus dans la nomenclature. Un exemple est un composant électrique standard, tel qu’une résistance. -
Mechanical– composants qui ne possèdent pas de propriétés électriques, ne sont pas synchronisés (vous devez les placer manuellement dans les deux éditeurs) et sont inclus dans la nomenclature. Un exemple est un dissipateur thermique. -
Graphical– composants qui ne possèdent pas de propriétés électriques, ne sont pas synchronisés (vous devez les placer manuellement dans les deux éditeurs) et ne sont not pas inclus dans la nomenclature. Un exemple est un logo d’entreprise. -
Net Tie (In BOM)– composants utilisés pour court-circuiter deux nets différents ou plus, toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et inclus dans la nomenclature. Ils diffèrent d’un composant standard en ce que la connectivité créée par le cuivre à l’intérieur de l’empreinte n’est pas vérifiée ; c’est ce cuivre qui permet de court-circuiter les nets. Remarque : activez l’option Verify Shorting Copper dans la boîte de dialogue de vérification des règles de conception pour vérifier qu’il n’y a pas de cuivre non connecté dans le composant. -
Net Tie (No BOM)– composants utilisés pour court-circuiter deux nets différents ou plus, toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et non not inclus dans la nomenclature. Ils diffèrent d’un composant standard en ce que la connectivité créée par le cuivre à l’intérieur de l’empreinte n’est pas vérifiée ; c’est ce cuivre qui permet de court-circuiter les nets. Remarque : activez l’option Verify Shorting Copper dans la boîte de dialogue de vérification des règles de conception pour vérifier qu’il n’y a pas de cuivre non connecté dans le composant. -
Standard (No BOM)– composants qui possèdent des propriétés électriques standard, sont toujours synchronisés entre le schéma et le PCB (l’empreinte, les broches/pastilles et les affectations de nets doivent toutes correspondre) et ne sont not pas inclus dans la nomenclature. Un exemple est un composant de point de test que vous souhaitez exclure de la nomenclature. -
Jumper– composants utilisés pour inclure des straps dans une conception de PCB, par exemple sur un PCB simple face qui ne peut pas être entièrement routé sur une seule couche. Pour ce type de composant, l’empreinte et les broches du composant sont synchronisées entre le schéma et le PCB, mais pas les affectations de nets, et le composant est inclus dans la nomenclature. Outre la sélection de cette option au niveau du composant, les deux pastilles du composant doivent avoir leur JumperID défini sur la même valeur non nulle. Les composants de type cavalier n’ont pas besoin d’être câblés sur le schéma ; ils doivent uniquement y figurer s’ils sont requis dans la nomenclature. S’ils ne sont pas requis dans la nomenclature, ils peuvent être placés directement sur le PCB, où le Component Type est défini, les JumperIDs sont définis et le Nets est affecté manuellement aux pastilles.
-
-
Design Item ID – ce champ indique le nom du composant sélectionné (pour un composant de l’espace de travail), le champ clé choisi défini dans le Field Settings zone du fichier DbLib/SVNDbLib (pour un composant de bibliothèque de base de données), ou le Design Item ID paramètre défini pour le symbole du composant (pour un composant de bibliothèque basée sur des fichiers). Cliquez sur
pour ouvrir la boîte de dialogue Remplacer le composant. Cette boîte de dialogue donne accès à toutes les informations du composant sélectionné (paramètres, modèles, choix de pièces, données fournisseurs, etc.), à la comparaison des composants et à la possibilité de remplacer le composant actuel par un autre, entre autres fonctionnalités. Si un autre composant est sélectionné comme remplacement, ce champ affiche alors le Design Item ID complet du nouveau composant sélectionné. Cliquez sur le bouton Validate pour afficher les informations sur l'emplacement du composant. S'il ne s'agit pas d'un composant d'espace de travail, le chemin du fichier dans lequel il est enregistré sur votre ordinateur s'affiche. S'il s'agit d'un composant d'espace de travail, les informations indiquent simplement que le composant a été trouvé.
-
Source – affiche le nom de la bibliothèque source du composant. Cliquez sur
pour rechercher et sélectionner la bibliothèque souhaitée.
-
Revision state – ce champ affiche l'état actuel du cycle de vie de la révision du composant sélectionné, avec l'icône colorée et le nom de l'état de la révision.
-
Revision status – si la révision du composant sélectionné est dans un état applicable (autorisée à être utilisée dans les conceptions), l'entrée indique si cette révision est la plus récente (
Up to date) ou non (Out of date). Si la révision est dans un état non applicable (non autorisée à être utilisée dans les conceptions), l'entrée afficheNot applicable. Cliquez sur le bouton
pour mettre à jour le composant vers la dernière révision.
-
Component issues (panneau Properties uniquement) – si un composant sélectionné provenant de l'espace de travail Altium 365 connecté présente des problèmes d'intégrité, ceux-ci sont signalés par l'icône
(pour les erreurs) ou
(pour les erreurs fatales). Le nombre à droite de l'icône indique le nombre de problèmes détectés. Cliquez sur la flèche vers le bas à droite du nombre pour afficher une brève description des problèmes.

Exemple de problèmes d'intégrité détectés dans une bibliothèque. -
Supply Chain Data (panneau Properties uniquement) – affiche les informations de chaîne d'approvisionnement issues du choix de pièce associé :
- Prix unitaire médian. Cette entrée s'affiche en rouge si aucun prix n'est disponible ou si le prix est égal à 0.
- Stock. Cette entrée affiche la somme totale des stocks disponibles auprès des fournisseurs activés dans le cadre de la source Altium Parts Provider de votre espace de travail.
-
Barre du cycle de vie fabricant. Survolez la barre pour afficher une infobulle informative. Elle peut présenter l'un des quatre états suivants :
- Blanc/Gris = Par défaut, inconnu ou aucune information
- Vert = Nouveau ou production en série
- Orange = Non recommandé pour les nouvelles conceptions
- Rouge = Obsolète ou en fin de vie
Position
-
(X/Y)
- X (premier champ) – la coordonnée X (horizontale) actuelle du point de référence de l'objet, par rapport à l'origine actuelle de l'espace de conception. Modifiez cette valeur pour changer la position X de l'objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si vous saisissez une valeur dans des unités autres que celles définies par défaut.
- Y (deuxième champ) – la coordonnée Y (verticale) actuelle du point de référence de l'objet, par rapport à l'origine actuelle. Modifiez cette valeur pour changer la position Y de l'objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si vous saisissez une valeur dans des unités autres que celles définies par défaut.
-
Rotation – utilisez la liste déroulante pour sélectionner la rotation. Les choix sont
0 Degrees,90 Degrees,180 Degreeset270 Degrees.
Paramètres
-
Grid – répertorie les Name et Value des paramètres associés au composant actuellement sélectionné. Utilisez
pour verrouiller/déverrouiller un paramètre de la liste et empêcher sa mise à jour. Les valeurs des paramètres peuvent être saisies manuellement ou sélectionnées dans une liste déroulante proposant des valeurs issues de tous les composants disponibles de ce type. Vous pouvez cliquer sur l’icône en forme d’œil pour afficher/masquer le paramètre.
-
Favorites – les paramètres marqués comme favoris sont affichés dans la liste des paramètres, tandis que les autres sont masqués. Placez le pointeur à droite du nom d’un filtre de paramètres et cliquez sur l’icône
pour définir ce filtre comme favori. Pour retirer un paramètre des favoris, cliquez à nouveau sur l’icône.
Pour afficher tous les paramètres masqués, cliquez sur la commande Show More en bas de la liste. Cliquez sur la commande Show Less pour afficher uniquement les paramètres favoris.
-
Font – cliquez sur la police affichée pour modifier le style de police.
-
Other – cliquez pour ouvrir une liste déroulante permettant de modifier des options supplémentaires :
- Show Parameter Name – activez cette option pour afficher le nom du paramètre.
- Allow Synchronization with Database – activez cette option pour synchroniser avec la base de données. Cette option permet de déterminer si le commentaire peut être mis à jour. Par défaut, ces options sont activées afin de toujours autoriser la synchronisation avec la bibliothèque ou la base de données source. Vous pouvez désactiver cette option pour empêcher l’inclusion de ce commentaire dans un processus de mise à jour.
- (X/Y) – saisissez les coordonnées X et Y.
-
Rotation – utilisez la liste déroulante pour sélectionner la rotation. Les choix possibles sont :
0°,90°,180°et270°. - Autoposition – cochez cette option pour activer le positionnement automatique : le paramètre est alors positionné automatiquement chaque fois que le composant associé subit une rotation. Désactivez cette option pour conserver la position du paramètre par rapport au composant associé lors de sa rotation.
-
Add – cliquez pour ajouter un paramètre, par exemple une empreinte, un modèle ou une règle. Cliquez sur
pour supprimer une entrée sélectionnée dans la grille. Cliquez sur
pour modifier le paramètre via la boîte de dialogue correspondante.
Graphique
-
Mode – utilisez la liste déroulante pour sélectionner le mode souhaité. Si aucun mode autre que Normal n’est disponible, cette liste déroulante est grisée.
- Mirrored – activez cette option pour appliquer une symétrie au composant.
- Local Colors – activez l’option de couleur locale pour remplacer les couleurs de remplissage, de ligne et de broche du composant du schéma par celles des cases de couleur Fill, Lines et Pins, respectivement. Désactivez cette option pour utiliser les couleurs prédéfinies dans la bibliothèque.
Choix de composants
Cette zone fournit des informations sur les choix de composants et les liens fournisseurs attribués au composant sélectionné. Consultez la page Ajout d’informations de chaîne d’approvisionnement à un composant pour en savoir plus sur les informations fournies par les entrées de cette section.
Onglet Broches
-
Grid – cette zone répertorie les Pins et Names de toutes les broches du composant sélectionné. Utilisez l’icône en forme d’œil pour afficher/masquer la broche. Utilisez l’icône en forme de cadenas pour verrouiller/déverrouiller les broches.
Pour une broche multifonction (une broche dont les fonctions sont spécifiées dans le champ Functions du mode Broches du panneau Propriétés), cliquez dans la cellule de la broche dans la colonne Name, puis sélectionnez la fonction de la broche dans la liste déroulante qui apparaît. La fonction sélectionnée sera affichée comme nom de la broche sur la feuille de schéma.
- Show Full/Show Short - en Show Full les noms étendus complets de toutes les broches répertoriées sont affichés ; en mode Show Short, le nom actuel de la broche est affiché.
-
– lorsque le bouton est activé (icône de cadenas fermé), les broches du composant ne peuvent pas être modifiées dans l’éditeur de schémas (mais peuvent l’être dans l’éditeur de bibliothèques de schémas). Désactivez cette option pour modifier une broche de composant sur la feuille de schéma.
-
– cliquez pour afficher toutes les broches masquées et leurs propriétés (noms et numéros), y compris les broches dont la propriété Show est désactivée dans l’éditeur de broches de composant. Notez que si vous travaillez dans l’éditeur de bibliothèques de schémas, l’option View » Show Hidden Pins doit également être activée pour afficher les broches masquées dans cet éditeur.
-
– cliquez pour ajouter une broche au composant. Configurez la broche dans le panneau Properties, puis cliquez et faites-la glisser pour la positionner.
-
– cliquez pour supprimer les broches sélectionnées du composant.
-
– cliquez pour ouvrir la boîte de dialogue de l’éditeur de broches de composant. Cette boîte de dialogue permet de visualiser et de modifier facilement toutes les broches du composant actuellement ouvert dans l’éditeur de bibliothèques de schémas, ou du composant sélectionné (ou d’une partie de celui-ci) dans l’éditeur de schémas.
Propriétés des composants génériques
Composants génériques

Placement d’un composant générique depuis le panneau Components
Lorsque Altium Designer est connecté à un espace de travail, les composants génériques disponibles sont accessibles depuis le panneau Components, où ils sont affichés lorsque l’option All est sélectionnée dans le volet Categories – ou depuis le menu déroulant supérieur lorsque le panneau est en mode compact. Cliquez sur le bouton
dans la vignette d’un composant générique pour attacher le composant au curseur et le placer dans le schéma actif. La sélection de la vignette elle-même ouvre la catégorie correspondant à ce type de composant dans le panneau Components.
Propriétés des composants génériques
Général
- Designator – saisissez le repère. Utilisez l’icône en forme d’œil pour afficher ou masquer le repère. Cliquez sur l’icône de cadenas pour verrouiller ou déverrouiller le repère.
- Comment – saisissez le nom. Utilisez l’icône en forme d’œil pour afficher ou masquer le nom.
-
Description – la description du composant ou de la partie générique.
- Replace – sélectionnez le bouton Replace lorsque la conception a suffisamment progressé pour qu’un composant générique puisse être remplacé par un composant physique spécifique à l’aide de la boîte de dialogue de remplacement de composant.
Position
-
(X/Y)
- X (premier champ) – la coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de conception. Modifiez-la pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Y (deuxième champ) – la coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez-la pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Rotation – utilisez la liste déroulante pour sélectionner la rotation.
Paramètres
- Grid – répertorie les Name et Value des paramètres associés au composant actuellement sélectionné. Utilisez l’icône de cadenas pour verrouiller ou déverrouiller un paramètre répertorié. Les valeurs des paramètres peuvent être saisies manuellement ou sélectionnées dans une liste déroulante proposant des valeurs provenant de tous les composants disponibles de ce type. Vous pouvez utiliser l’icône en forme d’œil pour afficher ou masquer le paramètre.
- Font – cliquez sur la police affichée pour modifier le style de police.
-
Other – cliquez pour ouvrir une liste déroulante permettant de modifier des options supplémentaires :
- Show Parameter Name – activez cette option pour afficher le nom du paramètre.
- Allow Synchronization with Database – activez cette option pour synchroniser avec la base de données. Cette option permet de déterminer si le commentaire peut être mis à jour. Par défaut, ces options sont activées afin de toujours autoriser la synchronisation avec la bibliothèque ou la base de données source. Vous pouvez désactiver cette option pour exclure ce commentaire du processus de mise à jour.
- (X/Y) – saisissez les coordonnées X et Y.
- Rotation – utilisez la liste déroulante pour sélectionner la rotation.
- Autoposition – cochez cette option pour activer le positionnement automatique : le paramètre est alors positionné automatiquement à chaque rotation du composant associé. Désactivez cette option pour conserver la position du paramètre par rapport au composant associé lors de sa rotation.
Repère
Le repère identifie de manière unique chaque composant de la conception.
Résumé
Le champ du repère est un objet paramètre enfant d’un composant schématique (partie). Il sert à identifier de manière unique chaque partie placée afin de la distinguer de toutes les autres parties placées sur l’ensemble des feuilles de schéma du projet.
Disponibilité et placement
Le repère est placé automatiquement lors du placement de l’objet parent représentant la partie du composant. Il ne s’agit pas d’un objet de conception que vous pouvez placer directement.
Modification graphique
La chaîne du repère peut être modifiée graphiquement à l’aide de ce que l’on appelle la modification in-place. Pour modifier une chaîne de repère sur place, sélectionnez le repère en traçant un cadre autour de lui avec le curseur, puis appuyez sur Entrée.

Exemple de modification sur place
Une fois la modification terminée, appuyez sur Enter ou cliquez en dehors de la chaîne pour quitter le mode de modification sur place.
Modification non graphique
Deux aspects sont à prendre en compte pour modifier le repère : la modification de sa valeur et celle de ses propriétés d’affichage.
Les chaînes du repère (et du commentaire) peuvent être affichées dans l’éditeur de bibliothèques de schémas, puis modifiées par un double-clic pour en éditer les propriétés. L’icône
associée au champ dans le panneau Properties permet d’afficher ou de masquer le repère.
Modification de la valeur du repère dans l’éditeur de schémas
Le repère peut être défini dans l’éditeur de schémas pendant le placement du composant ou après son placement sur une feuille de schéma dans le Properties panel.
- Pour modifier le repère pendant le placement du composant, appuyez sur la touche Tab lorsque le composant est attaché au curseur. Le panneau Properties s’ouvre ; saisissez la chaîne souhaitée pour le repère. Cliquez sur le bouton de pause superposé à l’espace de conception pour reprendre le placement.
- Continuez à placer des composants ou appuyez sur Esc pour terminer le placement.
- Appuyez sur Spacebar pour faire pivoter l’arc dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. Cette action peut également être effectuée pendant le déplacement de l’objet. La rotation s’effectue par incréments de 90°.
- Pour modifier le repère après le placement, double-cliquez sur le composant placé pour ouvrir le panneau Propriétés , dans lequel le repère peut être modifié.
Modification des propriétés d’affichage du repère
L’apparence de la chaîne du repère, notamment le type, la taille et la couleur de la police, peut être configurée sur la page Schéma - Valeurs par défaut de la boîte de dialogue Preferences. Ces paramètres s’appliquent sauf s’ils sont remplacés par ceux définis dans le symbole du composant dans l’éditeur de bibliothèques de schémas.
Fixation de la position de la chaîne du repère
Par défaut, le repère est positionné automatiquement lorsqu’un composant est pivoté pendant son placement. Si ce comportement n’est pas souhaité, désactivez l’option Autoposition dans la boîte de dialogue Preferences (voir l’image précédente), soit lors de la création du symbole, soit après le placement du composant sur une feuille de schéma. Notez que cette opération classe ce paramètre comme manual parameter (c’est-à-dire un paramètre positionné manuellement). Les paramètres manuels sont identifiés par un point dans le coin inférieur gauche de leur cadre de sélection.
Remarques
-
L’éditeur de schémas comprend une fonction simple d’incrémentation automatique du repère, utilisable lors du placement de plusieurs instances d’un même composant. Pour l’utiliser, appuyez sur Tab lorsque le premier composant est attaché au curseur, puis saisissez un repère approprié, par exemple
R1. Les composants suivants recevront alors les repèresR2,R3, etc. Notez que lorsque vous passez au placement d’un autre type de composant, vous devez à nouveau appuyer sur Tab et saisir un préfixe de repère approprié. -
Lors du placement de composants à plusieurs parties, si le repère initial est attribué comme décrit ci-dessus, un suffixe de partie est automatiquement attribué, par exemple
U3A,U3B, etc. Si le repère initial n’est pas attribué, toutes les parties auront le même suffixe. Ce problème est résolu par la commande Annotation de l’éditeur de schémas. Le suffixe de partie peut être alphabétique ou numérique. Utilisez l’option Alpha Numeric Suffix sur la page Schéma - Général de la boîte de dialogue Preferences pour le configurer.
Propriétés du repère
Position
-
(X/Y)
- X (premier champ) - coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de travail. Modifiez-la pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités ne sont pas celles définies par défaut.
- Y (deuxième champ) - coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez-la pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités ne sont pas celles définies par défaut.
- Rotation - utilisez la liste déroulante pour sélectionner la rotation.
Propriétés
- Object - affiche l’objet associé.
- Nom - activez ce champ en cliquant sur l’icône de visibilité pour ajouter le préfixe « Designator: » à la valeur du repère. Cela permet de distinguer visuellement la valeur textuelle et de confirmer qu’il s’agit d’un repère dans le document schématique.
-
Value - affiche le nom du repère lui-même. Cliquez sur l’icône en forme d’œil
pour afficher/masquer la valeur.
- Positionnement automatique - cochez cette option pour activer le positionnement automatique : le texte restera à la position choisie lorsque le composant sera déplacé et pivoté.
- Verrouiller le paramètre - cochez cette option pour verrouiller le paramètre, ce qui empêche la modification de sa valeur depuis le panneau Properties ou le document schématique.
- Autoriser la synchronisation avec la base de données - activez cette option pour synchroniser avec la base de données. Cette option permet de déterminer si le commentaire peut être mis à jour. Par défaut, ces options sont activées pour toujours autoriser la synchronisation avec la bibliothèque/base de données source. Vous pouvez désactiver cette option pour exclure ce commentaire du processus de mise à jour.
- Police - utilisez les commandes pour sélectionner la police, sa taille et sa couleur, et lui appliquer les styles souhaités, tels que le gras, l’italique et le soulignement.
- Alignement - cliquez sur les flèches pour configurer l’alignement du texte ou sur le cercle pour le centrer.
- Override Library Primitive (boîte de dialogue Preferences uniquement) - cochez cette case pour remplacer les paramètres de primitive définis pour l’objet repère dans une bibliothèque. Ainsi, lorsqu’un composant est placé, il adopte les paramètres de primitive que vous avez définis dans la boîte de dialogue Préférences, plutôt que ceux définis pour le composant dans la bibliothèque.
Commentaire
Un commentaire permet d’afficher des informations supplémentaires sur un composant.
Résumé
Le champ Commentaire est un objet paramètre enfant d’un composant de schéma. Il affiche des informations supplémentaires sur le composant.
Disponibilité et placement
Le commentaire est configuré lors du placement de l’objet composant parent. Il ne s’agit pas d’un objet de conception que vous pouvez placer directement.
Édition graphique
Le commentaire peut être modifié graphiquement à l’aide de ce que l’on appelle l’édition in-place. Pour modifier un commentaire sur place, cliquez une fois pour le sélectionner, attendez une seconde, puis cliquez une seconde fois pour passer en mode édition.
Cliquez une fois pour sélectionner la chaîne de caractères.
Une fois la modification terminée, appuyez sur Enter ou cliquez en dehors de la chaîne pour quitter le mode d’édition sur place.
Modification non graphique
Deux aspects sont à prendre en compte lors de la modification du commentaire : la modification de sa valeur et celle de ses propriétés d’affichage.
Modification du commentaire dans l’éditeur de schémas
Le commentaire peut être défini dans l’éditeur de schémas pendant le placement du composant ou après son placement sur une feuille de schéma, dans le champ Comment du panneau Properties.
- Pour modifier le commentaire pendant le placement du composant, appuyez sur la touche Tab lorsque le composant est attaché au curseur. Le panneau Properties s’ouvre ; saisissez le commentaire souhaité. Cliquez sur le bouton de pause superposé à l’espace de conception pour reprendre le placement du composant.
- Continuez à placer des composants ou appuyez sur Esc pour terminer le placement.
- Pour modifier le commentaire après le placement, double-cliquez sur le composant placé afin d’ouvrir le panneau Propriétés , dans lequel vous pouvez modifier le commentaire.
Modification des propriétés d’affichage du commentaire
L’apparence des commentaires, notamment le type, la taille et la couleur de la police, peut être configurée sur la page Schéma - Valeurs par défaut de la boîte de dialogue Preferences .
Fixer la position du commentaire
Par défaut, le commentaire se positionne automatiquement lorsque le composant est pivoté pendant le placement. Si ce comportement n’est pas souhaité, désactivez l’option Autoposition dans la boîte de dialogue Preferences (voir l’image précédente), soit pendant la création du symbole, soit après le placement du composant sur une feuille de schéma. Notez que cette action classe ce paramètre comme manual parameter (c’est-à-dire un paramètre positionné manuellement). Les paramètres manuels sont identifiés par un point dans le coin inférieur gauche de leur cadre de sélection.
Propriétés du commentaire
Position
-
(X/Y)
- X (premier champ) - coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de conception. Modifiez-la pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Y (deuxième champ) - coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez-la pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Rotation - utilisez la liste déroulante pour sélectionner la rotation. Les choix possibles sont : 0 Degrees, 90 Degrees, 180 Degrees et 270 Degrees.
Propriétés
- Composant - affiche le nom du composant associé. Cliquez sur le lien Component pour ouvrir le panneau Propriétés du composant, dans lequel vous pouvez modifier les options du composant ainsi que le commentaire lui-même, défini dans le champ Comment de ce panneau.
- Nom - activez ce champ en cliquant sur l’icône de visibilité pour ajouter le préfixe « Commentaire: » à la valeur du commentaire. Cela permet de distinguer visuellement cette valeur textuelle et de confirmer qu’il s’agit d’un commentaire dans le document schématique.
-
Valeur - affiche le nom du commentaire lui-même. Cliquez sur pour afficher ou masquer la valeur.
- Positionnement automatique - cochez cette case pour activer le positionnement automatique : le texte reste à la position choisie lorsque le composant est déplacé et pivoté.
- Verrouiller le paramètre - cochez cette case pour verrouiller le paramètre et empêcher la modification de sa valeur depuis le panneau Properties ou le document schématique.
- Autoriser la synchronisation avec la base de données - activez cette option pour permettre la synchronisation avec la base de données. Cette option détermine si le commentaire peut être mis à jour. Par défaut, elle est activée afin de toujours autoriser la synchronisation avec la bibliothèque ou la base de données source. Vous pouvez la désactiver pour exclure le commentaire du processus de mise à jour.
- Police - utilisez les commandes pour sélectionner la police, sa taille et sa couleur, et appliquer les attributs souhaités, comme le gras, l’italique et le soulignement.
- Alignement - cliquez sur les flèches pour configurer l’alignement du texte ou sur le cercle pour le centrer.
- Override Library Primitive (boîte de dialogue Preferences uniquement) - cochez cette case pour remplacer les paramètres de primitive définis pour l’objet commentaire dans une bibliothèque. Ainsi, lorsqu’un composant est placé, il adopte les paramètres de primitive que vous avez définis dans la boîte de dialogue Preferences, plutôt que ceux définis pour le composant dans la bibliothèque.
Mise à jour et remplacement des composants à partir d’une bibliothèque
Une fois les composants placés sur les feuilles de schéma d’une conception de carte, il est nécessaire de pouvoir mettre à jour ces instances afin de répercuter les modifications apportées aux composants sources auxquels elles sont liées dans l’espace de travail concerné. Autrement dit, il faut disposer d’un moyen de maintenir la conception synchronisée avec les entités de l’espace de travail qu’elle utilise.
Par exemple, un composant peut avoir été enregistré à nouveau dans l’espace de travail, éventuellement pour prendre en compte une modification d’un modèle enfant. Cela crée une nouvelle révision de ce composant. L’instance placée utilise alors une ancienne révision, et vous pouvez souhaiter la mettre à jour pour qu’elle utilise la plus récente. Vous pouvez également avoir décidé d’utiliser un composant entièrement différent et avoir simplement besoin de remplacer le composant existant dans la conception par un autre.
Plusieurs méthodes permettent de gérer les composants après leur placement initial dans une conception.
Modification d’une instance de composant
Chaque composant placé possède un lien vers la révision du composant dans l’espace de travail. Ces informations sont disponibles dans le panneau Properties, lorsque vous consultez les propriétés du composant sélectionné.
Chaque instance placée d’un composant possède un lien vers la révision spécifique de ce composant dans l’espace de travail.
À ce niveau élémentaire, celui du composant individuel, l’instance placée peut être :
-
Mise à jour vers la dernière révision du composant existant, en cliquant sur le bouton
.
Exemple de mise à jour du même composant vers sa dernière révision : survolez l’image pour voir le résultat.
-
Remplacée par la dernière révision d’un autre composant de l’espace de travail (un composant de remplacement) ou par un composant de bibliothèque basée sur des fichiers en cliquant sur le bouton
à droite du champ Design Item ID. La boîte de dialogue Replace Component s’ouvre et présente les composants de votre espace de travail connecté et des bibliothèques basées sur des fichiers disponibles. Le composant actuel apparaît en haut de la liste. Recherchez le composant de remplacement souhaité, sélectionnez-le, puis cliquez sur OK.
Exemple de remplacement du composant existant par un autre (une alternative)
La boîte de dialogue Replace Component donne un accès direct à tous les composants disponibles dans les bibliothèques de l’espace de travail et les bibliothèques basées sur des fichiers. Elle fournit des informations détaillées sur le composant sélectionné (paramètres, modèles, choix de pièces, données fournisseurs, etc.), permet de comparer les composants et, pour les composants de bibliothèque de l’espace de travail, propose une recherche paramétrique par filtres permettant de spécifier les paramètres du composant recherché.
Options et commandes de la boîte de dialogue Replace Component
- Search - utilisez le champ de recherche textuelle pour rechercher manuellement un composant spécifique.
-
- cliquez pour développer ou réduire le Categories volet afin d’afficher certains types de composants ou tous les composants disponibles. Utilisez la barre de recherche située sous le Categories volet pour rechercher manuellement une catégorie de composants spécifique ou une bibliothèque de composants basée sur des fichiers disponible.
-
- cliquez pour accéder à un menu et sélectionner l’une des options suivantes :
- File-based Libraries Preferences - cliquez pour ouvrir la boîte de dialogue Available File-based Libraries afin d’ ajouter ou de supprimer des bibliothèques.
- File-based Libraries Search - cliquez pour ouvrir la boîte de dialogue File-based Libraries Search afin de rechercher des bibliothèques.
- Refresh - cliquez pour actualiser la boîte de dialogue.
-
- cliquez pour ouvrir ou fermer la Details zone de la boîte de dialogue (décrite ci-dessous).
Filtres
Lorsqu’une catégorie de composants de l’espace de travail est sélectionnée, cliquez sur l’icône Filters pour ouvrir la zone Filters, dans laquelle vous pouvez affiner le filtrage des catégories sélectionnées dans la liste Components . Les options Filters du panneau peuvent être adaptées à vos besoins en définissant certains types de paramètres comme Favorites ; ils sont alors déplacés en haut de la liste pour la catégorie de composants actuelle. Survolez la zone à droite du nom d’un filtre de paramètre et cliquez sur l’icône pour définir ce filtre comme favori. Les paramètres des filtres favoris s’appliquent à chaque Categories de composants et sont enregistrés individuellement.
Composants
- Name - le nom du composant.
- Description - la description de chaque composant.
- Footprint - l’empreinte du composant.
- Results - indique le nombre total de composants trouvés ou répertoriés dans la recherche.
Détails
- Component Revision ID - indique l’identifiant de révision et le prix d’un composant donné. Cliquez sur l’identifiant de révision pour ouvrir le panneau Explorer et obtenir des informations supplémentaires sur un composant.
- References - cliquez pour ouvrir les informations de référence du composant dans un navigateur Web. Utilisez la liste déroulante pour accéder à Manufacturer URL ou à Datasheet.
- Place - cliquez pour placer le composant sélectionné dans un document schématique.
- Component information - répertorie les informations pertinentes sur le composant, notamment le fabricant, la date de publication et les informations descriptives. Cliquez sur le lien Show More pour afficher toutes les informations ; cliquez sur Show Less pour les réduire.
- Models - développez pour afficher les modèles fournis. Utilisez les liens disponibles pour afficher différentes parties d’un même modèle.
- References - développez pour accéder à Manufacturer URL, Datasheet et Package Specification.
- Part Choices - développez pour afficher les choix de pièces. Un nom, un prix et une description sont fournis. La fiche technique du composant est également répertoriée.
- Where Used - développez pour afficher les projets qui utilisent le composant.
Menu contextuel
- Find Similar Components - cliquez pour ouvrir la boîte de dialogue Find Similar Components, dans laquelle vous pouvez rechercher plusieurs autres composants présentant des caractéristiques similaires.
- Place <component> - cliquez pour placer le composant dans le document approprié.
- Edit - cliquez pour ouvrir les documents de bibliothèque du composant sélectionné.
- Navigate to <revision> - cliquez pour ouvrir le composant sélectionné dans le panneau Explorer.
- Operations - survolez pour accéder aux options Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL et Full Item History.
- Refresh- cliquez pour actualiser l’affichage et voir les mises à jour ou modifications récentes. Vous pouvez également actualiser à l’aide du raccourci F5.
- Library Report - lorsqu’une bibliothèque basée sur des fichiers est sélectionnée dans le volet Categories, cliquez pour accéder à la boîte de dialogue Library Report Settings, dans laquelle les commandes disponibles permettent de configurer un rapport de bibliothèque.
Modification des composants par lots avec Item Manager
Related page: Gestion du contenu avec Item Manager
La modification individuelle des composants est pratique, mais elle devient vite fastidieuse lorsque le nombre de composants augmente. Il vous faut alors un point d’accès unique et centralisé pour effectuer plusieurs modifications par lots. C’est là qu’intervient Item Manager (Tools » Item Manager).
Le Item Manager est le « centre de commande » permettant de synchroniser les entités de conception du Workspace, placées sur les feuilles de schéma, avec le contenu source auquel elles sont liées dans un Workspace. Il détecte et répertorie automatiquement tous les composants, indique s’il s’agit ou non d’entités du Workspace, puis compare la révision de l’élément de chaque composant du Workspace présent sur les schémas aux révisions disponibles de ce composant dans le Workspace. Pour chaque entité, des informations sur l’élément actuellement lié sont fournies : sa révision, son état dans le cycle de vie et le Workspace source dans lequel il réside.
Vous gardez le contrôle total sur les entités du Workspace à mettre à jour et sur la manière de procéder. Par exemple :
- Sélectionnez une entrée individuelle et mettez-la à jour pour utiliser la dernière révision de l’élément lié, ou choisissez d’utiliser la dernière révision d’un élément entièrement différent.
- Sélectionnez un groupe d’entrées utilisant le même élément lié et mettez-les à jour vers la dernière révision de cet élément, ou choisissez d’utiliser la dernière révision d’un élément entièrement différent.
Toutes les modifications proposées sont affichées dans le gestionnaire.
Une fois les modifications configurées selon vos besoins, générez un ordre de modification technique (ECO) et examinez les actions qui seront exécutées pour les appliquer. Désactivez certaines actions si nécessaire : vous gardez toujours la maîtrise ! Lorsque vous êtes prêt, exécutez l’ECO pour appliquer les modifications. Rapide et efficace, la gestion du contenu du Workspace placé dans votre conception devient très simple.
Les exemples suivants illustrent l’utilisation du Item Manager :
- Mettre à jour plusieurs composants pour utiliser la dernière révision du composant existant du Workspace.

Mettre à jour un groupe de composants obsolètes vers leurs dernières révisions.
- Remplacer quelques composants par la dernière révision d’un autre composant du Workspace, choisi dans la boîte de dialogue Remplacer un composant.

Remplacer un ou plusieurs composants par un autre composant du Workspace.
Le Item Manager permet non seulement de maintenir les composants de vos conceptions synchronisés avec les modifications du contenu source dans les Workspaces connectés, mais constitue également un outil puissant pour faciliter la migration de vos conceptions de cartes existantes : vous passez ainsi d’éléments de conception locaux à du contenu de conception du Workspace. Une fois vos composants de conception et vos feuilles de schéma (feuilles de circuits) migrés vers un Workspace, utilisez le Item Manager pour « remplacer » les composants et les symboles de feuille existants par leurs nouvelles versions migrées dans le Workspace. Autrement dit, les composants restent identiques du point de vue de la conception, mais leur source change.
Modifier un composant depuis un BomDoc
Il n’est pas rare de détecter un problème avec un composant lors de la vérification du BomDoc et de sa préparation pour la commande des pièces. Par exemple, le concepteur peut avoir oublié de finaliser le choix d’un composant, ou un composant peut être arrivé en fin de vie et le concepteur souhaite alors examiner le prix et la disponibilité de remplacements potentiels. Vous pourriez résoudre ce problème en revenant au schéma pour modifier le composant, sélectionner une pièce adaptée, puis actualiser le BomDoc. Toutefois, ActiveBOM permet d’effectuer cette opération directement depuis le BomDoc, puis de répercuter la modification sur le schéma via un ordre de modification technique.
Dans le BomDoc, faites un clic droit sur le ou les composants sélectionnés et choisissez la commande Operations » Change <ComponentName>. La boîte de dialogue Remplacer un composant s’ouvre et vous permet de rechercher le composant de remplacement. Une fois le composant souhaité trouvé, sélectionnez-le, puis cliquez sur OK. La boîte de dialogue Engineering Change Order s’ouvre et détaille les modifications nécessaires pour synchroniser le schéma avec le BomDoc.

Exemple de remplacement d’un composant directement depuis un BomDoc.
Remplacer un composant générique
Lorsque la conception a suffisamment avancé pour qu’un composant générique puisse être remplacé par un composant physique précis, ouvrez la boîte de dialogue Remplacer un composant en sélectionnant le bouton
dans le panneau Properties. Cette opération peut également être effectuée depuis le Gestionnaire d’éléments ou via le document ActiveBOM du projet.
Les valeurs des paramètres appliquées au composant générique (ici, les valeurs de puissance et de résistance) sont automatiquement utilisées comme termes de recherche dans la boîte de dialogue Replace Generic Component. Vous pouvez ainsi choisir un composant de remplacement adapté parmi les résultats filtrés. Dans cet exemple, deux entrées de composants répondent aux critères de recherche.
|
Remplacer un composant générique via le panneau Properties. Remplacer un composant générique via le panneau Properties. |
Gérer les empreintes dans l’ensemble de la conception
L’éditeur de schémas d’Altium Designer comprend un puissant Footprint Manager. Accessible depuis le menu Outils de l’éditeur de schémas (Tools » Footprint Manager), le Footprint Manager vous permet d’examiner toutes les empreintes associées à chaque composant de l’ensemble du projet. La prise en charge des sélections multiples facilite la modification de l’affectation des empreintes pour plusieurs composants, du mode de liaison des empreintes ou de l’empreinte actuellement affectée aux composants auxquels plusieurs empreintes sont associées. Le Footprint Manager facilite l’examen des affectations d’empreintes et la détection des problèmes dans l’ensemble de la conception, ce qui est particulièrement utile lorsque vous travaillez sur une conception ancienne ou provenant d’une autre organisation. Les modifications de conception sont appliquées via le système ECO, qui met à jour le schéma et le PCB si nécessaire.
La boîte de dialogue Footprint Manager présente une liste de tous les composants figurant sur tous les schémas sources de la conception du projet actif. Utilisez les commandes disponibles à droite de la boîte de dialogue pour gérer les empreintes disponibles pour les composants de la conception et celles qu’ils utilisent actuellement. Les fonctionnalités comprennent :
- L’ajout, la modification et la suppression de modèles d’empreinte pour un ou plusieurs composants sélectionnés.
- La copie d’empreintes entre composants.
- La modification de l’empreinte actuellement affectée (celle qui sera utilisée pour représenter un composant sur le PCB, parmi les différentes empreintes pouvant être disponibles pour ce composant).
- La validation des empreintes, afin de vérifier que les modèles d’empreinte sont effectivement disponibles, en particulier ceux définis comme modèles actuels.
Une fois toutes les modifications nécessaires apportées aux affectations des modèles d’empreinte, elles sont appliquées au moyen d’un ordre de modification technique (ECO) standard. Pour ce faire, cliquez simplement sur le bouton Accept Changes (Create ECO) en bas à droite de la boîte de dialogue Footprint Manager.
Options et commandes de la boîte de dialogue Footprint Manager
Liste des composants
Cette liste contient tous les composants des feuilles de schéma du projet de conception de PCB actuellement actif. Les informations comprennent :
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Affichage et modification des empreintes
Cette liste contient les empreintes associées au composant sélectionné dans la Component List. Utilisez les commandes au bas de la zone ou celles du menu contextuel pour manipuler les empreintes de la liste.
Menu contextuel
-
Add - cliquez pour ouvrir la boîte de dialogue PCB Model et choisir un nouveau modèle d’empreinte à ajouter au composant schématique en surbrillance. Non disponible lorsqu’un composant géré est sélectionné.
-
Remove - cliquez pour supprimer l’empreinte sélectionnée. Non disponible lorsqu’un composant géré est sélectionné.
-
Edit Footprint - cliquez pour ouvrir la boîte de dialogue PCB Model. La boîte de dialogue PCB Model définit le modèle d’empreinte associé au composant schématique et les bibliothèques dans lesquelles l’éditeur de schémas peut rechercher l’empreinte. Non disponible lorsqu’un composant géré est sélectionné.
-
Validate Footprint Paths - cliquez pour vérifier que l’empreinte en surbrillance est accessible à l’emplacement autorisé. Si l’empreinte est introuvable, Not Validated apparaît dans le champ Found In. Si l’empreinte est validée, son chemin d’accès complet s’affiche.
-
Change PCB Library - cliquez pour ouvrir la boîte de dialogue Edit PCB Library afin de changer la bibliothèque PCB de l’empreinte sélectionnée. Cette boîte de dialogue est une version simplifiée de la boîte de dialogue PCB Model, qui donne accès aux options PCB Library pour définir où le logiciel peut rechercher les modèles d’empreinte.

La boîte de dialogue Edit PCB Library- Any - recherche un modèle correspondant dans toutes les bibliothèques disponibles.
- Library name - recherche un modèle correspondant uniquement dans les bibliothèques disponibles portant ce nom.
- Library path - recherche un modèle correspondant uniquement dans une bibliothèque portant ce nom, à cet emplacement. Saisissez manuellement le chemin d’accès et le nom de la bibliothèque, ou cliquez sur le bouton Choose pour ouvrir la boîte de dialogue Windows Open, qui vous permet de parcourir les dossiers jusqu’à la bibliothèque souhaitée.
- Use footprint from source integrated library, database library, or server - recherche le modèle uniquement dans la bibliothèque intégrée, la bibliothèque de base de données ou le serveur depuis lequel le composant a été placé. La bibliothèque intégrée ou la bibliothèque de base de données doit être disponible ; dans le cas d’un serveur, vous devez y être connecté.
-
Copy - cliquez pour copier les détails de l’empreinte actuellement sélectionnée.
-
Paste - cliquez pour coller (ajouter) les détails de l’empreinte copiée dans le composant schématique actuellement sélectionné.
-
Select All - cliquez pour sélectionner toutes les empreintes actuellement visibles dans la liste View and Edit Footprints.
-
Set As Current - cliquez pour définir l’empreinte sélectionnée comme empreinte courante (signalée par un
dans la colonne Current ).
-
Add to All Parts - cliquez pour ajouter l’empreinte sélectionnée à toutes les autres parties du même composant schématique (cette commande n’est disponible que si le composant sélectionné comporte plusieurs parties et que cette empreinte n’est pas définie pour une ou plusieurs d’entre elles).
Commandes supplémentaires
-
Menu - cliquez pour afficher un menu contenant les mêmes commandes que le menu contextuel ci-dessus.
-
Add, Remove, Edit, Validate - ces boutons remplissent les mêmes fonctions que les entrées de menu décrites ci-dessus.
-
Accept Changes (Create ECO) - cliquez pour accepter les modifications apportées aux composants schématiques et à leurs modèles d’empreinte associés, puis ouvrir la boîte de dialogue Engineering Change Order. La boîte de dialogue ECO vous permet de valider et d’appliquer les changements après avoir examiné les modifications apportées aux valeurs d’empreinte des composants schématiques correspondants.












