Progettazione per l’elettronica stampata

A colpo d'occhio

Questo articolo illustra come Altium Designer supporta la progettazione di elettronica stampata, spiegando come i circuiti possano essere stampati direttamente sul substrato di un prodotto anziché essere realizzati come PCB tradizionali. Descrive la tecnologia di base, le differenze tra i processi di stampa additiva e la fabbricazione convenzionale di PCB e il modo in cui Altium Designer gestisce l'elettronica stampata tramite passaggi di stampa con materiali conduttivi e non conduttivi, configurazione dello stack di strati, selezione dei materiali e sbroglio. Chiarisce inoltre le funzionalità attualmente supportate, tra cui l'uso di substrati con superfici piane, e il ruolo delle aree dielettriche nei punti di incrocio dei segnali. Se vuoi capire come configurare e progettare l'elettronica stampata in Altium Designer, questo articolo ti fornirà una base pratica. Continua a leggere per scoprire come questo approccio emergente può ampliare le tue possibilità di progettazione.

- Scopri cos'è l'elettronica stampata, in cosa si differenzia dalla fabbricazione tradizionale di PCB e perché è importante per la progettazione dei prodotti del futuro.
- Scopri come Altium Designer rappresenta l'elettronica stampata attraverso passaggi di stampa, aree non conduttive, configurazione dello stack di strati e definizioni dei materiali.
- Comprendi il flusso di progettazione attuale e i suoi limiti, tra cui il supporto per substrati piani, la generazione degli output standard e lo sbroglio in un progetto di elettronica stampata.
Approfondisci con l'IA:
 

Progettazione di elettronica stampata

Un'interessante evoluzione nella progettazione e nello sviluppo di prodotti elettronici è la possibilità di stampare il circuito elettronico direttamente su un substrato, ad esempio un elemento in plastica stampata che diventa parte del prodotto.

Javascript

Queste diapositive mostrano le viste 2D e 3D di un esempio di layout di elettronica stampata. (Immagine per gentile concessione di "csi entwicklungstechnik", tratta da un loro progetto che utilizza la tecnologia TactoTek® In-Mold Structural Electronics).

Questa tecnica di realizzazione orientata alla superficie è denominata Printed Electronics. Sebbene il termine Printed Electronics non descriva con precisione la tecnologia, poiché la stampa non è l'unica tecnica impiegata per realizzarla, è ampiamente accettato nel settore e verrà utilizzato in questa pagina.

Sono in fase di sviluppo diversi approcci per realizzare l'elettronica stampata, tra cui: la stampa 3D con inchiostri conduttivi; tecniche di stampaggio in grado di creare sia conduttori sia semplici elementi circuitali, come i transistor; e tecniche di deposizione laser che consentono di realizzare percorsi conduttivi su scale estremamente ridotte, con una precisione elevatissima.

L'elettronica stampata diventerà una tecnologia fondamentale, consentendo l'integrazione dell'elettronica in nuovi mercati. Permette infatti una stretta integrazione tra il circuito e il prodotto. Da un sensore flessibile applicato direttamente sul corpo a un elemento stampato multisensore a forma di polpastrello, che consente a una mano robotica di reggere un bicchiere di plastica morbida mentre vi viene versato un liquido, l'elettronica stampata renderà possibile lo sviluppo di nuove soluzioni innovative in numerosi segmenti di mercato. 

La tecnologia

In termini di what offerto dalla tecnologia, il principio rimane lo stesso: i componenti elettronici sono collegati tra loro mediante percorsi conduttivi, formando un circuito elettronico che svolge una funzione utile. Ciò che cambia è l'approccio utilizzato per realizzare il circuito.

La tecnologia di fabbricazione a strati utilizzata per realizzare un PCB tradizionale è un reductive process. Ogni strato conduttivo nasce come un foglio continuo di materiale conduttivo, ad esempio rame, che viene poi rimosso mediante incisione, lasciando soltanto il rame che forma i percorsi conduttivi richiesti. Si tratta inoltre di un processo articolato in più fasi, poiché i singoli strati conduttivi vengono assemblati alternandoli a strati isolanti e sottoposti a diversi processi di foratura e successiva metallizzazione.

L'elettronica stampata è un additive process, in cui i percorsi dei segnali vengono stampati direttamente su un substrato. Se un percorso di segnale successivo deve incrociarne uno esistente, viene stampata una piccola zona isolante direttamente nel punto richiesto. Agendo come un minuscolo ponte, questa consente di stampare il nuovo percorso sopra quello esistente, senza creare un collegamento elettrico tra i due. Ad esempio, se il progetto utilizza la tecnologia DuPont InMold, il circuito viene prima stampato su un substrato plastico piano, che viene poi termoformato e sottoposto a stampaggio a iniezione per ottenere la forma finale del prodotto. 

Con l'elettronica stampata, il comune substrato rigido in fibra di vetro del circuito stampato non è più necessario. Il circuito viene invece realizzato direttamente come parte del prodotto, con i conduttori che seguono la forma e i contorni della sua superficie. Grazie al minore impiego di materiale e alla riduzione degli scarti, in molte situazioni l'elettronica stampata diventerà un approccio più conveniente rispetto a un PCB tradizionale. 

NOTE - attualmente, le funzionalità di progettazione di elettronica stampata di Altium Designer supportano soltanto superfici di substrato piane. Per la progettazione di circuiti completamente 3D, è già disponibile lo strumento dedicato alla progettazione 3D-MID di Altium Designer.

Consulta la pagina della funzionalità Progettazione True 3D-MID  per una panoramica delle funzionalità.

Consulta la pagina della documentazione Progettazione 3D-MID per saperne di più.

Progettazione di elettronica stampata in Altium Designer

A parte il substrato su cui viene stampato il progetto, un prodotto di elettronica stampata non presenta strati fisici: i percorsi conduttivi vengono stampati direttamente sul substrato. Nei punti in cui il progetto richiede che i percorsi si incrocino, viene stampata una piccola zona di materiale dielettrico, estesa sufficientemente oltre l'incrocio per garantire il livello di isolamento richiesto tra i diversi segnali. 

I file di output necessari per il processo di stampa vengono generati utilizzando un formato di output standard, come Gerber.

Gli output includeranno un file per:

  • Ogni passata di stampa conduttiva, sostanzialmente equivalente a uno strato di instradamento in rame di un PCB tradizionale
  • Ogni passata di stampa dielettrica: poiché le zone dielettriche vengono stampate, anche le loro forme sono specificate in un file di output, ad esempio un file Gerber.

Definizione dello stackup

Come si definiscono queste molteplici passate di stampa nell'editor PCB? Nell'elettronica stampata, ogni passata di stampa richiede un file di output; pertanto, anziché pensare a una serie di strati di rame separati da strati dielettrici, occorre pensare a un insieme di passate di stampa, ciascuna delle quali deposita uno strato di inchiostro conduttivo oppure non conduttivo.

Per creare un progetto di elettronica stampata, crea innanzitutto un nuovo PCB utilizzando File » New » PCB dai menu principali.

La configurazione di una nuova scheda come progetto di elettronica stampata viene eseguita nel Layer Stack Manager. Scegli Design » Layer Stack Manager dai menu principali per accedere a Layer Stack Manager. Utilizza il menu a discesa  , quindi seleziona Printed Electronics oppure seleziona Tools » Features » Printed Electronics dai menu principali.

Per impostazione predefinita, un nuovo PCB presenta due strati di rame separati da uno strato dielettrico.Per impostazione predefinita, un nuovo PCB presenta due strati di rame separati da uno strato dielettrico.

Quando la funzionalità Printed Electronics è abilitata, lo strato dielettrico tra i due strati di rame scompare. Perché? Perché l'elettronica stampata richiede un file di output per ogni strato; gli strati dielettrici non vengono quindi utilizzati, poiché non servono a generare file di output.

Quando la funzionalità Printed Electronics è abilitata, lo strato dielettrico viene rimosso.Quando la funzionalità Printed Electronics è abilitata, lo strato dielettrico viene rimosso.

Al suo posto vengono aggiunti strati non conduttivi. Su questi strati è possibile definire manualmente o automaticamente forme dielettriche, denominate zone isolanti, in tutti i punti in cui i percorsi dei segnali devono incrociarsi sugli strati conduttivi.

Non-Conductive possono essere inseriti tra gli strati Conductive  ed è possibile definirvi le zone dielettriche.
Non-Conductive possono essere inseriti tra gli strati Conductive ed è possibile definirvi le zone dielettriche.
Fai clic con il pulsante destro del mouse su uno strato per inserire uno strato sopra o sotto, spostare uno strato verso l'alto o verso il basso oppure eliminare uno strato. L'elettronica stampata non utilizza gli strati Bottom Solder e Bottom Overlay; questi sono stati rimossi.

Una volta aggiunti gli strati, imposta le proprietà del materiale per ciascuno di essi.

Utilizza il pulsante con i puntini di sospensione per selezionare il materiale da utilizzare per ciascuno strato stampato.Utilizza il pulsante con i puntini di sospensione per selezionare il materiale da utilizzare per ciascuno strato stampato.

Selezione del materiale

I materiali utilizzati sia nella progettazione di PCB tradizionali sia nella progettazione di elettronica stampata vengono selezionati nella libreria dei materiali del Layer Stack Manager.

Quando il Layer Stack Manager è aperto, utilizza il comando Tools » Material Library per aprire la finestra di dialogo Altium Material Library.

  • La finestra di dialogo Altium Material Library include materiali per strati sia conduttivi sia non conduttivi.
  • È possibile definire nuovi materiali nella libreria facendo clic sul pulsante New nella parte inferiore della finestra di dialogo. Se vengono creati materiali personalizzati, è possibile salvarli in una libreria di materiali personalizzata e caricarli da essa.
  • Per selezionare un materiale per uno strato specifico, fai clic sul pulsante con i puntini di sospensione () nella cella Material di quello strato nel gestore dello stack degli strati. Si aprirà la finestra di dialogo Select Material, che mostra solo i materiali adatti al tipo di strato. Seleziona il materiale desiderato e fai clic su OK.

Pannello Proprietà

Quando la scheda Printed Electronics Stackup del documento dello stack degli strati è attiva, il pannello Properties consente di modificare e configurare le proprietà degli strati dello stack per un progetto di elettronica stampata.

  • Layer
    • Name – il nome dello strato.
    • Manufacturer – il produttore dello strato.
    • Material – il materiale dello strato. Può essere predefinito nel campo Constructions della finestra di dialogo Altium Material Library (Tools » Material Library), oppure definito dall'utente nello stack degli strati. Fai clic su per aprire la finestra di dialogo Seleziona materiale e scegliere il materiale desiderato per lo strato attualmente selezionato nello stack.
    • Thickness – lo spessore dello strato di segnale.
    • Dk – la costante dielettrica (indicata anche come εr in elettromagnetismo). Indica la permittività relativa di un materiale isolante, ovvero la sua capacità di immagazzinare energia elettrica in un campo elettrico. Ai fini dell'isolamento, è preferibile un materiale con una costante dielettrica inferiore, mentre nelle applicazioni RF può essere auspicabile una costante dielettrica superiore. Inoltre, quanto più bassa è la costante dielettrica relativa, tanto più le prestazioni del materiale si avvicinano a quelle dell'aria. Questa proprietà è fondamentale per soddisfare i requisiti di impedenza di determinate linee di trasmissione.
    • Df – il fattore di dissipazione. Indica l'efficienza del materiale isolante attraverso il tasso di perdita di energia per una determinata modalità di oscillazione, ad esempio meccanica, elettrica o elettromeccanica. In altre parole, è la proprietà di un materiale che descrive quanta energia trasmessa viene assorbita dal materiale stesso. Maggiore è la tangente di perdita, maggiore è l'assorbimento di energia nel materiale. Questa proprietà influisce direttamente sull'attenuazione del segnale alle alte velocità.
    • Frequency – la frequenza alla quale viene testato il materiale e alla quale corrispondono i valori di Dk / Df. Anche la frequenza viene ricavata dai dati di riferimento del materiale.
    • Description – inserisci una descrizione significativa.
    • Color – il colore desiderato della maschera di saldatura. Fai clic per aprire un menu a discesa e impostare o modificare il colore.
    • Solid – N/D
    • Material Frequency – N/D
    • GlassTransTemp – la temperatura di transizione vetrosa (nota anche come TG), ovvero la temperatura alla quale la resina passa da uno stato vetroso a uno stato amorfo, modificando il proprio comportamento meccanico, ossia il tasso di espansione.
    • Note – inserisci eventuali note pertinenti per lo strato.
    • Comment – inserisci eventuali commenti necessari per lo strato.
  • Board
    • Library Compliance – quando questa opzione è abilitata, per ogni strato selezionato dalla libreria dei materiali, le proprietà attuali vengono confrontate con i valori della definizione del materiale presente nella libreria.
    • Layers – il numero di strati conduttivi.
    • Dielectrics – il numero di strati dielettrici.
    • Conductive Thickness – la somma degli spessori di tutti gli strati di segnale e dei piani (tutti gli strati in rame o conduttivi).
    • Dielectric Thickness – lo spessore dello strato o degli strati dielettrici.
    • Total Thickness – lo spessore totale della scheda finita.
  • Other

Roughness – mostra la rugosità degli strati conduttivi.

  • Model Type – il modello preferito per calcolare l'impatto della rugosità superficiale (per maggiori informazioni sui vari modelli, consulta gli articoli riportati di seguito). Si applica a tutti gli strati di rame dello stack.
  • Surface Roughness – il valore della rugosità superficiale (disponibile presso il produttore). Inserisci un valore compreso tra 0 e 10 µm; il valore predefinito è 0,1 µm.
  • Roughness Factor – caratterizza il massimo incremento previsto delle perdite nel conduttore dovuto all'effetto della rugosità. Inserisci un valore compreso tra 1 e 100; il valore predefinito è 2.

Instradamento delle reti

  • Le reti in un progetto di elettronica stampata vengono instradate come in un PCB tradizionale, utilizzando il comando Interactive Routing.
  • I passaggi tra strati conduttivi vengono eseguiti utilizzando i tasti + e - del tastierino numerico oppure la scorciatoia Ctrl+Shift+Wheelroll.
  • Quando cambi strato durante l'instradamento, viene aggiunto un via, le cui proprietà sono determinate dalla regola di progettazione applicabile relativa allo stile dei via di instradamento.

I via sono necessari?

Il software deve inserire un via per mantenere la connettività della rete durante l'instradamento e per gestirla quando l'instradamento viene modificato mediante spostamento a spinta o trascinamento. I via non sono necessari per la connessione tra strati: il software presuppone che le piste sovrapposte su strati diversi siano collegate.

Il diametro dei via può essere impostato sullo stesso valore della larghezza delle piste.

Aumento dello spessore delle piste

Se necessario, è possibile aumentare lo spessore delle piste, ad esempio per realizzare una struttura come un'antenna stampata. Questo si ottiene posizionando più piste una sopra l'altra, su strati conduttivi diversi.

Aggiunta di forme dielettriche

Una volta instradate le reti, il passaggio successivo consiste nel creare le zone dielettriche necessarie per separare gli incroci tra reti diverse. Le forme dielettriche vengono definite su strati non conduttivi. Possono essere definite manualmente o create automaticamente utilizzando Dielectric Shapes Generator.

Le forme manuali possono essere create a partire da archi, linee, riempimenti o regioni solide. Gli oggetti regione solida offrono la massima flessibilità, poiché i loro bordi possono essere modificati per creare praticamente qualsiasi forma.

Generatore di forme dielettriche

Il software include anche un Dielectric Shapes Generator automatico. Il principio consiste nel completare prima l'instradamento sugli strati conduttivi secondo necessità, inserendo via per passare da uno strato all'altro.

Per accedere al generatore di forme dielettriche in Altium Designer, è necessario installare l'estensione software Printed Electronics Crossover Generator. Questa estensione può essere installata o rimossa manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Una volta completato l'instradamento, esegui il comando Tools » Printed Electronics » Generate Dielectric Patterns per aprire la finestra di dialogo Dielectric Shapes Generator. Quando viene eseguito, il generatore di forme dielettriche rimuove tutte le forme sugli strati di destinazione e poi le ricrea. Se sono state definite forme manualmente, bloccale prima di eseguire Dielectric Shapes Generator.

Connettività delle net e controlli delle regole di progettazione

Il DRC online non è supportato quando lo stack degli strati è configurato come Printed Electronics, a causa della diversa logica utilizzata per definire le condizioni di violazione; ad esempio, le net che si incrociano su strati diversi vengono segnalate come cortocircuiti. Una volta completato lo sbroglio e definite le patch isolanti, fare clic sul pulsante Run Design Rule Check nella finestra di dialogo Design Rule Checker (Tools » Design Rule Check) per eseguire un DRC batch.

Note sulla connettività delle net e sui controlli delle regole di progettazione:

  • Quando una net deve passare a un altro strato conduttivo, inserire una via. In questo modo i segmenti di pista vengono gestiti correttamente se lo sbroglio viene trascinato o spinto.
  • Le piste che si toccano o si incrociano su strati diversi sono considerate connesse. Se appartengono alla stessa net, non viene segnalata un'interruzione della net; se appartengono a net diverse, viene segnalato un cortocircuito.
  • Per isolare le piste che si toccano o si incrociano è necessaria una forma dielettrica, posizionata su uno strato non conduttivo. La forma dielettrica può essere posizionata manualmente oppure tramite Dielectric Shape Generator. La forma dielettrica deve estendersi oltre i bordi delle piste che si incrociano in misura sufficiente a soddisfare la regola di progettazione relativa al vincolo di distanza minima applicabile.
  • In un progetto di elettronica stampata, i controlli delle regole di progettazione relativi a cortocircuiti, violazioni della distanza minima e net non sbrogliate si comportano come descritto di seguito.

Regola di progettazione per i cortocircuiti

In un progetto Printed Electronics, quando net diverse si incrociano su strati diversi, vengono segnalate come cortocircuiti. Questi incroci vengono isolati posizionando una patch dielettrica su uno strato non conduttivo.

Regola di progettazione per la distanza minima

Le distanze minime tra le net vengono verificate su tutti gli strati, non solo sullo stesso strato.

Net non sbrogliata

Le transizioni tra strati non richiedono una via: l'analizzatore delle net riconosce che la net non è interrotta.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents