ActiveRouteガイド付きインタラクティブルータの使用
概略
- ActiveRouteとオートルーターの違いを理解し、選択したネットをガイドに沿って高品質に配線するうえで、ActiveRouteがより適している理由を把握できます。
- 配線ガイド、複数レイヤーでの配線、グロス処理、チューニング、ミアンダー制御、ピンスワップなど、ActiveRouteの主な機能を学べます。
- PCB ActiveRouteパネルを使用して、設計ルールと配線の目標に基づいてActiveRouteを設定し、実行する方法を確認できます。
基板設計で最も時間のかかる工程の1つが、ネットの配線です。配線幅、ビアサイズ、クリアランスなどの設計制約はルールシステムが管理しますが、基板全体の配線を完了するために必要な数千ものトラックセグメントを配置するのは、設計者自身です。
オートルーターはこの負担を軽減できますが、一般的には次の理由から不十分と見なされています。
-
人間の設計者が配線時に直感的に考慮する、無数の細かな設計制約を適切に考慮できません。
-
設定をすべて整えるのに時間がかかるため、最初からインタラクティブに配線する方が効率的な場合がよくあります。
-
配線後の修正に多大な時間と手間がかかり、インタラクティブに配線する方が効率的な場合がよくあります。
PCB配線の究極の目標は、設計者の制御のもとで、設計ルールを満たす高品質な配線を短時間で実現することです。 ActiveRouteは、この課題の解決を目指しています。
ActiveRouteとは?
ActiveRouteは、効率的なマルチネット配線アルゴリズムを備えた自動インタラクティブ配線技術で、選択した特定のネットや接続に適用されます。また、設計者はActiveRouteを使用して、配線経路またはガイドをインタラクティブに定義できます。このガイドによって、新しい配線が通るthe riverが定義されます。
通常のインタラクティブ配線と自動配線を組み合わせる方法と比べて、この手法を大幅に優れたものにしているActiveRouteの主な機能は、次のとおりです。
- 手動配線で最も時間のかかる、ピン/ビア配列からの引き出し配線を自動的に最適化します。
- 高い処理性能により、信号ネットを1本あたり1秒未満で配線します。
- 優先順位を考慮しながら、ネットおよびネットクラスごとに設定された配線幅、クリアランス、レイヤー、トポロジー、ルームの設計ルールに従います。
- 複数のレイヤーで同時に配線し、それらのレイヤーに配線を分散します。
- 設計者が配線の配置を指示できる、直感的なRoute Guideを備えています。
- River Route方式を使用し、ビアを使用せずに高い配線完了率を実現します。
- ポリゴンプレーンを通して配線し、再ポアできます(再ポアオプションが有効な場合)。
- シングルエンドネットと差動ペアネットの両方に対応しています。
- 最後に強力なGlossingツールを実行し、コーナーの数をさらに減らして配線長を短縮します。
PCB ActiveRouteパネル
ActiveRouteはPCB設計ルールで定義された条件と制限に従うため、対象の接続またはネットを選択して実行するだけで使用できます。 また、PCB ActiveRouteパネルで設定できる専用の制御機能も用意されています。 PCB ActiveRoute パネルでは、インタラクティブなActiveRouteの実行、Route Guideとその内部の配線間隔の定義、自動配線長調整の有効化、自動ピンスワップの有効化など、ActiveRouteが提供するさまざまな機能を設定、操作できます。ActiveRouteを開始する前に、PCB ActiveRouteパネルを開いておくことを強くお勧めします。
PCBがアクティブなドキュメントになっている状態で、 PCB ActiveRouteパネルを開くには、次の操作を行います。
-
ワークスペースの右下にある
ボタンをクリックし、 PCB ActiveRouteメニューオプションを選択します。
-
View » Panels » PCB ActiveRouteをクリックします。
PCB ActiveRouteパネルを使用して、ActiveRouteの処理を制御します。
PCB ActiveRouteパネルでは、次の操作を行えます。
- ActiveRouteで接続を配線できる信号レイヤーを有効にします。
- 選択した接続に対してActiveRouteを実行します。
- ActiveRouteの実行後にGlossing処理を行うように設定します。
-
Route Guideを定義します。
- Route Guide内で使用するトラック間隔を設定します。
- ActiveRouteで配置した配線の配線長調整を設定し、有効にします。
- Meanderオプションを設定します。このオプションでは、ActiveRouteがより長い配線経路を定義できるようになり、配線完了率の向上につながる場合があります。
- ピンスワップを設定し、有効にします。ActiveRouteは配線中にピンスワップを行い、配線品質を向上させることができます。
PCB ActiveRoute パネルの内容は折りたたみ可能なセクションに分かれており、各セクション見出しにある►アイコンで開閉できます。以下のプロパティコントロールの説明も、対応するセクションごとにまとめられており、各折りたたみセクションは同じ方法で開閉できます。
操作
ActiveRouteの制御に使用する主なオプションです。
-
ActiveRoute - パネル内の
ボタンをクリックすると、選択した接続に対してActiveRouteが実行されます。ActiveRouteは、選択した接続の配線を試みます。パッドまたはビアが選択されている場合は、それらが属するネットのすべての接続が対象となります。選択方法の詳細については、ActiveRouteのページを参照してください。
-
Route Guide - Route Guideは、選択した接続をActiveRouteが配線する範囲を指定する、ユーザー定義の経路です。ActiveRouteの主な目的の1つは、配線長の合計が最短になる配線の組み合わせを見つけることですが、その経路が、すべての接続群で意図した経路になるとは限りません。Route Guideを使用すると、選択した接続を通したい特定の経路を設計者が描くことができます。Route Guideの色は、選択した接続のActiveRouteで使用できるレイヤーによって決まります。有効なレイヤーが1つの場合はそのレイヤーの色で描画され、複数のレイヤーが有効な場合はデフォルトのRoute Guideの色で描画されます。
-
Route Guideを定義するには、まずガイド内で配線する接続を選択し、
をクリックします。パネルのボタンをクリックし、次にクリックしてガイドの開始位置を指定します。その後、マウスを動かしてクリックしながら経路を指定します。経路を指定したら、ActiveRoute ボタンをクリックして、選択した接続をその経路に沿って配線します。
-
Route Guideの配置中は、
キーまたは
キーを押すことで、ガイドの幅を広げたり狭めたりできます。デフォルトの幅は、選択した接続に適用される配線幅とクリアランスのデザインルールの合計を、レイヤー数で割り、1.3を掛けた値です。別の経路を指定する必要がある場合は、Backspace キーを押してガイドを巻き戻します。
- ActiveRouteはデザインルールに従って配線間隔を確保しようとしますが、Route Guide内で配線を広げたり、利用可能なスペースをすべて使用したりすることはありません。Route Guide内で配線間隔を広げるには、このページの後半で説明する Track-Track Space in Route Guide 機能を使用します。
-
Route Guideを定義するには、まずガイド内で配線する接続を選択し、
-
Tune Selected - このオプションを有効にすると、パネルのTuneセクションで有効になっている、適用可能なMatched Lengthsルールのうち、最も優先順位の高いルールが適用されます。
-
Pin Swap Routing – PCBエディターはピンスワップに対応しています。このオプションを有効にすると、ActiveRouteが配線処理中にピンスワップを実行できるようになります。このオプションを有効にするだけでなく、以下で説明するように、パネルの Pin Swap セクションで対象のコンポーネントも有効にする必要があります。ピンスワップシステムの詳細については、ピン、ペア、パーツのスワップ ページを参照してください。
-
Gloss Results – このオプションを有効にすると、ActiveRouteの結果にグロス処理が自動的に適用されます。選択した既存の配線にもグロス処理を適用できます。その場合は、Route » Gloss Selected コマンド(Ctrl+Alt+G)を実行します。詳細については、既存配線のグロス処理と再トレース ページを参照してください。
レイヤー
ActiveRouteは複数のレイヤーで同時に配線できます。レイヤーを変更するためのビアは配置できませんが、使用可能なレイヤーに接続やネットを分散させることはできます。使用可能なレイヤーは、パネルのLayersセクションで設定します。
- Show Signal Layers Only – デフォルトでは、使用可能なすべての信号レイヤーとプレーンレイヤーが表示されます。このオプションを有効にすると、信号レイヤーのみが表示されます。
- List of Layers – ActiveRouteによる信号の配線を許可する信号レイヤーを有効にします。ActiveRouteは、使用可能な信号レイヤーに接続を分散させます。ActiveRouteはレイヤーを変更するためのビアを配置しないことに注意してください。
制御
これらのコントロールは、適用されるクリアランスのデザインルールを満たす配線間隔に対するActiveRouteの制約を緩和し、接続を完了するために迂回する経路を使用できるようにするためのものです。
- Track-Track Space in Route Guide – このコントロールは、Route Guideに沿って配線する接続の間隔(配線の中心間距離)を、ActiveRouteがどの程度広げるかを指定するために使用します。間隔に合わせてガイド幅が正しく計算されるように、Route Guideを指定する前に設定する必要があります。スライダーで値を選択するか、編集ボックスに距離を入力します。
-
Meander % Over Manhattan Length – ActiveRouteは、選択した接続を可能な限り最短の経路で、つまり迂回を最小限に抑えて配線しようとします。ActiveRouteの配線完了率が予想より低い場合は、許容する迂回量を増やすことで完了率が向上することがあります。Meanderのデフォルトの最大設定値は100%で、配線の総延長として
Manhattan Length + 100% of Manhattan Lengthが許容されることを意味します。スライダーで値を選択するか、編集ボックスにパーセンテージを入力します。Route Guideは迂回量が大幅に増える可能性のある経路を指定するためのものなので、Route Guideの使用時にはMeander設定が無視されることに注意してください。
チューニング
ActiveRouteは、現在配線中の接続、または選択した既存の配線に長さチューニングを適用できます。
-
Match Length Rules for Selected – 定義済みのすべてのMatched Lengthsデザインルールがここに表示されます。選択した接続に対してActiveRouteで使用するルールを有効にします。
-
Single Ended – シングルエンド信号のチューニングに使用するアコーディオン形状のプロパティです。
- Max Amplitude - チューニング用アコーディオン形状の最大許容振幅です。既存のパッド、ビア、配線などの障害物がある場合は、デザインルールで定められたクリアランスを維持するために振幅が自動的に小さくなります。
- Min Space - アコーディオン形状のゼロ交差部分間の最小エッジ間隔です。
-
Differential Pair - 差動ペアのチューニングに使用するアコーディオン形状のプロパティです。
- Max Amplitude - 差動ペアの外側の配線に対する、チューニング用アコーディオン形状の最大許容振幅です。配置の障害物がある場合は、デザインルールで定められたクリアランスを維持するために振幅が自動的に小さくなります。
- Min Space - 差動ペアの内側の配線に対する、アコーディオン形状のゼロ交差部分間の最小エッジ間隔です。
ピンスワップ
コンポーネント内の機能的に等価なピンは、スワップ可能に設定できます。設定するには、Tools » Pin/Part Swapping » Configure コマンドを選択します。ピンスワップを実行する前には、対話操作の場合でもActiveRouteによる場合でも、プロジェクトを開くたびにコンパイル(Project メニュー)する必要があります。
- Components with Pin Swap Enabled – ピンスワップが有効になっているすべてのコンポーネントがここに表示されます。ActiveRouteの実行中に自動スワップを許可するコンポーネントを有効にします。
ActiveRouteの追加機能
ActiveRouteは自動化されたインタラクティブルーターで、 使い方は簡単です。 接続を選択し、 Shift+A を押すだけで、 デザインルールに従ってActiveRouteによる配線が実行されます。ActiveRouteには、このほかにもさまざまな機能やコントロールが用意されており、設計者は特定の機能や動作をより細かく制御できます。
主な機能は次のとおりです。
- Route Guideを配置して、配線経路と配線間隔を指定します。
- Meanderコントロールで、より長い配線経路を許可します。
- 長さチューニングで配線長を自動的に揃えます。
- ピンスワップを許可して、配線を容易にします。
それぞれについて詳しく見ていきましょう。
Route Guideで経路を指定する
ActiveRouteの主な目的の1つは、配線長の合計が最短となる経路の組み合わせを見つけることです。ただし、それがすべての接続グループにとって望ましい経路とは限りません。Route Guideを使用すると、最短経路でなくても、選択した接続を通したい特定の経路を設計者が描くことができます。
-
Defining the Route Guide - まず、ガイド内で配線する接続を選択し、
をクリックします。 PCB ActiveRouteパネルのボタンをクリックし、次にクリックしてガイドの開始位置を指定します。 続けてマウスを移動し、クリックして経路を指定します。経路を指定したら、ActiveRouteボタンをクリックして、選択した接続をその経路に沿って配線します。詳細については、このページの後半にあるルートガイドの定義セクションを参照してください。
-
Changing the Route Guide Width - ルートガイドの配置中に、
キーまたは
キーを押すと、ガイドの幅を広げたり狭めたりできます。デフォルトの幅は、選択した接続に適用される配線幅とクリアランスのデザインルール値の合計を、レイヤー数で割り、1.3を掛けた値です。別の経路を指定する必要がある場合は、Backspaceキーを押してガイドを直前の状態に戻します。
- The Route Guide color - 選択した接続のActiveRouteで使用可能なレイヤーによって決まります。有効なレイヤーが1つの場合は、そのレイヤーの色で描画されます。 複数のレイヤーが有効な場合は、ルートガイドのデフォルトの色で描画されます。
- The track spacing within the Route Guide - デフォルトでは、ActiveRouteはデザインルールに従って配線間隔を設定し、ルートガイド内の使用可能なスペース全体に配線を広げたり、すべてのスペースを使用したりはしません。ルートガイド内で配線を広げるには、このページの後半で説明するルートガイド内のトラック間隔機能を使用します。

ルートガイドの配置中に、幅をインタラクティブに変更する様子を示した動画。
ルートガイド内のトラック間隔
ルートガイド内のトラック間隔機能を使用すると、ルートガイドの幅全体に配線を広げるようActiveRouteに指示できます。スライダーで間隔の値を選択するか、編集ボックスに値を入力します。この設定を考慮して、ルートガイドのサイズが自動的に調整されます。この動作を有効にするには、ルートガイドを配置する前にTrack-Track Space in Route Guide設定を構成する必要があります。また、配置中に
キーと
キーを押して、ルートガイドの幅をさらに調整できます。

トラック間隔機能を使用して、ルートガイド内の配線を広げます。
配線の蛇行を許可する
ActiveRouteは、選択した接続を可能な限り最短の経路で配線しようとします。つまり、蛇行を最小限に抑えます。ActiveRouteの配線完了率が予想より低い場合は、MeanderコントロールでActiveRouteに許可する蛇行量を増やすことで、完了率が向上する可能性があります。Meanderの最大値のデフォルト設定は100%で、配線の総延長としてManhattan Length + 100% of Manhattan Lengthまで許容されることを意味します。スライダーで蛇行量を選択するか、 編集ボックスにパーセンテージを入力します。
ルートガイドを使用する場合、蛇行の設定は無視されることに注意してください。 ルートガイドは、蛇行が大幅に増える可能性のある経路を指定するためのものだからです。
配線長のチューニング
ActiveRouteは、現在配線中の接続、 または選択した既存の配線に対して、配線長チューニングを適用できます。ActiveRouteは、選択したMatched Lengthsデザインルールを満たすように処理します。
ActiveRouteで配線長チューニングを行うには、次のように設定します。
-
パネルのAction領域にあるTune Selectedチェックボックスを有効にします。
-
パネルのTune領域で、必要なMatched Lengthsデザインルールを有効にします。
-
パネルのTune領域で、必要なMax AmplitudeおよびMin Spaceの設定(シングルエンドまたは差動ペア)を構成します。
ピンスワップ
このソフトウェアには、回路図エディターとPCBエディター間で連携する、強力なピンおよびパーツのスワップ機能が搭載されています。ActiveRouteはピンスワップ設定にアクセスし、配線全体の長さを短縮して配線品質を向上できる場合、配線中にピンをスワップできます。
ピンスワップを使用するには:
- ピンスワップを実行するには(インタラクティブ操作でもActiveRouteでも)、プロジェクトを開くたびにコンパイルする必要があります(Projectメニュー)。
- コンポーネントのピンスワップ設定を構成・管理するには、Tools » Pin/Part Swapping » Configureコマンドを実行してConfigure Swapping Information in Componentsダイアログを開きます。
- PCB ActiveRouteパネルのAction領域にあるPin Swap Routingオプションを有効にします。
- PCB ActiveRouteパネルのPin Swap領域で、必要なコンポーネントを有効にします。
ActiveRouteの準備
2. 既存のポリゴンをシェルフに移動
ActiveRouteは、PreferencesダイアログのPCB Editor - GeneralページでRepour Polygons after Modificationオプションが有効になっている場合、既存のポリゴンを通過して配線できます。また、Tools » Polygon Pours » Shelve Polygonsコマンドを使用して、ポリゴンをシェルフに移動する(非表示にし、デザイン内には保持する)こともできます。
3. デザインルールを設定
- クリアランス – ActiveRouteは、適用対象のクリアランスデザインルールを優先順位に従って適用します。
- 配線幅 – 適用対象の配線幅ルールのPreferred設定を使用します。インタラクティブ配線と同様に、特定の領域(たとえばBGAの下を通る部分)で配線幅を変更するには、より狭いPreferred幅の配線幅デザインルールを適用するRoomを定義します。Preferred幅で手動配線できない場合は、ActiveRouteでも配線できません。
- 差動ペア – ActiveRouteは差動ペアを配線できます。差動ペアが正しく定義されていることを確認し(PCBパネルのDifferential Pairs Editorモードで確認)、差動ペア配線ルールが正しく設定されていることを確認してください(Preferred値が使用されます)。
- パッドへの進入 – ActiveRouteは、鋭角を作らずにルールを守りながら、パッドに出入りする最も直接的な経路を使用しようとします。SMT to CornerルールとSMT Pad Entryルールに従いますが、トラックを常にパッドの中央に配置するわけではありません(インタラクティブルーターは、SMT to Cornerルールが有効な場合、中央に配置します)。差動ペアのパッドには専用のアルゴリズムを使用し、整った配線を維持しながらペアの結合を重視します。
4. ネットトポロジーを設定
ActiveRouteは、接続線のパターンに従います。DDR3/4のフライバイなど、特定のトポロジーが必要なネット群がある場合は、xSignalsを使用して接続元から接続先への順序を定義できます。xSignals Multi-Chip Wizard(Design » xSignals » Run xSignals Wizard)では、DDR3/4やUSB 3.0タイプの信号を含むデザイン用のxSignalsを作成できます。また、PCBパネルのFrom-To EditorモードでFrom-Toを作成することで、ネットのポイントツーポイント接続線パターンを定義することもできます。
5. デザインをファンアウト
ActiveRouteはビアを配置しないため、BGA、コネクター、SMTピンを使用するディスクリート部品には、ファンアウトを作成する必要があります(外層で配線するピンは除きます)。
6. 電源とグランドを配線
ActiveRouteは信号ネット用です。電源プレーンに割り当てられたネットと、20を超えるピンを含むネット(電源ネットとみなされます)は無視します。完成済みのデザインでActiveRouteを使用する場合は、信号配線を削除し、電源配線、グランド配線、およびファンアウトは残してください。
7. 必要な配線レイヤーを有効化
PCB ActiveRouteパネルで、必要な配線レイヤーを有効にします。詳細は後述します。
ActiveRouteの実行
ActiveRouteを実行するには:
1. 配線する接続を選択
配線を選択するための方法ページで説明されている方法を使用して、配線する接続またはネットを選択します。接続は直接選択することも、ピン、トラック、ビア、部品などの配線オブジェクトを選択して選択することもできます。カーソルが別のオブジェクト上に移動するまで、ステータスバーには選択した接続の数が表示されます。
- 接続を選択した場合、適用対象の配線幅デザインルールで定義されたPreferred幅で配線されます。
- 既存の配線を選択した場合、選択したトラックにつながる接続は、そのトラックの幅で配線されます。
- 部品のパッドを選択した場合、選択したパッドからのすべての接続が、ルールのPreferred設定で配線されます。
2. ActiveRouteで配線するレイヤーを有効化
PCB ActiveRouteパネルで、選択した接続を配線するレイヤーを有効にします。ActiveRouteは、これらのレイヤーに配線を分散します。
レイヤーが選択されていない場合は、アクティブレイヤーに配線します。アクティブレイヤーは、メインPCBエディターウィンドウの下部で選択されているタブのレイヤーです。
PCB ActiveRouteパネルでは、配線するレイヤーの選択、ルートガイドの作成、ActiveRouteの開始ができます。
3. 必要に応じてルートガイドを定義
ルートガイドを配置するには:
- ルートガイドに沿って配線する接続を選択します。カーソルが別のオブジェクト上に移動するまで、ステータスバーには選択した接続の数が表示されます。
- PCB ActiveRouteパネルのRoute Guideボタンをクリックします。
- カーソルが選択したすべての接続をholdingしているように表示され、この接続群がガイドを通過する必要があることを示します。定義する経路のどちらか一方の端で、適切な開始位置にカーソルを移動します。
- クリックしてガイドの開始位置を定義します。このとき、接続がガイドの丸みを帯びた端部に入るためのスペースを確保します。
- ガイドは、非常に幅の広いトラックのように配置されます。ガイドの最初のコーナーを設ける位置にカーソルを移動し、クリックしてそのコーナーを定義します。
- この経路定義の操作を繰り返し、接続線の終端から少し離れた位置で止めます。接続がガイドから出て、接続先のパッド、ビア、トラック端に到達するためのスペースを確保してください。
- Up Arrowキーを押すとガイドの幅が広がり、Down Arrowキーを押すと狭くなります。
- Backspaceを押すと、ガイドの最後のコーナーを削除できます。
- 右クリックして、ガイド配置モードを終了します。
一度に定義できるルートガイドは1つだけです。
4. ActiveRouteの実行
ActiveRouteを実行するには、次のいずれかの操作を行います。
- Route » ActiveRouteコマンドを選択します。
-
Active BarのActiveRoute (
) ボタンをクリックします。
- PCB ActiveRouteパネルのActiveRouteボタンをクリックします。
- Shift+Aショートカットを使用します。
5. 進行状況とフィードバックの確認
- PCBエディターのステータスバーにActiveRouteの進行状況が表示されます。
- Messagesパネルに完了率が表示されます。
使いこなすためのヒント
-
ActiveRouteを使いこなすうえで重要なのは、ショートカットに習熟することです。よく使用するキー操作は次のとおりです。
- Alt+Click - 個々の接続線を選択します。
- Alt+Click&Drag - 領域内の接続線を選択します。右から左にドラッグすると、選択範囲に触れるすべての接続線が選択されます。左から右にドラッグすると、選択矩形内に完全に収まる接続線だけが選択されます。Tabを押すと、同じネットに属する他の接続線も含むように選択範囲が拡張されます。カーソルを別のオブジェクト上に移動するまで、選択した接続線の数がステータスバーに表示されます。
- Ctrl+Click&Drag - コンポーネント内のパッドを選択します。右から左にドラッグすると、選択範囲に触れるすべてのパッドが選択されます。左から右にドラッグすると、選択矩形内に完全に収まるパッドだけが選択されます。Tabを押すと、同じネットに属する他の配線オブジェクトも含むように選択範囲が拡張されます。Tabを繰り返し押すと、選択可能なすべての状態が順番に切り替わります。
- Click&Drag - 既存のトラックセグメントを選択します。右から左にドラッグすると、選択範囲に触れるすべてのトラックが選択されます。左から右にドラッグすると、選択矩形内に完全に収まるトラックだけが選択されます。Tabを押すと、同じネットに属する他の配線オブジェクトも含むように選択範囲が拡張されます。Tabを繰り返し押すと、選択可能なすべての状態が順番に切り替わります。
- 別の選択操作を行う際にShiftも併用すると、現在の選択を保持できます。
- Shift+Aで、現在の選択に対してActiveRouteを実行します。
- Ctrl+Alt+G - 現在の選択に対してGlossを実行します。
-
選択操作の対象となるのは、表示されているオブジェクトだけです(Ctrl+Aを除く)。
- Shift+Sを押して単層モードを切り替え、対象のレイヤーだけを表示します。
- 設計で配置ルームを使用している場合は、デザインルールの定義でルームをロックするか、非表示にすることで、クリック&ドラッグ操作中に選択や移動が行われないようにできます。ルームは、View ConfigurationパネルのView Optionsタブで非表示にできます。
-
SMDパッドをファンアウトします。ActiveRouteはレイヤーを変更しないため、SMDパッドをファンアウトしておく必要があります。ファンアウト作業を効率化するには、次の方法があります。
- 接続の配線中に/ショートカット(テンキー)を押すと、ビアを配置してその接続の配線を終了します。テンキーがない場合は、2ショートカットを使用します(配線を中断せずにビアを配置します)。
- 既存のファンアウトをコピーして貼り付けます。PCBエディターがネット名を自動的に更新します。複数のファンアウトに対しても実行できます。
-
既存のファンアウトを保持します。ActiveRouteは、より適切な配線が見つかるとファンアウトを変更します。変更したくない場合は、ファンアウトをロックしてください。最も簡単な方法は、ファンアウトのトラックとビアを選択し(Propertiesパネル上部のSelection Filterを使用すると便利です)、F11を押してPropertiesパネルを開き、Lockedチェックボックスをオンにすることです。これにより、選択したすべてのオブジェクトを一度にロックできます。
-
ルートガイドを使用していて完了率が低い場合は、経路上に障害物が多すぎるため、ガイドの幅を広げる必要がある可能性があります。配置中にUp矢印キーを押すと、ガイドの幅が広がります。
-
ActiveRouteが終了すると、グロッシングが適用されます(PCB ActiveRouteパネルで有効になっている場合)。ActiveRouteによる配線が完了した時点の状態を確認するには、Ctrl+Zを1回押してグロッシングを元に戻します。Glossコマンド(Route » Gloss Selected)は、ActiveRouteによる配線だけでなく、あらゆる配線のトラックを滑らかにし、パッドへの進入形状を改善するために使用できます。特に差動ペアについては、高品質なパッド進入形状を確保するための配慮がなされています。グロッシングの詳細については、既存配線のグロッシングと再トレースのページを参照してください。
-
ActiveRouteが動作しない場合、通常はルールが正しく設定されていないことが原因です。ActiveRouteが失敗する最も一般的な理由は、トラックを配置するためのスペースが不足していることです。ルールが適切かどうかを確認してください。たとえば、新規PCBファイルのデフォルトルールでは、高密度のBGA設計に対して寸法値が大きすぎる場合があります。
-
ActiveRouteは、レイヤー別、ルーム別、クラス別に設定された配線幅、クリアランス、差動ペアのギャップに関する配線ルールに従います。ActiveRouteは、円弧や任意角度のトラックを使用した配線は行いません。