ActiveRouteガイド付きインタラクティブルータの使用

概略

この記事では、Altium DesignerのActiveRouteが、従来のオートルーターに頼るのではなく、自動化と設計者による制御を組み合わせることで、PCB配線をどのように効率化するかを解説します。ActiveRouteとは何か、何ではないのか、主なメリットに加え、PCB ActiveRouteパネルを使ってネットを選択し、配線ガイドを定義し、レイヤーを選択し、グロス処理、チューニング、ピンスワップを有効にして、配線動作を調整する方法を紹介します。設計者がプロセスを制御しながら、より高速できれいな、ルールに準拠した配線を実現する方法を知りたい方に向けて、このガイドでは最初の一歩を示します。ActiveRouteでワークフローをどのように改善できるか、ぜひ読み進めてください。

- ActiveRouteとオートルーターの違いを理解し、選択したネットをガイドに沿って高品質に配線するうえで、ActiveRouteがより適している理由を把握できます。
- 配線ガイド、複数レイヤーでの配線、グロス処理、チューニング、ミアンダー制御、ピンスワップなど、ActiveRouteの主な機能を学べます。
- PCB ActiveRouteパネルを使用して、設計ルールと配線の目標に基づいてActiveRouteを設定し、実行する方法を確認できます。
AIでさらに深掘り:

Concept image showing routing

基板設計で最も時間のかかる工程の1つが、ネットの配線です。配線幅、ビアサイズ、クリアランスなどの設計制約はルールシステムが管理しますが、基板全体の配線を完了するために必要な数千ものトラックセグメントを配置するのは、設計者自身です。

オートルーターはこの負担を軽減できますが、一般的には次の理由から不十分と見なされています。 

  • 人間の設計者が配線時に直感的に考慮する、無数の細かな設計制約を適切に考慮できません。

  • 設定をすべて整えるのに時間がかかるため、最初からインタラクティブに配線する方が効率的な場合がよくあります。

  • 配線後の修正に多大な時間と手間がかかり、インタラクティブに配線する方が効率的な場合がよくあります。

PCB配線の究極の目標は、設計者の制御のもとで、設計ルールを満たす高品質な配線を短時間で実現することです。 ActiveRouteは、この課題の解決を目指しています。

Improving the Completed Routes

ActiveRouteを補完する独立した機能として、GlossingとRetraceがあります。これらの機能を使用すると、作成方法に関係なく、既存の配線の品質を向上できます。

Glossingはデフォルトで有効になっており、ActiveRouteの完了時に実行されます。必要に応じて、PCB ActiveRouteパネルで無効にできます。また、Glossingには、配線のコーナーを曲線にする機能など、独自のオプションが用意されています。

► 詳細はこちら:既存配線のGlossingとRetrace

ActiveRouteとは?

ActiveRouteは、効率的なマルチネット配線アルゴリズムを備えた自動インタラクティブ配線技術で、選択した特定のネットや接続に適用されます。また、設計者はActiveRouteを使用して、配線経路またはガイドをインタラクティブに定義できます。このガイドによって、新しい配線が通るthe riverが定義されます。

通常のインタラクティブ配線と自動配線を組み合わせる方法と比べて、この手法を大幅に優れたものにしているActiveRouteの主な機能は、次のとおりです。 

  • 手動配線で最も時間のかかる、ピン/ビア配列からの引き出し配線を自動的に最適化します。
  • 高い処理性能により、信号ネットを1本あたり1秒未満で配線します。
  • 優先順位を考慮しながら、ネットおよびネットクラスごとに設定された配線幅、クリアランス、レイヤー、トポロジー、ルームの設計ルールに従います。
  • 複数のレイヤーで同時に配線し、それらのレイヤーに配線を分散します。
  • 設計者が配線の配置を指示できる、直感的なRoute Guideを備えています。
  • River Route方式を使用し、ビアを使用せずに高い配線完了率を実現します。
  • ポリゴンプレーンを通して配線し、再ポアできます(再ポアオプションが有効な場合)。
  • シングルエンドネットと差動ペアネットの両方に対応しています。
  • 最後に強力なGlossingツールを実行し、コーナーの数をさらに減らして配線長を短縮します。

ActiveRouteが行わないこと

ActiveRouteはオートルーターではありません。選択したネット群をすっきりと高品質に配線することに重点を置いた、ガイド付きのインタラクティブルーターです。通常のインタラクティブ配線と同じ考え方でActiveRouteを使用してください。 対象のネットを選択し、それらを配線するレイヤーを有効にし、通すべき経路を検討してから配線を実行します。

基板上のすべてのネットを選択してActiveRouteを実行しても、期待どおりの結果は得られないでしょう。 ActiveRouteはオートルーターではありません。 ビアを配置することはできず、電源ネット向けの配線戦略も備えていません。

PCB ActiveRouteパネル

ActiveRouteはPCB設計ルールで定義された条件と制限に従うため、対象の接続またはネットを選択して実行するだけで使用できます。 また、PCB ActiveRouteパネルで設定できる専用の制御機能も用意されています。 PCB ActiveRoute パネルでは、インタラクティブなActiveRouteの実行、Route Guideとその内部の配線間隔の定義、自動配線長調整の有効化、自動ピンスワップの有効化など、ActiveRouteが提供するさまざまな機能を設定、操作できます。ActiveRouteを開始する前に、PCB ActiveRouteパネルを開いておくことを強くお勧めします。

PCBがアクティブなドキュメントになっている状態で、 PCB ActiveRouteパネルを開くには、次の操作を行います。 

  • ワークスペースの右下にある  Panels button, click to enable the display of workspace panels available in the current editorボタンをクリックし、 PCB ActiveRouteメニューオプションを選択します。

  •  View » Panels » PCB ActiveRouteをクリックします。

Altium DesignerでActiveRouteの機能を使用するには、ActiveRoute ソフトウェア拡張機能がインストールされている必要があります。この拡張機能は、手動でインストールまたは削除できます。

拡張機能の管理については、 Extending Your Installation ページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

PCB ActiveRouteパネルを使用して、ActiveRouteの処理を制御します。PCB ActiveRouteパネルを使用して、ActiveRouteの処理を制御します。

PCB ActiveRouteパネルでは、次の操作を行えます。

  • ActiveRouteで接続を配線できる信号レイヤーを有効にします。
  • 選択した接続に対してActiveRouteを実行します。
  • ActiveRouteの実行後にGlossing処理を行うように設定します。
  • Route Guideを定義します。
    • Route Guide内で使用するトラック間隔を設定します。
  • ActiveRouteで配置した配線の配線長調整を設定し、有効にします。
  • Meanderオプションを設定します。このオプションでは、ActiveRouteがより長い配線経路を定義できるようになり、配線完了率の向上につながる場合があります。
  • ピンスワップを設定し、有効にします。ActiveRouteは配線中にピンスワップを行い、配線品質を向上させることができます。
ActiveRouteは選択した接続を対象に動作します。パネル内の一部のコントロールは、接続が選択されている場合にのみ有効になります。

 PCB ActiveRoute パネルの内容は折りたたみ可能なセクションに分かれており、各セクション見出しにある►アイコンで開閉できます。以下のプロパティコントロールの説明も、対応するセクションごとにまとめられており、各折りたたみセクションは同じ方法で開閉できます。

ActiveRouteの追加機能

ActiveRouteは自動化されたインタラクティブルーターで、 使い方は簡単です。 接続を選択し、 Shift+A を押すだけで、 デザインルールに従ってActiveRouteによる配線が実行されます。ActiveRouteには、このほかにもさまざまな機能やコントロールが用意されており、設計者は特定の機能や動作をより細かく制御できます。

主な機能は次のとおりです。

  • Route Guideを配置して、配線経路と配線間隔を指定します。
  • Meanderコントロールで、より長い配線経路を許可します。
  • 長さチューニングで配線長を自動的に揃えます。
  • ピンスワップを許可して、配線を容易にします。

それぞれについて詳しく見ていきましょう。

Route Guideで経路を指定する

ActiveRouteの主な目的の1つは、配線長の合計が最短となる経路の組み合わせを見つけることです。ただし、それがすべての接続グループにとって望ましい経路とは限りません。Route Guideを使用すると、最短経路でなくても、選択した接続を通したい特定の経路を設計者が描くことができます。

  • Defining the Route Guide - まず、ガイド内で配線する接続を選択し、  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along をクリックします。 PCB ActiveRouteパネルのボタンをクリックし、次にクリックしてガイドの開始位置を指定します。 続けてマウスを移動し、クリックして経路を指定します。経路を指定したら、ActiveRouteボタンをクリックして、選択した接続をその経路に沿って配線します。詳細については、このページの後半にあるルートガイドの定義セクションを参照してください。

ルートガイドの端点は、配線対象のパッドに重ならないように配置してください。パッドをルートガイド内に含めない方が、パッドからの引き出し配線の品質が向上します。

  • Changing the Route Guide Width - ルートガイドの配置中に、  Keyboard Up arrow keyキーまたは  Keyboard Down arrow keyキーを押すと、ガイドの幅を広げたり狭めたりできます。デフォルトの幅は、選択した接続に適用される配線幅とクリアランスのデザインルール値の合計を、レイヤー数で割り、1.3を掛けた値です。別の経路を指定する必要がある場合は、Backspaceキーを押してガイドを直前の状態に戻します。
  • The Route Guide color - 選択した接続のActiveRouteで使用可能なレイヤーによって決まります。有効なレイヤーが1つの場合は、そのレイヤーの色で描画されます。 複数のレイヤーが有効な場合は、ルートガイドのデフォルトの色で描画されます。
  • The track spacing within the Route Guide - デフォルトでは、ActiveRouteはデザインルールに従って配線間隔を設定し、ルートガイド内の使用可能なスペース全体に配線を広げたり、すべてのスペースを使用したりはしません。ルートガイド内で配線を広げるには、このページの後半で説明するルートガイド内のトラック間隔機能を使用します。

ルートガイドの配置中に、幅をインタラクティブに変更する様子を示した動画。
ルートガイドの配置中に、幅をインタラクティブに変更する様子を示した動画。

ルートガイドの幅

デフォルトの幅は、選択した接続に適用される配線幅とクリアランスのデザインルール値の合計を、レイヤー数で割り、1.3を掛けた値です。 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • ガイドはデフォルトで1.3倍に拡張されます。 これにより、配線がガイド内に収まり、経路上のビアなどの障害物を迂回できるようになります。この幅は配線の厳密な境界となり、 配線が収まらない場合、その配線は配置されません。
  • ガイドの配置中に、キーボードの  Keyboard Up arrow keyキーまたは  Keyboard Down arrow keyキーを押すと、幅を広げたり狭めたりできます。最小サイズの倍率は1.0、 最大サイズの倍率は10.0です。

ガイドの編集

ルートガイドは、メカニカルレイヤー上に配置された一連のトラックで構成されます。

  • トラックセグメントはデフォルトでロックされています。ロックを解除すると、標準的なトラックのドラッグ操作でガイドの形状を変更できます。 
  • ガイドを削除するには、いずれかのセグメントをダブルクリックして選択し、 Deleteキーを押します。

ルートガイド内のトラック間隔

ルートガイド内のトラック間隔機能を使用すると、ルートガイドの幅全体に配線を広げるようActiveRouteに指示できます。スライダーで間隔の値を選択するか、編集ボックスに値を入力します。この設定を考慮して、ルートガイドのサイズが自動的に調整されます。この動作を有効にするには、ルートガイドを配置する前にTrack-Track Space in Route Guide設定を構成する必要があります。また、配置中に  Keyboard Up arrow keyキーと  Keyboard Down arrow key キーを押して、ルートガイドの幅をさらに調整できます。

トラック間隔機能を使用して、ルートガイド内の配線を広げます。
トラック間隔機能を使用して、ルートガイド内の配線を広げます。

配線の蛇行を許可する

ActiveRouteは、選択した接続を可能な限り最短の経路で配線しようとします。つまり、蛇行を最小限に抑えます。ActiveRouteの配線完了率が予想より低い場合は、MeanderコントロールでActiveRouteに許可する蛇行量を増やすことで、完了率が向上する可能性があります。Meanderの最大値のデフォルト設定は100%で、配線の総延長としてManhattan Length + 100% of Manhattan Lengthまで許容されることを意味します。スライダーで蛇行量を選択するか、 編集ボックスにパーセンテージを入力します。

ルートガイドを使用する場合、蛇行の設定は無視されることに注意してください。 ルートガイドは、蛇行が大幅に増える可能性のある経路を指定するためのものだからです。 

配線長のチューニング

ActiveRouteは、現在配線中の接続、 または選択した既存の配線に対して、配線長チューニングを適用できます。ActiveRouteは、選択したMatched Lengthsデザインルールを満たすように処理します。

ActiveRouteで配線長チューニングを行うには、次のように設定します。

  • パネルのAction領域にあるTune Selectedチェックボックスを有効にします。

  • パネルのTune領域で、必要なMatched Lengthsデザインルールを有効にします。

  • パネルのTune領域で、必要なMax AmplitudeおよびMin Spaceの設定(シングルエンドまたは差動ペア)を構成します。

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

現在使用できるチューニングスタイルはMitered Linesのみで、 コーナーのマイター率は約20%です。また、ActiveRouteによって配置されるアコーディオン形状はユニオンではありません。ActiveRouteの配線長チューニング機能は継続的に開発されており、ほかのチューニングスタイルやアコーディオン形状のユニオン化が検討されています。

► ActiveRouteの配線長チューニング設定の詳細については、PCB ActiveRouteパネルのページにある配線長チューニングセクションを参照してください。

► 調整可能なアコーディオン形状を使用した既存配線の配線長チューニングについては、配線長チューニングの記事を参照してください。

ピンスワップ

このソフトウェアには、回路図エディターとPCBエディター間で連携する、強力なピンおよびパーツのスワップ機能が搭載されています。ActiveRouteはピンスワップ設定にアクセスし、配線全体の長さを短縮して配線品質を向上できる場合、配線中にピンをスワップできます。

ピンスワップを使用するには:

  • ピンスワップを実行するには(インタラクティブ操作でもActiveRouteでも)、プロジェクトを開くたびにコンパイルする必要があります(Projectメニュー)。
  • コンポーネントのピンスワップ設定を構成・管理するには、Tools » Pin/Part Swapping » Configureコマンドを実行してConfigure Swapping Information in Componentsダイアログを開きます。
  • PCB ActiveRouteパネルのAction領域にあるPin Swap Routingオプションを有効にします。
  • PCB ActiveRouteパネルのPin Swap領域で、必要なコンポーネントを有効にします。

ピンスワップ機能の詳細については、ピン、ペア、パーツのスワップを参照してください。

ActiveRouteの準備

ActiveRouteでは、グロス機能(Route » Gloss Selected)を使用できます。この機能は、PCB ActiveRoute パネルで有効になっている場合、ActiveRoute処理の一環として自動的に実行されます。

ActiveRouteが失敗する最も一般的な原因は、トラックを配置するためのスペース不足です。そのため、配線幅ルールとクリアランスルールが正しく設定されていることを確認することが重要です。

ActiveRouteの実行

ActiveRouteを実行するには:

使いこなすためのヒント

  1. ActiveRouteを使いこなすうえで重要なのは、ショートカットに習熟することです。よく使用するキー操作は次のとおりです。

    • Alt+Click - 個々の接続線を選択します。
    • Alt+Click&Drag - 領域内の接続線を選択します。右から左にドラッグすると、選択範囲に触れるすべての接続線が選択されます。左から右にドラッグすると、選択矩形内に完全に収まる接続線だけが選択されます。Tabを押すと、同じネットに属する他の接続線も含むように選択範囲が拡張されます。カーソルを別のオブジェクト上に移動するまで、選択した接続線の数がステータスバーに表示されます。
    • Ctrl+Click&Drag - コンポーネント内のパッドを選択します。右から左にドラッグすると、選択範囲に触れるすべてのパッドが選択されます。左から右にドラッグすると、選択矩形内に完全に収まるパッドだけが選択されます。Tabを押すと、同じネットに属する他の配線オブジェクトも含むように選択範囲が拡張されます。Tabを繰り返し押すと、選択可能なすべての状態が順番に切り替わります。
    • Click&Drag - 既存のトラックセグメントを選択します。右から左にドラッグすると、選択範囲に触れるすべてのトラックが選択されます。左から右にドラッグすると、選択矩形内に完全に収まるトラックだけが選択されます。Tabを押すと、同じネットに属する他の配線オブジェクトも含むように選択範囲が拡張されます。Tabを繰り返し押すと、選択可能なすべての状態が順番に切り替わります。
    • 別の選択操作を行う際にShiftも併用すると、現在の選択を保持できます。
    • Shift+Aで、現在の選択に対してActiveRouteを実行します。
    • Ctrl+Alt+G - 現在の選択に対してGlossを実行します。
  2. 選択操作の対象となるのは、表示されているオブジェクトだけです(Ctrl+Aを除く)。

    • Shift+Sを押して単層モードを切り替え、対象のレイヤーだけを表示します。
    • 設計で配置ルームを使用している場合は、デザインルールの定義でルームをロックするか、非表示にすることで、クリック&ドラッグ操作中に選択や移動が行われないようにできます。ルームは、View ConfigurationパネルのView Optionsタブで非表示にできます。
  3. SMDパッドをファンアウトします。ActiveRouteはレイヤーを変更しないため、SMDパッドをファンアウトしておく必要があります。ファンアウト作業を効率化するには、次の方法があります。

    • 接続の配線中に/ショートカット(テンキー)を押すと、ビアを配置してその接続の配線を終了します。テンキーがない場合は、2ショートカットを使用します(配線を中断せずにビアを配置します)。
    • 既存のファンアウトをコピーして貼り付けます。PCBエディターがネット名を自動的に更新します。複数のファンアウトに対しても実行できます。
  4. 既存のファンアウトを保持します。ActiveRouteは、より適切な配線が見つかるとファンアウトを変更します。変更したくない場合は、ファンアウトをロックしてください。最も簡単な方法は、ファンアウトのトラックとビアを選択し(Propertiesパネル上部のSelection Filterを使用すると便利です)、F11を押してPropertiesパネルを開き、Lockedチェックボックスをオンにすることです。これにより、選択したすべてのオブジェクトを一度にロックできます。

  5. ルートガイドを使用していて完了率が低い場合は、経路上に障害物が多すぎるため、ガイドの幅を広げる必要がある可能性があります。配置中にUp矢印キーを押すと、ガイドの幅が広がります。

  6. ActiveRouteが終了すると、グロッシングが適用されます(PCB ActiveRouteパネルで有効になっている場合)。ActiveRouteによる配線が完了した時点の状態を確認するには、Ctrl+Zを1回押してグロッシングを元に戻します。Glossコマンド(Route » Gloss Selected)は、ActiveRouteによる配線だけでなく、あらゆる配線のトラックを滑らかにし、パッドへの進入形状を改善するために使用できます。特に差動ペアについては、高品質なパッド進入形状を確保するための配慮がなされています。グロッシングの詳細については、既存配線のグロッシングと再トレースのページを参照してください。

  7. ActiveRouteが動作しない場合、通常はルールが正しく設定されていないことが原因です。ActiveRouteが失敗する最も一般的な理由は、トラックを配置するためのスペースが不足していることです。ルールが適切かどうかを確認してください。たとえば、新規PCBファイルのデフォルトルールでは、高密度のBGA設計に対して寸法値が大きすぎる場合があります。

  8. ActiveRouteは、レイヤー別、ルーム別、クラス別に設定された配線幅、クリアランス、差動ペアのギャップに関する配線ルールに従います。ActiveRouteは、円弧や任意角度のトラックを使用した配線は行いません。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents