デザインの詳細を含む
概略
- PCBエディターやPCBライブラリエディターで追加できるドキュメント情報と、それらを整理するためのメカニカルレイヤーの使い方を学びます。
- レイヤースタックテーブルとドリルテーブルに含まれる情報、配置できる場所、現在の基板設計に応じた更新や反映の仕組みを確認します。
- これらのドキュメント要素のPCB出力での表示を制御する、配置、移動、サイズ変更、プロパティの主なオプションを理解します。
生成する出力の多くには、詳細情報を追加する必要があります。たとえば、製造図面には寸法が必要であり、組立図面には基板の特定領域の拡大図が必要になる場合があります。また、基板製作図面にはレイヤースタックテーブルとドリルテーブルが必要です。これらの詳細情報は、PCBエディターまたはPCBライブラリエディターで追加できます。
汎用作図レイヤー
PCBエディターでは、寸法や基板製作・組立に関する指示などの詳細情報をメカニカルレイヤーに追加します。汎用メカニカルレイヤーは枚数の制限なく使用でき、View Configurationパネルで有効にします。これらのレイヤーには必要に応じて名前を付けることができ(名前を右クリックし、Edit Layerを選択)、印刷出力やレイヤーベースの基板製作出力に含めることができます。
レイヤースタックテーブル

レイヤースタックテーブルは、PCBドキュメント内で設計そのものの横に配置できます。基板のレイヤースタック構成と、レイヤーグループの割り当て方法の詳細な概要を示します。
レイヤースタックテーブルは、現在のPCB設計に使用されているレイヤー、材料、厚さ、比誘電率を記録する表形式のグラフィカルオブジェクトです。設計スペース内で基板設計の横に配置され、基板の各領域で使用されるレイヤースタックを示す凡例とオプションマップも含まれます。レイヤースタックテーブルには、Layer Stack Managerで定義されたレイヤー構成が反映されます。リジッドフレックス設計のように複雑なレイヤースタック構造を持つ設計では、重要なドキュメントとなります。
レイヤースタックテーブルは、設計スペースの表示が通常の2Dモード(ショートカット:2)に設定されている場合に、PCBエディターで使用できます。レイヤースタックテーブルの配置コマンド(Place » Layer Stack Table)を実行すると、カーソルが十字に変わり、レイヤースタックテーブルの配置モードになります。次の手順で配置します。
- クリックしてテーブルを配置します。
- エディターはレイヤースタックテーブルの配置モードを維持するため、必要に応じて別のテーブルを配置できます。配置を終了するには、右クリックするかEscを押します。
配置中にレイヤースタックテーブルがまだカーソルに追従しており、その中心点の位置が確定する前であれば、次の操作も実行できます。
- Altキーを押すと、最初に移動した方向に応じて、移動方向を水平軸または垂直軸に制限できます。
- Spacebarを押すとレイヤースタックテーブルが反時計回りに、Shift+Spacebarを押すと時計回りに回転します。回転は90°刻みです。
レイヤースタックテーブルを移動するには、テーブルをクリックしたまま目的の位置までドラッグします。

レイヤースタックテーブルを選択してドラッグし、位置を変更します。
レイヤースタックテーブルのプロパティ

PropertiesパネルのLayer Stack Tableモード。
位置
-
(X/Y)
- X (最初のフィールド)- 現在の設計スペース原点を基準とした、オブジェクトの基準点の現在のX座標(水平方向)です。編集すると、オブジェクトのX位置を変更できます。値はメートル単位系またはインチ単位系で入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY座標(垂直方向)です。編集すると、オブジェクトのY位置を変更できます。値はメートル単位系またはインチ単位系で入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
- Rotation - ゼロ(3 o'clockの水平方向)から反時計回りに測定した、オブジェクトの回転角度(度)です。編集すると、オブジェクトの回転を変更できます。最小角度分解能は0.001°です。
プロパティ
- Layer - テーブルが現在割り当てられているレイヤーです。ドロップダウンから別のレイヤーを選択できます。
- Alignment - ドロップダウンから目的の配置揃えを選択します。
-
Units - ドロップダウンから
Metric (mm)またはImperial (mil)を選択します。 - Show Board Map - 有効にすると、各レイヤースタックが基板のどの領域に割り当てられているかを示す基板外形が表示されます。スライダーバーを使用して、表示される基板外形の縮尺を変更します。
- Show Total Board Thickness - 有効にすると、レイヤースタックテーブルのグリッドの下に基板全体の厚さが表示されます。
- Line Width - テーブル内のテキストの線幅を指定します。Line Widthはテキストの線の太さに影響します。
- Text Height - 現在の文字の高さです。テーブル内のテキストの高さを指定します。 Text Heightはテーブルのサイズにも影響します。テキストの高さを大きく設定すると、テーブルは自動的に拡張されます。
フォントの種類
-
TrueType - このフィールドで、使用するTrueTypeフォントを選択します。Fontドロップダウンリストには、
\Windows\Fontsフォルダー内にあるTrueTypeフォントとOpenType(TrueTypeの上位セット)フォントが表示されます。このリストには、検出されたルートフォント(名前が一意のもの)のみが表示されます。B(bold) およびI(Italic)オプションを使用して、テキストを強調できます。 -
Stroke
-
Font - このフィールドを使用して、必要なストロークフォントを選択します。使用可能なオプションは次のとおりです。
-
Default- ペンプロッティングとベクターフォトプロッティングに対応したシンプルなベクターフォントです。 -
Serif- Gerberなどのベクター出力の生成に時間がかかる、より複雑なフォントです。 -
Sans Serif- Gerberなどのベクター出力の生成に時間がかかる、より複雑なフォントです。
-
-
Font - このフィールドを使用して、必要なストロークフォントを選択します。使用可能なオプションは次のとおりです。
-
Stroke Width - 現在のストローク幅を表示します。
列
この領域では、レイヤースタックテーブルに表示する列、各列のテキストの配置、および列全体の幅を指定します。
- Caption - 表示する列のタイトルです。
- Align - 配置を変更する見出しの配置セルをクリックします。クリックするたびに、配置オプション(左揃え、中央揃え、右揃え)が切り替わります。配置フィールドをクリックするたびに、テーブル内のその列のテキスト配置が変わります。
-
Width - フィールドをクリックして、選択した見出しの幅を編集します。
Autoを指定すると、その列に入力されたテキストに応じて、列幅が自動的に調整されます。必要に応じて任意の幅を入力することもできます。 - Add - ドロップダウンを使用して、使用可能なオプションからレイヤースタックテーブルに列を追加します。ドロップダウンで、テーブルに表示する見出しをクリックします。
- Up - クリックすると、選択した見出しがテーブル内で1列左に移動します。Up ボタンを繰り返しクリックすると、選択した列をさらに左へ移動できます。
- Down - クリックすると、選択した見出しがテーブル内で1列右に移動します。Down ボタンを繰り返しクリックすると、選択した列をさらに右へ移動できます。
-
- クリックすると、選択した見出しがテーブルから削除されます。選択した項目を削除するかどうかを確認するメッセージがテーブル内に表示されます。削除する場合はYes を、削除しない場合はNo をクリックします。
ドリルテーブル

ドリルテーブルには、基板上のすべてのドリル穴の概要がリアルタイムで表示されます
ドリルテーブル(ドリル図面テーブル、またはドリル図面凡例とも呼ばれます)は、プリント基板の製造に必要な標準的な要素です。ドリルテーブルには、基板に使用する各ドリルの穴径と穴数が一覧表示されます。各ドリル径は、シンボル、文字、または実際の穴径で表すことができます。基板のドリル図面を生成すると、実際の各穴位置にシンボルが表示されます。ドリルテーブルはリアルタイムで更新されます。つまり、パッドやビアなどの穴を持つオブジェクトをPCB設計に配置したり、設計から削除したりすると、テーブルも更新されます。
ドリルテーブルは、PCBエディターでのみ配置できます。コマンドを実行すると、ドリルテーブルがカーソルに追従して表示されます。基板の外側の適切な位置にテーブルを移動し、クリックするかEnterを押して配置します。
配置中にドリルテーブルがカーソルに追従しており、まだ位置が確定していない状態では、次の操作も行えます。
-
Tabキーを押すと配置が一時停止し、Properties パネルのドリルテーブルモードにアクセスして、その場でプロパティを変更できます。重ねて表示される一時停止ボタン(
)をクリックすると、配置を再開できます。
- Altキーを押すと、最初の移動方向に応じて、移動方向が水平軸または垂直軸に制限されます。
ドリルテーブルの移動
ドリルテーブル内の任意の場所をクリックしたまま、PCBエディターの設計スペース内の目的の位置に移動します。
ドリルテーブルのインタラクティブなサイズ変更
ドリルテーブルのサイズは、指定したText Height設定、異なる穴径の数(行数)、および定義した列数に基づいて自動的に決まります。テーブルのサイズをインタラクティブに変更するには、1回クリックして選択し、角の頂点をクリックしたまま移動して、必要なサイズに調整します。テーブルのサイズをインタラクティブに変更すると、フォントサイズも拡大または縮小されることに注意してください。
プレビューするレイヤーペアのインタラクティブな切り替え
基板にレイヤーペアが含まれている場合、表示されるレイヤーペアは、Properties パネルのDrill TableモードにあるLayers Pairsオプションで制御されます。
選択したレイヤーペアは、次の方法でも切り替えられます。
-
PCBエディターの右クリックメニュー - ドリルテーブルを右クリックし、下の図に示すように、Drill Tableサブメニューで必要なレイヤーペアを選択します。
-
下の図に示すように、設計スペースの下部にあるレイヤータブからアクセスできるレイヤーペア選択メニュー。
ドリルテーブルのプロパティ
アクション
Refresh – ボタンをクリックすると、PCBの現在のドリルシンボルデータでドリルテーブルが更新されます。
位置
-
(X/Y) – ドリルテーブルの基準点の現在のX座標とY座標です。基準点は、Alignment =
Bottomの場合は左下隅、Alignment =Topの場合は左上隅になります。 - Rotation – ドリルテーブルの回転角度(度単位)です。
プロパティ
-
Layer Pairs – ドリルテーブルは、レイヤーペアごとの穴あけを行う多層基板に対応しています。ドロップダウンから、Layer Stack ManagerのVia Typesタブで定義されたレイヤーペア、または以下のいずれかのオプションを選択します。
- All Layer Pairs (Composite table) – すべてのレイヤーペアの情報を表示します。
-
All Layer Pairs (Separate tables) – 各レイヤーペアの情報を個別のテーブルに表示します。
- Top - Bottom – スルーホールのみを表示します。
- Counterhole Bottom – PCBの下面にある座ぐり穴(平座ぐり/皿座ぐり)のみを表示します。
- Counterhole Top – PCBの上面にある座ぐり穴(平座ぐり/皿座ぐり)のみを表示します。
- Text Height – テキストの高さを表示します。
フォントの種類
-
TrueType – PC上(\Windows\Fonts フォルダー内)で使用可能なフォントを使用する場合に選択します。TrueTypeフォントはUnicodeに完全対応しています。 デフォルトでは、ソフトウェアは使用するTrueTypeフォントにリンクします(フォントはPCBファイルに保存されません)。そのため、デザインの移動先となる各PCに同じフォントが必要です。または、Preferences ダイアログのPCB Editor – True Type Fontsページのオプションを使用して、使用するTrueTypeフォントをPCBファイルに埋め込むこともできます。このページでは、埋め込まれていないフォントが使用できない場合に使用する Substitution Font も選択できます。
- Font – ドロップダウンから目的のTrueTypeフォントを選択します。B を使用するとテキストが太字になり、I を使用すると斜体になります。
-
Stroke
-
Font – ドロップダウンから目的のストロークフォントを選択します。選択肢は以下のとおりです。
-
Default– ペンプロットおよびベクターフォトプロット用に設計されたシンプルなベクターフォントです。 -
Sans Serif -
Serif
-
- Stroke Width – ストロークの幅を表示します。
-
Font – ドロップダウンから目的のストロークフォントを選択します。選択肢は以下のとおりです。
- Show Footer – テーブルのフッターの表示を有効/無効に切り替えます。
- Alignment – テーブルは下から上(Bottom)、または上から下(Top)に構築できます。この設定を使用すると、デザインスペース内の周囲のオブジェクトに影響を与えずにテーブルのサイズを変更できます。
- Table Border Width – テーブルの枠線の幅です。
-
Drill Symbols – クリックすると Drill Symbols ダイアログが開き、穴径に記号や文字を割り当てることができます。
Drill Symbolsダイアログのオプションとコントロール
Grid Area
グリッド領域には、記号と穴径の対応付けに関する詳細情報が表示されます。列ヘッダーをクリックしてドラッグすると列の順序を変更でき、列ヘッダーを右クリックしてチェックボックスをオン/オフにすると列の表示/非表示を切り替えられます。
Grouping
Grouping ボタンをクリックして、記号をドリル加工箇所(穴)に割り当てる際の基準となるプロパティを設定します。穴は最初に穴径でグループ化され、その後、穴を区別するグループ化オプションが有効になっている場合は、それぞれに異なる記号が割り当てられます。たとえば、デザインに穴径1mmの丸型パッドと、同じく穴径1mmの角型パッドが含まれているとします。Grouping で Pad Shape が有効になっていない場合、これらには同じ記号が割り当てられます。一方、Grouping で Pad Shape が有効になっている場合は、それぞれに異なる記号が割り当てられます。
Graphic Symbol
各穴位置は、記号、文字、または実際の穴径を示す文字列で表すことができます。以下のオプションで、記号のスタイルとサイズを設定します。
-
Symbol - 各穴位置に記号を使用する場合に選択します。ソフトウェアには、下の画像に示す15種類の定義済み記号スタイルが用意されています。穴径が15種類を超える場合は、英字が自動的に割り当てられます。
- Character - 各穴位置に英字を使用する場合に選択します。
- Symbol Size - Drill Drawingレイヤーに表示される記号/文字の高さです。この設定は、ドリル図面で使用されるすべての記号/文字に適用されることに注意してください。
Draw Symbols
以下のオプションで、ドリル記号のスタイルと表示条件を設定します。
- Show Symbols - 各穴位置に記号を表示します。
- Show Hole Size - 各穴位置に実際のドリル径を数値で表示します。
- Show Drill Symbols - デフォルトでは、Drill Drawingレイヤーにドリル記号は表示されません。ドリル記号を表示するには、このオプションを有効にします。
-
-
– ドリルテーブルに影響するデザイン変更があった場合に、クリックしてテーブルを更新します。なお、出力生成時にはテーブルが自動的に更新されます。
単位
-
Primary Units – ドロップダウンから、主単位を
Metric (mm)またはImperial (mil)に設定します。 -
Dual Units – ドロップダウンから、併記単位を
Metric (mm)またはImperial (mil)に設定します。デザインスペースでこれらの単位を表示するには
、非表示にするには
を使用します。
精度
- Primary Precision – ドロップダウンから、必要な精度(小数点以下の桁数)を設定します。
- Dual Precision – ドロップダウンから、併記単位の精度(小数点以下の桁数)を設定します。
列
- Grid – ドリルテーブルのすべての列見出し(Caption)、グリッド内の内容の配置を変更するAlign設定、Width、および各列の情報を表示するOrderを表示します。 昇順と降順を切り替えるには、Order列をクリックしてドロップダウンメニューを開き、目的の並び順を選択します。 Asc – 昇順、またはDsc – 降順。
-
Edit Columns – クリックするとColumnsダイアログが開き、ドリルテーブルに新しい列を追加したり、既存の列を編集したりできます。
このダイアログには、既存のすべての列と、それぞれに関連するデータ(読み取り専用)が表示されます。グリッドの下にある次のボタンを使用して、テーブルに表示するデータを整理します。
- Add Column - ドリルテーブルに新しい列を追加します。クリックすると、使用可能な列のメニューが開きます。すでに使用されている列や使用できない列は、メニュー内でグレー表示されます。このコマンドは右クリックメニューからも使用できます。
- Remove Column - クリックすると、選択した列が削除されます。確認ダイアログは表示されず、ボタンをクリックすると列が削除されることに注意してください。 このコマンドは右クリックメニューからも使用できます。
- Change Header - クリックすると 列見出しの変更ダイアログが開き、選択した列のタイトルを変更できます。 このコマンド(Change column header)は右クリックメニューからも使用できます。
右クリックのコンテキストメニューからは、次の追加コマンドを使用できます。
-
Text Alignment - 選択した列のテキストの配置を設定します。選択肢は、
Left、Center、Rightです。 -
Set column width - 選択した列の幅を設定します。選択肢は、
Autosize(デフォルト)とManualです。Manualをクリックすると 列幅の設定ダイアログが開き、目的の幅を入力できます。
デザインビュー

デザインビューを配置して、基板の特定の領域を表示します。この例では、200%に拡大しています。
PCBのデザインビューオブジェクトは、現在の基板または別の基板の任意の矩形領域を画像として切り取ったものです。設計スペース内の任意の場所に配置でき、任意のサイズに拡大・縮小できます。
デザインビューは、PCBエディターでのみ配置できます。デザインビューの配置コマンド(Place » Design View)を実行すると、カーソルにデザインビューが追従して表示されます。適切な位置に移動し、クリックするかEnterを押して配置します。
配置中、デザインビューがまだカーソルに追従しており、位置が確定する前に実行できる追加操作は次のとおりです。
- Altキーを押すと、最初の移動方向に応じて、移動方向が水平軸または垂直軸に制限されます。
デザインビューを配置した後、次の手順で目的のレイヤーの表示を設定できます。
- 設計スペースでデザインビューを選択した状態で、ダブルクリックするか、右クリックしてコンテキストメニューからProperties を選択し、Propertiesパネルを開きます。
- Properties パネルのDefine ボタンを使用して、対象領域を対話的に定義します。
-
Properties パネルのLayers セクションで、
アイコンをクリック(切り替え)して、目的のレイヤーの表示を有効にします。Properties パネルで有効にしたレイヤーには、
アイコンが表示されます。
デザインビューは、印刷出力とPDF出力に含まれます。出力時にもデザインビュー独自のレイヤー表示設定が保持されるため、印刷やPDFで必要な表示を実現できます。ただし、デザインビューで使用するレイヤー上のプリミティブには、Printダイアログでそのレイヤーに対して定義した表示設定が引き続き適用されます。たとえば、デザインビューにTop Overlayが表示されており、Output Jobの該当出力でTop Overlayのトラックをドラフトモードで表示するように設定している場合、デザインビュー内のTop Overlayのトラックもドラフトモードで表示されます。
設計スペースにデザインビューを配置すると、ビューの位置、縮尺、サイズ、および表示対象領域を対話的に調整できます。
- Change the position – デザインビューオブジェクトをPCBの設計スペース内の新しい位置にClick+Dragします。
- Adjusting the Scale – 1回クリックしてデザインビューを選択し、コーナーハンドルでClick+Dragして、デザインビューを拡大(外側へドラッグ)または縮小(内側へドラッグ)します。
- Adjusting the View Size – 1回クリックしてデザインビューを選択し、コーナーハンドルでCtrl+Click+Dragして、デザインビューのサイズを変更します。
- Changing the Focus – Ctrl+Click+Dragをデザインビュー内の任意の場所で行うと、現在表示されている領域をデザインビューウィンドウ内で移動できます。

Ctrl+Click+Dragで、デザインビューに現在表示されている領域を移動して調整します。
デザインビューのプロパティ
位置
- (X/Y) - デザインビューの基準点の現在のX座標とY座標。
プロパティ
- This document - 現在アクティブなドキュメントのプロパティを指定する場合に選択します。
-
Specify document - 別のドキュメントのプロパティを指定する場合に選択します。選択した場合は、Document フィールドの
をクリックし、目的のドキュメントを参照します。
-
Document - Specify document が選択されている場合に、
をクリックして目的のドキュメントを検索し、選択します。
- Mirrored - クリックすると、デザインビュー内の基板領域を反転(ミラー)表示します。
- Scale - クリックして、倍率でオブジェクトのサイズを定義します。
- Title - デザインビューのタイトルを入力します。
- Text Height - デザインビューのタイトル文字の高さを入力します。
- Font - ドロップダウンから、タイトルに使用するフォントを選択します。 カラーボックスを使用して、タイトル文字の色を選択するカラーピッカーを開きます。文字が見えるように、設計スペースの背景色とコントラストのある色を選ぶ必要があります。
- Define - クリックして 十字カーソルの状態で設計スペースに戻り、クリックしてドラッグし、ビューの矩形領域を定義します。
レイヤー
この領域には、基板のすべてのレイヤーが一覧表示され、デザインビューに表示するレイヤーを設定できます。
-
Name - レイヤーの名前。
を使用して または
アイコンを使用して、Design Viewにリストされているレイヤーをそれぞれ表示または非表示にします。
- Type - レイヤーの種類。
OLEオブジェクト

配置された一連のOLEオブジェクト – 上から順に、画像、スプレッドシートのセル、Word文書のテキスト
PCBエディターのObject Linking and Embedding(OLE)技術により、WindowsのOLEアプリケーションから提供されるデータを、元のアプリケーションとのリンクを維持しながらPCB設計に埋め込むことができます。多くの場合、埋め込まれたPCBデータは、そのデータを作成したアプリケーション内で編集できます。
PCBドキュメントに配置できる一般的なOLEオブジェクトには、Excel文書、Word文書、適切なOLE画像アプリケーションのグラフィックオブジェクトなどがあります。サポートされるファイル形式には、CSVおよびXLS形式のスプレッドシート、DOCおよびRTF形式の文書、BMP画像ファイルなどの汎用形式が含まれます。
OLEオブジェクトは、PCBエディターに配置または埋め込むことができます。Place » Object From File コマンドを実行したら、Choose Fileダイアログで目的のファイルを選択し、クリックしてデザインスペースにオブジェクトを配置します。
Altiumのスマートペースト機能を使用して、OLEアプリケーションで選択した範囲をコピーし、OLEオブジェクトとしてPCBドキュメントに貼り付ける(Edit » Paste)こともできます。必要に応じて、テキスト貼り付けオプション(Edit » Paste Text)を使用して、OLEオブジェクトからテキスト要素を抽出できます。これらはPCBテキストオブジェクトとして配置されます。
配置後、埋め込みオブジェクトの選択ハンドルをクリックしたままドラッグすると、縦横比を維持して拡大縮小できます。Word文書やExcel文書などのテキストベースのオブジェクトでは、新しい寸法に合わせて、埋め込まれたテキストのサイズと太さが自動的に調整されます。
- OLEオブジェクトは、Tools » Convert » Explode OLE Object to Free Primitivesコマンドを使用して、独立したプリミティブオブジェクトの集合に変換することもできます。これにより、オブジェクトは適切なリージョンやテキストオブジェクトに分解されます。
- OLEオブジェクトを編集しようとした際に対応するOLEアプリケーションが見つからない場合も、独立したプリミティブに変換するオプションが提示されます。
OLEオブジェクトのプロパティ
位置
- (X/Y) - 現在のデザインスペース原点を基準とした、オブジェクトの基準点の現在のX(水平)座標とY(垂直)座標。編集すると、オブジェクトの位置が変わります。
- Rotation - ゼロ(3 o'clock 水平)から反時計回りに測定した、オブジェクトの回転角度(度単位)。編集すると、オブジェクトの回転が変わります。角度の最小分解能は0.001°です。
プロパティ
- Layer - オブジェクトが現在割り当てられているレイヤー。ドロップダウンを使用して別のレイヤーを選択します。
- Edit Data - クリックして、関連付けられたアプリケーションでオブジェクトを開き、必要な編集を行います。編集を行って関連付けられたアプリケーションを閉じたら、PropertiesパネルでSave をクリックして編集内容を保存するか、Cancelをクリックします。
寸法
PCBエディターおよびPCBライブラリエディターには、さまざまな設計要件に対応する各種の寸法記入ツールが用意されています。
| 寸法オブジェクト | 説明 |
|---|---|
| Angular Dimension | 角度の寸法を記入できます。 |
| Baseline Dimension | 単一の基準点を基準として、複数の参照点までの直線距離の寸法を記入できます。最初に選択した点が「基準」になります。それ以降のすべての点は、この最初の点を基準とします。したがって、各寸法値は、各参照点と「基準」との間の距離をデフォルトの単位で測定した値になります。参照には、トラック、アーク、パッド、ビア、テキスト、フィル、ポリゴン、コンポーネントを使用できます。 |
| Center Dimension | アークまたは円の中心にマークを付けることができます。 |
| Leader Dimension | オブジェクト、点、領域にラベルを付けることができます。引出線には、自動、丸、四角の3種類があり、ラベルのテキストを円または四角で囲むか、囲まないかを指定できます。指示部には矢印または点を使用できます。 |
| Linear Dimension | 直線距離の寸法を記入できます。寸法値は、開始マーカーと終了マーカー(ユーザーが選択した参照点)の間の距離をデフォルトの単位で測定した値です。参照には、オブジェクト(トラック、アーク、パッド、ビア、テキスト、フィル、ポリゴン、コンポーネント)または空きスペース内の点を使用できます。 |
| Linear Diameter Dimension | アークまたは円に対して、半径ではなく直径の寸法を記入できます。寸法は内側にも外側にも配置できます。 |
| Ordinate Dimension | 単一の基準オブジェクトを基準として、複数のオブジェクトまでの直線距離の寸法を記入できます。最初に選択したオブジェクトが「基準」になります。それ以降のすべてのオブジェクトは、この最初のオブジェクトを基準とします。したがって、各寸法値は、各参照オブジェクトと「基準」との間の距離をデフォルトの単位で測定した値になります。参照には、トラック、アーク、パッド、ビア、テキスト、フィル、ポリゴン、コンポーネントを使用できます。 |
| Radial Dimension | アークまたは円の半径の寸法を記入できます。寸法は内側にも外側にも配置できます。 |
| Radial Diameter Dimension | アークまたは円に対して、半径ではなく直径の寸法を記入できます。寸法は、アーク/円の円周に対して内側にも外側にも配置できます。 |
| Standard Dimension | 現在のPCBレイヤーに寸法情報を配置します。寸法値は、開始マーカーと終了マーカーの間の距離をデフォルトの単位で測定した値です。 |
寸法オブジェクトは、メインメニューのPlace » Dimensionサブメニューから使用できます。オブジェクトに寸法を記入する際は、寸法を接続できる位置を示すアンカーポイントがハイライト表示されます。処理中は、各ステップで必要な操作の情報がステータスバーに表示されます。そのままクリックするかEnterを押すと、カーソルに最も近い点が使用され、そこに寸法が接続されます。
以下の動画では、いくつかの寸法の配置例を紹介しています。
配置中には、次の操作も実行できます。
- テンキーの+キーと-キーを押すと、設計内の表示されているすべてのレイヤーをそれぞれ順方向、逆方向に切り替え、配置レイヤーをすばやく変更できます。
- 基準線寸法、中心寸法、直線直径寸法、直線寸法、または座標寸法を配置する際は、Spacebar を押すと寸法が反時計回りに、Shift+Spacebar を押すと時計回りに回転します。回転は、Preferences ダイアログの PCB Editor – General ページで定義された Rotation Step の値に従います。
- 標準寸法を配置する際は、L キーを押すと寸法を基板の反対側に反転できます。ただし、この操作は寸法の始点を固定する前にのみ可能です。
寸法値(該当する場合)は、始点または終点を移動すると自動的に更新されます。同様に、寸法の参照点が固定されているオブジェクトの位置を変更すると、それに応じて寸法が更新され、伸縮します。半径または直径に基づく寸法では、参照する円弧や円の直径が変わると、値が自動的に更新されます。
寸法オブジェクトが関連付けられている参照対象を削除すると、寸法も削除するかどうかを確認するダイアログが開きます。寸法を削除しない場合、寸法はデザインスペースに残りますが、参照のない状態になります。
寸法オブジェクトは、次の方法で移動できます。
- Selecting both the dimension object and the dimensioned object(s). 必要に応じて、全体を新しい位置にドラッグできます。
- Selecting a dimensioned object only. 寸法テキストは、その配置方向に沿ってのみオブジェクトに追従します。寸法補助線(半径方向の直径寸法または半径寸法の場合は、ポインターとテール)は、寸法と寸法測定対象のオブジェクトとの関係を維持するように伸縮します。中心寸法または引出線寸法の場合は、オブジェクトとともに移動します。引出線寸法のセグメント(矢印/ドットと最初に定義された屈曲点の間)は、寸法と寸法測定対象のオブジェクトとの関係を維持するように伸縮します。
- Selecting the dimension object only. 寸法がデザインオブジェクトを参照している場合、寸法だけを移動することはできない点に注意してください。寸法だけを移動するには、まず寸法測定対象のオブジェクトから切り離す必要があります。
寸法オブジェクトを選択すると編集ハンドルが表示され、テキストや参照点の位置などのプロパティをグラフィカルに変更して、配置済みの寸法オブジェクトをデザインスペース内で直接編集できます。以下に、いくつかの寸法の編集ハンドルの例を示します。
|
直線寸法オブジェクトを選択すると、次の編集ハンドルが使用できます。
角度寸法オブジェクトを選択すると、次の編集ハンドルが使用できます。
半径寸法オブジェクトを選択すると、次の編集ハンドルが使用できます。
座標寸法オブジェクトを選択すると、次の編集ハンドルが使用できます。
|
寸法測定対象のオブジェクト上(または最も近い位置)にあるハンドル(上図の直線寸法の C と D、角度寸法の C & E および D & F など)を使用すると、参照を再定義できます。寸法を参照オブジェクトから切り離すと、参照のない状態になり、移動して別の参照点やオブジェクトに関連付けることができます。参照のない直線寸法、座標寸法、または基準線寸法の編集ハンドルをドラッグしている間は、寸法を回転させることもできます。
寸法オブジェクトのプロパティ
寸法にはさまざまな設定オプションがあり、矢印とテキストを細かくカスタマイズできます。1つまたは複数の寸法オブジェクトを選択して Properties パネルを開くと、プロパティを編集できます。
| プロパティ | 適用対象オブジェクト | 説明 |
|---|---|---|
スタイル |
||
| Width | 中心寸法と座標寸法を除くすべて | 現在の寸法線の幅。 |
| Width(Extension Line 領域内) | 角度寸法 基準線寸法 直線寸法 直線直径寸法 座標寸法 |
現在の寸法補助線の幅。 |
| Gap | 角度寸法 基準線寸法 引出線寸法 直線寸法 直線直径寸法 座標寸法 |
|
| Offset | 角度寸法 基準線寸法 直線寸法 直線直径寸法 |
寸法補助線に対する現在の矢印線のオフセット。 |
| Text Gap | 中心寸法と標準寸法を除くすべて |
|
| Leader Shape | 引出線寸法 | ドロップダウンを使用して、寸法テキストを囲む図形を指定します。選択肢は Automatic、 Round、 Squareです。 Round または Square を選択した場合は、希望する Size を入力します。 |
| Arrow Style | 引出線寸法 | ドロップダウンを使用して、希望する引出線のスタイルを選択します。選択肢は Arrow または Dot です。希望する Size を入力します。 |
| Height | 標準寸法 | 現在の寸法補助線の高さです。 |
| Arrow Size | 角度寸法 並列寸法 直線寸法 直線直径寸法 半径寸法 半径方向の直径寸法 |
現在の矢印の先端サイズです。サイズは、矢印の先端から矢羽の端までの距離として測定されます。 |
| Arrow Length | 角度寸法 並列寸法 直線寸法 直線直径寸法 半径寸法 半径方向の直径寸法 |
現在の矢印の長さです。このフィールドに入力した値は、 Arrow Position ( Properties 領域内)が Outside に設定されている場合にのみ適用されます。 |
プロパティ |
||
| Text | 引出線寸法 | 希望するテキストを入力します。 |
| Layer | すべて | 寸法が現在割り当てられているレイヤーです。ドロップダウンを使用して、希望するレイヤーを選択します。寸法は、使用可能な任意のレイヤーに割り当てることができます。 |
| Text Position | 中心寸法と標準寸法を除くすべて | 寸法テキストの現在の位置です。対応するドロップダウンリストから、次のいずれかのオプションを選択します(選択可能なオプションは寸法オブジェクトの種類によって異なります)。
|
| Arrow Position | 角度寸法 並列寸法 直線寸法 直線直径寸法 半径寸法 半径方向の直径寸法 |
寸法矢印の現在の位置です。使用可能なオプションは次のとおりです。
|
| Angular Step | 半径方向の直径寸法 | 寸法の現在の角度ステップ設定です。これは、寸法の矢印部分を配置するときに使用される回転ステップです。寸法の配置中に円または円弧に沿って矢印を動かすと、寸法を固定できる位置の数と場所が、この角度ステップ値によって決まります。 |
| Text Height | 中心寸法を除くすべて | 寸法テキストの現在の文字高さです。テキストの表示または印刷に使用される文字幅は、この高さに比例して自動的に設定されます。高さを最低 36mil (0.9mm)にすると、フォトプロット時にテキストの判読性を確保できます。 |
| Rotation | 中心寸法 直線寸法 直線直径寸法 座標寸法 |
寸法の配置角度です。水平方向を基準に反時計回りの角度(度)で測定されます。 |
| Size | 中心寸法 | 寸法の十字線の現在の長さ(または外接円の直径)です。 |
| Font Type | 中心寸法を除くすべて |
|
単位 |
||
| Primary Units | 角度 寸法 基準線 寸法 長さ 寸法 直線直径 寸法 座標寸法 半径寸法 半径方向の 直径 寸法 |
寸法値の計算と表示に使用する、現在選択されている単位。
|
| Value Precision | 角度 寸法 基準線 寸法 長さ 寸法 直線直径 寸法 座標寸法 半径寸法 半径方向の 直径 寸法 |
寸法の表示に使用する、小数点以下の桁数の現在の設定。 |
値 |
||
| Format | 中心寸法と引出線寸法を除くすべて |
寸法テキストの形式の現在の設定。必要に応じて、対応するドロップダウンで形式を変更します。表示されるオプションは、選択した Unit によって異なり、現在の寸法の実際の値に基づいて表示されます。一般的に、使用できるオプションは次のとおりです(使用できるオプションの組み合わせは、寸法オブジェクトの種類によって異なります)。
|
| Prefix | 角度 寸法 基準線 寸法 長さ 寸法 直線直径 寸法 座標寸法 半径寸法 半径方向の 直径 寸法 |
寸法値の接頭辞。直線直径寸法または半径方向の直径寸法の場合、このフィールドは文字 øに固定されます。 |
| Suffix | 角度 寸法 基準線 寸法 長さ 寸法 直線直径 寸法 座標寸法 半径寸法 半径方向の 直径 寸法 |
寸法値の接尾辞。 |
| Sample | 中心寸法と引出線寸法を除くすべて |
このフィールドには、指定した Format と、定義されている Prefix および/または Suffixに応じた寸法テキストの表示例が示されます。 |
| Start point (X/Y) | 標準寸法 | 寸法の始点のX座標(最初の値)とY座標(2番目の値)。 |
| End point (X/Y) | 標準寸法 | 寸法の終点のX座標(最初の値)とY座標(2番目の値)。 |
寸法をプリミティブに変換する
寸法はグループ化された設計オブジェクトであり、1つ以上の文字列とトラックセグメントで構成されています。Tools » Convert » Explode Dimension to Free Primitives コマンドを使用すると、寸法をその構成要素であるプリミティブオブジェクトに変換できます。






