Rigid 및 Flex 영역 계획 - 표준 모드

개요

이 문서에서는 Altium Designer의 표준 Rigid-Flex 모드가 작동하는 방식을 살펴보고, 특히 보드 계획 모드에서 분할선을 사용해 보드 영역을 계획하는 방법을 중점적으로 설명합니다. PCB가 표준 모드와 고급 Rigid-Flex 모드 중 어떤 모드를 사용하는지 확인하는 방법, 표준 워크플로에서 분할선으로 보드 영역을 나누는 방식, 설계가 진행됨에 따라 분할선을 배치하고 이동하거나 제거하는 방법을 알아봅니다. 또한 레이어 스택을 할당하고, 영역 이름을 변경하며, 보드 형상을 정의하거나 재정의하여 처음부터 리지드 및 플렉스 영역을 올바르게 구성하는 방법도 다룹니다. Altium Designer에서 간단한 리지드 플렉스 영역 계획을 관리하는 실용적인 가이드가 필요하다면, 이 문서를 통해 자신감을 높이고 레이아웃 작업을 원활하게 진행할 수 있습니다.

- 표준 Rigid-Flex 모드와 고급 Rigid-Flex 모드의 핵심 차이를 알아보고, PCB에서 사용 중인 모드를 빠르게 확인하는 방법을 익힙니다.
- 분할선 배치, 이동, 삭제를 포함하여 표준 모드에서 보드 영역을 생성하고 편집하는 기본 워크플로를 따라 해 봅니다.
- 리지드 및 플렉스 영역을 올바르게 구성할 수 있도록 레이어 스택 할당, 영역 이름 변경, 보드 형상 정의 방법을 알아봅니다.
AI로 더 깊이 알아보기:

Altium의 PCB 설계 소프트웨어에서는 두 가지 Rigid-Flex 설계 모드를 사용할 수 있습니다. Rigid-Flex라고 하는 기존의 표준 모드는 간단한 Rigid-Flex 설계를 지원합니다. Flex 영역이 겹치는 등 설계에 더 복잡한 Rigid-Flex 요구 사항이 있는 경우 고급 Rigid-Flex 모드(Rigid-Flex 2.0이라고도 함)가 필요합니다. 모드는 Layer Stack Manager의 Tools 메뉴에서 선택합니다.

두 모드의 근본적인 차이는 기존 모드에서는 Split 라인을 배치하여 보드 형상을 별도의 보드 영역으로 나누고, 이 Split 라인이 한 보드 영역이 끝나고 다른 보드 영역이 시작되는 위치를 정의하는 객체로 유지된다는 점입니다. 고급 모드에서는 각 보드 영역을 개별적으로 배치하며, 큰 영역을 분할하면 두 개의 별도 영역 객체가 됩니다. 고급 모드에서는 Split 라인의 존재가 아니라 인접한 보드 영역의 가장자리가 두 영역이 만나는 위치를 정의합니다. 이러한 차이로 인해 보드가 고급 Rigid-Flex 모드에 있을 때는 Split 라인 객체가 존재하지 않습니다.

► Rigid-Flex PCB 설계에 대해 자세히 알아보기

View 메뉴에는 기억하기 쉬운 단축키가 있는 세 가지 PCB Editor 작업 모드가 있어 다음 모드 간에 빠르게 전환할 수 있습니다.

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

2D 및 3D 보기 모드 간에 전환할 때는 기본적으로 각 보기 모드의 확대/축소 및 방향 설정이 개별적으로 유지됩니다. 전환할 때 보드의 동일한 위치와 방향을 보려면 2 또는 3 대신 Ctrl+Alt+2 또는 Ctrl+Alt+3을 누르십시오.

방금 PCB를 열었는데 표준 Rigid-Flex 모드를 사용하는지 고급 Rigid-Flex 모드를 사용하는지 궁금하신가요?

Layer Stack Manager를 열어 확인할 수 있습니다. 또는 보드 계획 모드(1 단축키)로 전환한 후 Active Bar를 확인하십시오.

표준 Rigid-Flex 모드
고급 Rigid-Flex 모드

Split 라인을 배치하여 보드 형상을 두 영역으로 나눕니다. 이 작업은 PCB Editor가 Board Planning Mode 상태일 때 수행합니다. Board Region은 Split 라인 사이의 영역이며, 기본 영역 이름이 할당됩니다.

Split 라인 배치

Split 라인을 배치하려면:

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 들어갑니다.
  2. Design » Define Split Line을 선택하여 Split 라인 배치 모드로 들어갑니다( D, S 키 시퀀스를 사용하면 이 명령에 빠르게 액세스할 수 있습니다).
  3. 보드 형상의 within을 클릭하여 Split 라인 정의 프로세스를 시작합니다. 라인의 한쪽 끝은 클릭한 위치에서 가장 가까운 보드 형상 외곽선의 지점에 연결되고, 다른 쪽 끝은 커서에 연결됩니다.
  4. 커서를 원하는 위치로 이동한 다음 한 번 클릭하여 두 번째 끝점을 배치합니다. 위치가 유효하면 Split 라인은 파란색으로 유지됩니다. 위치가 유효하지 않으면(예: 보드 형상 외부) Split 라인이 빨간색으로 바뀝니다. 빨간색인 상태에서 클릭하여 배치하면 Split 라인이 제거됩니다.
  5. Split 라인 배치 모드가 유지되므로 필요한 경우 다른 Split 라인을 배치할 수 있습니다. 더 이상 배치하지 않으려면 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 Split 라인 배치 모드를 종료합니다.

Board Region은 Split 라인 사이의 영역이며, 기본 영역 이름이 할당됩니다.

보드 형상의 한쪽 가장자리에서 다른 가장자리까지 이어지는 Split 라인을 배치하여 보드를 개별 영역으로 나눕니다.
보드 형상의 한쪽 가장자리에서 다른 가장자리까지 이어지는 Split 라인을 배치하여 보드를 개별 영역으로 나눕니다.

Split 라인을 배치하여 보드를 여러 개의 개별 영역으로 나눈 모습입니다. 굽힘 라인도 배치되어 있습니다.
Split 라인을 배치하여 보드를 여러 개의 개별 영역으로 나눈 모습입니다. 굽힘 라인도 배치되어 있습니다.

Split 라인 이동

Split 라인을 이동하려면:

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 들어갑니다.
  2. 라인의 끝점을 이동하려면 해당 끝점을 클릭한 상태로 보드 형상 둘레의 원하는 위치로 드래그합니다. 커서는 현재 Snap Grid로 제한됩니다.

편집한 Split 라인의 새 위치에 따라 Board Region이 다시 정의됩니다.

유효한 분할을 유지할 수 있는 허용된 위치로 드래그하는 동안 Split 라인은 파란색으로 유지됩니다. 이동 중인 끝점의 새 위치가 유효하지 않으면(예: 고정된 끝점과 동일한 보드 형상 가장자리에 있는 경우) Split 라인이 빨간색으로 바뀝니다. 라인이 빨간색인 상태에서 배치하려고 하면 Split 라인이 제거됩니다.

Split 라인의 끝 노드를 선택하고 드래그하여 Board Region 영역을 다시 정의합니다.
Split 라인의 끝 노드를 선택하고 드래그하여 Board Region 영역을 다시 정의합니다.

Split 라인 제거

Split 라인을 삭제하려면:

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 들어갑니다.
  2. 끝점 중 하나를 클릭한 상태에서 Delete 키를 누릅니다. 또는 끝점을 클릭한 상태로 Split 라인이 빨간색으로 바뀌는(유효하지 않은 분할을 나타냄) 보드 형상 둘레의 지점으로 이동한 다음 놓습니다.

활성 보드에서 기존 Split 라인을 하나 이상 삭제하려면 Board Planning Mode에서 기본 메뉴의 Design » Delete Split Line 명령을 사용할 수도 있습니다. 명령을 실행하면 커서가 십자선으로 바뀌고 Split 라인 삭제 모드로 들어갑니다. Split 라인을 삭제하려면 커서를 끝점 중 하나(편집 핸들) 위에 놓고 클릭하거나 Enter을 누릅니다. 같은 방법으로 다른 Split 라인을 계속 제거하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 Split 라인 삭제 모드를 종료합니다.

레이어 스택 할당 및 Board Region 이름 편집

Related page: 레이어 스택 정의

새 보드를 생성하면 이름이 Default Layer Stack Region인 하나의 영역이 만들어집니다. 이 영역에는 이름이 Board Layer Stack인 기본 레이어 스택이 할당됩니다.

보드 형상을 여러 영역으로 분할하면 각각의 새 영역에도 기본 레이어 스택이 할당됩니다. 원래 영역의 이름은 Default Layer Stack Region이며, 이후 영역의 이름은 Layer Stack Region 형식으로 지정됩니다. 필요한 레이어 스택이 Layer Stack Manager에 정의되어 있으면 각 영역에 스택을 할당하고 알아보기 쉬운 이름을 지정할 수 있습니다.

각 영역에는 영역 이름과 할당된 레이어 스택 이름을 Region Name - Layer Stack Name 형식으로 보여 주는 레이블이 표시됩니다. 레이어 스택에 Flex가 활성화되어 있으면 (flex)로도 표시됩니다. 스택의 Flex 설정은 Layer Stack Manager에서 활성화합니다.

레이어 스택을 할당하고 영역 이름을 지정하려면:

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 들어갑니다.
  2.  Multi-Layer을 클릭합니다. 워크스페이스 하단의 탭을 클릭하여 활성 레이어로 설정합니다(레이어 탭이 보이지 않으면 L을 눌러 View Configuration 패널을 열고 해당 레이어를 활성화합니다).
  3. 보드 영역을 두 번 클릭하여 Board Region 대화상자를 엽니다. 영역이 선택되지 않고 대화상자도 열리지 않으면 선택 필터에서 영역을 제외하고 있지 않은지 확인합니다.
  4. Layer stack 드롭다운에서 필요한 스택을 선택하여 레이어 스택을 할당합니다.
  5. 필요에 따라 Name을 편집합니다.
  6. 3D 표시 모드의 물리적 접지 기준을 정의하려면 보드 영역 중 하나에서 3D Locked 옵션을 활성화해야 합니다.
  7. OK을 클릭하여 설정을 적용하고 대화상자를 닫습니다.

보드 영역을 두 번 클릭하여 영역 이름을 정의하고 레이어 스택을 할당합니다.
보드 영역을 두 번 클릭하여 영역 이름을 정의하고 레이어 스택을 할당합니다.

PCB 패널의 레이어 스택 영역 모드에서 원하는 스택업 영역을 두 번 클릭해도 Board Region 대화상자를 열 수 있습니다. Board Planning Mode으로 전환하면 PCB 패널에 이 모드가 자동으로 표시됩니다.

보드 외곽선을 분할하여 영역을 생성하는 방법 요약

분할선을 배치하면 보드 형상이 별도의 보드 영역으로 나뉩니다. 보드 형상은 여러 가지 방법으로 정의할 수 있습니다. 아래 동영상에서는 기계 레이어의 선과 원호로 생성한 외곽선을 사용하는 방법을 보여줍니다. 전체 외곽선을 정의한 후에는 이를 서로 다른 리지드 및 플렉스 영역으로 분할합니다.

보드 형상 및 영역 정의:

  • 보드 계획 모드(View » Board Planning Mode)에서 대화형으로 보드 형상을 정의하거나, 위 동영상에서 보여주는 것처럼 2D 레이아웃 모드(View » 2D Layout Mode)에서 기존 외곽선을 기반으로 정의할 수 있습니다.
  • 기존 외곽선으로 보드 형상을 정의하려면 2D 레이아웃 모드에서 외곽선을 선택하고 Design » Board Shape » Define Board Shape from Selected Objects 명령을 실행합니다. 소프트웨어는 선택한 트랙/원호 객체의 중심선을 따라 추적하여 보드 형상의 바깥쪽 경계를 정의합니다. 추적 알고리즘이 중심선을 따라갈 수 있으려면 외곽선을 구성하는 트랙/원호의 끝점이 일치해야 합니다. 추적에 실패하면 추적 알고리즘은 선택한 객체의 바깥쪽 경계를 따라 추적을 시도할지 묻습니다.
  • 보드 형상을 대화형으로 정의하려면 보드 계획 모드(1 단축키)로 전환하고 Design » Redefine Board Shape 명령을 선택합니다. 보드 형상을 정의할 때는 표준 영역 객체 배치 방식이 적용되며, Snap Grid와 워크스페이스 가이드를 활용하면 작업에 도움이 됩니다. 보드 형상을 편집할 때 가장 정밀하게 제어하려면 Snap 옵션 팔레트에서 보드 형상 옵션을 활성화합니다. Snap 동작 이해하기에서 자세히 알아보세요.
  • 각 영역의 Name을 정의하고 Layer stack을 할당하려면 해당 영역을 두 번 클릭합니다. 또는 PCB 패널을 Layer Stack Regions 모드로 설정하여 영역과 굽힘 선을 확인하고 편집할 수 있습니다.
  • Board Region을 두 개의 더 작은 영역으로 분할하려면 Design » Define Split Line 명령을 사용합니다. 이 명령은 두 번 클릭한 위치 사이에 직선을 배치합니다. 보드 형상 내부를 클릭하면 첫 번째 위치는 클릭한 지점에서 가장 가까운 보드 가장자리로 지정됩니다. 커서를 움직여 두 번째 위치를 지정한 다음 다시 클릭합니다. 분할선의 꼭짓점을 클릭한 채 드래그하면 새 위치로 이동할 수 있습니다.
  • 기존 Board Region의 위치와 형상을 편집할 수 있습니다. 설계 Design » Edit Board Shape 명령을 실행한 다음 표준 다각형 객체 편집 기법을 사용하여 형상을 조정합니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents