Component Templates

Aby usprawnić tworzenie komponentów, Altium Designer we współpracy z połączoną przestrzenią roboczą umożliwia tworzenie i definiowanie Component Templates (elementów szablonów komponentów) w tej przestrzeni roboczej. Podobnie jak szablon schematu pozwala wstępnie określić informacje na arkuszach schematów, które się do niego odwołują, tak szablon komponentu jest wykorzystywany przez komponent biblioteczny przestrzeni roboczej i udostępnia wstępnie zdefiniowane ustawienia używane podczas definiowania tego komponentu.

Szablony komponentów opracowano przede wszystkim z myślą o informacjach parametrycznych. Umożliwiają one zdefiniowanie w jednym miejscu zestawu parametrów, który będzie dostępny dla komponentu odwołującego się do szablonu. Za pomocą szablonu można określić, które parametry mają być widoczne, uzupełnić ich wartości domyślne, a nawet oznaczyć wybrane parametry jako obowiązkowe. Podczas zapisywania komponentu przeprowadzane są kontrole poprawności, aby zapewnić zgodność z tymi wymaganiami.

Wartości domyślne określone dla wielu ustawień szablonu można zablokować jako wartości tylko do odczytu lub wybiórczo zezwolić projektantowi na ich zmianę podczas definiowania komponentu.

Szablon komponentu stanowi również podstawę do tworzenia komponentu ogólnego. Więcej informacji można znaleźć na stronie Tworzenie komponentów ogólnych.

Dostęp do szablonów komponentów zależy od posiadanej licencji oprogramowania. Więcej informacji można znaleźć w ramce Note po prawej stronie.

Takie szablony komponentów tworzy się bezpośrednio w przestrzeni roboczej. Po utworzeniu szablonu komponentu i zapisaniu danych w jego rewizji można go ponownie wykorzystać do utworzenia jednego lub większej liczby komponentów.

Typ folderu

Podczas tworzenia folderu do przechowywania szablonów komponentów można określić jego typ. Nie ma to wpływu na zawartość folderu — opublikowanie szablonu komponentu zawsze spowoduje utworzenie odpowiedniego elementu szablonu komponentu. Typ folderu stanowi jedynie wizualną wskazówkę dotyczącą jego zawartości i może być pomocny podczas przeglądania przestrzeni roboczej w poszukiwaniu określonych danych. Aby wskazać, że folder ma służyć do przechowywania szablonów komponentów, ustaw jego Folder Type na Component Templates podczas definiowania właściwości folderu w oknie dialogowym Edytuj folder.

Określenie typu folderu — czyli jego przeznaczenia — pozwala wizualnie rozpoznać jego zawartość podczas przeglądania przestrzeni roboczej.
Określenie typu folderu — czyli jego przeznaczenia — pozwala wizualnie rozpoznać jego zawartość podczas przeglądania przestrzeni roboczej.

Typ zawartości

Podczas tworzenia docelowego elementu szablonu komponentu, w którym ma zostać zapisany szablon, upewnij się, że jego Content Type jest ustawiony na Component Template w oknie dialogowym Utwórz nowy element. Jeśli tworzysz element w folderze typu Component Templates, ten typ zawartości będzie dostępny w menu kontekstowym otwieranym prawym przyciskiem myszy podczas tworzenia elementu.

Tworzenie szablonu komponentu w folderze Component Templates — odpowiedni Content Type jest dostępny w menu kontekstowym.
Tworzenie szablonu komponentu w folderze Component Templates — odpowiedni Content Type jest dostępny w menu kontekstowym.

Zapisywanie szablonu komponentu

Related page: Tworzenie i edytowanie zawartości

Dotychczas omówiliśmy obsługę szablonu komponentu w przestrzeni roboczej w kontekście powiązanych typów folderów i zawartości. Zapisanie zdefiniowanego szablonu komponentu w rewizji takiego elementu szablonu komponentu można przeprowadzić w prosty i sprawny sposób.

Dzięki obsłudze bezpośredniej edycji w przestrzeni roboczej szablon komponentu można edytować i zapisać w początkowej rewizji nowo utworzonego elementu szablonu komponentu. Bezpośrednia edycja eliminuje konieczność korzystania z oddzielnych danych źródłowych objętych kontrolą wersji. Obsługiwany typ zawartości można po prostu edytować w tymczasowym edytorze, do którego wczytywane są najnowsze dane źródłowe bezpośrednio z przestrzeni roboczej. Po zakończeniu edycji obiekt jest zapisywany (lub zapisywany ponownie) w kolejnej zaplanowanej rewizji jego elementu nadrzędnego, a tymczasowy edytor zostaje zamknięty. Na dysku twardym nie pozostają żadne pliki, nie trzeba zastanawiać się, czy używane dane źródłowe są właściwe lub aktualne, ani utrzymywać oddzielnego oprogramowania do kontroli wersji. Przestrzeń robocza obsługuje cały proces, zapewniając integralność danych i znacznie przyspieszając wprowadzanie w nich zmian.

Podczas tworzenia elementu szablonu komponentu możesz edytować szablon komponentu i zapisać go w początkowej rewizji tego elementu po jego utworzeniu. W tym celu włącz opcję Open for editing after creation u dołu okna dialogowego Create New Item (opcja ta jest domyślnie włączona). Element zostanie utworzony, a tymczasowy edytor szablonów komponentów otworzy się z dokumentem .CMPT jako aktywnym dokumentem w głównym oknie projektowania. Nazwa tego dokumentu będzie odpowiadać elementowi i jego rewizji, w formacie: <Item><Revision>.CMPT (np. CMPT-0001-1.CMPT).

 
 
 
 
 

Przykład edycji początkowej rewizji szablonu komponentu bezpośrednio z przestrzeni roboczej — tymczasowy edytor szablonów komponentów udostępnia dokument służący do zdefiniowania szablonu komponentu.
Przykład edycji początkowej rewizji szablonu komponentu bezpośrednio z przestrzeni roboczej — tymczasowy edytor szablonów komponentów udostępnia dokument służący do zdefiniowania szablonu komponentu.

Użyj dokumentu, aby zdefiniować szablon komponentu zgodnie z potrzebami. Więcej informacji na ten temat znajdziesz w sekcji Definiowanie szablonu.

Podczas edycji bezpośredniej dostępne są trzy przydatne elementy sterujące, które znajdziesz w Quick Access Bar (w lewym górnym rogu głównego okna aplikacji) lub na pasku narzędzi Component Template Standard:

  • – Save Active Document. Użyj tego przycisku, aby zapisać lokalnie zmiany wprowadzone w dokumencie. Pozwala to zachować bieżące zmiany, jeśli chcesz wrócić później do edycji i wprowadzić kolejne zmiany przed ostatecznym zapisaniem dokumentu w przestrzeni roboczej.
  • / – Save to Server. Użyj tego przycisku, aby zapisać zdefiniowany szablon komponentu w przestrzeni roboczej, w początkowej (planowanej) rewizji docelowego elementu szablonu komponentu. Zostanie wyświetlone okno dialogowe Edit Revision, w którym możesz zmienić nazwę i opis oraz w razie potrzeby dodać uwagi do wydania. Po zapisaniu dokument i edytor zostaną zamknięte. Dokument zawierający źródłowy szablon komponentu, *.CMPT, zostanie zapisany w rewizji elementu.

    Element sterujący Save to Server jest również dostępny po prawej stronie wpisu szablonu komponentu bezpośrednio w panelu Projects.
  • / – Discard Local Changes. Użyj tego przycisku, jeśli chcesz anulować edycję i odrzucić wszystkie wprowadzone zmiany. Dokument i edytor zostaną zamknięte, a do docelowego elementu szablonu komponentu nie zostaną opublikowane żadne dane.

Te elementy sterujące są również dostępne jako polecenia — Save (skrót: Ctrl+S), Save to Server (skrót: Ctrl+Alt+S) i Discard Local Changes — w menu głównym File oraz w menu kontekstowym wpisu szablonu komponentu w panelu Projects.

Dane zapisane w przestrzeni roboczej obejmują źródłowy szablon komponentu zdefiniowany w pliku szablonu komponentu (<Item><Revision>.CMPT).

 
 
 
 
 

Przykładowy zdefiniowany szablon komponentu zapisany z powrotem w przestrzeni roboczej.
Przykładowy zdefiniowany szablon komponentu zapisany z powrotem w przestrzeni roboczej.

Dziedziczenie szablonu komponentu

Ta funkcja jest dostępna, gdy opcja UI.ComponentTemplateInheritance jest włączona w oknie dialogowym Advanced Settings.

Możesz użyć szablonu komponentu przypisanego do nadrzędnego typu komponentu, jeśli podtyp nie ma powiązanego szablonu komponentu. Podczas tworzenia hierarchii typów komponentów podtypy dziedziczą szablon komponentu przypisany do głównego lub nadrzędnego typu komponentu.

Edytor CMPT (szablonów komponentów)

Aby uzyskać dostęp do edytora szablonów komponentów w Altium Designer, należy zainstalować rozszerzenie Component Template Editor. Rozszerzenie to jest domyślnie instalowane wraz z Altium Designer. Można je ręcznie zainstalować lub usunąć.

Więcej informacji o zarządzaniu rozszerzeniami znajdziesz na stronie Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definiowanie szablonu

Edytor szablonów komponentów jest podzielony na dwa główne obszary, pokazane na poniższej ilustracji i opisane pod nią.

 
 
 
 
 

Edytor szablonów komponentów można podzielić na dwa główne obszary.
Edytor szablonów komponentów można podzielić na dwa główne obszary.

  1. Upper Region — służy do definiowania opcji na poziomie komponentu (cyklu życia, nazewnictwa i folderów) dla komponentu korzystającego z szablonu.
  2. Lower Region — służy do definiowania parametrów używanych przez komponent korzystający z szablonu.

Określanie opcji komponentu

Górna połowa edytora służy do definiowania wartości domyślnych następujących właściwości komponentu:

  • Lifecycle Definition — wybierz definicję cyklu życia, która zostanie zastosowana do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie definicje skonfigurowane dla przestrzeni roboczej, które mogą być używane przez komponent.

  • Revision Naming — wybierz schemat nazewnictwa rewizji, który zostanie zastosowany do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie schematy skonfigurowane dla przestrzeni roboczej, które mogą być używane przez komponent.

    Jeśli dla dowolnych definicji lub schematów włączono opcję kontrolowania użycia definicji cyklu życia i schematów nazewnictwa rewizji według typu zawartości, a typ zawartości Komponent nie jest skonfigurowany do używania danej definicji lub schematu, ta definicja lub schemat nie będą dostępne na odpowiedniej liście rozwijanej.

  • Component Naming – w tym polu zdefiniuj domyślny schemat nazewnictwa elementów dla komponentu tworzonego na podstawie szablonu, zapewniający mu unikatowy identyfikator w przestrzeni roboczej. Wpis w tym polu będzie używany jako szablon do automatycznego nadawania nazwy komponentowi (w powiązanym polu Id, gdy edytor komponentów pracuje w trybie Single Component Editing, lub w polu Item ID, gdy edytor komponentów pracuje w trybie Batch Component Editing). Po sprawdzeniu całej przestrzeni roboczej i identyfikatorów istniejącej zawartości oprogramowanie automatycznie przypisze następny dostępny unikatowy identyfikator zgodnie z tym schematem. Dostępny jest domyślny schemat nazewnictwa elementów – CMP-{00000} – ale możesz oczywiście utworzyć własny, wpisując go w tym polu i ujmując część zmienną w nawiasy klamrowe (np. CMP-001-{0000}).

  • Default Folder – pozwala określić domyślny folder w docelowej przestrzeni roboczej, w którym będzie przechowywany zapisany komponent. Kliknij przycisk Choose, aby otworzyć okno dialogowe Choose Folder (odmianę panelu Explorer), w którym możesz przejść do istniejącego folderu w przestrzeni roboczej i go wybrać lub od razu utworzyć nowy.

Nie ma pola umożliwiającego ustawienie docelowej przestrzeni roboczej, ponieważ na stałe używana jest ta sama przestrzeń robocza, w której znajduje się rewizja szablonu komponentu.

Opcja Allow override dla każdej właściwości pozwala niezależnie określić, czy użytkownik może ją zmieniać (opcja włączona), czy nie (opcja wyłączona) podczas definiowania komponentu w edytorze komponentów.

Gdy szablon jest używany, wpisy określone w tym obszarze służą do wstępnego wypełnienia odpowiednich pól w edytorze komponentów (tam, gdzie są dostępne):

  • Single Component Editing mode – pola Id i Folder w obszarze Advanced Settings sekcji Component.
  • Batch Component Editing mode – na karcie Document Options w oknie dialogowym Document Options, a w konsekwencji także pola Item ID i FolderPath w obszarze Component sekcji definicji komponentów.

Gdy szablon jest używany, wpisy służą do wstępnego wypełnienia odpowiednich pól podczas edycji komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i Batch Component Editing (po prawej).
Gdy szablon jest używany, wpisy służą do wstępnego wypełnienia odpowiednich pól podczas edycji komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i Batch Component Editing (po prawej).

Definiowanie parametrów

Dolna połowa edytora służy do definiowania parametrów i zarządzania nimi. Parametry te będą dostępne dla komponentu korzystającego z szablonu.

 
 
 
 
 

Przykładowe parametry zdefiniowane w szablonie komponentu.
Przykładowe parametry zdefiniowane w szablonie komponentu.

Domyślne parametry systemowe

Podczas tworzenia nowego szablonu komponentu domyślnie dodawane są różne parametry systemowe, pokazane na poniższej ilustracji i szczegółowo opisane dalej.

 
 
 
 
 

Domyślne parametry systemowe zawarte w nowo utworzonym szablonie komponentu.
Domyślne parametry systemowe zawarte w nowo utworzonym szablonie komponentu.

  • ComponentType – ten parametr pozwala określić typ komponentu. Ułatwia to precyzyjne wyszukiwanie za pomocą rozbudowanej funkcji wyszukiwania w przestrzeni roboczej, która umożliwia nie tylko wyszukiwanie według typu komponentu, ale także bardziej inteligentne wyszukiwanie dzięki obsłudze parametrów komponentów uwzględniających jednostki. Podczas przeglądania własnych komponentów w przestrzeni roboczej za pomocą panelu Components grupowanie komponentów według Categories wynika z parametrów ComponentType przypisanych do każdego komponentu. Kliknij powiązane pole Default Value, a następnie przycisk , aby otworzyć okno dialogowe Choose component type. Wybierz w nim wymagany typ komponentu i kliknij OK – wybrany typ zostanie wstawiony jako wartość parametru ComponentType w głównej tabeli parametrów.

    Okno dialogowe Choose component type odzwierciedla zestaw typów komponentów zdefiniowanych na stronie Data Management – Component Types w oknie dialogowym Preferences. Kliknij przycisk u dołu okna dialogowego Choose component type, aby otworzyć tę stronę preferencji. Możesz na niej dostosować listę do swoich potrzeb, dodając nowe typy i podtypy lub edytując i usuwając istniejące typy.

    Przykładowy szablon komponentu z parametrem systemowym ComponentType ustawionym na Diodes.
    Przykładowy szablon komponentu z parametrem systemowym ComponentType ustawionym na Diodes.

     
     
     
     
     

    Typ danych tego parametru jest ustawiony na ComponentType i nie można go zmienić. Ponadto parametru ComponentType nie można kopiować ani usuwać. Zaznacz komórkę i użyj klawisza Delete , aby wyczyścić wartość.

  • SCHLIB i PCBLIB — te dwa parametry pozwalają określić odpowiednio domyślne modele symbolu i footprintu. Kliknij powiązane pole Default Value dla każdego parametru, a następnie kliknij przycisk , aby otworzyć okno dialogowe umożliwiające wybór wymaganego modelu.

    Pamiętaj, że wybierasz model, a nie jego konkretną rewizję. Dzięki temu komponent korzystający z szablonu będzie zawsze używać najnowszej rewizji wybranego modelu.

    Określ modele symbolu i footprintu w swoim szablonie.
    Określ modele symbolu i footprintu w swoim szablonie.

     
     
     
     
     

    Typy danych tych parametrów są ustawione odpowiednio na SCHLIB i PCBLIB i nie można ich zmienić. Ponadto parametrów modeli nie można kopiować ani usuwać. Zaznacz komórkę i użyj klawisza Delete , aby wyczyścić wartość.

  • Name i Description — te dwa parametry pozwalają zdefiniować odpowiednio nazwę i opis komponentu. Wprowadź wymagane ciągi tekstowe w powiązanym polu Default Value dla każdego parametru.

    Określ parametry Name i Description w swoim szablonie.
    Określ parametry Name i Description w swoim szablonie.

     
     
     
     
     

    Typ danych obu tych parametrów jest ustawiony na Text i nie można go zmienić. Ponadto tych parametrów nie można kopiować ani usuwać.

Dodawanie nowego parametru użytkownika

Aby dodać nowy parametr użytkownika do listy, kliknij przycisk (lub użyj polecenia Add z menu kontekstowego dostępnego po kliknięciu prawym przyciskiem myszy) — parametr zostanie dodany na końcu bieżącej listy.

 
 
 
 
 

Przykład dodania nowego parametru użytkownika do szablonu.
Przykład dodania nowego parametru użytkownika do szablonu.

Każdy parametr jest przedstawiony w tabeli za pomocą następujących informacji:

  • Name – w tym polu nadaj parametrowi nazwę, najlepiej taką, która jasno określa jego przeznaczenie. Nowo dodane parametry otrzymują nazwy domyślne (Parameter, Parameter 1, Parameter 2 itd.).

  • Type – typ parametru. Początkowo domyślną wartością tego pola jest Text, ale obsługiwane są różne typy danych uwzględniające jednostki, a także typ PCBLIB, który umożliwia definiowanie wielu obudów PCB, oraz HarnessWiring, który umożliwia zdefiniowanie komponentu okablowania wiązki. Obsługiwane są również typy parametrów zdefiniowane w dostępnych słownikach – dowiedz się więcej.

  • Visible – włącz tę opcję (domyślnie jest włączona dla nowo dodanego parametru), aby odpowiednia opcja Show dla tego parametru była włączona podczas edycji jednego lub wielu komponentów w Edytorze komponentów (skonfigurowanym w trybie Batch Component Editing). Steruje ona wyświetlaniem kolumny odpowiadającej temu parametrowi w dolnej części Edytora komponentów, w której definiuje się same komponenty. Ta właściwość nie ma wpływu na definiowanie komponentu w trybie Single Component Editing edytora.

  • Read Only – włącz tę opcję, aby parametr był tylko do odczytu. Podczas edycji komponentu korzystającego z tego szablonu nie będzie można edytować wartości parametru.

  • Required – włącz tę opcję, aby parametr był wymagany. Podczas edycji komponentu korzystającego z tego szablonu parametr musi mieć zdefiniowaną wartość; w przeciwnym razie zapisanie komponentu nie będzie możliwe. W Edytorze komponentów taki parametr jest wyróżniany czerwoną ramką komórki wartości (w trybie Batch Component Editing) lub ikoną w tej komórce (w trybie Single Component Editing), gdy nie wprowadzono wartości.

  • Default Value – w tym polu wprowadź domyślną wartość parametru.

    • Jeśli parametr jest oznaczony jako wymagany (opcja Required jest włączona), a jednocześnie ustawiony jako tylko do odczytu (opcja Read Only jest włączona), MUST wprowadzić wartość domyślną. W przeciwnym razie podczas edycji komponentu korzystającego z tego szablonu parametr zostanie oznaczony jako niemający wartości, ale nie będzie można tego naprawić, ponieważ parametr jest tylko do odczytu i nie można go edytować. Dopóki ten problem nie zostanie rozwiązany, nie będzie można zapisać nowej rewizji tego szablonu komponentu w przestrzeni roboczej.

    • Podczas edycji rewizji komponentu istniejący parametr zdefiniowany przez użytkownika, który ma taką samą nazwę jak parametr w powiązanym szablonie komponentu, zostanie zastąpiony wersją z szablonu. Istniejąca wartość tego parametru zostanie zachowana (i nie zostanie nadpisana wartością domyślną z szablonu).

  • Description – dodaj opis parametru, na przykład krótką informację o jego przeznaczeniu. Jeśli parametr w szablonie ma zdefiniowany opis, kolumna Description będzie odpowiednio wyświetlana w obszarze Parameters Edytora komponentów w jego Single Component Editing.

Lista parametrów obsługuje również proste operacje kopiowania i wklejania, umożliwiające powielanie jednego lub wielu istniejących parametrów użytkownika. Wklejone parametry zostaną dodane na końcu listy.

Obsługiwane są standardowe skróty kopiowania (Ctrl+C) i wklejania (Ctrl+V), a polecenia te są również dostępne w menu wyświetlanym po kliknięciu prawym przyciskiem myszy. Do operacji kopiowania i wklejania można zaznaczyć wiele parametrów użytkownika, korzystając ze standardowych metod z użyciem Ctrl+Click i Shift+Click.
Aby usunąć z listy jeden lub więcej parametrów użytkownika, zaznacz każdy z nich, a następnie kliknij przycisk lub użyj polecenia Remove z menu kontekstowego dostępnego po kliknięciu prawym przyciskiem myszy.

Typy danych parametrów komponentów uwzględniające jednostki

Edytor szablonów komponentów umożliwia określanie konkretnych typów danych dla parametrów komponentów zdefiniowanych w szablonie komponentu (*.CMPT). Typy te uwzględniają również jednostki i obsługują szereg popularnych przedrostków jednostek. Dzięki temu wartość parametru można wprowadzać w różnych formatach — takich jak 2.2k, 2k2, 4M, 2.5GHz — a Workspace potrafi rozpoznać wartość liczbową kryjącą się za tymi zapisami.

Ta funkcja szablonu komponentu ułatwia precyzyjne wyszukiwanie za pomocą serwerowej funkcji wyszukiwania zaawansowanego, która pozwala nie tylko wyszukiwać według typu komponentu, lecz także wyszukiwać bardziej inteligentnie, z użyciem zakresów wartości. Dzięki parametrom komponentów uwzględniającym jednostki można szybko zdefiniować wyszukiwanie, na przykład wszystkich kondensatorów o pojemności od 47uF do 220uF.

Parametry uwzględniające jednostki są również używane do inteligentnego filtrowania podczas wyszukiwania własnych komponentów za pomocą panelu Components.

Więcej informacji o parametrach uwzględniających jednostki znajdziesz w poniższych rozwijanych sekcjach.

Typy danych parametrów zdefiniowane przez słownik

Słowniki to niestandardowe typy parametrów z zestawem zdefiniowanych wartości. Słownikami zarządzają administratorzy przestrzeni roboczej na stronie Settings – Vault – Dictionaries w interfejsie przeglądarkowym przestrzeni roboczej. Można ją otworzyć z edytora szablonów komponentów, wybierając opcję Add New Dictionary z listy rozwijanej Type lub klikając element Manage Dictionaries w prawym górnym rogu obszaru Parameters.

  • Stronę Settings – Vault – Dictionaries można również otworzyć ze strony Zarządzanie danymi – Słowniki w oknie dialogowym Preferences, klikając element Manage Dictionaries, a także ze strony Zarządzanie danymi – Serwery w oknie dialogowym Preferences, klikając element Properties dla aktywnej lub znanej przestrzeni roboczej i wybierając z menu pozycję Dictionaries.

  • Gdy dla parametru wybrano typ zdefiniowany przez słownik, stronę Settings – Vault – Dictionaries można również otworzyć, klikając komórkę parametru w kolumnie Type, a następnie przycisk  ().

Otwórz stronę zarządzania słownikami w interfejsie przeglądarkowym przestrzeni roboczej z poziomu edytora szablonów komponentów.
Otwórz stronę zarządzania słownikami w interfejsie przeglądarkowym przestrzeni roboczej z poziomu edytora szablonów komponentów.

Dowiedz się więcej o zarządzaniu słownikami w interfejsie przeglądarkowym przestrzeni roboczej (Altium 365 Workspace, przestrzeń robocza Enterprise Server).

Zdefiniowane słowniki są dostępne jako typy parametrów na liście rozwijanej Type.

Wybierz typ parametru zdefiniowany przez słownik z listy rozwijanej Typ.
Wybierz typ parametru zdefiniowany przez słownik z listy rozwijanej Typ.

Wartości zdefiniowane dla wybranego typu słownikowego są dostępne na liście rozwijanej Default Value. Wybierz żądaną wartość jako domyślną wartość parametru lub wybierz <None>.

Wybierz wartość domyślną spośród wartości zdefiniowanych dla wybranego typu słownikowego.
Wybierz wartość domyślną spośród wartości zdefiniowanych dla wybranego typu słownikowego.

  • Wartości domyślne są sprawdzane podczas zapisywania szablonu komponentu w przestrzeni roboczej. Jeśli wartość domyślna stanie się niezgodna ze słownikiem (np. wartość została usunięta ze słownika, a następnie szablon używający tej wartości został otwarty do edycji), zostanie ona wyróżniona na czerwono w kolumnie Wartość domyślna, a przy próbie ponownego zapisania szablonu w przestrzeni roboczej w panelu Messages pojawi się komunikat o błędzie.

  • Jeśli wartość parametru komponentu stanie się niezgodna ze słownikiem (np. typ tego parametru został zmieniony w szablonie komponentu z typu Tekst na typ zdefiniowany przez słownik, a bieżąca wartość parametru komponentu nie odpowiada żadnej wartości z wybranego typu słownikowego), parametr ten zostanie wyróżniony podczas edycji komponentu w edytorze komponentów: obok niezgodnej wartości parametru pojawi się ikona wykrzyknika w trybie edycji pojedynczego komponentu, a w trybie zbiorczej edycji komponentów wartość parametru zostanie wyróżniona na czerwono. Upewnij się, że wszystkie parametry komponentu są zgodne z wartościami szablonu; w przeciwnym razie zapisanie kolejnej rewizji komponentu nie będzie możliwe.

  • Jeśli słowniki zostały zmienione w interfejsie przeglądarkowym połączonej przestrzeni roboczej, należy rozłączyć się z przestrzenią roboczą i ponownie się z nią połączyć, aby zmiany zostały uwzględnione w Altium Designer. Więcej informacji można znaleźć na stronie Uzyskiwanie dostępu do przestrzeni roboczej.

Definiowanie wielu footprintów

Edytor szablonów komponentów umożliwia również definiowanie wielu footprintów PCB w ramach szablonu komponentu. Można określić dowolną liczbę powiązań z modelami footprintów. Jest to przydatna funkcja dla osób chcących tworzyć komponenty odwołujące się do 3 footprintów, spełniających wymagania IPC dla różnych poziomów gęstości: L (najmniejsza, czyli minimalna ilość miedzi), M (największa, czyli maksymalna ilość miedzi) oraz N (nominalna, czyli pośrednia ilość miedzi).

Aby dodać do szablonu definicję kolejnego modelu footprintu, kliknij , aby dodać nowy parametr, a następnie wybierz pozycję PCBLIB z menu rozwijanego powiązanego z polem Type.

Przekształć nowo dodany parametr w definicję modelu footprintu, ustawiając jego Type na PCBLIB.
Przekształć nowo dodany parametr w definicję modelu footprintu, ustawiając jego Type na PCBLIB.

Nazwa parametru zmieni się z Parameter na PCBLIB n, gdzie n to kolejna dostępna liczba całkowita pozwalająca rozróżnić wiele modeli footprintów (np. PCBLIB 1, PCBLIB 2 itd.). Modelem domyślnym będzie model powiązany z pozycją PCBLIB. Po wczytaniu footprintów do edytora komponentów podczas definiowania komponentu domyślny model footprintu jest oznaczony ikoną w lewym górnym rogu okna podglądu modelu (w trybie Single Component Editing) oraz pozycją PCBLIB (default) w obszarze Required Models/Parameters (w trybie Batch Component Editing).

Przykładowy komponent zdefiniowany w edytorze komponentów (tryb Single Component Editing) z użyciem wskazanego szablonu komponentu. W szablonie zdefiniowano trzy modele footprintów, które są przenoszone do definicji komponentu. Zwróć uwagę, że podczas definiowania komponentu wpis modelu PCBLIB w szablonie jest używany jako domyślny model footprintu (wyróżniony ikoną w lewym górnym rogu). Najedź kursorem na obraz, aby zobaczyć ten sam komponent definiowany w edytorze komponentów w trybie Batch Component Editing. W tym przypadku domyślny footprint nosi nazwę PCBLIB (default).
Przykładowy komponent zdefiniowany w edytorze komponentów (tryb Single Component Editing) z użyciem wskazanego szablonu komponentu. W szablonie zdefiniowano trzy modele footprintów, które są przenoszone do definicji komponentu. Zwróć uwagę, że podczas definiowania komponentu wpis modelu PCBLIB w szablonie jest używany jako domyślny model footprintu (wyróżniony ikoną w lewym górnym rogu). Najedź kursorem na obraz, aby zobaczyć ten sam komponent definiowany w edytorze komponentów w trybie Batch Component Editing. W tym przypadku domyślny footprint nosi nazwę PCBLIB (default).

Importowanie i eksportowanie szablonu komponentu

Istniejący plik szablonu komponentu (*.CMPT) lub plik biblioteki komponentów (*.CMPLIB) można zaimportować do edytora szablonów komponentów, a edytowany szablon komponentu można wyeksportować do pliku szablonu komponentu (*.CMPT). Użyj poleceń File » Import » Component Template, File » Import » Component Library i File » Export z menu głównego edytora komponentów, aby wybrać żądaną czynność, a następnie w otwartym standardowym oknie dialogowym systemu Windows przejdź do odpowiedniej lokalizacji i wybierz plik do zaimportowania lub określ nazwę pliku, który zostanie wyeksportowany.

Ponowne wykorzystanie szablonu komponentu

Wersję szablonu komponentu można wykorzystać — a dokładniej wskazać ją w aktualnie edytowanej wersji komponentu — na następujące sposoby.

Komponent może odwoływać się tylko do jednego szablonu komponentu naraz.

Podczas tworzenia nowego komponentu

Podczas tworzenia nowego komponentu za pomocą polecenia File » New » Component z menu głównego można wybrać szablon w oknie dialogowym Create new component.

Szybkie powiązanie szablonu komponentu z listy wszystkich dostępnych szablonów podczas tworzenia nowego komponentu.
Szybkie powiązanie szablonu komponentu z listy wszystkich dostępnych szablonów podczas tworzenia nowego komponentu.

Ręcznie w edytorze komponentów

Sposób ponownego wykorzystania wersji szablonu komponentu w edytorze komponentów zależy od trybu pracy edytora.

W trybie edycji pojedynczego komponentu

Podczas edycji pojedynczego komponentu w tym trybie edytora komponentów wybierz odpowiedni szablon komponentu z menu rozwijanego powiązanego z polem Template — należącym do grupy Advanced Settings w obszarze Component edytora. Na liście znajdują się nazwy wszystkich szablonów komponentów dostępnych obecnie w tym samym obszarze roboczym, w którym znajduje się komponent, a ich najnowsze wersje podano w nawiasach. Wybierz odpowiedni szablon, aby go zastosować.

Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów podczas edycji wersji komponentu w edytorze komponentów w trybie Single Component Editing.
Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów podczas edycji wersji komponentu w edytorze komponentów w trybie Single Component Editing.

W trybie zbiorczej edycji komponentów

Istnieją dwa sposoby powiązania wersji szablonu komponentu z aktualnie edytowaną wersją komponentu:

  • Na karcie Template w oknie dialogowym Opcje dokumentu (Edit » Document Options). Kliknij przycisk Choose po prawej stronie pola Item Revision. Otworzy to okno dialogowe Choose Item (wariant panelu Explorer). Użyj tego okna, aby odszukać i wybrać wersję odpowiedniego szablonu komponentu. Po kliknięciu OK zostanie utworzone powiązanie między wersją komponentu a docelową wersją szablonu komponentu. Potwierdzenie tego powiązania można zobaczyć na karcie Template w oknie dialogowym Document Options.

    Ręczne powiązanie komponentu z wersją szablonu komponentu w docelowym obszarze roboczym.
    Ręczne powiązanie komponentu z wersją szablonu komponentu w docelowym obszarze roboczym.

    Używany szablon komponentu można zmienić w dowolnym momencie — kliknij Choose i wybierz wersję innego szablonu komponentu.
    Status powiązanej wersji elementu szablonu komponentu jest widoczny na karcie Template w oknie dialogowym Document Options. Jeśli dostępna jest nowsza wersja powiązanego elementu, kliknij przycisk , aby użyć najnowszej wersji.
  • Z menu Add powiązanego z obszarem Required Models/Parameters edytora komponentów. Podmenu Templates zawiera nazwy wszystkich szablonów komponentów dostępnych obecnie w tym samym obszarze roboczym, w którym znajduje się komponent, a ich najnowsze wersje podano w nawiasach. Kliknij wybraną pozycję, aby utworzyć powiązanie z najnowszą wersją danego szablonu komponentu. Także w tym przypadku potwierdzenie powiązania można zobaczyć na karcie Templates w oknie dialogowym Document Options.

    Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów.
    Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów.

Dziedziczenie z folderu komponentów w obszarze roboczym

Można wskazać szablon komponentu, który będzie automatycznie używany dla wszystkich komponentów (i ich wersji) przechowywanych w folderze komponentów w obszarze roboczym.

Domyślny szablon komponentu można zdefiniować tylko dla folderu typu Components.

Wskaż odpowiedni szablon w polu Component Template podczas definiowania właściwości folderu w oknie dialogowym Edytuj folder. Lista rozwijana tego pola zawiera nazwy wszystkich szablonów komponentów dostępnych obecnie w tym samym obszarze roboczym, w którym znajduje się folder komponentów, a ich najnowsze wersje podano w nawiasach. Wybierz pozycję, aby każdy kolejny komponent utworzony w tym folderze był powiązany z najnowszą wersją danego szablonu komponentu.

Wskaż domyślny szablon komponentu, który będzie stosowany do wszystkich komponentów tworzonych w nadrzędnym folderze komponentów.
Wskaż domyślny szablon komponentu, który będzie stosowany do wszystkich komponentów tworzonych w nadrzędnym folderze komponentów.

Aby nie korzystać z tej funkcji, pozostaw lub ustaw w polu Component Template wartość None.

Jeśli szablon komponentu zostanie wybrany na poziomie folderu, ten sam szablon będzie domyślnie używany podczas tworzenia komponentów w jego podfolderach. Umożliwia to szybkie dziedziczenie szablonu przez wszystkie komponenty w folderach podrzędnych.

Zapisanie wersji komponentu w obszarze roboczym utrwala konkretną wersję użytego szablonu komponentu — tworząc trwałe powiązanie z tą wersją, chyba że zostanie ono zmienione ręcznie.

Wpływ użycia szablonu komponentu na modele i parametry komponentu

Podczas edycji wersji komponentu, gdy jest z nią powiązana wersja szablonu komponentu lub gdy komponent się do niej odwołuje, w edytorze komponentów zachodzą następujące zmiany dotyczące modeli i parametrów:

  • Modele zdefiniowane we wskazanym szablonie są dodawane do obszaru Models (tryb Single Component Editing) oraz obszaru Model Links (tryb Batch Component Editing).
  • Istniejące odwołanie do modelu zostanie zachowane, a komponent będzie nadal korzystać z tego modelu, chyba że zostanie on celowo zmieniony ręcznie.
  • Parametry zdefiniowane we wskazanym szablonie są dodawane do obszaru Parameters (tryb Single Component Editing) oraz obszaru Required Models/Parameters (tryb Batch Component Editing).

    Przykład parametrów po powiązaniu z wersją szablonu komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i w trybie Batch Component Editing (po prawej).
    Przykład parametrów po powiązaniu z wersją szablonu komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i w trybie Batch Component Editing (po prawej).

    Wszystkie parametry pochodzące ze wskazanego szablonu komponentu są wyróżnione ikoną (tryb Single Component Editing) oraz ikoną (tryb Batch Component Editing). Ponadto, wyłącznie w trybie zbiorczej edycji komponentów, stan opcji Show dla każdego parametru pochodzącego z szablonu odpowiada stanowi właściwej opcji Visible w szablonie.
    Parametrów pochodzących z szablonu nie można usuwać.
    W razie potrzeby można dodawać dodatkowe parametry użytkownika.
  • Wyłącznie w trybie Batch Component Editing parametry pochodzące z szablonu, dla których włączono wyświetlanie, są grupowane w obszarze definicji komponentów edytora, a tekstem nagłówka jest Template Parameters.

    Wygląd przykładowych parametrów opartych na szablonie w obszarze definiowania komponentów podczas korzystania z edytora komponentów w trybie Batch Component Editing.
    Wygląd przykładowych parametrów opartych na szablonie w obszarze definiowania komponentów podczas korzystania z edytora komponentów w trybie Batch Component Editing.

  • Pola wartości parametrów opartych na szablonie, które oznaczono jako tylko do odczytu, nie będą dostępne do edycji. W przypadku wszystkich pozostałych parametrów opartych na szablonie, których nie oznaczono jako tylko do odczytu, można dowolnie zmieniać wartości zgodnie z potrzebami.

    Gdy edytor komponentów działa w trybie Single Component Editing, parametr szablonu oznaczony jako tylko do odczytu jest wyróżniony w obszarze Parameters ikoną .
  • Jeśli parametr oparty na szablonie został oznaczony jako wymagany, ale nie przypisano mu wartości w szablonie, jego pole wartości będzie miało czerwoną obwódkę (w trybie Batch Component Editing) lub będzie zawierać ikonę (w trybie Single Component Editing), sygnalizując konieczność podania wartości tego parametru. Zapisanie komponentu w przestrzeni roboczej będzie możliwe dopiero po zdefiniowaniu wartości wszystkich wymaganych parametrów.

    Gdy edytor komponentów działa w trybie Single Component Editing, wymagany parametr szablonu jest wyróżniony w obszarze Parameters ikoną .

Ponowne zapisywanie szablonu komponentu

W dowolnym momencie można wrócić do dowolnej rewizji szablonu komponentu w przestrzeni roboczej i edytować ją bezpośrednio. Kliknij rewizję prawym przyciskiem myszy i wybierz polecenie Edit z menu kontekstowego. Ponownie otworzy się tymczasowy edytor, a szablon zawarty w tej rewizji zostanie otwarty do edycji. Wprowadź potrzebne zmiany, a następnie zapisz szablon komponentu jako kolejną rewizję elementu.

Kliknięcie prawym przyciskiem myszy wpisu najwyższego poziomu dla samego szablonu komponentu umożliwi edycję najnowszej rewizji tego szablonu.

Dostęp do polecenia uruchamiającego bezpośrednią edycję istniejącej rewizji szablonu komponentu.
Dostęp do polecenia uruchamiającego bezpośrednią edycję istniejącej rewizji szablonu komponentu.

Pobieranie zapisanych danych

Aby pobrać dane zapisane w rewizji szablonu komponentu, kliknij tę rewizję prawym przyciskiem myszy (w panelu Explorer) i wybierz polecenie Operations » Download z menu kontekstowego. Plik szablonu komponentu zostanie pobrany do podfolderu w wybranym katalogu, nazwanego zgodnie z identyfikatorem rewizji elementu. Plik można znaleźć w znajdującym się w nim folderze Released.

Aby pobrać plik szablonu komponentu zapisany w najnowszej rewizji tego szablonu, wybierz polecenie Download z wpisu najwyższego poziomu dla samego szablonu komponentu.
Kliknij przycisk Explore w oknie dialogowym Download from Server, aby szybko otworzyć folder pobierania.

Usuwanie nietrwałe

Po połączeniu z przestrzenią roboczą dostępne są elastyczne funkcje umożliwiające usuwanie szablonu komponentu bezpośrednio z Altium Designer, z poziomu panelu Explorer. Kliknij wpis szablonu komponentu w panelu prawym przyciskiem myszy i wybierz polecenie Delete Item z menu kontekstowego. Pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. W rzeczywistości jest to „usuwanie nietrwałe”, w wyniku którego szablon komponentu zostanie przeniesiony do obszaru Trash przestrzeni roboczej. Trash pełni zasadniczo funkcję kosza, do którego można przenieść dowolną zawartość przestrzeni roboczej (poprzez usuwanie nietrwałe). Jest on odizolowany od reszty przestrzeni roboczej.

Funkcja usuwania nietrwałego umożliwia usunięcie szablonu komponentu, który jest aktualnie używany.
Wiele szablonów komponentów można usunąć w ramach jednej operacji. Zaznacz wszystkie potrzebne szablony komponentów, korzystając ze standardowych metod zaznaczania wielu elementów (Shift+Click, Ctrl+Click), a następnie kliknij prawym przyciskiem myszy i wybierz polecenie Delete Items z menu kontekstowego.

Usuwanie nietrwałe szablonu komponentu. Szablon zostanie przeniesiony do obszaru Trash przestrzeni roboczej.
Usuwanie nietrwałe szablonu komponentu. Szablon zostanie przeniesiony do obszaru Trash przestrzeni roboczej.

Aby kontynuować usuwanie, kliknij przycisk . Element zostanie usunięty, a okno dialogowe Deletion Summary potwierdzi pomyślne usunięcie. Jeśli podczas usuwania wystąpi problem, otrzymasz stosowną informację.

Wszystkie treści usunięte w ten sposób można znaleźć na stronie Trash interfejsu przeglądarkowego przestrzeni roboczej. Pamiętaj, że możesz wyświetlać tylko treści usunięte nietrwale przez Ciebie. Administratorzy mogą zobaczyć pełną zawartość strony Trash — czyli wszystkie treści, które zostały usunięte nietrwale.

Kwestie, o których należy pamiętać w odniesieniu do nietrwale usuniętego szablonu komponentu:

  • Szablon komponentu nie będzie dostępny w oprogramowaniu projektowym ani w interfejsie internetowym.
  • We wszystkich miejscach, w których używano szablonu komponentu, pojawi się informacja, że został on usunięty.
  • Szablon komponentu można przywrócić lub trwale usunąć ze strony Trash, pod warunkiem posiadania uprawnień do edycji. Trwałe usunięcie jest możliwe tylko wtedy, gdy szablon nie jest używany przez element nadrzędny.
Pamiętaj, że po nietrwałym usunięciu szablonu komponentu — czyli przeniesieniu go do Trash — można ponownie utworzyć nowy szablon komponentu o tej samej nazwie. Jeśli później przywrócisz pierwotny szablon komponentu, a jego pierwotna nazwa będzie już zajęta, do nazwy zostanie dodany przyrostek w postaci liczby całkowitej, aby zachować jej unikalność w przestrzeni roboczej.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents