Component Templates

W skrócie

Szablony komponentów w połączonym obszarze roboczym usprawniają tworzenie komponentów w Altium Designer, udostępniając ustawienia i parametry do wielokrotnego użytku. W tym artykule wyjaśniono, jak organizować elementy szablonów komponentów, wybierać schematy nazewnictwa i cyklu życia oraz korzystać z edycji bezpośredniej do definiowania szablonów i zapisywania ich w obszarze roboczym. Przedstawiono również opcje sterowania widocznością parametrów, wartościami domyślnymi, polami obowiązkowymi oraz możliwością nadpisywania ustawień przez projektanta. Czytaj dalej, aby zacząć tworzyć szablony wielokrotnego użytku, które pomogą zapewnić większą spójność definicji komponentów.

- Dowiedz się, jak skonfigurować foldery obszaru roboczego i elementy szablonów komponentów z odpowiednimi schematami nazewnictwa, rewizji i cyklu życia.
- Poznaj sposób, w jaki szablony sterują parametrami komponentów, w tym wymaganymi wartościami i domyślnymi wartościami tylko do odczytu.
- Sprawdź, jak edytować szablony bezpośrednio i zapisywać je z powrotem w obszarze roboczym jako nowe rewizje.
Zagłęb się w temat dzięki AI:

Aby usprawnić tworzenie komponentów, Altium Designer we współpracy z połączoną przestrzenią roboczą umożliwia tworzenie i definiowanie Component Templates (elementów szablonów komponentów) w tej przestrzeni. Podobnie jak szablon schematu pozwala wstępnie określić informacje na korzystających z niego arkuszach schematu, tak komponent biblioteczny przestrzeni roboczej odwołuje się do szablonu komponentu, który udostępnia wstępnie zdefiniowane ustawienia używane podczas definiowania tego komponentu.

Szablony komponentów opracowano przede wszystkim z myślą o informacjach parametrycznych. Umożliwiają one zdefiniowanie w jednym miejscu zestawu parametrów, które będą dostępne dla komponentu korzystającego z szablonu. Za pomocą szablonu można określić, które parametry mają być widoczne, wprowadzić wartości domyślne, a nawet oznaczyć wymagane parametry jako obowiązkowe. Podczas zapisywania komponentu przeprowadzana jest walidacja, która zapewnia zgodność z tymi wymaganiami.

Domyślne wartości wielu ustawień szablonu można zablokować jako przeznaczone tylko do odczytu lub wybiórczo udostępnić projektantowi do zmiany podczas definiowania komponentu.

Szablon komponentu stanowi również podstawę do tworzenia komponentu ogólnego. Więcej informacji można znaleźć na stronie Tworzenie komponentów ogólnych.

Dostęp do szablonów komponentów zależy od licencji oprogramowania. Więcej informacji można znaleźć w polu Note po prawej stronie.

Takie szablony komponentów są tworzone bezpośrednio w przestrzeni roboczej. Po utworzeniu szablonu komponentu i zapisaniu danych w jego rewizji można go ponownie wykorzystać do utworzenia jednego lub większej liczby komponentów.

Typ folderu

Podczas tworzenia folderu do przechowywania szablonów komponentów można określić jego typ. Nie ma to wpływu na zawartość folderu — opublikowanie szablonu komponentu zawsze spowoduje utworzenie odpowiedniego elementu szablonu komponentu. Typ folderu stanowi jedynie wizualną wskazówkę dotyczącą jego zawartości i może być pomocny podczas przeglądania przestrzeni roboczej w poszukiwaniu określonych treści. Aby wskazać, że folder ma służyć do przechowywania szablonów komponentów, podczas definiowania jego właściwości w oknie dialogowym Edit Folder ustaw Folder Type na Component Templates.

Określenie typu folderu — jego przeznaczenia — zapewnia wizualną informację o zawartości folderu podczas przeglądania przestrzeni roboczej.
Określenie typu folderu — jego przeznaczenia — zapewnia wizualną informację o zawartości folderu podczas przeglądania przestrzeni roboczej.

Typ zawartości

Podczas tworzenia docelowego elementu szablonu komponentu, w którym ma zostać zapisany szablon, upewnij się, że w oknie dialogowym Create New Item jego Content Type ma wartość Component Template. Jeśli tworzysz element w folderze typu Component Templates, ten typ zawartości będzie dostępny w menu kontekstowym otwieranym prawym przyciskiem myszy podczas tworzenia elementu.

Tworzenie szablonu komponentu w folderze Component Templates — odpowiedni Content Type jest dostępny w menu kontekstowym.
Tworzenie szablonu komponentu w folderze Component Templates — odpowiedni Content Type jest dostępny w menu kontekstowym.

Zapisywanie szablonu komponentu

Related page: Tworzenie i edytowanie zawartości

Dotychczas omówiliśmy obsługę szablonów komponentów w przestrzeni roboczej w kontekście powiązanych typów folderów i zawartości. Zapisanie zdefiniowanego szablonu komponentu w rewizji takiego elementu szablonu komponentu można przeprowadzić w prosty sposób.

Dzięki obsłudze edycji bezpośredniej w przestrzeni roboczej szablon komponentu można edytować i zapisać w początkowej rewizji nowo utworzonego elementu szablonu komponentu. Edycja bezpośrednia eliminuje konieczność korzystania z oddzielnych danych źródłowych objętych kontrolą wersji. Obsługiwany typ zawartości można po prostu edytować w tymczasowym edytorze, do którego wczytywane są najnowsze dane źródłowe bezpośrednio z przestrzeni roboczej. Po zakończeniu edycji obiekt jest zapisywany (lub zapisywany ponownie) w kolejnej zaplanowanej rewizji elementu nadrzędnego, a tymczasowy edytor zostaje zamknięty. Na dysku twardym nie ma żadnych plików, nie trzeba się zastanawiać, czy używane dane źródłowe są właściwe i aktualne, ani utrzymywać oddzielnego oprogramowania do kontroli wersji. Przestrzeń robocza zarządza wszystkim, zapewniając wysoką integralność danych i znacznie przyspieszając wprowadzanie zmian.

Podczas tworzenia elementu szablonu komponentu można edytować i zapisać szablon komponentu w początkowej rewizji tego elementu po jego utworzeniu. W tym celu włącz opcję Open for editing after creation u dołu okna dialogowego Create New Item (domyślnie jest ona włączona). Element zostanie utworzony i otworzy się tymczasowy edytor szablonów komponentów, wyświetlając dokument .CMPT jako aktywny dokument w głównym oknie projektowania. Dokument otrzyma nazwę zgodną z oznaczeniem elementu i rewizji, w formacie: <Item><Revision>.CMPT (np. CMPT-0001-1.CMPT).

 
 
 
 
 

Przykład edycji początkowej rewizji szablonu komponentu bezpośrednio z przestrzeni roboczej — tymczasowy edytor szablonów komponentów udostępnia dokument służący do zdefiniowania szablonu komponentu.
Przykład edycji początkowej rewizji szablonu komponentu bezpośrednio z przestrzeni roboczej — tymczasowy edytor szablonów komponentów udostępnia dokument służący do zdefiniowania szablonu komponentu.

Użyj dokumentu, aby zdefiniować szablon komponentu zgodnie z potrzebami. Więcej informacji na ten temat można znaleźć w sekcji Definiowanie szablonu.

Podczas edycji bezpośredniej dostępne są trzy przydatne przyciski, znajdujące się w Quick Access Bar (w lewym górnym rogu głównego okna aplikacji) lub na pasku narzędzi Component Template Standard:

  • – Save Active Document. Użyj tego przycisku, aby lokalnie zapisać zmiany wprowadzone w dokumencie. Pozwala to zapisać bieżące zmiany, jeśli chcesz wrócić do dokumentu później i wprowadzić kolejne zmiany przed ostatecznym zapisaniem go w przestrzeni roboczej.
  • / – Save to Server. Użyj tego przycisku, aby zapisać zdefiniowany szablon komponentu w przestrzeni roboczej, w początkowej (planowanej) rewizji docelowego elementu szablonu komponentu. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać uwagi do wydania. Po zapisaniu dokument i edytor zostaną zamknięte. Dokument zawierający źródłowy szablon komponentu, *.CMPT, zostanie zapisany w rewizji elementu.

    Przycisk Save to Server jest również dostępny po prawej stronie wpisu szablonu komponentu w samym panelu Projects.
  • / – Discard Local Changes. Użyj tego przycisku, jeśli chcesz anulować edycję i odrzucić wszystkie wprowadzone zmiany. Dokument i edytor zostaną zamknięte, a do docelowego elementu szablonu komponentu nic nie zostanie opublikowane.

Te funkcje są również dostępne jako polecenia — Save (skrót: Ctrl+S), Save to Server (skrót: Ctrl+Alt+S) i Discard Local Changes — w głównym menu File oraz w menu kontekstowym wpisu szablonu komponentu w panelu Projects.

Dane zapisane w przestrzeni roboczej obejmują źródłowy szablon komponentu zdefiniowany w pliku szablonu komponentu (<Item><Revision>.CMPT).

 
 
 
 
 

Przykładowy zdefiniowany szablon komponentu zapisany w przestrzeni roboczej.
Przykładowy zdefiniowany szablon komponentu zapisany w przestrzeni roboczej.

Dziedziczenie szablonu komponentu

Ta funkcja jest dostępna, gdy opcja UI.ComponentTemplateInheritance jest włączona w oknie dialogowym Advanced Settings.

Możesz użyć szablonu komponentu z nadrzędnego typu komponentu, jeśli z podtypem nie jest powiązany żaden szablon komponentu. Podczas tworzenia hierarchii typów komponentów podtypy komponentów dziedziczą szablon przypisany do głównego/nadrzędnego typu komponentu.

Edytor CMPT (szablonów komponentów)

Aby uzyskać dostęp do edytora szablonów komponentów w Altium Designer, należy zainstalować rozszerzenie Component Template Editor. To rozszerzenie jest domyślnie instalowane wraz z Altium Designer. Można je ręcznie zainstalować lub usunąć.

Więcej informacji na temat zarządzania rozszerzeniami można znaleźć na stronie Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definiowanie szablonu

Edytor szablonów komponentów jest podzielony na dwa główne obszary, pokazane na poniższym rysunku i opisane pod nim.

 
 
 
 
 

W edytorze szablonów komponentów można wyróżnić dwa główne obszary.
W edytorze szablonów komponentów można wyróżnić dwa główne obszary.

  1. Upper Region — służy do definiowania opcji na poziomie komponentu (cyklu życia, nazewnictwa i folderów) dla komponentu odwołującego się do szablonu.
  2. Lower Region — służy do definiowania parametrów używanych przez komponent odwołujący się do szablonu.

Określanie opcji komponentu

Górna połowa edytora służy do definiowania wartości domyślnych następujących właściwości komponentu:

  • Lifecycle Definition — wybierz definicję cyklu życia, która ma być stosowana do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie definicje zdefiniowane dla przestrzeni roboczej i dopuszczone do stosowania w komponentach.

  • Revision Naming — wybierz schemat nazewnictwa rewizji, który ma być stosowany do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie schematy zdefiniowane dla przestrzeni roboczej i dopuszczone do stosowania w komponentach.

    Jeśli dla dowolnej definicji cyklu życia lub schematu nazewnictwa rewizji włączono opcję kontrolowania ich użycia według typu zawartości, a typ zawartości Component nie został skonfigurowany do korzystania z danej definicji lub schematu, nie będą one dostępne na odpowiedniej liście rozwijanej.

  • Component Naming – użyj tego pola, aby zdefiniować domyślny schemat nazewnictwa elementów dla komponentu tworzonego na podstawie szablonu, zapewniający unikalny identyfikator komponentu w przestrzeni roboczej. Wpis ten będzie używany jako szablon automatycznego nadawania nazwy komponentowi (w powiązanym polu Id, gdy edytor komponentów działa w trybie Single Component Editing, lub w polu Item ID, gdy edytor komponentów działa w trybie Batch Component Editing). Oprogramowanie automatycznie przypisze następny dostępny unikalny identyfikator zgodny z tym schematem po przeszukaniu całej przestrzeni roboczej i sprawdzeniu identyfikatorów istniejącej zawartości. Dostępny jest domyślny schemat nazewnictwa elementów – CMP-{00000} – ale można oczywiście utworzyć własny schemat, wpisując go w tym polu i ujmując część zmienną w nawiasy klamrowe (np. CMP-001-{0000}).

  • Default Folder – umożliwia określenie domyślnego folderu w docelowej przestrzeni roboczej, w którym ma być przechowywany zapisany komponent. Kliknij przycisk Choose, aby otworzyć okno dialogowe Choose Folder (będące odmianą panelu Explorer), w którym można przejść do istniejącego folderu w przestrzeni roboczej i go wybrać lub od razu utworzyć nowy folder.

Nie ma pola umożliwiającego ustawienie docelowej przestrzeni roboczej, ponieważ zawsze używana jest ta sama przestrzeń robocza, w której znajduje się rewizja szablonu komponentu.

Opcja Allow override dla każdej właściwości pozwala niezależnie określić, czy użytkownik może zmieniać tę właściwość podczas definiowania komponentu w edytorze komponentów (opcja włączona), czy nie (opcja wyłączona).

Gdy szablon jest używany, wpisy określone w tym obszarze służą do wstępnego wypełniania odpowiednich pól w edytorze komponentów (o ile są dostępne):

  • Single Component Editing mode – pola Id i Folder w obszarze Advanced Settings sekcji Component.
  • Batch Component Editing mode – na karcie Document Options w oknie dialogowym Document Options, a w konsekwencji również pola Item ID i FolderPath w obszarze Component sekcji definicji komponentów.

Gdy szablon jest używany, wpisy służą do wstępnego wypełniania odpowiednich pól podczas edycji komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i w trybie Batch Component Editing (po prawej).
Gdy szablon jest używany, wpisy służą do wstępnego wypełniania odpowiednich pól podczas edycji komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i w trybie Batch Component Editing (po prawej).

Definiowanie parametrów

Dolna połowa edytora służy do definiowania parametrów, które będą dostępne dla komponentu korzystającego z szablonu, oraz do zarządzania nimi.

 
 
 
 
 

Przykładowe parametry zdefiniowane w szablonie komponentu.
Przykładowe parametry zdefiniowane w szablonie komponentu.

Domyślne parametry systemowe

Podczas tworzenia nowego szablonu komponentu domyślnie dodawane są różne parametry systemowe, co przedstawiono na poniższej ilustracji i szczegółowo opisano w dalszej części.

 
 
 
 
 

Domyślne parametry systemowe zawarte w nowo utworzonym szablonie komponentu.
Domyślne parametry systemowe zawarte w nowo utworzonym szablonie komponentu.

  • ComponentType – ten parametr pozwala określić typ komponentu. Ułatwia to ukierunkowane wyszukiwanie za pomocą zaawansowanej funkcji wyszukiwania w przestrzeni roboczej. Funkcja ta umożliwia nie tylko wyszukiwanie według typu komponentu, lecz także bardziej inteligentne wyszukiwanie dzięki obsłudze parametrów komponentów uwzględniających jednostki. Podczas przeglądania komponentów z własnej przestrzeni roboczej w panelu Components grupowanie komponentów według Categories jest oparte na parametrach ComponentType powiązanych z każdym komponentem. Kliknij powiązane pole Default Value, a następnie przycisk , aby otworzyć okno dialogowe Choose component type. Wybierz w nim wymagany typ komponentu i kliknij OK – wybrany typ zostanie wstawiony jako wartość parametru ComponentType w głównej tabeli parametrów.

    Okno dialogowe Choose component type odzwierciedla zestaw typów komponentów zdefiniowanych na stronie Data Management – Component Types w oknie dialogowym Preferences. Kliknij przycisk u dołu okna dialogowego Choose component type, aby przejść do tej strony preferencji, na której można dostosować listę do swoich potrzeb, dodając nowe typy i podtypy lub edytując i usuwając istniejące typy.

    Przykładowy szablon komponentu z parametrem systemowym ComponentType ustawionym na Diodes.
    Przykładowy szablon komponentu z parametrem systemowym ComponentType ustawionym na Diodes.

    Typ danych tego parametru jest ustawiony na ComponentType i nie można go zmienić. Nie można również usunąć parametru ComponentType. Aby wyczyścić wartość, zaznacz komórkę i użyj klawisza Delete .

  • SCHLIB i PCBLIB – te dwa parametry pozwalają określić odpowiednio domyślny model symbolu i obudowy PCB. Dla każdego parametru kliknij powiązane pole Default Value, a następnie przycisk , aby otworzyć okno dialogowe umożliwiające wybór wymaganego modelu.

    Pamiętaj, że wybierasz model, a nie jego konkretną rewizję. Dzięki temu komponent korzystający z szablonu będzie zawsze używał najnowszej rewizji wybranego modelu.

    Określ modele symbolu i obudowy PCB w szablonie.
    Określ modele symbolu i obudowy PCB w szablonie.

    Typy danych tych parametrów są ustawione odpowiednio na SCHLIB i PCBLIB i nie można ich zmienić. Nie można również usunąć parametrów modeli. Aby wyczyścić wartość, zaznacz komórkę i użyj klawisza Delete.

  • Name i Description – te dwa parametry pozwalają zdefiniować odpowiednio nazwę i opis komponentu. Dla każdego parametru wprowadź wymagany tekst w powiązanym polu Default Value.

    Określ parametry Name i Description w szablonie.
    Określ parametry Name i Description w szablonie.

    Typ danych dla obu tych parametrów jest ustawiony na Text i nie można go zmienić. Parametrów tych nie można również usunąć.

Obsługiwane jest kopiowanie i wklejanie parametrów systemowych , w tym wklejanie między dokumentami szablonów.

Zaznacz jeden lub więcej parametrów w szablonie komponentu, a następnie użyj polecenia Copy z menu kontekstowego zaznaczenia (skrót: Ctrl+C). Skopiowane parametry można następnie wkleić do innego szablonu komponentu za pomocą polecenia Paste z menu kontekstowego (skrót: Ctrl+V).

 
 
 
 
 

SCHLIB, Name i Description to parametry systemowe, które zaznaczono i skopiowano w szablonie komponentu Diodes.

Parametry te wklejono do innego szablonu komponentu (Zeners), a ich wartości zastosowano do odpowiadających im parametrów. 

 

Dodawanie nowego parametru użytkownika

Aby dodać do listy nowy parametr użytkownika, kliknij przycisk (lub użyj polecenia Add z menu kontekstowego) — parametr zostanie dodany na końcu bieżącej listy.

 
 
 
 
 

Przykład dodawania nowego parametru użytkownika do szablonu.
Przykład dodawania nowego parametru użytkownika do szablonu.

Każdy parametr jest przedstawiony w tabeli za pomocą następujących informacji:

  • Name — użyj tego pola, aby nadać parametrowi nazwę, najlepiej taką, która jasno określa jego przeznaczenie. Po dodaniu parametrom nadawane są nazwy domyślne (Parameter, Parameter 1, Parameter 2 itd.).

  • Type — typ parametru. Początkowo domyślnie ustawiana jest wartość Text, ale obsługiwany jest szereg typów danych uwzględniających jednostki, a także typ PCBLIB, który umożliwia definiowanie wielu footprintów, oraz HarnessWiring, który umożliwia zdefiniowanie komponentu okablowania wiązki. Obsługiwane są również typy parametrów zdefiniowane w dostępnych słownikach — dowiedz się więcej.

  • Visible — włącz tę opcję (jest to domyślny stan nowo dodanego parametru), aby odpowiadająca jej opcja Show dla danego parametru była włączona podczas edytowania jednego lub większej liczby komponentów w edytorze komponentów (skonfigurowanym w trybie Batch Component Editing). To z kolei steruje wyświetlaniem kolumny odpowiadającej temu parametrowi w dolnej części edytora komponentów, w której definiowane są same komponenty. Ta właściwość nie ma wpływu na definiowanie komponentu w trybie Single Component Editing edytora.

  • Read Only — włącz tę opcję, aby parametr był tylko do odczytu. Podczas edytowania komponentu odwołującego się do szablonu nie będzie można zmienić wartości tego parametru.

  • Required — włącz tę opcję, aby parametr był wymagany. Podczas edytowania komponentu odwołującego się do szablonu parametr musi mieć zdefiniowaną wartość, w przeciwnym razie zapisanie komponentu nie będzie możliwe. W edytorze komponentów taki parametr jest wyróżniony czerwoną ramką komórki wartości (w trybie Batch Component Editing) lub ikoną w tej komórce (w trybie Single Component Editing), jeśli nie wprowadzono żadnej wartości.

  • Default Value — użyj tego pola, aby wprowadzić domyślną wartość parametru.

    • Jeśli parametr jest oznaczony jako wymagany (opcja Required jest włączona) i jednocześnie ustawiony jako tylko do odczytu (opcja Read Only jest włączona), wartość domyślna MUST zostać wprowadzona. W przeciwnym razie podczas edytowania komponentu odwołującego się do szablonu parametr zostanie oznaczony jako pozbawiony wartości, ale nie będzie można tego naprawić, ponieważ parametr jest tylko do odczytu i nie można go edytować. Dopóki problem ten nie zostanie rozwiązany, nie będzie można zapisać nowej rewizji tego szablonu komponentu w przestrzeni roboczej.

    • Podczas edytowania rewizji komponentu istniejący parametr zdefiniowany przez użytkownika, który ma taką samą nazwę jak parametr w powiązanym szablonie komponentu, zostanie zastąpiony wersją z szablonu. Istniejąca wartość tego parametru zostanie zachowana (i nie zostanie nadpisana wartością domyślną z szablonu).

  • Description — dodaj dowolny opis parametru, na przykład krótką informację o jego przeznaczeniu. Jeśli dla parametru w szablonie zdefiniowano opis, kolumna Description będzie odpowiednio wyświetlana w obszarze Parameters edytora komponentów w jego Single Component Editing.

Lista parametrów obsługuje również proste operacje kopiowania i wklejania, umożliwiając powielanie jednego lub większej liczby istniejących parametrów użytkownika. Wklejone parametry zostaną dodane na końcu listy.

Obsługiwane są standardowe skróty kopiowania (Ctrl+C) i wklejania (Ctrl+V), a polecenia te są również dostępne w menu kontekstowym otwieranym prawym przyciskiem myszy. Do operacji kopiowania i wklejania można zaznaczyć wiele parametrów użytkownika, stosując standardowe metody z użyciem Ctrl+Click i Shift+Click.
Aby usunąć z listy jeden lub więcej parametrów użytkownika, zaznacz odpowiednie parametry, a następnie kliknij przycisk lub użyj polecenia Remove z menu kontekstowego otwieranego prawym przyciskiem myszy.

Typy danych parametrów komponentów uwzględniające jednostki

Edytor szablonów komponentów umożliwia określanie konkretnych typów danych dla parametrów zdefiniowanych w szablonie komponentu (*.CMPT). Ponadto te typy danych uwzględniają jednostki i obsługują szereg popularnych przedrostków jednostek. Dzięki temu wartość parametru można wprowadzać w różnych formatach, takich jak 2.2k, 2k2, 4M czy 2.5GHz, a przestrzeń robocza automatycznie rozpozna wartość liczbową odpowiadającą tym zapisom.

Ta funkcja szablonu komponentu ułatwia precyzyjne wyszukiwanie za pomocą dostępnej na serwerze funkcji wyszukiwania zaawansowanego, która pozwala nie tylko wyszukiwać według typu komponentu, lecz także korzystać z inteligentniejszego wyszukiwania według zakresów wartości. Dzięki parametrom komponentów uwzględniającym jednostki można szybko zdefiniować wyszukiwanie, na przykład w celu znalezienia wszystkich kondensatorów o pojemności od 47uF do 220uF.

Parametry uwzględniające jednostki są również używane do inteligentnego filtrowania podczas wyszukiwania własnych komponentów za pomocą panelu Components.

Więcej informacji o parametrach uwzględniających jednostki znajdziesz w poniższych rozwijanych sekcjach.

Typy danych parametrów definiowane przez słowniki

Słowniki to niestandardowe typy parametrów z zestawem zdefiniowanych wartości. Słownikami zarządzają administratorzy obszaru roboczego na stronie Settings – Vault – Dictionaries w interfejsie przeglądarkowym obszaru roboczego. Można ją otworzyć z edytora szablonów komponentów, wybierając opcję Add New Dictionary z listy rozwijanej Type lub klikając element sterujący Manage Dictionaries w prawym górnym rogu obszaru Parameters.

  • Stronę Settings – Vault – Dictionaries można również otworzyć ze strony Zarządzanie danymi – Słowniki w oknie dialogowym Preferences, klikając element sterujący Manage Dictionaries, a także ze strony Zarządzanie danymi – Serwery w oknie dialogowym Preferences, klikając element sterujący Properties dla aktywnego lub znanego obszaru roboczego i wybierając z menu pozycję Dictionaries.

  • Gdy dla parametru wybrano typ zdefiniowany przez słownik, stronę Settings – Vault – Dictionaries można również otworzyć, klikając komórkę parametru w kolumnie Type, a następnie przycisk  ().

Otwórz stronę zarządzania słownikami w interfejsie przeglądarkowym obszaru roboczego z poziomu edytora szablonów komponentów.
Otwórz stronę zarządzania słownikami w interfejsie przeglądarkowym obszaru roboczego z poziomu edytora szablonów komponentów.

Dowiedz się więcej o zarządzaniu słownikami w interfejsie przeglądarkowym obszaru roboczego (obszar roboczy Altium 365, obszar roboczy Enterprise Server).

Zdefiniowane słowniki są dostępne jako typy parametrów na liście rozwijanej Type.

Wybierz typ parametru zdefiniowany przez słownik z listy rozwijanej Typ.
Wybierz typ parametru zdefiniowany przez słownik z listy rozwijanej Typ.

Wartości zdefiniowane dla wybranego typu słownikowego są dostępne na liście rozwijanej Default Value. Wybierz wymaganą wartość jako wartość domyślną parametru lub wybierz <None>.

Wybierz wartość domyślną spośród wartości zdefiniowanych dla wybranego typu słownikowego.
Wybierz wartość domyślną spośród wartości zdefiniowanych dla wybranego typu słownikowego.

  • Wartości domyślne są sprawdzane podczas zapisywania szablonu komponentu w obszarze roboczym. Jeśli wartość domyślna stanie się niezgodna ze słownikiem (np. wartość zostanie usunięta ze słownika, a następnie szablon korzystający z tej wartości zostanie otwarty do edycji), zostanie ona wyróżniona na czerwono w kolumnie wartości domyślnej, a przy próbie ponownego zapisania szablonu w obszarze roboczym w panelu Messages pojawi się komunikat o błędzie.

  • Jeśli wartość parametru komponentu stanie się niezgodna ze słownikiem (np. typ tego parametru zostanie zmieniony w szablonie komponentu z tekstowego na typ słownikowy, a bieżąca wartość komponentu nie będzie odpowiadać żadnej wartości wybranego typu słownikowego), parametr ten zostanie wyróżniony podczas edycji komponentu w edytorze komponentów: w trybie edycji pojedynczego komponentu obok niezgodnej wartości parametru pojawi się ikona wykrzyknika, natomiast w trybie edycji zbiorczej komponentów wartość parametru zostanie wyróżniona na czerwono. Upewnij się, że wszystkie parametry komponentu są zgodne z wartościami szablonu; w przeciwnym razie nie będzie można zapisać komponentu jako kolejnej rewizji.

  • Jeśli słowniki zostały zmienione w interfejsie przeglądarkowym połączonego obszaru roboczego, należy rozłączyć się z obszarem roboczym i ponownie się z nim połączyć, aby zmiany zostały uwzględnione w Altium Designer. Więcej informacji znajdziesz na stronie Uzyskiwanie dostępu do obszaru roboczego.

Definiowanie wielu footprintów

Edytor szablonów komponentów obsługuje również definiowanie wielu footprintów PCB w ramach szablonu komponentu. Można określić dowolną liczbę odwołań do modeli footprintów. Funkcja ta jest szczególnie przydatna podczas tworzenia komponentów odwołujących się do trzech footprintów spełniających wymagania IPC dla różnych poziomów gęstości: L (najmniejsza, czyli minimalna ilość miedzi), M (największa, czyli maksymalna ilość miedzi) oraz N (nominalna, czyli pośrednia ilość miedzi).

Aby dodać do szablonu definicję kolejnego modelu footprintu, kliknij w celu dodania nowego parametru, a następnie wybierz pozycję PCBLIB z menu rozwijanego powiązanego z polem Type.

Zmień nowo dodany parametr w definicję modelu footprintu, ustawiając jego Type na PCBLIB.
Zmień nowo dodany parametr w definicję modelu footprintu, ustawiając jego Type na PCBLIB.

Nazwa parametru zmieni się z Parameter na PCBLIB n, gdzie n to kolejna dostępna liczba całkowita służąca do rozróżniania modeli footprintów (np. PCBLIB 1, PCBLIB 2 itd.). Modelem domyślnym będzie model powiązany z pozycją PCBLIB. Po wczytaniu footprintów do edytora komponentów podczas definiowania komponentu domyślny model footprintu jest oznaczony ikoną w lewym górnym rogu okna podglądu modelu (w trybie Single Component Editing) oraz wpisem PCBLIB (default) w obszarze Required Models/Parameters (w trybie Batch Component Editing).

Przykładowy komponent zdefiniowany w edytorze komponentów (w trybie Single Component Editing) z użyciem wskazanego szablonu komponentu. W szablonie zdefiniowano trzy modele footprintów, które są wczytywane do definicji komponentu. Zwróć uwagę, że pozycja modelu PCBLIB w szablonie jest używana jako domyślny model footprintu (oznaczony ikoną w lewym górnym rogu) podczas definiowania komponentu. Najedź kursorem na obraz, aby zobaczyć definiowanie tego samego komponentu w edytorze komponentów w trybie Batch Component Editing. W tym przypadku domyślny footprint jest określany jako PCBLIB (default).
Przykładowy komponent zdefiniowany w edytorze komponentów (w trybie Single Component Editing) z użyciem wskazanego szablonu komponentu. W szablonie zdefiniowano trzy modele footprintów, które są wczytywane do definicji komponentu. Zwróć uwagę, że pozycja modelu PCBLIB w szablonie jest używana jako domyślny model footprintu (oznaczony ikoną w lewym górnym rogu) podczas definiowania komponentu. Najedź kursorem na obraz, aby zobaczyć definiowanie tego samego komponentu w edytorze komponentów w trybie Batch Component Editing. W tym przypadku domyślny footprint jest określany jako PCBLIB (default).

Import i eksport szablonów komponentów

Istniejący plik szablonu komponentu (*.CMPT) lub plik biblioteki komponentów (*.CMPLIB) można zaimportować do edytora szablonów komponentów, a edytowany szablon można wyeksportować do pliku szablonu komponentu (*.CMPT). Użyj poleceń File » Import » Component Template, File » Import » Component Library i File » Export z menu głównego edytora komponentów, aby wybrać żądaną czynność, a następnie w otwartym standardowym oknie dialogowym systemu Windows przejdź do wymaganej lokalizacji i wybierz plik do zaimportowania lub określ nazwę pliku do wyeksportowania.

Ponowne użycie szablonu komponentu

Rewizję szablonu komponentu można wykorzystać — a dokładniej odwołać się do niej z aktualnie edytowanej rewizji komponentu — na poniższe sposoby.

Komponent może odwoływać się tylko do jednego szablonu komponentu naraz.

Podczas tworzenia nowego komponentu

Podczas tworzenia nowego komponentu za pomocą polecenia File » New » Component z menu głównego można wybrać szablon w oknie dialogowym Create new component.

Szybkie powiązanie szablonu komponentu z listy wszystkich dostępnych szablonów podczas tworzenia nowego komponentu.
Szybkie powiązanie szablonu komponentu z listy wszystkich dostępnych szablonów podczas tworzenia nowego komponentu.

Ręcznie w edytorze komponentów

Sposób ponownego użycia rewizji szablonu komponentu w edytorze komponentów zależy od trybu pracy edytora.

W trybie edycji pojedynczego komponentu

Podczas edycji pojedynczego komponentu w tym trybie edytora komponentów wybierz wymagany szablon komponentu z menu rozwijanego powiązanego z polem Template, należącym do grupy Advanced Settings w obszarze Component edytora. Na liście znajdują się nazwy wszystkich szablonów komponentów dostępnych obecnie w tym samym obszarze roboczym, w którym znajduje się komponent, wraz z ich najnowszymi rewizjami podanymi w nawiasach. Wybierz wymagany szablon, aby go zastosować.

Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów podczas edycji rewizji komponentu w edytorze komponentów w trybie Single Component Editing.
Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów podczas edycji rewizji komponentu w edytorze komponentów w trybie Single Component Editing.

W trybie edycji zbiorczej komponentów

Istnieją dwa sposoby powiązania rewizji szablonu komponentu z aktualnie edytowaną rewizją komponentu:

  • Na karcie Template okna dialogowego Opcje dokumentu (Edit » Document Options). Kliknij przycisk Choose po prawej stronie pola Item Revision. Spowoduje to otwarcie okna dialogowego Choose Item (odmiany panelu Eksplorator). W tym oknie przejdź do wymaganego szablonu komponentu i wybierz jego rewizję. Po kliknięciu OK zostanie utworzone powiązanie między rewizją komponentu a docelową rewizją szablonu komponentu. Informację o tym powiązaniu można zobaczyć po powrocie na kartę Template okna dialogowego Document Options.

    Ręczne powiązanie komponentu z rewizją szablonu komponentu w docelowym obszarze roboczym.
    Ręczne powiązanie komponentu z rewizją szablonu komponentu w docelowym obszarze roboczym.

    Używany szablon komponentu można zmienić w dowolnym momencie — kliknij Choose i wybierz rewizję innego szablonu komponentu.
    Status powiązanej rewizji elementu szablonu komponentu jest widoczny na karcie Template okna dialogowego Document Options. Jeśli dostępna jest nowsza rewizja powiązanego elementu, kliknij przycisk , aby jej użyć.
  • Z menu Add powiązanego z obszarem Required Models/Parameters Edytora komponentów. Podmenu Templates zawiera listę nazw wszystkich szablonów komponentów dostępnych obecnie w tej samej przestrzeni roboczej, w której znajduje się komponent, z najnowszymi rewizjami podanymi w nawiasach. Kliknij pozycję, aby utworzyć powiązanie z najnowszą rewizją danego szablonu komponentu. Powiązanie można również sprawdzić na karcie Templates okna dialogowego Document Options.

    Szybkie tworzenie powiązania z szablonem komponentu z menu wszystkich dostępnych szablonów.
    Szybkie tworzenie powiązania z szablonem komponentu z menu wszystkich dostępnych szablonów.

Dziedziczenie z folderu komponentów w przestrzeni roboczej

Możesz wskazać szablon komponentu, który będzie automatycznie stosowany do wszystkich komponentów (i ich rewizji) przechowywanych w folderze komponentów w przestrzeni roboczej.

Domyślny szablon komponentu można zdefiniować wyłącznie dla folderu typu Components.

Wskaż wymagany szablon w polu Component Template podczas definiowania właściwości folderu w oknie dialogowym Edit Folder. Lista rozwijana tego pola zawiera nazwy wszystkich szablonów komponentów dostępnych obecnie w tej samej przestrzeni roboczej, w której znajduje się folder komponentów, z najnowszymi rewizjami podanymi w nawiasach. Wybierz pozycję, aby dla każdego kolejnego komponentu tworzonego w tym folderze utworzyć powiązanie z najnowszą rewizją danego szablonu komponentu.

Wskaż domyślny szablon komponentu, który będzie stosowany do wszystkich komponentów tworzonych w nadrzędnym folderze komponentów.
Wskaż domyślny szablon komponentu, który będzie stosowany do wszystkich komponentów tworzonych w nadrzędnym folderze komponentów.

Aby nie korzystać z tej funkcji, pozostaw lub ustaw w polu Component Template wartość None.

Jeśli szablon komponentu zostanie wybrany na poziomie folderu, będzie on domyślnie używany również podczas tworzenia komponentów w jego podfolderach. Umożliwia to szybkie dziedziczenie szablonu przez wszystkie komponenty w folderach podrzędnych.

Zapisanie rewizji komponentu w przestrzeni roboczej powoduje utrwalenie konkretnej rewizji użytego szablonu komponentu — powstaje trwałe powiązanie z tą rewizją, które można zmienić tylko ręcznie.

Wpływ stosowania szablonu komponentu na modele i parametry komponentu

Podczas edytowania rewizji komponentu powiązanie z rewizją szablonu komponentu powoduje następujące zmiany dotyczące modeli i parametrów w Edytorze komponentów:

  • Modele zdefiniowane we wskazanym szablonie są dodawane do obszaru Models (w trybie Single Component Editing) i obszaru Model Links (w trybie Batch Component Editing).
  • Istniejące odwołanie do modelu zostanie zachowane, a komponent będzie nadal korzystać z tego modelu, chyba że zostanie on celowo zmieniony ręcznie.
  • Parametry zdefiniowane we wskazanym szablonie są dodawane do obszaru Parameters (w trybie Single Component Editing) i obszaru Required Models/Parameters (w trybie Batch Component Editing).

    Przykład parametrów po utworzeniu powiązania z rewizją szablonu komponentu w Edytorze komponentów pracującym w trybie Single Component Editing (po lewej) i Batch Component Editing (po prawej).
    Przykład parametrów po utworzeniu powiązania z rewizją szablonu komponentu w Edytorze komponentów pracującym w trybie Single Component Editing (po lewej) i Batch Component Editing (po prawej).

    Wszystkie parametry pochodzące ze wskazanego szablonu komponentu są oznaczone ikoną (w trybie Single Component Editing) i ikoną (w trybie Batch Component Editing). Ponadto, wyłącznie w trybie zbiorczej edycji komponentów, opcja Show dla każdego parametru opartego na szablonie przyjmuje stan odpowiadającej jej opcji Visible w szablonie.
    Parametrów opartych na szablonie nie można usuwać.
    W razie potrzeby można dodawać dodatkowe parametry użytkownika.
  • Wyłącznie w trybie Batch Component Editing parametry oparte na szablonie, dla których włączono wyświetlanie, są grupowane w obszarze definicji komponentów edytora pod nagłówkiem Template Parameters.

    Wygląd przykładowych parametrów opartych na szablonie w obszarze definiowania komponentów w Edytorze komponentów pracującym w trybie Batch Component Editing.
    Wygląd przykładowych parametrów opartych na szablonie w obszarze definiowania komponentów w Edytorze komponentów pracującym w trybie Batch Component Editing.

  • Pola wartości parametrów opartych na szablonie, które oznaczono jako tylko do odczytu, nie będą dostępne do edycji. W przypadku pozostałych parametrów opartych na szablonie, których nie oznaczono jako tylko do odczytu, można dowolnie zmieniać wartości zgodnie z potrzebami.

    W Edytorze komponentów pracującym w trybie Single Component Editing parametr szablonu tylko do odczytu jest oznaczony w obszarze Parameters ikoną .
  • Jeśli parametr oparty na szablonie został oznaczony jako wymagany, ale w szablonie nie przypisano mu wartości, jego pole wartości będzie miało czerwoną ramkę (w trybie Batch Component Editing) lub będzie zawierało ikonę (w trybie Single Component Editing), sygnalizując konieczność podania wartości tego parametru. Zapisanie komponentu w przestrzeni roboczej nie będzie możliwe, dopóki nie zostaną zdefiniowane wartości wszystkich wymaganych parametrów.

    W Edytorze komponentów pracującym w trybie Single Component Editing wymagany parametr szablonu jest oznaczony w obszarze Parameters ikoną .

Ponowne zapisywanie szablonu komponentu

W dowolnym momencie możesz wrócić do dowolnej rewizji szablonu komponentu w przestrzeni roboczej i bezpośrednio ją edytować. Kliknij rewizję prawym przyciskiem myszy i wybierz polecenie Edit z menu kontekstowego. Ponownie otworzy się tymczasowy edytor z szablonem zawartym w tej rewizji, gotowym do edycji. Wprowadź potrzebne zmiany, a następnie zapisz szablon komponentu jako kolejną rewizję elementu.

Kliknięcie prawym przyciskiem myszy pozycji najwyższego poziomu dla samego szablonu komponentu umożliwia edycję jego najnowszej rewizji.

Dostęp do polecenia uruchamiającego bezpośrednią edycję istniejącej rewizji szablonu komponentu.
Dostęp do polecenia uruchamiającego bezpośrednią edycję istniejącej rewizji szablonu komponentu.

Pobieranie zapisanych danych

Aby pobrać dane zapisane w rewizji szablonu komponentu, kliknij tę rewizję prawym przyciskiem myszy (w panelu Explorer) i wybierz polecenie Operations » Download z menu kontekstowego. Plik szablonu komponentu zostanie pobrany do podfolderu w wybranym katalogu, którego nazwa będzie odpowiadać identyfikatorowi rewizji elementu. Plik znajduje się w zawartym w nim folderze Released.

Aby pobrać plik szablonu komponentu zapisany w jego najnowszej rewizji, wybierz polecenie Download z pozycji najwyższego poziomu dla samego szablonu komponentu.
Kliknij przycisk Explore w oknie dialogowym Download from Server, aby szybko otworzyć folder pobierania.

Usuwanie miękkie

Po połączeniu z przestrzenią roboczą dostępna jest elastyczna funkcja usuwania szablonów komponentów bezpośrednio z programu Altium Designer, z poziomu panelu Explorer. Kliknij prawym przyciskiem myszy pozycję szablonu komponentu w panelu i wybierz polecenie Delete Item z menu kontekstowego. Pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. W rzeczywistości jest to „usuwanie miękkie”, w wyniku którego szablon komponentu zostaje przeniesiony do obszaru Trash przestrzeni roboczej. Obszar Trash pełni funkcję kosza, do którego można przenieść dowolną zawartość przestrzeni roboczej (za pomocą usuwania miękkiego). Jest on odizolowany od pozostałej części przestrzeni roboczej.

Funkcja usuwania miękkiego umożliwia usunięcie szablonu komponentu, który jest aktualnie używany.
Można usunąć wiele szablonów komponentów jednocześnie. Zaznacz wszystkie wymagane szablony komponentów za pomocą standardowych metod zaznaczania wielu pozycji (Shift+Click, Ctrl+Click), a następnie kliknij prawym przyciskiem myszy i wybierz polecenie Delete Items z menu kontekstowego.

Usuwanie miękkie szablonu komponentu. Szablon zostanie przeniesiony do obszaru Trash przestrzeni roboczej.
Usuwanie miękkie szablonu komponentu. Szablon zostanie przeniesiony do obszaru Trash przestrzeni roboczej.

Aby kontynuować usuwanie, kliknij przycisk . Element zostanie usunięty, a okno dialogowe Deletion Summary potwierdzi pomyślne usunięcie. Jeśli podczas usuwania wystąpi problem, otrzymasz o tym powiadomienie.

Wszystkie treści usunięte w ten sposób można znaleźć na stronie Trash w interfejsie przeglądarkowym przestrzeni roboczej. Pamiętaj, że możesz przeglądać tylko treści usunięte nietrwale przez Ciebie. Administratorzy widzą pełną zawartość strony Trash — czyli wszystkie treści, które zostały usunięte nietrwale.

Kwestie, o których należy pamiętać w przypadku nietrwale usuniętego szablonu komponentu:

  • Szablon komponentu nie będzie dostępny w oprogramowaniu projektowym ani w interfejsie internetowym.
  • We wszystkich miejscach, w których szablon komponentu był używany, pojawi się informacja o jego usunięciu.
  • Szablon komponentu można przywrócić lub trwale usunąć ze strony Trash, pod warunkiem posiadania uprawnień do edycji. Trwałe usunięcie jest możliwe tylko wtedy, gdy szablon nie jest używany przez element nadrzędny.
Pamiętaj, że po nietrwałym usunięciu szablonu komponentu — przeniesieniu go do Trash — możesz ponownie utworzyć nowy szablon komponentu o tej samej nazwie. Jeśli następnie przywrócisz oryginalny szablon komponentu, a jego pierwotna nazwa będzie już zajęta, zostanie do niej dodany przyrostek w postaci liczby całkowitej, aby zachować unikatowość nazwy w przestrzeni roboczej.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents