Component Templates
W skrócie
- Dowiedz się, jak skonfigurować foldery obszaru roboczego i elementy szablonów komponentów z odpowiednimi schematami nazewnictwa, rewizji i cyklu życia.
- Poznaj sposób, w jaki szablony sterują parametrami komponentów, w tym wymaganymi wartościami i domyślnymi wartościami tylko do odczytu.
- Sprawdź, jak edytować szablony bezpośrednio i zapisywać je z powrotem w obszarze roboczym jako nowe rewizje.
Aby usprawnić tworzenie komponentów, Altium Designer we współpracy z połączoną przestrzenią roboczą umożliwia tworzenie i definiowanie Component Templates (elementów szablonów komponentów) w tej przestrzeni. Podobnie jak szablon schematu pozwala wstępnie określić informacje na korzystających z niego arkuszach schematu, tak komponent biblioteczny przestrzeni roboczej odwołuje się do szablonu komponentu, który udostępnia wstępnie zdefiniowane ustawienia używane podczas definiowania tego komponentu.
Szablony komponentów opracowano przede wszystkim z myślą o informacjach parametrycznych. Umożliwiają one zdefiniowanie w jednym miejscu zestawu parametrów, które będą dostępne dla komponentu korzystającego z szablonu. Za pomocą szablonu można określić, które parametry mają być widoczne, wprowadzić wartości domyślne, a nawet oznaczyć wymagane parametry jako obowiązkowe. Podczas zapisywania komponentu przeprowadzana jest walidacja, która zapewnia zgodność z tymi wymaganiami.
Takie szablony komponentów są tworzone bezpośrednio w przestrzeni roboczej. Po utworzeniu szablonu komponentu i zapisaniu danych w jego rewizji można go ponownie wykorzystać do utworzenia jednego lub większej liczby komponentów.
Typ folderu
Podczas tworzenia folderu do przechowywania szablonów komponentów można określić jego typ. Nie ma to wpływu na zawartość folderu — opublikowanie szablonu komponentu zawsze spowoduje utworzenie odpowiedniego elementu szablonu komponentu. Typ folderu stanowi jedynie wizualną wskazówkę dotyczącą jego zawartości i może być pomocny podczas przeglądania przestrzeni roboczej w poszukiwaniu określonych treści. Aby wskazać, że folder ma służyć do przechowywania szablonów komponentów, podczas definiowania jego właściwości w oknie dialogowym Edit Folder ustaw Folder Type na Component Templates.

Określenie typu folderu — jego przeznaczenia — zapewnia wizualną informację o zawartości folderu podczas przeglądania przestrzeni roboczej.
Schemat nazewnictwa elementów
Innym ważnym aspektem folderu nadrzędnego jest stosowany w nim Item Naming Scheme. Określa on format unikatowego identyfikatora każdego elementu tworzonego w tym folderze. Dostępnych jest kilka domyślnych przykładowych schematów, które wykorzystują skrócony kod typu folderu (CTC — kolekcja szablonów komponentów) lub typu zawartości (CMPT — szablon komponentu):
-
$CONTENT_TYPE_CODE-001-{0000}— na przykładCMPT-001-0001. -
$CONTENT_TYPE_CODE-001-{A00}— na przykładCMPT-001-A01. -
$FOLDER_TYPE_CODE-001-{0000}— na przykładCTC-001-0001. -
$FOLDER_TYPE_CODE-001-{A000}— na przykładCTC-001-A001.
W przypadku korzystania z domyślnego schematu nazewnictwa oprogramowanie automatycznie przypisze kolejny dostępny unikatowy identyfikator zgodny z tym schematem, po przeskanowaniu całej przestrzeni roboczej i identyfikatorów istniejącej zawartości. Może to znacznie zaoszczędzić czas podczas ręcznego tworzenia szablonów komponentów.
Dla folderu można również zdefiniować własny schemat, wpisując go bezpośrednio w polu i pamiętając, aby część zmienna była ujęta w nawiasy klamrowe (np. CMP-TMP-{0000}).

Schemat nazewnictwa elementów folderu nadrzędnego jest stosowany do unikatowego identyfikatora każdego elementu utworzonego w tym folderze.
Typ zawartości
Podczas tworzenia docelowego elementu szablonu komponentu, w którym ma zostać zapisany szablon, upewnij się, że w oknie dialogowym Create New Item jego Content Type ma wartość Component Template. Jeśli tworzysz element w folderze typu Component Templates, ten typ zawartości będzie dostępny w menu kontekstowym otwieranym prawym przyciskiem myszy podczas tworzenia elementu.

Tworzenie szablonu komponentu w folderze Component Templates — odpowiedni Content Type jest dostępny w menu kontekstowym.
Definicja cyklu życia elementu i nazewnictwo rewizji
Related pages: Definiowanie schematów nazewnictwa rewizji w przestrzeni roboczej, Tworzenie definicji cyklu życia w przestrzeni roboczej
Podczas definiowania szablonu komponentu należy określić typ zarządzania cyklem życia, który będzie dla niego stosowany, oraz schemat nazewnictwa jego rewizji.
Podczas definiowania każdego schematu w oknie dialogowym Content Types można na poziomie globalnym określić i włączyć kontrolę nad tym, które typy zawartości mogą korzystać z danej definicji cyklu życia lub schematu nazewnictwa rewizji. Domyślne schematy przypisane do szablonu komponentu to odpowiednio Generic Lifecycle i 1-Level Revision Scheme.
Określ wymagane schematy w oknie dialogowym Create New Item, korzystając odpowiednio z pól Lifecycle Definition i Revision Naming Scheme.

Wybieranie definicji cyklu życia i schematu nazewnictwa rewizji dla ręcznie tworzonego szablonu komponentu.
Zapisywanie szablonu komponentu
Related page: Tworzenie i edytowanie zawartości
Dotychczas omówiliśmy obsługę szablonów komponentów w przestrzeni roboczej w kontekście powiązanych typów folderów i zawartości. Zapisanie zdefiniowanego szablonu komponentu w rewizji takiego elementu szablonu komponentu można przeprowadzić w prosty sposób.
Dzięki obsłudze edycji bezpośredniej w przestrzeni roboczej szablon komponentu można edytować i zapisać w początkowej rewizji nowo utworzonego elementu szablonu komponentu. Edycja bezpośrednia eliminuje konieczność korzystania z oddzielnych danych źródłowych objętych kontrolą wersji. Obsługiwany typ zawartości można po prostu edytować w tymczasowym edytorze, do którego wczytywane są najnowsze dane źródłowe bezpośrednio z przestrzeni roboczej. Po zakończeniu edycji obiekt jest zapisywany (lub zapisywany ponownie) w kolejnej zaplanowanej rewizji elementu nadrzędnego, a tymczasowy edytor zostaje zamknięty. Na dysku twardym nie ma żadnych plików, nie trzeba się zastanawiać, czy używane dane źródłowe są właściwe i aktualne, ani utrzymywać oddzielnego oprogramowania do kontroli wersji. Przestrzeń robocza zarządza wszystkim, zapewniając wysoką integralność danych i znacznie przyspieszając wprowadzanie zmian.
Podczas tworzenia elementu szablonu komponentu można edytować i zapisać szablon komponentu w początkowej rewizji tego elementu po jego utworzeniu. W tym celu włącz opcję Open for editing after creation u dołu okna dialogowego Create New Item (domyślnie jest ona włączona). Element zostanie utworzony i otworzy się tymczasowy edytor szablonów komponentów, wyświetlając dokument .CMPT jako aktywny dokument w głównym oknie projektowania. Dokument otrzyma nazwę zgodną z oznaczeniem elementu i rewizji, w formacie: <Item><Revision>.CMPT (np. CMPT-0001-1.CMPT).
Użyj dokumentu, aby zdefiniować szablon komponentu zgodnie z potrzebami. Więcej informacji na ten temat można znaleźć w sekcji Definiowanie szablonu.
Podczas edycji bezpośredniej dostępne są trzy przydatne przyciski, znajdujące się w Quick Access Bar (w lewym górnym rogu głównego okna aplikacji) lub na pasku narzędzi Component Template Standard:
-
– Save Active Document. Użyj tego przycisku, aby lokalnie zapisać zmiany wprowadzone w dokumencie. Pozwala to zapisać bieżące zmiany, jeśli chcesz wrócić do dokumentu później i wprowadzić kolejne zmiany przed ostatecznym zapisaniem go w przestrzeni roboczej.
-
/
– Save to Server. Użyj tego przycisku, aby zapisać zdefiniowany szablon komponentu w przestrzeni roboczej, w początkowej (planowanej) rewizji docelowego elementu szablonu komponentu. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać uwagi do wydania. Po zapisaniu dokument i edytor zostaną zamknięte. Dokument zawierający źródłowy szablon komponentu, *.CMPT, zostanie zapisany w rewizji elementu. -
/
– Discard Local Changes. Użyj tego przycisku, jeśli chcesz anulować edycję i odrzucić wszystkie wprowadzone zmiany. Dokument i edytor zostaną zamknięte, a do docelowego elementu szablonu komponentu nic nie zostanie opublikowane.
Te funkcje są również dostępne jako polecenia — Save (skrót: Ctrl+S), Save to Server (skrót: Ctrl+Alt+S) i Discard Local Changes — w głównym menu File oraz w menu kontekstowym wpisu szablonu komponentu w panelu Projects.
Dane zapisane w przestrzeni roboczej obejmują źródłowy szablon komponentu zdefiniowany w pliku szablonu komponentu (<Item><Revision>.CMPT).
Dziedziczenie szablonu komponentu
Możesz użyć szablonu komponentu z nadrzędnego typu komponentu, jeśli z podtypem nie jest powiązany żaden szablon komponentu. Podczas tworzenia hierarchii typów komponentów podtypy komponentów dziedziczą szablon przypisany do głównego/nadrzędnego typu komponentu.
Edytor CMPT (szablonów komponentów)
Definiowanie szablonu
Edytor szablonów komponentów jest podzielony na dwa główne obszary, pokazane na poniższym rysunku i opisane pod nim.
- Upper Region — służy do definiowania opcji na poziomie komponentu (cyklu życia, nazewnictwa i folderów) dla komponentu odwołującego się do szablonu.
- Lower Region — służy do definiowania parametrów używanych przez komponent odwołujący się do szablonu.
Określanie opcji komponentu
Górna połowa edytora służy do definiowania wartości domyślnych następujących właściwości komponentu:
-
Lifecycle Definition — wybierz definicję cyklu życia, która ma być stosowana do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie definicje zdefiniowane dla przestrzeni roboczej i dopuszczone do stosowania w komponentach.
-
Revision Naming — wybierz schemat nazewnictwa rewizji, który ma być stosowany do komponentu utworzonego przy użyciu szablonu. Lista rozwijana zawiera wszystkie schematy zdefiniowane dla przestrzeni roboczej i dopuszczone do stosowania w komponentach.
-
Component Naming – użyj tego pola, aby zdefiniować domyślny schemat nazewnictwa elementów dla komponentu tworzonego na podstawie szablonu, zapewniający unikalny identyfikator komponentu w przestrzeni roboczej. Wpis ten będzie używany jako szablon automatycznego nadawania nazwy komponentowi (w powiązanym polu Id, gdy edytor komponentów działa w trybie Single Component Editing, lub w polu Item ID, gdy edytor komponentów działa w trybie Batch Component Editing). Oprogramowanie automatycznie przypisze następny dostępny unikalny identyfikator zgodny z tym schematem po przeszukaniu całej przestrzeni roboczej i sprawdzeniu identyfikatorów istniejącej zawartości. Dostępny jest domyślny schemat nazewnictwa elementów –
CMP-{00000}– ale można oczywiście utworzyć własny schemat, wpisując go w tym polu i ujmując część zmienną w nawiasy klamrowe (np.CMP-001-{0000}). -
Default Folder – umożliwia określenie domyślnego folderu w docelowej przestrzeni roboczej, w którym ma być przechowywany zapisany komponent. Kliknij przycisk Choose, aby otworzyć okno dialogowe Choose Folder (będące odmianą panelu Explorer), w którym można przejść do istniejącego folderu w przestrzeni roboczej i go wybrać lub od razu utworzyć nowy folder.
Gdy szablon jest używany, wpisy określone w tym obszarze służą do wstępnego wypełniania odpowiednich pól w edytorze komponentów (o ile są dostępne):
- Single Component Editing mode – pola Id i Folder w obszarze Advanced Settings sekcji Component.
- Batch Component Editing mode – na karcie Document Options w oknie dialogowym Document Options, a w konsekwencji również pola Item ID i FolderPath w obszarze Component sekcji definicji komponentów.

Gdy szablon jest używany, wpisy służą do wstępnego wypełniania odpowiednich pól podczas edycji komponentu w edytorze komponentów w trybie Single Component Editing (po lewej) i w trybie Batch Component Editing (po prawej).
Definiowanie parametrów
Dolna połowa edytora służy do definiowania parametrów, które będą dostępne dla komponentu korzystającego z szablonu, oraz do zarządzania nimi.
Domyślne parametry systemowe
Podczas tworzenia nowego szablonu komponentu domyślnie dodawane są różne parametry systemowe, co przedstawiono na poniższej ilustracji i szczegółowo opisano w dalszej części.
-
ComponentType– ten parametr pozwala określić typ komponentu. Ułatwia to ukierunkowane wyszukiwanie za pomocą zaawansowanej funkcji wyszukiwania w przestrzeni roboczej. Funkcja ta umożliwia nie tylko wyszukiwanie według typu komponentu, lecz także bardziej inteligentne wyszukiwanie dzięki obsłudze parametrów komponentów uwzględniających jednostki. Podczas przeglądania komponentów z własnej przestrzeni roboczej w panelu Components grupowanie komponentów według Categories jest oparte na parametrachComponentTypepowiązanych z każdym komponentem. Kliknij powiązane pole Default Value, a następnie przycisk
, aby otworzyć okno dialogowe Choose component type. Wybierz w nim wymagany typ komponentu i kliknij OK – wybrany typ zostanie wstawiony jako wartość parametru ComponentType w głównej tabeli parametrów.

Przykładowy szablon komponentu z parametrem systemowym ComponentType ustawionym naDiodes. -
SCHLIBiPCBLIB– te dwa parametry pozwalają określić odpowiednio domyślny model symbolu i obudowy PCB. Dla każdego parametru kliknij powiązane pole Default Value, a następnie przycisk
, aby otworzyć okno dialogowe umożliwiające wybór wymaganego modelu.
-
NameiDescription– te dwa parametry pozwalają zdefiniować odpowiednio nazwę i opis komponentu. Dla każdego parametru wprowadź wymagany tekst w powiązanym polu Default Value.
Dodawanie nowego parametru użytkownika
Aby dodać do listy nowy parametr użytkownika, kliknij przycisk
(lub użyj polecenia Add z menu kontekstowego) — parametr zostanie dodany na końcu bieżącej listy.

Przykład dodawania nowego parametru użytkownika do szablonu.
Każdy parametr jest przedstawiony w tabeli za pomocą następujących informacji:
-
Name — użyj tego pola, aby nadać parametrowi nazwę, najlepiej taką, która jasno określa jego przeznaczenie. Po dodaniu parametrom nadawane są nazwy domyślne (
Parameter,Parameter 1,Parameter 2itd.). -
Type — typ parametru. Początkowo domyślnie ustawiana jest wartość
Text, ale obsługiwany jest szereg typów danych uwzględniających jednostki, a także typPCBLIB, który umożliwia definiowanie wielu footprintów, orazHarnessWiring, który umożliwia zdefiniowanie komponentu okablowania wiązki. Obsługiwane są również typy parametrów zdefiniowane w dostępnych słownikach — dowiedz się więcej. -
Visible — włącz tę opcję (jest to domyślny stan nowo dodanego parametru), aby odpowiadająca jej opcja Show dla danego parametru była włączona podczas edytowania jednego lub większej liczby komponentów w edytorze komponentów (skonfigurowanym w trybie Batch Component Editing). To z kolei steruje wyświetlaniem kolumny odpowiadającej temu parametrowi w dolnej części edytora komponentów, w której definiowane są same komponenty. Ta właściwość nie ma wpływu na definiowanie komponentu w trybie Single Component Editing edytora.
-
Read Only — włącz tę opcję, aby parametr był tylko do odczytu. Podczas edytowania komponentu odwołującego się do szablonu nie będzie można zmienić wartości tego parametru.
-
Required — włącz tę opcję, aby parametr był wymagany. Podczas edytowania komponentu odwołującego się do szablonu parametr musi mieć zdefiniowaną wartość, w przeciwnym razie zapisanie komponentu nie będzie możliwe. W edytorze komponentów taki parametr jest wyróżniony czerwoną ramką komórki wartości (w trybie Batch Component Editing) lub ikoną
w tej komórce (w trybie Single Component Editing), jeśli nie wprowadzono żadnej wartości.
-
Default Value — użyj tego pola, aby wprowadzić domyślną wartość parametru.
-
Description — dodaj dowolny opis parametru, na przykład krótką informację o jego przeznaczeniu. Jeśli dla parametru w szablonie zdefiniowano opis, kolumna Description będzie odpowiednio wyświetlana w obszarze Parameters edytora komponentów w jego Single Component Editing.
Lista parametrów obsługuje również proste operacje kopiowania i wklejania, umożliwiając powielanie jednego lub większej liczby istniejących parametrów użytkownika. Wklejone parametry zostaną dodane na końcu listy.
Kolejność i rozmiar kolumn
Kolejność kolumn można dostosować. Kliknij nagłówek kolumny i przeciągnij go poziomo w nowe położenie. Dostępne pozycje są wskazywane pionowymi strzałkami.
Sortowanie
Parametry można sortować według wybranej kolumny, klikając jej nagłówek. Kliknij raz, aby posortować rosnąco (według zawartości tej kolumny). Kliknij ponownie, aby posortować malejąco.
Można sortować według wielu kolumn. Gdy parametry są już posortowane według wybranej kolumny, użyj Shift+Click na innej kolumnie, aby zastosować dodatkowe sortowanie według jej zawartości.
Typy danych parametrów komponentów uwzględniające jednostki
Edytor szablonów komponentów umożliwia określanie konkretnych typów danych dla parametrów zdefiniowanych w szablonie komponentu (*.CMPT). Ponadto te typy danych uwzględniają jednostki i obsługują szereg popularnych przedrostków jednostek. Dzięki temu wartość parametru można wprowadzać w różnych formatach, takich jak 2.2k, 2k2, 4M czy 2.5GHz, a przestrzeń robocza automatycznie rozpozna wartość liczbową odpowiadającą tym zapisom.
Ta funkcja szablonu komponentu ułatwia precyzyjne wyszukiwanie za pomocą dostępnej na serwerze funkcji wyszukiwania zaawansowanego, która pozwala nie tylko wyszukiwać według typu komponentu, lecz także korzystać z inteligentniejszego wyszukiwania według zakresów wartości. Dzięki parametrom komponentów uwzględniającym jednostki można szybko zdefiniować wyszukiwanie, na przykład w celu znalezienia wszystkich kondensatorów o pojemności od 47uF do 220uF.
Więcej informacji o parametrach uwzględniających jednostki znajdziesz w poniższych rozwijanych sekcjach.
Obsługiwane jednostki
Podczas definiowania parametru użytkownika w szablonie komponentu obsługiwane są następujące typy danych uwzględniające jednostki:
-
Liczba całkowita
-
Liczba dziesiętna
-
Amper (A)
-
Pole powierzchni (mm2)
-
Bit
-
Kandela (cd)
-
Stopień Celsjusza (C)
-
Decybel (dB)
-
Farad (F)
-
Gram (g)
-
Henr (H)
-
Herc (Hz)
-
Dżul (J)
-
Lumen (lm)
-
Metr (m)
-
Milimetr (mm)
-
Om
-
Procent (%)
-
Paskal (Pa)
-
Bar (bar)
-
Funty na cal kwadratowy (psi)
-
Obroty na minutę (rpm)
-
Sekunda (s)
-
Simens (S)
-
Współczynnik temperaturowy (ppm/°C)
-
Tesla (T)
-
Wolt (V)
-
Waty (W)
Obsługiwane przedrostki jednostek
Poniższa tabela przedstawia przedrostki jednostek obsługiwane podczas wprowadzania wartości parametru typu uwzględniającego jednostki.
| Przedrostek | Nazwa | Wartość (zapis naukowy) | Wartość (zapis zwykły) |
|---|---|---|---|
| T | Tera | 1 x 1012 | 1 000 000 000 000 |
| G | Giga | 1 x 109 | 1 000 000 000 |
| M | Mega | 1 x 106 | 1 000 000 |
| k | kilo | 1 x 103 | 1 000 |
| m | mili | 1 x 10-3 | 1 / 1 000 |
| u | mikro | 1 x 10-6 | 1 / 1 000 000 |
| n | nano | 1 x 10-9 | 1 / 1 000 000 000 |
| p | piko | 1 x 10-12 | 1 / 1 000 000 000 000 |
| f | femto | 1 x 10-15 | 1 / 1 000 000 000 000 000 |
Dodawanie parametru komponentu uwzględniającego jednostki
Podczas dodawania parametru do szablonu (kliknij
w obszarze Parameters) użyj powiązanego pola Type, aby wybrać z listy rozwijanej wymagany typ danych uwzględniający jednostki.

Wybieranie obsługiwanego typu danych uwzględniającego jednostki dla parametru użytkownika w szablonie komponentu. W tym przykładzie typem parametru jest Ampere.
Podczas wprowadzania wartości parametru komponentu korzystającego z typu danych uwzględniającego jednostki — jako Default Value w szablonie komponentu lub jako wymaganej wartości w definicji komponentu — należy wziąć pod uwagę następujące kwestie:
-
Wartość można wprowadzić w różnych formatach:
-
Tylko wartość liczbowa (np.
10). Jeśli typ danych ma jednostkę, zostanie ona zastosowana automatycznie. Typy mające jednostki zawierają jednostkę w nawiasach po nazwie. -
Wartość liczbowa w zapisie naukowym (np.
1e10,1E6). -
Wartość liczbowa i jednostka (np.
10F). -
Wartość liczbowa z przedrostkiem (np.
10k). Odpowiednia jednostka zostanie dodana automatycznie (jeśli ma zastosowanie). -
Wartość liczbowa z przedrostkiem i jednostką (np.
10kF). -
Wartość liczbowa z przedrostkiem w typowym zapisie inżynierskim (np. dla rezystancji:
2k2,2K2,10r2,10R2). Wartość zostanie automatycznie odpowiednio znormalizowana (np.2K2zostanie zmienione na2.2k).
-
Tylko wartość liczbowa (np.
-
Przedrostek i/lub jednostkę można wprowadzić ze spacją po wartości liczbowej lub bez niej (np.
10uFlub10 uF). Spacja zostanie automatycznie usunięta.
Walidacja danych
Gdy dla parametru komponentu używany jest typ danych uwzględniający jednostki, wprowadzona wartość jest sprawdzana pod kątem zgodności z określonym typem danych. Zapewnia to użycie prawidłowej jednostki miary dla danego typu danych. Na przykład parametr typu Celsius nie może mieć wartości 10V!
Walidacja jest wykonywana wszędzie tam, gdzie używany jest parametr komponentu o typie danych uwzględniającym jednostki i podawana jest jego wartość:
- Podczas definiowania wartości domyślnej parametru w szablonie komponentu.
- Podczas definiowania wartości parametru w ramach definicji komponentu w edytorze komponentów.
- Podczas konfigurowania wyszukiwania zakresowego na podstawie wartości parametru w ramach zapisanego schematu wyszukiwania.

Przykład działania walidacji danych w edytorze szablonów komponentów.
Typy danych parametrów definiowane przez słowniki
Słowniki to niestandardowe typy parametrów z zestawem zdefiniowanych wartości. Słownikami zarządzają administratorzy obszaru roboczego na stronie Settings – Vault – Dictionaries w interfejsie przeglądarkowym obszaru roboczego. Można ją otworzyć z edytora szablonów komponentów, wybierając opcję Add New Dictionary z listy rozwijanej Type lub klikając element sterujący Manage Dictionaries w prawym górnym rogu obszaru Parameters.

Otwórz stronę zarządzania słownikami w interfejsie przeglądarkowym obszaru roboczego z poziomu edytora szablonów komponentów.
Zdefiniowane słowniki są dostępne jako typy parametrów na liście rozwijanej Type.

Wybierz typ parametru zdefiniowany przez słownik z listy rozwijanej Typ.
Wartości zdefiniowane dla wybranego typu słownikowego są dostępne na liście rozwijanej Default Value. Wybierz wymaganą wartość jako wartość domyślną parametru lub wybierz <None>.

Wybierz wartość domyślną spośród wartości zdefiniowanych dla wybranego typu słownikowego.
Definiowanie wielu footprintów
Edytor szablonów komponentów obsługuje również definiowanie wielu footprintów PCB w ramach szablonu komponentu. Można określić dowolną liczbę odwołań do modeli footprintów. Funkcja ta jest szczególnie przydatna podczas tworzenia komponentów odwołujących się do trzech footprintów spełniających wymagania IPC dla różnych poziomów gęstości: L (najmniejsza, czyli minimalna ilość miedzi), M (największa, czyli maksymalna ilość miedzi) oraz N (nominalna, czyli pośrednia ilość miedzi).
Aby dodać do szablonu definicję kolejnego modelu footprintu, kliknij
w celu dodania nowego parametru, a następnie wybierz pozycję PCBLIB z menu rozwijanego powiązanego z polem Type.

Zmień nowo dodany parametr w definicję modelu footprintu, ustawiając jego Type na PCBLIB.

Przykładowy komponent zdefiniowany w edytorze komponentów (w trybie Single Component Editing) z użyciem wskazanego szablonu komponentu. W szablonie zdefiniowano trzy modele footprintów, które są wczytywane do definicji komponentu. Zwróć uwagę, że pozycja modelu PCBLIB w szablonie jest używana jako domyślny model footprintu (oznaczony ikoną w lewym górnym rogu) podczas definiowania komponentu. Najedź kursorem na obraz, aby zobaczyć definiowanie tego samego komponentu w edytorze komponentów w trybie Batch Component Editing. W tym przypadku domyślny footprint jest określany jako PCBLIB (default).
Import i eksport szablonów komponentów
Istniejący plik szablonu komponentu (*.CMPT) lub plik biblioteki komponentów (*.CMPLIB) można zaimportować do edytora szablonów komponentów, a edytowany szablon można wyeksportować do pliku szablonu komponentu (*.CMPT). Użyj poleceń File » Import » Component Template, File » Import » Component Library i File » Export z menu głównego edytora komponentów, aby wybrać żądaną czynność, a następnie w otwartym standardowym oknie dialogowym systemu Windows przejdź do wymaganej lokalizacji i wybierz plik do zaimportowania lub określ nazwę pliku do wyeksportowania.
Ponowne użycie szablonu komponentu
Rewizję szablonu komponentu można wykorzystać — a dokładniej odwołać się do niej z aktualnie edytowanej rewizji komponentu — na poniższe sposoby.
Podczas tworzenia nowego komponentu
Podczas tworzenia nowego komponentu za pomocą polecenia File » New » Component z menu głównego można wybrać szablon w oknie dialogowym Create new component.

Szybkie powiązanie szablonu komponentu z listy wszystkich dostępnych szablonów podczas tworzenia nowego komponentu.
Ręcznie w edytorze komponentów
Sposób ponownego użycia rewizji szablonu komponentu w edytorze komponentów zależy od trybu pracy edytora.
W trybie edycji pojedynczego komponentu
Podczas edycji pojedynczego komponentu w tym trybie edytora komponentów wybierz wymagany szablon komponentu z menu rozwijanego powiązanego z polem Template, należącym do grupy Advanced Settings w obszarze Component edytora. Na liście znajdują się nazwy wszystkich szablonów komponentów dostępnych obecnie w tym samym obszarze roboczym, w którym znajduje się komponent, wraz z ich najnowszymi rewizjami podanymi w nawiasach. Wybierz wymagany szablon, aby go zastosować.

Szybkie powiązanie szablonu komponentu z menu wszystkich dostępnych szablonów podczas edycji rewizji komponentu w edytorze komponentów w trybie Single Component Editing.
W trybie edycji zbiorczej komponentów
Istnieją dwa sposoby powiązania rewizji szablonu komponentu z aktualnie edytowaną rewizją komponentu:
-
Na karcie Template okna dialogowego Opcje dokumentu (Edit » Document Options). Kliknij przycisk Choose po prawej stronie pola Item Revision. Spowoduje to otwarcie okna dialogowego Choose Item (odmiany panelu Eksplorator). W tym oknie przejdź do wymaganego szablonu komponentu i wybierz jego rewizję. Po kliknięciu OK zostanie utworzone powiązanie między rewizją komponentu a docelową rewizją szablonu komponentu. Informację o tym powiązaniu można zobaczyć po powrocie na kartę Template okna dialogowego Document Options.

Ręczne powiązanie komponentu z rewizją szablonu komponentu w docelowym obszarze roboczym. -
Z menu Add powiązanego z obszarem Required Models/Parameters Edytora komponentów. Podmenu Templates zawiera listę nazw wszystkich szablonów komponentów dostępnych obecnie w tej samej przestrzeni roboczej, w której znajduje się komponent, z najnowszymi rewizjami podanymi w nawiasach. Kliknij pozycję, aby utworzyć powiązanie z najnowszą rewizją danego szablonu komponentu. Powiązanie można również sprawdzić na karcie Templates okna dialogowego Document Options.

Szybkie tworzenie powiązania z szablonem komponentu z menu wszystkich dostępnych szablonów.
Dziedziczenie z folderu komponentów w przestrzeni roboczej
Możesz wskazać szablon komponentu, który będzie automatycznie stosowany do wszystkich komponentów (i ich rewizji) przechowywanych w folderze komponentów w przestrzeni roboczej.
Wskaż wymagany szablon w polu Component Template podczas definiowania właściwości folderu w oknie dialogowym Edit Folder. Lista rozwijana tego pola zawiera nazwy wszystkich szablonów komponentów dostępnych obecnie w tej samej przestrzeni roboczej, w której znajduje się folder komponentów, z najnowszymi rewizjami podanymi w nawiasach. Wybierz pozycję, aby dla każdego kolejnego komponentu tworzonego w tym folderze utworzyć powiązanie z najnowszą rewizją danego szablonu komponentu.

Wskaż domyślny szablon komponentu, który będzie stosowany do wszystkich komponentów tworzonych w nadrzędnym folderze komponentów.
Jeśli szablon komponentu zostanie wybrany na poziomie folderu, będzie on domyślnie używany również podczas tworzenia komponentów w jego podfolderach. Umożliwia to szybkie dziedziczenie szablonu przez wszystkie komponenty w folderach podrzędnych.
Wpływ stosowania szablonu komponentu na modele i parametry komponentu
Podczas edytowania rewizji komponentu powiązanie z rewizją szablonu komponentu powoduje następujące zmiany dotyczące modeli i parametrów w Edytorze komponentów:
- Modele zdefiniowane we wskazanym szablonie są dodawane do obszaru Models (w trybie Single Component Editing) i obszaru Model Links (w trybie Batch Component Editing).
- Istniejące odwołanie do modelu zostanie zachowane, a komponent będzie nadal korzystać z tego modelu, chyba że zostanie on celowo zmieniony ręcznie.
-
Parametry zdefiniowane we wskazanym szablonie są dodawane do obszaru Parameters (w trybie Single Component Editing) i obszaru Required Models/Parameters (w trybie Batch Component Editing).

Przykład parametrów po utworzeniu powiązania z rewizją szablonu komponentu w Edytorze komponentów pracującym w trybie Single Component Editing (po lewej) i Batch Component Editing (po prawej). -
Wyłącznie w trybie Batch Component Editing parametry oparte na szablonie, dla których włączono wyświetlanie, są grupowane w obszarze definicji komponentów edytora pod nagłówkiem
Template Parameters.
Wygląd przykładowych parametrów opartych na szablonie w obszarze definiowania komponentów w Edytorze komponentów pracującym w trybie Batch Component Editing. -
Pola wartości parametrów opartych na szablonie, które oznaczono jako tylko do odczytu, nie będą dostępne do edycji. W przypadku pozostałych parametrów opartych na szablonie, których nie oznaczono jako tylko do odczytu, można dowolnie zmieniać wartości zgodnie z potrzebami.
-
Jeśli parametr oparty na szablonie został oznaczony jako wymagany, ale w szablonie nie przypisano mu wartości, jego pole wartości będzie miało czerwoną ramkę (w trybie Batch Component Editing) lub będzie zawierało ikonę
(w trybie Single Component Editing), sygnalizując konieczność podania wartości tego parametru. Zapisanie komponentu w przestrzeni roboczej nie będzie możliwe, dopóki nie zostaną zdefiniowane wartości wszystkich wymaganych parametrów.
Ponowne zapisywanie szablonu komponentu
W dowolnym momencie możesz wrócić do dowolnej rewizji szablonu komponentu w przestrzeni roboczej i bezpośrednio ją edytować. Kliknij rewizję prawym przyciskiem myszy i wybierz polecenie Edit z menu kontekstowego. Ponownie otworzy się tymczasowy edytor z szablonem zawartym w tej rewizji, gotowym do edycji. Wprowadź potrzebne zmiany, a następnie zapisz szablon komponentu jako kolejną rewizję elementu.

Dostęp do polecenia uruchamiającego bezpośrednią edycję istniejącej rewizji szablonu komponentu.
Pobieranie zapisanych danych
Aby pobrać dane zapisane w rewizji szablonu komponentu, kliknij tę rewizję prawym przyciskiem myszy (w panelu Explorer) i wybierz polecenie Operations » Download z menu kontekstowego. Plik szablonu komponentu zostanie pobrany do podfolderu w wybranym katalogu, którego nazwa będzie odpowiadać identyfikatorowi rewizji elementu. Plik znajduje się w zawartym w nim folderze Released.
Usuwanie miękkie
Po połączeniu z przestrzenią roboczą dostępna jest elastyczna funkcja usuwania szablonów komponentów bezpośrednio z programu Altium Designer, z poziomu panelu Explorer. Kliknij prawym przyciskiem myszy pozycję szablonu komponentu w panelu i wybierz polecenie Delete Item z menu kontekstowego. Pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. W rzeczywistości jest to „usuwanie miękkie”, w wyniku którego szablon komponentu zostaje przeniesiony do obszaru Trash przestrzeni roboczej. Obszar Trash pełni funkcję kosza, do którego można przenieść dowolną zawartość przestrzeni roboczej (za pomocą usuwania miękkiego). Jest on odizolowany od pozostałej części przestrzeni roboczej.

Usuwanie miękkie szablonu komponentu. Szablon zostanie przeniesiony do obszaru Trash przestrzeni roboczej.
Aby kontynuować usuwanie, kliknij przycisk
. Element zostanie usunięty, a okno dialogowe Deletion Summary potwierdzi pomyślne usunięcie. Jeśli podczas usuwania wystąpi problem, otrzymasz o tym powiadomienie.
Wszystkie treści usunięte w ten sposób można znaleźć na stronie Trash w interfejsie przeglądarkowym przestrzeni roboczej. Pamiętaj, że możesz przeglądać tylko treści usunięte nietrwale przez Ciebie. Administratorzy widzą pełną zawartość strony Trash — czyli wszystkie treści, które zostały usunięte nietrwale.
Kwestie, o których należy pamiętać w przypadku nietrwale usuniętego szablonu komponentu:
- Szablon komponentu nie będzie dostępny w oprogramowaniu projektowym ani w interfejsie internetowym.
- We wszystkich miejscach, w których szablon komponentu był używany, pojawi się informacja o jego usunięciu.
- Szablon komponentu można przywrócić lub trwale usunąć ze strony Trash, pod warunkiem posiadania uprawnień do edycji. Trwałe usunięcie jest możliwe tylko wtedy, gdy szablon nie jest używany przez element nadrzędny.









).