Definiowanie linii gięcia — tryb standardowy

W skrócie

W tym artykule wyjaśniamy, jak definiować, umieszczać, przesuwać, usuwać i konfigurować linie gięcia w obszarach elastycznych podczas pracy w trybie Standard Rigid-Flex w Altium Designer. Omawiamy również różnice między trybami Standard Rigid-Flex i Advanced Rigid-Flex, sposób sprawdzania, z którego trybu korzysta płytka, oraz widoki i panele edytora służące do precyzyjnego zarządzania zgięciami. Jeśli szukasz praktycznych instrukcji ustawiania położenia, kąta i promienia gięcia, szerokości obszaru objętego gięciem oraz kolejności zginania we właściwym trybie, ten przewodnik pomoże Ci pracować z większą pewnością. Czytaj dalej i zastosuj opisane kroki w kolejnym projekcie.

- Dowiedz się, kiedy można korzystać z linii gięcia w trybie Standard Rigid-Flex i czym ten tryb różni się od Advanced Rigid-Flex pod względem definiowania obszarów płytki.
- Poznaj dokładne kroki umieszczania, przesuwania, usuwania i precyzyjnego wyrównywania linii gięcia w trybie planowania płytki.
- Sprawdź, jakie właściwości linii gięcia można konfigurować, w tym kąt i promień gięcia, szerokość obszaru objętego gięciem oraz kolejność zginania na potrzeby weryfikacji złożenia płytki w widoku 3D.
Zagłęb się w temat dzięki AI:

W oprogramowaniu Altium do projektowania PCB dostępne są dwa tryby projektowania sztywno-giętkiego. Pierwotny, czyli standardowy tryb, określany jako Rigid-Flex, obsługuje proste projekty sztywno-giętkie. Jeśli projekt ma bardziej złożone wymagania dotyczące konstrukcji sztywno-giętkiej, takie jak nakładające się obszary giętkie, należy użyć trybu Advanced Rigid-Flex (znanego również jako rigid-flex 2.0). Tryb wybiera się w menu Tools w Menedżerze stosu warstw.

Podstawowa różnica między tymi trybami polega na tym, że w trybie pierwotnym kształt płytki dzieli się na oddzielne obszary przez umieszczenie linii podziału, która pozostaje obiektem wyznaczającym miejsce, w którym kończy się jeden obszar płytki, a zaczyna drugi. W trybie zaawansowanym każdy obszar płytki umieszcza się oddzielnie, a przecięcie większego obszaru powoduje powstanie dwóch oddzielnych obiektów obszarów. W trybie zaawansowanym miejsce styku dwóch sąsiadujących obszarów płytki wyznaczają ich krawędzie, a nie linia podziału. Z tego powodu w trybie Advanced Rigid-Flex nie występuje obiekt linii podziału.

► Dowiedz się więcej o projektowaniu sztywno-giętkich PCB

Menu View udostępnia trzy tryby pracy edytora PCB z łatwymi do zapamiętania skrótami, które umożliwiają szybkie przełączanie między nimi:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Domyślnie podczas przełączania między widokami 2D i 3D zachowywane są oddzielne ustawienia powiększenia i orientacji dla każdego z nich. Aby podczas przełączania zachować tę samą lokalizację i orientację płytki, naciśnij Ctrl+Alt+2 lub Ctrl+Alt+3 zamiast 2 lub 3.

Po otwarciu PCB zastanawiasz się, czy korzysta ono ze standardowego, czy zaawansowanego trybu sztywno-giętkiego?

Możesz to sprawdzić, otwierając Menedżer stosu warstw. Możesz też przełączyć się do trybu planowania płytki (skrót 1) i spojrzeć na aktywny pasek narzędzi:

Standardowy tryb Rigid-Flex
Tryb Advanced Rigid-Flex

Aby określić sposób zginania płytki giętkiej, należy umieścić jedną lub więcej linii zgięcia. Linia zgięcia wyznacza miejsce na powierzchni obszaru giętkiego, w którym ma nastąpić zgięcie. Określa również kąt i promień zgięcia oraz szerokość pasa powierzchni płytki poddawanego zginaniu. Linie zgięcia umieszcza się i edytuje w edytorze PCB w trybie Board Planning Mode (View » Board Planning Mode lub naciśnij skrót 1).

Linię zgięcia można umieścić wyłącznie w obszarze skonfigurowanym jako obszar Flex w Layer Stack Manager.


Linia zgięcia jest umieszczana na obszarze giętkim i konfigurowana tak, aby płytkę można było złożyć o 180 stopni. Ten film przedstawia umieszczanie linii zgięcia w standardowym trybie Rigid-Flex.

Umieszczanie linii zgięcia

Aby umieścić linię zgięcia:

  1. Wybierz View » Board Planning Mode lub naciśnij skrót 1, aby przejść do Board Planning Mode.

  2. Linie zgięcia są umieszczane na warstwie Multi-Layer. Jeśli karta Mutli-Layer nie jest widoczna u dołu obszaru edycji, włącz tę warstwę w panelu View Configuration (skrót L wyświetla panel).

  3. Wybierz polecenie Design » Define Bending Line.

  4. Kliknij wewnątrz obszaru płytki, w którym ma zostać umieszczona linia zgięcia. Jeden koniec linii zostanie przyciągnięty do krawędzi obszaru najbliższej miejscu kliknięcia, a drugi będzie podążać za kursorem.

  5. Ustaw drugi koniec w żądanym miejscu, a następnie kliknij raz, aby go umieścić.

  6. Tryb umieszczania linii zgięcia pozostaje aktywny, umożliwiając umieszczenie kolejnej linii. Jeśli nie jest to potrzebne, kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z tego trybu.

Panel PCB w trybie Layer Stack Regions wyświetla dane Bending Lines. Kliknij dwukrotnie wpis, aby otworzyć okno dialogowe linii zgięcia. 

W tym obszarze płytki giętkiej umieszczono trzy linie zgięcia. Szerokość pomarańczowego pasa odpowiada parametrowi Szerokość obszaru objętego zginaniem.
W tym obszarze płytki giętkiej umieszczono trzy linie zgięcia. Szerokość pomarańczowego pasa odpowiada parametrowi Szerokość obszaru objętego zginaniem.

Gdy obszar płytki zostanie skonfigurowany do korzystania z giętkiego stosu warstw, automatycznie dodawana jest pionowa linia zgięcia przechodząca przez jego środek geometryczny. W razie potrzeby usuń tę linię albo zmień jej położenie i konfigurację.

Przesuwanie linii zgięcia

Aby zmienić położenie istniejącej linii zgięcia:

  1. Wybierz View » Board Planning Mode (lub naciśnij skrót  1), aby przejść do Board Planning Mode.
  2. Kliknij raz, aby zaznaczyć obszar płytki zawierający linię zgięcia. Zostaną wyświetlone uchwyty wszystkich linii zgięcia w tym obszarze.
  3. Aby przesunąć koniec linii, kliknij i przytrzymaj węzeł, a następnie przeciągnij go w żądane miejsce na obwodzie obszaru płytki. Ruch kursora będzie ograniczony przez bieżącą siatkę przyciągania i/lub istniejące obiekty projektu.
  4. Miejsce zgięcia zostanie określone przez nowe położenie linii zgięcia.

Zaznacz i przeciągnij węzeł końcowy linii zgięcia, aby zmienić położenie zgięcia na płytce.
Zaznacz i przeciągnij węzeł końcowy linii zgięcia, aby zmienić położenie zgięcia na płytce.

Precyzyjne pozycjonowanie linii zgięcia

Podczas przesuwania linii zgięcia jej uchwyt jest przyciągany do punktów bieżącej siatki przyciągania. Może być również przyciągany do istniejących obiektów projektu, takich jak linie na warstwie mechanicznej. Poniższa ilustracja przedstawia ustawianie uchwytu linii zgięcia na końcu linii na warstwie Mechanical 2 (oznaczone numerem 1). Pamiętaj, że aby przyciąganie działało, warstwa mechaniczna musi być aktywną warstwą projektową.

Numer 1 wskazuje uchwyt linii zgięcia przyciągany do linii na warstwie Mechanical 2; zwróć uwagę, że jest to warstwa aktywna.
Numer 1 wskazuje uchwyt linii zgięcia przyciągany do linii na warstwie Mechanical 2; zwróć uwagę, że jest to warstwa aktywna.

Aby dokładniej przedstawić powyższy proces, na poniższych ilustracjach pokazano linie konstrukcyjne umieszczone na warstwie Mechanical 2 w 2D Layout Mode, które precyzyjnie wyznaczają górny i dolny punkt odniesienia do umieszczenia linii zgięcia pod kątem 45 stopni.

Płytka w trybie projektowania 2D z liniami konstrukcyjnymi ułatwiającymi precyzyjne umieszczenie ukośnych linii zgięcia.Płytka w trybie projektowania 2D z liniami konstrukcyjnymi ułatwiającymi precyzyjne umieszczenie ukośnych linii zgięcia.

Płytka w trybie planowania płytki z ukośnymi liniami zgięcia przyciągniętymi do linii konstrukcyjnych na warstwie Mechanical 2.Płytka w trybie planowania płytki z ukośnymi liniami zgięcia przyciągniętymi do linii konstrukcyjnych na warstwie Mechanical 2.

Usuwanie linii zgięcia

Aby usunąć linię zgięcia:

  1. Wybierz View » Board Planning Mode (lub naciśnij skrót 1), aby przejść do Board Planning Mode.
  2. Kliknij i przytrzymaj jeden z jej punktów końcowych, a następnie naciśnij klawisz Delete. Możesz też zaznaczyć i usunąć wpis linii zgięcia w sekcji Bending Lines panelu PCB .

Gdy obszar płytki zostanie skonfigurowany do korzystania z giętkiego stosu warstw, automatycznie dodawana jest pionowa linia zgięcia przechodząca przez jego środek geometryczny. W razie potrzeby usuń tę linię albo zmień jej położenie i konfigurację.

Konfigurowanie właściwości linii zgięcia

Obszary płytki, linie podziału i linie zgięcia można przeglądać i edytować w Board Planning Mode (naciśnij 1). Linie zgięcia można edytować interaktywnie w obszarze projektowania lub za pomocą PCB panelu, gdy jest ustawiony na tryb Layer Stack Regions. Aby wyświetlić panel, kliknij przycisk Panels w prawym dolnym rogu Altium Designer, a następnie wybierz z menu PCB. W panelu wybierz Layer Stack Regions z listy rozwijanej u góry. W tym trybie panel pokazuje:

  • Dostępne stosy warstw płytki w sekcji Layer Stacks.
  • Regiony przypisane do tych stosów w sekcji Stackup Regions.
  • Linie gięcia zdefiniowane w wybranym regionie w sekcji Bending Lines.

Po przejściu do Board Planning Mode panel PCB zostanie automatycznie przełączony w tryb Layer Stack Regions.

Aby edytować właściwości linii gięcia w panelu PCB:

  1. Linie gięcia można edytować w trybie 2D Layout Mode (naciśnij 2) lub Board Planning Mode (naciśnij 1).
  2. Zaznacz pole Select u góry panelu.
  3. Wybierz region płytki zawierający linię gięcia w obszarze Stackup Regions panelu PCB .
  4. Wybierz linię gięcia z listy w sekcji Bending Lines panelu. Linia gięcia zostanie podświetlona (zaznaczona) na płytce, jeśli w panelu PCB jest włączona opcja Select. Wpis linii gięcia można również usunąć z sekcji Bending Lines.
  5. Kliknij dwukrotnie wpis linii gięcia w sekcji Bending Lines, aby otworzyć okno dialogowe Bending Line, jak pokazano na poniższym obrazie.

  6. W oknie dialogowym Bending Line edytuj dwie z trzech pierwszych właściwości, na przykład Radius (odległość środka gięcia od giętej powierzchni) i Bending Angle (kąt, o jaki ma zostać zgięta powierzchnia regionu elastycznego). Trzecia właściwość — Affected area width (szerokość obszaru powierzchni, który zostanie zgięty dla danych wartości Radius i Bending Angle) — zostanie obliczona automatycznie (więcej na ten temat poniżej). Zwróć uwagę, że Affected area width każdej linii gięcia jest wyświetlany jako obszar z pomarańczowym cieniowaniem.
  7. W oknie dialogowym Bending Line ustaw odpowiednio Fold Index, aby określić kolejność wykonywania zgięć podczas korzystania z suwaka Fold State w panelu PCB lub polecenia View » Fold/Unfold, które służą do zginania płytki w trybie 3D. Najpierw wykonywane jest zgięcie o najniższej wartości, a na końcu — o najwyższej.

Dla jednego z regionów płytki należy zaznaczyć pole 3D Locked w oknie dialogowym Board Region, aby określić fizyczny poziom odniesienia dla trybu wyświetlania 3D (gdzie Z = 0). W przeciwnym razie Affected area width dla każdej zdefiniowanej linii gięcia nie będzie wyświetlany.

Okno dialogowe Bending Line można również otworzyć, naciskając Tab podczas umieszczania lub przesuwania uchwytu linii gięcia albo klikając dwukrotnie uchwyt linii gięcia.

Podsumowanie definiowania zgięć

Linia gięcia to obiekt liniowy umieszczany w poprzek regionu w celu określenia położenia, promienia i kąta zgięcia, które ma zostać zastosowane do danego regionu elastycznego płytki.

Definiowanie linii gięcia:

  • Linie gięcia umieszcza się w trybie planowania płytki (skrót 1).
  • Aby umieścić linię gięcia, uruchom polecenie Design » Define Bending Line.
  • Umieść linię gięcia w poprzek elastycznego regionu płytki. Początek i koniec linii gięcia nie muszą dokładnie stykać się z krawędziami regionu — oprogramowanie automatycznie ją wydłuży (jeśli jest zbyt krótka) lub skróci (jeśli jest zbyt długa). Co najmniej jeden koniec linii gięcia musi dotykać krawędzi regionu lub poza nią wystawać.
  • Aby edytować właściwości linii gięcia, kliknij w dowolnym miejscu wewnątrz regionu, aby wyświetlić wierzchołki wszystkich linii gięcia w tym regionie, a następnie:
    • Kliknij dwukrotnie wierzchołek linii gięcia, aby otworzyć okno dialogowe linii gięcia, lub
    • Wyświetl panel PCB i ustaw go w tryb Layer Stack Regions, w którym można przeglądać i edytować regiony oraz linie gięcia.
    • Ustaw odpowiednio Bending Angle i Radius zgięcia.
    • Zgięcia są wykonywane w kolejności określonej przez Fold Index. Skorzystaj z tej funkcji, gdy istotne jest sprawdzenie kolejności zginania.
  • Aby przesunąć linię gięcia, kliknij i przeciągnij każdy z jej wierzchołków.
  • Linię gięcia można usunąć, klikając i przytrzymując jeden z jej wierzchołków, a następnie naciskając Delete na klawiaturze.
  • Linii gięcia nie można stosować do krawędzi wycięcia w płytce. Jeśli płytka tego wymaga, przełącz się na tryb Rigid-Flex Advanced.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents