PCB Placement & Editing Techniques
W skrócie
- Poznaj różnice między obiektami podstawowymi a grupowymi oraz ich wpływ na umieszczanie obiektów i operowanie nimi w edytorze PCB.
- Zapoznaj się z typowym procesem edycji przed umieszczeniem obiektu, w trakcie jego umieszczania i po nim, w tym z ustawieniami domyślnymi, dostępem do Properties oraz przełączaniem wyświetlanych jednostek.
- Sprawdź, które polecenia zaznaczania obiektów PCB ułatwiają pracę z nakładającymi się obiektami, logiczną hierarchią sieci, połączonymi obszarami miedzi oraz zaznaczaniem poprowadzonych połączeń na podstawie komponentów.
Podczas projektowania PCB można korzystać z różnych obiektów. Większość obiektów umieszczanych w dokumencie PCB definiuje obszary miedzi lub obszary jej pozbawione. Dotyczy to zarówno obiektów elektrycznych, takich jak ścieżki i pola lutownicze, jak i obiektów nieelektrycznych, takich jak tekst i wymiarowanie. Dlatego należy pamiętać o szerokości linii używanych do definiowania poszczególnych obiektów oraz o warstwie, na której dany obiekt jest umieszczony.
W edytorze PCB występują dwa typy obiektów — obiekty podstawowe i obiekty grupowe:
-
Obiekty podstawowe to fundamentalne elementy projektu, takie jak ścieżki, pola lutownicze, przelotki, wypełnienia, łuki i obiekty tekstowe. Są nazywane „podstawowymi” ze względu na ich elementarny charakter.
-
Każdy obiekt złożony z obiektów podstawowych i rozpoznawany jako obiekt projektu jest obiektem grupowym. Przykładami obiektów grupowych są komponenty, wymiary i wylewki wielokątne. Obiektem grupowym można manipulować w obszarze projektowym jak pojedynczym obiektem. Można go na przykład umieszczać, zaznaczać, kopiować, zmieniać, przesuwać i usuwać.
Wspólne zasady umieszczania i edycji obiektów
W Altium Designer proces umieszczania obiektu przebiega podobnie niezależnie od jego rodzaju. W najprostszej postaci wygląda następująco:
-
Wybierz obiekt do umieszczenia z jednego z pasków narzędzi lub z menu Place .
-
Za pomocą myszy określ położenie umieszczanego obiektu w obszarze projektowym edytora PCB oraz jego rozmiar (jeśli dotyczy).
-
Kliknij prawym przyciskiem myszy (lub naciśnij Esc), aby zakończyć polecenie i wyjść z trybu umieszczania.
Edycja przed umieszczeniem
Domyślne właściwości obiektu można zmienić w dowolnym momencie na stronie Edytor PCB – Ustawienia domyślne w oknie dialogowym Preferences . Właściwości te będą stosowane podczas umieszczania kolejnych obiektów.

Użyj kolumny Primitives , aby uzyskać dostęp do właściwości obiektów i odpowiednio zmienić wartości domyślne.
Edycja podczas umieszczania
Podczas początkowego umieszczania obiektu można edytować szereg jego atrybutów. Aby uzyskać do nich dostęp, naciśnij klawisz Tab w trybie umieszczania, aby otworzyć powiązany panel Properties. Naciśnięcie klawisza Tab wstrzymuje umieszczanie, umożliwiając wprowadzenie wymaganych zmian w obiekcie.
Przykładowe okno dialogowe właściwości obiektu pola lutowniczego .
Po wprowadzeniu zmian kliknij przycisk pauzy wyświetlany na obszarze projektowym (
), aby wznowić umieszczanie.
Edycja po umieszczeniu
Po umieszczeniu obiektu można go edytować na kilka sposobów. Opisano je poniżej.
Powiązany panel lub okno dialogowe właściwości
Ta metoda edycji wykorzystuje odpowiedni tryb panelu Properties oraz okno dialogowe do modyfikowania właściwości umieszczonego obiektu.
Po umieszczeniu obiektu dostęp do powiązanego okna dialogowego można uzyskać w następujący sposób:
-
Kliknij dwukrotnie umieszczony obiekt.
-
Umieść kursor nad obiektem, kliknij prawym przyciskiem myszy, a następnie wybierz Properties z menu kontekstowego.
Po umieszczeniu obiektu dostęp do odpowiedniego trybu panelu Properties można uzyskać na jeden z następujących sposobów:
- Jeśli panel Properties jest już aktywny, zaznacz obiekt.
- Po zaznaczeniu obiektu wybierz panel Properties za pomocą przycisku Panels w prawym dolnym rogu obszaru projektowego lub wybierz View » Panels » Properties z menu głównego.
Polecenia zaznaczania obiektów PCB
Oprócz standardowych poleceń zaznaczania obiektów i usuwania ich zaznaczenia edytor PCB zawiera szereg specjalnych poleceń ułatwiających te operacje. Polecenia te są dostępne w podmenu Edit » Select i Edit » DeSelect menu głównego. Polecenia zaznaczania są również dostępne w menu przycisku
w Active Bar.
-
Select overlapped - służy do zaznaczania pojedynczo kolejnego obiektu projektu w zbiorze obiektów znajdujących się w tym samym miejscu (nakładających się) bez korzystania z wyskakującego okna wyboru. Zaznaczanie odbywa się według następującej stałej kolejności priorytetów, powtarzanej cyklicznie przy kolejnych użyciach polecenia:
- Pole lutownicze
- Przelotka
- Ścieżka/łuk
- Komponent
- Wielokąt
- Region/wypełnienie
- Tekst
Ponadto podczas używania klawisza Shift do dodawania kolejnych obiektów do bieżącego zaznaczenia można użyć Shift+Tab do cyklicznego przełączania zaznaczenia nakładających się obiektów bez utraty pierwotnego zaznaczenia.
-
Select next (skrót: Tab) - gdy w projekcie zaznaczono już obiekt początkowy, to polecenie rozszerza zaznaczenie o obiekt (lub obiekty) na kolejnym, wyższym poziomie hierarchii logicznej. Obsługiwane są następujące cykliczne sekwencje zaznaczania logicznego:
- Segment ścieżki ---> Wszystkie połączone (ciągłe) ścieżki na tej samej warstwie ---> Cała połączona miedź ---> Wszystkie obiekty elektryczne należące do powiązanej sieci
- Podłączony pad ---> Wszystkie połączone (ciągłe) ścieżki na tej samej warstwie ---> Cała połączona miedź ---> Wszystkie obiekty elektryczne należące do powiązanej sieci
- Niepodłączony pad ---> Wszystkie obiekty elektryczne należące do powiązanej sieci
- Przelotka ---> Wszystkie połączone (ciągłe) ścieżki na warstwach powiązanych z przelotką ---> Cała połączona miedź ---> Wszystkie obiekty elektryczne należące do powiązanej sieci
- Miedź (region/wylewka wielokątna/wypełnienie) ---> Cała połączona miedź ---> Wszystkie obiekty elektryczne należące do powiązanej sieci
- Wolny pad/przelotka ---> Wszystkie połączone (ciągłe) ścieżki na tej samej warstwie co pad lub na warstwach powiązanych z przelotką ---> Cała połączona miedź ---> Wszystkie obiekty elektryczne należące do powiązanej sieci.
- Komponent ---> Wyprowadzenia do przelotek, wyprowadzenia ścieżek, połączenia między obiektami
Ponadto funkcja umożliwia rozszerzanie zaznaczenia obejmującego wiele obiektów należących do różnych sieci w projekcie.

Przykład zaznaczania w wielu sieciach, rozszerzanego od początkowo zaznaczonych segmentów ścieżek na kolejne, wyższe poziomy hierarchii logicznej.To polecenie jest szczególnie przydatne podczas zaznaczania sieci z wytrasowanymi połączeniami. Dowiedz się więcej o strategiach zaznaczania trasowanych połączeń.
-
Board - służy do zaznaczania wszystkich obiektów znajdujących się w granicach zdefiniowanego obrysu płytki.
-
Net - służy do zaznaczania wszystkich obiektów elektrycznych należących do określonej sieci.
Po uruchomieniu polecenia możesz kliknąć obiekt elektryczny lub połączenie, aby zaznaczyć wszystkie obiekty elektryczne w powiązanej sieci. Jeśli znasz nazwę sieci, którą chcesz zaznaczyć, kliknij obszar projektu z dala od obiektów; otworzy się okno dialogowe Net Name. Możesz w nim wpisać nazwę żądanej sieci; sieć ta zostanie zaznaczona po zamknięciu okna dialogowego. Jeśli nie masz pewności co do nazwy sieci, wpisz ?, a następnie kliknij OK , aby otworzyć okno dialogowe Nets Loaded, które zawiera listę wszystkich aktualnie wczytanych sieci projektu.
-
Connected Copper - służy do zaznaczania wszystkich obiektów elektrycznych połączonych z tym samym fragmentem miedzi.
-
Physical Connection - służy do zaznaczania wszystkich fizycznie wytrasowanych ścieżek między padami. Kliknij ścieżkę, pad lub przelotkę; zaznaczone zostaną wszystkie ciągłe ścieżki aż do kolejnego pada, wraz z przelotkami (same pady nie zostaną uwzględnione w zaznaczeniu).
-
Physical Connection Single Layer - służy do zaznaczania wszystkich fizycznie wytrasowanych ścieżek między padami na jednej warstwie. Kliknij ścieżkę lub przelotkę; zaznaczone zostaną wszystkie ciągłe ścieżki na tej samej warstwie aż do kolejnego pada (same pady i przelotki nie zostaną uwzględnione w zaznaczeniu).
-
Component Connections - służy do zaznaczania wszystkich wytrasowanych połączeń wychodzących z padów wybranego komponentu (w tym ścieżek i przelotek), w każdym przypadku aż do następnego napotkanego pada. Same pady nie zostaną uwzględnione w zaznaczeniu.
Polecenie jest również dostępne po kliknięciu prawym przyciskiem myszy umieszczonego komponentu i wybraniu polecenia Component Actions » Select Component Connections z menu kontekstowego.
-
Component Nets - służy do zaznaczania wszystkich sieci (oraz należących do nich obiektów) połączonych z wybranym komponentem w bieżącym dokumencie.
Polecenie jest również dostępne po kliknięciu prawym przyciskiem myszy umieszczonego komponentu i wybraniu polecenia Component Actions » Select Component Nets z menu kontekstowego.
-
Room Connections - służy do zaznaczania wszystkich wytrasowanych połączeń między padami, które znajdują się w całości w granicach wybranego obszaru rozmieszczenia (Room) w bieżącym dokumencie.
Polecenie jest również dostępne po kliknięciu prawym przyciskiem myszy umieszczonego obszaru rozmieszczenia (Room) i wybraniu polecenia Room Actions » Select Room Connections z menu kontekstowego.
-
All on Layer - służy do zaznaczania wszystkich obiektów na bieżącej warstwie lub usuwania ich zaznaczenia.
-
Free Objects - służy do zaznaczania wszystkich wolnych obiektów podstawowych w projekcie. Komponenty, obiekty współrzędnych, wymiary, obiekty dostrajania długości, obiekty OLE i wylewki wielokątne są obiektami grupowymi, dlatego to polecenie na nie nie wpływa.
-
All Locked - służy do zaznaczania wszystkich obiektów projektu, które mają włączoną właściwość Locked .
-
Off Grid Pads - służy do zaznaczania wszystkich padów, które nie znajdują się na bieżącej siatce przyciągania.
Edycja graficzna
Ta metoda edycji pozwala zaznaczyć umieszczony obiekt bezpośrednio w obszarze projektowym i graficznie zmienić jego rozmiar, kształt lub położenie. Zmiana kształtu i/lub rozmiaru (jeśli ma zastosowanie) odbywa się za pomocą uchwytów edycyjnych, które pojawiają się po zaznaczeniu obiektu.

Przykładowe uchwyty edycyjne zaznaczonego obiektu wypełnienia (Fill).
Kliknij w dowolnym miejscu obiektu poza uchwytami edycyjnymi (jeśli występują), aby przeciągnąć obiekt i zmienić jego położenie. W zależności od typu obiektu podczas przeciągania można go obracać i/lub odbijać.
- Naciśnij Spacebar , aby obrócić obiekt przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Obrót jest wykonywany zgodnie z wartością Rotation Step zdefiniowaną na stronie PCB Editor – General okna dialogowego Preferences.
- Naciśnij klawisz L, aby przenieść obiekt na drugą stronę płytki (jeśli ma zastosowanie).
- Naciśnij klawisz X lub Y , aby odbić obiekt względem osi X lub Y, jeśli ma to zastosowanie.
- Naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, w zależności od początkowego kierunku ruchu.
- Przesuwaj obiekt małymi krokami (zgodnie z bieżącym krokiem siatki przyciągania), naciskając klawisze strzałek i przytrzymując klawisz Ctrl . Aby przesuwać go większymi krokami (10 × krok siatki przyciągania), naciskaj klawisze strzałek, przytrzymując klawisze Ctrl+Shift.
Polecenia przemieszczania
Położenie obiektu można zmienić za pomocą poleceń z podmenu Edit » Move w menu głównym lub podmenu przemieszczania w Active Bar.
-
Move - to polecenie służy do przemieszczania dowolnego obiektu w bieżącym dokumencie. Wszystkie sieci powiązane z obiektem pozostają połączone, a linie połączeń podążają za nim podczas przemieszczania (są wyświetlane lub nie, zgodnie z aktualnym trybem wyświetlania połączeń). Żadna poprowadzona ścieżka połączona z obiektem nie zostanie przesunięta.
-
Drag - to polecenie służy do przemieszczania dowolnego obiektu w bieżącym dokumencie. Jeśli do obiektu (np. komponentu, pola lutowniczego lub przelotki) są podłączone ścieżki i/lub łuki, pozostają one połączone podczas jego przemieszczania.
-
Component - to polecenie umożliwia przemieszczanie komponentów w bieżącym dokumencie. Po uruchomieniu polecenia kliknij komponent w projekcie, który chcesz przesunąć, przemieść go w wymagane miejsce, a następnie kliknij. Możesz też kliknąć w obszarze projektowym poza obiektami, aby otworzyć okno dialogowe Choose Component. Użyj tego okna, aby znaleźć komponent, który chcesz przesunąć (przechodząc do niego lub przenosząc go do kursora), a następnie zmień jego położenie w sposób opisany powyżej. Pamiętaj, że ta funkcja działa tylko wtedy, gdy komponent docelowy jest not zablokowany.
Polecenie jest również dostępne po kliknięciu komponentu prawym przyciskiem myszy w obszarze projektowym i wybraniu polecenia Component Actions » Move Component z menu kontekstowego.
-
Move Selection - to polecenie umożliwia ręczną zmianę położenia zaznaczonych obiektów w bieżącym dokumencie. Wszystkie sieci powiązane z zaznaczonym obiektem pozostają połączone, a linie połączeń podążają za nim podczas przemieszczania (są wyświetlane lub nie, zgodnie z aktualnym trybem wyświetlania połączeń). Żadna poprowadzona ścieżka połączona z obiektem nie zostanie przesunięta.
-
Move Selection by X, Y - to polecenie służy do przesunięcia aktualnie zaznaczonych obiektów o dokładnie określoną odległość w kierunku X i/lub Y. Po uruchomieniu polecenia otworzy się okno dialogowe Get X/Y Offsets. W tym oknie określ wartości przyrostów delta X i/lub delta Y, o które ma zostać przesunięte zaznaczenie.

Okno dialogowe Get X/Y OffsetsOpcje i elementy sterujące okna dialogowego Get X/Y Offsets
- X Offset - w tym polu określ odległość, o jaką zaznaczenie ma zostać przesunięte wzdłuż osi poziomej. Możesz podać wartości dodatnie lub ujemne, w zależności od wymaganego kierunku ruchu. Użyj przycisku po prawej stronie pola, aby szybko zmienić znak wprowadzonej wartości na dodatni lub ujemny.
- Y Offset - w tym polu określ odległość, o jaką zaznaczenie ma zostać przesunięte wzdłuż osi pionowej. Możesz podać wartości dodatnie lub ujemne, w zależności od wymaganego kierunku ruchu. Użyj przycisku po prawej stronie pola, aby szybko zmienić znak wprowadzonej wartości na dodatni lub ujemny.
- Toggle X/Y Offsets - kliknij ten przycisk, aby szybko zamienić wartości przesunięć miejscami. Wartość X Offset zostanie użyta jako wartość Y Offset i odwrotnie.
- Reset X/Y Offsets - kliknij ten przycisk, aby szybko wyzerować obie wartości przesunięć.
- Define X/Y Offsets Interactively - kliknij ten przycisk, aby obliczyć przesunięcia interaktywnie. Nastąpi przejście do obszaru roboczego, gdzie pojawią się kolejno monity o wybranie punktu początkowego i końcowego. Kliknij w żądanych miejscach; wartości dX i dY zostaną wprowadzone odpowiednio do pól X Offset i Y Offset.
-
Rotate Selection - to polecenie służy do obracania zaznaczonych obiektów w obszarze projektowym przeciwnie do ruchu wskazówek zegara lub zgodnie z nim o określony kąt. Po uruchomieniu polecenia otworzy się okno dialogowe Rotation Angle (Degrees). Wprowadź wymagany kąt obrotu od 0,001° do 360,00° (rozdzielczość 0,001°). Wprowadź wartość dodatnią, aby obrócić obiekty przeciwnie do ruchu wskazówek zegara, lub ujemną, aby obrócić je zgodnie z ruchem wskazówek zegara. Kliknij OK, aby zamknąć okno dialogowe, a następnie ustaw kursor i kliknij, aby określić punkt odniesienia obrotu. Zaznaczone obiekty zostaną obrócone wokół punktu odniesienia o wprowadzony kąt.

Okno dialogowe Rotation Angle -
Flip Selection - odwraca zaznaczone obiekty w poziomie (względem osi Y) i przenosi je na odpowiadającą im warstwę po przeciwnej stronie płytki. Na przykład obiekty na warstwie Top Layer zostaną przeniesione na warstwę Bottom Layer, obiekty na warstwie Top Overlay zostaną przeniesione na warstwę Bottom Overlay itd.
Polecenia wyrównywania
Obiekty można również przesuwać, zmieniając ich wyrównanie. Aby wyrównać obiekty względem innych obiektów, kliknij zaznaczony obiekt prawym przyciskiem myszy, a następnie wybierz Align. Możesz też użyć podmenu Edit » Align w menu głównym lub podmenu wyrównywania w Active Bar. Podmenu wyrównywania zawiera szereg opcji rozmieszczania zaznaczonych obiektów.
Polecenie Align otwiera okno dialogowe Align Objects, które udostępnia opcje szybkiego wyrównywania aktualnie zaznaczonych obiektów projektu zgodnie z potrzebami. W oknie dialogowym ustaw odpowiednie opcje wyrównania Vertical i/lub Horizontal zaznaczonych obiektów, a następnie kliknij OK , aby zastosować wyrównanie.

Okno dialogowe Align Objects
Opcje i elementy sterujące okna dialogowego wyrównywania obiektów
-
Horizontal - wybierz jedną z poniższych opcji, aby określić wyrównanie zaznaczonych obiektów w poziomie:
- No Change - pozostawia wyrównanie obiektów w poziomie bez zmian.
- Left - wyrównuje obiekty tak, aby zewnętrzne krawędzie ich skrajnie lewych elementów podstawowych miały tę samą współrzędną X. Jako odniesienie używany jest obiekt z elementem podstawowym wysuniętym najdalej w lewo.
- Center - przesuwa obiekty w poziomie tak, aby ich środki były wyrównane. Po kliknięciu OK, pojawi się prośba o kliknięcie obiektu odniesienia.
- Right - wyrównuje obiekty tak, aby zewnętrzne krawędzie ich skrajnie prawych elementów podstawowych miały tę samą współrzędną X. Jako odniesienie używany jest obiekt z elementem podstawowym wysuniętym najdalej w prawo.
- Space equally - rozmieszcza obiekty w równych odstępach w poziomie między obiektami położonymi skrajnie po lewej i prawej stronie (które nie są przesuwane).
-
Vertical - wybierz jedną z poniższych opcji, aby określić wyrównanie zaznaczonych obiektów w pionie:
- No Change - pozostawia wyrównanie zaznaczonych obiektów w pionie bez zmian.
- Top - wyrównuje obiekty tak, aby zewnętrzne krawędzie ich najwyżej położonych elementów podstawowych miały tę samą współrzędną Y. Jako odniesienie używany jest obiekt z najwyżej położonym elementem podstawowym.
- Center - przesuwa obiekty w pionie tak, aby ich środki były wyrównane. Po kliknięciu OK pojawi się prośba o kliknięcie obiektu odniesienia.
- Bottom - wyrównuje obiekty tak, aby zewnętrzne krawędzie ich najniżej położonych elementów podstawowych miały tę samą współrzędną Y. Jako odniesienie używany jest obiekt z najniżej położonym elementem podstawowym.
- Space equally - rozmieszcza obiekty w równych odstępach w pionie między obiektami położonymi najwyżej i najniżej (które nie są przesuwane).
Polecenie Position Component Text służy do otwierania okna dialogowego Component Text Position, w którym można zmienić położenie tekstu oznaczenia i/lub komentarza dla jednego lub kilku zaznaczonych komponentów w bieżącym dokumencie.

Okno dialogowe Component Text Position
Okno dialogowe jest podzielone na dwa główne obszary — tekst oznaczenia i tekst komentarza. W obu obszarach graficzna reprezentacja komponentu pomaga zobaczyć, gdzie pojawi się tekst przy wybranym położeniu. Dla tekstu dostępnych jest dziewięć poniższych wariantów położenia. Wszystkie są klasyfikowane jako „położenia automatyczne”, co oznacza, że tekst pozostaje w wybranym położeniu względem komponentu podczas jego przesuwania i obracania:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Aby pozostawić tekst w bieżącym położeniu bez zmian, pozostaw włączoną opcję No Change.
Polecenie Align Left / Align Right / Align Top / Align Bottom umożliwia wyrównanie zaznaczonych obiektów projektu odpowiednio według ich lewej/prawej/górnej/dolnej krawędzi. Po uruchomieniu polecenia jako odniesienie używana jest lewa/prawa/górna/dolna krawędź obiektu położonego najdalej w lewo/w prawo/u góry/u dołu, a wszystkie pozostałe zaznaczone obiekty zostają przesunięte w lewo/w prawo/w górę/w dół tak, aby ich lewe krawędzie były wyrównane do tego odniesienia.
Polecenie Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) umożliwia wyrównanie zaznaczonych obiektów projektu według ich lewej/prawej/górnej/dolnej krawędzi z zachowaniem odpowiednich odstępów zgodnie z obowiązującymi regułami projektowymi. Po uruchomieniu polecenia jako punkt odniesienia używana jest lewa/prawa/górna/dolna krawędź obiektu położonego najbardziej na lewo/na prawo/u góry/u dołu, a wszystkie pozostałe zaznaczone obiekty zostaną przesunięte w lewo/w prawo/w górę/w dół, tak aby ich lewe krawędzie były wyrównane do tego punktu odniesienia. Obiekt zostanie przesunięty w lewo/w prawo/w górę/w dół możliwie najbliżej obiektu odniesienia, na ile pozwala obowiązująca reguła odstępu:
- W przypadku wyrównywania wyłącznie komponentów przestrzegana jest reguła odstępu między komponentami (Component Clearance).
- W przypadku wyrównywania wyłącznie obiektów niebędących komponentami przestrzegana jest reguła odstępu (Clearance).
- W przypadku wyrównywania komponentów i obiektów niebędących komponentami przestrzegana jest reguła odstępu (Clearance).
Polecenie Align Horizontal Centers / Align Vertical Centers umożliwia umieszczenie zaznaczonych obiektów w jednej kolumnie/jednym wierszu, z wyrównaniem według ich środków w poziomie/pionie. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się prośba o wybranie jednego z zaznaczonych obiektów; kliknij go. Stanie się on obiektem odniesienia. Wszystkie pozostałe zaznaczone obiekty zostaną przesunięte względem niego i wyrównane według ich środków w poziomie/pionie.
Polecenie Distribute Horizontally / Distribute Vertically umożliwia równomierne rozmieszczenie zaznaczonych obiektów w poziomie/pionie. Po uruchomieniu polecenia skrajny lewy i skrajny prawy / skrajny górny i skrajny dolny obiekt w zaznaczeniu pozostaną na swoich pozycjach, a wszystkie pozostałe obiekty zostaną równomiernie rozmieszczone między nimi. Położenie obiektów w pionie/poziomie nie ulegnie zmianie.
Polecenie Increase Horizontal Spacing / Increase Vertical Spacing umożliwia zwiększenie odstępów w poziomie/pionie między zaznaczonymi obiektami. Po uruchomieniu polecenia skrajny lewy/dolny obiekt pozostanie na swojej pozycji, a pozostałe zaznaczone obiekty zostaną przesunięte w prawo/w górę. Przesunięcie zwiększa odległość w poziomie/pionie między punktami odniesienia kolejnych obiektów o wartość określoną w polu Step X / Step Y dla domyślnego Global Board Snap Grid.
Polecenie Decrease Horizontal Spacing / Decrease Vertical Spacing umożliwia zmniejszenie odstępów w poziomie/pionie między zaznaczonymi obiektami. Po uruchomieniu polecenia skrajny lewy/dolny obiekt pozostanie na swojej pozycji, a pozostałe zaznaczone obiekty zostaną przesunięte w lewo/w dół. Przesunięcie zmniejsza odległość w poziomie/pionie między punktami odniesienia kolejnych obiektów o wartość określoną w polu Step X / Step Y dla domyślnego Global Board Snap Grid.
Polecenie Align To Grid służy do przesuwania zaznaczonych komponentów do najbliższego punktu obowiązującej i zmodyfikowanej siatki przyciągania. Po uruchomieniu polecenia punkty odniesienia każdego z zaznaczonych komponentów zostaną przesunięte do najbliższego punktu obowiązującej siatki przyciągania.
Polecenie Move All Components Origin To Grid służy do przesuwania punktów odniesienia wszystkich komponentów na bieżącą siatkę przyciągania. Po uruchomieniu polecenia wszystkie komponenty w obszarze projektowym, których pady znajdują się na siatce, zostaną przesunięte tak, aby ich punkty odniesienia były wyrównane do bieżącej siatki przyciągania. Domyślnie raport — Move Component(s) Origin To Grid - <PCBDocumentName>.html — zostanie automatycznie wygenerowany i otwarty jako aktywny dokument, ze szczegółowymi informacjami o tym, które komponenty zostały przesunięte, a które nie.
Za pomocą panelu PCB List
Panel PCB List umożliwia wyświetlanie obiektów projektu w formie tabeli, co ułatwia szybkie sprawdzanie i modyfikowanie ich atrybutów. Używany wraz z panelem PCB Filter pozwala wyświetlać wyłącznie obiekty objęte aktywnym filtrem — umożliwiając dokładniejsze i sprawniejsze wybieranie oraz edytowanie wielu obiektów projektu.
Wybieranie aktywnej warstwy
Aktywna warstwa to warstwa, na której będą umieszczane obiekty. Można ją wybrać spośród aktualnie widocznych warstw, klikając jej kartę u dołu obszaru projektowego lub korzystając z listy rozwijanej Active Layer w sekcji Layers na karcie Layers & Colors panelu View Configuration.
Można również użyć następujących skrótów, aby szybko wybrać aktywną warstwę:
- * (na klawiaturze numerycznej) – przełączenie na następną włączoną warstwę sygnałową.
-
Shift+* (na klawiaturze numerycznej) – przełączenie na poprzednią włączoną warstwę sygnałową.
- + (na klawiaturze numerycznej) – przełączenie na następną włączoną warstwę.
- - (na klawiaturze numerycznej) – przełączenie na poprzednią włączoną warstwę.
Wycinanie/kopiowanie i wklejanie
W edytorze PCB można wycinać/kopiować i wklejać obiekty w obrębie jednego dokumentu PCB lub między dokumentami, np. kopiować komponenty z jednej płytki PCB do innego dokumentu PCB. Obiekty można wycinać/kopiować do schowka systemu Windows i wklejać do innych dokumentów.
Podczas korzystania z 2D Layout Mode zaznacz obiekty, które chcesz wyciąć/skopiować, kliknij Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) w menu głównym lub wybierz polecenie Cut/Copy z menu kontekstowego. Kursor zmieni się w krzyżyk i pojawi się prośba o wybranie punktu odniesienia. Jest to współrzędna względem zaznaczonych obiektów, używana do precyzyjnego pozycjonowania zaznaczenia podczas wklejania.
Aby skopiować aktualnie zaznaczone obiekty projektu do schowka w formacie tekstowym, można użyć polecenia Edit » Copy As Text z menu głównego. Informacje te można następnie wkleić do dowolnego pola tekstowego lub zewnętrznego dokumentu tekstowego. Dane kopiowane do schowka obejmują:
- Typ obiektu.
- Oznaczenie i komentarz (w przypadku komponentu).
- Położenie obiektu w obszarze projektowania.
- Warstwę, na której znajduje się obiekt (lub warstwę początkową i końcową w przypadku przelotki).
Przykład komponentu skopiowanego do schowka jako tekst:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Przykład ścieżki i przelotki skopiowanych do schowka jako tekst:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Aby wkleić ostatnią zawartość wyciętą lub skopiowaną do schowka do aktywnego dokumentu, wybierz polecenie Edit » Paste z menu głównego lub kliknij prawym przyciskiem myszy w obszarze projektowania i wybierz polecenie Paste z menu kontekstowego (skrót: Ctrl+V). Ostatnia zawartość schowka zostanie dołączona do kursora. Położenie kursora względem zawartości jest określane przez punkt odniesienia wskazany podczas używania Cut lub Copy do dodania zaznaczenia do schowka.
Aby wkleić tekst skopiowany z obsługiwanej aplikacji OLE do dowolnego otwartego dokumentu PCB, można użyć polecenia Edit » Paste Text z menu głównego. Tekst jest konwertowany i wklejany jako obiekty tekstowe PCB, a nie jako pojedynczy obiekt OLE. Obsługiwane typy plików obejmują uniwersalne formaty, takie jak arkusze kalkulacyjne w formatach CSV i XLS oraz dokumenty tekstowe w formatach DOC i RTF.
Aby określić, co dzieje się z wybranymi atrybutami obiektów podczas ich ponownego wklejania do obszaru projektowania, można użyć polecenia Edit » Paste Special z menu głównego. Po uruchomieniu polecenia otworzy się okno dialogowe Paste Special.

Okno dialogowe Paste Special
Opcje i elementy sterujące okna dialogowego Wklej specjalnie
Atrybuty wklejania
- Paste on current layer - włącz tę opcję, aby wkleić obiekty na bieżącą warstwę.
- Keep net name - włącz tę opcję, aby zachować oryginalne nazwy sieci obiektów.
- Duplicate designator - włącz tę opcję, aby wkleić komponent z tym samym oznaczeniem, bez automatycznej inkrementacji.
- Add to component class - włącz tę opcję, aby dodać wklejany komponent do tej samej klasy komponentów co komponent źródłowy.
Przyciski
- Paste - kliknij, aby wkleić obiekt ze wszystkimi określonymi atrybutami.
- Paste Array - kliknij, aby otworzyć okno dialogowe Konfiguracja wklejania szyku, w którym można ustawić opcje wklejania szyku.
W zależności od wklejanej zawartości można kontrolować następujące atrybuty:
-
Obiekty można wkleić na bieżącą warstwę zamiast domyślnie wklejać je na tę samą warstwę, z której skopiowano obiekty źródłowe.
- Możliwość zachowania przypisanych nazw sieci.
- Możliwość zduplikowania oznaczenia (w przypadku wklejanego komponentu).
- Możliwość dodania wklejanego komponentu do tej samej klasy komponentów co oryginalny komponent źródłowy.
Ustaw opcje zgodnie z potrzebami, a następnie kliknij przycisk Paste , aby rozpocząć wklejanie.
Kliknięcie przycisku Paste Array w oknie dialogowym Paste Special otworzy okno dialogowe Setup Paste Array, które umożliwia wklejenie wielu kopii obiektów ze schowka do bieżącego dokumentu.

Okno dialogowe Setup Paste Array
Opcje i elementy sterujące okna dialogowego Konfiguracja wklejania szyku
Parametry rozmieszczania
- Item Count - liczba powtórzeń wstawiania. Na przykład wpisanie 4 spowoduje wstawienie 4 kopii bieżącej zawartości schowka.
-
Text Increment - wprowadź wartość automatycznej inkrementacji wyświetlanego tekstu (np. oznaczenia komponentu lub pola lutowniczego). Obsługiwane są zarówno przyrosty literowe, jak i liczbowe inne niż 1. Na przykład, ustawiając oznaczenie pola lutowniczego przed skopiowaniem go do schowka oraz wartość pola Text Increment, można wstawić następujące sekwencje oznaczeń pól lutowniczych:
- Liczbowe (1, 3, 5)
- Literowe (A, B, C)
- Połączenie liter i liczb (A1, A2 lub 1A, 1B lub A1, B1 lub 1A, 2A itd.)
Typ szyku
- Circular- włącz tę opcję, aby wkleić szyk kołowy z użyciem bieżących ustawień Circular Array.
- Linear - włącz tę opcję, aby wkleić szyk w linii prostej z użyciem bieżących ustawień Linear Array.
Szyk kołowy
- Rotate Item to Match - jeśli opcja jest włączona, elementy szyku będą obracane o kąt równy ich odstępowi kątowemu.
- Spacing (degrees) - odstęp kątowy między dwoma sąsiednimi wklejanymi elementami.
Szyk liniowy
- X-Spacing - wprowadź żądany odstęp w osi X między dwoma sąsiednimi elementami.
- Y- Spacing - wprowadź żądany odstęp w osi Y między dwoma sąsiednimi elementami.
Wprowadź odpowiednie wartości w tym oknie dialogowym, a następnie kliknij OK , aby wstawić szyk.
- Jeśli wstawiasz szyk liniowy, pojawi się monit o wybranie jego punktu początkowego. Ustaw kursor, a następnie kliknij lub naciśnij Enter, aby wstawić szyk.
- Podczas umieszczania szyku kołowego pojawi się monit o wskazanie jego środka, a następnie punktu początkowego. W obu przypadkach ustaw kursor w odpowiednim miejscu, a następnie kliknij lub naciśnij Enter , aby umieścić szyk. Obiekty zostaną rozmieszczone wokół wskazanego środka w kierunku przeciwnym do ruchu wskazówek zegara.
Priorytety podczas wklejania obiektów
Jeśli obiekt wklejany na warstwę miedzi nakłada się na zbiór obiektów różnych typów, zostanie mu przypisana sieć obiektu o najwyższym priorytecie. Priorytety są następujące (1 oznacza najwyższy priorytet):
- Pad
- Wypełnienie
- Region
- Ścieżka
- Łuk
- Przelotka
- Wylewka poligonowa

Wklejanemu obiektowi przypisywana jest sieć obiektu o najwyższym priorytecie. Tutaj pokazano obiekt (ścieżkę) wklejany na zbiór obiektów różnych typów, którym przypisano różne sieci. Ponieważ pad ma w tym zbiorze najwyższy priorytet, jego sieć (Pad_Net) zostanie przypisana wklejanemu obiektowi. Najedź kursorem na obraz, aby zobaczyć wynik.
Jeśli obiekt wklejany na warstwę miedzi nakłada się na zbiór obiektów tego samego typu, zostanie mu przypisana sieć obiektu znajdującego się pod kursorem w momencie kliknięcia w celu wklejenia.

Wklejanemu obiektowi przypisywana jest sieć obiektu znajdującego się pod kursorem. Tutaj pokazano obiekt (ścieżkę) wklejany na zbiór obiektów tego samego typu (padów). Ponieważ w momencie kliknięcia w celu wklejenia pod kursorem znajduje się pad 2, jego sieć (Pad2_Net) zostanie przypisana wklejanemu obiektowi. Najedź kursorem na obraz, aby zobaczyć wynik.
Jeśli zbiór fizycznie połączonych obiektów jest wklejany na warstwę miedzi, a należące do niego obiekty różnych typów nakładają się na istniejące obiekty o różnych sieciach, wszystkim wklejanym obiektom zostanie przypisana sieć obiektu o najwyższym priorytecie w tym zbiorze. W tym przypadku obowiązują powyższe priorytety.

Sieć przypisana obiektowi o najwyższym priorytecie jest przypisywana całemu zbiorowi fizycznie połączonych obiektów. Tutaj pokazano zbiór połączonych obiektów (od lewej: wypełnienie, region, ścieżka, łuk, przelotka, wylewka poligonowa) wklejany na obiekty (przelotki), którym przypisano różne sieci. Ponieważ wypełnienie ma najwyższy priorytet w tym wklejanym zbiorze, przypisana mu sieć (Via1_Net) zostanie przypisana każdemu obiektowi w tym zbiorze. Najedź kursorem na obraz, aby zobaczyć wynik.
Blokowanie obiektów projektu
Obiekty projektu można zablokować przed przesuwaniem lub edycją w dokumencie PCB, włączając ich atrybuty Locked . Na przykład, jeśli położenie lub rozmiar określonych obiektów ma kluczowe znaczenie, zablokuj je. Blokadę można włączyć w panelu Properties , klikając ikonę kłódki dla wybranych obiektów, jak pokazano w poniższych przykładach.
Przykłady ikony Lock w panelu Properties dla zaznaczonego komponentu i pada.
Aby przełączyć stan właściwości Locked umieszczonego obiektu, który ma właściwość Locked , możesz również kliknąć ten obiekt prawym przyciskiem myszy w obszarze projektowym i wybrać polecenie <ObjectType> Locked z menu kontekstowego. Jeśli obiekt jest już zablokowany, po lewej stronie pozycji polecenia w menu będzie widoczny znacznik wyboru.
Jeśli spróbujesz przesunąć lub obrócić obiekt projektu z włączoną właściwością Locked, pojawi się okno dialogowe z prośbą o potwierdzenie edycji.
Blokowanie obiektów podstawowych komponentu
Jeśli obiekty podstawowe komponentu PCB są zablokowane (opcja Primitives w trybie Komponent panelu Właściwości ma stan , wszystkich lub większości ich właściwości nie można modyfikować metodami edycji graficznej (np. przeciągania i upuszczania) ani niegraficznej (np. za pomocą panelu Properties lub List). Pomaga to zapobiegać przypadkowym zmianom obiektów podstawowych komponentu, które mogłyby prowadzić do powstania nieprawidłowych danych wyjściowych do montażu i produkcji.
Jako przykład na poniższym obrazie pokazano tryb Pad panelu Właściwości dla pada będącego częścią komponentu PCB, którego obiekty podstawowe są zablokowane. Zwróć uwagę, że wszystkie właściwości pada (z wyjątkiem Net i Testpoint) są wyszarzone i niedostępne do edycji. Zauważ również, że ikona
jest wyświetlana po prawej stronie właściwości Component pada. pole, które wskazuje, że obiekty podstawowe komponentu nadrzędnego są zablokowane, a właściwości pola lutowniczego nie mogą być modyfikowane.

Tryb Pad panelu Properties (po lewej) dla pola lutowniczego komponentu PCB, którego obiekty podstawowe są zablokowane (po prawej).
Edycja zagnieżdżona
Edytor PCB zawiera zaawansowaną funkcję o nazwie re-entrant editing. Umożliwia ona wykonanie drugiej operacji za pomocą skrótów klawiaturowych bez kończenia bieżącej operacji. Edycja zagnieżdżona pozwala pracować bardziej elastycznie i intuicyjnie. Załóżmy na przykład, że rozpoczynasz prowadzenie ścieżki i zauważasz, że trzeba usunąć inny jej segment. Nie musisz wychodzić z trybu Interaktywne trasowanie. Naciśnij klawisze skrótu E, D, usuń odpowiedni segment ścieżki, a następnie naciśnij klawisz Esc , aby powrócić do interaktywnego trasowania projektu.
Ustawianie wyglądu kursora PCB
Domyślnie kursor PCB ma postać małego zielonego krzyżyka o kącie 90 stopni. Można go skonfigurować za pomocą ustawień Cursor Type i Cursor Color na stronie Edytor PCB – Ogólne okna dialogowego Preferences . Na przykład duży krzyżyk o kącie 90 stopni, sięgający do krawędzi okna projektu (opcja Large 90), może być przydatny podczas umieszczania i wyrównywania obiektów projektu. Z kolei krzyżyk ustawiony pod kątem 45 stopni (opcja Small 45) może być przydatny, jeśli krzyżyki o kącie 90 stopni są słabo widoczne na tle linii siatki.
Obsługa czcionek TrueType
Edytor PCB umożliwia używanie czcionek kreskowych lub TrueType w obiektach tekstowych projektu (ciągach tekstowych i ramkach tekstowych, wymiarach, tabelach otworów oraz tabelach stosu warstw). Czcionkę wybiera się w odpowiednim panelu Properties . Dostępne są trzy czcionki kreskowe: Default, Sans Serif i Serif. Styl Default to prosta czcionka wektorowa obsługująca kreślenie pisakiem i fotoplotowanie wektorowe. Czcionki Sans Serif i Serif są bardziej złożone i spowalniają generowanie wektorowych danych wyjściowych, takich jak Gerber. Czcionki kreskowe są wbudowane w oprogramowanie i nie można ich zmieniać. Wszystkie trzy czcionki zawierają pełny rozszerzony zestaw znaków ASCII firmy IBM, obsługujący język angielski i inne języki europejskie. W przypadku czcionek TrueType dostępne są czcionki TrueType i OpenType (rozszerzenie TrueType) znajdujące się w folderze \Windows\Fonts. Funkcja ta zapewnia również pełną obsługę standardu Unicode.
Geometrie obiektów tekstowych korzystających z czcionek TrueType są automatycznie zapisywane w dokumentach PCB. Gdy obiekty w dokumencie PCB korzystają z czcionki TrueType, po otwarciu dokumentu na innym komputerze będą wyświetlane z użyciem tej samej geometrii czcionki, nawet jeśli ta czcionka TrueType nie jest na nim zainstalowana.
Po zaznaczeniu obiektu korzystającego z brakującej czcionki u góry panelu Properties pojawia się ostrzeżenie. Podczas zmiany właściwości obiektu wpływających na jego tekst (np. wysokości tekstu lub samej treści) otwiera się okno dialogowe Missing fonts, w którym można wybrać czcionkę zastępczą (Replacement). Włącz opcję Apply to all text elements, aby zastosować czcionkę zastępczą do wszystkich obiektów w dokumencie PCB korzystających z brakującej czcionki.
To okno dialogowe pojawia się również podczas zmiany właściwości tekstu w panelu PCB List.
Przy próbie edycji wielu obiektów korzystających z różnych brakujących czcionek okno dialogowe umożliwia wybranie zamiennika dla każdej z nich.
Obsługa renderowania rzeczywistych łuków
Obsługiwane są rzeczywiste łuki generowane w obszarze projektowym zarówno edytora PCB, jak i edytora bibliotek PCB, zamiast ich przybliżeń. Obsługa ta obejmuje tryby układu 2D/3D (oraz tryb planowania płytki w edytorze PCB). Renderowanie rzeczywistych łuków można zaobserwować w następujących obszarach:
-
Wypełnienia wielokątne (pełne, kreskowane, bez wypełnienia)
-
Wycięcia wypełnień wielokątnych
-
Kontur zaznaczenia wypełnień wielokątnych i regionów
-
Regiony
-
Poszerzenia maski lutowniczej i maski pasty lutowniczej
-
Podświetlanie sieci
-
Granice odstępów
-
Nakładka wskazująca naruszenie (oddzielne wypełnienie wielokątne na regionie lub wypełnieniu wielokątnym)
Poniżej przedstawiono przykłady renderowania rzeczywistych łuków wypełnień wielokątnych otaczających inne obiekty PCB.
Informacje o sieci
W przypadku obiektów miedzianych na PCB (ścieżek, przelotek, wielokątów itp.) po zaznaczeniu obiektu w sekcji Net Information panelu Properties prezentowane są następujące informacje:
- Nadrzędne Net, Diff Pair i/lub xSignal oraz powiązana klasa dla każdego z nich. Należy pamiętać, że pozycje Diff Pair i xSignal są wyświetlane tylko wtedy, gdy obiekt jest częścią odpowiednio pary różnicowej lub xSignal.
-
Delay – opóźnienie zaznaczonych obiektów oraz opóźnienie poprowadzonych segmentów całej sieci. Uwzględnia wartości Propagation Delay pól lutowniczych i przelotek, jeśli zostały dla nich zdefiniowane.
-
Length – suma długości zaznaczonych obiektów oraz całkowita wartość Signal Length. Wartość Signal Length jest wynikiem dokładnego obliczenia całkowitej odległości między węzłami. Umieszczone obiekty są analizowane w celu uwzględnienia obiektów nałożonych na siebie lub nakładających się oraz krętych przebiegów ścieżek w obrębie padów; uwzględniane są również długości przelotek. Wartość Pin Package Length jest także uwzględniana, jeśli została zdefiniowana dla padów. Jeśli sieć nie jest w pełni poprowadzona, uwzględniana jest również długość linii połączenia według metryki Manhattan (X + Y). Więcej informacji o długości sygnału i jej zastosowaniach można znaleźć w opisie panelu PCB - Nets.
-
Max Current – maksymalny prąd, jaki mogą przewodzić zaznaczone obiekty typu Ścieżka, Łuk lub Przelotka, określany na podstawie wzoru z normy IPC-2221A (sekcja 6.2):
I = k * ΔT0.44 * A0.725
gdzie:
I = prąd [A]
A = pole przekroju poprzecznego [mil²] (szerokość ścieżki * grubość miedzi w stosie warstw lub Aścianki, jak pokazano poniżej)
ΔT = dopuszczalny wzrost temperatury względem temperatury otoczenia [°C]
k = stała o wartości:k = 0,048 dla warstw zewnętrznych
k = 0,024 dla warstw wewnętrznych -
Resistance – suma rezystancji zaznaczonych obiektów typu Ścieżka, Łuk i Przelotka, określana na podstawie wyprowadzonego wzoru:
R = (ρ * L / A)
gdzie:
R = rezystancja [Ω]
ρ = rezystywność miedzi [Ω*mm2/m]
L = długość ścieżki [m] (lub długość przelotki, jak opisano poniżej)
A = pole przekroju poprzecznego = T * W [mm2] (lub Aścianki, jak pokazano poniżej)
T = grubość ścieżki (ze stosu warstw) [mm]
W = szerokość ścieżki [mm]Assumptions:
- Temperatura otoczenia = 22 °C
- Dopuszczalny wzrost temperatury = 20 °C
- Grubość miedzianej ścianki otworu przelotowego = 0,018 mm
- Rezystywność miedzi = 0,017 Ω*mm2/m

Sekcja Net Information panelu Properties. Pokazano tu przykład dla zaznaczonej ścieżki.
Kliknij łącze w sekcji Net Information, aby otworzyć powiązaną sieć, parę różnicową lub xSignal w panelu PCB.
Przypisywanie sieci do obiektów
Edytor PCB udostępnia kilka sposobów przypisywania sieci do obiektów podstawowych:
- Po zaznaczeniu jednego lub większej liczby obiektów użyj listy rozwijanej pola Nets w panelu Properties. Na liście rozwijanej znajdują się wszystkie sieci aktywnego projektu płytki. Wybierz No Net, aby określić, że ścieżka nie jest połączona z żadną siecią. Możesz też kliknąć ikonę Assign Net , aby wskazać obiekt w obszarze projektowym — sieć tego obiektu zostanie przypisana do zaznaczonych obiektów.
- Kliknij prawym przyciskiem myszy jeden lub więcej zaznaczonych obiektów, a następnie wybierz Net Actions » Assign Net. Po uruchomieniu polecenia pojawi się kursor krzyżowy. Umieść go nad siecią, do której chcesz przypisać obiekty, a następnie kliknij, aby wybrać tę sieć.
- Aby ponownie zsynchronizować nazwy sieci obiektów trasowania z nazwami sieci pól lutowniczych, z którymi są połączone, wybierz polecenie Design » Netlist » Update Free Primitives From Component Pads z menu głównego. Po uruchomieniu polecenia otworzy się okno dialogowe z pytaniem, czy chcesz zaktualizować sieci obiektów niezależnych zgodnie z sieciami pól lutowniczych komponentów. Po kliknięciu Yes oprogramowanie, zaczynając od każdego pola lutowniczego, zaznacza połączone z nim obiekty miedziane i ustawia nazwę sieci każdego obiektu tak, aby odpowiadała nazwie sieci pola lutowniczego. Ta operacja nie wpływa na wewnętrzną listę sieci PCB.
Aby sprawdzić i potwierdzić, że fizycznie połączone obiekty mają przypisaną właściwą sieć i należą do danej sieci fizycznej (w tym przypadku physical net oznacza connected copper), możesz użyć okna dialogowego Configure Physical Nets, dostępnego po wybraniu polecenia Design » Netlist » Configure Physical Nets z menu głównego. Oprogramowanie analizuje projekt, sprawdzając, czy wszystkie pola lutownicze oraz obiekty, które fizycznie je łączą (ścieżki, łuki, wypełnienia itp.), mają przypisaną tę samą nazwę sieci. Gdy wszystkie obiekty sieci są przypisane prawidłowo, sieć jest wyświetlana na zielono. Jeśli zostaną wykryte stykające się obiekty, które mają przypisane różne sieci, zostaną oznaczone na czerwono. Typowym przykładem takiej sytuacji jest footprint komponentu zawierający dodatkowe obiekty miedziane. Gdy taki footprint zostanie wczytany podczas synchronizacji, do każdego pola lutowniczego zostanie przypisana nazwa sieci, ale nie zostanie ona przypisana do dodatkowych obiektów miedzianych. Okno dialogowe jest interaktywne — kliknij sieć lub obiekt, aby zlokalizować go w projekcie. Kliknij prawym przyciskiem myszy lub kliknij przycisk Menu , aby uzyskać dostęp do dostępnych poleceń. Sekcja Action okna dialogowego zawiera elementy sterujące umożliwiające określenie działań niezbędnych do rozwiązania problemów z połączonymi obiektami miedzianymi. Domyślnie działania są ustawiane automatycznie, ale można je dostosować do potrzeb. Po ustawieniu działań kliknij przycisk Execute , aby zaktualizować przypisania sieci.

Okno dialogowe Configure Physical Nets (z włączoną opcją Only Show Errors w tle i wyłączoną opcją Only Show Errors na pierwszym planie).
Opcje i elementy sterujące okna dialogowego Configure Physical Nets
-
Electrically Connected Copper — ta sekcja zawiera listę odrębnych grup obiektów miedzianych połączonych elektrycznie, wykrytych w połączeniach projektu. Dla każdej grupy przedstawiane są następujące informacje:
-
Primitive — na najwyższym poziomie ten wpis wskazuje liczbę obiektów w grupie połączonych obiektów miedzianych. Obiekty mogą być wyświetlane na płaskiej liście lub pogrupowane według typu. Grupowanie według typu można włączyć za pomocą opcji Show Primitive Groups dostępnej pod przyciskiem Menu . Po jej włączeniu obiekty zostaną podzielone na następujące grupy:
- Connected Component Primitives — zawiera wszystkie pola lutownicze komponentów jako elementy podrzędne. Można je dodatkowo pogrupować według komponentu nadrzędnego, włączając opcję Show Components dostępną pod przyciskiem Menu .
- Connected Free Primitives — zawiera wszystkie obiekty miedziane nienależące do komponentów jako elementy podrzędne, dodatkowo pogrupowane według typu (wypełnienia, poligony, ścieżki, przelotki).
-
Primitive — na najwyższym poziomie ten wpis wskazuje liczbę obiektów w grupie połączonych obiektów miedzianych. Obiekty mogą być wyświetlane na płaskiej liście lub pogrupowane według typu. Grupowanie według typu można włączyć za pomocą opcji Show Primitive Groups dostępnej pod przyciskiem Menu . Po jej włączeniu obiekty zostaną podzielone na następujące grupy:
- Original Net Names — to pole wskazuje nazwę sieci aktualnie przypisanej do obiektu, czyli sieci, z którą obiekt jest obecnie połączony. Wpis będzie odpowiadał jednej z sieci zdefiniowanych dla płytki. Jeśli jednak obiekt nie jest połączony z żadną siecią, będzie miał wpis <Unassigned>.
-
Status — to pole przedstawia stan całej grupy na najwyższym poziomie, który może przyjmować jedną z czterech wartości:
- Blank - przypisanie sieci dla grupy połączonych obiektów miedzianych jest w pełni poprawne i nie wymaga aktualizacji. Wpis najwyższego poziomu dla tej grupy jest oznaczony kolorem zielonym.
- 1. Update Required - Unassigned Nets - w tym stanie żaden z obiektów podstawowych w grupie nie został przypisany do sieci. Wpis najwyższego poziomu dla tej grupy jest oznaczony kolorem żółtym.
- 2. Update Required - Some Unassigned Nets - w tym stanie niektóre obiekty podstawowe zostały przypisane do tej samej sieci, ale pozostałe nie zostały przypisane do żadnej sieci. Wpis najwyższego poziomu dla tej grupy jest oznaczony kolorem pomarańczowym.
- 3. Ambiguous - Multiple Net Names - w tym stanie w grupie znajdują się obiekty podstawowe przypisane do różnych sieci. Mogą w niej również występować obiekty, które nie zostały jeszcze przypisane. Wpis najwyższego poziomu dla tej grupy jest oznaczony kolorem czerwonym.
-
Action - ten obszar zawiera elementy sterujące umożliwiające określenie działań wymaganych do rozwiązania problemów z połączonymi obiektami miedzianymi oraz pokazuje wynik zastosowania skonfigurowanych zmian. Dla każdej grupy prezentowane są następujące informacje:
-
Proposed Action - to pole służy do określenia, jakie działanie ma zostać wykonane, o ile jest ono wymagane. Na najwyższym poziomie grupy wpis ten można ustawić na Update Net To lub Don't Update Net To. Podczas aktualizacji wybierz nową sieć docelową w polu New Net Name. Na podstawie tych dwóch ustawień oprogramowanie określa działania do wykonania na poziomie podrzędnych obiektów podstawowych, proponując jedno z poniższych:
- No Action Required - obiekt podstawowy jest już przypisany do sieci docelowej lub z nią połączony.
- Update - uwzględnij obiekt podstawowy w aktualizacji, aby został przypisany do nowej sieci docelowej lub z nią połączony.
- Don't Update - nie uwzględniaj obiektu podstawowego w aktualizacji. Pozostanie on połączony z obecną siecią.
- New Net Name - użyj tego pola, aby ustawić nową sieć docelową, z którą mają zostać połączone obiekty podstawowe. Lista rozwijana tego pola zawiera wszystkie sieci wykryte wśród obiektów podstawowych w grupie połączonych obiektów miedzianych. Jeśli chcesz użyć innej sieci, kliknij pole prawym przyciskiem myszy i wybierz polecenie Change Copper Net To Board Net z menu kontekstowego. Otworzy się okno dialogowe Choose Net, zawierające listę wszystkich sieci aktualnie zdefiniowanych dla płytki. Wybierz wymaganą sieć, a następnie kliknij OK. Wybrana sieć zostanie wprowadzona do pola.
- Done - to pole wskazuje powodzenie lub niepowodzenie aktualizacji po naciśnięciu przycisku Execute i zastosowaniu zmian.
-
Proposed Action - to pole służy do określenia, jakie działanie ma zostać wykonane, o ile jest ono wymagane. Na najwyższym poziomie grupy wpis ten można ustawić na Update Net To lub Don't Update Net To. Podczas aktualizacji wybierz nową sieć docelową w polu New Net Name. Na podstawie tych dwóch ustawień oprogramowanie określa działania do wykonania na poziomie podrzędnych obiektów podstawowych, proponując jedno z poniższych:
- Execute - gdy ustawione działania dotyczące listy połączeń spełniają Twoje oczekiwania, kliknij ten przycisk, aby zaktualizować przypisania sieci.
-
Menu - kliknij, aby otworzyć poniższe menu poleceń dotyczących całej listy głównej lub aktualnie zaznaczonych obiektów podstawowych. Polecenia te są identyczne z dostępnymi w menu wyświetlanym po kliknięciu prawym przyciskiem myszy w obszarze listy głównej.
- Update/Don't Update/No Action - służy do szybkiego przełączania proponowanego działania dla zaznaczonych obiektów podstawowych. Na wyższym, nadrzędnym poziomie hierarchii obiektów podstawowych przełącza proponowane działanie dla wszystkich elementów podrzędnych na niższych poziomach.
- Select All - służy do szybkiego zaznaczania wszystkich grup połączonych obiektów miedzianych (wpisów najwyższego poziomu na liście).
- Select All With Same Status - gdy zaznaczony jest wpis najwyższego poziomu grupy połączonych obiektów miedzianych, użyj tego polecenia, aby szybko zaznaczyć wszystkie pozostałe grupy najwyższego poziomu o tym samym statusie.
- Clear All Selected - służy do usuwania zaznaczenia wszystkich wpisów na liście.
- Expand All In Connected Copper - służy do szybkiego rozwijania wszystkich grup podrzędnych w aktualnie aktywnej grupie połączonych obiektów miedzianych.
- Expand All - służy do szybkiego rozwijania wszystkich grup w obrębie wszystkich grup połączonych obiektów miedzianych na liście.
- Expand Children - służy do szybkiego rozwijania wszystkich grup podrzędnych na wszystkich poziomach poniżej aktualnie zaznaczonej grupy.
- Collapse All In Connected Copper - służy do szybkiego zwijania wszystkich grup podrzędnych w aktualnie aktywnej grupie połączonych obiektów miedzianych.
- Collapse All - służy do szybkiego zwijania wszystkich grup w obrębie wszystkich grup połączonych obiektów miedzianych na liście.
- Collapse Children - służy do szybkiego zwijania wszystkich grup podrzędnych na wszystkich poziomach poniżej aktualnie zaznaczonej grupy.
- Only Show Errors - włącz, aby wyświetlać w oknie dialogowym tylko błędy. Na liście będą widoczne wyłącznie grupy połączonych obiektów miedzianych, których Status ma poziom 1, 2 lub 3. Wyłącz, aby wyświetlać również prawidłowo przypisane połączone obiekty miedziane.
- Show Components - włącz, aby grupować obiekty podstawowe pól lutowniczych komponentów według komponentów, do których należą.
- Show Primitive Groups - włącz, aby grupować obiekty podstawowe według ich typu.
- Animate Action Execution - włącz, aby okno dialogowe przewijało listę w miarę wykonywania operacji, pokazując animowany postęp zmian przypisań sieci w czasie rzeczywistym. Wyłączenie tej opcji oznacza, że zmiany będą wykonywane bez takiej animacji.
-
Warn On Netlist Change - włącz, aby otrzymywać ostrzeżenie, gdy zmiany wpłyną na listę połączeń płytki. Otworzy się okno dialogowe Netlist Change, informujące o liczbie obiektów podstawowych, których przypisania sieci zostaną zmienione, oraz o tym, że wpłynie to na listę połączeń. Możesz kliknąć Continue lub Filter Affected, aby dokładniej przeanalizować proponowane zmiany.

Okno dialogowe Netlist Change - Show Component Pads - włącz, aby wyświetlać na liście połączone obiekty podstawowe należące do komponentów.
- Show Non Component Pads - włącz, aby wyświetlać na liście połączone obiekty podstawowe niezależne od komponentów.
- Show Changes That Affect Netlist - włącz, aby wyświetlać wyłącznie listę proponowanych działań (zmian), które wpłyną na listę połączeń płytki.
- Change Copper Net To - co najmniej jedna pozycja menu tego typu pojawia się, gdy do obiektów podstawowych w aktywnej grupie połączonych obiektów miedzianych przypisanych jest niewiele sieci. Użyj takiej pozycji, aby szybko wybrać sieć docelową dla pola New Net Name.
- Change Copper Net To Net - ta pozycja menu pojawia się, gdy do obiektów podstawowych w grupie połączonych obiektów miedzianych przypisanych jest zbyt wiele sieci, aby wyświetlić je jako osobne pozycje menu. To polecenie otwiera okno dialogowe Choose Net, zawierające listę wszystkich sieci aktualnie przypisanych do obiektów podstawowych w grupie. Wybierz wymaganą sieć, a następnie kliknij OK; wybrana sieć zostanie wprowadzona do pola New Net Name dla aktywnej grupy połączonych obiektów miedzianych.
- Change Copper Net To Board Net - użyj tego polecenia, jeśli potrzebujesz innej sieci niż te, które są aktualnie przypisane do obiektów podstawowych w aktywnej grupie połączonych obiektów miedzianych. Otworzy się okno dialogowe Choose Net, zawierające listę wszystkich sieci aktualnie zdefiniowanych dla płytki. Wybierz wymaganą sieć, a następnie kliknij OK; wybrana sieć zostanie wprowadzona do pola New Net Name.
- Show All Primitives - kliknij ten przycisk, aby szybko wyświetlić wszystkie obiekty podstawowe. Przycisk staje się dostępny, gdy opcje Show Component Pads i/lub Show Non Component Pads są wyłączone w menu.
Możesz również usunąć wszystkie sieci z bieżącego dokumentu projektu, co w praktyce oznacza wyczyszczenie wewnętrznej listy połączeń PCB. Może to być przydatne, jeśli informacje o sieciach w źródłowych dokumentach schematu zostały zmienione i chcesz w pełni ponownie zsynchronizować płytkę PCB z listą połączeń schematu źródłowego. Aby to zrobić, wybierz Design » Netlist » Clear All Nets polecenie z menu głównego. Po uruchomieniu polecenia otworzy się okno dialogowe z ostrzeżeniem, że ta operacja usunie wszystkie informacje o sieciach z PCB. Po kliknięciu Yes wszystkie informacje o sieciach zostaną usunięte. Wszystkie poprowadzone ścieżki pozostaną na płytce, ale będą miały przypisanie No Net. Wszystkie niepoprowadzone połączenia logiczne zostaną usunięte.
Aby utworzyć plik listy połączeń na podstawie połączeń utworzonych przez poprowadzone ścieżki w bieżącym projekcie, wybierz polecenie Design » Netlist » Create Netlist From Connected Copper z menu głównego. Po kliknięciu Yes w wyświetlonym oknie dialogowym potwierdzenia lista połączeń (Generated <PCBDocumentName>.Net, dodana do panelu Projects jako dokument niezależny w podfolderze Source Documents) zostanie utworzona w tym samym folderze co dokument projektu PCB i automatycznie otwarta jako aktywny dokument. Każda sieć na liście połączeń otrzyma nazwę jednego z padów, z którymi łączą się poprowadzone ścieżki miedziane.

