High Speed Design
W skrócie
- Poznaj główne czynniki wpływające na projektowanie układów z szybkimi sygnałami, którymi pomaga zarządzać Altium Designer — od terminacji i ścieżek powrotnych po przelotki, pary różnicowe i kontrolę długości ścieżek.
- Zobacz, jak analiza integralności sygnałów przed i po rozmieszczeniu elementów oraz trasowaniu pozwala wykrywać potencjalne problemy z odbiciami i dopracowywać dobór terminacji.
- Dowiedz się, jak xSignals, profile impedancji stosu warstw oraz reguły projektowe trasowania służą do definiowania, pomiaru i kontroli krytycznych ścieżek szybkich sygnałów.
Projektowanie układów o dużej szybkości w Altium Designer
Projektowanie płytek drukowanych do układów o dużej szybkości to proces równoważenia wymagań projektowych obwodu, technologii komponentów oraz materiałów i metod produkcji w celu uzyskania płytki PCB, która umożliwia przesyłanie sygnałów między komponentami z zachowaniem ich integralności.
Elementy, które należy uwzględnić
Prowadzenie ścieżek na płytce z sygnałami o dużej szybkości wymaga zarządzania następującymi aspektami:
-
Komponenty terminujące, które mogą być wymagane
-
Definiowanie sygnałów, do których należy zastosować reguły projektowe dla układów o dużej szybkości
-
Wymiary geometryczne ścieżek — na potrzeby prowadzenia ścieżek o kontrolowanej impedancji
-
Właściwości i wymiary materiałów płytki
-
Liczba i rozmieszczenie warstw w stosie warstw
-
Droga powrotna każdego sygnału o dużej szybkości
-
Wpływ i konfiguracja przelotek
-
Konfiguracja i prowadzenie par różnicowych
-
Konfigurowanie i kontrolowanie długości ścieżek
Analiza integralności sygnałów przed i po zaprojektowaniu płytki
Już na wczesnym etapie projektowania należy zidentyfikować sygnały, które mogą wymagać dopasowania impedancji, aby można było uwzględnić dodatkowe komponenty terminujące przed zakończeniem rozmieszczania komponentów. Ponieważ wyprowadzenia wyjściowe mają zazwyczaj niską impedancję, a wyprowadzenia wejściowe — wysoką, uzyskanie dopasowania impedancji może wymagać dodania do projektu komponentów terminujących.
Altium Designer zawiera symulator integralności sygnałów, dostępny zarówno na etapie tworzenia schematu, jak i projektowania płytki, co umożliwia przeprowadzanie analizy integralności sygnałów przed i po zaprojektowaniu płytki (Tools » Signal Integrity). Symulator integralności sygnałów modeluje zachowanie płytki z poprowadzonymi ścieżkami, wykorzystując jako dane wejściowe symulacji obliczoną impedancję charakterystyczną ścieżek oraz informacje z makromodeli buforów wejścia/wyjścia. Symulator opiera się na silniku Fast Reflection and Crosstalk Simulator, który zapewnia bardzo dokładne symulacje z wykorzystaniem algorytmów sprawdzonych w branży.
Ponieważ zarówno tworzenie schematu, jak i projektowanie płytki wykorzystują zintegrowany system komponentów, łączący symbole schematowe z odpowiednimi footprintami PCB, modelami symulacyjnymi SPICE i makromodelami integralności sygnałów, analizę integralności sygnałów można przeprowadzić już na etapie tworzenia schematu, przed rozpoczęciem projektowania płytki. Gdy projekt płytki jeszcze nie istnieje, narzędzie umożliwia określenie właściwości fizycznych projektu, takich jak docelowa impedancja charakterystyczna ścieżek, bezpośrednio w symulatorze integralności sygnałów. Na tym etapie procesu projektowania symulator integralności sygnałów nie może określić rzeczywistej długości poszczególnych połączeń, dlatego do obliczeń linii transmisyjnych wykorzystuje średnią długość połączenia zdefiniowaną przez użytkownika. Odpowiednio dobierając tę domyślną długość do wymiarów planowanej płytki, można uzyskać dość dokładny obraz przewidywanej integralności sygnałów w projekcie.
Sieci, w których mogą wystąpić problemy z odbiciami, można zidentyfikować, a wszelkie dodatkowe komponenty terminujące dodać do schematu przed rozpoczęciem projektowania płytki. Wartości tych komponentów można następnie dokładniej dostroić po przeprowadzeniu analizy integralności sygnałów po zaprojektowaniu płytki.

Silnik analizy integralności sygnałów pomaga identyfikować sieci, w których mogą wystąpić problemy z odbiciami. Pomiary można wykonywać bezpośrednio na przebiegach.
► Dowiedz się więcej o dopasowaniu impedancji komponentów
Definiowanie sygnałów o dużej szybkości
Main page: Definiowanie dróg sygnałów o dużej szybkości za pomocą xSignals
Projektowanie układów o dużej szybkości to sztuka zarządzania przepływem energii między punktami na płytce drukowanej. Jako projektant musisz mieć możliwość skupienia uwagi na sygnale biegnącym z jednego punktu płytki do drugiego i zastosowania do niego ograniczeń projektowych. Sygnał, na którym się skupiasz, nie musi jednak odpowiadać jednej sieci PCB. Może to być jedna gałąź A0 w projekcie, w którym zamierzasz poprowadzić ścieżki w topologii rozgałęzienia typu T, podczas gdy druga gałąź A0 stanowi kolejny sygnał wymagający uwagi i porównania długości ścieżek obu sygnałów. Sygnał może też mieć na swojej drodze szeregowy komponent terminujący (który edytor PCB postrzega jako jeden komponent i dwie sieci PCB), a jeśli sygnał ten należy do pary różnicowej, jego długość należy porównać z długością drugiego sygnału w tej parze.
Wymaganiami tymi można zarządzać za pomocą funkcji xSignals, w której xSignal jest zasadniczo drogą sygnału zdefiniowaną przez użytkownika. Wybierz źródłowe i docelowe pole lutownicze (w obszarze roboczym lub w panelu PCB), a następnie kliknij jedno z nich prawym przyciskiem myszy, aby zdefiniować tę drogę sygnału jako xSignal. Oprócz interaktywnego definiowania xSignal przez wskazanie początkowego i końcowego pola lutowniczego można również uruchomić inteligentny kreator xSignals Wizard, którego heurystyki pomagają szybko skonfigurować dużą liczbę sygnałów xSignal między wybranymi komponentami. Sygnały xSignal można następnie wykorzystać do przypisania reguł projektowych do sygnałów o dużej szybkości. Oprogramowanie rozpoznaje strukturę tych sygnałów xSignal; potrafi na przykład obliczyć całkowitą długość wielu sieci połączonych przez komponent terminujący, uwzględniając również odległość przez ten komponent.
Panel PCB udostępnia tryb xSignal, który służy do przeglądania sygnałów xSignal i zarządzania nimi. Panel dostarcza również informacji o długości sygnałów, wyróżniając sygnały xSignal, które zbliżają się do granicy dopuszczonej przez obowiązujące ograniczenia projektowe (na żółto) lub ich nie spełniają (na czerwono). Na poniższej ilustracji różnica długości sygnałów xSignal pary różnicowej CLK1 przekracza wartość dopuszczalną przez obowiązującą regułę projektową dopasowania długości. Panel zawiera wartość Signal Length, która jest dokładną długością od punktu do punktu. Typowe nieścisłości pomiaru długości, takie jak odcinki ścieżek wewnątrz pól lutowniczych i nakładające się segmenty ścieżek, są eliminowane, a do obliczenia długości sygnału wykorzystywane są dokładne długości przejść przez przelotki.

Użyj trybu xSignals panelu PCB , aby zarządzać sygnałami xSignal i je analizować. Zwróć uwagę na cienką linię; wskazuje ona drogę sygnału przez komponent szeregowy. (Ilustracja dzięki uprzejmości FEDEVEL Open Source, www.fedevel.com)
Definiowanie właściwości prowadzonych ścieżek
Main page: Prowadzenie ścieżek o kontrolowanej impedancji
Tradycyjnie projektanci płytek określali szerokość i grubość ścieżek, wprowadzając wymiar szerokości i wybierając grubość miedzi dla danej warstwy. Zazwyczaj było to wystarczające, ponieważ należało jedynie zapewnić odpowiednią obciążalność prądową i zachować odstępy wymagane dla danego napięcia. Takie podejście nie wystarcza jednak w przypadku sygnałów o dużej szybkości występujących w projekcie — dla nich konieczne jest kontrolowanie impedancji ścieżek.
Prowadzenie ścieżek o kontrolowanej impedancji polega na dobraniu wymiarów ścieżek i właściwości materiałów płytki tak, aby uzyskać określoną impedancję. W tym celu definiuje się odpowiedni profil impedancji, a następnie przypisuje go do krytycznych sieci sygnałów o dużej szybkości w regułach projektowych dotyczących prowadzenia ścieżek.
Definiowanie profilu impedancji
Main page: Konfigurowanie stosu warstw do prowadzenia ścieżek o kontrolowanej impedancji
Profile impedancji definiuje się w Layer Stack Manager edytora PCB (Design » Layer Stack Manager). Layer Stack Manager otwiera się w edytorze dokumentów, podobnie jak arkusz schematu, płytka PCB i inne typy dokumentów.
Po skonfigurowaniu właściwości warstw przejdź do karty Layer Stack Manager's Impedance, aby dodać lub edytować profile impedancji dla sygnałów niesymetrycznych lub różnicowych.
Profil impedancji 50 Ω zdefiniowany dla pojedynczych sieci prowadzonych na warstwie górnej. Najedź kursorem na obraz, aby wyświetlić ustawienia tego samego profilu dla warstwy L3.
Konfigurowanie reguł projektowych
Impedancja ścieżki zależy od jej szerokości i grubości oraz właściwości otaczających ją materiałów dielektrycznych. Na podstawie właściwości materiałów zdefiniowanych w Layer Stack Manager podczas tworzenia każdego profilu impedancji obliczane są wymagane szerokości ścieżek. W zależności od właściwości materiałów szerokość może się zmieniać przy zmianie warstwy prowadzenia ścieżki. Wymagane zmiany szerokości przy przechodzeniu między warstwami są automatycznie obsługiwane przez odpowiednią regułę projektową dotyczącą prowadzenia ścieżek, skonfigurowaną w edytorze reguł i ograniczeń PCB (Design » Rules).
W większości projektów płytek występuje określony zestaw sieci, które wymagają prowadzenia ścieżek o kontrolowanej impedancji. Typowym podejściem jest utworzenie klasy sieci lub klasy par różnicowych obejmującej te sieci, a następnie utworzenie reguły prowadzenia ścieżek dotyczącej tej klasy, jak pokazano na poniższych ilustracjach.
Zwykle minimalną, maksymalną i preferowaną szerokość definiuje się ręcznie: w ustawieniach ograniczeń u góry, aby zastosować je do wszystkich warstw, albo indywidualnie dla każdej warstwy w tabeli warstw. W przypadku prowadzenia ścieżek o kontrolowanej impedancji zamiast tego włącz opcję Use Impedance Profile, a następnie wybierz wymagany profil impedancji z listy rozwijanej. Po wykonaniu tej czynności sekcja Constraints reguły ulegnie zmianie. Przede wszystkim zauważysz, że obszar dostępnych warstw w regule projektowej nie będzie już pokazywać wszystkich warstw sygnałowych płytki, lecz wyłącznie warstwy włączone w wybranym profilu impedancji. Wartości preferowanej szerokości (oraz odstępu między ścieżkami pary różnicowej) zostaną zaktualizowane zgodnie z szerokościami (i odstępami) obliczonymi dla każdej warstwy. Wartości preferowanych nie można edytować, ale wartości minimalne i maksymalne można — ustaw je na odpowiednio mniejsze i większe.
Reguła projektowa szerokości ścieżek
W przypadku sieci sygnałów niesymetrycznych szerokość ścieżek określa reguła projektowa Szerokość ścieżek.
Po wybraniu opcji używania profilu impedancji dostępne warstwy i preferowane szerokości są określane przez wybrany profil.
Reguła projektowa prowadzenia par różnicowych
Prowadzeniem par różnicowych steruje reguła projektowa Prowadzenie par różnicowych.
W przypadku pary różnicowej dostępne warstwy, preferowana szerokość i preferowany odstęp są określane przez wybrany profil.
► Dowiedz się więcej o prowadzeniu par różnicowych
Wybór impedancji
Skąd zatem wiadomo, jaką impedancję docelową wybrać? Zwykle wynika ona z impedancji charakterystycznej źródła dla używanej rodziny układów logicznych lub technologii. Na przykład układy logiczne ECL mają impedancję charakterystyczną 50Ω, a układy TTL — impedancję źródła w zakresie od 70Ω do 100Ω. W wielu projektach typowa impedancja docelowa wynosi od 50Ω do 60Ω, a w przypadku par różnicowych często stosuje się impedancję różnicową 90Ω lub 100 Ω. Pamiętaj: im niższa impedancja, tym większy pobór prądu, natomiast im wyższa impedancja, tym większe ryzyko emisji zakłóceń elektromagnetycznych i większa podatność sygnału na przesłuchy.
Parę różnicową o impedancji 100Ω można również traktować jako dwie ścieżki sygnałów niesymetrycznych o impedancji 50Ω i tej samej długości. Nie jest to jednak w pełni poprawne ze względu na sprzężenie między ścieżkami pary, które staje się silniejsze wraz ze zmniejszaniem odległości między nimi, obniżając impedancję różnicową pary. Aby utrzymać impedancję różnicową 100Ω , można zmniejszyć szerokość każdej ścieżki, co nieznacznie zwiększy impedancję charakterystyczną każdej z nich o kilka omów.
Definiowanie właściwości płytki
Main page: Zarządzanie stosem warstw
Materiały używane w warstwach płytki, ich wymiary, a także liczba i kolejność warstw są definiowane w menedżerze stosu warstw. W tym miejscu konfiguruje się poszczególne warstwy potrzebne do wyprodukowania gotowej płytki, w tym miedziane warstwy sygnałowe i płaszczyznowe, warstwy dielektryczne rozdzielające miedź, warstwy pokrywające oraz warstwę opisu elementów.

Wszystkie warstwy wykonywane podczas produkcji definiuje się na karcie stosu warstw w menedżerze stosu warstw.
Konfigurowanie przelotek
Main page: Definiowanie typów przelotek
Jak wspomniano w sekcji wprowadzającej na tej stronie, przelotki wpływają na impedancję ścieżek sygnałowych i są jednym z kluczowych aspektów projektowania układów o dużej szybkości działania. Oprócz długości, średnicy otworu i powierzchni pola lutowniczego przelotki, które wpływają na impedancję widzianą przez sygnał, każdy niewykorzystany odcinek metalizowanej ścianki przelotki może działać jak odgałęzienie, przyczyniając się do powstawania odbić sygnału. Aby temu zaradzić, można wykonywać różne typy przelotek między warstwami, w tym przelotki ślepe, zagrzebane, mikroprzelotki (µVia) oraz przelotki pomijające warstwy (Skip Via). Wszystkie te typy przelotek są obsługiwane w Altium Designer.
Przelotki definiuje się jako część stosu warstw na karcie Layer Stack Manager's Via Types. Obsługiwane jest również nawiercanie wsteczne niewykorzystanych odcinków metalizowanych ścianek przelotek, które definiuje się na karcie Layer Stack Manager's Back Drills (więcej informacji: konfigurowanie płytki do nawiercania wstecznego).
Wszystkie typy przelotek możliwe do wykonania można zdefiniować na karcie Via Types w menedżerze stosu warstw (Layer Stack Manager).
Przeprowadzono badania ilościowe mające na celu określenie wpływu przelotek, opisane na przykład w nocie aplikacyjnej Altera AN529 Techniki optymalizacji przelotek w projektach szybkich kanałów transmisyjnych.
Na podstawie tego badania i innych źródeł sformułowano następujące zalecenia pomagające zminimalizować wpływ przelotek:
- Zmniejsz rozmiar pierścienia przelotki w miejscu połączenia ze ścieżką sygnałową. W nocie aplikacyjnej sugerowana średnica przelotki/otworu dla przelotek wierconych mechanicznie wynosi 20/10 mil (0,5/0,25 mm).
- Usuń niewykorzystane pierścienie (znane również jako NFP, czyli nieaktywne pola lutownicze) na warstwach, z którymi przelotka nie jest połączona. W tym celu użyj polecenia Tools » Remove Unused Pad Shapes.
- Zwiększ odstęp między metalizowaną ścianką przelotki a sąsiednimi warstwami płaszczyzn. Parametr ten jest określany przez regułę projektową Power Plane Clearance. W nocie aplikacyjnej sugerowana wartość wynosi od 40 do 50 mil (od 1,0 do 1,25 mm). Pamiętaj, że zwiększa to rozmiar wycięć w tych warstwach płaszczyzn.
- Umieszczaj przelotki zszywające w pobliżu przelotek sygnałowych zawsze wtedy, gdy zmiana warstwy ścieżki sygnałowej powoduje przejście ścieżki powrotnej na inną warstwę. Jeśli nowa płaszczyzna odniesienia ma taki sam potencjał jak pierwotna, należy połączyć te płaszczyzny przelotką znajdującą się w odległości nie większej niż 35 mil (0,9 mm) od przelotki sygnałowej (między środkami).
- Gdy ścieżka sygnałowa zmienia warstwę, a nowa płaszczyzna odniesienia ma inny potencjał, umieść kondensatory odsprzęgające w pobliżu przelotki sygnałowej. Taki kondensator zapewnia odsprzęganie bezpośrednio między dwiema płaszczyznami, niezależnie od ich napięć. Pamiętaj, że to rozwiązanie może powodować przenoszenie zakłóceń z jednej płaszczyzny na drugą, dlatego należy je stosować wyłącznie w ostateczności, aby zmniejszyć powierzchnię pętli ścieżki powrotnej.
- Usuń niewykorzystane odcinki przelotek (części przelotki wystające poza warstwę, na której ścieżka sygnałowa łączy się z przelotką). W tym celu stosuje się odpowiednie przelotki ślepe i zagrzebane lub nawiercanie wsteczne przelotek podczas produkcji.
Zarządzanie ścieżką powrotną sygnałów o dużej szybkości
Każdy sygnał o dużej szybkości w projekcie wymaga odpowiedniej ścieżki powrotnej. Gdy ścieżka powrotna odchyla się od przebiegu ścieżki sygnałowej i prąd powrotny nie płynie bezpośrednio pod nią, powstaje pętla, która powoduje emisję zakłóceń elektromagnetycznych (EMI). Poziom tych zakłóceń jest bezpośrednio związany z powierzchnią pętli.
Tworzenie płaszczyzn zasilania
- Płaszczyznę zasilania można utworzyć zarówno z warstwy płaszczyzny, jak i z warstwy sygnałowej pokrytej jednym lub kilkoma poligonami.
-
Tworzenie płaszczyzny zasilania przy użyciu warstwy płaszczyzny:
- Warstwy płaszczyzn dodaje się w Layer Stack Manager. Kliknij istniejącą warstwę prawym przyciskiem myszy i wybierz Insert layer above lub Insert layer below, aby dodać nową warstwę płaszczyzny.
- Po wybraniu warstwy płaszczyzny jako warstwy aktywnej kliknij dwukrotnie w dowolnym miejscu płaszczyzny, aby otworzyć okno dialogowe Split Plane, w którym można przypisać sieć.
- Oprogramowanie automatycznie odsuwa krawędź płaszczyzny od krawędzi płytki o wartość określoną w kolumnie Pullback Distance dla danej warstwy w Layer Stack Manager. Jeśli ta kolumna nie jest widoczna, kliknij prawym przyciskiem myszy nagłówek istniejącej kolumny, aby uzyskać dostęp do polecenia Select Columns.
- Warstwę płaszczyzny można podzielić na oddzielne obszary, umieszczając linie (Place » Line). Po rozpoczęciu umieszczania pierwszego odcinka linii naciśnij Tab, aby ustawić szerokość linii podziału. Umieść odcinki linii od jednej krawędzi płytki do drugiej lub utwórz zamknięty kształt, aby wydzielić wyspę. Oprogramowanie automatycznie wykryje oddzielne kształty utworzone przez linie podziału. Kliknij dwukrotnie każdy kształt, aby przypisać go do sieci.
-
Tworzenie płaszczyzny zasilania przy użyciu poligonów na warstwie sygnałowej:
- Warstwy sygnałowe dodaje się w Layer Stack Manager. Kliknij istniejącą warstwę prawym przyciskiem myszy i wybierz Insert layer above lub Insert layer below, aby dodać nową warstwę sygnałową.
- Jeśli wymagane są oddzielne strefy zasilania, łatwiejszym rozwiązaniem może być pokrycie całej warstwy poligonem, a następnie jego przecięcie (Place » Slice Polygon Pour). Po rozpoczęciu umieszczania linii cięcia naciśnij Tab, aby otworzyć okno dialogowe Line Constraints, w którym można ustawić szerokość cięcia — będzie ona odległością między dwoma poligonami powstałymi w wyniku przecięcia. Linia cięcia musi zaczynać się i kończyć poza poligonem.
- Aby ponownie wypełnić poligon, kliknij prawym przyciskiem myszy i wybierz Polygon Actions » Repour Selected z menu kontekstowego.
- Poligony można również odłożyć (tymczasowo ukryć). Kliknij prawym przyciskiem myszy i wybierz odpowiednie polecenie z podmenu Polygon Actions . Używaj tej funkcji, gdy musisz przesunąć komponenty i ścieżki.
- Pomocne może być wyświetlanie poszczególnych sieci w różnych kolorach, jak pokazano na poniższych ilustracjach. Można to zrobić na schemacie lub na płytce PCB. Więcej informacji: Przypisywanie kolorów sieciom.
Pierwsza ilustracja przedstawia warstwę płaszczyzny podzieloną na strefy 3v3 i 5v0; druga ilustracja przedstawia warstwę sygnałową z poligonem 3v3 i poligonem 5v0. Sieciom przypisano kolory i włączono ich wyróżnianie.
Płaszczyzna jako ścieżka powrotna sygnału
Odpowiednia ścieżka powrotna to taka, w której:
- W płaszczyźnie zapewniającej ścieżkę powrotną (płaszczyźnie najbliższej danemu sygnałowi) nie ma pod ścieżką sygnałową żadnych przerw, podziałów ani wycięć (otworów w płaszczyźnie utworzonych przez przelotkę lub wyprowadzenie przewlekane).
- Szerokość drogi powrotnej powinna wynosić 3-krotność szerokości ścieżki sygnałowej lub 3-krotność odległości ścieżki od płaszczyzny, zależnie od tego, która wartość jest mniejsza. Chociaż największa gęstość prądu występuje bezpośrednio pod ścieżką sygnałową, prąd rozpływa się również w płaszczyźnie po obu stronach ścieżki — około 95% płynie w obszarze o szerokości równej 3-krotności szerokości ścieżki. Przerwy w płaszczyźnie w tym obszarze zwiększają impedancję drogi powrotnej, a każde odchylenie drogi powrotnej powoduje powstanie pętli. Z punktu widzenia integralności sygnałów wzrost impedancji drogi powrotnej wpływa na jakość sygnału w takim samym stopniu jak wzrost impedancji toru sygnałowego.
- Powierzchnia pętli została zminimalizowana. Zasadniczo zmniejszenie powierzchni pętli jest ważniejsze niż minimalizacja długości ścieżki sygnałowej. Jeśli droga powrotna napotyka wycięcie w płaszczyźnie, rozważ zmianę przebiegu ścieżki sygnałowej tak, aby dopasować ją do dostępnej drogi powrotnej.
- Gdy drogę powrotną zapewnia płaszczyzna zasilania, energia powrotna ostatecznie dotrze do masy przez kondensator odsprzęgający. Starannie dobierz położenie kondensatorów odsprzęgających w pobliżu wyprowadzenia źródłowego sygnału, aby zminimalizować powierzchnię powstającej pętli.
Zarządzanie dzielonymi i wieloma płaszczyznami zasilania oraz masy
Powszechnie przyjmuje się, że nie należy dzielić płaszczyzny masy, chyba że istnieje ku temu konkretna potrzeba i wiadomo, jak taki podział zdefiniować i nim zarządzać. Zamiast tego należy rozmieścić komponenty tak, aby oddzielić elementy generujące zakłócenia od elementów cichych, a także grupować komponenty według wykorzystywanej szyny zasilania.
Inne kwestie, o których warto pamiętać w przypadku płaszczyzn zasilania i masy:
- Jeśli projekt wymaga częściowego podziału płaszczyzny masy, sygnały przechodzące przez te obszary należy prowadzić przez mostek, czyli strefę, pod którą nie ma podziału.
- Jeśli celem jest minimalizacja zakłóceń w obwodzie, lepiej zastosować dodatkowe płaszczyzny masy niż dzielić jedną płaszczyznę. Tam, gdzie to możliwe, należy przewidzieć warstwy płaszczyzn zarówno dla szyny zasilania, jak i masy każdego stabilizowanego źródła zasilania.
- Jeśli projekt zawiera wiele szyn zasilania, z których każda jest rozprowadzana na osobnej płaszczyźnie, upewnij się, że każda płaszczyzna zasilania ma jako odniesienie wyłącznie własną płaszczyznę masy. Nie dopuszczaj do tego, aby płaszczyzna zasilania nakładała się na płaszczyznę masy innej szyny i wykorzystywała ją jako odniesienie. Powoduje to sprzężenie pojemnościowe, umożliwiające przenoszenie zakłóceń między źródłami zasilania.
- Jeśli sąsiednia płaszczyzna jest płaszczyzną zasilania, którą trzeba podzielić na obszary o różnych napięciach, może być konieczne zastosowanie kondensatora odsprzęgającego bezpośrednio między tymi obszarami, aby zapewnić odpowiednią drogę powrotną.
Wizualizacja dzielonych płaszczyzn
Aby ułatwić wzrokową kontrolę dróg powrotnych, możesz skonfigurować widok tak, by łatwiej sprawdzać drogę powrotną pod krytycznymi ścieżkami sygnałowymi.

Sprawdzanie, czy sygnały przebiegają nad linią podziału podczas przechodzenia między obszarami płaszczyzny o różnych napięciach. Cztery wyróżnione sieci przecinają podział w płaszczyźnie zasilania VCC, co powoduje przerwanie drogi powrotnej tych sygnałów.
Aby to zrobić:
- Przypisz kolor każdej sieci zasilającej. Więcej informacji znajdziesz w sekcji Nadawanie kolorów sieciom.
- Ogranicz wyświetlanie warstw do odpowiednich warstw sygnałowych i warstw płaszczyzn. Taką grupę warstw można zapisać jako zestaw warstw. Więcej informacji znajdziesz w sekcji tworzenie zestawu warstw.
- Przełącz się na warstwę sygnałową i użyj Ctrl+Click na interesującej Cię sieci, aby ją wyróżnić (podczas klikania przytrzymaj również Shift, aby wyróżnić wiele sieci). Zaletą wyróżniania w porównaniu z zaznaczaniem jest jego trwałość — sieci pozostaną wyróżnione po kliknięciu w innym miejscu. Naciśnij Shift+C , aby usunąć bieżące wyróżnienia.
- Wyróżnianie polega na przyciemnieniu pozostałych obiektów w obszarze projektowym. Poziom Dimmed Objects ustawia się w sekcji Ustawienia maskowania i przyciemniania panelu View Configuration.
- Ustaw warstwę płaszczyzny jako aktywną.
Sieci będą wyraźnie widoczne, a wszelkie podziały lub nieciągłości na drodze powrotnej, takie jak linie podziału czy wycięcia utworzone przez pola lutownicze otworów przelotowych i przelotki, będzie łatwiej dostrzec.
Wykrywanie przerw w drodze powrotnej
Przerwy lub przewężenia w drodze powrotnej można wykrywać za pomocą reguły projektowej Return Path. Reguła projektowa Return Path sprawdza ciągłość drogi powrotnej sygnału na wskazanych warstwach odniesienia powyżej lub poniżej sygnałów objętych regułą. Droga powrotna może być utworzona z wypełnień, regionów i wylewek poligonowych umieszczonych na sygnałowej warstwie odniesienia lub może ją stanowić warstwa płaszczyzny.
Warstwy drogi powrotnej to warstwy odniesienia zdefiniowane w Impedance Profile wybranym w regule projektowej Return Path. Warstwy te są sprawdzane pod kątem zachowania określonej wartości Minimum Gap (szerokości poza krawędzią ścieżki sygnałowej) na całej długości przebiegu sygnału. Dodaj nową regułę projektową Return Path w kategorii reguł High Speed.

Warstwy drogi powrotnej są zdefiniowane w wybranym Impedance Profile, a szerokość drogi (poza krawędzią ścieżki sygnałowej) określa Minimum Gap.
Poniższy obraz przedstawia błędy drogi powrotnej wykryte dla sygnału NetX, przy ustawieniu Minimum Gap na 0.1mm. Lokalizowanie błędów Return Path może być łatwiejsze po skonfigurowaniu DRC Violation Display Style tak, aby wyświetlane były szczegóły naruszeń, ale nie nakładka naruszeń, w oknie dialogowym Preferencje – pokaż obraz. Powoduje to wyróżnienie dokładnych miejsc, w których reguła została naruszona, zamiast całych obiektów naruszających regułę.
Sprawdzanie przelotek drogi powrotnej
Gdy sygnał o dużej szybkości przechodzi z jednej płaszczyzny odniesienia na drugą, należy również zapewnić przelotki powrotne, które umożliwią przepływ sygnałów powrotnych między tymi płaszczyznami. Aby sprawdzić, czy taka przelotka znajduje się w określonej odległości od przelotki sygnałowej, określ za pomocą opcji Max Stitch Via Distance w odpowiedniej regule projektowej ścieżki powrotnej, czy przelotka ścieżki powrotnej powinna znajdować się w zadanej odległości od przelotki sygnału objętego regułą. Przelotka ścieżki powrotnej powinna zapewniać połączenie z warstwą odniesienia zdefiniowaną w Layer Stack Manager dla odpowiedniego profilu impedancji.
Gdy w regule zdefiniowano Max Stitch Via Distance, obecność przelotki ścieżki powrotnej w określonej odległości jest sprawdzana w ramach wsadowej kontroli DRC.

Przykład naruszenia ograniczenia maksymalnej odległości przelotki zszywającej. W tym przypadku przelotka sieci DQS4R_N nie ma przelotki ścieżki powrotnej w określonej odległości.
Konfigurowanie i trasowanie par różnicowych
Main pages: Trasowanie par różnicowych, Trasowanie z kontrolowaną impedancją
Pary różnicowe można zdefiniować podczas tworzenia schematu lub po przeniesieniu projektu do edytora PCB. Podstawowym wymogiem definiowania pary na schemacie jest dodanie _P lub _N na końcu nazwy każdej z odpowiednich sieci. Pary różnicowe oznacza się na schemacie, umieszczając Differential Pair directive na każdej sieci lub na Blanket directive, gdzie dyrektywa Blanket obejmuje zestaw etykiet sieci o nazwach właściwych dla par różnicowych, jak pokazano na poniższym rysunku.
Dyrektywa Blanket umożliwia skonfigurowanie wielu sieci jako elementów par różnicowych.
Praca z parami różnicowymi:
- W edytorze PCB pary różnicowe można definiować w trybie Edytor par różnicowych panelu PCB. Aby uprościć definiowanie reguł projektowych dotyczących par różnicowych, można przypisać je do klas sieci lub klas par różnicowych. Oba rodzaje klas definiuje się w Eksploratorze klas obiektów.
- Aby trasować parę różnicową z kontrolowaną impedancją, utwórz profil impedancji w Layer Stack Manager. Dowiedz się więcej o trasowaniu z kontrolowaną impedancją.
- Właściwości trasowania par różnicowych określa reguła projektowa Trasowanie par różnicowych.
-
Do trasowania pary różnicowej służy polecenie trasowania Interaktywne trasowanie par różnicowych. Kliknij pole lutownicze
_Plub_N, aby rozpocząć trasowanie, a następnie użyj Spacebar, aby przełączać dostępne kształty wyprowadzenia ścieżek. Trasowanie odbywa się tak samo jak w przypadku pojedynczej sieci; naciśnij Shift+F1, aby wyświetlić listę skrótów interaktywnego trasowania. Gdy zbliżysz się do docelowych pól lutowniczych, naciśnij Ctrl+Click, aby dokończyć trasowanie do tych pól.
Praktyczne zasady dotyczące par różnicowych:
-
Dopasowanie długości ma kluczowe znaczenie dla prawidłowego działania par różnicowych. Utrzymuj zgodność długości w granicach tolerancji odpowiedniej dla danej technologii sygnalizacji. Na przykład w przypadku par USB 3.x dopasuj długości z tolerancją od 5 do 10 milsów. Inna praktyczna zasada polega na dopasowaniu długości tak, aby różnica opóźnień nie przekraczała 20% czasu narastania sygnału. Sygnalizacja różnicowa działa dzięki temu, że energia powrotna przepływa przez drugi przewodnik pary. Im większe niedopasowanie długości, tym większa część energii powraca zamiast tego przez najbliższą warstwę płaszczyzny.
-
Nieciągłości sprzężenia, występujące na przykład wtedy, gdy ścieżki pary omijają przeszkodę z przeciwnych stron, zwiększają impedancję. Lepszym rozwiązaniem może być poprowadzenie całej pary z luźniejszym sprzężeniem (na przykład z odstępem równym dwukrotnej szerokości ścieżki sygnałowej), aby ograniczyć zmiany impedancji spowodowane nieciągłościami sprzężenia.
-
Ścieżki zakłócające prowadź z dala od pary, zwłaszcza na warstwach zewnętrznych. W przypadku sieci mogących powodować zakłócenia dąż do zachowania odstępu równego trzykrotnej szerokości ścieżki sygnałowej.
-
Zgodnie z ogólną zasadą dąż do zachowania odstępu między parą a innymi sygnałami równego dwukrotnej szerokości ścieżki sygnałowej.
-
Zachowuj odległość od wielokątów masy na tej samej warstwie równą co najmniej trzykrotnej szerokości ścieżki sygnałowej.
-
Odbicia powodowane przez przelotki i nieciągłości sprzężenia ogranicza się przez prowadzenie ścieżek o kontrolowanej impedancji, co wymaga ciągłej płaszczyzny odniesienia pod ścieżką sygnałową.
-
Zmniejsz odległość między warstwą sygnałową a płaszczyzną odniesienia, aby zwiększyć odporność na przesłuchy.
Kontrola i dostrajanie długości ścieżek
Main pages: Dostrajanie długości, Reguła projektowa długości, Reguła projektowa dopasowania długości
Kluczowym wymogiem przy projektowaniu obwodów z sygnałami o dużej szybkości jest kontrolowanie i dostrajanie długości ich ścieżek.
- Długości bezwzględne można monitorować za pomocą reguły projektowej długości, a długości względne — za pomocą reguły projektowej dopasowania długości.
- Bieżące długości grupy sieci oraz ich zgodność z obowiązującymi regułami projektowymi można sprawdzić w panelu PCB w trybie Nets (jak pokazano poniżej).
- Jeśli zdefiniowano regułę długości lub dopasowania długości, można monitorować długość podczas interaktywnego prowadzenia ścieżek lub dostrajania ich długości, wyświetlając wskaźnik dostrajania długości (Shift+G).
- Obsługiwane jest opóźnienie wynikające z długości wyprowadzenia wewnątrz obudowy elementu. Więcej informacji można znaleźć w sekcji Opóźnienie wyprowadzenia w obudowie.
- Sieci zawierające na swojej trasie elementy połączone szeregowo obsługuje się przez zdefiniowanie xSignals.
Reguły projektowe
- Managing the Overall Route Lengths - całkowitą długość ścieżek sieci lub grupy sieci można monitorować za pomocą reguły projektowej długości. Reguła ta określa minimalną i maksymalną dopuszczalną długość. Jeśli długość sygnału jest mniejsza od dopuszczalnego minimum, jest wyróżniana na żółto w panelu PCB (w trybie Nets), a jeśli przekracza dopuszczalne maksimum — na czerwono.
- Managing the Relative Route Lengths - względne długości ścieżek w grupie sieci można monitorować za pomocą reguły projektowej dopasowania długości. Reguła ta określa tolerancję i przyjmuje najdłuższą trasę w grupie objętych nią sieci jako długość odniesienia. Żółte wyróżnienie długości sygnału w panelu oznacza, że jest ona mniejsza od długości najdłuższej trasy pomniejszonej o tolerancję. Czerwone wyróżnienie oznacza, że długość tego sygnału jest większa od długości najdłuższej trasy.
Aby dowiedzieć się, jak rozstrzygane są ustawienia tych dwóch reguł, gdy obie występują w projekcie, zapoznaj się ze stroną Dostrajanie długości.
Monitorowanie długości ścieżek
Bieżące długości ścieżek są wyświetlane w trybie Sieci panelu PCB i aktualizowane podczas prowadzenia ścieżek. Wartość długości Routed zmienia kolor na żółty w miarę zbliżania się do długości docelowej, a po jej przekroczeniu — na czerwony.
Jeśli zdefiniowano regułę długości lub dopasowania długości, można monitorować długość podczas interaktywnego prowadzenia ścieżek lub dostrajania ich długości, wyświetlając wskaźnik dostrajania długości. Podczas prowadzenia ścieżek użyj skrótu Shift+G, aby włączyć lub wyłączyć wskaźnik.
Wskaźnik pokazuje bieżącą długość poprowadzonych ścieżek jako liczbę nad suwakiem, natomiast suwak przedstawia szacowaną długość. Podczas dostrajania długości Estimated Length = Current Routed Length; jeśli wskaźnik jest używany podczas interaktywnego prowadzenia ścieżek, Estimated Length = Routed Length + distance to target (length of connection line).
Ustawienia wskaźnika są obliczane na podstawie ograniczeń określonych przez obowiązujące reguły.
-
Minimum wskaźnika (lewa krawędź) wynosi 45 (najniższa wartość
MinLimit) -
Maksimum wskaźnika (prawa krawędź) wynosi 48 (najwyższa wartość
MaxLimit) -
Lewy żółty pasek (najwyższa wartość
MinLimit) znajduje się na poziomie 46,58 -
Prawy żółty pasek (najniższa wartość
MaxLimit) znajduje się na poziomie 47,58 (na powyższej ilustracji jest zasłonięty przez zielony pasek) -
Zielony pasek (
TargetLength) znajduje się na poziomie 47,58 (długość ścieżek najdłuższej sieci w grupie, równaMaxLimit) - Zielony suwak i wyświetlana nad nim wartość liczbowa (bieżąca długość ścieżek) wskazują 47,197.
Dostrajanie długości ścieżek
Długości ścieżek można dostroić po zakończeniu ich prowadzenia za pomocą polecenia Interactive Length Tuning lub Interactive Diff Pair Length Tuning (menu Route). Polecenia te dodają do ścieżek odcinki meandrowe w jednym z trzech dostępnych kształtów.
Jeśli obowiązują zarówno reguła długości, jak i reguła dopasowania długości, narzędzie do dostrajania długości uwzględnia obie i wyznacza najbardziej restrykcyjny zestaw ograniczeń. Jeśli więc maksymalna długość określona przez regułę długości jest mniejsza niż najdłuższa długość objęta regułą dopasowania długości, pierwszeństwo ma reguła długości i to określona przez nią długość jest używana podczas dostrajania.
Aby sprawdzić, które reguły są stosowane, lub zmienić właściwości meandra podczas dostrajania długości, naciśnij Tab, aby otworzyć panel Properties w trybie Interactive Length Tuning, jak pokazano poniżej. Zwróć uwagę na Target Length — jest to Max Limit wynikająca z najbardziej restrykcyjnych ustawień obowiązujących reguł.

Naciśnij Tab podczas dostrajania długości, aby otworzyć panel w trybie Interactive Length Tuning, w którym można wybrać tryb długości docelowej i dostosować parametry meandra.
Aby dostroić długość sieci, uruchom polecenie, a następnie kliknij dowolne miejsce na jej trasie. Przesuwaj kursor wzdłuż trasy ścieżki — w trakcie tego ruchu będą dodawane odcinki meandrowe. Kolejne odcinki będą dodawane do momentu spełnienia wymagań dotyczących długości określonych przez obowiązujące reguły projektowe. Jeśli kursor znajdzie się poza granicami meandrów dostrajających, meandry znikną. Pojawią się ponownie, gdy kursor wróci w obręb ich obszaru.
Dowiedz się więcej o dostrajaniu długości.
Podsumowanie
Choć nie da się opracować uniwersalnego zestawu reguł dla każdego projektu układu o dużej szybkości, można stosować dobre praktyki projektowe, które pomogą osiągnąć sukces. Wielu ekspertów branżowych prowadzi praktyczne i popularne szkolenia z projektowania układów o dużej szybkości. Skorzystaj z poniższych odnośników, aby dowiedzieć się więcej i zapoznać się z ofertą specjalistycznych szkoleń.
Źródła
Autor z wdzięcznością docenia dorobek wymienionych poniżej ekspertów branżowych. Ta strona stanowi próbę podsumowania ich wspólnej wiedzy.
- Czasy propagacji w liniach mikropaskowych
- Podział płaszczyzn z myślą o szybkości i zasilaniu
- Efekt naskórkowy
- Reguły projektowania ścieżek różnicowych — prawda a fikcja
- Indukcyjność przelotek
- Układ 10 warstw
Książki i artykuły Lee W. Ritcheya
- Dobrze za pierwszym razem
- Omówienie sygnalizacji różnicowej i jej wymagań projektowych
- Wpływ laminatów PCB na szybkość transmisji danych, Część 1, Część 2
Artykuły In-Circuit Design — Barry Olney
- Prowadzenie par różnicowych
- Cała prawda o mostkach między płaszczyznami
- Krytyczne aspekty rozmieszczania elementów
- Planowanie układu warstw (części 1, 2 i 3)
- Idealny układ warstw
Najlepsze praktyki w projektowaniu płytek drukowanych - Tim Jarvis RadioCAD Limited
Projektowanie układu PCB - witryna Learn EMC
Artykuły Keitha Armstronga, Centrum Informacji EMC (wymagana bezpłatna rejestracja)
Podręcznik obudowywania układów elektronicznych - Glenn R. Blackwell
Podręcznik obwodów drukowanych - Clyde Coombs i Happy Holden
Podręcznik HDI - Happy Holden i inni
Techniki optymalizacji przelotek w projektach szybkich kanałów transmisyjnych - nota aplikacyjna Altera AN529
Zagadnienia projektowania szybkich PCB - nota aplikacyjna Lattice Semiconductor TN 1033
Pomiar czasu propagacji sygnału - Chris Grachanen, EDN
Przyszłość struktur przelotek HDI, dystrybucji zasilania i zarządzania ciepłem w obwodach drukowanych nowej generacji - Tom Buck TTM Technologies