Работа с экструдированными, сферическими и цилиндрическими 3D-телами
Краткий обзор
- Узнайте, чем отличаются тела выдавливания, цилиндрические и сферические объекты 3D Body, а также как задавать их параметры и размещать их.
- Посмотрите, как с помощью панели Properties и сочетаний клавиш, доступных во время выполнения команды, управлять размерами и внешним видом фигур, а также особенностями их размещения.
- Разберитесь, как создавать трехмерные тела на основе существующих фигур посадочного места и управлять ими с помощью Component Body Manager, включая возможности работы с отдельными компонентами и пакетного обновления.
Хотя размещение универсальных 3D-моделей — рекомендуемый способ использования объектов 3D Body, поскольку он обеспечивает точное и подробное представление компонента на печатной плате и позволяет точнее проверять пересечения в 3D в редакторе печатных плат, объект 3D Body также можно использовать для размещения вытянутых, сферических и цилиндрических трехмерных тел. Для размещения доступны три типа простых объектов 3D Body:
| Extruded | В плоскости X-Y (вид сверху) вытянутый объект задается интерактивно так же, как и другие многоугольные объекты в редакторе печатных плат. Затем объект вытягивается вверх (или вниз) по оси Z в соответствии со свойствами Overall Height и Standoff Height, заданными в режиме 3D Body панели Properties, и параметром Body Projection. На поверхность вытянутого объекта 3D Body также можно наложить файл текстуры, например логотип. |
| Cylindrical | Свойства этой формы задаются в режиме 3D Body панели Properties. |
| Spherical | Свойства этой формы задаются в режиме 3D Body панели Properties. |
Размещение вытянутого, сферического или цилиндрического объекта 3D Body
Непосредственное размещение
Вытянутые, сферические и цилиндрические объекты 3D Body можно размещать как в редакторе печатных плат, так и в редакторе посадочных мест следующими способами:
- Выбрав команду Place » Extruded 3D Body в главном меню.
- Найдя и выполнив команду размещения вытянутого объекта 3D Body на Active Bar.
Чтобы разместить вытянутый, сферический или цилиндрический объект 3D Body:
- После запуска команды курсор примет вид перекрестия, и включится режим размещения по умолчанию — размещение вытянутого объекта 3D Body.
- Нажмите Tab, чтобы приостановить размещение и открыть панель Properties в режиме 3D Body. В рабочей области появится кнопка паузы , указывающая на возможность работы с полями панели Properties.
- На панели Properties введите имя объекта 3D Body в поле Identifier. Это необязательно: идентификатор помогает различать несколько размещаемых объектов 3D Body и при необходимости позволяет указать этот объект 3D Body в правиле проектирования.
-
Выберите требуемое значение Board Side; обычно устанавливается
Top. В редакторе библиотек печатных плат посадочное место создается для верхней стороны платы; при необходимости его можно перенести на нижнюю сторону в процессе проектирования платы. - Выберите механический Layer, на котором будет размещен объект 3D Body. Механические слои типа Component следует объединять в пары со вторым механическим слоем, чтобы при переносе компонента с верхней стороны платы на нижнюю его механические элементы, например объект 3D Body, перемещались на парный механический слой. Пары механических слоев задаются на вкладке Layers and Colors панели View Configuration. Дополнительные сведения см. на странице описания панели.
- Выберите 3D Model Type из доступных форм: Extruded, Cylinder или Sphere.
-
Перед размещением необходимо задать размеры выбранной формы. Если выбрана форма:
- Extruded — задайте Overall Height.
- Cylinder — задайте Height и Radius.
- Sphere — задайте Radius.
- В области Display панели нажмите кнопку Color, чтобы задать цвет, и при необходимости настройте Opacity.
-
Завершив редактирование, нажмите кнопку паузы для возврата в рабочую область.
-
Если выбрана форма Cylinder или Sphere:
- При перемещении курсора в рабочей области к нему будет привязана прямоугольная фигура; щелкните, чтобы разместить объект 3D Body.
- Щелкните правой кнопкой мыши или нажмите Esc, чтобы завершить размещение объектов 3D Body.
-
Если выбрана форма Extruded, курсор будет готов к заданию многоугольного основания вытянутого объекта 3D Body:
- Щелкните, чтобы задать первую вершину.
- Переместите курсор в положение второй вершины. По умолчанию каждый щелчок размещает два ребра с заданной пользователем формой угла между ними. Подробнее см. в разделе Режимы размещения вытянутого объекта 3D Body ниже.
- Продолжайте перемещать мышь и щелкать для размещения следующих вершин.
- После размещения последней вершины щелкните правой кнопкой мыши или нажмите Esc, чтобы замкнуть контур и завершить размещение объекта 3D Body. Замыкать контур вручную не требуется: программа автоматически завершит фигуру, соединив начальную точку с последней размещенной точкой.
-
Если выбрана форма Cylinder или Sphere:
Режимы размещения вытянутого объекта 3D Body
При размещении вытянутого объекта 3D Body доступны пять режимов построения углов, четыре из которых также имеют подрежимы направления угла. Во время размещения:
- Нажимайте Shift+Spacebar для последовательного переключения между пятью доступными режимами построения углов.
- Нажимайте Spacebar для переключения между двумя подрежимами направления угла.
-
В любом из режимов построения дуговых углов удерживайте клавишу
или
, чтобы уменьшить или увеличить дугу. Для ускорения изменения размера дуги дополнительно удерживайте клавишу Shift.
- Используйте сочетание клавиш 1 для переключения между размещением двух ребер за щелчок и одного ребра за щелчок. Во втором режиме пунктирное ребро называется look-ahead segment.
- Нажмите клавишу Backspace, чтобы удалить последнюю вершину.

Вытянутый объект 3D Body; обратите внимание на опорную точку, показанную на видах 2D и 3D.
Создание из замкнутых фигур
Чтобы ускорить создание формы компонента из 3D-тел, программа может создавать набор выдавленных объектов 3D Body на основе замкнутых фигур, обнаруженных в посадочном месте. Эта функция полезна, если компонент имеет необычную форму, которая уже отражена в фигурах на слое шелкографии компонента в посадочном месте. Также можно добавить в посадочное место дополнительные объекты на механических слоях, а затем использовать их для создания дополнительных объектов 3D Body, например выводов.
На изображениях ниже показано посадочное место транзистора в корпусе TO-92. Контур, нарисованный на слое Top Overlay, используется для задания корпуса транзистора на выбранной паре слоев 3D Body (в диалоговом окне она обозначается как Registration Layer). Кроме того, на механическом слое созданы три небольших квадрата (каждый из четырех линий), которые используются для задания выводов компонента на выбранной паре слоев 3D Body. Настройки показаны на изображении диалогового окна ниже.

Существующие объекты посадочного места можно использовать для создания новых объектов 3D Body.
Чтобы создать объекты 3D Body из фигур в посадочном месте, выполните команду Tools » Manage 3D Bodies for Current Component. Откроется диалоговое окно Component Body Manager. В нем можно посмотреть, какие 3D-тела сейчас используются в компоненте, а какие — нет. При необходимости тела можно добавлять в компонент и удалять из него. Тела могут быть трех типов:
- Специально размещенный объект 3D Body (в его описании обозначается как Component Body).
- Прямоугольная фигура, автоматически созданная программой на основе ограничивающего прямоугольника.
- Замкнутая многоугольная фигура, автоматически созданная программой на основе графических примитивов.
Также можно изменять другие свойства тела, например высоты, проекцию тела, слой привязки, цвет и непрозрачность. Обратите внимание: столбец Body State показывает, что для создания объектов 3D Body будут использованы четыре фигуры.
После задания необходимых 3D-тел компонента нажмите кнопку Close , чтобы применить изменения.

Программа может создавать объекты 3D Body на основе формы существующих объектов.
Примечания по работе с этим диалоговым окном:
- Алгоритм распознавания предложит один из двух вариантов: прямоугольную фигуру, созданную на основе ограничивающего прямоугольника, или многоугольную фигуру, повторяющую контур, образованный примитивами (по осевым линиям дорожек и дуг, если их конечные точки совпадают).
- Чтобы создать объект 3D Body из существующего объекта, щелкните синий текст в столбце Body State.
- По умолчанию для Overall Height используется значение Height, заданное на панели Properties для посадочного места.
- Для вывода компонента, проходящего вниз сквозь плату, установите для Body Projection значение Bottom Side.
- Объекты 3D Body создаются при нажатии кнопки Close в диалоговом окне. Если уже включен режим 3D, для отображения новых объектов может потребоваться обновить вид (сочетание клавиш End), переключиться в режим 2D и затем обратно в 3D либо переключить параметр Show 3D Bodies между Off и On на вкладке View Options панели View Configurations.
- Чтобы изменить 3D-тела всех компонентов в активной библиотеке посадочных мест печатных плат, открытой в редакторе посадочных мест, выберите в главном меню команду Tools » Manage 3D Bodies for Library.
- Чтобы изменить 3D-тела в редакторе печатных плат с помощью этого диалогового окна, откройте его, выбрав команду Tools » Manage 3D Bodies for Components on Board в главном меню или щелкнув компонент правой кнопкой мыши и выбрав Действия с компонентом » Управление 3D-телами в контекстном меню.
-
При открытии диалогового окна с помощью команды Tools » Manage 3D Bodies for Components on Board (в редакторе печатных плат) или команды Tools » Manage 3D Bodies for Library (в редакторе посадочных мест) в верхней части окна доступна область Components. В этой области перечислены все посадочные места компонентов активной библиотеки (для проекта это список всех компонентов на плате). Для каждой записи отображаются позиционное обозначение (доступно только при работе с проектом), имя посадочного места, высота и сведения об исходной библиотеке.
Также доступна дополнительная вкладка Batch Update. Она позволяет быстро добавлять объекты 3D Body сразу ко всем или выбранным компонентам. Можно задать критерии поиска для обнаружения и создания 3D-тел, а также для задания их свойств. Настроив все параметры пакетной обработки, нажмите кнопку Execute Batch Update. Поиск будет выполнен для каждого компонента, включенного в обработку. Если форма 3D-тела обнаружена и тело создано, оно будет добавлено к компоненту с заданными свойствами. В этом режиме изменения применяются при выполнении пакетного обновления.
- Диалоговое окно позволяет управлять всеми 3D-телами компонента в одном месте, избавляя от необходимости открывать панель Properties для каждого объекта 3D Body.
Параметры и элементы управления диалогового окна Component Body Manager

Диалоговое окно Component Body Manager (на заднем плане) и диалоговое окно Управление телами компонента (на переднем плане)
Компоненты
В верхней области диалогового окна перечислены все посадочные места компонентов активной библиотеки (для проекта это список всех компонентов на плате). Для каждой записи отображаются позиционное обозначение (доступно только при работе с проектом), имя посадочного места, высота и сведения об исходной библиотеке.
Вкладка интерактивного управления

Вкладка Interactive диалогового окна Component Body Manager
В версии диалогового окна Component Body Manager предусмотрены две вкладки: Interactive и Batch Update. Вкладка Interactive позволяет удобно просматривать сведения о выбранном компоненте, включая предварительный просмотр тел компонента и выбранного тела.
Существующие и потенциальные тела компонента
-
Existing and Potential Component Bodies — в этой области перечислены все существующие тела компонента (3D-тела), которые используются или могут использоваться для компонента. Для каждого тела компонента приводятся следующие сведения:
-
Description — описание способа создания тела. Это может быть специально размещенный объект 3D Body (в его описании обозначается как Component Body), прямоугольная фигура, созданная на основе ограничивающего прямоугольника, или замкнутая многоугольная фигура, созданная на основе графических примитивов. Описание каждого тела (как размещенного вручную, так и созданного автоматически) также содержит механический слой, на котором оно находится (или на котором находятся объекты, использованные для его создания), и его площадь. Прямоугольные и многоугольные тела обозначаются с помощью
и
значки соответственно.
- Body State — показывает, используется ли тело в компоненте (In Component <ComponentDesignator>) или нет (Not In Component <ComponentDesignator>). Нажмите на запись, чтобы переключить состояние.
- Standoff Height — расстояние от поверхности платы до нижней грани вытянутого тела. Для вытянутых тел, которые должны проходить вниз сквозь печатную плату, используйте отрицательное значение.
- Overall Height — расстояние от поверхности платы до верхней грани вытянутого тела.
- Body Projection — сторона платы, относительно которой будет выступать 3D-тело. В раскрывающемся списке поля выберите Top Side или Bottom Side (выступать вверх или вниз). Этот параметр автоматически изменяется, если объект 3D-тела переносится на другую сторону платы при перевороте компонента.
- Registration Layer — механический слой, на котором находится 3D-тело. В раскрывающемся списке поля можно выбрать любой из включённых механических слоёв. Если выбранный механический слой входит в пару, то при переносе тела на другую сторону платы вместе с компонентом оно также будет перемещено на парный механический слой.
- Body 3D Color — текущий цвет 3D-тела. Нажмите на образец цвета, чтобы открыть стандартное диалоговое окно Choose Color и при необходимости назначить другой цвет.
- Body 3D Opacity — текущий уровень прозрачности 3D-тела. В раскрывающемся списке поля выберите Solid (полностью непрозрачное), Hide (тело становится невидимым), 25% Opacity, 50% Opacity или 75% Opacity.
-
Description — описание способа создания тела. Это может быть специально размещенный объект 3D Body (в его описании обозначается как Component Body), прямоугольная фигура, созданная на основе ограничивающего прямоугольника, или замкнутая многоугольная фигура, созданная на основе графических примитивов. Описание каждого тела (как размещенного вручную, так и созданного автоматически) также содержит механический слой, на котором оно находится (или на котором находятся объекты, использованные для его создания), и его площадь. Прямоугольные и многоугольные тела обозначаются с помощью
- Component bodies in: <ComponentDesignator> — показывает 2D-посадочное место компонента с наложенными 3D-телами, для которых параметр Body State сейчас имеет значение In Component <ComponentDesignator>. Предварительный просмотр динамически обновляется при включении или исключении тел.
- Selected Body — показывает тело, выбранное в списке выше. В заголовке окна также отображается описание тела.
Вкладка пакетного обновления

Вкладка Batch Update диалогового окна Component Body Manager
Вкладка Batch Update позволяет быстро добавлять объекты 3D-тел ко всем или выбранным посадочным местам в библиотеке либо ко всем или выбранным посадочным местам, размещённым в проекте.
Область таблицы
В этой области задаются критерии поиска для обнаружения и создания 3D-тел, а также их свойства, такие как Projection side (также называемое направлением выступания тела), Registration Layer, Standoff Height, Overall Height и 3D Body Color.
Каждая запись в списке задаёт свою область поиска — слои, на которых будет выполняться поиск при обнаружении и создании возможных форм 3D-тел. Каждый поиск включается отдельно с помощью параметра в столбце Enabled. Можно включить несколько поисков, однако учитывайте, что для каждого успешного поиска будет добавлено отдельное 3D-тело. Обычно поиск включают на одном конкретном слое или наборе слоёв — в зависимости от того, где обычно размещаются примитивы или контур компонента для посадочного места. По умолчанию выполняется поиск по All Layers.
Поле Detection Method позволяет выбрать способ определения формы каждого 3D-тела:
- Bounding Rectangle — использовать ограничивающий прямоугольник посадочного места.
- Closed Shapes — использовать замкнутый многоугольный контур, созданный из примитивов посадочного места компонента.
- Both (Prefer Closed Shapes) — обнаруживать ограничивающий прямоугольник или замкнутый многоугольный контур на основе примитивов посадочного места. Если обнаружены оба варианта, использовать замкнутый многоугольный контур.
Столбец параметра Prefer component height if not 0 позволяет указать, следует ли использовать атрибут высоты, заданный для посадочного места компонента, в качестве Overall Height 3D-тела. Если этот параметр включён, для каждого компонента с заданным атрибутом высоты больше нуля эта высота будет установлена в качестве Overall Height добавляемого 3D-тела, а его Standoff Height будет установлено в ноль.
Параметр Body 3-D Color задаёт цвет отображения 3D-тела. Нажмите на цвет, чтобы изменить его в диалоговом окне Choose Color.
Параметры
- Apply Only To Selected Components — включите этот параметр, чтобы применить критерии создания 3D-тел только к выбранной группе посадочных мест. Убедитесь, что соответствующие компоненты выбраны в верхней области диалогового окна (для множественного выбора используйте стандартные функции Ctrl+Click и Shift+Click ). Если этот параметр отключён, пакетное добавление будет применено ко всем посадочным местам в библиотеке (или ко всем компонентам на плате).
- Delete Existing Bodies In Components — включите этот параметр, чтобы удалить все существующие 3D-тела у посадочных мест, обрабатываемых в пакетном режиме. Окно предварительного просмотра в правом нижнем углу вкладки позволяет оценить, как будет выглядеть добавляемое 3D-тело для выбранного посадочного места компонента и выбранной (и включённой) записи поиска. Задав все необходимые параметры пакетной обработки, нажмите кнопку Execute Batch Update. Поиск будет выполнен для каждого посадочного места, включённого в обработку. Если форма 3D-тела будет обнаружена и создана, это тело будет добавлено к посадочному месту с заданными свойствами.
Предварительный просмотр пакетной операции
Позволяет просмотреть заданные 3D-тела на разных слоях.
Дополнительный элемент управления
- Execute Batch Update — нажмите, чтобы выполнить обновление каждого посадочного места, включённого в обработку. Если форма 3D-тела будет обнаружена и создана, это тело будет добавлено к посадочному месту с заданными свойствами.
Создание из выбранных примитивов
Помимо интерактивного размещения, 3D-тело можно создать из набора существующих дорожек, дуг и сплошных областей, образующих замкнутый контур. Это отличный вариант для простой модели. Чтобы создать 3D-тело из существующего замкнутого контура:
- Выберите все примитивы, образующие замкнутый контур.
- Нажмите Tools » Convert » Create 3D Body From selected primitives.
3D-тело будет создано на верхнем слое (Top Layer) по замкнутому контуру, образованному примитивами, независимо от слоя, на котором находятся выбранные дорожки. Таким образом, контур можно задать на механическом слое. Обратите внимание, что после создания области исходные выбранные примитивы сохранятся и останутся выбранными. Граница 3D-тела проходит по осевым линиям дорожек, образующих контур, а само тело не будет выбрано.
Поскольку алгоритм Create 3D Body From selected primitives использует осевые линии выбранных объектов, конечная и начальная точки соприкасающихся объектов должны точно совпадать (иметь одинаковые координаты X, Y). Если это условие не выполняется, появится диалоговое окно Confirm с указанием места, где алгоритм не смог продолжить работу. В нём также можно предложить алгоритму попытаться определить 3D-тело по краям объектов. Если выбранные объекты хотя бы немного перекрываются, этот вариант должен создать 3D-тело, граница которого будет проходить по внешнему краю выбранных объектов.
Графическое редактирование
Графический способ редактирования позволяет выбрать размещенный объект 3D-тела непосредственно в рабочей области и графически изменить его размер, форму или положение.
Чтобы выбрать экструдированное 3D-тело и перевести его в режим редактирования, щелкните по нему один раз. Внешняя форма объекта 3D-тела определяется последовательностью ребер: на концах каждого ребра находятся концевые вершины, отображаемые сплошными белыми квадратами (A на изображении ниже), а в середине — центральная вершина, отображаемая полым белым квадратом (B на изображении ниже). Каждая концевая вершина обозначает место соединения двух ребер.
Для изменения формы доступны стандартные приемы редактирования многоугольников.
При редактировании многоугольного объекта доступны три режима: Slide/Miter, Incurvate (дуга) и Move. Текущий режим можно изменить while dragging a vertex or an edge, нажимая Shift+Spacebar для циклического переключения между тремя режимами.
- Slide/Miter — нажмите и удерживайте кнопку мыши на ребре или центральной вершине, чтобы сдвинуть это ребро; нажмите и удерживайте кнопку мыши на концевой вершине, чтобы сделать скос угла.
- Incurvate — нажмите и удерживайте кнопку мыши на ребре или центральной вершине, чтобы изогнуть это ребро; нажмите и удерживайте кнопку мыши на концевой вершине, чтобы скруглить угол дугой.
- Move — нажмите и удерживайте кнопку мыши на ребре или центральной вершине, чтобы разделить это ребро на два; нажмите и удерживайте кнопку мыши на концевой вершине, чтобы свободно переместить этот угол.
Во время редактирования также можно:
- Ctrl+click and hold в любом месте ребра вне маркеров редактирования, чтобы вставить новую вершину.
- Чтобы удалить вершину, нажмите и удерживайте на ней кнопку мыши, затем нажмите клавишу Delete.
-
Щелкните в любом месте 3D-тела вне маркеров редактирования, затем перетащите его в новое положение. При перетаскивании 3D-тело можно поворачивать или зеркально отражать:
- Нажмите Spacebar, чтобы повернуть 3D-тело против часовой стрелки, или Shift+Spacebar, чтобы повернуть его по часовой стрелке. Величина Rotation Step задается на странице PCB Editor – General диалогового окна Preferences.
- Нажмите клавишу X или Y, чтобы зеркально отразить 3D-тело по оси X или Y.
Преобразование в STEP
Выбранный объект 3D-тела экструдированной, цилиндрической или сферической формы можно преобразовать в модель STEP. Модель STEP автоматически встраивается в файл проекта. Чтобы преобразовать отдельный объект 3D-тела, выберите его в рабочей области, затем щелкните правой кнопкой мыши и выберите команду Convert To STEP в контекстном меню. Команда недоступна, если ни один объект не выбран или выбрано более одного объекта. После преобразования объекта в STEP изменить его размер в рабочей области уже нельзя.

Преобразуйте экструдированное тело в STEP, если его необходимо вращать вокруг оси X или Y.
Опорная точка экструдированного, сферического или цилиндрического 3D-тела
Экструдированный, сферический или цилиндрический объект 3D-тела имеет опорную точку, или начало координат.
- Для цилиндра и сферы опорной точкой является центр круглого сечения объекта в плоскости X-Y.
- Для экструдированного объекта опорная точка задается в положении Длина по X/2, Длина по Y/2 при виде сверху.
- Именно положение этой опорной точки в рабочей области отображается в X/Y Location на панели Properties.

Экструдированные, сферические и цилиндрические объекты 3D-тел имеют опорную точку, как показано на изображениях. Обратите внимание, что линии опорной точки короткие, поэтому они могут не выходить за пределы объекта.
Добавление текстуры на экструдированное 3D-тело
На верхнюю поверхность экструдированных объектов также можно наложить изображение — это делает плату более реалистичной при просмотре в 3D. При добавлении Texture File изображение автоматически растягивается так, чтобы покрыть всю верхнюю поверхность 3D-тела, как показано ниже. Обратите внимание, что файл текстуры связан с файлом библиотеки или платы.
Поддерживаются следующие форматы файлов текстур: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; и *.tga.

На экструдированный объект 3D-тела можно добавить текстуру или логотип.
Результат можно скорректировать, изменив положение Center, а также настройки Size и Rotation в режиме 3D Body панели Properties.
Также можно изменить положение объекта текстуры, связанного с выбранной экструдированной 3D-моделью, выбрав команду Tools » 3D Body Placement » Move Texture Location в главном меню, когда редактор работает в режиме 3D-компоновки. После запуска команды курсор примет вид синих конусов (обозначающих режим выбора в 3D), и вам будет предложено выбрать экструдированное 3D-тело с текстурой. Наведите курсор на нужное 3D-тело, затем щелкните или нажмите Enter. Щелкните или нажмите Enter еще раз, чтобы «подхватить» текстуру за ближайший угол. Переместите текстуру в нужное положение, затем щелкните или нажмите Enter, чтобы разместить ее. Во время перемещения, пока текстура прикреплена к курсору, доступны стандартные дополнительные действия для перемещения объектов (Spacebar/Shift+Spacebar для поворота, X или Y для зеркального отражения, клавиши со стрелками для небольшого смещения текстуры).
Кроме того, текстуру в выбранном экструдированном 3D-теле можно переместить перетаскиванием с помощью мыши.