Проектирование 3D-MID
Краткий обзор
- Узнайте, что такое 3D-MID, как в этой технологии используется лазерное прямое структурирование (LDS) и как она позволяет проектировать трехмерные схемы в Altium Designer.
- Научитесь создавать документ 3D-MID, импортировать или заменять подложку и работать с поддерживаемыми файлами STEP и IGES.
- Ознакомьтесь с основами работы в трехмерном редакторе, включая управление камерой, параметры отображения, настройку цветов и инструменты выравнивания.
Наш инструмент 3D-MID впервые обеспечивает полноценное трехмерное проектирование электронных схем в Altium Designer, позволяя объединить электрические и механические функции в одной детали.
Документ 3D-MID интегрируется в проект Altium Designer так же, как обычная печатная плата: его компоненты и соединения определяются принципиальной схемой, а для компонентов используются стандартные посадочные места SMT из вашей привычной библиотеки.
Что такое 3D-MID?
3D-MID расшифровывается как Three-Dimensional Mechatronic Integrated Devices — трехмерные мехатронные интегрированные устройства.
При изготовлении 3D-MID рисунок схемы формируется лазером непосредственно на поверхности трехмерной подложки, которая затем проходит стандартную обработку металлизацией для формирования токопроводящих дорожек. Этот процесс, известный как прямое лазерное структурирование (LDS), позволяет встроить электронную схему в конструкцию конечного изделия.
Проектирование проводящих дорожек на поверхности трехмерной конструкции сопряжено с особыми трудностями. Рабочая область редактора должна поддерживать размещение компонентов и соединений между ними, определяющих конкретную схему. Кроме того, редактор должен позволять импортировать трехмерную подложку, на которой будет создана электронная схема, — это должен быть полноценный трехмерный редактор для проектирования электроники.
Разработчик должен иметь возможность размещать компоненты на любой поверхности импортированной трехмерной подложки. Затем он должен иметь возможность задать проводящие дорожки между выводами компонентов — этот процесс обычно называют трассировкой соединений. При этом дорожки должны проходить по поверхности подложки независимо от ориентации этой поверхности в любой точке маршрута.
Наконец, разработчик должен иметь возможность формировать производственные данные в формате, необходимом для процесса прямого лазерного структурирования (LDS).
Новый инструмент проектирования 3D-MID впервые предоставляет эти возможности в Altium Designer.
Создание документа 3D-MID
Как и стандартный документ печатной платы (PcbDoc), документ 3D-MID (PcbDoc3D) можно создать как в составе проекта, так и в виде свободного документа.
-
Чтобы создать новый документ 3D-MID в составе проекта, щелкните правой кнопкой мыши имя проекта на панели Projects, затем выберите Add New to Project » PCB3D.
-
Чтобы создать документ 3D-MID в виде свободного документа, выберите в меню File » New » PCB3D.
-
В процессе создания появится диалоговое окно с предложением выбрать файл, который будет использоваться в качестве подложки документа 3D-MID. Выбранный файл должен иметь формат STEP или IGES. Преимущество формата IGES заключается в том, что он может содержать встроенные эскизы.
После выбора файла подложка появится в окне редактирования 3D-MID. Если отменить выбор подложки, отобразится подложка по умолчанию, как показано ниже.
Если вы не открываете собственную трехмерную подложку, создается подложка по умолчанию.
Замена подложки
При необходимости трехмерную подложку можно заменить, выбрав команду File » Change Substrate в главном меню.
Если конструкция подложки изменилась, ее можно обновить.
Обработка существующих объектов при замене подложки
|
При выборе новой подложки программа сравнивает ее с существующей. Для этого положение каждой существующей поверхности сравнивается с положением соответствующей поверхности новой подложки. Если расстояние между новой и существующей поверхностями не превышает заданного порога, новая поверхность считается той же поверхностью в новом положении, и все существующие объекты топологии переносятся на нее. Если расстояние превышает порог, новая поверхность считается другой поверхностью, а объекты топологии удаляются. Пороговое значение задается параметром Advanced Option |
Работа в редакторе документов 3D-MID
Для управления камерой используются следующие действия:
- Для панорамирования перетаскивайте указатель, удерживая правую кнопку мыши.
- Для масштабирования используйте колесо прокрутки.
- Для вращения удерживайте Shift и перетаскивайте указатель, удерживая правую кнопку мыши. Центр вращения определяется положением указателя мыши в момент запуска команды.
Изменение ракурса подложки
В левом нижнем углу области проектирования находится красно-зелено-синий указатель осей — элемент ориентации вида Gizmo.
Щелкните цветную плоскость или ось в Gizmo, чтобы изменить ракурс подложки в соответствии с этой плоскостью или осью.
Gizmo
Gizmo используется для изменения ракурса подложки. Каждой оси рабочего пространства и соответствующей ей плоскости назначен свой цвет. При наведении указателя мыши на цветной элемент Gizmo он увеличивается, показывая, что активен. При щелчке по этому элементу вид переориентируется так, чтобы вы смотрели down этой оси в направлении подложки. Повторный щелчок переворачивает вид, позволяя смотреть вдоль той же оси с противоположной стороны.
- Blue — ось Z, вид на плоскость X-Y.
- Red — ось X, вид на плоскость Y-Z.
- Green — ось Y, вид на плоскость X-Z.
Управление 3D-видом
Ракурсом подложки также можно управлять через подменю 3D View Control.
- Используйте верхнюю группу команд для просмотра подложки вдоль указанной оси.
- Используйте нижнюю группу команд, чтобы Rotate или Roll подложку в выбранном направлении. Каждую из этих команд также можно вызвать с помощью сочетания клавиш, указанного на изображении ниже. При выборе команды Rotate или Roll также выполняется масштабирование, чтобы расположить подложку по центру экрана.
Изменение типа проекции
Тип проекции можно изменить с помощью команды View » Switch Perspective/Orthographic view. Перспективная проекция позволяет получить более реалистичное трехмерное представление 3D-MID. Ортографическая проекция устраняет искажения, вызванные перспективой, и обеспечивает параллельное отображение параллельных элементов.
Настройка цветов
Цвет поверхности и контура подложки, а также цвета выбранного объекта и меди можно настроить на панели View Configuration, как показано ниже. Откройте панель с помощью кнопки Panels в правом нижнем углу окна программы.
|
Цвет поверхности и контура подложки, а также цвет выбранного объекта можно настроить в разделе System Colors панели. Цвет меди можно настроить в разделе Layers панели. Новый цвет меди отобразится в графическом окне только после переключения видимости компонентов с помощью сочетаний клавиш 2 и 3. |
Инструменты выравнивания
Для размещения объектов на поверхности подложки доступны два инструмента. Можно импортировать эскиз из MCAD или воспользоваться функцией создания сетки выравнивания в редакторе 3D-MID. Отображаемые элементы эскиза можно использовать для размещения компонентов, медных дорожек и областей.
- При перетаскивании компонента указатель мыши привязывается к центру посадочного места. Затем указатель мыши (а значит, и центр компонента) привязывается к элементам эскиза.
- При выборе компонента также отображается маркер вращения. Щелкните маркер и перетащите его, чтобы повернуть компонент. Маркер будет привязываться к элементам эскиза. Подробнее об интерактивном вращении компонентов.
- При трассировке начальная и конечная точки медной дорожки привязываются к пересечениям элементов эскиза. Если указатель мыши находится вдали от пересечений, он привязывается к линиям эскиза. Если во время трассировки перемещать указатель мыши вдоль линии эскиза (в том числе кривой), дорожка будет следовать этой линии.
- Вершины и края области также можно выравнивать по сетке или импортированным эскизам.
- Оба описанных ниже инструмента можно использовать независимо друг от друга и одновременно на одной подложке.
Импорт эскиза
- При проектировании подложки в MCAD на поверхности детали можно разместить трехмерные кривые и включить их в экспортируемый файл IGES.
- Например, в Solidworks команда Project Curve позволяет разместить двумерный эскиз на трехмерной поверхности.
- Затем эти «кривые» можно включить в экспорт IGES с помощью параметра Export 3D Curve features.
- При импорте файла IGES в Altium Designer для создания подложки 3D-MID эти элементы можно отобразить, выбрав команду View » Show Sketches.
Эскизы, созданные в MCAD, отображаются красным цветом.
- Затем элементы эскиза можно использовать в качестве ориентиров при размещении компонентов и областей, а также при трассировке.
Сетка выравнивания
- В документе 3D-MID можно создать сетку на одной из трех опорных плоскостей с помощью раздела Alignment Grid панели Properties, когда в трехмерной области проектирования не выбрано ни одного объекта. Затем эта сетка проецируется с указанной плоскости на поверхности детали. Обратите внимание, что эта сетка не зависит от эскизов, импортированных вместе с подложкой.
-
Пользователь может настраивать свойства сетки. Обратите внимание, что начало координат подложки наследуется из импортированной модели STEP/IGES.
- Enable Grid - привязка к сетке выполняется только тогда, когда сетка видима.
-
Plane Kind — плоскость XY, XZ или YZ, из которой проецируется сетка выравнивания. Наследуется от модели STEP/IGES, импортированной для формирования подложки.
В качестве альтернативы можно выбрать тип плоскости UV, при котором сетка формируется на основе поверхностей подложки, а ее линии более естественно повторяют изгибы подложки (показать изображение). Тип плоскости UV позволяет выполнять трассировку вдоль более «естественных» линий на поверхности трехмерной подложки. - Horizontal/Vertical Size — шаг сетки.
- Horizontal/Vertical Offset — смещение сетки относительно начала координат подложки.
- Rotation — угол поворота сетки в выбранной плоскости (применимо только к плоскостям XY, XZ и YZ).
Привязка курсора
Редактор документов 3D-MID позволяет переопределить приоритет привязки. Элементы управления приоритетом привязки доступны по кнопке Objects for snapping на Active Bar.
Доступны два уровня привязки курсора: к сеткам и к объектам. Если привязка к объектам включена, она имеет приоритет над привязкой к сетке. Это, например, позволяет при трассировке к существующей дорожке или от нее выполнять привязку к сетке, а не к осевой линии этой дорожки: для этого включите привязку к Grids и отключите привязку к Track Lines (при условии, что сама сетка включена на панели Properties), как показано в видео ниже.
Работа с компонентами
- Если документ 3D-MID входит в состав проекта, компоненты можно синхронизировать с ним из листов схемы с помощью стандартных команд: Design » Update PCB, если вы работаете в редакторе схем, или Design » Import Changes from xxx.PrjPcb, если вы работаете в редакторе документов 3D-MID. При этом назначения цепей выводам на схеме также будут перенесены на контактные площадки компонентов 3D-MID. Обратите внимание, что в ходе этого процесса создаются правила проектирования по умолчанию. Подробнее см. в разделе Параметры проекта и правила проектирования по умолчанию на этой странице.
- После синхронизации с документом 3D-MID компоненты первоначально появляются в трехмерном пространстве рядом с телом подложки. Их можно по одному перетаскивать на поверхность подложки. По умолчанию начальная ориентация компонента на поверхности подложки зависит от траектории перемещения мыши при перетаскивании.
|
После синхронизации компонентов и цепей со схемой компоненты появляются рядом с подложкой в ее плоскости X-Y. Обратите внимание, что контактная площадка 1 имеет скругленные углы. Ориентация перемещаемого компонента при приближении к подложке спереди. Ориентация перемещаемого компонента при приближении к подложке сбоку. |
-
Компоненты также можно перетаскивать непосредственно на подложку с панели Components. При размещении компонента с панели Components ему присваивается позиционное обозначение по умолчанию, а все его контактные площадки обозначаются как
No Net. - При перетаскивании компонента курсор мыши (обозначенный зеленым крестиком) привязывается к центру посадочного места. Затем курсор (вместе с привязанным к нему центром посадочного места) привязывается к видимой сетке выравнивания. Подробнее см. в разделе Сетки и инструменты выравнивания.
- Компоненты также можно перетаскивать при скрытых трехмерных телах. Чтобы выбрать компонент, нажмите и удерживайте кнопку мыши на одной из его контактных площадок. Как только мышь начнет перемещаться, центр компонента привяжется к курсору.
-
При перетаскивании компонента в документе 3D-MID со скрытыми телами компонентов (View » Component Bodies » Hide; сочетание клавиш: 2) будет отображаться упрощенная графика (зеленые пирамиды), если число его выводов превышает предел, заданный расширенным параметром
3DLayout.ComponentDrag.DrawShapesPinsLimit(по умолчанию 15). Это сделано для повышения производительности. Значение параметра можно настроить с учетом характеристик вашего ПК. - При перетаскивании компонента Spacebar поворачивает его с шагом, определяемым углом Rotation Step, заданным на странице PCB Editor - General диалогового окна Preferences (показать изображение). По умолчанию шаг поворота составляет 90 градусов.
-
Изменение ориентации компонента при перетаскивании по различным поверхностям подложки определяется расширенным параметром
3DLayout.ComponentDrag.KeepOrientation.
|
Если установлено значение Если для расширенного параметра |
|
Щелкните компонент один раз, чтобы выбрать его. Вокруг компонента появится рамка, и станет виден маркер. Его можно использовать для интерактивной настройки ориентации компонента. Нажмите и удерживайте этот маркер, затем перетащите его в нужное положение. Маркер будет привязываться к сетке выравнивания. |
- Можно также перетаскивать несколько компонентов одновременно. Выберите несколько компонентов (используя сочетание клавиш Shift+Click или другие способы выбора), затем примените Click, Hold&Drag к выбранным объектам, чтобы переместить все выбранные компоненты одновременно. Как и при перетаскивании одного компонента, перемещение ограничивается текущими настройками привязки.
- Контактные площадки, заливки и сплошные области в составе посадочного места компонента — это медные объекты, поддерживаемые для размещения в документе 3D-MID. Это позволяет размещать на подложках компоненты с посадочными местами сложной формы, включая ВЧ-структуры (например, антенны).
- При перетаскивании компонента по поверхности подложки форма его контактных площадок создается путем переноса их геометрии из плоскости двумерного посадочного места на поверхность подложки. Если эта поверхность не плоская, полученная форма контактных площадок будет искажена. Допустимая степень искажения ограничена. При достижении этого предела контактная площадка не создается.
- Чтобы открыть свойства компонента, щелкните его тело левой кнопкой мыши. Вокруг компонента появится каркасная рамка. После этого его свойства будут доступны на панели Properties.
- После выбора компонента можно выбрать контактную площадку, повторно щелкнув левой кнопкой мыши непосредственно по ней. Затем свойства контактной площадки можно изменить на панели Properties.
- Если свойства контактной площадки недоступны для редактирования, это означает, что на странице PCB Editor - General диалогового окна Preferences включен глобальный параметр Protect Locked Primitives in Component (показать изображение). Чтобы локально отменить эту настройку и изменить контактную площадку данного компонента, выберите компонент, а не площадку (появится каркасная рамка), затем нажмите кнопку блокировки Primitives (показать изображение), чтобы разблокировать примитивы этого компонента. После завершения редактирования свойств контактной площадки не забудьте снова заблокировать примитивы компонента.
Трассировка
Трассировка — это процесс формирования медных проводников между соединяемыми выводами компонентов. При трассировке проекта каждая линия связи цепи заменяется объектами дорожек на медном слое.
Отображение линий связи
Для удобства трассировки можно включить отображение линий связи цепей (View » Connections » Show All). Линии связи отображаются между несоединенными дорожками и контактными площадками одной цепи и отражают соединения, заданные в документах схемы проекта. По умолчанию для каждой цепи алгоритм рассчитывает такую конфигурацию линий, при которой их суммарная длина минимальна.
Цветовая маркировка линий связи
- Набору линий связи каждой цепи можно назначить свой цвет, как показано ниже:
|
Чтобы назначить цвет определенной цепи, сначала... выберите контактную площадку, принадлежащую этой цепи (щелкните один раз, чтобы выбрать компонент, сделайте небольшую паузу, затем щелкните второй раз, чтобы выбрать площадку), затем нажмите гиперссылку Net на панели Properties. Нажмите значок цвета и выберите новый цвет линий связи этой цепи в появившейся палитре. Также можно найти цепь в списке на панели PCB, переключенной в режим Nets, и щелкнуть ее имя правой кнопкой мыши, чтобы открыть контекстное меню. Выберите команду Change Net Color, чтобы открыть диалоговое окно Choose Color, и выберите новый цвет. |
Переопределение цвета цепи — отображение цвета цепи на проложенных дорожках
Цвет цепи также можно использовать для уже проложенных дорожек, включив функцию Net Override Color. Эта функция позволяет управлять подсветкой проложенных цепей в документах 3D-MID с помощью собственной цветовой схемы. Вместо того чтобы отображать объект цепи цветом слоя, ему можно назначить другой определенный цвет.
Чтобы использовать функцию Net Override Color:
- Apply the required color to the net(s) — воспользуйтесь способами, описанными выше в разделе Цветовая маркировка линий связи.
-
Enable Color Override for the net(s) — переопределение цвета включается для каждой цепи с помощью флажка рядом с ее именем на панели PCB (в режиме Nets), как показано для цепи
NetR2_1на изображении ниже. Установить или снять флажки сразу для нескольких выбранных цепей можно с помощью команд Right-click » Display Override » Selected On/Off.
Подготовка к трассировке
- После прокладки дорожки между двумя контактными площадками одной цепи соответствующая линия связи исчезает. Это позволяет использовать линии связи для визуальной проверки полноты трассировки всех цепей: в полностью разведенном проекте линий связи не остается (за исключением линий между парой контактных площадок переходного отверстия). При необходимости линии связи можно скрыть с помощью команды View » Connections » Hide All.
- Поддерживается только ручная интерактивная трассировка (автоматическая трассировка в настоящее время не поддерживается).
-
Доступны два режима интерактивной трассировки:
- Ignore Obstacles — необходимо вручную избегать соединения с медными объектами другой цепи. Возможно образование коротких замыканий. В этом режиме программа работает быстро и оперативно реагирует на действия пользователя.
-
Walkaround Obstacles — алгоритм трассировки предотвращает короткие замыкания, поддерживая зазор между прокладываемой дорожкой и медными объектами другой цепи. Это требует значительных вычислительных ресурсов, поэтому обнаружение столкновения и обход препятствия могут происходить с задержкой. Для работы алгоритма курсор должен находиться за пределами объекта, принадлежащего другой цепи.
Настройка зазора между объектами и ширины дорожек
Редактор 3D-MID использует правила проектирования для задания ширины дорожек и минимально допустимого зазора между объектами, принадлежащими разным цепям.
- Чтобы задать требования к зазору и ширине дорожек, откройте PCB Rules and Constraints Editor (Design » Rules).
Настройка ограничения зазора
- Разверните дерево в левой части диалогового окна правил проектирования и выберите правило Clearance, заданное по умолчанию.
- На работу алгоритма влияют только три значения, выделенные на изображении ниже:
- Обратите внимание: контактные площадки TH (для сквозного монтажа) распознаются в документе 3D-MID как таковые, однако само отверстие не создается.
Настройка ширины дорожек
- Ширина новых дорожек определяется применимым правилом проектирования Width. 3D-трассировщик поддерживает только значение Preferred Width для слоя Top Layer. Его можно задать в общем поле Preferred Width (выделено на изображении ниже) или в поле ширины для конкретного слоя.
Параметры проекта и правила проектирования по умолчанию
В каждом новом проекте используются настройки создания правил по умолчанию, а в каждом новом документе PcbDoc3D — правила по умолчанию. Например, при настройках проекта по умолчанию во время синхронизации проекта между редактором схем и редактором PCB3D создается одно или несколько правил проектирования Placement. В результате действия этого правила размещения по умолчанию оперативная проверка DRC обнаруживает, что компоненты находятся за пределами области размещения, и подсвечивает их зеленым цветом как нарушающие правило.
- Правило проектирования Placement, заданное по умолчанию, можно удалить: щёлкните правой кнопкой мыши по правилу в PCB Rules and Constraints Editor, чтобы открыть контекстное меню, и удалите его, как показано ниже. Подробнее о правилах проектирования.
- Чтобы при синхронизации проекта между редакторами схем и 3DPCB программа не создавала правило Placement для каждого листа схемы в проекте, откройте диалоговое окно Options for PCB Project (Project » Project Options), перейдите на вкладку Class Generation и отключите параметр Generate Rooms, как показано ниже. Подробнее о параметрах проекта.
Трассировка с использованием направляющей сетки и эскизов
Поскольку трассировка соединений выполняется по поверхностям 3D-объектов сложной формы, традиционная сетка в плоскости XY, используемая при проектировании печатных плат, здесь не подходит. Вместо неё редактор 3D-MID поддерживает два типа вспомогательной геометрии: направляющую сетку и импортированные эскизы.
-
В редакторе 3D-MID Alignment Grid включается и настраивается на панели Properties, когда в рабочей области не выбрано ни одного объекта. Настройте свойства направляющей сетки в соответствии с требуемым шагом трассировки, включая:
- Plane Kind (плоскость, из которой проецируется направляющая сетка);
- Size (шаг сетки) и
- Rotation (угол поворота параллельно этой плоскости). Во время трассировки при приближении указателя мыши к направляющей сетке он будет привязываться к ближайшей линии сетки.
- Если подложка импортирована из файла IGES, любые элементы эскиза (линии и дуги), содержащиеся в этом файле IGES, также можно использовать в качестве направляющих при прокладке трасс. Если во время трассировки подвести указатель мыши к пересечению линий эскиза, он привяжется к этому пересечению. В противном случае он привяжется к ближайшей линии эскиза. Обратите внимание: эскизы можно использовать при размещении только в том случае, если они видимы. Чтобы переключить их видимость, выберите View » Show Sketches (обратите внимание, что эта команда не влияет на отображение Alignment Grid; оно настраивается на панели Properties).
Включите направляющую сетку для привязки к ней трасс.
Трассировка соединения
Чтобы начать трассировку, выберите команду меню Route » Interactive Routing, нажмите кнопку быстрого доступа в Active Bar, как показано ниже, или используйте сочетание клавиш Ctrl+W.
Трассировка — это процесс создания медных проводников между соединяемыми выводами компонентов.
Советы по трассировке
-
Запустите команду Interactive Routing. Курсор примет вид зелёного перекрестия, указывая на то, что команда интерактивной трассировки активна. Обратите внимание: при первом запуске команды в текущем сеансе редактирования между её выбором и возможностью начать трассировку может возникнуть небольшая задержка.
-
Щёлкните в любом месте нужной контактной площадки (или существующей трассы), чтобы начать трассировку. Появится сегмент дорожки: его неподвижный конец автоматически прикрепится к центру контактной площадки (или к концу существующей дорожки), а другой конец будет следовать за курсором. Сегментам дорожки, размещаемым каждым щелчком мыши, автоматически назначается цепь этой контактной площадки или существующей трассы.
-
К подвижному концу трассы будет прикреплена зелёная интерактивная линия связи. Программа автоматически соединит другой конец этой линии связи с ближайшим объектом той же цепи. Вы можете прокладывать трассу к любому объекту этой цепи, следовать расположению линий связи необязательно. Программа автоматически обновит линии связи после выхода из режима интерактивной трассировки. На изображении ниже показаны исходная линия связи бледного цвета и зелёная интерактивная линия связи при приближении трассы к целевой контактной площадке. Наведите указатель на изображение, чтобы увидеть завершённое соединение.
-
Щёлкните левой кнопкой мыши, чтобы разместить сегмент дорожки и задать фиксированную точку трассы. Затем продолжайте перемещать курсор и щёлкать мышью для размещения последующих сегментов дорожки.
-
При приближении к целевому объекту, как только курсор окажется в его границах, он привяжется к центру контактной площадки или к осевой линии существующего сегмента дорожки (либо к концу дорожки, если он ближе).
-
Во время трассировки соединения можно открыть панель Properties, включить или отключить сетку и при необходимости изменить её настройки. Это показано в видеоролике в начале данного раздела.
-
Завершив трассировку этого соединения, right-click (или нажмите Esc на клавиатуре), чтобы выйти из режима интерактивной трассировки. Обратите внимание: это действие завершает режим интерактивной трассировки; для продолжения трассировки необходимо повторно запустить команду.
-
Вы можете оставить трассу незавершённой и вернуться к ней позже. Right-click мыши, чтобы остановить трассировку.
-
Трассировку также можно начать в любом месте поверхности подложки. В этом случае для Net трассы будет задано значение
No Net, поэтому, если затем провести её к контактной площадке с назначенной цепью, возникнет нарушение зазора. По этой причине рекомендуется начинать трассировку с существующего объекта цепи. -
При необходимости на панели Properties можно изменить цепь, назначенную уже размещённым сегментам дорожки.
-
При трассировке в режиме обхода препятствий перед появлением сегментов дорожки может возникнуть задержка, когда курсор приближается к существующему объекту другой цепи. Обратите внимание: для расчёта пути трассы алгоритмом обхода курсор должен находиться за пределами объектов других цепей. Также возможна задержка между щелчком мыши и появлением дорожки.
-
Если интерактивный трассировщик, по-видимому, завис, прекратите перемещать мышь и дождитесь, пока программа завершит расчёт требуемых положений объектов. Это особенно важно при переходе с одной поверхности подложки на другую.
-
Дорожку можно редактировать перетаскиванием.
- Перетащите дорожку, чтобы добавить новую вершину.
- Перетащите вершину, чтобы переместить её.
-
Чтобы изменить ширину уже размещённого сегмента дорожки, выберите его и измените параметр Width на панели Properties.
-
Чтобы изменить ширину нескольких сегментов, удерживайте клавишу Shift и щёлкните по каждому нужному сегменту. Затем ширину всех выбранных сегментов можно изменить на панели Properties.
-
Чтобы выбрать все сегменты дорожек, области и контактные площадки цепи, выберите один объект, затем нажмите клавишу Tab.
-
Чтобы удалить уже проложенные трассы, выберите сегменты дорожек и нажмите клавишу Delete на клавиатуре.
-
Чтобы удалить трассировку всей цепи, откройте панель PCB, переключите её в режим Nets, установите флажок Select, затем выберите нужную цепь (или несколько цепей) в разделе Nets панели. Если активным элементом программы является панель, щёлкните один раз по вкладке документа PcbDoc3D в верхней части графической рабочей области, чтобы сделать документ активным элементом программы, затем нажмите клавишу Delete. Выбранные контактные площадки не будут удалены, поскольку они являются дочерними объектами компонентов и могут быть удалены только вместе с этими компонентами.
Размещение сплошной области
Поддерживается размещение сплошной области. Объект области позволяет создавать медные фигуры любой формы, при необходимости переходящие через ребра конструкции. В видео показан процесс размещения сплошной области на 3D-конструкции.
Примечания по размещению сплошной области:
- Используйте сочетания клавиш 2 (скрыть компоненты) и 3 (показать компоненты) для переключения видимости компонентов.
- Курсор привязывается как к сетке выравнивания, так и к эскизу, импортированному вместе с подложкой. Включите и настройте Alignment Grid (панель Properties) и/или эскизы (View » Show Sketches).
- Нажмите кнопку Place Solid Region на Active Bar, чтобы начать размещение сплошной области.
- Программа распознает сплошную фигуру как меньшую область, ограниченную вершинами, которые вы задаете щелчками мыши. Если задаваемая область проходит по нескольким поверхностям 3D-подложки, программа не всегда может правильно определить внутреннюю и внешнюю части области. При необходимости во время размещения можно переключать область между inside и outside и заданной вами областью, нажимая Spacebar.
- Когда все будет готово, щелкните правой кнопкой мыши, чтобы завершить размещение области. Программа автоматически создаст последнее ребро между точками последнего и первого щелчков.
- После размещения форму области нельзя редактировать интерактивно.
-
Щелкните размещенную область один раз, чтобы выбрать ее. После выбора:
- Если область требуется подключить к цепи, имя цепи можно задать на панели Properties.
- Нажмите клавишу Delete, чтобы удалить выбранные области.
- Криволинейные области можно создавать, обводя импортированный криволинейный эскиз, как показано в видео ниже. Подробнее об импорте эскиза.
- При экспорте несколько перекрывающихся областей одной цепи объединяются в одну область. В результате образуются области с вырезами, как показано в видео ниже.
Переходные отверстия в проекте 3D-MID
Переходные отверстия можно создавать в процессе изготовления 3D-MID с учетом определенных ограничений. Рекомендуется напрямую уточнить у производителя технологические возможности в этой области. Полноценная поддержка переходных отверстий в инструменте 3D-MID пока не реализована, однако их можно включить в проект следующим образом.
- В отличие от обычной печатной платы, каждую контактную площадку переходного отверстия необходимо рассматривать как компонент. Для нее нужно создать компонент с одним выводом в условном обозначении и одной соответствующей контактной площадкой в посадочном месте.
- Добавление переходных отверстий включает их ручное размещение, назначение имен цепей и трассировку. Этот процесс показан в следующем слайд-шоу.
|
Предположим, в этом примере требуется соединить две контактные площадки компонентов, обозначенные желтой линией связи, используя три дорожки и два переходных отверстия, показанные синим цветом. В отличие от обычной печатной платы, каждую контактную площадку переходного отверстия необходимо рассматривать как компонент. Для нее нужно создать компонент с одним выводом в условном обозначении и одной соответствующей контактной площадкой в посадочном месте. Перетащите два компонента контактных площадок переходных отверстий с панели Components на одну поверхность подложки. Перетащите еще два компонента контактных площадок переходных отверстий на противоположную сторону подложки, используя сетку для их совмещения с первыми двумя. Выберите одну из контактных площадок компонентов, чтобы определить имя соответствующей цепи; в этом примере — В режиме Components на панели PCB двойным щелчком откройте редактирование и назначьте уникальное значение Designator каждому переходному отверстию;
Чтобы задать свойство Net для всех этих контактных площадок 3dVia за одну операцию, сначала выберите их в разделе Components на PCB панели (обратите внимание, что флажок Select установлен), затем выберите четыре контактные площадки в разделе Component Primitives этой панели. Теперь переключитесь на панель Properties, где можно назначить имя цепи этим четырем контактным площадкам (обратите внимание: в нижней части панели указано, сколько объектов выбрано для редактирования). Линии соединений обновятся, показывая, что контактные площадки переходных отверстий теперь принадлежат той же цепи, что и контактные площадки компонентов. Выполните трассировку соединений на видимой поверхности подложки. Переверните подложку и выполните трассировку соединения на другой ее поверхности. Теперь остались только линии соединений, представляющие сами переходные отверстия. Завершить эти соединения в инструменте проектирования невозможно. Разработчик должен указать производителю, какие контактные площадки необходимо просверлить насквозь и металлизировать для формирования переходных отверстий. Если соединения в документе 3D-MID определяются документом схемы, то для согласованности двух документов компоненты контактных площадок переходных отверстий также необходимо добавить на схему и подключить к той же цепи, что и в топологии. Вместо перетаскивания компонента с панели щелкните правой кнопкой мыши и выберите Place в контекстном меню, но пока ничего не размещайте. Пока компонент прикреплен к курсору, нажмите клавишу Tab на клавиатуре, чтобы изменить позиционное обозначение размещаемого компонента на before. После этого при последующих щелчках для размещения оставшихся трех компонентов их позиционные обозначения будут автоматически увеличиваться. Подключите компоненты переходных отверстий нужным образом. Чтобы синхронизировать схему и топологию, выберите Design » Update PCB 3D Document в меню редактора схем. Откроется диалоговое окно Component Links; воспользуйтесь кнопкой, чтобы автоматически связать каждый новый компонент схемы с соответствующим компонентом 3D-MID. После нажатия OK для принятия изменений связей откроется диалоговое окно ECO с подробным перечнем всех изменений, необходимых для синхронизации документов схемы и топологии. Нажмите Execute, чтобы применить эти изменения. Чтобы убедиться в успешной синхронизации, выберите Design » Import Changes в меню редактора 3D-MID. |
Проверка правил проектирования (DRC) проекта 3D-MID
Редактор документов 3D-MID позволяет выполнять пакетную проверку правил проектирования (DRC) для выявления нарушений следующих правил в проложенных проводниках на трехмерной подложке:
Настройка проверки правил проектирования выполняется в диалоговом окне Design Rule Checker, доступном по команде Tools » Design Rule Check из главного меню.
Подробнее о настройке и запуске DRC см. на странице Настройка и запуск DRC.
Экспорт трехмерной печатной платы
После завершения проектирования проект 3D-MID можно экспортировать с помощью команды File » Export » 3D-MID. Экспортированные данные будут сохранены в локальной папке проекта.
|
Готовый проект в редакторе Altium 3D-MID; экспортированные данные, открытые в MCAD; и визуализация изделия в MCAD. Обратите внимание, что команда Export » 3D-MID не включает компоненты в экспорт. |
Настройки экспорта по умолчанию (перечисленные ниже) обычно подходят для процесса прямого лазерного структурирования, но при необходимости можно задать другие параметры с помощью соответствующих расширенных настроек (Advanced Settings).
| Параметр | Результат по умолчанию | Параметры Advanced Settings |
|---|---|---|
| Форматы | STEP IGES Parasolid |
Выберите нужный формат в диалоговом окне Export File |
| Содержимое | Подложка и проводящий рисунок
|
Только проводящий рисунок
|
| Структура | Подложка и проводящий рисунок как отдельные детали в одной сборке
|
Подложка и проводящий рисунок как отдельные элементы/тела в одной детали
|
| Толщина проводящего рисунка | 0
|
Любое значение выдавливания внутрь и/или наружу подложки
|
Также можно управлять обработкой переходов между проводящими поверхностями (сопряжений) в экспортируемом файле, изменяя значения двух параметров Advanced Settings. Чтобы быстро найти эти настройки, выполните поиск по merge в диалоговом окне Advanced Settings, как показано на изображении ниже.
Влияние этих настроек на экспортируемые данные показано в следующей таблице:
| TrackToTrackMergeMode=0 | TrackToTrackMergeMode=1 | TrackToTrackMergeMode=2 | |
|---|---|---|---|
| PadToTrackMergeMode=0 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=1 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=2 | ![]() |
![]() |
![]() |
Другие выходные данные проекта
-
Выходные данные проекта, формируемые на основе документов схемы, например спецификация (BOM), доступны в обычном режиме.
-
Выходные данные проекта, для формирования которых требуется документ печатной платы, например сборочный чертеж Draftsman, в настоящее время недоступны для документа 3D-MID.
-
При экспорте проекта 3D-MID (File » Export » 3D-MID) файл
txtустановки компонентов формируется в той же папке, что и экспортированный файл 3D-MID (STEP, IGES или Parasolid). Этот файл содержит информацию о положении каждого компонента в проекте: координаты X, Y и Z центра компонента и векторы его поворота. Векторы поворота зависят от маркера поворота компонента (который отображается при выборе компонента):- Вектор поворота 1 направлен в сторону, противоположную маркеру поворота.
- Вектор поворота 2 — это вектор нормали к поверхности в точке расположения компонента.
- Вектор поворота 3 направлен вправо относительно вектора поворота 1 при взгляде сверху (в направлении, противоположном вектору поворота 2).

Пример сформированного файла установки компонентов для трехмерной печатной платы
Расположение векторов поворота, используемых в файле установки компонентов











































