Прокладка управляемого импеданса

Краткий обзор

В этой статье объясняется, почему с ростом скорости переключения устройств трассировка с контролируемым импедансом становится всё важнее и как Altium Designer помогает устранять риски нарушения целостности сигналов до того, как они приведут к проблемам на плате. Вы узнаете, что вызывает отражения и звон сигналов, как оценить, будут ли ваши проводники вести себя как линии передачи, и как инструменты анализа целостности сигналов в Altium Designer помогают согласовывать импедансы и принимать решения по трассировке в процессе проектирования. Если вы хотите лучше понять, когда необходим контроль импеданса и как Altium Designer помогает решать эту задачу, начните с этой статьи.

- Узнайте, что представляют собой такие нарушения целостности сигналов, как отражения и звон, и почему с ростом скорости переключения трассировка с контролируемым импедансом становится всё важнее.
- Разберитесь, как оценить необходимость контроля импеданса в вашем проекте, в том числе с помощью практического правила, позволяющего определить, когда длина проводника становится критичной.
- Узнайте, как инструменты анализа целостности сигналов в Altium Designer помогают согласовывать импедансы компонентов и анализировать цепи ещё до принятия решений по трассировке.
Узнайте больше с ИИ:

С ростом скорости переключения устройств трассировка с контролируемым импедансом стала актуальной темой для разработчиков цифровой электроники. На этой странице рассказывается, как использовать механизм анализа целостности сигналов для согласования импедансов компонентов, а также возможности трассировки с контролируемым импедансом в редакторе печатных плат.

В инженерных кругах есть поговорка: специалисты по цифровой электронике делятся всего на два типа — те, кто уже столкнулся с проблемами целостности сигналов, и те, кому это ещё предстоит. Ещё не так давно целостность сигналов была темой для узких специалистов, и заниматься ею приходилось только при разработке высокоскоростных устройств. Однако скорости переключения, характерные для таких устройств, уже перестали быть чем-то особенным и стремительно становятся нормой. По мере совершенствования технологии интегральных схем размеры транзисторов уменьшаются, а скорость их переключения растёт. Именно эта скорость переключения влияет на целостность цифровых сигналов.

К счастью, многих потенциальных проблем с целостностью сигналов можно избежать, соблюдая принципы грамотного проектирования и разрабатывая плату с контролируемым импедансом. Для этого необходимы определённые возможности инструментов проектирования: средства анализа, выявляющие цепи с потенциальными проблемами звона и отражений, и средства проектирования плат, позволяющие обеспечить нужный импеданс проводников. Редактор печатных плат Altium Designer обладает этими возможностями.

Эта страница поможет вам понять, что вызывает проблемы с целостностью сигналов и насколько вероятно их возникновение на вашей плате. Здесь также рассматриваются два подхода к проектированию, которые необходимо применять для минимизации потенциальных проблем с целостностью сигналов: согласование импедансов компонентов и трассировка с контролируемым импедансом.

Controlled Impedance Routing: настройка ширины проводников и зазоров, а также свойств и размеров материалов для обеспечения требуемых значений импеданса проводников.

Когда проводники становятся частью схемы

По мере роста скорости переключения устройств повышаются и требования к разработчику и изготовителю печатной платы. Когда пространственная протяжённость фронта сигнала становится меньше длины проводника печатной платы, по которому он распространяется, проводник необходимо рассматривать как часть схемы. У этого проводника есть импеданс, который называется characteristic impedance (Zo).

Лучший способ учесть влияние этих дополнительных элементов схемы — спроектировать трассировку так, чтобы волновое сопротивление оставалось постоянным по всей длине проводника. Этот метод называется controlled impedance routing.

Импеданс проводников определяется следующими факторами:

  • Cross-sectional area of the trace — определяется шириной, высотой (толщиной меди) и наклоном боковых стенок проводника, образующихся в процессе травления.
  • Distance from the trace to the reference plane(s) — путь возврата энергии сигнала так же важен, как и путь самого сигнала. Этот обратный путь проходит вдоль сигнального проводника в соседних опорных плоскостях.
  • Properties of the surrounding materials — энергия сигнала не сосредоточена внутри меди проводника: из-за скин-эффекта она также распространяется вдоль окружающего проводник диэлектрического материала. Диэлектрическая проницаемость материала характеризует степень влияния диэлектрика на распространение этой энергии.

Калькулятор импеданса Simbeor рассчитывает значения ширины проводников, необходимые для получения заданного импеданса.   
Калькулятор импеданса Simbeor рассчитывает значения ширины проводников, необходимые для получения заданного импеданса.

Нужна ли мне трассировка с контролируемым импедансом?

Стоит ли вообще заниматься трассировкой с контролируемым импедансом, спросите вы?

В идеальном случае вся энергия, поступающая с выходного вывода компонента, должна передаваться в подключённый к нему проводник печатной платы, проходить по проводникам платы до входного вывода нагрузки на другом конце и поглощаться этой нагрузкой. Если нагрузка поглощает не всю энергию, оставшаяся часть может отражаться обратно в проводники платы и распространяться к выходному выводу источника. Эта отражённая энергия может взаимодействовать с исходным сигналом, усиливая или ослабляя его в зависимости от полярности, что приводит к звону. Если амплитуда звона достаточно велика, он нарушает целостность сигнала, вызывая непредсказуемую и ошибочную работу схемы.

Как же определить, может ли это произойти? Если на выводе источника переключение успевает завершиться до того, как сигнал достигнет вывода нагрузки, возникают условия, при которых отражённая энергия может повлиять на работу устройства. Для оценки вероятности проблем с целостностью сигналов часто используют эмпирическое правило «1/3 времени нарастания». Согласно этому правилу, если задержка распространения по проводнику превышает 1/3 времени нарастания, могут возникать отражения (звон). Если время нарастания сигнала на выводе источника составляет 1 нс, проводник с задержкой более 0,33 нс (длиной примерно 2 дюйма на FR4) необходимо рассматривать как линию передачи, в которой возможны проблемы с целостностью сигналов. Если ваши устройства имеют такое время нарастания и вы знаете, что на плате будут проводники такой длины, вы можете столкнуться с проблемами целостности сигналов.

Скорость, с которой электрическая энергия распространяется вдоль проводника, называется скоростью распространения, при этом:

Vp = скорость света / √ относительной диэлектрической проницаемости

Используем следующие значения:

Time = 1/3 * время нарастания
eR = 4 (приблизительное значение для FR4)
C = 11,811 дюйма/нс (скорость света в дюймах за наносекунду)

√ — знак квадратного корня

Чтобы определить длину проводника, при превышении которой могут возникнуть проблемы с целостностью сигнала:

LR = Time * Vp
LR = Time * C / √ eR
LR = .33 * 11.811 / 2
LR = 1.95 in

Как контролировать импедансы?

Как избежать ситуации, когда энергия многократно отражается между источником и нагрузкой? Для этого необходимо согласовать импедансы. Согласование импедансов обеспечивает передачу всей энергии от источника в проводники, а затем из проводников в нагрузку. Трассировка платы с учётом импеданса называется трассировкой с контролируемым импедансом, а плата, на которой обеспечены заданные значения импеданса, — печатной платой с контролируемым импедансом.

Согласование импедансов включает два отдельных этапа: первый — согласование компонентов, второй — трассировка платы с обеспечением требуемого импеданса.

Согласование импедансов компонентов

Невозможно создать печатную плату с контролируемым импедансом только за счёт трассировки. Сначала необходимо проверить и при необходимости согласовать импедансы компонентов.

В идеале цепи с потенциальными проблемами целостности сигналов следует выявлять на этапе разработки схемы, чтобы добавить все необходимые согласующие компоненты до начала проектирования платы. Поскольку выходные выводы имеют низкий импеданс, а входные — высокий, для согласования импедансов вам, скорее всего, потребуется добавить в проект согласующие компоненты.

Анализ целостности сигналов можно выполнить ещё на этапе разработки принципиальной схемы. При выполнении команды Tools » Signal Integrity часто появляется диалоговое окно Errors or Warnings, указывающее, что не всем компонентам назначены модели для анализа целостности сигналов. Механизм анализа целостности сигналов автоматически выбирает модели по умолчанию на основе позиционных обозначений компонентов. Нажмите Continue, чтобы использовать модели по умолчанию, или Model Assignments, чтобы просмотреть и изменить их. Диалоговое окно Signal Integrity Model Assignments можно открыть в любой момент с помощью кнопки Model Assignments на панели Signal Integrity.

Модуль анализа целостности сигналов использует значения по умолчанию для требуемого импеданса и средней длины проводников. Он также использует значения по умолчанию для параметров возбуждающего сигнала (свойств теоретического сигнала, подаваемого в цепь). Эти значения можно настроить после открытия панели Signal Integrity с помощью команды Menu button » Setup Options этой панели. Команда открывает диалоговое окно SI Setup Options (показать изображение), в котором также можно настроить цепи питания. Если проект включает печатную плату, будут проверены настройки стека слоев, а также правила проектирования для цепей питания и возбуждающего сигнала. Обратите внимание: модуль анализа целостности сигналов требует использования плоскостей питания в качестве опорных плоскостей. Он не может использовать сигнальный слой с полигональной заливкой.

Для доступа к модулю анализа целостности сигналов в Altium Designer необходимо установить системное расширение Signal Integrity Analysis. Это расширение по умолчанию устанавливается вместе с Altium Designer. Его можно установить или удалить вручную.

Подробнее об управлении расширениями см. на странице Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Анализ проекта

При выполнении команды Tools » Signal Integrity проект анализируется, а потенциально проблемные цепи отображаются на панели Signal Integrity, как показано ниже.

Проверка проекта на потенциальные проблемы с целостностью сигналов на этапе разработки схемы. Проверка проекта на потенциальные проблемы с целостностью сигналов на этапе разработки схемы.

С помощью панели можно выполнить анализ отражений для выбранной цепи или нескольких цепей. Слева представлены результаты анализа всех цепей проекта. Выберите цепь и нажмите кнопку  Button to add the selected net(s) to the analysis region of the Signal Integrity panel (или дважды щелкните имя цепи), чтобы перенести ее в поле Net в правой части панели, где можно выполнить подробный анализ этой цепи, включая:

  • Просмотр выводов этой цепи: одинарный щелчок позволяет перейти к соответствующему выводу на схеме, а двойной — проверить и настроить модель, назначенную этому выводу.
  • Включение одного или нескольких теоретических вариантов согласования для этой цепи.
  • Выполнение анализа отражений в цепи с получением набора осциллограмм, показывающих поведение сигнала на каждом выводе цепи.

Панель позволяет экспериментировать с возможными конфигурациями и параметрами согласования. Обратите внимание: в области Termination панели Signal Integrity, показанной на изображении выше, включен параметр Serial Res. В расположенной ниже части панели показан последовательный согласующий резистор. Здесь задаются минимальное и максимальное теоретические значения сопротивления последовательного согласующего резистора, которые будут использоваться при анализе отражений (снимите флажок Suggest, чтобы ввести собственные значения).

Изучение результатов

При нажатии кнопки Reflection Waveforms выполняется точный анализ отражений в этой цепи, а результаты представляются в новом окне осциллограмм (*.SDF).

Окно осциллограмм содержит:

  • Диаграмму для каждой анализируемой цепи. Для переключения между диаграммами используйте вкладки в нижней части окна.
  • Каждая диаграмма содержит график для каждого вывода этой цепи, показывающий поведение сигнала на данном выводе.

На изображениях ниже показаны два графика результатов для входного вывода цепи, выбранной на предыдущем изображении панели. Первый график показывает сигнал на входном выводе цепи без согласования; второй содержит шесть кривых: одну для исходной цепи без согласования и пять с теоретическим последовательным согласующим резистором, подключенным к выводу источника.

Было выполнено пять проходов анализа отражений (значение параметра Sweep Steps = 5) с пошаговым изменением теоретического сопротивления согласующего резистора от Min = 20 Ом до Max = 60 Ом. Эти пять проходов (первый — при 20 Ом, последний — при 60 Ом) перечислены справа от графика. Щелчок по каждой подписи выделяет соответствующий результат и отображает теоретическое значение сопротивления согласующего резистора в правом нижнем углу. Для этой цепи последовательное согласующее сопротивление 40 Ом дает график, выделенный на изображении справа.

График слева показывает результаты анализа отражений в цепи с потенциальными проблемами целостности сигналов; график справа — ту же цепь с добавленным теоретическим последовательным согласующим резистором сопротивлением около 40 Ом. Reflection analysis results when the net includes a theoretical series termination resistor, with its value being sweptГрафик слева показывает результаты анализа отражений в цепи с потенциальными проблемами целостности сигналов; график справа — ту же цепь с добавленным теоретическим последовательным согласующим резистором сопротивлением около 40 Ом.

Чтобы скрыть плавающую панель, нажмите F4, когда панель активна (ее строка заголовка выделена цветом). Нажмите F4, чтобы снова отобразить панель.

От чего зависит импеданс трассировки?

Вторая составляющая создания печатной платы с контролируемым импедансом — трассировка платы таким образом, чтобы проводники имели заданный импеданс. На импеданс сигнальных трасс влияет ряд факторов, включая размеры проводников и свойства материалов, используемых для изготовления печатной платы.

Редактор печатных плат включает модуль электромагнитного анализа целостности сигналов Simbeor® компании Simberian. Точность моделей Simbeor подтверждена с помощью передовых алгоритмов трехмерного полноволнового анализа, сравнительных испытаний и экспериментальной проверки. Модуль Simbeor поддерживает все современные структуры и материалы печатных плат.

Версия Simbeor

Эта функция доступна, когда включен параметр PCB.SimbeorVersion в диалоговом окне Advanced Settings.

Версию Simbeor, используемую для расчета задержки и импеданса, можно выбрать с помощью настроек параметра PCB.SimbeorVersion в расширенных настройках. Выберите значение «0» для использования Simbeor 2020.3 или «1» для Simbeor 2023.1.

На сайте Simberian также представлена обширная библиотека рекомендаций по применению и статей, опубликованных главным разработчиком Simberian Юрием Шлепневым, а также статей, написанных совместно с другими ведущими исследователями из промышленности и научных организаций.

Решатель Simbeor SFS

Импедансы рассчитываются с помощью Simbeor SFS — квазистатического решателя полей. Simbeor SFS — это усовершенствованный двумерный квазистатический решатель полей на основе метода моментов, точность которого подтверждена проверками сходимости, сравнением результатов и измерениями. Решатель строит сетку на границах диэлектриков и проводников и решает соответствующие уравнения для построения частотно-зависимых матриц RLGC для телеграфных уравнений.

Simbeor SFS не является полноволновым решателем, поскольку для оценки импеданса, задержки или затухания в межсоединениях печатных плат это не требуется из-за квази-ТЕМ-характера распространяющихся в них волн. Такие волны можно точно моделировать с помощью параметров RLGC, полученных двумерным квазистатическим решателем полей.

Уникальное свойство решателя Simbeor SFS — поддержка моделей шероховатости проводников. Обратите внимание: он не поддерживает модель многослойного проводника (с покрытием), а шероховатость задается одинаковой для всех проводников. Решатель является квазистатическим, поскольку решение не учитывает высокочастотную дисперсию, возникающую в микрополосковых линиях (более высокую концентрацию полей в диэлектрике с большей диэлектрической проницаемостью на высоких частотах).

► Подробнее об электромагнитной технологии анализа целостности сигналов Simberian

Поддерживаемые структуры печатных плат

Импеданс можно рассчитать для следующих структур печатных плат:

  • Микрополосковая линия
  • Симметричная полосковая линия
  • Асимметричная полосковая линия
  • Одиночные и дифференциальные копланарные структуры
  • Несколько смежных диэлектрических слоев с различными диэлектрическими свойствами.

Настройка печатной платы для трассировки с контролируемым импедансом

Трассировка с контролируемым импедансом предполагает настройку геометрических параметров проводников и свойств материалов платы для получения заданного импеданса. Это выполняется в Layer Stack Manager редактора печатных плат. Чтобы открыть Layer Stack Manager,, выберите Design » Layer Stack Manager в главном меню. Layer Stack Manager открывается в редакторе документов так же, как лист схемы, печатная плата и документы других типов.

Ширина проводника, необходимая для получения заданного импеданса, рассчитывается в рамках профиля импеданса, который настраивается на вкладке Impedance в Layer Stack Manager.

На основе следующих данных:

  • значений Target Impedance, Target Tolerance и Roughness, задаваемых на вкладке Impedance, и
  • параметров материалов, заданных на вкладке Stackup, в том числе:
    • толщины сигнального слоя,
    • толщины окружающих диэлектрических слоев (расстояний до опорных плоскостей) и 
    • свойств диэлектрического материала (диэлектрической проницаемости Dk и тангенса угла диэлектрических потерь Df).

При правильной настройке этих параметров калькулятор импеданса получает достаточно информации для расчета следующих величин:

  • Ширина проводника
  • Расчетный импеданс (Z)
  • Синфазный импеданс (Zcomm)
  • Отклонение импеданса (Z Deviation)
  • Задержка распространения (Tp)
  • Погонная индуктивность (p.u.l.)
  • Погонная емкость (p.u.l.)

Для ускорения вычислений расчет профилей импеданса выполняется в отдельных потоках, если это возможно.

Расчетные значения отображаются в разделе Transmission Line панели Properties при выборе вкладки Impedance в Layer Stack Manager, как показано ниже.

Профиль импеданса 50ОмПрофиль импеданса 50Ом, заданный для одиночных цепей, трассируемых на верхнем слое. Наведите указатель на изображение, чтобы увидеть настройки того же профиля для слоя L3 (изображение предоставлено FEDEVEL Open Source, www.fedevel.com).

Настройка стека слоев

Main page: Определение стека слоев

Медные и диэлектрические слои, используемые при изготовлении платы, настраиваются на вкладке Stackup в Layer Stack Manager.

  • На этой вкладке можно добавлять, удалять и настраивать слои. Для гибко-жестких плат на этой вкладке также можно включать и отключать слои.
  • Свойства выбранного слоя можно редактировать непосредственно в таблице или на панели Properties. Чтобы открыть панель, нажмите кнопку  Panels button, click to show or hide a workspace panel в нижней части рабочей области.
  • Чтобы добавить слой, щелкните правой кнопкой мыши в таблице слоев или воспользуйтесь командами Edit » Add Layer. При добавлении медного слоя также добавляется диэлектрический слой, если существующий смежный слой тоже является медным.
  • Если в разделе Board панели Properties включена опция Stack Symmetry, слои добавляются симметричными парами относительно центрального диэлектрического слоя.
  • Материал слоя можно ввести в выбранную ячейку Material или выбрать в диалоговом окне Select Material; чтобы открыть его, нажмите кнопку с многоточием (Ellipsis button, click to select a suitable material from the Select Material dialog).
  • К медному слою можно добавить финишное покрытие. С помощью подменю Add Layer добавьте слой Surface Finish к выбранному медному слою, затем нажмите кнопку с многоточием для нового слоя финишного покрытия, чтобы выбрать тип покрытия.
  • Выбранный слой можно перемещать вверх или вниз среди слоев того же типа с помощью контекстного меню или меню Edit.
  • В области Board панели Properties доступны опции для принудительного соблюдения Stack Symmetry и Library Compliance. Подробнее о них — ниже.
  • В области Board панели Properties отображаются сводные сведения о выбранном стеке (или подстеке для гибко-жесткой платы с несколькими стеками).

Рекомендации по формированию стека слоев

Основное требование для обеспечения контролируемого импеданса — наличие пути возвратного тока под каждым сигнальным проводником. Расчетный модуль Simbeor SI поддерживает как слои-плоскости, так и сигнальные слои с полигонной заливкой. Эти слои возвратного тока следует распределить по стеку платы. В идеале рядом с каждым сигнальным слоем, на котором выполняется трассировка с контролируемым импедансом, должен находиться хотя бы один слой возвратного тока. Смежный слой обеспечивает путь возвратного тока сигнала, причем по причинам, которые здесь не рассматриваются, это происходит независимо от постоянного напряжения, подаваемого по этой плоскости.

Возвратный ток в плоскости стремится следовать по тому же физическому пути, что и проводник на сигнальном слое. Поэтому важно не допускать разрывов, например разделений или вырезов, в слое возвратного тока под критически важными сигнальными проводниками.

Помимо выбора подходящего порядка сигнальных слоев и слоев-плоскостей, необходимо задать свойства материалов каждого слоя, в том числе:

  • Толщину меди
  • Толщину диэлектрика
  • Диэлектрическую проницаемость

Все эти значения, а также ширина проводника влияют на итоговый импеданс. Таким образом, получение требуемого импеданса сводится к подбору всех этих параметров. Помните, что допустимые значения толщины меди и диэлектрика также могут быть ограничены материалами, доступными у изготовителя печатных плат.

► Подробнее о возможных стеках слоев

Определение профилей импеданса

Расчетный модуль Simbeor встроен в Layer Stack Manager редактора печатных плат (Design » Layer Stack Manager). Чтобы настроить стек слоев для трассировки с контролируемым импедансом, перейдите на вкладку Layer Stack Manager's Impedance, где можно добавить и настроить профиль импеданса.

Профиль импеданса 50 Ом, заданный для отдельных цепей, трассируемых на верхнем слое. Наведите указатель на изображение, чтобы увидеть настройки того же профиля для слоя L3.Профиль импеданса 50 Ом, заданный для отдельных цепей, трассируемых на верхнем слое. Наведите указатель на изображение, чтобы увидеть настройки того же профиля для слоя L3.

Примечания по созданию и настройке профиля импеданса:

  1. В Layer Stack Manager перейдите на вкладку Impedance, как показано выше.
  2. Нажмите кнопку Add Impedance Profile button, appears when there are no impedance profiles defined (или кнопку Plus button, click to add an additional impedance profile, если профиль уже задан), чтобы добавить новый профиль.
  3. Задайте требуемые параметры импеданса Type, Target Impedance и Target Tolerance на панели Properties. Параметр Description необязателен; он будет отображаться везде, где отображается имя профиля импеданса.
  4. Таблица слоев разделена на две области: слева отображаются слои стека, а справа, в области профиля импеданса, — соответствующая строка для каждого сигнального слоя стека. Установите флажок слоя в области профиля, чтобы включить расчет импеданса для этого слоя. В примере на изображении выше, если ориентироваться на номера слоев в крайнем левом столбце, флажки установлены для слоев L1, L3, L10 и L12, поэтому для них включен расчет импеданса.
  5. При щелчке по включенному слою в области Profile все слои стека, кроме используемых для расчета импеданса выбранного сигнального слоя, отображаются бледнее (как показано на изображении выше). Изменить опорные слои для этого слоя можно в столбцах Top Ref и Bottom Ref области Impedance Profile . Обратите внимание, что опорные слои могут иметь Type типа Plane или Signal. Например, на изображении выше слой L10 в стеке включен в расчет импеданса: для Top Ref задано значение 9-L9, соответствующее слою Plane, а для Bottom Ref — значение 11-L11, соответствующее слою Signal. Программа предполагает, что сигнальный слой, используемый в качестве опорной плоскости, содержит сплошной медный полигон, подключенный к цепи питания или земли.
  6. Установите флажок Impedance Profile для каждого другого слоя, на котором будет выполняться трассировка с этим импедансом, и настройте опорные плоскости. Наведите курсор на изображение выше, чтобы отобразить профиль импеданса S50 для слоя L3.
  7. Если расчетная ширина проводника не может быть обеспечена при изготовлении, можно скорректировать настройки ширины и зазора.

Корректировка настроек ширины и зазора

Программа рассчитывает ширину проводника на основе целевого импеданса и допуска. Нередко расчетная ширина проводника оказывается такой, которую невозможно обеспечить при изготовлении, например 0,0683 мм. Изготовитель сообщит, какая толщина материалов доступна и с какой точностью он может выдержать ширину проводников. После этого следует, отталкиваясь от требуемых значений, проверить, как приведение размеров к доступным значениям влияет на расчетный импеданс.

Для проверки и корректировки настроек калькуляторы импеданса поддерживают прямой и обратный расчет. По умолчанию используется прямой расчет: вы вводите импеданс, а программа рассчитывает ширину. Значок  указывает на рассчитываемую переменную.

При целевом импедансе 50Ом  При целевом импедансе 50Ом прямой расчет дает ширину (W1) 94,6 мкм. На изображении справа показан обратный расчет при заданной ширине (W1) 95 мкм.

Чтобы перейти к обратному расчету и проверить разные значения ширины проводника для выбранного слоя, введите новое значение Width (W1) и нажмите Enter на клавиатуре. Расчетные значения обновятся с учетом изменения ширины. Нажмите кнопку  , чтобы вернуть калькулятор в режим прямого расчета. Ввод нового значения в Width (W2) изменит значение Etch.

Чтобы исследовать результаты расчета линии передачи дифференциальной пары, выберите рассчитываемую переменную — Trace Width или Trace Gap — нажав соответствующую кнопку . Измените другую переменную, чтобы изменить Target Impedance, либо измените Target Impedance, чтобы оценить влияние на другую переменную.

Нажмите Enter на клавиатуре, чтобы применить значение, введенное в поле панели.

Коэффициент травления

Сигнальные проводники на печатной плате изготавливаются путем вытравливания лишней меди. Поскольку травление начинается с поверхности, медь на поверхности дольше контактирует с травителем. В результате боковые стенки готового проводника получаются наклонными, что уменьшает площадь его поперечного сечения, как показано на изображении ниже.

Площадь сечения меди, удаленной с краев проводника (с обеих сторон) при травлении = X * Y

Степень наклона характеризуется коэффициентом травления (Etch Factor), где:

Etch Factor = Y/X

Если Y = X, то Etch Factor = 1

На изображении, показанном на панели Properties:

Наведите курсор на знак ?, чтобы отобразить формулу.Наведите курсор на знак ?, чтобы отобразить формулу.

В стандартном определении коэффициент травления задается как отношение  trace thickness / amount of over-etching. Это дает следующую формулу:

Etch Factor = T/[0.5(W1-W2)]

Недостаток такого подхода заключается в том, что для задания отсутствия бокового подтравливания (то есть вертикальных боковых стенок проводника) пришлось бы ввести значение коэффициента травления inf (бесконечность). Чтобы упростить задание степени травления, формулу инвертировали: теперь для обозначения отсутствия бокового подтравливания можно ввести значение 0 (ноль).

Etch = [0.5(W1-W2)]/T

  • Чтобы исключить коэффициент травления из расчетов (указать, что боковые стенки проводника не имеют наклона), задайте значение 0 (zero). Обратная величина коэффициента травления используется для упрощения настройки при отсутствии бокового подтравливания.
  • Сведения о коэффициенте травления, характерном для используемого технологического процесса, уточняйте у изготовителя платы.

Ориентация меди

Еще одна технологическая особенность, связанная с коэффициентом травления, — ориентация меди. Проводники печатной платы формируются путем вытравливания лишней меди из сплошного медного листа, ламинированного на диэлектрическую подложку. Ориентация меди определяет направление, в котором медь выступает относительно этой подложки. Это также можно рассматривать как направление, с которого выполняется травление меди: сверху или снизу.

Установите или снимите флажок Trace Inverted, чтобы переключить ориентацию меди с Above на Below.  Установите или снимите флажок Trace Inverted, чтобы переключить ориентацию меди с Above на Below.

Ориентацию меди можно изменить на панели Properties: в разделе Transmission line (при активной вкладке Impedance) или в разделе Layer (при активной вкладке Stackup). Ее также можно изменить в таблице Layer Stack Manager, если в ней отображается столбец Copper Orientation.

Для медных слоев также предусмотрен параметр Orientation. Это поле определяет, с какой стороны данного медного слоя устанавливаются компоненты. Настройте этот параметр, если в жестко-гибкой конструкции компоненты устанавливаются на внутреннем или гибком слое либо если в проекте используются встроенные компоненты, чтобы указать ориентацию компонента относительно этого медного слоя.

► Подробнее: Определение и настройка стеков жестко-гибкой платы

► Подробнее: Встроенные компоненты

Шероховатость поверхности проводника

Поверхность каждого медного слоя печатной платы имеет определенную шероховатость. При изготовлении платы поверхность медных слоев обрабатывают для увеличения шероховатости и улучшения сцепления между медью и диэлектриком. При скоростях переключения выше 10 ГБ/с эта шероховатость начинает существенно влиять на импеданс проводника. На основе обширных исследований и анализа специалисты отрасли пришли к выводу, что шероховатость поверхности можно моделировать с помощью поправочного коэффициента, вычисляемого на основе значений Surface Roughness и Roughness Factor.

RoughnessНастройки доступны в режиме Layer Stack Manager панели Properties . Эти параметры используются только для проводящих слоев.

Шероховатость поверхности учитывается при расчете волнового сопротивления.Шероховатость поверхности учитывается при расчете волнового сопротивления.

Шероховатость:

  • Model Type — предпочтительная модель для расчета влияния шероховатости поверхности (подробнее о различных моделях см. в статьях ниже). Применяется ко всем медным слоям в стеке.

  • Surface Roughness — значение шероховатости поверхности (можно получить у изготовителя). Введите значение от 0 до 10 мкм; по умолчанию — 0,1 мкм.

  • Roughness Factor — характеризует ожидаемое максимальное увеличение потерь в проводнике из-за шероховатости. Введите значение от 1 до 100; по умолчанию — 2.

Дополнительные материалы

Поддержка копланарных линий передачи

Калькулятор импеданса в Layer Stack Manager поддерживает одиночные и дифференциальные копланарные структуры. Создайте новый профиль импеданса, затем выберите Single-Coplanar или Differential-Coplanar в раскрывающемся списке Impedance Profile Type.

Работа с копланарными структурами:

  • Как и для стандартных одиночных и дифференциальных линий, значения всех переменных автоматически рассчитываются на основе заданных пользователем Target Impedance и Target Tolerance и физических свойств слоев платы. Эти автоматически рассчитанные значения можно скорректировать, введя новые значения в поля редактирования в режиме Layer Stack Manager панели Properties.
  • Чтобы указать сигнальные цепи, которые необходимо трассировать с использованием копланарной структуры, настройте правило проектирования Ширина трассировки (или Трассировка дифференциальных пар), включив опцию Use Impedance Profile и выбрав требуемый профиль копланарного импеданса.
  • Для копланарных структур необходима опорная плоскость с обеих сторон сигнальной трассы. Ее можно создать с помощью размещенного полигона или, при добавлении сшивающих переходных отверстий, с помощью команды Add Shielding to Net (подробнее см. ниже). При размещении полигона расстояние между ним и сигнальной трассой определяется значением Clearance (S), рассчитанным калькулятором импеданса Simbeor (отображается на панели Properties, показанной на изображениях выше и ниже). Настройте правило проектирования зазоров, чтобы задать зазор между опорным полигоном и сигнальной трассой (показать изображение).
  • Для заземленной копланарной структуры обычно размещают ряд переходных отверстий вдоль каждой стороны сигнальной дорожки. Для этого используйте команду Tools » Via Stitching/Shielding » Add Shielding to Net в редакторе печатных плат. Помимо размещения переходных отверстий, эта команда при включенной опции Add shielding copper может также разместить вокруг сигнальной трассировки полигон, охватывающий ряды переходных отверстий, как показано на изображении справа внизу.
    ► Подробнее об экранировании переходными отверстиями

Калькулятор импеданса определяет параметры сигнала и зазоры (первое изображение). Используйте полученный зазор в параметре Distance при настройке экранирования переходными отверстиями.  Калькулятор импеданса определяет параметры сигнала и зазоры (первое изображение). Используйте полученный зазор в параметре Distance при настройке экранирования переходными отверстиями.

Выбор материала слоя

При проектировании с контролируемым импедансом выбор материалов для стека слоев имеет очень большое значение.

Например, наиболее распространенный материал для изготовления печатных плат — эпоксидная смола, армированная стекловолокном (стеклотекстолит), с медной фольгой, приклеенной с обеих сторон. Плотность переплетения стеклоткани влияет на величину и стабильность диэлектрической проницаемости Dk и тангенса угла диэлектрических потерь Df. Стеклоткань окружена смолой, процентное содержание которой также существенно влияет на характеристики материала.

Существует множество вариантов переплетения стеклоткани. Чтобы обеспечить предсказуемость и стабильность характеристик материалов на основе стекловолокна, используемых при изготовлении печатных плат, IPC разработал стандарт на типы переплетения:

IPC standard IPC-4412B: Specification for Finished Fabric Woven from "E" Glass for Printed Boards

  • Номера типов переплетения, приведенные в стандарте, соответствуют значениям Constructions, отображаемым в диалоговом окне Altium Material Library.
  • Если структура слоев симметрична, включите опцию Stack Symmetry в разделе Board панели Properties. При каждом добавлении слоя в другой половине стека автоматически добавляется парный слой. 

Библиотека материалов

Как разработчик, вы можете редактировать свойства материалов непосредственно в Layer Stack Manager или выбирать материалы из Altium Material Library.

Всю библиотеку можно просмотреть (и дополнить) в диалоговом окне Altium Material Library (Tools » Material Library).

Материалы организованы в категории по назначению, доступные через древовидную структуру в левой части диалогового окна. На следующем уровне каждая категория по назначению разделена на функциональные категории, например Conductive layer material, Dielectric layer material, и Surface Layer Material iв категории PCB layer material.

Добавление, сохранение и загрузка материалов

Новый материал можно добавить в библиотеку, выбрав определенную категорию материалов в дереве. Материалы, заданные во внешней библиотеке, можно загрузить (кнопка Load), а пользовательские материалы, добавленные в диалоговом окне Altium Material Library, можно сохранить в пользовательскую библиотеку (кнопка Save). Сохраняются только пользовательские материалы.

Добавление пользовательских свойств материалов

К материалам, представленным в библиотеке (как стандартным, так и пользовательским), можно добавлять пользовательские свойства. Чтобы добавить пользовательское свойство, сначала выберите соответствующий узел в дереве слева, указав материалы, к которым оно будет добавлено, затем нажмите кнопку  , чтобы открыть диалоговое окно Material Library Settings.

Затем требуемое значение можно добавить для выбранного материала в диалоговом окне Altium Material Library: выберите строку и нажмите кнопку Edit.

Поведение диэлектрических материалов

Значения Dk/Df диэлектриков печатных плат зависят от частоты: у композитных диэлектриков Dk уменьшается с ростом частоты, а Df немного увеличивается (из-за релаксационного характера атомной поляризации в таких диэлектриках).

Частотную дисперсию можно описать многополюсной моделью Дебая, для построения которой требуются данные на нескольких частотах. Для диэлектриков печатных плат была разработана более простая модель с непрерывным распределением полюсов, называемая моделью Джорджевича — Саркара, или широкополосной моделью Дебая. Эта модель является аналитической и причинной, и для ее построения достаточно измерить Dk/Df всего на одной частоте. Такой подход значительно проще, но при этом сохраняет точность (подробнее см. Material World tutorial #2016_01 в библиотеке технических презентаций Simberian).

Калькулятор импеданса Layer Stack Manager's использует широкополосную модель Дебая с частотой по умолчанию 1 ГГц. Если требуется другая частота, возьмите из спецификации ламината значения Dk/Df для одной частоты в диапазоне от 1 до 10 ГГц, а затем используйте значение волнового сопротивления, рассчитанное на частоте 1 ГГц.

  • Во всех расчетах по умолчанию используется частота 1 ГГц.
  • Если Df не задан, по умолчанию используется нулевое значение.

Панель Properties

Когда в документе Layer Stack активна вкладка Impedance, панель Properties позволяет настроить требования к профилю импеданса. Затем требуемый профиль импеданса можно выбрать в правилах проектирования Routing Width или Differential Pairs Routing.

  • Impedance Profile
    • Description — введите содержательное описание. Это необязательное поле, которое отображается везде, где отображается имя профиля импеданса.
    • Type — выберите тип импеданса в раскрывающемся списке. Доступные варианты: Single, Differential, Single-Coplanar и Differential-Coplanar.
При работе с копланарными структурами и стандартными одиночными/дифференциальными линиями значения всех переменных автоматически рассчитываются на основе заданных пользователем Target Impedance и Target Tolerance и физических свойств слоев платы. Эти автоматически рассчитанные значения можно скорректировать, введя новые значения в поля редактирования в режиме Layer Stack Manager панели Properties.
  • Target Impedance — введите требуемое значение импеданса.
  • Target Tolerance – введите требуемый допуск. Согласуйте с изготовителем реалистичное значение допуска, которое он сможет обеспечить.
  • Transmission Line
    • Trace inverted – включите этот параметр, чтобы перевернуть проводник, как показано на панели Properties. Этот параметр аналогичен параметру Copper Orientation, отображаемому при активной вкладке Stackup, и определяет направление ламинирования меди на сердечник. Ориентация меди определяет, в какую сторону медь выступает относительно этой подложки. Это также можно рассматривать как направление, с которого выполняется травление меди: сверху или снизу.
    • Etch – коэффициент травления равен = T/[(W1-W2)/2], что уменьшает общую площадь поперечного сечения проводника на квадрат толщины меди. Уточните у изготовителя платы значение Etch, обеспечиваемое его технологическими процессами.
Чтобы исключить Etch из расчётов (т. е. считать, что боковые стенки проводника не имеют наклона), установите значение 0.
  • Width (W1) / (W2) – W1 — ширина прокладываемого проводника, W2 — ширина его верхней поверхности после травления с учётом коэффициента Etch. Для ширины проводника доступны прямой и обратный расчёт. По умолчанию ширина рассчитывается на основе введённого значения Target Impedance (прямой расчёт). Полученное значение, например 5,978, может оказаться неудобным для изготовления, и изготовитель предпочтёт более подходящее значение, например 6,0. Можно ввести 6,0 в поле Width и нажать Enter на клавиатуре, чтобы пересчитать вычисляемые значения (Impedance, Deviation и т. д.). Кнопка станет серой (неактивной), и будет включён режим обратного расчёта. Если нажать эту кнопку, сделав её активной, снова включится режим прямого расчёта, а Width (W1) вернётся к рассчитанному значению. Эта функция позволяет подбирать технологически реализуемые значения ширины. При ручном вводе значения W2 коэффициент травления будет соответствующим образом пересчитан.
  • Impedance – программа рассчитывает импеданс на основе свойств материалов платы (меди, сердечника и препрега) и площади поперечного сечения проводника, определяемой его шириной, толщиной и коэффициентом травления.
  • Deviation – это мера разницы между требуемым (целевым) и полученным (расчётным) импедансом. Программа рассчитывает отклонение импеданса (то, что фактически будет получено при заданных материалах и размерах) на основе свойств материалов платы (меди, сердечника и препрега) и площади поперечного сечения проводника, определяемой его шириной, толщиной и коэффициентом травления.
  • Delay – время прохождения сигнала от передатчика к приёмнику.
  • Inductance – калькулятор импеданса использует значение Impedance для расчёта погонной индуктивности.
  • Capacitance – калькулятор импеданса использует значение Impedance для расчёта погонной ёмкости.
  • Board
    • Stack Symmetry – включите этот параметр, чтобы добавлять слои симметричными парами относительно центрального слоя диэлектрика. При включении параметра сразу выполняется проверка симметрии стека относительно центрального слоя диэлектрика. Если какие-либо два слоя, равноудалённые от центрального опорного слоя диэлектрика, не идентичны, открывается диалоговое окно «Стек несимметричен».
    • Library Compliance – если этот параметр включён, для каждого слоя, материал которого выбран из библиотеки материалов, текущие свойства слоя сравниваются со значениями, заданными для этого материала в библиотеке.
Если Stack Symmetry включён:
– Изменение свойства слоя автоматически применяется к парному симметричному слою.
– При добавлении слоёв автоматически добавляются соответствующие симметричные слои.
  • Substack – сведения о выбранном в данный момент подстеке (слоях, диэлектриках, толщинах и т. д.). При переключении между подстеками эти сведения обновляются в соответствии с текущим выбором.
Область Substack доступна только в том случае, если в раскрывающемся списке Features включён параметр Rigid/Flex.
  • Stack Name – введите понятное имя подстека. Это поле удобно использовать при назначении подстека слоёв области стека X/Y.
  • Is Flex – включите этот параметр, если подстек является гибким.
  • Layers – общее количество слоёв.
  • Dielectrics – общее количество слоёв диэлектрика.
  • Conductive Thickness – толщина проводящего слоя или слоёв. Медные сигнальные слои называются проводящими слоями.
  • Dielectric Thickness – толщина слоя или слоёв диэлектрика.
  • Total Thickness – общая толщина платы.
  • Other
  • Roughness – шероховатость проводящих слоёв.
    • Model Type – предпочтительная модель для расчёта влияния шероховатости поверхности (подробнее о различных моделях см. в статьях ниже). Применяется ко всем медным слоям стека (возможно, имеется в виду подстек?).
    • Surface Roughness – значение шероховатости поверхности (его можно получить у изготовителя). Введите значение от 0 до 10 мкм; значение по умолчанию — 0,1 мкм.
    • Roughness Factor – характеризует ожидаемое максимальное увеличение потерь в проводнике из-за шероховатости. Введите значение от 1 до 100; значение по умолчанию — 2.

Настройка правил проектирования

Импеданс проводника определяется его шириной и толщиной, а также свойствами окружающих диэлектрических материалов. На основе свойств материалов, заданных в Layer Stack Manager, при создании каждого профиля импеданса рассчитывается необходимая ширина проводников. В зависимости от свойств материалов ширина может меняться при переходе на другой слой трассировки. Необходимое изменение ширины при смене слоя трассировки автоматически обеспечивается соответствующим правилом трассировки, настроенным в редакторе правил и ограничений печатной платы PCB Rules and Constraints Editor (Design » Rules).

В большинстве проектов плат определённый набор цепей трассируется с контролируемым импедансом. Обычно для этого создают класс цепей или класс дифференциальных пар, включающий эти цепи, а затем — правило трассировки, действующее на этот класс, как показано на изображениях ниже.

Обычно значения Min, Max и Preferred Widths задают вручную: либо в верхней области настроек ограничений, чтобы применить их ко всем слоям, либо отдельно для каждого слоя в таблице слоёв. Для трассировки с контролируемым импедансом вместо этого включите параметр Use Impedance Profile и выберите нужный профиль импеданса в раскрывающемся списке. После этого область Constraints правила изменится. Прежде всего вы заметите, что в области доступных слоёв больше не отображаются все сигнальные слои платы. Теперь в ней будут показаны только слои, включённые в выбранном профиле импеданса. Значения Preferred Width (и зазора дифференциальной пары) обновятся в соответствии с ширинами (и зазорами), рассчитанными для каждого слоя. Эти предпочтительные значения нельзя изменить, однако значения Min и Max редактируются. Задайте для них подходящие меньшие и большие значения соответственно. После этого цепи можно трассировать интерактивно обычным способом.

  • При применении профиля импеданса все остальные сигнальные слои исключаются из ограничения правила проектирования, поскольку предполагается, что цепи, на которые оно распространяется, будут трассироваться только на слоях этого профиля.
  • Предпочтительная ширина фиксируется на значениях, рассчитанных в профиле импеданса; минимальную и максимальную ширину по-прежнему может задавать пользователь.
  • Если размеры заданы в метрических единицах, значения Min Width и Max Width может потребоваться немного уменьшить и увеличить соответственно, чтобы избежать ложных нарушений правил проектирования из-за ошибок округления.

Правило проектирования ширины трассировки

Для одиночных цепей ширина трассировки определяется правилом проектирования Ширина трассировки.

При выборе параметра Use an Impedance Profile доступные слои и предпочтительные значения ширины определяются выбранным профилем.При выборе параметра Use an Impedance Profile доступные слои и предпочтительные значения ширины определяются выбранным профилем.

Правило проектирования трассировки дифференциальных пар

Трассировка дифференциальных пар определяется правилом проектирования Трассировка дифференциальных пар.

Для дифференциальной пары доступные слои, предпочтительная ширина и предпочтительный зазор определяются выбранным профилем.Для дифференциальной пары доступные слои, предпочтительная ширина и предпочтительный зазор определяются выбранным профилем.

► Подробнее о трассировке дифференциальных пар

Правило проектирования обратного пути тока

Разрывы или сужения обратного пути тока можно обнаружить с помощью правила проектирования обратного пути тока. Это правило проверяет непрерывность обратного пути сигнального тока на заданных опорных слоях выше или ниже сигнальных проводников, к которым применяется правило. Обратный путь тока может быть сформирован заливками, областями и полигонными заливками, размещёнными на опорном сигнальном слое или слое сплошной металлизации.

Слои обратного пути тока — это опорные слои, заданные в Impedance Profile, выбранном в правиле проектирования Return Path. Эти слои проверяются на наличие заданного Minimum Gap (ширины за пределами края сигнального проводника) вдоль пути сигнала. Добавьте новое правило проектирования Return Path в категории правил High Speed.

Слои обратного пути тока определяются в выбранном Impedance Profile, а ширина пути (за пределами края сигнального проводника) задаётся параметром Minimum Gap.Слои обратного пути тока определяются в выбранном Impedance Profile, а ширина пути (за пределами края сигнального проводника) задаётся параметром Minimum Gap.

На изображении ниже показаны ошибки обратного пути тока, обнаруженные для сигнала NetXпри значении параметра Minimum Gap, равном 0.1mm. Чтобы упростить поиск ошибок обратного пути тока, можно настроить DRC Violation Display Style на отображение подробностей нарушения (Violation Details), отключив наложение индикации нарушения (Violation Overlay) (показать изображение) в диалоговом окне Preferences. В этом случае подсвечиваются конкретные места нарушения правила, а не объекты с нарушениями целиком. 

Чтобы исключить обнаружение незначительных ошибок, таких как выделенный участок диагонального сегмента дорожки на изображении выше, настройте параметр PCB.Rules.ReturnPathIgnoreArea в диалоговом окне расширенных настроек. По умолчанию игнорируются области < 10 sq mils.

► Подробнее о проектировании высокоскоростных устройств в Altium Designer

Трассировка цепей с требуемым импедансом

При трассировке платы и переходе между слоями программа автоматически изменяет ширину дорожки до значения, необходимого для получения заданного импеданса. Такая интерактивная трассировка с контролируемым импедансом значительно упрощает проектирование печатных плат с контролируемым импедансом.

Ни калькулятор импеданса Simbeor, встроенный в Layer Stack Manager, ни модуль анализа целостности сигналов не учитывают переходные отверстия в своих расчётах. Подробнее о задании типов переходных отверстий.

Подстройка длины трасс

Две основные задачи при трассировке высокоскоростных устройств — контроль импеданса трасс и согласование длин критически важных цепей. Трассировка с контролируемым импедансом обеспечивает корректный приём сигнала, поступающего с выходного вывода, целевыми входными выводами. Согласование длин трасс обеспечивает одновременное поступление критичных по времени сигналов на целевые выводы. Подстройка и согласование длин трасс также являются важнейшей составляющей трассировки дифференциальных пар.

Для согласования длин проводников дифференциальных пар в трассировку добавлены меандры. Для согласования длин проводников дифференциальных пар в трассировку добавлены меандры.

Команды Interactive Length Tuning и Interactive Diff Pair Length Tuning (меню Route) предоставляют интерактивные средства оптимизации и управления длинами цепей или дифференциальных пар: они позволяют вставлять волнообразные участки переменной амплитуды (меандры) с учётом доступного пространства, правил и препятствий в проекте.

► Подробнее о подстройке длины

Проверка целостности сигналов на разведённой плате

Подобно тому как вы проверяли цепи на этапе разработки схемы, используя предполагаемые длину и импеданс трассировки, после завершения трассировки следует повторить эту проверку для платы, чтобы выявить возможные рассогласования импеданса и проблемы с отражениями. Запустите команду Signal Integrity из меню Tools редактора печатных плат. Поскольку печатная плата входит в состав проекта, для расчёта импедансов при проверке целостности сигналов будут использоваться свойства материалов и размеры, заданные в Layer Stack Manager, а также фактическая ширина трасс на плате.

Обеспечение заданных импедансов

Помимо итеративного подбора геометрических размеров для получения требуемых импедансов, на итоговый импеданс изготовленной печатной платы влияют и другие факторы. К ним относятся однородность и стабильность диэлектрического материала платы, а также стабильность и качество процесса травления. Если вам требуется печатная плата с контролируемым импедансом, обсудите это с изготовителем. Некоторые изготовители могут порекомендовать геометрию дорожек, если вы предоставите им желаемую структуру слоёв. Многие также могут разместить на каждой изготавливаемой групповой заготовке тестовый купон для контроля импеданса — с его помощью можно измерить фактические значения импеданса, полученные на плате.

Дополнительные материалы и ресурсы

Эта статья знакомит с темой целостности сигналов и проектирования печатных плат с контролируемым импедансом. Перейдите по следующим ссылкам, чтобы узнать больше и ознакомиться с материалами признанных отраслевых экспертов.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents