Методы размещения и редактирования печатных плат
Краткий обзор
- Узнайте, чем примитивы отличаются от групповых объектов и как это влияет на их размещение и обработку в редакторе печатных плат.
- Освойте общий порядок редактирования до, во время и после размещения, включая настройку параметров по умолчанию, доступ к свойствам через Properties и переключение отображаемых единиц измерения.
- Ознакомьтесь с командами выбора объектов печатной платы, которые помогают работать с перекрывающимися объектами, логическими иерархиями цепей, связанной медью и выбирать элементы трассировки, относящиеся к компонентам.
При проектировании печатной платы можно использовать различные объекты. Большинство объектов, размещаемых в документе печатной платы, определяют области меди или вырезы в них. Это относится как к электрическим объектам, например дорожкам и контактным площадкам, так и к неэлектрическим, например тексту и размерам. Поэтому важно учитывать ширину линий, которыми задаётся каждый объект, и слой, на котором он размещён.
В редакторе печатных плат есть два типа объектов: примитивы и групповые объекты:
-
Примитивы — это базовые элементы проекта: дорожки, контактные площадки, переходные отверстия, заливки, дуги и текстовые объекты. Они называются «примитивами», поскольку представляют собой простейшие элементы.
-
Любой объект, состоящий из примитивов и распознаваемый как объект проекта, является групповым объектом. К групповым объектам относятся компоненты, размеры и полигональные заливки. В рабочей области проекта с групповым объектом можно работать как с единым целым. Например, его можно размещать, выбирать, копировать, изменять, перемещать и удалять.
Общие принципы размещения и редактирования объектов
В Altium Designer процесс размещения объектов практически одинаков независимо от их типа. В простейшем случае он выглядит следующим образом:
-
Выберите объект для размещения на одной из панелей инструментов или в меню Place .
-
С помощью мыши задайте положение размещаемого объекта в рабочей области редактора печатных плат и его размер (если применимо).
-
Щёлкните правой кнопкой мыши (или нажмите Esc), чтобы завершить команду и выйти из режима размещения.
Редактирование до размещения
Свойства объекта по умолчанию можно в любой момент изменить на странице Редактор печатных плат — Значения по умолчанию диалогового окна Preferences . Эти свойства будут применяться при размещении последующих объектов.

Используйте столбец Primitives для доступа к свойствам объектов и при необходимости изменяйте значения по умолчанию.
Редактирование во время размещения
При первоначальном размещении объекта можно изменить ряд его атрибутов. Чтобы получить к ним доступ, нажмите клавишу Tab в режиме размещения — откроется соответствующая панель Properties. Нажатие клавиши Tab приостанавливает размещение, позволяя внести необходимые изменения в свойства объекта.
Пример диалогового окна свойств объекта Контактная площадка .
После внесения изменений нажмите кнопку паузы, отображаемую поверх рабочей области (
), чтобы продолжить размещение.
Редактирование после размещения
После размещения объект можно редактировать несколькими способами, описанными ниже.
Соответствующая панель или диалоговое окно свойств
При этом способе редактирования для изменения свойств размещённого объекта используются соответствующий режим панели Properties и диалоговое окно.
После размещения соответствующее диалоговое окно можно открыть следующими способами:
-
Дважды щёлкните размещённый объект.
-
Наведите курсор на объект, щёлкните правой кнопкой мыши и выберите Properties в контекстном меню.
После размещения перейти в соответствующий режим панели Properties можно одним из следующих способов:
- Если панель Properties уже активна, выберите объект.
- Выбрав объект, откройте панель Properties с помощью кнопки Panels в правом нижнем углу рабочей области или выберите View » Panels » Properties в главном меню.
Команды выбора объектов печатной платы
Помимо стандартных команд выбора объектов и снятия выбора, редактор печатных плат содержит ряд специальных команд, упрощающих эти операции. Эти команды доступны в подменю Edit » Select и Edit » DeSelect главного меню. Команды выбора также доступны в меню кнопки
на Active Bar.
-
Select overlapped — используйте для выбора следующего объекта проекта в группе объектов, расположенных в одном месте (перекрывающихся), без использования всплывающего окна выбора. Выбор выполняется в следующем фиксированном порядке приоритетов с циклическим переходом при каждом повторном вызове команды:
- Контактная площадка
- Переходное отверстие
- Дорожка/дуга
- Компонент
- Полигон
- Область/заливка
- Текст
Кроме того, при использовании клавиши Shift для добавления объектов к текущему выбору можно использовать Shift+Tab для циклического выбора перекрывающихся объектов без потери исходного выбора.
-
Select next (сочетание клавиш: Tab) - если в проекте уже выбран исходный объект, эта команда расширяет выделение, включая в него объект (или объекты) следующего уровня логической иерархии. Поддерживаются следующие циклические последовательности логического выбора:
- Сегмент дорожки ---> Все соединенные (непрерывные) дорожки на том же слое ---> Вся соединенная медь ---> Все электрические объекты соответствующей цепи
- Соединенная контактная площадка ---> Все соединенные (непрерывные) дорожки на том же слое ---> Вся соединенная медь ---> Все электрические объекты соответствующей цепи
- Несоединенная контактная площадка ---> Все электрические объекты соответствующей цепи
- Переходное отверстие ---> Все соединенные (непрерывные) дорожки на слоях, связанных с переходным отверстием ---> Вся соединенная медь ---> Все электрические объекты соответствующей цепи
- Медь (область/заливка полигона/заливка) ---> Вся соединенная медь ---> Все электрические объекты соответствующей цепи
- Свободная контактная площадка/переходное отверстие ---> Все соединенные (непрерывные) дорожки на том же слое, что и контактная площадка, или на слоях, связанных с переходным отверстием ---> Вся соединенная медь ---> Все электрические объекты соответствующей цепи.
- Компонент ---> Веерные отводы с переходными отверстиями, отводы от контактных площадок, межсоединения
Кроме того, эта функция позволяет расширять выделение для нескольких объектов, выбранных в разных цепях проекта.

Пример выбора объектов в нескольких цепях с расширением выделения от исходных сегментов дорожек к более высоким уровням логической иерархии.Эта команда особенно полезна при выборе трассированных цепей. Подробнее см. Стратегии выбора трассировки.
-
Board - используйте для выбора всех объектов, находящихся в пределах заданного контура платы.
-
Net - используйте для выбора всех электрических объектов определенной цепи.
После запуска команды можно щелкнуть электрический объект или линию связи, чтобы выбрать все электрические объекты соответствующей цепи. Если вы знаете имя нужной цепи, щелкните в области проекта, где нет объектов; откроется диалоговое окно Net Name. В нем можно ввести имя нужной цепи; после закрытия диалогового окна эта цепь будет выбрана. Если вы не уверены в имени цепи, введите ?, затем нажмите OK , чтобы открыть диалоговое окно Nets Loaded, в котором перечислены все загруженные в данный момент цепи проекта.
-
Connected Copper - используйте для выбора всех электрических объектов, соединенных с одним и тем же участком меди.
-
Physical Connection - используйте для выбора всех физически проложенных дорожек между контактными площадками. Щелкните дорожку, контактную площадку или переходное отверстие; будут выбраны все непрерывно соединенные дорожки до следующей контактной площадки, включая переходные отверстия (сами контактные площадки в выделение не включаются).
-
Physical Connection Single Layer - используйте для выбора всех физически проложенных дорожек между контактными площадками на одном слое. Щелкните дорожку или переходное отверстие; будут выбраны все непрерывно соединенные дорожки на том же слое до следующей контактной площадки (сами контактные площадки и переходные отверстия в выделение не включаются).
-
Component Connections - используйте для выбора всех трассированных соединений, отходящих от контактных площадок выбранного компонента (включая дорожки и переходные отверстия), до первой встреченной контактной площадки в каждом случае. Сами контактные площадки в выделение не включаются.
Эту команду также можно вызвать, щелкнув правой кнопкой мыши размещенный компонент и выбрав команду Component Actions » Select Component Connections в контекстном меню.
-
Component Nets - используйте для выбора всех цепей (и входящих в них объектов), подключенных к выбранному компоненту в текущем документе.
Эту команду также можно вызвать, щелкнув правой кнопкой мыши размещенный компонент и выбрав команду Component Actions » Select Component Nets в контекстном меню.
-
Room Connections - используйте для выбора всех трассированных соединений между контактными площадками, полностью находящихся в пределах выбранной комнаты в текущем документе.
Эту команду также можно вызвать, щелкнув правой кнопкой мыши размещенную комнату и выбрав команду Room Actions » Select Room Connections в контекстном меню.
-
All on Layer - используйте для выбора всех объектов на текущем слое или снятия их выделения.
-
Free Objects - используйте для выбора всех свободных объектов-примитивов в проекте. Компоненты, координатные объекты, размерные объекты, объекты подстройки длины, OLE-объекты и объекты заливки полигонов являются групповыми объектами, поэтому эта команда на них не действует.
-
All Locked - используйте для выбора всех объектов проекта, у которых включено свойство Locked .
-
Off Grid Pads - используйте для выбора всех контактных площадок, расположенных вне узлов текущей сетки привязки.
Графическое редактирование
Этот способ редактирования позволяет выбрать размещённый объект непосредственно в рабочей области проекта и графически изменить его размер, форму или положение. Изменение формы и/или размера (если применимо) выполняется с помощью маркеров редактирования, которые появляются после выбора объекта.

Пример маркеров редактирования для выбранного объекта «Заливка».
Щёлкните в любом месте объекта за пределами маркеров редактирования (если они есть), чтобы перетащить объект в новое положение. В зависимости от типа объекта при перетаскивании его можно поворачивать и/или зеркально отражать.
- Нажмите Spacebar для поворота объекта против часовой стрелки или Shift+Spacebar для поворота по часовой стрелке. Поворот выполняется в соответствии со значением Rotation Step, заданным на странице Редактор печатных плат — Общие диалогового окна Preferences.
- Нажмите клавишу L, чтобы перенести объект на другую сторону платы (если применимо).
- Нажмите клавишу X или Y , чтобы зеркально отразить объект по оси X или Y (если применимо).
- Нажмите клавишу Alt, чтобы ограничить направление перемещения горизонтальной или вертикальной осью в зависимости от исходного направления движения.
- Для перемещения объекта небольшими шагами (в соответствии с текущим шагом сетки привязки) нажимайте клавиши со стрелками, удерживая клавишу Ctrl . Для перемещения более крупными шагами (10 шагов сетки привязки) нажимайте клавиши со стрелками, удерживая клавиши Ctrl+Shift.
Команды перемещения
Положение объекта можно изменить с помощью команд подменю Edit » Move главного меню или подменю перемещения в Active Bar.
-
Move — эта команда используется для перемещения любого объекта в текущем документе. Все цепи, связанные с объектом, сохраняют связь с ним, а линии соединений следуют за объектом при его перемещении (их отображение зависит от действующего режима отображения соединений). Проложенные дорожки, подключённые к объекту, не перемещаются.
-
Drag — эта команда используется для перемещения любого объекта в текущем документе. Если к объекту (например, компоненту, контактной площадке или переходному отверстию) подключены дорожки и/или дуги, они сохраняют соединение с ним при его перемещении.
-
Component — эта команда позволяет перемещать компоненты в текущем документе. После запуска команды щёлкните по компоненту в проекте, который требуется переместить, переместите его в нужное положение и щёлкните ещё раз. Либо щёлкните в свободном месте рабочей области проекта, чтобы открыть диалоговое окно Выбор компонента. В этом окне найдите нужный компонент (перейдя к нему или перенеся его к курсору), а затем измените его положение описанным выше способом. Обратите внимание: эта функция работает, только если целевой компонент not заблокирован.
Эту команду также можно вызвать, щёлкнув правой кнопкой мыши по компоненту в рабочей области проекта и выбрав команду Component Actions » Move Component в контекстном меню.
-
Move Selection — эта команда позволяет вручную изменить положение выбранных объектов в текущем документе. Все цепи, связанные с выбранным объектом, сохраняют связь с ним, а линии соединений следуют за объектом при его перемещении (их отображение зависит от действующего режима отображения соединений). Проложенные дорожки, подключённые к объекту, не перемещаются.
-
Move Selection by X, Y — эта команда используется для смещения выбранных объектов на точно заданную величину по оси X и/или Y. После запуска команды открывается диалоговое окно Get X/Y Offsets. В этом окне задайте значения приращений по X и/или Y, на которые требуется переместить выбранные объекты.

Диалоговое окно Get X/Y OffsetsПараметры и элементы управления диалогового окна Get X/Y Offsets
- X Offset — в этом поле укажите расстояние, на которое выбранные объекты должны быть перемещены по горизонтальной оси. В зависимости от требуемого направления перемещения можно задать положительное или отрицательное значение. Кнопка справа от поля позволяет быстро изменить знак введённого значения.
- Y Offset — в этом поле укажите расстояние, на которое выбранные объекты должны быть перемещены по вертикальной оси. В зависимости от требуемого направления перемещения можно задать положительное или отрицательное значение. Кнопка справа от поля позволяет быстро изменить знак введённого значения.
- Toggle X/Y Offsets — нажмите эту кнопку, чтобы быстро поменять значения смещений местами. Значение X Offset будет использовано как значение Y Offset, и наоборот.
- Reset X/Y Offsets — нажмите эту кнопку, чтобы быстро сбросить оба значения смещения до нуля.
- Define X/Y Offsets Interactively — нажмите эту кнопку, чтобы определить смещения в интерактивном режиме. Вы перейдёте в рабочую область, где вам будет предложено последовательно выбрать начальную и конечную точки. Щёлкните в нужных местах; значения dX и dY будут введены в поля X Offset и Y Offset соответственно.
-
Rotate Selection - эта команда используется для поворота выбранных объектов в рабочей области проектирования против часовой стрелки или по часовой стрелке на заданный угол. После запуска команды откроется диалоговое окно Rotation Angle (Degrees). Введите требуемый угол поворота от 0,001° до 360,00° (с шагом 0,001°). Введите положительное значение для поворота против часовой стрелки или отрицательное значение для поворота по часовой стрелке. Нажмите OK, чтобы закрыть диалоговое окно, затем установите курсор в нужное положение и щелкните, чтобы задать опорную точку поворота. Выбранные объекты будут повернуты вокруг опорной точки на введенный угол.

Диалоговое окно Rotation Angle -
Flip Selection - отразить выбранные объекты по горизонтали (относительно оси Y) с переносом на соответствующий слой на противоположной стороне платы. Например, объекты на Top Layer будут перенесены на Bottom Layer, объекты на Top Overlay — на Bottom Overlay и т. д.
Команды выравнивания
Объекты также можно перемещать, изменяя их выравнивание. Чтобы выровнять объекты относительно других объектов, щелкните правой кнопкой мыши по выбранному объекту, затем выберите Align. Также можно воспользоваться подменю Edit » Align главного меню или подменю выравнивания в Active Bar. Подменю выравнивания содержит ряд команд для распределения выбранных объектов.
Команда Align открывает диалоговое окно Align Objects, в котором можно быстро настроить требуемое выравнивание выбранных объектов проекта. В этом диалоговом окне задайте необходимые параметры выравнивания выбранных объектов по Vertical и/или Horizontal , затем нажмите OK для выполнения выравнивания.

Диалоговое окно Align Objects
Параметры и элементы управления диалогового окна Align Objects
-
Horizontal - выберите один из следующих вариантов горизонтального выравнивания выбранных объектов:
- No Change - оставить горизонтальное выравнивание объектов без изменений.
- Left - выровнять объекты так, чтобы внешние края их крайних левых примитивов имели одинаковую координату X. В качестве опорного используется объект с самым левым примитивом.
- Center - переместить объекты по горизонтали так, чтобы их центры были выровнены. После нажатия OK, вам будет предложено щелчком выбрать опорный объект.
- Right - выровнять объекты так, чтобы внешние края их крайних правых примитивов имели одинаковую координату X. В качестве опорного используется объект с самым правым примитивом.
- Space equally - равномерно распределить объекты по горизонтали между крайним левым и крайним правым объектами (которые остаются неподвижными).
-
Vertical - выберите один из следующих вариантов вертикального выравнивания выбранных объектов:
- No Change - оставить вертикальное выравнивание выбранных объектов без изменений.
- Top - выровнять объекты так, чтобы внешние края их самых верхних примитивов имели одинаковую координату Y. В качестве опорного используется объект с самым верхним примитивом.
- Center - переместить объекты по вертикали так, чтобы их центры были выровнены. После нажатия OK вам будет предложено щелчком выбрать опорный объект.
- Bottom - выровнять объекты так, чтобы внешние края их самых нижних примитивов имели одинаковую координату Y. В качестве опорного используется объект с самым нижним примитивом.
- Space equally - равномерно распределить объекты по вертикали между самым верхним и самым нижним объектами (которые остаются неподвижными).
Команда Position Component Text открывает диалоговое окно Component Text Position, в котором можно изменить положение текста позиционного обозначения и/или комментария для одного или нескольких выбранных компонентов в текущем документе.

Диалоговое окно Component Text Position
Диалоговое окно разделено на две области: текст позиционного обозначения и текст комментария. В каждой из них графическое изображение компонента помогает определить, где будет отображаться текст в зависимости от выбранного положения. Для текста доступны следующие девять вариантов расположения. Все они относятся к «автоматическим положениям»: это означает, что текст сохраняет выбранное положение при перемещении и повороте компонента:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Чтобы оставить текст в текущем положении без изменений, оставьте параметр No Change включенным.
Команда Align Left / Align Right / Align Top / Align Bottom позволяет выровнять выбранные объекты проекта по их левым/правым/верхним/нижним краям соответственно. После запуска команды в качестве опорного используется левый/правый/верхний/нижний край крайнего левого/правого/верхнего/нижнего объекта, а все остальные выбранные объекты перемещаются влево/вправо/вверх/вниз так, чтобы их левые края были выровнены относительно этого опорного края.
Команда Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) позволяет выравнивать выбранные объекты проекта по левому/правому/верхнему/нижнему краю, сохраняя необходимые расстояния в соответствии с применимыми правилами проектирования. После запуска команды левый/правый/верхний/нижний край самого левого/правого/верхнего/нижнего объекта используется в качестве ориентира, а все остальные выбранные объекты перемещаются влево/вправо/вверх/вниз так, чтобы их левые края были выровнены относительно этого ориентира. Объект перемещается влево/вправо/вверх/вниз как можно ближе к опорному объекту, насколько это допускает применимое правило зазора:
- При выравнивании только компонентов соблюдается правило зазора между компонентами (Component Clearance).
- При выравнивании только объектов, не являющихся компонентами, соблюдается правило зазора (Clearance).
- При выравнивании компонентов и объектов, не являющихся компонентами, соблюдается правило зазора (Clearance).
Команда Align Horizontal Centers / Align Vertical Centers позволяет размещать выбранные объекты в один столбец/ряд с выравниванием по их центрам по горизонтали/вертикали. После запуска команды курсор примет вид перекрестия, и вам будет предложено выбрать один из выделенных объектов; щелкните по нему. Этот объект станет опорным. Все остальные выбранные объекты будут перемещены относительно него с выравниванием по их центрам по горизонтали/вертикали.
Команда Distribute Horizontally / Distribute Vertically позволяет сделать горизонтальные/вертикальные расстояния между выбранными объектами одинаковыми. После запуска команды самый левый и самый правый / самый верхний и самый нижний объекты останутся на своих местах, а все остальные объекты будут равномерно распределены между ними. Положение объектов по вертикали/горизонтали не изменяется.
Команда Increase Horizontal Spacing / Increase Vertical Spacing позволяет увеличить горизонтальные/вертикальные расстояния между выбранными объектами. После запуска команды самый левый/нижний объект останется на своем месте, а остальные выбранные объекты будут перемещены вправо/вверх. Перемещение выполняется так, чтобы горизонтальное/вертикальное расстояние между опорными точками соседних объектов увеличилось на величину, указанную в поле Step X / Step Y для используемого по умолчанию Global Board Snap Grid.
Команда Decrease Horizontal Spacing / Decrease Vertical Spacing позволяет уменьшить горизонтальные/вертикальные расстояния между выбранными объектами. После запуска команды самый левый/нижний объект останется на своем месте, а остальные выбранные объекты будут перемещены влево/вниз. Перемещение выполняется так, чтобы горизонтальное/вертикальное расстояние между опорными точками соседних объектов уменьшилось на величину, указанную в поле Step X / Step Y для используемого по умолчанию Global Board Snap Grid.
Команда Align To Grid используется для перемещения выбранных компонентов к ближайшему узлу применимой и измененной сетки привязки. После запуска команды опорная точка каждого выбранного компонента будет перемещена к ближайшему узлу применимой сетки привязки.
Команда Move All Components Origin To Grid используется для перемещения опорных точек всех компонентов на текущую сетку привязки. После запуска команды все компоненты в рабочей области, контактные площадки которых находятся на сетке, будут перемещены так, чтобы их опорные точки совпали с узлами текущей сетки привязки. По умолчанию автоматически создается и открывается в качестве активного документа отчет — Move Component(s) Origin To Grid - <PCBDocumentName>.html, в котором подробно указано, какие компоненты были и какие не были перемещены.
Через панель PCB List
Панель PCB List позволяет отображать объекты проекта в табличном виде для быстрого просмотра и изменения их атрибутов. При совместном использовании с панелью PCB Filter она позволяет отображать только объекты, соответствующие активному фильтру, что обеспечивает более точный и эффективный выбор и редактирование нескольких объектов проекта.
Выбор активного слоя
Активный слой — это слой, на котором будут размещаться объекты. Активный слой можно выбрать из числа отображаемых в данный момент слоев, щелкнув по вкладке этого слоя в нижней части рабочей области или воспользовавшись раскрывающимся списком Active Layer в области Layers на вкладке Layers & Colors панели View Configuration.
Для быстрого выбора активного слоя также можно использовать следующие сочетания клавиш:
- * (на цифровой клавиатуре) — переход к следующему включенному сигнальному слою.
-
Shift+* (на цифровой клавиатуре) — переход к предыдущему включенному сигнальному слою.
- + (на цифровой клавиатуре) — переход к следующему включенному слою.
- - (на цифровой клавиатуре) — переход к предыдущему включенному слою.
Вырезание/копирование и вставка
В редакторе печатных плат можно вырезать/копировать и вставлять объекты как внутри одного документа печатной платы, так и между разными документами. Например, компоненты одной платы можно скопировать в документ другой платы. Объекты можно вырезать/копировать в буфер обмена Windows и вставлять в другие документы.
При использовании 2D Layout Mode выберите объекты, которые нужно вырезать/скопировать, и нажмите Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) в главном меню или выберите команду Cut/Copy в контекстном меню. Курсор примет вид перекрестия, и вам будет предложено выбрать опорную точку. Это точка с координатами относительно выбранных объектов, которая используется для точного размещения выделенных объектов при выполнении команды вставки.
Чтобы скопировать выбранные объекты проекта в буфер обмена в текстовом формате, можно использовать команду Edit » Copy As Text из главного меню. Затем эту информацию можно вставить в любое текстовое поле или внешний текстовый документ. В буфер обмена копируются следующие сведения:
- Тип объекта.
- Позиционное обозначение и комментарий (для компонента).
- Расположение объекта в рабочей области проекта.
- Слой, на котором расположен объект (или начальный и конечный слои для переходного отверстия).
Пример компонента, скопированного в буфер обмена в виде текста:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Пример дорожки и переходного отверстия, скопированных в буфер обмена в виде текста:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Чтобы вставить в активный документ последнее содержимое, вырезанное или скопированное в буфер обмена, выберите команду Edit » Paste из главного меню или щелкните правой кнопкой мыши в рабочей области проекта и выберите команду Paste из контекстного меню (сочетание клавиш: Ctrl+V). Последнее содержимое буфера обмена будет прикреплено к курсору. Положение курсора относительно содержимого определяется опорной точкой, заданной при использовании Cut или Copy для добавления выбранных объектов в буфер обмена.
Чтобы вставить текст, скопированный из поддерживаемого OLE-приложения, в любой открытый документ печатной платы, можно использовать команду Edit » Paste Text из главного меню. Текст преобразуется в текстовые объекты печатной платы и вставляется в этом виде, а не как единый OLE-объект. Поддерживаемые типы файлов включают распространенные форматы: электронные таблицы CSV и XLS, а также текстовые документы DOC и RTF.
Чтобы управлять обработкой определенных атрибутов объектов при их вставке обратно в рабочую область проекта, можно использовать команду Edit » Paste Special из главного меню. После запуска команды откроется диалоговое окно Paste Special.

Диалоговое окно Paste Special
Параметры и элементы управления диалогового окна специальной вставки
Атрибуты вставки
- Paste on current layer — включите этот параметр, чтобы вставлять объекты на текущий слой.
- Keep net name — включите этот параметр, чтобы сохранить исходные имена цепей объектов.
- Duplicate designator — включите этот параметр, чтобы вставить компонент с тем же позиционным обозначением без автоматического увеличения.
- Add to component class — включите этот параметр, чтобы добавить вставляемый компонент в тот же класс компонентов, что и исходный компонент.
Кнопки
- Paste — нажмите, чтобы вставить объект со всеми заданными атрибутами.
- Paste Array — нажмите, чтобы открыть диалоговое окно Настройка вставки массива, в котором можно задать параметры вставки массива.
В зависимости от вставляемого содержимого можно управлять следующими атрибутами:
-
Объекты можно вставить на текущий слой, а не на слой, с которого были скопированы исходные объекты, как это происходит по умолчанию.
- Возможность сохранить назначенные имена цепей.
- Возможность дублировать позиционное обозначение (для вставляемого компонента).
- Возможность добавить вставляемый компонент в тот же класс компонентов, что и исходный компонент.
Задайте необходимые параметры, затем нажмите кнопку Paste для начала операции вставки.
При нажатии кнопки Paste Array в диалоговом окне Paste Special откроется диалоговое окно Setup Paste Array, позволяющее вставить в текущий документ несколько копий объектов из буфера обмена.

Диалоговое окно Setup Paste Array
Параметры и элементы управления диалогового окна настройки вставки массива
Параметры размещения
- Item Count — количество повторных размещений. Например, если ввести 4, будут размещены 4 копии текущего содержимого буфера обмена.
-
Text Increment — введите шаг автоматического изменения отображаемого текста (например, позиционного обозначения компонента или обозначения контактной площадки). Поддерживаются как буквенные, так и числовые шаги, отличные от 1. Например, задав обозначение контактной площадки перед ее копированием в буфер обмена и настроив поле Text Increment, можно разместить следующие последовательности обозначений контактных площадок:
- Числовая (1, 3, 5)
- Буквенная (A, B, C)
- Комбинация букв и цифр (A1, A2, или 1A, 1B, или A1, B1, или 1A, 2A и т. д.)
Тип массива
- Circular— включите этот параметр, чтобы вставить круговой массив с использованием текущих настроек Circular Array.
- Linear — включите этот параметр, чтобы вставить массив по прямой линии с использованием текущих настроек Linear Array.
Круговой массив
- Rotate Item to Match — если этот параметр включен, элементы массива будут повернуты на угол, равный угловому шагу между ними.
- Spacing (degrees) — угловой шаг между двумя соседними вставляемыми элементами.
Линейный массив
- X-Spacing — введите требуемый шаг по оси X между двумя соседними элементами.
- Y- Spacing — введите требуемый шаг по оси Y между двумя соседними элементами.
Введите необходимые значения в этом диалоговом окне, затем нажмите OK для размещения массива.
- При размещении линейного массива вам будет предложено выбрать его начальную точку. Установите курсор в нужное положение, затем щелкните мышью или нажмите Enter для размещения массива.
- При размещении кругового массива вам будет предложено сначала выбрать его центральную точку, а затем начальную точку. В каждом случае установите курсор в нужное положение, затем щелкните мышью или нажмите Enter для размещения массива. Объекты будут размещены против часовой стрелки вокруг указанной центральной точки.
Приоритеты при вставке объектов
Если объект вставляется на медный слой и при вставке перекрывает несколько объектов разных типов, ему будет назначена цепь объекта с наивысшим приоритетом. Приоритеты следующие (1 — наивысший приоритет):
- Контактная площадка
- Заливка
- Область
- Дорожка
- Дуга
- Переходное отверстие
- Полигональная заливка

Вставляемому объекту назначается цепь объекта с наивысшим приоритетом. Здесь показан объект (дорожка), вставляемый поверх нескольких объектов разных типов, которым назначены разные цепи. Поскольку контактная площадка имеет наивысший приоритет среди этих объектов, ее цепь (Pad_Net) будет назначена вставляемому объекту. Наведите курсор на изображение, чтобы увидеть результат.
Если объект вставляется на медный слой и при вставке перекрывает несколько объектов одного типа, ему будет назначена цепь объекта, находящегося под курсором в момент щелчка для вставки.

Вставляемому объекту назначается цепь объекта под курсором. Здесь показан объект (дорожка), вставляемый поверх нескольких объектов одного типа (контактных площадок). Поскольку в момент щелчка для вставки под курсором находится контактная площадка 2, ее цепь (Pad2_Net) будет назначена вставляемому объекту. Наведите курсор на изображение, чтобы увидеть результат.
Если набор физически соединенных объектов вставляется на медный слой и объекты разных типов из этого набора перекрывают существующие объекты с разными цепями, цепь объекта с наивысшим приоритетом в этом наборе будет назначена всем вставляемым объектам. В этом случае применяются приведенные выше приоритеты.

Цепь, назначенная объекту с наивысшим приоритетом, назначается всему набору физически соединенных объектов. Здесь показан набор соединенных объектов (слева направо: заливка, область, дорожка, дуга, переходное отверстие, полигональная заливка), вставляемый поверх объектов (переходных отверстий), которым назначены разные цепи. Поскольку заливка имеет наивысший приоритет в этом вставляемом наборе, назначенная ей цепь (Via1_Net) будет назначена каждому объекту набора. Наведите курсор на изображение, чтобы увидеть результат.
Блокировка объектов проекта
Объекты проекта можно заблокировать от перемещения или редактирования в документе печатной платы, включив их атрибуты Locked . Например, если положение или размеры определенных объектов критически важны, заблокируйте их. Для блокировки на панели Properties щелкните значок замка для нужных объектов, как показано в следующих примерах.
Примеры значка Lock на панели Properties для выбранного компонента и контактной площадки.
Чтобы переключить состояние свойства Locked у размещенного объекта, имеющего свойство Locked , можно также щелкнуть правой кнопкой мыши по объекту в рабочей области и выбрать команду <ObjectType> Locked в контекстном меню. Если объект уже заблокирован, слева от этой команды в меню отображается значок галочки.
При попытке переместить или повернуть объект проекта с включенным свойством Locked появится диалоговое окно с запросом подтверждения редактирования.
Блокировка примитивов компонента
Если примитивы компонента печатной платы заблокированы (параметр Primitives в режиме Component панели Properties находится в состоянии , все или большинство свойств этих примитивов нельзя изменить ни графическими (например, перетаскиванием), ни неграфическими (например, с помощью панели Properties или List) способами редактирования. Это помогает предотвратить случайные изменения примитивов компонента, которые могут привести к ошибкам в выходных данных для сборки и изготовления.
В качестве примера на изображении ниже показан режим Pad панели Properties для контактной площадки, входящей в состав компонента печатной платы с заблокированными примитивами. Обратите внимание, что все свойства контактной площадки (кроме свойств Net и Testpoint) отображаются серым цветом и недоступны для редактирования. Также обратите внимание, что значок
отображается у правого края Component контактной площадки поле, которое указывает, что примитивы родительского компонента заблокированы и свойства контактной площадки нельзя изменить.

Режим Pad панели Properties (слева) для контактной площадки компонента печатной платы с заблокированными примитивами (справа).
Редактирование без завершения текущей операции
Редактор печатных плат включает мощную функцию под названием re-entrant editing. Она позволяет выполнять вторую операцию с помощью сочетаний клавиш, не завершая текущую. Такое редактирование делает работу более гибкой и интуитивно понятной. Например, начав прокладывать дорожку, вы можете обнаружить, что необходимо удалить другой сегмент дорожки. При этом выходить из режима Интерактивная трассировка не требуется. Нажмите сочетание клавиш E, D, удалите нужный сегмент дорожки, затем нажмите клавишу Esc , чтобы вернуться к интерактивной трассировке проекта.
Настройка внешнего вида курсора печатной платы
По умолчанию курсор печатной платы имеет вид небольшого зелёного перекрестия под углом 90 градусов. Его можно настроить с помощью параметров Cursor Type и Cursor Color на странице PCB Editor – General диалогового окна Preferences . Например, большое перекрестие под углом 90 градусов, доходящее до краёв окна проектирования (параметр Large 90), может быть полезно при размещении и выравнивании объектов проекта. Перекрестие под углом 45 градусов (параметр Small 45) может пригодиться, если варианты под углом 90 градусов плохо различимы на фоне линий сетки.
Поддержка шрифтов TrueType
Редактор печатных плат позволяет использовать штриховые шрифты или шрифты TrueType для текстовых объектов проекта (текстовых строк и рамок, размеров, таблиц сверления и/или таблиц стека слоёв). Шрифт выбирается на соответствующей панели Properties . Доступны три штриховых шрифта: Default, Sans Serif и Serif. Стиль Default — это простой векторный шрифт, который поддерживает вывод на перьевой плоттер и векторный фотоплоттер. Шрифты Sans Serif и Serif более сложные и замедляют формирование векторных выходных данных, например Gerber. Штриховые шрифты встроены в программу и не могут быть изменены. Все три шрифта содержат полный расширенный набор символов IBM ASCII, который поддерживает английский и другие европейские языки. При использовании шрифтов TrueType доступны шрифты TrueType и OpenType (расширение TrueType), находящиеся в папке \Windows\Fonts. Также обеспечивается полная поддержка Unicode.
Геометрия текстовых объектов, использующих шрифты TrueType, автоматически сохраняется в документах печатных плат. Если объекты в документе печатной платы используют шрифт TrueType, при открытии документа на другом компьютере они будут отображаться с той же геометрией шрифта, даже если этот шрифт TrueType не установлен.
При выборе объекта, использующего отсутствующий шрифт, в верхней части панели Properties появляется предупреждение. При изменении свойств объекта, влияющих на его текст (например, высоты текста или самого текста), открывается диалоговое окно Missing fonts, в котором можно выбрать шрифт для замены (Replacement). Включите параметр Apply to all text elements, чтобы применить выбранный шрифт ко всем объектам документа печатной платы, использующим отсутствующий шрифт.
Это диалоговое окно также появляется при изменении свойств текста на панели PCB List.
При попытке редактировать несколько объектов, использующих разные отсутствующие шрифты, диалоговое окно позволяет выбрать замену для каждого отсутствующего шрифта.
Поддержка отображения точных дуг
В рабочей области редактора печатных плат и редактора библиотек печатных плат поддерживается отображение точных дуг вместо их аппроксимаций. Эта поддержка распространяется на режимы 2D/3D-компоновки (а также на режим планирования платы в редакторе печатных плат). Отображение точных дуг используется в следующих случаях:
-
Заливки полигонов (сплошная, штриховая, без заливки)
-
Вырезы в заливках полигонов
-
Контуры выделения заливок полигонов и областей
-
Области
-
Расширения паяльной маски и маски паяльной пасты
-
Подсветка цепей
-
Границы зазоров
-
Наложение, обозначающее нарушение (отдельная заливка полигона поверх области или заливки полигона)
Ниже приведены примеры отображения точных дуг в заливках полигонов, огибающих другие объекты печатной платы.
Информация о цепи
При выборе медного объекта на печатной плате (дорожки, переходного отверстия, полигона и т. д.) в разделе Net Information панели Properties отображается следующая информация:
- Родительские Net, Diff Pair и/или xSignal, а также соответствующий класс для каждого из них. Обратите внимание: записи Diff Pair и xSignal отображаются только в том случае, если объект входит в состав дифференциальной пары или xSignal соответственно.
-
Delay — задержка выбранного объекта (объектов) и задержка протрассированных сегментов всей цепи. Учитываются значения Propagation Delay контактных площадок и переходных отверстий, если они были для них заданы.
-
Length – суммарная длина выбранных объектов и общее значение Signal Length. Signal Length представляет собой точный расчет общего расстояния между узлами. Размещенные объекты анализируются для учета наложенных или перекрывающихся объектов и извилистых путей внутри контактных площадок; также учитывается длина переходных отверстий. Значение Pin Package Length также учитывается, если оно задано для контактных площадок. Если цепь разведена не полностью, также учитывается манхэттенская длина (X + Y) линии соединения. Дополнительные сведения о длине сигнала и ее применении см. в описании панели PCB — Nets.
-
Max Current — максимальный ток, который могут проводить выбранные объекты Дорожка, Дуга или Переходное отверстие, определяемый по формуле из стандарта IPC-2221A (раздел 6.2):
I = k * ΔT0.44 * A0.725
где:
I = ток [А]
A = площадь поперечного сечения [кв. мил] (ширина дорожки * толщина меди из стека слоев или Aстенки, как показано ниже)
ΔT = допустимое превышение температуры над температурой окружающей среды [°C]
k = константа, равная:k = 0.048 для внешних слоев
k = 0.024 для внутренних слоев -
Resistance — сумма сопротивлений выбранных объектов «Дорожка», «Дуга» и «Переходное отверстие», определяемая по следующей формуле:
R = (ρ * L / A)
где:
R = сопротивление [Ом]
ρ = удельное сопротивление меди [Ом*мм2/м]
L = длина дорожки [м] (или длина переходного отверстия, как описано ниже)
A = площадь поперечного сечения = T * W [мм2] (или Aстенки, как показано ниже)
T = толщина дорожки (из стека слоев) [мм]
W = ширина дорожки [мм]Assumptions:
- Температура окружающей среды = 22 °C
- Допустимое повышение температуры = 20 °C
- Толщина медной стенки сквозного отверстия = 0.018 мм
- Удельное сопротивление меди = 0.017 Ом*мм2/м

Область Net Information панели Properties. Здесь показан пример для выбранной дорожки.
Щелкните ссылку в области Net Information, чтобы открыть соответствующую цепь, дифференциальную пару или xSignal на панели PCB.
Назначение цепей объектам
Редактор печатных плат предоставляет несколько способов назначения цепей объектам-примитивам:
- Выбрав один или несколько объектов, воспользуйтесь раскрывающимся списком поля Nets на панели Properties. В раскрывающемся списке перечислены все цепи активного проекта платы. Выберите No Net, чтобы указать, что дорожка не подключена ни к одной цепи. Также можно щелкнуть значок Assign Net , чтобы выбрать объект в рабочей области: цепь этого объекта будет назначена выбранным объектам.
- Щелкните правой кнопкой мыши по одному или нескольким выбранным объектам, затем выберите Net Actions » Assign Net. После запуска команды появится перекрестие. Наведите перекрестие на цепь, которую нужно назначить объектам, и щелкните, чтобы выбрать эту цепь.
- Чтобы привести имена цепей примитивов трассировки в соответствие с именами цепей контактных площадок, к которым они подключены, выберите команду Design » Netlist » Update Free Primitives From Component Pads в главном меню. После запуска команды откроется диалоговое окно подтверждения с вопросом, хотите ли вы обновить цепи свободных примитивов в соответствии с цепями контактных площадок компонентов. После нажатия Yes для каждой контактной площадки выбираются связанные с ней медные объекты, а каждому примитиву назначается имя цепи этой площадки. Эта операция не влияет на внутренний список цепей печатной платы.
Чтобы проверить и убедиться, что физически соединённым объектам назначена правильная цепь, соответствующая их физическому соединению (в данном случае physical net означает connected copper), можно воспользоваться диалоговым окном Configure Physical Nets, которое открывается командой Design » Netlist » Configure Physical Nets из главного меню. Программа анализирует проект и проверяет, что всем контактным площадкам и физически соединяющим их объектам (дорожкам, дугам, заливкам и т. д.) назначено одно и то же имя цепи. Если все объекты цепи назначены правильно, цепь отображается зелёным цветом. Если обнаружены соприкасающиеся объекты, которым назначены разные цепи, они отмечаются красным цветом. Типичный пример такой ситуации — наличие дополнительных медных объектов в посадочном месте компонента. При загрузке такого посадочного места во время синхронизации каждой контактной площадке назначается имя цепи, но дополнительным медным объектам оно не назначается. Диалоговое окно интерактивно: щёлкните цепь или примитив, чтобы перейти к соответствующему объекту в редакторе. Щёлкните правой кнопкой мыши или нажмите кнопку Menu , чтобы получить доступ к доступным командам. В области Action диалогового окна находятся элементы управления для выбора действий, необходимых для устранения проблем со связанными медными объектами. По умолчанию действия задаются автоматически, но при необходимости их можно изменить. После настройки действий нажмите кнопку Execute , чтобы обновить назначения цепей.

Диалоговое окно Configure Physical Nets с включённым параметром Only Show Errors (на заднем плане) и отключённым параметром Only Show Errors (на переднем плане).
Параметры и элементы управления диалогового окна Configure Physical Nets
-
Electrically Connected Copper — в этой области перечислены отдельные группы медных примитивов, электрическое соединение которых обнаружено при анализе разводки проекта. Для каждой группы представлена следующая информация:
-
Primitive — на верхнем уровне эта запись показывает количество примитивов в группе связанных медных объектов. Примитивы могут отображаться в виде плоского списка или группироваться по типу. Группировка по типу включается параметром Show Primitive Groups в меню кнопки Menu . При его включении примитивы распределяются по следующим группам:
- Connected Component Primitives — содержит все примитивы контактных площадок компонентов в виде дочерних элементов. Их можно дополнительно сгруппировать по компонентам, которым они принадлежат, включив параметр Show Components в меню кнопки Menu .
- Connected Free Primitives — содержит все медные примитивы, не принадлежащие компонентам, в виде дочерних элементов, дополнительно сгруппированных по типу примитива (заливки, полигоны, дорожки, переходные отверстия).
-
Primitive — на верхнем уровне эта запись показывает количество примитивов в группе связанных медных объектов. Примитивы могут отображаться в виде плоского списка или группироваться по типу. Группировка по типу включается параметром Show Primitive Groups в меню кнопки Menu . При его включении примитивы распределяются по следующим группам:
- Original Net Names — в этом поле отображается имя цепи, назначенной примитиву в данный момент, то есть цепи, к которой он сейчас подключён. Здесь указывается одна из цепей, определённых для платы. Однако если примитив не подключён к цепи, отображается запись <Unassigned>.
-
Status — в этом поле отображается общий статус группы, который может принимать одно из четырёх значений:
- Blank - все назначения цепей для группы соединённых медных объектов корректны, обновление не требуется. Запись верхнего уровня для этой группы выделена зелёным цветом.
- 1. Update Required - Unassigned Nets - в этом состоянии ни одному из примитивов группы не назначена цепь. Запись верхнего уровня для этой группы выделена жёлтым цветом.
- 2. Update Required - Some Unassigned Nets - в этом состоянии некоторым примитивам назначена одна и та же цепь, а остальным цепь не назначена. Запись верхнего уровня для этой группы выделена оранжевым цветом.
- 3. Ambiguous - Multiple Net Names - в этом состоянии в группе есть примитивы, которым назначены разные цепи. Также могут присутствовать примитивы, которым цепь ещё не назначена. Запись верхнего уровня для этой группы выделена красным цветом.
-
Action - в этой области находятся элементы управления для выбора действий, необходимых для устранения проблем с соединёнными медными объектами, а также отображаются результаты применения настроенных изменений. Для каждой группы представлены следующие сведения:
-
Proposed Action - это поле определяет, какое действие следует выполнить и требуется ли оно вообще. На верхнем уровне группы для этой записи можно задать Update Net To или Don't Update Net To. При обновлении выберите новую целевую цепь в поле New Net Name. На основе этих двух настроек программа определяет действия для дочерних примитивов и предлагает один из следующих вариантов:
- No Action Required - примитиву уже назначена целевая цепь или он уже подключён к ней.
- Update - включить примитив в обновление, чтобы назначить ему новую целевую цепь или подключить его к ней.
- Don't Update - не включать примитив в обновление. Он останется подключённым к своей текущей цепи.
- New Net Name - используйте это поле для задания новой целевой цепи, к которой должны быть подключены примитивы. В раскрывающемся списке поля перечислены все цепи, обнаруженные среди примитивов группы соединённых медных объектов. Если требуется другая цепь, щёлкните поле правой кнопкой мыши и выберите команду Change Copper Net To Board Net в контекстном меню. Откроется диалоговое окно Choose Net со списком всех цепей, определённых для платы. Выберите нужную цепь и нажмите OK. Эта цепь будет внесена в поле.
- Done - это поле показывает, завершилось ли обновление успешно или с ошибкой , после нажатия кнопки Execute и применения изменений.
-
Proposed Action - это поле определяет, какое действие следует выполнить и требуется ли оно вообще. На верхнем уровне группы для этой записи можно задать Update Net To или Don't Update Net To. При обновлении выберите новую целевую цепь в поле New Net Name. На основе этих двух настроек программа определяет действия для дочерних примитивов и предлагает один из следующих вариантов:
- Execute - когда все действия для списка соединений настроены нужным образом, нажмите эту кнопку, чтобы обновить назначения цепей.
-
Menu - нажмите, чтобы открыть следующее меню команд, относящихся ко всему основному списку или к выбранным примитивам. Эти команды идентичны командам контекстного меню основной области списка.
- Update/Don't Update/No Action - используйте для быстрого переключения предлагаемого действия для выбранных примитивов. На вышестоящем родительском уровне иерархии примитивов эта команда переключает предлагаемое действие для всех вложенных дочерних элементов.
- Select All - используйте для быстрого выбора всех групп соединённых медных объектов (записей верхнего уровня в списке).
- Select All With Same Status - выбрав запись верхнего уровня для группы соединённых медных объектов, используйте эту команду, чтобы быстро выбрать все остальные группы верхнего уровня с таким же статусом.
- Clear All Selected - используйте для снятия выделения со всех записей в списке.
- Expand All In Connected Copper - используйте для быстрого разворачивания всех дочерних групп внутри текущей группы соединённых медных объектов.
- Expand All - используйте для быстрого разворачивания всех групп во всех группах соединённых медных объектов в списке.
- Expand Children - используйте для быстрого разворачивания всех вложенных дочерних групп под выбранной группой.
- Collapse All In Connected Copper - используйте для быстрого сворачивания всех дочерних групп внутри текущей группы соединённых медных объектов.
- Collapse All - используйте для быстрого сворачивания всех групп во всех группах соединённых медных объектов в списке.
- Collapse Children - используйте для быстрого сворачивания всех вложенных дочерних групп под выбранной группой.
- Only Show Errors - включите, чтобы в диалоговом окне отображались только ошибки. В списке будут представлены только группы соединённых медных объектов, для которых Status имеет уровень 1, 2 или 3. Отключите, чтобы также отображались соединённые медные объекты с корректно назначенными цепями.
- Show Components - включите, чтобы примитивы контактных площадок компонентов группировались по компонентам, которым они принадлежат.
- Show Primitive Groups - включите, чтобы примитивы группировались по типу.
- Animate Action Execution - включите, чтобы список в диалоговом окне прокручивался по мере выполнения изменений цепей, наглядно показывая ход выполнения в реальном времени. Если этот параметр отключён, изменения выполняются без такой анимации.
-
Warn On Netlist Change - включите, чтобы получать предупреждение, когда изменения затрагивают список соединений платы. Откроется диалоговое окно Netlist Change с указанием количества примитивов, для которых будут изменены цепи, и предупреждением о том, что это повлияет на список соединений. Вы можете нажать Continue или нажать Filter Affected, чтобы подробнее изучить предлагаемые изменения.

Диалоговое окно Netlist Change - Show Component Pads - включите, чтобы в списке отображались соединённые примитивы компонентов.
- Show Non Component Pads - включите, чтобы в списке отображались соединённые свободные примитивы.
- Show Changes That Affect Netlist - включите, чтобы отображался только список предлагаемых действий (изменений), которые повлияют на список соединений платы.
- Change Copper Net To - один или несколько пунктов меню этого типа появляются, когда примитивам в текущей группе соединённых медных объектов назначено небольшое количество цепей. Используйте такой пункт, чтобы быстро выбрать целевую цепь для поля New Net Name.
- Change Copper Net To Net - этот пункт меню появляется, когда примитивам в группе соединённых медных объектов назначено слишком много цепей, чтобы представить их отдельными пунктами меню. Эта команда открывает диалоговое окно Choose Net со списком всех цепей, назначенных примитивам группы. Выберите нужную цепь и нажмите OK; эта цепь будет внесена в поле New Net Name для текущей группы соединённых медных объектов.
- Change Copper Net To Board Net - используйте эту команду, если нужна цепь, отличная от уже назначенных примитивам текущей группы соединённых медных объектов. Откроется диалоговое окно Choose Net со списком всех цепей, определённых для платы. Выберите нужную цепь и нажмите OK; эта цепь будет внесена в поле New Net Name.
- Show All Primitives - нажмите эту кнопку, чтобы быстро отобразить все примитивы. Кнопка становится доступной, если в меню отключены параметры Show Component Pads и/или Show Non Component Pads.
Вы также можете удалить все назначения цепей из текущего документа проекта, фактически очистив внутренний список соединений платы. Это может потребоваться, если вы изменили информацию о цепях в исходных документах схемы и хотите полностью синхронизировать плату со списком соединений исходной схемы. Для этого выберите Design » Netlist » Clear All Nets команду в главном меню. После запуска команды откроется диалоговое окно с предупреждением о том, что эта операция удалит всю информацию о цепях с печатной платы. После нажатия Yes вся информация о цепях будет удалена. Все проложенные дорожки сохранятся, но им будет присвоено значение No Net. Все неразведённые логические соединения будут удалены.
Чтобы создать файл списка цепей на основе связности, сформированной трассировкой в текущем проекте, выберите команду Design » Netlist » Create Netlist From Connected Copper в главном меню. После нажатия Yes в открывшемся диалоговом окне подтверждения список цепей (Generated <PCBDocumentName>.Net, добавляемый на панель Projects как свободный документ в подпапку Source Documents) будет создан в той же папке, что и документ проекта печатной платы, и автоматически открыт как активный документ. Каждая цепь в списке получает имя одной из контактных площадок, к которым подключены проложенные медные проводники.

