Работа с размещенными компонентами
Краткий обзор
- Узнайте, откуда берутся компоненты, как работать с секциями и многосекционными компонентами и какими основными способами их можно размещать на схеме.
- Посмотрите, как эффективнее искать компоненты и быстро выполнять графические операции во время или после размещения.
- Разберитесь, как компоненты схемы связаны с компонентами печатной платы и какие основные свойства можно просматривать и изменять после размещения.
Компонент в библиотеке представляет физическое устройство, размещаемое на реальной печатной плате. На листе схемы компонент представлен моделью условного графического обозначения (УГО). Каждый компонент может содержать одну или несколько секций.
Секция

Секция представляет реальный физический электронный компонент.
Общие сведения
Секция — это примитив электрической схемы. Она представляет собой УГО электронного устройства, например резистора, переключателя, операционного усилителя, стабилизатора напряжения и т. д. Секции хранятся в составе компонентов в библиотеках компонентов схем. Обратите внимание, что каждый компонент может содержать одну или несколько секций. Помимо графического представления компонента, секция также содержит ссылки на модели, например посадочное место на печатной плате, и параметры, используемые для документирования характеристик компонента и сведений о поставщике. Способ добавления ссылок на модели и параметров в секцию зависит от используемого типа библиотечного хранилища.
Доступность
Секции можно размещать как в редакторе схем, так и в редакторе библиотек схем.
- В редакторе схем нажмите Place » Part.
- Щелкните правой кнопкой мыши в рабочей области и выберите Place » Part в контекстном меню.
- На панели Components щелкните правой кнопкой мыши по компоненту и выберите Place <ComponentName>.
- На панели Components выберите типовой компонент в качестве заполнителя.
- Перетащите компонент с панели Components.
- Нажмите кнопку Place в области Details панели Components или воспользуйтесь сочетанием клавиш Enter.
- В редакторе библиотек схем выберите компонент на панели SCH Library, затем нажмите Place.
Размещение с панели Components
В редакторе схем выбор и размещение секций можно выполнять с панели Components.
- На панели отображается содержимое выбранной библиотеки. Чтобы выбрать другую библиотеку, воспользуйтесь раскрывающимся списком рядом с ее названием.
- Используйте поле маски под полем выбранной библиотеки, чтобы отфильтровать список и ускорить поиск, либо прокрутите список и выберите нужную секцию.
- Нажмите Place, дважды щелкните по выбранному компоненту или перетащите его, чтобы разместить на активном листе схемы. Пока секция находится на курсоре, перед размещением ее можно повернуть (нажмите Spacebar), зеркально отразить относительно оси (нажмите X или Y) или отредактировать (нажмите Tab).
- Столбцы в списке компонентов выбранной библиотеки можно переставлять (перетаскиванием) или настраивать (щелкните правой кнопкой мыши и выберите Select Columns).
-
Нажмите кнопку
на плитке типового компонента, чтобы прикрепить компонент к курсору для размещения в активном документе схемы. При выборе самой плитки на панели Components откроется категория компонентов соответствующего типа.
Поиск компонента
Пункты меню библиотек, не относящихся к Workspace, позволяют задавать настройки, выполнять поиск и переносить содержимое библиотек на основе баз данных и файлов. Чтобы открыть эти пункты, нажмите кнопку меню библиотек
в правом верхнем углу панели Components.
Выберите File-based Libraries Preferences, чтобы открыть диалоговое окно Available File-based Libraries, в котором доступны элементы управления для добавления, удаления и установки библиотек, а также задания путей поиска библиотек.
Текущий список компонентов библиотек на основе баз данных и файлов можно отфильтровать, введя поисковую фразу в поле Search панели Components. Для доступа к расширенным возможностям поиска в библиотеках компонентов выберите пункт File-based Libraries Search в меню
панели (в правом верхнем углу). Откроется диалоговое окно File-based Libraries Search. В нем доступны гибкие настройки поиска, включая ограничения фильтра на основе запросов, а также поиск по всем доступным библиотекам на основе баз данных и файлов или по библиотекам в указанном каталоге.
- По умолчанию для поиска Scope задан поиск Components в Available File-based Libraries.
- Кроме того, диалоговое окно поддерживает поиск по Libraries on path, хранящимся в папках на диске. Для этого включите параметр Libraries on path, затем настройте параметры Path нужным образом.
- В Filters используется логическое «И», поэтому лучше начинать с простого фильтра, а при большом количестве результатов использовать режим Refine last search для поиска среди найденного.
- При выборе Helper результаты поиска по запросу отображаются в диалоговом окне File-based Libraries Search.
Размещение из редактора библиотек схем
Секцию также можно разместить непосредственно из библиотеки, открытой в редакторе библиотек схем, с помощью панели SCH Library. Обратите внимание:
- Нажатие кнопки Place на панели размещает выбранную секцию (компонент) на последнем активном листе схемы.
- Пока секция находится на курсоре, перед размещением ее можно повернуть (нажмите Spacebar), зеркально отразить относительно оси (нажмите X или Y) или отредактировать (нажмите Tab). Эти действия также можно выполнять при перетаскивании объекта. Поворот выполняется с шагом 90°.
-
При размещении секции непосредственно из библиотеки предварительно добавлять эту библиотеку в диалоговом окне Available File-based Libraries не требуется.
Графическое редактирование
Графическое редактирование секции ограничивается перемещением, поворотом и зеркальным отражением. При выборе секции в рабочей области вокруг нее появляется пунктирная рамка выделения. Для графического редактирования выбранного компонента:
- Нажмите Delete, чтобы удалить выбранную секцию из проекта.
- Нажмите и удерживайте кнопку мыши, чтобы переместить выбранную секцию. Курсор переместится к ближайшей точке электрического подключения (концу ближайшего вывода, к которому подключается провод).
- Нажмите Spacebar, чтобы повернуть дугу против часовой стрелки, или Shift+Spacebar для поворота по часовой стрелке. Это действие также можно выполнять при перетаскивании объекта. Поворот выполняется с шагом 90°.
- Пока секция перемещается вместе с курсором, нажмите клавишу X или Y, чтобы зеркально отразить ее относительно соответствующей оси.
Работа с компонентом на схеме и на печатной плате
Программа включает инструменты для работы с компонентом на схеме и тем же компонентом на печатной плате. К ним относятся перекрестный переход, перекрестное выделение и выбор компонентов печатной платы со схемы.
Перекрестный переход
Как следует из названия, перекрестный переход позволяет щелкнуть компонент в одном редакторе и перейти к этому компоненту в другом редакторе. Чтобы выполнить перекрестный переход:
- Выберите Cross Probe в меню Tools редактора схем или печатных плат.
- При щелчке по компоненту в редакторе схем он будет показан по центру и в увеличенном масштабе в редакторе печатных плат. Масштаб задается на странице System – Navigation диалогового окна Preferences.
- По умолчанию вы остаетесь в текущем редакторе и можете выполнить перекрестный переход к другому компоненту. Чтобы при перекрестном переходе переключиться в другой редактор, удерживайте клавишу Ctrl.
Режим перекрестного выделения
Режим перекрестного выделения выделяет тот же компонент в другом редакторе. Обратите внимание: масштабирование и центрирование при этом не выполняются. Перекрестное выделение может быть включено или отключено. Нажмите Tools » Cross Select Mode, чтобы включить или отключить этот режим. Чтобы выделить несколько компонентов, удерживайте клавишу Shift при щелчках по ним.
Выбор компонентов печатной платы
Эта функция позволяет выбрать несколько компонентов схемы в определенном порядке, а затем разместить эти же компоненты в редакторе печатных плат в том же порядке. Чтобы воспользоваться этой функцией:
- Последовательно выберите компоненты на схеме (удерживайте Shift при щелчках, чтобы выбрать несколько компонентов).
- Переключитесь в редактор печатных плат и нажмите сочетание клавиш I, C, чтобы запустить команду Reposition Selected Components. Команда Reposition Selected Components также доступна в контекстном меню после нажатия сочетания клавиш I.
Свойства части компонента
Вкладка General
Общие параметры
-
Reuse Block – если компонент входит в блок повторного использования, в этом поле отображается имя родительского блока повторного использования. Нажмите гиперссылку Reuse Block, чтобы просмотреть свойства этого блока повторного использования.
-
Designator – введите позиционное обозначение. Используйте значок глаза, чтобы показать или скрыть позиционное обозначение. Используйте значок замка, чтобы заблокировать или разблокировать позиционное обозначение. Подробнее о позиционном обозначении.
-
Comment – введите имя или комментарий. Используйте значок глаза, чтобы показать или скрыть имя. Используйте значок замка, чтобы заблокировать или разблокировать имя. Поле Comment также можно использовать для отображения значения пользовательского или системного параметра. Подробнее о комментарии.
-
Part <x> of Parts – отображает номер выбранной части компонента и общее количество частей. Нажмите
, чтобы заблокировать или разблокировать поля, затем выберите номер соответствующей части в раскрывающемся списке.
-
Description – описание компонента или его части.
-
Type – выберите здесь один из следующих типов компонентов для посадочного места компонента. Доступны следующие типы:
-
Standard– компоненты, которые обладают стандартными электрическими свойствами, всегда синхронизируются между схемой и печатной платой (посадочное место, выводы/контактные площадки и назначение цепей должны совпадать) и включаются в спецификацию (BOM). Пример — стандартный электрический компонент, такой как резистор. -
Mechanical– компоненты, которые не обладают электрическими свойствами, не синхронизируются (их необходимо вручную размещать в обоих редакторах) и включаются в спецификацию (BOM). Пример — радиатор. -
Graphical– компоненты, которые не обладают электрическими свойствами, не синхронизируются (их необходимо вручную размещать в обоих редакторах) и not включаются в спецификацию (BOM). Пример — логотип компании. -
Net Tie (In BOM)– компоненты, которые используются для замыкания двух или более разных цепей, всегда синхронизируются между схемой и печатной платой (посадочное место, выводы/контактные площадки и назначение цепей должны совпадать) и включаются в спецификацию (BOM). Они отличаются от компонентов типа Standard тем, что соединения, образованные медью внутри посадочного места, не проверяются; именно эта медь позволяет замыкать цепи. Примечание: включите параметр Verify Shorting Copper в диалоговом окне Design Rule Checker, чтобы убедиться в отсутствии неподключенной меди внутри компонента. -
Net Tie (No BOM)– компоненты, которые используются для замыкания двух или более разных цепей, всегда синхронизируются между схемой и печатной платой (посадочное место, выводы/контактные площадки и назначение цепей должны совпадать) и not включаются в спецификацию (BOM). Они отличаются от компонентов типа Standard тем, что соединения, образованные медью внутри посадочного места, не проверяются; именно эта медь позволяет замыкать цепи. Примечание: включите параметр Verify Shorting Copper в диалоговом окне Design Rule Checker, чтобы убедиться в отсутствии неподключенной меди в компоненте. -
Standard (No BOM)– компоненты, которые обладают стандартными электрическими свойствами, всегда синхронизируются между схемой и печатной платой (посадочное место, выводы/контактные площадки и назначение цепей должны совпадать) и not включаются в спецификацию (BOM). Пример — компонент контрольной точки, который требуется исключить из спецификации (BOM). -
Jumper– компоненты, которые используются для добавления проволочных перемычек в проект печатной платы, например на односторонней плате, которую невозможно полностью трассировать на одном слое. Для этого типа компонентов посадочное место и выводы синхронизируются между схемой и печатной платой, а назначение цепей — нет; компонент включается в спецификацию (BOM). Помимо выбора этого параметра на уровне компонента, для обеих его контактных площадок необходимо задать одинаковое ненулевое значение JumperID. Компоненты типа Jumper не требуется соединять проводами на схеме; их нужно включать в схему только в том случае, если они должны присутствовать в спецификации (BOM). Если они не нужны в спецификации (BOM), их можно разместить непосредственно на печатной плате, где задается Component Type, устанавливаются JumperIDs и вручную назначаются Nets для контактных площадок.
-
-
Design Item ID – в этом поле отображается имя выбранного компонента (для компонента из Workspace), выбранное ключевое поле, определенное в Field Settings области файла DbLib/SVNDbLib (для компонента библиотеки баз данных) или параметра Design Item ID, заданного для символа компонента (для компонента файловой библиотеки). Нажмите
, чтобы открыть диалоговое окно Замена компонента. В этом диалоговом окне доступны полные сведения о выбранном компоненте (параметры, модели, варианты компонентов, данные поставщиков и т. д.), сравнение компонентов, замена текущего компонента другим и другие возможности. Если для замены выбран другой компонент, в этом поле будет отображаться полное значение Design Item ID для нового выбранного компонента. Нажмите кнопку Validate , чтобы просмотреть информацию о расположении компонента. Если компонент не относится к рабочему пространству, отобразится путь к файлу, в котором он сохранен на вашем компьютере. Если компонент относится к рабочему пространству, будет показано сообщение о том, что компонент найден.
-
Source — отображает имя исходной библиотеки компонента. Нажмите
, чтобы найти и выбрать нужную библиотеку.
-
Revision state — в этом поле отображается текущее состояние жизненного цикла выбранной ревизии компонента: цветной значок и название состояния ревизии.
-
Revision status — если выбранная ревизия компонента находится в допустимом состоянии (разрешена для использования в проектах), запись показывает, является ли ревизия последней (
Up to date) или нет (Out of date). Если ревизия находится в недопустимом состоянии (не разрешена для использования в проектах), отображаетсяNot applicable. Нажмите кнопку
, чтобы обновить компонент до последней ревизии.
-
Component issues (только на панели Properties) — если у выбранного компонента из подключенного рабочего пространства Altium 365 обнаружены проблемы, они обозначаются значком
(для ошибок) или
(для критических ошибок). Число справа от значка указывает количество обнаруженных проблем. Нажмите стрелку вниз справа от числа, чтобы просмотреть краткие описания проблем.

Пример обнаруженных проблем состояния библиотеки. -
Supply Chain Data (только на панели Properties) — отображает информацию о цепочке поставок для соответствующего варианта компонента:
- Медианная цена за единицу. Эта запись отображается красным цветом, если цены отсутствуют или цена = 0.
- Складские запасы. Эта запись отображает суммарный объем запасов у поставщиков, включенных в источник Altium Parts Provider для вашего рабочего пространства.
-
Индикатор жизненного цикла у производителя. Наведите указатель на индикатор, чтобы просмотреть информационную подсказку. Индикатор может находиться в одном из четырех состояний:
- Белый/серый = по умолчанию, неизвестно или нет информации
- Зеленый = новый компонент или серийное производство
- Оранжевый = не рекомендуется для новых разработок
- Красный = устарел или достиг конца жизненного цикла (EOL)
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области проекта. Измените значение, чтобы изменить положение объекта по оси X. Значение можно вводить в метрических или британских единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе значения.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно вводить в метрических или британских единицах; если используемые единицы отличаются от текущих единиц по умолчанию, укажите их при вводе значения.
-
Rotation — выберите угол поворота в раскрывающемся списке. Доступные варианты:
0 Degrees,90 Degrees,180 Degreesи270 Degrees.
Параметры
-
Grid – список Name и Value параметров, связанных с выбранным компонентом. Используйте
, чтобы заблокировать или разблокировать параметр в списке и предотвратить его обновление. Значения параметров можно вводить вручную или выбирать из раскрывающегося списка, содержащего значения из всех доступных компонентов данного типа. Нажимайте значок глаза, чтобы показать или скрыть параметр.
-
Favorites – параметры, отмеченные как избранные, отображаются в списке Parameters, а остальные скрыты. Наведите указатель на область справа от имени фильтра параметров и нажмите значок
, чтобы добавить фильтр в избранное. Чтобы удалить параметр из избранного, нажмите этот значок еще раз.
Чтобы увидеть все скрытые параметры, нажмите элемент управления Show More внизу списка. Нажмите элемент управления Show Less, чтобы просматривать только избранные параметры.
-
Font – нажмите на отображаемый шрифт, чтобы изменить его начертание.
-
Other – нажмите, чтобы открыть раскрывающийся список дополнительных настроек:
- Show Parameter Name – включите, чтобы отображать имя параметра.
- Allow Synchronization with Database – включите для синхронизации с базой данных. Эта опция определяет, можно ли обновлять комментарий. По умолчанию эти опции включены, чтобы всегда разрешать синхронизацию с исходной библиотекой или базой данных. Можно отключить эту опцию, чтобы исключить данный комментарий из процесса обновления.
- (X/Y) – введите координаты X и Y.
-
Rotation – выберите угол поворота из раскрывающегося списка. Доступные варианты:
0°,90°,180°и270°. - Autoposition – установите флажок, чтобы включить автоматическое позиционирование: в этом случае положение параметра задается автоматически при каждом повороте связанного компонента. Отключите эту опцию, чтобы при повороте компонента сохранять положение параметра относительно него.
-
Add – нажмите, чтобы добавить параметр, например посадочное место, модель или правило. Нажмите
, чтобы удалить выбранную запись из таблицы. Нажмите
, чтобы изменить параметр в соответствующем диалоговом окне.
Графическое представление
-
Mode – выберите нужный режим из раскрывающегося списка. Если кроме Normal нет доступных режимов, этот список будет неактивен.
- Mirrored – включите, чтобы зеркально отразить секцию.
- Local Colors – включите опцию локальных цветов, чтобы заменить цвета заливки, линий и выводов компонента схемы цветами из полей Fill, Lines и Pins соответственно. Отключите эту опцию, чтобы использовать цвета, заданные в библиотеке.
Варианты компонентов
В этой области представлены сведения о вариантах компонентов и ссылках на поставщиков, назначенных выбранному компоненту. Подробнее о сведениях, представленных в записях этого раздела, см. на странице Добавление информации о цепочке поставок в компонент.
Вкладка Pins
-
Grid – в этой области перечислены Pins и Names для всех выводов выбранного компонента. Используйте значок глаза, чтобы показать или скрыть вывод. Используйте значок замка, чтобы заблокировать или разблокировать выводы.
Для многофункционального вывода (вывода, функции которого заданы в поле Functions в режиме Pins панели Properties) щелкните ячейку этого вывода в столбце Name и выберите функцию вывода из появившегося раскрывающегося списка. Выбранная функция будет отображаться как имя вывода на листе схемы.
- Show Full/Show Short — в Show Full отображаются полные расширенные имена всех перечисленных выводов; в режиме Show Short отображается текущее имя вывода.
-
– когда кнопка включена (значок закрытого замка), выводы компонента нельзя редактировать в редакторе схем (но можно в редакторе библиотек схем). Отключите эту опцию, чтобы редактировать вывод компонента на листе схемы.
-
– нажмите, чтобы отобразить все скрытые выводы и их свойства (имена и номера), включая выводы, у которых свойство Show отключено в редакторе выводов компонента. Обратите внимание: если вы работаете в редакторе библиотек схем, для отображения скрытых выводов также необходимо включить опцию View » Show Hidden Pins.
-
– нажмите, чтобы добавить вывод к компоненту. Настройте вывод на панели Properties, затем щелкните и перетащите его в нужное положение.
-
– нажмите, чтобы удалить выбранные выводы из компонента.
-
– нажмите, чтобы открыть диалоговое окно редактора выводов компонента. Это окно позволяет удобно просматривать и редактировать все выводы компонента, открытого в редакторе библиотек схем, либо выбранного компонента (или его секции) в редакторе схем.
Свойства универсального компонента
Универсальные компоненты

Размещение универсального компонента с панели Components
Когда Altium Designer подключен к рабочему пространству, доступные универсальные компоненты можно найти на панели Components. Они отображаются при выборе опции All в области Categories — либо в верхнем раскрывающемся меню, если панель находится в компактном режиме. Нажмите кнопку
на плитке универсального компонента, чтобы прикрепить компонент к указателю для размещения на активной схеме. При выборе самой плитки на панели Components откроется категория компонентов этого типа.
Свойства универсального компонента
Общие
- Designator — введите позиционное обозначение. Используйте значок глаза, чтобы показать или скрыть позиционное обозначение. Нажмите значок замка, чтобы заблокировать или разблокировать позиционное обозначение.
- Comment — введите имя. Используйте значок глаза, чтобы показать или скрыть имя.
-
Description — описание универсального компонента/секции.
- Replace — нажмите кнопку Replace, когда проект достигнет стадии, на которой универсальный компонент можно заменить конкретным физическим компонентом с помощью диалогового окна замены компонента.
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение объекта по оси X. Значение можно вводить в метрических или британских единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно вводить в метрических или британских единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Rotation — выберите угол поворота в раскрывающемся списке.
Параметры
- Grid — список Name и Value параметров, связанных с выбранным компонентом. Используйте значок замка, чтобы заблокировать или разблокировать параметр в списке. Значения параметров можно вводить вручную или выбирать из раскрывающегося списка, содержащего значения из всех доступных компонентов этого типа. Используйте значок глаза, чтобы показать или скрыть параметр.
- Font — щелкните отображаемый шрифт, чтобы изменить его начертание.
-
Other — нажмите, чтобы открыть раскрывающееся меню с дополнительными настройками:
- Show Parameter Name — включите, чтобы отображать имя параметра.
- Allow Synchronization with Database — включите для синхронизации с базой данных. Эта опция определяет, можно ли обновлять комментарий. По умолчанию эти опции включены, чтобы всегда разрешать синхронизацию с исходной библиотекой/базой данных. Вы можете отключить эту опцию, чтобы исключить данный комментарий из процесса обновления.
- (X/Y) — введите координаты X и Y.
- Rotation — выберите угол поворота в раскрывающемся списке.
- Autoposition — установите флажок, чтобы включить автоматическое позиционирование: положение параметра будет автоматически определяться при каждом повороте связанного компонента. Отключите эту опцию, чтобы при повороте компонента сохранять положение параметра относительно него.
Позиционное обозначение
Позиционное обозначение однозначно идентифицирует каждый компонент в проекте.
Краткие сведения
Поле позиционного обозначения — это дочерний объект-параметр компонента (секции) схемы. Оно используется для однозначной идентификации каждой размещенной секции, чтобы отличать ее от всех остальных секций, размещенных на всех листах схем проекта.
Доступность и размещение
Позиционное обозначение размещается автоматически при размещении родительского объекта — секции компонента. Оно не является объектом проектирования, который можно разместить напрямую.
Графическое редактирование
Строку позиционного обозначения можно редактировать графически с помощью так называемого редактирования in-place. Чтобы изменить строку позиционного обозначения на месте, выделите обозначение рамкой с помощью указателя, затем нажмите Enter.

Пример редактирования на месте
Завершив редактирование, нажмите Enter или щелкните за пределами строки, чтобы выйти из режима редактирования на месте.
Неграфическое редактирование
При редактировании позиционного обозначения следует учитывать два аспекта: изменение его значения и изменение свойств его отображения.
Строки позиционного обозначения (и комментария) можно отобразить в редакторе библиотек схем, а затем дважды щелкнуть по ним для редактирования свойств. Значок
рядом с полем на панели Properties используется для отображения или скрытия позиционного обозначения.
Редактирование значения позиционного обозначения в редакторе схем
Позиционное обозначение можно задать в редакторе схем во время размещения компонента или после его размещения на листе схемы в Properties panel.
- Чтобы изменить позиционное обозначение во время размещения компонента, нажмите клавишу Tab, пока компонент прикреплен к курсору. Откроется панель Properties ; введите требуемую строку позиционного обозначения. Нажмите кнопку приостановки, отображаемую поверх рабочей области , чтобы продолжить размещение.
- Продолжайте размещать компоненты или нажмите Esc для завершения размещения.
- Нажмите Spacebar, чтобы повернуть дугу против часовой стрелки, или Shift+Spacebar, чтобы повернуть ее по часовой стрелке. Это действие также можно выполнить при перетаскивании объекта. Поворот выполняется с шагом 90°.
- Чтобы изменить позиционное обозначение после размещения, дважды щелкните по размещенному компоненту. Откроется панель Свойства , на которой можно отредактировать позиционное обозначение.
Редактирование свойств отображения позиционного обозначения
Внешний вид строки позиционного обозначения, включая тип, размер и цвет шрифта, можно настроить на странице Схема — Значения по умолчанию диалогового окна Preferences. Эти настройки применяются, если они не переопределены настройками, заданными для символа компонента в редакторе библиотек схем.
Фиксация положения строки позиционного обозначения
По умолчанию позиционное обозначение автоматически меняет положение при повороте компонента во время размещения. Если такое поведение не требуется, отключите параметр Autoposition в диалоговом окне Preferences (см. предыдущее изображение) при создании символа или после размещения компонента на листе схемы. Обратите внимание, что при этом данный параметр классифицируется как manual parameter (то есть параметр, положение которого задано вручную). Такие параметры отмечаются точкой в левом нижнем углу рамки выделения.
Примечания
-
Редактор схем поддерживает простую функцию автоматического увеличения номера позиционного обозначения, которую можно использовать при размещении нескольких экземпляров одного и того же компонента. Чтобы воспользоваться ею, нажмите Tab, пока первый компонент прикреплен к курсору, и введите подходящее позиционное обозначение, например
R1. Следующим компонентам будут присвоены обозначенияR2,R3и т. д. Обратите внимание: при переходе к размещению компонента другого типа необходимо снова нажать Tab и ввести соответствующий префикс позиционного обозначения. -
При размещении многосекционных компонентов, если начальное позиционное обозначение задано описанным выше способом, суффикс секции назначается автоматически, например
U3A,U3Bи т. д. Если начальное позиционное обозначение не задано, все секции будут иметь одинаковый суффикс. Это исправляется командой Annotation редактора схем. Суффикс секции может быть буквенным или числовым. Для настройки используйте параметр Alpha Numeric Suffix на странице Схема — Общие диалогового окна Preferences.
Свойства позиционного обозначения
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение объекта по оси X. Значение можно вводить как в метрических, так и в британских единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно вводить как в метрических, так и в британских единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Rotation — выберите угол поворота в раскрывающемся списке.
Свойства
- Object — отображает связанный объект.
- Имя — включите отображение этого поля, щелкнув значок видимости , чтобы добавить префикс «Позиционное обозначение:» к самому значению позиционного обозначения. Это позволяет визуально выделить текстовое значение и подтвердить, что оно является позиционным обозначением в документе схемы.
-
Value — отображает само позиционное обозначение. Щелкните значок глаза
, чтобы показать или скрыть значение.
- Автопозиционирование — установите флажок, чтобы включить автоматическое позиционирование: текст будет оставаться в выбранном положении относительно компонента при его перемещении и повороте.
- Заблокировать параметр — установите флажок, чтобы заблокировать параметр и запретить изменение его значения на панели Properties или в документе схемы.
- Разрешить синхронизацию с базой данных — включите для синхронизации с базой данных. Этот параметр определяет, можно ли обновлять комментарий. По умолчанию эти параметры включены, чтобы всегда разрешать синхронизацию с исходной библиотекой или базой данных. Отключите этот параметр, чтобы исключить комментарий из процесса обновления.
- Шрифт — используйте элементы управления, чтобы выбрать шрифт, его размер и цвет, а также задать нужное начертание, например полужирное, курсив или подчеркивание.
- Выравнивание — нажимайте стрелки, чтобы настроить выравнивание текста, или круг, чтобы выровнять его по центру.
- Override Library Primitive (только в диалоговом окне Preferences ) — установите этот флажок, чтобы переопределить настройки примитива, заданные для объекта позиционного обозначения в библиотеке. В результате при размещении компонента будут применяться настройки примитива, заданные в диалоговом окне «Настройки», а не настройки, определенные для компонента в библиотеке.
Комментарий
Комментарий позволяет отображать дополнительную информацию о компоненте.
Общие сведения
Поле комментария — это дочерний объект-параметр компонента (секции) схемы. Оно отображает дополнительную информацию о компоненте.
Доступность и размещение
Комментарий настраивается при размещении родительского объекта — секции компонента. Он не является объектом проекта, который можно разместить напрямую.
Графическое редактирование
Комментарий можно редактировать графически с помощью так называемого in-place редактирования. Чтобы отредактировать комментарий на месте, щелкните по нему один раз для выделения, подождите секунду, затем щелкните еще раз для перехода в режим редактирования.
Щелкните один раз, чтобы выделить строку.
Завершив редактирование, нажмите Enter или щелкните вне строки, чтобы выйти из режима редактирования на месте.
Неграфическое редактирование
При редактировании комментария следует учитывать два аспекта: изменение значения комментария и изменение свойств его отображения.
Редактирование комментария в редакторе схем
Комментарий можно задать в редакторе схем во время размещения компонента или после его размещения на листе схемы в поле Comment панели Properties.
- Чтобы изменить комментарий во время размещения компонента, нажмите клавишу Tab, пока компонент находится на курсоре. Откроется панель Properties ; введите нужный комментарий. Нажмите кнопку паузы, отображаемую поверх рабочей области , чтобы возобновить размещение компонента.
- Продолжайте размещать компоненты или нажмите Esc, чтобы завершить размещение.
- Чтобы изменить комментарий после размещения, дважды щелкните по размещенному компоненту. Откроется панель Свойства , в которой можно изменить комментарий.
Редактирование свойств отображения комментария
Внешний вид комментариев, включая тип, размер и цвет шрифта, можно настроить на странице Схема — Значения по умолчанию диалогового окна Preferences .
Фиксация положения комментария
По умолчанию положение комментария автоматически изменяется при повороте компонента во время размещения. Если такое поведение не требуется, отключите параметр Autoposition в диалоговом окне Preferences (см. предыдущее изображение) при создании условного обозначения или после размещения компонента на листе схемы. Обратите внимание: при этом данный параметр классифицируется как manual parameter (то есть параметр, размещенный вручную). Параметры, размещенные вручную, обозначаются точкой в левом нижнем углу рамки выделения.
Свойства комментария
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените ее, чтобы переместить объект по оси X. Значение можно вводить в метрических или дюймовых единицах; указывайте единицы измерения, если они отличаются от используемых по умолчанию.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените ее, чтобы переместить объект по оси Y. Значение можно вводить в метрических или дюймовых единицах; указывайте единицы измерения, если они отличаются от используемых по умолчанию.
- Rotation — выберите угол поворота в раскрывающемся списке. Доступные варианты: 0 Degrees, 90 Degrees, 180 Degrees и 270 Degrees.
Свойства
- Компонент — отображает имя связанного компонента. Нажмите ссылку Component , чтобы открыть панель свойств компонента, где можно изменить параметры компонента, а также сам комментарий, который задается в поле Comment этой панели.
- Имя — включите это поле, нажав значок видимости , чтобы добавить префикс «Комментарий:» к значению комментария. Это визуально выделяет текстовое значение и подтверждает, что оно является комментарием в документе схемы.
-
Значение — отображает само имя комментария. Используйте , чтобы показать или скрыть значение.
- Автоматическое позиционирование — установите флажок, чтобы включить автоматическое позиционирование: текст будет оставаться в выбранном положении при перемещении и повороте компонента.
- Заблокировать параметр — установите флажок, чтобы заблокировать параметр и запретить изменение его значения на панели Properties или в документе схемы.
- Разрешить синхронизацию с базой данных — включите для синхронизации с базой данных. Этот параметр определяет, можно ли обновлять комментарий. По умолчанию он включен, чтобы всегда разрешать синхронизацию с исходной библиотекой или базой данных. Его можно отключить, чтобы исключить комментарий из процесса обновления.
- Шрифт — используйте элементы управления для выбора шрифта, его размера и цвета, а также нужного начертания, например полужирного, курсивного или подчеркнутого.
- Выравнивание — нажимайте стрелки, чтобы настроить выравнивание текста, или круг, чтобы выровнять его по центру.
- Override Library Primitive (только в диалоговом окне Preferences ) — установите этот флажок, чтобы переопределить настройки примитива, заданные для объекта комментария в библиотеке. В результате при размещении компонента будут использоваться настройки примитива, заданные в диалоговом окне Preferences, а не настройки, заданные для компонента в библиотеке.
Обновление и замена компонентов из библиотеки
После первоначального размещения компонентов на листах схемы проекта платы необходимо иметь возможность обновлять эти экземпляры с учетом изменений связанных исходных компонентов в соответствующем рабочем пространстве. Иными словами, нужен способ поддерживать синхронизацию проекта с используемыми в нем объектами рабочего пространства.
Например, компонент мог быть повторно сохранен в рабочем пространстве, в том числе вследствие изменения дочерней модели. При этом создается новая ревизия компонента. Размещенный экземпляр этого компонента теперь использует более старую ревизию, и вам может потребоваться обновить его до последней ревизии. Или же вы могли решить использовать совершенно другой компонент, и вам нужно просто заменить существующий компонент в проекте на альтернативный.
Для управления компонентами после их первоначального размещения в проекте доступны различные способы.
Изменение отдельного экземпляра компонента
Каждый размещенный компонент связан с ревизией компонента в рабочем пространстве. Эту информацию можно найти на панели Properties при просмотре свойств выбранного компонента.
Каждый размещенный экземпляр компонента связан с определенной ревизией этого компонента в рабочем пространстве.
На этом базовом уровне — уровне отдельного компонента — размещенный экземпляр можно:
-
Обновить до последней ревизии существующего компонента, нажав кнопку
.
Пример обновления того же компонента до последней ревизии — наведите указатель на изображение, чтобы увидеть результат.
-
Заменить последней ревизией другого компонента рабочего пространства или компонентом из файловой библиотеки, нажав кнопку
справа от поля Design Item ID. Откроется диалоговое окно Replace Component с компонентами из подключенного рабочего пространства и доступных файловых библиотек. Текущий компонент отображается в начале списка. Найдите нужный компонент для замены, выберите его и нажмите OK.
Пример замены существующего компонента другим (альтернативным)
Диалоговое окно Replace Component предоставляет прямой доступ ко всем доступным компонентам библиотек рабочего пространства и файловых библиотек. В нем представлены подробные сведения о выбранном компоненте (параметры, модели, варианты комплектующих, данные поставщиков и т. д.), возможность сравнения компонентов, а для компонентов библиотек рабочего пространства — параметрический поиск на основе фильтров, позволяющий задать требуемые параметры компонента.
Параметры и элементы управления диалогового окна Replace Component
- Search — используйте текстовое поле поиска для поиска определенного компонента вручную.
-
— нажмите, чтобы развернуть или свернуть панель Categories для отображения определенных типов компонентов или всех доступных компонентов. Используйте строку поиска под панелью Categories для поиска определенной категории компонентов или доступной файловой библиотеки компонентов вручную.
-
— нажмите, чтобы открыть меню и выбрать один из следующих пунктов:
- File-based Libraries Preferences — нажмите, чтобы открыть диалоговое окно Available File-based Libraries для добавления или удаления библиотек.
- File-based Libraries Search — нажмите, чтобы открыть диалоговое окно File-based Libraries Search для поиска библиотек.
- Refresh — нажмите, чтобы обновить содержимое диалогового окна.
-
— нажмите, чтобы открыть или закрыть Details область диалогового окна (описана ниже).
Фильтры
Когда выбрана категория компонентов рабочего пространства, нажмите значок Filters , чтобы открыть область Filters, в которой можно дополнительно отфильтровать категории, выбранные в списке Components . Параметры панели Filters можно настроить в соответствии со своими потребностями, отметив определенные типы параметров как Favorites. После этого они переместятся в начало списка для текущей категории компонентов. Наведите указатель на область справа от имени фильтра параметра и нажмите значок , чтобы добавить фильтр в избранное. Настройки избранных фильтров применяются и сохраняются отдельно для каждой Categories компонентов.
Компоненты
- Name — имя компонента.
- Description — описание каждого компонента.
- Footprint — посадочное место компонента.
- Results — общее количество найденных или отображаемых в результатах поиска компонентов.
Подробные сведения
- Component Revision ID — идентификатор ревизии и цена компонента. Нажмите идентификатор ревизии, чтобы открыть панель Explorer с дополнительной информацией о компоненте.
- References — нажмите, чтобы открыть справочную информацию о компоненте в веб-браузере. Используйте раскрывающийся список для доступа к Manufacturer URL или Datasheet.
- Place — нажмите, чтобы разместить выбранный компонент в документе схемы.
- Component information — соответствующая информация о компоненте, включая производителя, дату выпуска и описание. Нажмите ссылку Show More для просмотра всей информации; нажмите Show Less , чтобы свернуть ее.
- Models — разверните для просмотра предоставленных моделей. Используйте доступные ссылки для отображения различных частей одной модели.
- References — разверните для доступа к Manufacturer URL, Datasheet и Package Specification.
- Part Choices — разверните для просмотра вариантов комплектующих. Для каждого варианта указаны наименование, цена и описание. Также приводится техническое описание компонента (Datasheet).
- Where Used — разверните для просмотра проектов, в которых используется компонент.
Контекстное меню
- Find Similar Components — нажмите, чтобы открыть диалоговое окно Find Similar Components, в котором можно найти другие компоненты с похожими характеристиками.
- Place <component> — нажмите, чтобы разместить компонент в соответствующем документе.
- Edit — нажмите, чтобы открыть документы библиотеки компонентов для выбранного компонента.
- Navigate to <revision> — нажмите, чтобы открыть выбранный компонент на панели Explorer.
- Operations — наведите указатель для доступа к действиям Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL и Full Item History.
- Refresh— нажмите, чтобы обновить содержимое и увидеть последние обновления или изменения. Для обновления также можно использовать сочетание клавиш F5.
- Library Report — если на панели Categories выбрана файловая библиотека, нажмите, чтобы открыть диалоговое окно Library Report Settings, в котором с помощью доступных элементов управления можно настроить отчет по библиотеке.
Пакетное изменение компонентов — Item Manager
Related page: Управление содержимым с помощью Item Manager
Изменять компоненты по отдельности удобно, однако при работе с большим количеством компонентов это быстро становится утомительным. Для этого нужен единый централизованный инструмент, позволяющий вносить несколько изменений в пакетном режиме. Именно для этого предназначен Item Manager (Tools » Item Manager).
Item Manager — это «центр управления» синхронизацией объектов проектирования из рабочего пространства, размещенных на листах схемы, с исходными данными, с которыми они связаны в рабочем пространстве. Он автоматически обнаруживает и выводит список всех компонентов, отмечая, являются ли они объектами рабочего пространства, а затем сравнивает ревизию элемента каждого компонента рабочего пространства на схемах с доступными ревизиями этого компонента в рабочем пространстве. Для каждого объекта приводятся сведения о текущем связанном элементе: его ревизия, состояние жизненного цикла и исходное рабочее пространство, в котором он находится.
Вы полностью контролируете, какие из этих объектов рабочего пространства обновлять и каким образом. Например:
- Выберите отдельную запись и обновите ее, чтобы использовать последнюю ревизию связанного элемента, или выберите последнюю ревизию совершенно другого элемента.
- Выберите группу записей, использующих один и тот же связанный элемент, и обновите их до последней ревизии этого элемента либо выберите последнюю ревизию совершенно другого элемента.
Все предлагаемые изменения отображаются в менеджере.
Настроив необходимые изменения, сформируйте извещение об изменении (Engineering Change Order, ECO) и просмотрите действия, которые будут выполнены для их внесения. При необходимости отключите отдельные действия — управление всегда остается за вами! Когда все будет готово, выполните ECO, и изменения будут внесены. Это быстрый, эффективный и простой способ управления размещенными в проекте объектами рабочего пространства.
Следующие примеры иллюстрируют использование Item Manager:
- Обновление нескольких компонентов для использования последней ревизии существующего компонента рабочего пространства.

Обновление группы устаревших компонентов до последних ревизий.
- Замена нескольких компонентов последней ревизией другого компонента рабочего пространства, выбранного в диалоговом окне Replace Component.

Замена одного или нескольких компонентов другим компонентом рабочего пространства.
Item Manager позволяет не только поддерживать синхронизацию компонентов в проектах с изменениями исходных данных в подключенных рабочих пространствах, но и служит мощным инструментом для переноса существующих проектов плат с локальных объектов проектирования на содержимое рабочего пространства. После переноса компонентов проекта и используемых листов схемы (device sheets) в рабочее пространство с помощью Item Manager можно «заменить» существующие компоненты и символы листов их новыми версиями из рабочего пространства. Иными словами, с точки зрения проекта компоненты остаются прежними, но их источник меняется.
Замена компонента из BomDoc
При проверке BomDoc и подготовке к заказу комплектующих нередко обнаруживаются проблемы с компонентами. Например, разработчик мог забыть окончательно выбрать компонент, либо компонент был снят с производства (EOL), и разработчик хочет изучить цены и доступность возможных замен. Можно вернуться к схеме, отредактировать компонент, выбрать подходящую деталь и затем обновить BomDoc, однако ActiveBOM позволяет выполнить замену непосредственно в BomDoc, а затем передать это изменение в схему с помощью извещения об изменении (ECO).
В BomDoc щелкните правой кнопкой мыши выбранный компонент или компоненты и выберите команду Operations » Change <ComponentName>. Откроется диалоговое окно Replace Component, в котором можно найти компонент для замены. Найдя нужный компонент, выберите его и нажмите OK. Откроется диалоговое окно Engineering Change Order с подробным описанием изменений, необходимых для синхронизации схемы с BomDoc.

Пример замены компонента непосредственно из BomDoc.
Замена обобщенного компонента
Когда проект достигнет стадии, на которой обобщенный компонент (Generic Component) можно заменить конкретным физическим компонентом, откройте диалоговое окно Replace Component, нажав кнопку
на панели Properties. Это также можно сделать из Item Manager или через документ ActiveBOM проекта.
Значения параметров, заданные для обобщенного компонента (здесь — мощность и сопротивление), автоматически используются в качестве поисковых запросов в диалоговом окне Replace Generic Component. Это позволяет выбрать подходящий компонент для замены из отфильтрованных результатов — в данном примере критериям поиска соответствуют две записи компонентов.
|
Замена обобщенного компонента через панель Properties. Замена обобщенного компонента через панель Properties. |
Управление посадочными местами во всем проекте
Редактор схем Altium Designer включает мощный инструмент Footprint Manager. Инструмент Footprint Manager, запускаемый из меню Tools редактора схем (Tools » Footprint Manager), позволяет просматривать все посадочные места, связанные с каждым компонентом во всем проекте. Поддержка множественного выбора упрощает назначение посадочных мест нескольким компонентам, изменение способа связи с посадочным местом и выбор текущего посадочного места для компонентов, которым назначено несколько посадочных мест. Footprint Manager упрощает проверку назначений посадочных мест и выявление проблем во всем проекте, что особенно полезно при работе с унаследованным проектом или проектом другой организации. Изменения в проект вносятся через систему ECO с обновлением схемы и, при необходимости, печатной платы.
В диалоговом окне Footprint Manager представлен список всех компонентов на всех исходных схемах активного проекта. Используйте элементы управления в правой части диалогового окна для управления посадочными местами, доступными компонентам проекта и используемыми ими в данный момент. Доступны следующие возможности:
- Добавление, редактирование и удаление моделей посадочных мест для одного или нескольких выбранных компонентов.
- Копирование посадочных мест между компонентами.
- Изменение текущего посадочного места (того, которое будет использоваться для представления компонента на печатной плате, из нескольких доступных для этого компонента).
- Проверка посадочных мест, позволяющая убедиться в фактической доступности их моделей, особенно тех, которые назначены текущими.
После внесения всех необходимых изменений в назначения моделей посадочных мест эти изменения применяются с помощью стандартного извещения об изменениях (Engineering Change Order, ECO). Для этого просто нажмите кнопку Accept Changes (Create ECO) в правом нижнем углу диалогового окна Footprint Manager.
Параметры и элементы управления диалогового окна «Диспетчер посадочных мест»
Список компонентов
Это список всех компонентов с листов схемы текущего активного проекта печатной платы. Представлены следующие сведения:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Просмотр и редактирование посадочных мест
Это список посадочных мест, связанных с компонентом, выбранным в Component List. Для работы с посадочными местами в списке используйте элементы управления в нижней части области или команды контекстного меню.
Контекстное меню
-
Add — нажмите, чтобы открыть диалоговое окно «Модель печатной платы» и выбрать новую модель посадочного места для добавления к выделенному компоненту схемы. Недоступно, если выбран управляемый компонент.
-
Remove — нажмите, чтобы удалить выбранное посадочное место. Недоступно, если выбран управляемый компонент.
-
Edit Footprint — нажмите, чтобы открыть диалоговое окно «Модель печатной платы». Диалоговое окно PCB Model определяет, какая модель посадочного места связана с компонентом схемы и в каких библиотеках редактор схем может искать это посадочное место. Недоступно, если выбран управляемый компонент.
-
Validate Footprint Paths — нажмите, чтобы проверить, можно ли найти выделенное посадочное место в разрешенном расположении. Если посадочное место не найдено, в поле Found In отображается Not Validated . Если проверка прошла успешно, отображается полный путь к этому посадочному месту.
-
Change PCB Library — нажмите, чтобы открыть диалоговое окно Edit PCB Library и изменить библиотеку посадочных мест для выбранного посадочного места. Это упрощенная версия диалогового окна PCB Model, предоставляющая доступ к параметрам PCB Library, которые определяют, где программа может искать модели посадочных мест.

Диалоговое окно Edit PCB Library- Any — поиск соответствующей модели во всех доступных библиотеках.
- Library name — поиск соответствующей модели только в доступных библиотеках с этим именем.
- Library path — поиск соответствующей модели только в библиотеке с этим именем, расположенной по указанному пути. Введите путь и имя библиотеки вручную или нажмите кнопку Choose , чтобы открыть диалоговое окно Windows Open, в котором можно найти нужную библиотеку.
- Use footprint from source integrated library, database library, or server — поиск модели только в той интегрированной библиотеке, библиотеке базы данных или на том сервере, откуда был размещен компонент. Интегрированная библиотека или библиотека базы данных должна быть доступна, а для работы с сервером необходимо подключение к нему.
-
Copy — нажмите, чтобы скопировать данные выбранного посадочного места.
-
Paste — нажмите, чтобы вставить (добавить) скопированные данные посадочного места в выбранный компонент схемы.
-
Select All — нажмите, чтобы выбрать все посадочные места, отображаемые в списке View and Edit Footprints.
-
Set As Current — нажмите, чтобы назначить выбранное посадочное место текущим (обозначается символом
в столбце Current ).
-
Add to All Parts — нажмите, чтобы добавить выбранное посадочное место ко всем остальным частям того же компонента схемы (команда доступна, только если выбран многосекционный компонент и для одной или нескольких его частей это посадочное место не задано).
Дополнительные элементы управления
-
Menu — нажмите, чтобы открыть меню с теми же элементами управления, что и в описанном выше контекстном меню.
-
Add, Remove, Edit, Validate — эти кнопки выполняют те же функции, что и описанные выше пункты меню.
-
Accept Changes (Create ECO) — нажмите, чтобы принять изменения компонентов схемы и связанных с ними моделей посадочных мест и открыть диалоговое окно Engineering Change Order. В диалоговом окне ECO можно проверить и применить изменения, предварительно просмотрев изменения значений посадочных мест для соответствующих компонентов схемы.












