Arbeiten mit extrudierten, kugelförmigen und zylindrischen 3D-Körpern
Auf einen Blick
- Lernen Sie die Unterschiede zwischen extrudierten, zylindrischen und kugelförmigen 3D-Körperobjekten kennen und erfahren Sie, wie die einzelnen Formen definiert und platziert werden.
- Erfahren Sie, wie Sie mit dem Properties-Panel und Tastenkürzeln während der Befehlsausführung die Abmessungen, das Erscheinungsbild und das Platzierungsverhalten der Formen steuern.
- Erfahren Sie, wie Sie mit dem Component Body Manager 3D-Körper aus vorhandenen Footprint-Formen erzeugen und verwalten – einschließlich der Optionen für einzelne Bauteile und Stapelaktualisierungen.
Obwohl das Platzieren generischer 3D-Modelle die empfohlene Methode zur Verwendung von 3D-Körperobjekten ist, da dies eine genaue und detaillierte Darstellung der Bauteile auf der Leiterplatte sowie präzisere 3D-Kollisionsprüfungen im PCB-Editor ermöglicht, können mit einem 3D-Körperobjekt auch extrudierte, kugelförmige und zylindrische 3D-Körper platziert werden. Es können drei Arten einfacher 3D-Körperobjekte platziert werden:
| Extruded | In der X-Y-Ebene (Draufsicht) wird das extrudierte Objekt interaktiv definiert, genauso wie andere polygonale Objekte im PCB-Editor. Das Objekt wird anschließend entlang der Z-Achse nach oben (oder unten) extrudiert. Grundlage dafür sind die Eigenschaften Overall Height und Standoff Height, die im Modus 3D Body des Panels Properties definiert werden, sowie die Option Body Projection. Sie können außerdem eine Texturdatei, beispielsweise ein Logo, auf die Oberfläche eines extrudierten 3D-Körperobjekts aufbringen. |
| Cylindrical | Die Eigenschaften dieser Form werden im Modus 3D Body des Panels Properties definiert. |
| Spherical | Die Eigenschaften dieser Form werden im Modus 3D Body des Panels Properties definiert. |
Platzieren extrudierter, kugelförmiger oder zylindrischer 3D-Körperobjekte
Direkte Platzierung
Extrudierte, kugelförmige und zylindrische 3D-Körperobjekte können sowohl im PCB-Editor als auch im PCB-Footprint-Editor auf folgende Weise platziert werden:
- Wählen Sie den Befehl Place » Extruded 3D Body in den Hauptmenüs.
- Suchen und verwenden Sie den Befehl „Extrudierter 3D-Körper“ auf der Active Bar.
So platzieren Sie ein extrudiertes, kugelförmiges oder zylindrisches 3D-Körperobjekt:
- Nach dem Starten des Befehls wird der Cursor zu einem Fadenkreuz, und Sie befinden sich im standardmäßigen Platzierungsmodus für ein extrudiertes 3D-Körperobjekt.
- Drücken Sie Tab, um die Platzierung anzuhalten und das Panel Properties im 3D-Körpermodus anzuzeigen. Die eingeblendete Pausenschaltfläche erscheint im Designbereich und zeigt an, dass Sie auf die Felder des Panels Properties zugreifen können.
- Geben Sie im Panel Properties im Feld Identifier einen Namen für den 3D-Körper ein. Dies ist optional. Die Kennung kann hilfreich sein, wenn mehrere 3D-Körper platziert werden, und kann bei Bedarf auch dazu verwendet werden, diesen 3D-Körper gezielt in einer Designregel anzusprechen.
-
Wählen Sie die erforderliche Board Side aus; in der Regel ist hier
Topeingestellt. Im PCB-Bibliothekseditor wird der Footprint für die Oberseite der Leiterplatte erstellt. Bei Bedarf kann er während des PCB-Designprozesses auf die Unterseite gespiegelt werden. - Wählen Sie die mechanische Layer aus, auf der der 3D-Körper platziert werden soll. Mechanische Lagen vom Typ „Component“ sollten mit einer zweiten mechanischen Lage gepaart werden, damit beim Spiegeln des Bauteils von der Oberseite auf die Unterseite der Leiterplatte auch dessen mechanische Details, etwa der 3D-Körper, auf die zugeordnete mechanische Lage verschoben werden. Mechanische Lagen werden auf der Registerkarte Layers and Colors des Panels Ansichtskonfiguration gepaart. Weitere Informationen finden Sie auf der Dokumentationsseite des Panels.
- Wählen Sie die 3D Model Type aus den verfügbaren Formen aus: Extruded, Cylinder oder Sphere.
-
Für jede Form muss vor der Platzierung eine Größe festgelegt werden. Je nach ausgewählter Form:
- Extruded – definieren Sie Overall Height.
- Cylinder – definieren Sie Height und Radius.
- Sphere – definieren Sie Radius.
- Klicken Sie im Bereich Display des Panels auf die Schaltfläche Color, um die Farbe festzulegen, und passen Sie Opacity nach Bedarf an.
-
Klicken Sie nach Abschluss der Bearbeitung auf die eingeblendete Pausenschaltfläche, um zum Designbereich zurückzukehren.
-
Wenn die Form Cylinder oder Sphere ist:
- Am Cursor wird beim Bewegen durch den Designbereich eine rechteckige Form angezeigt. Klicken Sie, um den 3D-Körper zu platzieren.
- Klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um die Platzierung von 3D-Körperobjekten zu beenden.
-
Wenn die Form Extruded ist, ist der Cursor bereit, die polygonale Grundfläche des extrudierten 3D-Körpers zu definieren:
- Klicken Sie, um den ersten Eckpunkt festzulegen.
- Bewegen Sie den Cursor, um den zweiten Eckpunkt zu platzieren. Standardmäßig werden mit jedem Klick zwei Kanten mit einer benutzerdefinierten Eckenform dazwischen platziert. Weitere Informationen finden Sie unten im Abschnitt Platzierungsmodi für extrudierte 3D-Körper.
- Bewegen Sie die Maus weiter und klicken Sie, um weitere Eckpunkte zu platzieren.
- Klicken Sie nach dem Platzieren des letzten Eckpunkts mit der rechten Maustaste oder drücken Sie Esc, um den 3D-Körper zu schließen und die Platzierung abzuschließen. Sie müssen den 3D-Körper nicht manuell schließen, da die Software die Form automatisch vervollständigt, indem sie den Startpunkt mit dem zuletzt platzierten Punkt verbindet.
-
Wenn die Form Cylinder oder Sphere ist:
Platzierungsmodi für extrudierte 3D-Körper
Beim Platzieren eines extrudierten 3D-Körpers stehen fünf Eckenmodi zur Verfügung, von denen vier zusätzlich Untermodi für die Eckenrichtung bieten. Während der Platzierung:
- Drücken Sie Shift+Spacebar, um die fünf verfügbaren Eckenmodi nacheinander zu durchlaufen.
- Drücken Sie Spacebar, um zwischen den beiden Untermodi für die Eckenrichtung zu wechseln.
-
Halten Sie in einem der beiden Bogen-Eckenmodi die Taste
oder
gedrückt, um den Bogen zu verkleinern oder zu vergrößern. Halten Sie dabei zusätzlich die Taste Shift gedrückt, um die Größenänderung des Bogens zu beschleunigen.
- Drücken Sie die Tastenkombination 1, um zwischen der Platzierung von zwei Kanten pro Klick und einer Kante pro Klick zu wechseln. Im zweiten Modus wird die gestrichelte Kante als look-ahead segment bezeichnet.
- Drücken Sie die Taste Backspace, um den letzten Eckpunkt zu entfernen.

Ein extrudiertes 3D-Körperobjekt; beachten Sie den in der 2D- und 3D-Ansicht angezeigten Referenzpunkt.
Erstellen aus geschlossenen Formen
Um den Aufbau der Bauteilform aus 3D-Körpern zu beschleunigen, kann die Software eine Reihe extrudierter 3D-Körperobjekte anhand geschlossener Formen erstellen, die im Footprint erkannt werden. Diese Funktion kann hilfreich sein, wenn das Bauteil eine ungewöhnliche Form hat, die bereits durch die Formen im Bestückungsdruck des Footprints abgebildet wird. Sie können dem Footprint auch zusätzliche Objekte auf mechanischen Lagen hinzufügen und daraus weitere 3D-Körperobjekte erstellen, beispielsweise für die Anschlüsse.
Die folgenden Abbildungen zeigen den Footprint eines TO-92-Transistors. Die auf der Lage „Top Overlay“ gezeichnete Kontur wird verwendet, um den Transistorkörper auf dem ausgewählten 3D-Körper-Lagenpaar zu definieren (im Dialog als Registration Layer bezeichnet). Außerdem wurden auf einer mechanischen Lage drei kleine Quadrate erstellt (jedes Quadrat aus vier Linien), mit denen die Bauteilanschlüsse auf dem ausgewählten 3D-Körper-Lagenpaar definiert werden. Die Einstellungen sind in der folgenden Abbildung des Dialogs dargestellt.

Vorhandene Objekte im Footprint können zum Erstellen neuer 3D-Körperobjekte verwendet werden.
Um 3D-Körperobjekte aus Formen im Footprint zu erstellen, führen Sie den Befehl Tools » Manage 3D Bodies for Current Component aus. Der Dialog Component Body Manager wird geöffnet. Darin können Sie sehen, welche 3D-Körper derzeit im Bauteil verwendet werden und welche nicht. Körper können dem Bauteil nach Bedarf hinzugefügt und/oder daraus entfernt werden. Es gibt drei unterschiedliche Arten von Körpern:
- Ein gezielt platzierter 3D-Körper (in seiner Beschreibung als Component Body bezeichnet).
- Eine rechteckige Form, die von der Software automatisch aus einem umschließenden Rechteck erstellt wird.
- Eine geschlossene polygonale Form, die von der Software automatisch aus Design-Primitiven erstellt wird.
Sie können auch weitere Eigenschaften eines Körpers ändern, etwa Höhen, Körperprojektion, Referenzlage sowie Farbe und Deckkraft. Beachten Sie, dass die Spalte Body State anzeigt, dass vier Formen zum Erstellen von 3D-Körperobjekten verwendet werden sollen.
Sobald die 3D-Körper für das Bauteil wie gewünscht definiert sind, werden die Änderungen durch Klicken auf die Schaltfläche Close übernommen.

Die Software kann 3D-Körperobjekte anhand der Form vorhandener Objekte erstellen.
Hinweise zur Verwendung dieses Dialogs:
- Der Erkennungsalgorithmus bietet entweder eine aus dem umschließenden Rechteck erzeugte rechteckige Form oder eine polygonale Form an, die der durch die Primitive gebildeten Kontur folgt (entlang der Mittellinie von Leiterbahnen/Kreisbögen, sofern deren Endpunkte zusammenfallen).
- Um einen 3D-Körper aus einem vorhandenen Objekt zu erstellen, klicken Sie auf den blauen Text in der Spalte Body State.
- Der Standardwert für Overall Height entspricht dem Wert für Height, der im Panel „Eigenschaften“ für den Footprint definiert ist.
- Bei einem Bauteilanschluss, der nach unten durch die Leiterplatte geführt wird, setzen Sie Body Projection auf Bottom Side.
- Die 3D-Körperobjekte werden erstellt, wenn Sie im Dialog auf die Schaltfläche Close klicken. Wenn die Anzeige bereits auf den 3D-Modus eingestellt ist, müssen Sie sie möglicherweise aktualisieren (Tastenkürzel End), in den 2D-Modus und anschließend zurück in den 3D-Modus wechseln oder die Option Show 3D Bodies auf der Registerkarte View Options des Panels „Ansichtskonfigurationen“ zwischen Off und On umschalten, damit die neuen Objekte angezeigt werden.
- Um die 3D-Körper aller Bauteile in der aktiven, derzeit im PCB-Footprint-Editor geöffneten PCB-Footprint-Bibliothek zu bearbeiten, wählen Sie in den Hauptmenüs den Befehl Tools » Manage 3D Bodies for Library aus.
- Um 3D-Körper im PCB-Editor mit diesem Dialog zu bearbeiten, öffnen Sie ihn über den Befehl Tools » Manage 3D Bodies for Components on Board in den Hauptmenüs oder klicken Sie mit der rechten Maustaste auf ein Bauteil und wählen Sie Bauteilaktionen » 3D-Körper verwalten aus dem Kontextmenü.
-
Wenn der Dialog über den Befehl Tools » Manage 3D Bodies for Components on Board (im PCB-Editor) oder den Befehl Tools » Manage 3D Bodies for Library (im PCB-Footprint-Editor) geöffnet wird, steht oben im Dialog der Bereich Components zur Verfügung. Dieser Bereich listet alle Bauteil-Footprints in der aktiven Bibliothek auf (im eigentlichen Design wäre dies eine Liste aller Bauteile auf der Leiterplatte). Für jeden Eintrag werden das Referenzkennzeichen (nur im Design verfügbar), der Footprint-Name, die Höhe und Informationen zur Quellbibliothek angezeigt.
Außerdem steht eine zusätzliche Registerkarte Batch Update zur Verfügung. Über diese Registerkarte können Sie allen oder ausgewählten Bauteilen schnell in einem einzigen Vorgang 3D-Körperobjekte hinzufügen. Sie können Suchkriterien für das Erkennen und Erstellen von 3D-Körpern sowie Kriterien für deren Eigenschaften festlegen. Nachdem Sie alle Optionen für die Stapelverarbeitung wie gewünscht definiert haben, klicken Sie auf die Schaltfläche Execute Batch Update . Die Suche wird für jedes in den Vorgang einbezogene Bauteil durchgeführt. Wird dabei eine 3D-Körperform erkannt und erstellt, wird dieser Körper dem Bauteil mit den festgelegten Eigenschaften hinzugefügt. In diesem Modus werden Änderungen beim Ausführen der Stapelaktualisierung übernommen.
- Der Dialog ermöglicht es Ihnen, die 3D-Körper des Bauteils zentral zu verwalten, ohne für jeden 3D-Körper das Panel Properties öffnen zu müssen.
Optionen und Bedienelemente des Dialogs „Component Body Manager“

Der Dialog Component Body Manager (hinten) und der Dialog Bauteilkörperverwaltung für Bauteil (vorne)
Bauteile
Der obere Bereich des Dialogs listet alle Bauteil-Footprints in der aktiven Bibliothek auf (im eigentlichen Design wäre dies eine Liste aller Bauteile auf der Leiterplatte). Für jeden Eintrag werden das Referenzkennzeichen (nur im Design verfügbar), der Footprint-Name, die Höhe und Informationen zur Quellbibliothek angezeigt.
Registerkarte „Interaktiv“

Die Registerkarte Interactive des Dialogs Component Body Manager
Die Version Component Body Manager des Dialogs verfügt über zwei Registerkarten: Interactive und Batch Update. Auf der Registerkarte Interactive können Sie Informationen zum ausgewählten Bauteil bequem einsehen, einschließlich einer Vorschau der Bauteilkörper und des ausgewählten Körpers.
Vorhandene und potenzielle Bauteilkörper
-
Existing and Potential Component Bodies – dieser Bereich listet alle vorhandenen Bauteilkörper (3D-Körper) auf, die für das Bauteil verwendet werden oder potenziell verwendet werden könnten. Zu jedem Bauteilkörper werden folgende Angaben aufgeführt:
-
Description – eine Beschreibung, wie der Körper erstellt wurde. Dabei kann es sich um einen gezielt platzierten 3D-Körper (in seiner Beschreibung als Component Body bezeichnet), eine aus einem umschließenden Rechteck erstellte rechteckige Form oder eine aus Design-Primitiven erstellte geschlossene polygonale Form handeln. Die Beschreibung jedes Körpers (ob platziert oder automatisch erstellt) enthält außerdem die mechanische Lage, auf der er sich befindet (bzw. auf der sich die Objekte befinden, aus denen er erstellt wurde), sowie seine Fläche. Rechteckige und polygonale Körper werden durch
und
unterschieden. entsprechenden Symbolen.
- Body State - zeigt an, ob der Körper im Bauteil verwendet wird (In Component <ComponentDesignator>) oder nicht (Not In Component <ComponentDesignator>). Klicken Sie auf den Eintrag, um den Status nach Bedarf umzuschalten.
- Standoff Height - der Abstand von der Leiterplattenoberfläche zur Unterseite des extrudierten Körpers. Verwenden Sie einen negativen Wert für extrudierte Körper, die nach unten durch die Leiterplatte reichen müssen.
- Overall Height - der Abstand von der Leiterplattenoberfläche zur Oberseite des extrudierten Körpers.
- Body Projection - die Seite der Leiterplatte, von der aus der 3D-Körper herausragt. Wählen Sie über die Dropdown-Liste des Feldes entweder Top Side oder Bottom Side (nach oben bzw. nach unten herausragend). Diese Einstellung wird automatisch geändert, wenn das 3D-Körperobjekt beim Wechseln der Bauteilseite auf die andere Seite der Leiterplatte gespiegelt wird.
- Registration Layer - die mechanische Lage, auf der sich der 3D-Körper befindet. Wählen Sie über die Dropdown-Liste des Feldes eine der derzeit aktivierten mechanischen Lagen aus. Wenn die gewählte mechanische Lage Teil eines Lagenpaars ist, wird der Körper beim Wechseln der Bauteilseite auch auf die zugehörige mechanische Lage verschoben.
- Body 3D Color - die aktuell für den 3D-Körper verwendete Farbe. Klicken Sie auf das Farbfeld, um den Standarddialog Choose Color zu öffnen und bei Bedarf eine andere Farbe zuzuweisen.
- Body 3D Opacity - der aktuelle Transparenzgrad des 3D-Körpers. Wählen Sie über die Dropdown-Liste des Feldes zwischen Solid (vollständig undurchsichtig), Hide (macht den Körper unsichtbar), 25% Opacity, 50% Opacity und 75% Opacity.
-
Description – eine Beschreibung, wie der Körper erstellt wurde. Dabei kann es sich um einen gezielt platzierten 3D-Körper (in seiner Beschreibung als Component Body bezeichnet), eine aus einem umschließenden Rechteck erstellte rechteckige Form oder eine aus Design-Primitiven erstellte geschlossene polygonale Form handeln. Die Beschreibung jedes Körpers (ob platziert oder automatisch erstellt) enthält außerdem die mechanische Lage, auf der er sich befindet (bzw. auf der sich die Objekte befinden, aus denen er erstellt wurde), sowie seine Fläche. Rechteckige und polygonale Körper werden durch
- Component bodies in: <ComponentDesignator> - zeigt den 2D-Footprint des Bauteils zusammen mit überlagerten 3D-Körpern, deren Body State derzeit auf In Component <ComponentDesignator> eingestellt ist. Die Vorschau ist dynamisch und ändert sich, wenn Körper einbezogen oder ausgeschlossen werden.
- Selected Body - zeigt den aktuell ausgewählten Körper aus der obigen Liste. Im Titelbereich des Fensters wird außerdem die Beschreibung des Körpers angezeigt.
Registerkarte „Stapelaktualisierung“

Die Registerkarte Batch Update des Dialogs Component Body Manager
Die Registerkarte Batch Update bietet eine Möglichkeit, schnell 3D-Körperobjekte zu allen oder ausgewählten Footprints in einer Bibliothek oder zu allen oder ausgewählten platzierten Footprints in einem Design hinzuzufügen.
Tabellenbereich
Verwenden Sie diesen Bereich, um Suchkriterien für das Erkennen und Erstellen von 3D-Körpern sowie deren Eigenschaften festzulegen, beispielsweise Projection side (auch als Körperprojektion bezeichnet), Registration Layer, Standoff Height, Overall Height und 3D Body Color.
Jeder Eintrag in der Liste legt einen anderen Suchumfang für die Lagen fest, die beim Erkennen und Erstellen möglicher 3D-Körperformen durchsucht werden. Jede Suche wird einzeln über die Option in der Spalte Enabled aktiviert. Sie können mehrere Suchen aktivieren. Beachten Sie jedoch, dass für jede erfolgreiche Suche ein 3D-Körper hinzugefügt wird. In der Regel aktivieren Sie eine Suche auf einer bestimmten Lage oder einem Lagensatz, je nachdem, wo Sie üblicherweise die Grundelemente oder die Bauteilkontur eines Footprints platzieren. Standardmäßig wird eine Suche nach All Layers durchgeführt.
Mit dem Feld Detection Method können Sie steuern, wie die Form jedes 3D-Körpers definiert wird:
- Bounding Rectangle - verwendet das umschließende Rechteck des Footprints.
- Closed Shapes - verwendet eine geschlossene polygonale Form, die aus den Grundelementen des Bauteil-Footprints erstellt wird.
- Both (Prefer Closed Shapes) - erkennt anhand der Grundelemente des Footprints entweder ein umschließendes Rechteck oder eine geschlossene polygonale Form. Wenn beide erkannt werden, wird die geschlossene polygonale Form verwendet.
Mit der Optionsspalte Prefer component height if not 0 können Sie festlegen, ob das für einen Bauteil-Footprint definierte Höhenattribut als Overall Height für den 3D-Körper verwendet wird. Wenn diese Option aktiviert ist, wird für jedes Bauteil mit einem definierten Höhenattribut größer als null diese Höhe als Overall Height des hinzugefügten 3D-Körpers festgelegt und dessen Standoff Height auf null gesetzt.
Die Body 3-D Color legt die Farbe fest, in der der 3D-Körper dargestellt wird. Klicken Sie auf die Farbe, um sie im Dialog Choose Color zu ändern.
Optionen
- Apply Only To Selected Components - aktivieren Sie diese Option, wenn Sie die 3D-Körperkriterien nur auf eine ausgewählte Gruppe von Footprints anwenden möchten. Stellen Sie sicher, dass diese Bauteile im oberen Bereich des Dialogs ausgewählt sind (verwenden Sie die standardmäßigen Funktionen Ctrl+Click und Shift+Click für die Mehrfachauswahl). Wenn diese Option deaktiviert ist, wird der Stapelprozess zum Hinzufügen auf alle Footprints in der Bibliothek (oder alle Bauteile auf der Leiterplatte) angewendet.
- Delete Existing Bodies In Components - aktivieren Sie diese Option, um alle derzeit definierten 3D-Körper der vom Stapelprozess erfassten Footprints zu entfernen. Im Vorschaufenster unten rechts auf der Registerkarte können Sie sehen, wie der hinzugefügte 3D-Körper auf Grundlage des aktuell ausgewählten Bauteil-Footprints und des aktuell ausgewählten (und aktivierten) Sucheintrags aussehen wird. Nachdem Sie alle Optionen für den Stapelprozess wie gewünscht festgelegt haben, klicken Sie auf die Schaltfläche Execute Batch Update. Die Suche wird für jeden in den Prozess einbezogenen Footprint durchgeführt. Wenn dabei eine 3D-Körperform erkannt und erstellt wird, wird dieser Körper mit den festgelegten Eigenschaften zum Footprint hinzugefügt.
Vorschau des Stapelprozesses
Dient zur Vorschau der definierten 3D-Körper auf verschiedenen Lagen.
Zusätzliches Bedienelement
- Execute Batch Update - klicken Sie hier, um die Aktualisierung für jeden in den Prozess einbezogenen Footprint durchzuführen. Wenn dabei eine 3D-Körperform erkannt und erstellt wird, wird dieser Körper mit den festgelegten Eigenschaften zum Footprint hinzugefügt.
Erstellen aus ausgewählten Grundelementen
3D-Körper lassen sich nicht nur interaktiv platzieren, sondern auch aus einer Gruppe vorhandener Leiterbahn-, Kreisbogen- und Vollflächenobjekte erstellen, die eine geschlossene Form bilden. Dies ist eine ausgezeichnete Möglichkeit für einfache Modelle. So definieren Sie einen 3D-Körper aus einer vorhandenen geschlossenen Form:
- Wählen Sie alle Grundelemente aus, die die geschlossene Form bilden.
- Klicken Sie auf Tools » Convert » Create 3D Body From selected primitives.
Der 3D-Körper wird auf der obersten Lage aus der geschlossenen Begrenzung erstellt, die durch die Grundelemente gebildet wird, unabhängig davon, auf welcher Lage sich die ausgewählten Leiterbahnen befinden. Sie können die Form also auf einer mechanischen Lage definieren. Beachten Sie, dass die ursprünglich ausgewählten Grundelemente nach dem Erstellen der Fläche weiterhin vorhanden und ausgewählt sind. Die Begrenzung des 3D-Körpers folgt der Mittellinie der begrenzenden Leiterbahnobjekte. Der 3D-Körper selbst ist nicht ausgewählt.
Da der Algorithmus Create 3D Body From selected primitives die Mittellinie der ausgewählten Objekte verwendet, müssen die End- und Anfangspunkte sich berührender Objekte exakt übereinstimmen (dieselbe X-, Y-Position haben). Ist dies nicht der Fall, erscheint der Dialog Confirm, der die Stelle angibt, an der der Algorithmus fehlgeschlagen ist. Außerdem können Sie den Algorithmus anweisen, stattdessen zu versuchen, den 3D-Körper anhand der Kanten der Objekte zu definieren. Solange sich die ausgewählten Objekte leicht überlappen, sollte diese Option einen 3D-Körper erstellen, dessen Begrenzung der Außenkante der ausgewählten Objekte folgt.
Grafische Bearbeitung
Die grafische Bearbeitung ermöglicht es Ihnen, ein platziertes 3D-Körperobjekt direkt im Designbereich auszuwählen und seine Größe, Form oder Position grafisch zu ändern.
Um einen extrudierten 3D-Körper zu bearbeiten, klicken Sie einmal auf das Objekt, um es auszuwählen und in den Bearbeitungsmodus zu versetzen. Die äußere Form des 3D-Körperobjekts wird durch eine Reihe von Kanten definiert: Jede Kante besitzt an beiden Enden einen Endpunkt, der als ausgefülltes weißes Quadrat dargestellt wird (A in der Abbildung unten), sowie einen Mittelpunkt, der als nicht ausgefülltes weißes Quadrat dargestellt wird (B in der Abbildung unten). Jeder Endpunkt kennzeichnet die Stelle, an der zwei Kanten aufeinandertreffen.
Zur Bearbeitung der Form stehen die üblichen Techniken zur Bearbeitung polygonaler Formen zur Verfügung.
Bei der Bearbeitung eines polygonalen Objekts stehen drei Bearbeitungsmodi zur Verfügung: Slide/Miter, Incurvate (Bogen) und Move. Der aktuelle Modus kann while dragging a vertex or an edge durch Drücken von Shift+Spacebar geändert werden, um die drei Modi nacheinander zu durchlaufen.
- Slide/Miter – Klicken Sie auf eine Kante oder einen Mittelpunkt und halten Sie die Maustaste gedrückt, um die Kante zu verschieben. Klicken Sie auf einen Endpunkt und halten Sie die Maustaste gedrückt, um die Ecke abzuschrägen.
- Incurvate – Klicken Sie auf eine Kante oder einen Mittelpunkt und halten Sie die Maustaste gedrückt, um die Kante zu krümmen. Klicken Sie auf einen Endpunkt und halten Sie die Maustaste gedrückt, um die Ecke bogenförmig abzurunden.
- Move – Klicken Sie auf eine Kante oder einen Mittelpunkt und halten Sie die Maustaste gedrückt, um die Kante in zwei Kanten aufzuteilen. Klicken Sie auf einen Endpunkt und halten Sie die Maustaste gedrückt, um die Ecke frei zu verschieben.
Während der Bearbeitung können Sie außerdem:
- Ctrl+click and hold an einer beliebigen Stelle entlang einer Kante außerhalb der Bearbeitungsgriffe, um einen neuen Eckpunkt einzufügen.
- Um einen Eckpunkt zu entfernen, klicken Sie auf ihn und halten Sie die Maustaste gedrückt. Drücken Sie anschließend die Taste Delete.
-
Klicken Sie auf eine beliebige Stelle des 3D-Körpers außerhalb der Bearbeitungsgriffe und ziehen Sie ihn anschließend an die gewünschte Position. Während des Ziehens kann der 3D-Körper gedreht oder gespiegelt werden:
- Drücken Sie Spacebar, um den 3D-Körper gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um ihn im Uhrzeigersinn zu drehen. Die Größe von Rotation Step wird auf der Seite PCB-Editor – Allgemein des Dialogs Preferences festgelegt.
- Drücken Sie die Taste X oder Y, um den 3D-Körper entlang der X- bzw. Y-Achse zu spiegeln.
In STEP umwandeln
Ein ausgewähltes extrudiertes, zylindrisches oder kugelförmiges 3D-Körperobjekt kann in ein STEP-Modell umgewandelt werden. Das STEP-Modell wird automatisch in die Designdatei eingebettet. Um ein freies 3D-Körperobjekt umzuwandeln, wählen Sie es im Designbereich aus, klicken Sie mit der rechten Maustaste und wählen Sie den Befehl Convert To STEP aus dem Kontextmenü. Der Befehl ist nicht verfügbar, wenn kein Objekt oder mehr als ein Objekt ausgewählt ist. Sobald ein Objekt in STEP umgewandelt wurde, lässt sich seine Größe im Designbereich nicht mehr ändern.

Wandeln Sie eine extrudierte Form in STEP um, wenn Sie sie um die X- oder Y-Achse drehen müssen.
Referenzpunkt eines extrudierten, kugelförmigen oder zylindrischen 3D-Körperobjekts
Ein extrudiertes, kugelförmiges oder zylindrisches 3D-Körperobjekt besitzt einen Referenzpunkt bzw. Ursprung.
- Bei einem Zylinder oder einer Kugel ist der Referenzpunkt der Mittelpunkt der kreisförmigen Kontur des Objekts in der X-Y-Ebene.
- Bei einem extrudierten Objekt liegt der Referenzpunkt, von oben betrachtet, an der Position X-Länge/2, Y-Länge/2.
- Die Position dieses Referenzpunkts im Designbereich wird in den X/Y-Location im Panel Properties angezeigt.

Extrudierte, kugelförmige und zylindrische 3D-Körperobjekte besitzen einen Referenzpunkt, wie in den Abbildungen gezeigt. Beachten Sie, dass die Linien des Referenzpunkts kurz sind und daher möglicherweise nicht über das Objekt hinausragen.
Eine Textur auf einem extrudierten 3D-Körper hinzufügen
Bei extrudierten Objekten kann außerdem ein Bild auf die oberste Fläche gelegt werden, damit Ihre Leiterplatte in der 3D-Ansicht realistischer wirkt. Wenn eine Texture File hinzugefügt wird, wird sie automatisch so gestreckt, dass sie die gesamte obere Fläche des 3D-Körpers abdeckt, wie in der Abbildung unten gezeigt. Beachten Sie, dass die Texturdatei mit der Bibliotheks- oder Leiterplattendatei verknüpft ist.
Folgende Texturdateiformate werden unterstützt: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; und *.tga.

Einem extrudierten 3D-Körperobjekt kann eine Textur oder ein Logo hinzugefügt werden.
Dies lässt sich anpassen, indem Sie die Position Center sowie die Einstellungen Size und Rotation im Modus 3D Body des Panels Properties ändern.
Sie können außerdem die Position einer Textur ändern, die einem ausgewählten extrudierten 3D-Modell zugeordnet ist, indem Sie den Befehl Tools » 3D Body Placement » Move Texture Location aus den Hauptmenüs wählen, wenn sich der Editor im 3D-Layout-Modus befindet. Nach dem Aufrufen des Befehls nimmt der Cursor die Form blauer Kegel an (zur Kennzeichnung des 3D-Auswahlmodus), und Sie werden aufgefordert, einen extrudierten 3D-Körper mit einer zugeordneten Textur auszuwählen. Positionieren Sie den Cursor über dem gewünschten 3D-Körper und klicken Sie oder drücken Sie Enter. Klicken Sie oder drücken Sie Enter ein zweites Mal, um die Textur an ihrer nächstgelegenen Ecke „aufzunehmen“. Verschieben Sie die Textur an die gewünschte Position und klicken Sie oder drücken Sie Enter, um sie zu platzieren. Die üblichen zusätzlichen Aktionen zum Verschieben von Objekten (Spacebar/Shift+Spacebar zum Drehen, X oder Y zum Spiegeln und die Pfeiltasten zum schrittweisen Verschieben der Textur) können während des Verschiebens ausgeführt werden, solange die Textur noch am Cursor hängt.
Alternativ können Sie die Textur in einem ausgewählten extrudierten 3D-Körper mit der Maus durch Klicken und Ziehen verschieben.