Festlegen der Leiterplattenform
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Erfahren Sie, was die Platinenform definiert, wie die Software sie verwendet und wie sie sich bei Designs mit nur einem Platinenbereich und bei Starrflex-Designs unterscheidet.
- Lernen Sie die verfügbaren Methoden zum Erstellen und Bearbeiten der Platinenkontur kennen, darunter interaktive Werkzeuge, ausgewählte Objekte und die Definition anhand von 3D-Körpern.
- Verstehen Sie, welche Befehle im Standard- und im erweiterten Starrflex-Modus verfügbar sind und wie sich die Ansichtsmodi auf den Bearbeitungsablauf auswirken.
Zusammenfassung
Die Leiterplattenform, auch als Leiterplattenkontur bezeichnet, ist eine geschlossene polygonale Form, die die Gesamtabmessungen der Leiterplatte definiert. Die Leiterplattenform kann aus einem einzigen Leiterplattenbereich (bei einer herkömmlichen starren Leiterplatte) oder mehreren Leiterplattenbereichen (bei einer Starrflex-Leiterplatte) bestehen. Die Software verwendet die Leiterplattenform für folgende Zwecke:
- Als visuelle Orientierung für die Grenzen des verfügbaren Platzes zur Bauteilplatzierung und Leiterbahnführung im Design.
- Zur Festlegung des Randabstands von Versorgungslagen und als Randreferenz beim Aufteilen einer Versorgungslage in separate Spannungszonen. Erfahren Sie mehr über das Definieren und Verwalten von Kupferflächen.
- Zur Berechnung der Leiterplattenkante bei der Ausgabe von Designdaten an andere Werkzeuge.
Verfügbarkeit
Die Leiterplattenform ist nur im PCB-Editor verfügbar. Wenn eine neue PCB-Datei erstellt wird, öffnet sie sich mit einer rechteckigen Leiterplattenform, die aus einem einzigen Leiterplattenbereich besteht.
Die gesamte Leiterplattenform kann auf folgende Weise erstellt werden:
- Durch interaktives Definieren der Leiterplattenform im Leiterplattenplanungsmodus.
- Durch Erstellen der Leiterplattenform aus ausgewählten Leiterbahn- und Bogenobjekten, die eine geschlossene Begrenzung bilden. Wenn Sie im Modus Advanced Rigid-Flex arbeiten, können mehrere Leiterplattenbereiche aus im Designbereich ausgewählten Objekten erstellt werden.
- Bei einem Starrflex-Design (Standard- oder erweiterter Modus) kann die Leiterplattenform in die verschiedenen für das Design erforderlichen Leiterplattenbereiche unterteilt werden.
- Durch Platzieren eines oder mehrerer Leiterplattenbereiche, um die gesamte Leiterplattenform aufzubauen (Modus Advanced Rigid-Flex).
Interaktives Definieren und Bearbeiten der Leiterplattenform
Die Leiterplattenform wird aus einem oder mehreren Leiterplattenbereichen erstellt. Wenn Sie an einem Leiterplattendesign mit nur einem Bereich arbeiten, können Sie die folgenden Befehle zum Definieren der Leiterplattenform verwenden:
-
Board Planning Mode (standard Rigid-Flex mode - the Active Bar at the top of the graphical editing space has two buttons):
-
Design » Redefine Board Shape - Verwenden Sie diesen Befehl, um die aktuelle Platinenkontur interaktiv neu zu zeichnen. Beachten Sie, dass dieser Befehl nicht verfügbar ist, wenn der erweiterte Rigid-Flex-Modus in Layer Stack Manager aktiviert wurde. Wenn sich die Platine im erweiterten Rigid-Flex-Modus befindet, klicken Sie einfach auf die Kontur, um sie auszuwählen, und ändern Sie sie mit den Standardverfahren zur Bearbeitung polygonaler Objekte.
Verwenden des Befehls „Redefine Board Shape“
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz, und Sie gelangen in den Standardmodus zum Platzieren polygonaler Objekte. Die Platinenkontur wird durch die folgenden Schritte definiert:
- Positionieren Sie den Cursor und klicken Sie, um den ersten Eckpunkt der Platinenkontur festzulegen.
- Bewegen Sie den Cursor, um den zweiten Eckpunkt zu platzieren. Standardmäßig werden mit jedem Klick zwei Kanten mit einer benutzerdefinierten Eckform dazwischen platziert. Weitere Informationen zum Ändern der Eckenmodi finden Sie auf der Seite Bearbeiten polygonaler PCB-Designobjekte.
- Bewegen Sie die Maus weiter und klicken Sie, um weitere Eckpunkte zu platzieren.
- Nachdem Sie den letzten Eckpunkt platziert haben, klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um die Platinenkontur zu schließen und ihre Definition abzuschließen. Sie müssen die Platinenkontur nicht manuell schließen, da die Software die Kontur automatisch vervollständigt, indem sie den Startpunkt mit dem zuletzt platzierten Punkt verbindet.
-
Design » Edit Board Shape - Verwenden Sie diesen Befehl, um die Kanten der Platinenkontur mit den standardmäßigen Verfahren zur Bearbeitung polygonaler Objekte zu verschieben und umzuformen.
Verwenden des Befehls „Edit Board Shape“
Nach dem Aufrufen des Befehls wird die vorhandene Platinenkontur grün dargestellt. Die äußere Kontur wird durch eine Reihe von Kanten definiert. Jede Kante besitzt Endpunkte, die als ausgefüllte weiße Quadrate dargestellt werden, und einen Mittelpunkt, der als hohles weißes Quadrat dargestellt wird. Jeder Endpunkt kennzeichnet die Stelle, an der zwei Kanten aufeinandertreffen.
Bearbeitungsgriffe einer beispielhaften Platinenkontur nach dem Wechsel in den Bearbeitungsmodus.
-
Klicken und ziehen Sie A, um je nach aktuellem Modus eine der folgenden Aktionen auszuführen (mit Shift+Spacebar wechseln Sie den Modus):
- Moving Vertex mode - Verschiebt den Endpunkt frei, wobei er als Endpunkt erhalten bleibt.
- Miter to Segment mode - Erstellt eine neue gerade Kante, wobei der verschobene Endpunkt zum Mittelpunkt dieser Kante wird.
- Miter to Arc mode - Erstellt eine neue gekrümmte Kante, wobei der verschobene Endpunkt zum Mittelpunkt dieser Kante wird.
-
Klicken und ziehen Sie B, um je nach aktuellem Modus eine der folgenden Aktionen auszuführen (mit Shift+Spacebar wechseln Sie den Modus):
- Move mode - Verschiebt die gesamte Kante einschließlich ihrer Endpunkte frei. Der verschobene Mittelpunkt bleibt der Mittelpunkt dieser Kante.
- Break mode - Verschiebt den Mittelpunkt, wandelt ihn in einen neuen Endpunkt um und teilt die ursprüngliche Kante in zwei Kanten auf. Die Endpunkte bleiben an ihren ursprünglichen Positionen.
- Incurvate mode - Krümmt die Kante, wobei die Endpunkte an ihren ursprünglichen Positionen bleiben. Der verschobene Mittelpunkt bleibt der Mittelpunkt dieser Kante.
- Klicken Sie an einer beliebigen Stelle einer Kante außerhalb der Bearbeitungsgriffe und ziehen Sie, um diese Kante zu verschieben. Dabei wird die verschobene Kante verkürzt oder verlängert, sodass die Position der angrenzenden Kanten erhalten bleibt.
- Ctrl+Klicken Sie an einer beliebigen Stelle einer Kante außerhalb der Bearbeitungsgriffe, um einen neuen Endpunkt einzufügen.
- Klicken Sie auf einen Endpunkt (A), halten Sie die Maustaste gedrückt und drücken Sie dann Delete, um diesen Punkt zu entfernen. Alternativ halten Sie Ctrl gedrückt und bewegen den Mauszeiger über einen zu entfernenden Endpunkt (A). Ein weißes Kreuz erscheint. Klicken Sie und halten Sie die Maustaste kurz gedrückt, um den Punkt zu entfernen.
Verlassen Sie den Bearbeitungsmodus, indem Sie auf eine beliebige Stelle im Designbereich klicken (auf die Platinenkontur oder außerhalb davon).
-
Klicken und ziehen Sie A, um je nach aktuellem Modus eine der folgenden Aktionen auszuführen (mit Shift+Spacebar wechseln Sie den Modus):
-
-
Board Planning Mode (Advanced Rigid-Flex mode - the Active Bar at the top of the graphical editing space has six buttons):
- Place » Board Region - Verwenden Sie diesen Befehl, um den Platinenbereich interaktiv zu definieren (bei einer Platine mit nur einem Bereich definiert der Platinenbereich die Platinenkontur). Weitere Informationen finden Sie unter Platzieren eines Platinenbereichs.
-
2D Layout Mode:
-
Design » Board Shape » Define Board Shape from Selected Objects - Wählen Sie eine Gruppe von Linien- und/oder Bogenprimitiven aus, die eine geschlossene Kontur definieren, und verwenden Sie dann diesen Befehl, um die Platinenkontur entsprechend dieser Kontur neu zu definieren.
-
Design » Board Shape » Create Primitives from Board Shape - Erstellt eine Gruppe von Primitiven entlang der Begrenzung der Platinenkontur gemäß den Einstellungen im Dialogfeld Line/Arc Primitives from Board Shape.
-
-
3D Layout Mode:
- Design » Board Shape » Define Board Shape from 3D body - Verwenden Sie diesen Befehl, um die Platinenkontur durch Auswahl der gewünschten Fläche eines 3D-Modells zu definieren.
Im Platinenplanungsmodus können Sie außerdem die folgenden Befehle verwenden:
-
Design » Modify Board Shape - Verwenden Sie diesen Befehl, um die vorhandene Platinenkontur durch Platzieren zusätzlicher Eckpunkte zu ändern und so die Begrenzung weiter auszuformen.
Verwenden des Befehls „Modify Board Shape“
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz, und Sie gelangen in den Modus zum Ändern der Platinenkontur. Auf der vorhandenen Begrenzung erscheint ein neuer Endpunkt. Wenn Sie den Cursor bewegen, bewegt sich dieser Punkt ebenfalls entlang der Begrenzung. So ändern Sie die Begrenzung:
- Positionieren Sie den neuen Eckpunkt an der gewünschten Stelle entlang der vorhandenen Kontur und klicken Sie, um ihn zu platzieren.
- Positionieren Sie den Cursor und klicken Sie, um weitere Eckpunkte zu platzieren und so die Kontur weiter auszuformen. Sie können die ursprüngliche Kontur über die vorhandene Form hinaus erweitern und/oder wieder innerhalb der ursprünglichen Kontur fortfahren, um vorhandene Fläche praktisch zu „entfernen“.
- Wenn die Form Ihren Anforderungen entspricht, führen Sie den Cursor wieder zu einem Punkt auf der ursprünglichen Kontur und klicken Sie dort, um die Bearbeitung abzuschließen und die Änderung zu übernehmen.
- Um den Vorgang ohne Änderung zu beenden, klicken Sie einfach mit der rechten Maustaste oder drücken Sie Esc.
-
Design » Move Board Shape – Mit diesem Befehl verschieben Sie die Leiterplattenform an eine andere Position im aktuellen Dokument. Dabei wird nur die Leiterplattenform verschoben. Das eigentliche Design und die zugehörigen Objekte bleiben unverändert an ihrer Position.
Nach dem Aufrufen des Befehls hängt eine Umrisskopie der Form mit ihrer linken unteren Ecke am Cursor. Bewegen Sie die Form an die gewünschte neue Position im Arbeitsbereich und klicken Sie oder drücken Sie Enter, um sie zu platzieren. Drücken Sie während des Verschiebens Spacebar, um die Leiterplattenform gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um sie im Uhrzeigersinn zu drehen (die Schrittweite für Rotation Step wird auf der Seite PCB Editor – General im Dialog Preferences festgelegt). Mit den Tasten X bzw. Y spiegeln Sie die Leiterplattenform an der X- bzw. Y-Achse. Um den Vorgang ohne Verschieben abzubrechen, klicken Sie mit der rechten Maustaste oder drücken Sie Esc.
-
Design » Move Board – Mit diesem Befehl verschieben Sie die gesamte Leiterplatte – die Leiterplattenform einschließlich aller darin enthaltenen Designobjekte – an eine andere Position im aktuellen Dokument.
Nach dem Aufrufen des Befehls hängt eine Umrisskopie der Leiterplattenform mit ihrer linken unteren Ecke am Cursor. Bewegen Sie die Form an die gewünschte neue Position im Designbereich und klicken Sie oder drücken Sie Enter, um sie zu platzieren. Alle zugehörigen Designobjekte werden ebenfalls verschoben, sodass ihre Position innerhalb der Leiterplattenform erhalten bleibt. Um den Vorgang ohne Verschieben abzubrechen, klicken Sie mit der rechten Maustaste oder drücken Sie Esc.
Definieren der Leiterplattenform anhand ausgewählter Objekte
Die Leiterplattenform kann auch anhand ausgewählter Objekte definiert werden (im 2D-Layoutmodus). In der Regel handelt es sich dabei um eine Reihe von Linien und/oder Kreisbögen auf dem Keepout-Layer oder einem mechanischen Layer.
Gehen Sie wie folgt vor:
- Stellen Sie den Ansichtsmodus auf 2D Layout Mode ein (Menü View).
-
Öffnen Sie das Panel View Configuration und doppelklicken Sie auf den mechanischen Layer, der die Leiterplattenform enthält, um ihn zu bearbeiten. Der Dialog Edit Layer wird geöffnet. Dort können Sie Layer Type auf
Board Shapesetzen, wie im folgenden Video gezeigt. - Aktivieren Sie den mechanischen Layer, der die Form enthält, und wählen Sie die Objekte aus. Der Befehl Edit » Select » All on Layer eignet sich hierfür ideal; die Auswahl darf nur die Leiterbahnsegmente und Kreisbögen enthalten, die den Leiterplattenumriss bilden.
- Führen Sie nach Auswahl aller Objekte den Befehl Design » Board Shape » Define Board Shape from Selected Objects aus. Die Leiterplattenform wird so aktualisiert, dass sie dem durch die ausgewählten Linien definierten Verlauf folgt. Wenn die Software der Mittellinie der ausgewählten Objekte nicht folgen kann, wird ein Warndialog angezeigt. Der Ansichtsmodus wechselt zu Board Planning Mode.
Demonstration der Leiterplattenform im Standard-Starrflex-Modus
Das Video zeigt, wie die Leiterplattenform anhand ausgewählter Objekte erstellt wird und anschließend Trennlinien platziert werden, um die drei benötigten Bereiche zu erzeugen.
Demonstration der Leiterplattenform im erweiterten Starrflex-Modus
Das Video zeigt zunächst, wie die Leiterplattenform anhand ausgewählter Objekte erstellt und anschließend unterteilt wird, um die drei benötigten Bereiche zu erzeugen. Danach wird eine alternative Vorgehensweise gezeigt, bei der
die drei Leiterplattenbereiche anhand ausgewählter Objekte definiert werden. Beachten Sie, dass in diesen Demonstrationen die am Anfang dieser Seite beschriebenen Starrflex-2.0-Funktionen verwendet werden.
Importieren eines Umrisses zur Verwendung als Leiterplattenform
Die Leiterplattenform kann anhand eines geschlossenen Umrisses definiert werden, der als DXF-/DWG-Daten importiert wurde.
Durch den Import von DXF-/DWG-Daten auf einen mechanischen Layer und die anschließende Definition der Leiterplattenform anhand ausgewählter Objekte lässt sich eine in einem mechanischen CAD-Programm definierte Form in den PCB-Editor übertragen.
So bereiten Sie die neue Leiterplatte für den Import vor:
- Wählen Sie File » New » PCB. Eine neue, leere Leiterplatte wird geöffnet. Der schwarze Bereich stellt die aktuelle Leiterplattenform dar.
- Passen Sie vor dem Importieren einer neuen Form die folgenden Einstellungen an die Anforderungen Ihres Designs und der zu importierenden Form an:
- Einheiten – Stellen Sie die gewünschten Einheiten im Abschnitt Other des Panels Properties im Modus Board ein (Bild anzeigen).
- Raster – Doppelklicken Sie auf das globale Fangraster der Leiterplatte und passen Sie es im Abschnitt Grid Manager des Panels Properties im Modus Board an (Bild anzeigen).
- Ursprung – Bei einer neuen Leiterplatte liegt der benutzerdefinierbare Ursprung standardmäßig am absoluten Ursprung, links unten im Designbereich. Wählen Sie in den Hauptmenüs Edit » Origin » Set und klicken Sie anschließend, um die Position des benutzerdefinierbaren Ursprungs festzulegen, beispielsweise die linke untere Ecke der aktuellen Leiterplattenform. Es empfiehlt sich, diese Position an die Lage des Ursprungs im zu importierenden Umriss anzupassen.
Im nächsten Schritt importieren Sie die Leiterplattenkontur als .DXF- oder .DWG-Datei. Beachten Sie, dass die zu importierende Kontur geschlossen sein muss und interne Ausschnitte nicht automatisch erstellt werden (sie können jedoch später anhand importierter Objekte definiert werden).
- Wählen Sie File » Import » DXF/DWG, um den Dialog Import File zu öffnen. Stellen Sie sicher, dass File Type unten rechts im Dialog auf AutoCAD Files (*.DXF, *.DWG) eingestellt ist, und suchen Sie anschließend die gewünschte Datei.
- Wenn Sie auf die Schaltfläche Open klicken, öffnet sich der Dialog Import from AutoCAD (Bild anzeigen).
- Legen Sie Scale, Default Line Width und Layer Mappings nach Bedarf fest und klicken Sie dann auf OK.
- Jedes DXF/DWG-Objekt wird einem Objekt zugeordnet und im Designbereich angezeigt.
- Aktivieren Sie die mechanische Lage, die die Objekte der Leiterplattenkontur enthält, und wählen Sie dann alle Objekte auf dieser Lage aus (Edit » Select » All on Layer).
- Um die Leiterplattenkontur an den ausgewählten Umriss anzupassen, führen Sie den Befehl Design » Board Shape » Define from Selected Objects aus.
- Wenn die Leiterplatte Ausschnitte enthält, können Sie diese erstellen, indem Sie den Umriss des Ausschnitts auswählen und den Befehl Tools » Convert » Create Board Cutout from Selected Primitives ausführen.
Definieren der Leiterplattenkontur anhand eines 3D-Körpers
Diese Funktion definiert die Leiterplattenkontur anhand einer Fläche eines importierten 3D-Modells neu. Unterstützte Modellformate sind STEP (*.Stp oder *.STEP), Parasolid (*.x_t oder *x_b) und SOLIDWORKS-Teiledateien (*.SldPrt). Damit lassen sich komplexe Leiterplattenkonturen schnell erstellen und die Integration von Elektronik- und Mechanikentwicklung verbessern. Der Vorgang besteht aus zwei Schritten: Zunächst wird das STEP-Modell importiert, anschließend wird die gewünschte Kontur am STEP-Modell ausgewählt.
Gehen Sie dazu wie folgt vor:
- Wechseln Sie zu View » 3D Layout Mode (Tastenkürzel: 3).
- Um das 3D-Modell zu importieren, platzieren Sie einen 3D-Körper (Place » 3D Body).
- Suchen und wählen Sie im Dialog Choose Model die Modelldatei aus. Das 3D-Modell wird in den PCB-Editor importiert und in einem 3D-Körperobjekt gespeichert. Bei Bedarf können Sie dieses Modell von der Leiterplatte löschen, sobald die Leiterplattenkontur neu definiert wurde.
- Wählen Sie Design » Board Shape » Define Board Shape from 3D body.
- Die Statusleiste fordert Sie zu Pick a 3D body auf. Klicken Sie auf den importierten 3D-Körper, um ihn auszuwählen. Das Modell wird transparent.
- Der Cursor wird zu einem Fadenkreuz, und die Statusleiste fordert Sie zu Choose Face auf. Wenn Sie den Cursor über eine Fläche bewegen, wird deren Umriss hervorgehoben. Befindet sich eine ebene Fläche unter dem Cursor, wird sie undurchsichtig und mit einem dünnen blauen Rand dargestellt. Klicken Sie, um die gewünschte Fläche auszuwählen.
- Der Dialog Board Outline Creation Successful wird angezeigt. Er bietet Optionen dafür, welche Leiterplattenoberfläche an der ausgewählten Fläche ausgerichtet werden soll (in der Regel die Oberseite) und ob das 3D-Modell in der Ansicht ausgeblendet und von der Designregelprüfung ausgeschlossen werden soll. Dieses Verhalten können Sie bei Bedarf später im Modus „3D Models“ des Panels PCB ändern.
Beachten Sie: Wenn das STEP-Modell in die PCB-Datei eingebettet oder mit ihr verknüpft bleibt, werden Sie bei jeder Änderung der STEP-Datei benachrichtigt. Sie werden außerdem aufgefordert, die Kontur zu aktualisieren. Dies ist hilfreich, wenn sich die Kontur noch in der Entwicklung befindet und mit Aktualisierungen zu rechnen ist.
Erstellen von Grundelementen aus der Leiterplattenkontur
Sie können nicht nur die Leiterplattenkontur anhand ausgewählter Grundelemente definieren, sondern mit dem Befehl Design » Board Shape » Create Primitives from Board Shape auch Grundelemente aus der Leiterplattenkontur erstellen. Dieser Befehl öffnet den Dialog Line/Arc Primitives from Board.

Der Dialog Line/Arc Primitives From Board Shape
Optionen und Bedienelemente des Dialogs „Line/Arc Primitives From Board Shape“
- Width – Geben Sie die Breite der erzeugten Linien-/Bogen-Grundelemente an.
-
Layer – Wählen Sie in der Dropdown-Liste eine Lage für die erzeugten Linien-/Bogen-Grundelemente aus.
-
Include Cutouts – Aktivieren Sie diese Option, um beim Erzeugen der Umriss-Grundelemente auch Ausschnitte zu berücksichtigen.
-
Include layer stack regions – Aktivieren Sie diese Option, um beim Erzeugen der Umriss-Grundelemente auch Lagenaufbaubereiche zu berücksichtigen. Ein Lagenaufbaubereich ist ein benutzerdefinierter Bereich einer Leiterplatte, dem ein eigener Lagenaufbau zugewiesen werden kann. Eine Leiterplatte kann in mehrere Bereiche aufgeteilt werden, denen jeweils ein individueller Lagenaufbau zugewiesen wird. Die im Layer Stack Manager definierten Lagenaufbauten können sowohl für starre als auch für flexible Bereiche der Leiterplatte konfiguriert werden und ermöglichen so das Starrflex-Leiterplattendesign. Lagenaufbaubereiche lassen sich im Panel PCB im Modus „Layer Stack Regions“ durchsuchen.
-
Route Tool Outline – Standardmäßig werden die Umriss-Grundelemente so platziert, dass ihre Mittellinie auf dem Rand der Leiterplattenkontur liegt. Wenn diese Option aktiviert ist, werden die Linien-/Bogenobjekte stattdessen so platziert, dass ihre Kante den Rand der Leiterplattenkontur beziehungsweise des Ausschnitts berührt, wie es für eine Fräswerkzeugkontur erforderlich ist.
-
Delete Existing Non-Net Lines/Arcs On Layer – Aktivieren Sie diese Option, um vorhandene Linien/Bögen auf der ausgewählten Lage zu löschen, die keinem bestimmten Netz zugeordnet sind.
-
Verwenden Sie diesen Befehl, wenn die Leiterplattenkontur bereits vorhanden ist, sich jedoch noch keine Objekte entlang ihres Umrisses befinden. Der Befehl kann unter anderem in folgenden Situationen hilfreich sein:
- Wenn Sie die Leiterplattenkontur (oder Leiterplattenausschnitte) ändern möchten, indem Sie zunächst Leiterbahn- und Bogen-Grundelemente bearbeiten.
-
Wenn Sie eine Sperrbereichsbegrenzung für die Leiterplatte oder Sperrbereichsbegrenzungen für Leiterplattenausschnitte auf der Keep-Out-Lage benötigen. Dies wird im Abschnitt Wichtige Designaspekte bei der Verwendung von Leiterplattenausschnitten weiter unten ausführlicher erläutert.
Erstellen eines Lochs in der Leiterplattenkontur
Ein Platinenausschnitt kann an beliebiger Stelle innerhalb der Platinenkontur platziert werden. Um einen Ausschnitt zu platzieren, wechseln Sie in den 2D-Layoutmodus und verwenden Sie anschließend den Befehl Design » Board Shape » Define Board Cutout aus den Hauptmenüs (alternativ können Sie auch den Befehl Place » Define Board Cutout im Platinenplanungsmodus verwenden). Beachten Sie, dass der Ausschnitt tatsächlich ein Region-Objekt ist, das als negatives Objekt konfiguriert ist.
Ein Platinenausschnitt wurde innerhalb der Platinenkontur platziert.
Wichtige Designaspekte bei der Verwendung von Platinenausschnitten
Abstand eines Polygons zum Rand eines Platinenausschnitts
Polygone, die einen als Solid Region definierten Platinenausschnitt überlagern, werden bis zu dem Abstand zum Ausschnittrand gefüllt, den die geltende Clearance-Designregel zulässt. Bei Bedarf kann eine spezielle Clearance-Designregel erstellt werden, deren Geltungsbereich beispielsweise auf den Abstand zwischen IsBoardCutoutRegion und InPolygon beschränkt ist.
Definieren einer Fräserbahn entlang des Platinenrands und der Ausschnitte
Ein gängiges Verfahren zum Heraustrennen der fertigen Platine aus dem Fertigungsnutzen ist das Ausfräsen. Auch Platinenausschnitte können ausgefräst werden. Eine Fräserbahn wird durch das Platzieren von Linien- und/oder Kreisbogenobjekten auf einer mechanischen Lage definiert. Dies kann manuell oder automatisch durch die Software erfolgen.
So definieren Sie eine Fräserbahn für die Platine und etwaige Platinenausschnitte:
-
Führen Sie im 2D-Layoutmodus den Befehl Design » Board Shape » Create Primitives From Board Shape aus. Der Dialog „Line/Arc Primitives From Board Shape“ wird geöffnet.
-
Legen Sie eine geeignete Width für die Objekte fest, die die Fräserbahn definieren sollen. Wenden Sie sich bei Unsicherheiten an Ihren Leiterplattenhersteller.
-
Wählen Sie eine verfügbare mechanische Lage aus. Diese Lage sollte ausschließlich für die Definition der Fräserbahn reserviert sein.
-
Aktivieren Sie die Option Include Cutouts, wenn die Platine Ausschnitte enthält.
-
Aktivieren Sie die Option Route Tool Outline. Wenn diese Option aktiviert ist, werden die Linien-/Kreisbogenobjekte so platziert, dass ihre Kanten den Rand der Platinenkontur und den Rand des Ausschnitts berühren.
-
Klicken Sie auf OK, um die Fräserbahnobjekte auf der ausgewählten mechanischen Lage zu erstellen.
-
Die verwendete mechanische Lage muss als Fräserlage festgelegt werden. Öffnen Sie dazu die Registerkarte Layers & Colors im Panel „View Configuration“. Klicken Sie mit der rechten Maustaste in eine Lagentabelle und wählen Sie den Befehl Add Mechanical Layer. Setzen Sie im daraufhin geöffneten Dialog Edit Layer die Einstellung Layer Type auf Route Tool Path. Dieser Lagentyp kennzeichnet die Lage, die die Informationen zum mechanischen Fräsen enthält.
Die folgenden Abbildungen zeigen die auf einer mechanischen Lage definierte Fräserbahn.
Die erste Abbildung zeigt einen Platinenausschnitt, die zweite die dazu definierte Fräserbahn.
Sperrbereiche und Platinenkontur
Zusätzlich zur Platinenkontur sollten Sie entlang des Platinenrands auch eine Begrenzung für die Bauteilplatzierung und das Routing definieren. Diese kann automatisch aus der Platinenkontur selbst erstellt werden. Verwenden Sie dazu den Befehl Design » Board Shape » Create Primitives From Board Shape (im 2D-Layoutmodus) und setzen Sie Layer im Dialog Line/Arc Primitives from Board auf Keep-Out Layer.
Alternativ können Sie dies manuell durch das Platzieren von Objekten auf der Keepout-Lage tun. Auf dieser Lage platzierte Objekte definieren eine no-crossing-allowed-Begrenzung für Bauteile und Leiterbahnen. Üblicherweise sollen Objekte wie Bauteile und Leiterbahnen einen bestimmten Abstand zum Platinenrand einhalten. Dieser Abstand lässt sich über die entsprechenden Designregeln für das Routing und die Bauteilplatzierung steuern. Sie können auch weitere Routing- und Bauteilsperrbereiche für mechanische Objekte wie Schraubenköpfe oder andere Montageanforderungen definieren.
Eine Sperrbereichsbegrenzung, die durch das Platzieren standardmäßiger Linienobjekte auf der Keepout-Lage (violett) definiert wurde.
- Sperrbereichsbegrenzungen können durch das Platzieren beliebiger Standard-Designobjekte wie Linien, Kreisbögen, Füllflächen und Regionen auf der Keepout-Lage definiert werden. Auf der Keepout-Lage platzierte Objekte erzeugen einen Sperrbereich auf allen Signallagen.
- Sie können auch lagenspezifische Sperrbereiche auf jeder beliebigen Kupferlage definieren. Gehen Sie dazu wie folgt vor:
- Klicken Sie auf die Lagenregisterkarte der gewünschten Lage.
- Definieren Sie die Begrenzung oder Fläche des Sperrbereichs, indem Sie lagenspezifische Sperrbereichsobjekte platzieren (Untermenü Place » Keepout). Lagenspezifische Sperrbereiche sind Standardobjekte, bei denen das Attribut Keepout aktiviert ist. Sie werden in derselben Farbe wie die Lage und mit einer Umrandung in der Sperrbereichsfarbe dargestellt. Beachten Sie, dass lagenspezifische Sperrbereichsobjekte nicht in Gerber- oder ODB++-Ausgabedateien enthalten sind.






).