Altium NEXUS Documentation

PlaceOLEObject

Modified by Susan Riege on Aug 1, 2018

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to place an OLE object onto the active document. This is made possible through Object Linking and Embedding (OLE) technology in the PCB Editor, which allows data supplied by Windows OLE applications to be embedded in a PCB design while actively linked back to the source application. In many cases, this allows the embedded PCB data to be edited from within the application that created it.

Typical objects that might be placed in a PCB document include common Excel documents, Word documents or graphics objects from a suitable OLE image application. The supported file types include universal formats such as CSV and XLS format spreadsheets, DOC and RTF word documents, and BMP image files.

For detailed information about this object type, see OLE Object.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the Place » Object From File command from the main menus.
  • Right-clicking and choosing the Place » Object From File command from the context menu.

Use

First, make the layer on which you wish to place the OLE Object data the active layer in the workspace. After launching the command, the standard Windows Choose file dialog will open. Use this dialog to browse to the required OLE file - making sure it is a supported format! After clicking Open, the data from the chosen file will appear floating on the cursor. Position as required within the workspace then click or press Enter to effect placement.

Press the Tab key to access the Properties panel, from where properties for the OLE object can be changed on-the-fly. Pressing Tab pauses placement, allowing you to interact with the panel (or other area of the software) directly. To resume, click the pause symbol that appears over the workspace.

Tips

  1. Altium NEXUS’s Smart Paste capability also allows a selection in an OLE application to be copied and pasted (Edit » Paste) into the PCB document as an OLE object.
  2. To paste copied text from an OLE application as pure PCB text string primitive objects rather than a single OLE object, use the Edit » Paste Text command.
  3. An OLE Object can be converted to a collection of free primitive objects using the Tools » Convert » Explode OLE Object To Free Primitives command. This will break the object into appropriate Regions and/or Text objects. A convert to free primitives option is also offered if the matching OLE application cannot be found when attempting to edit an OLE Object.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.