Searching for & Placing Components in Altium Designer

Created: April 12, 2022 | Updated: November 16, 2022
現在、バージョン 22 を表示しています。 最新バージョンについては、こちらをご覧ください: バージョン 24 の

Parent page: Capturing Your Design Idea as a Schematic

When creating a schematic, you can use both your own component libraries accessible from the Components panel and thousands of real-world manufactured parts available through the Manufacturer Part Search panel. You can search for the required component by specifying the category, using parametric filtering or using straightforward search mode, by entering a query (a full or partial component name, value, etc.) in the search field. A component can be placed on the schematic by dragging it or using the Place command from the component's right-click menu.

Components Panel

The Components panel provides direct access to available Workspace components, and database and file-based library components in Altium Designer.

The panel sources components from a connected Workspace and any open or installed libraries. The panel offers full details of the selected component (Parameters, Models, Part Choices, Supplier data, etc.), component comparison, and for Workspace components, a filter-based parametric search capability for specifying target component parameters.

The Components panel uses the basic search engine functionality and view that is applied in the Manufacturer Part Search panel. While the Manufacturer Part Search panel harnesses the Altium Parts Provider service and focuses on the component manufacturer and supplier data searches, the Components panel is populated with ready-to-place components from your connected Workspace and database and file-based library sources.

Components Panel Access

To open the Components panel, select View » Panels » Components from the main menus or the Components option from the button menu at the lower right of the main screen. Using a responsive design configuration, the panel layout will dynamically adapt between full-screen normal mode () and its compact mode () where the Categories/Filters options collapse to menus.

From within a schematic document, use the P, P keyboard shortcut to open the Components panel. From within a PCB document, use the P, C keyboard shortcut.

To access the panel, you can also use the Place » Component command from the main menus, the Place » Component command from the right-click menu of the schematic or PCB editor design space, or the Component command ( in the schematic editor,  in the PCB editor) in the Active Bar.

The Components panel in its normal mode. Hover the cursor over the image to see the panel in compact mode.
The Components panel in its normal mode. Hover the cursor over the image to see the panel in compact mode.

The panel’s Categories pane (or the drop-down menu in compact mode) lists all available Workspace components under the All category entry and any available libraries. When the panel is in its normal mode, click the Categories list icon or the « icon to collapse or expand the display of the column and use the button (top right) to toggle the visibility of the component Details pane. When sifting through the Categories pane, the Up/Down and PgUp/PgDn keyboard shortcuts may be used to walk through the list. The Left/Right keyboard shortcuts may be used to open and close the individual branches.

The Categories grouping for Workspace components is derived from the Component Type parameters associated with each component. For example, if the Component Type for a component has been specified as Resistor, then that component will be listed under the Resistor category in the Components panel (regardless of the workspace folder it resides in).

To specify or change a component's type on-the-fly, right-click on its entry then select the Operations » Change Component Type option from the context menu to open the Choose component type dialog.

A component's Type parameter is established:

Component Types are managed (created/edited/removed) on the Data Management – Component Types page of the Preferences dialog. The dialog's Templates button opens the Edit Templates dialog, where the Component Template associated with each Component Type can be specified or changed. When connected to an Altium 365 Workspace, note that Component Templates are not available to those on the Altium Designer Standard Subscription.

NOTE: The Category a component is listed under is defined by its Component Type parameter, and is not related to the Workspace folder it resides in. Therefore, if you move a component to a different folder through the Explorer panel, such a change will not be reflected in the Components panel.

Operations Menu

The operations menu options provide you the ability to set file-based libraries preferences, perform searches, and specify if component models collection is visible. To access these options, select the operations menu button at the top right of the panel.

  • Create Component – select to open the Create New Component dialog followed by the Component Editor in Single Component Editing mode ready to define a new component.
  • Import Library – select to open the standard Windows Open dialog and select a database or file-based library saved on your local or network folder. After opening a library file, the Library Importer in its Simple mode will launch with the selected library loaded.
  • Clean-up Library – select to open the Delete Existing Components dialog followed by the Data Cleanup page of your Workspace's Settings where you can select the content types to be removed.
  • Models – select to include library model collection entries in the Categories listing. The additional entries in this browsing mode include Symbol, Footprint and Simulation model collections sourced from the connected Workspace, and also installed PCB footprint libraries (*.PcbLib).
  • File-based Libraries Preferences – select to open the Available File-based Libraries dialog, where you may view controls to add database and file-based libraries to or remove libraries from the current project, install libraries, and specify library search paths. Refer to the Managing Available Database and File-based Libraries section of the Searching for Components in File-based & Database Libraries page to learn more.
  • File-based Library Search – select to open the File-based Libraries Search dialog, where you may search for a component when you do not know which database or file-based library contains it or if it is even available. Refer to the Searching for Components in Database and File-based Libraries section of the Searching for Components in File-based & Database Libraries page to learn more.
  • Refresh – click to quickly refresh the panel. The current component selection will be saved.

Components List

Within the component listing grid itself, the content that is included in the list is managed by:

  • Setting the component listing sort order – click a column heading to sort the component listing by that column data. Click the heading again to reverse the sort order.
  • Setting the order of the displayed columns – drag and drop a column heading to a new position.
  • Specifying which parameter columns are shown – right-click in a column header and choose Select Columns to open the Select Columns dialog then toggle a parameter column’s visibility and move its positional order with the Up/Down buttons.
  • Grouping the list by column data – right-click in a column header, select the Enable Columns Grouping option then drag a column header (e.g., Footprint) into the grouping space at the top of the list. The list entries will be collected under each unique parameter (e.g., type of footprint) from the specified grouping column.

    When using Grouping to collate components in the listing, there is a limit of 10,000 entries that can be accommodated.
  • Filtering the listing by a specific column entry – select in a column header to display a list of its unique parameter entries then select an entry to constrain the listed components to those that include the specified parameter (e.g., a footprint type code). Select the All option to reset the filter. Select (Custom) to open the Filter Editor dialog in order to further refine the filtering in the selected column.

Displaying Columns

There are various manners in which you may display the contents within the Components panel. When right-clicking on the names of each column (Name, Description, Footprint) you may select from the following options, depending on how you wish to display the components:

  • Best Fit – merges the contents from the Name and Descriptions columns together so they are closely placed, with no excess room between each column.
  • Best Fit All Columns – merges the contents from all columns together so they are closely placed, with no excess room between each column.
  • Clear Sorting – used to undo the sorting of columns.
  • Enable Columns Grouping – allows you to drag column headers by a specific column, allowing you to change the order of the Name, Description, and Footprint columns.
  • Select Columns – opens the Select Columns dialog, which allows you to select other columns you would like visible in this section.
  • Apply Column Visibility to Child Categories – in cases when the selected category has a child category, use this command to ensure the possibility of pushing column visibility settings from parent categories to child categories. This command is available only when a child category exists.

Component Search and Functions

Searching for components

To search for available components in the Components panel, enter a phrase in the Search field and/or use the panel's Categories and Filters selections to narrow the component listing to your specific needs. Filters are supported for Workspace components only, and as in the Manufacturer Part Search panel, the Components panel supports unit-aware (text to number) search filters. The search functionality prioritizes results according to the entered search criteria.

The Search function allows you to select then edit or add to an active Search string. Click the 'active' search string to enter it into the Search field. You can reuse or edit that search from the Search field.

The Search field also supports searching with wildcards, denoted by an asterisk (*) in the string.

The Find Similar Components dialog provides the possibility to define search preferences based on the selected component.

The Find Similar Components dialog is used to define your search preferences based on the selected component. The final search results will depend on the selected component type, be it Workspace or non-Workspace components, and your Workspace connection status. For example, Workspace components will often display more parameters than a non-Workspace component. To specifically gather components and parameters that are the same or different from the one selected, the drop-downs may be utilized to select Same, Any, or Different choices.

The dialog can be accessed by right-clicking on a listed component, then selecting Find Similar Components.

Placing Components

A selected component is placed on a schematic by dragging and dropping, by selecting Place from its right-click context menu, by using the button in the Details pane, or by using the Enter hotkey.

Placing a Multi-part Component

If the component being placed has multiple parts, the part selected under the symbol preview image in the Models region of the panel will be initially placed.

Once a part of a multi-part component is placed, it can be changed to another part of this component using the Part drop-down in the Properties panel when the part is selected, or it can be switched to the next available part using Edit » Increment Part Number command from the main menus or the Part Actions » Increment Part Number command from the part's right-click menu.

Replacing a Component

A component placed in a schematic sheet can be replaced with another available Workspace and file-based library component. With a component selected, from the General tab of the Properties panel, select the required source from the Source drop-down in the Properties region, then click the  in the Design Item ID field. The Replace Component dialog will open.

The Replace Component dialogThe Replace Component dialog

The Replace Component dialog provides direct access to all available Workspace library components and file-based library components. The dialog offers full details of the selected component (Parameters, Models, Part Choices, Supplier data, etc.,), component comparison, and for Workspace Library Components, a filter-based parametric search capability for specifying target component parameters.

The Replace Component dialog can also be accessed from other places of Altium Designer when performing a component replacement operation, e.g. from an ActiveBOM document or the Item Manager dialog.
  • Search - use the search text box to manually search for a specific component.
  •  - click to expand or collapse the Categories pane - to show certain types of components, or to display all available components. Use the search bar underneath the Categories pane to manually search for a specific component or .IntLib file.
  •  - click to access a menu and select from:
  •  - click to open/close the Details region of the dialog (described below).

Filters

Click the Filters icon ( ) to open the Filters region, where you can further filter the categories that are selected in the Components list. The panel Filters options can be tailored your needs by selecting particular parameter types as Favorites, which then shift to the top of the list for the current component Category. Hover to the right of a parameter filter’s name and click the () icon to set the filter as a Favorite. Favorite filter settings apply to and are saved for individual component Categories.

Components

  • Name - the name of the component.
  • Description - the description of each component.
  • Footprint - the footprint of the component.
  • Manufacturer Part Search - click to open the Manufacturer Part Search panel to search for and choose the most suitable component part.
  • Create component - click to open the Create new component dialog to select the type of component.
  • Results - lists the total number of components found/listed in the search.

Details

Click  to display the Details region for the selected component.
  • Component Revision ID - lists the Revision ID and price of a given component. Click the Revision ID to open the Explorer panel for further information regarding a component.
  • References - click to open reference information in a web browser for the component. Use the drop-down to access the Manufacturer URL or Datasheet.
  • Place - click to place the selected component on a schematic document.
  • Component information - lists relevant information about the component, including manufacturer, release date, and descriptive information. Click the Show More link to view all information; click Show Less to collapse the information.
  • Models - expand to view the provided models. Use the available links to display various parts of a single model.
  • References - expand to access the Manufacturer URL, Datasheet, and Package Specification.
  • Part Choices - expand to view the part choices. A name, price, and description is provided. The Datasheet of the component also will be listed.
  • Where Used - expand to view the projects that utilize the component.

Right-Click Menu

  • Find Similar Components - click to open the Find Similar Components dialog, where you may search for several other components with similar characteristics.
  • Place <component> - click to place the component in the appropriate document.
  • Edit - click to open the selected component's Component Library Documents.
  • Navigate to <revision> - click to open the selected component within the Explorer panel.
  • Operations - hover to access the ability to Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL, and Full Item History.
  • Refresh- click to refresh to view recent updates or edits. You may also refresh by using the F5 shortcut.

Filtering Through Components

When viewing Workspace components, the Filters pane is populated by selected filter options based on the current search and available parameters. Parametric filtering of the listed components provides further options for locating a specific component or type of component. Open the Filters pane from the button above the Categories pane.

Note that filters are only supported for Workspace components. Use the Filter Search field within the pane to find a specific parameter filter, and in the panel's narrow/docked mode, click the button to pop out the Filters as a panel extension.

The parametric search capability of the panel's Filters relies on suitable component parameter data being passed from the Workspace that hosts the Workspace components. As a result, the Filter functionality may be disabled when the software is connected to an older Altium server product. To enable the Filter for previous server versions, check the ComponentSearch.LegacyAFS.Filters option in the Advanced Settings dialog, which is accessed by clicking the Advanced button in the System – General page of the Preferences dialog.

The panel Filters options can be tailored to your needs by selecting particular parameter types as Favorites, which then shift to the top of the list for the current component Category. Hover to the right of a parameter filter’s name and click the icon to set the filter as a Favorite. Favorite filter settings apply to and are saved for individual component Categories.

To reset your favorites to the five default parameters, right-click then choose Reset Favorite Parameters.

For Workspace components, the right-click menu offers options to edit the component through the Single Component Editor (Edit) and perform component management functions such as component creation and cloning, or editing the selected component's Part Choices and Type (Operations).

Additional information options in the component Details pane include: viewing a model image, viewing online datasheets (References), live Supplier information (Part Choices), seeing where the part has been used in Workspace projects and Managed Sheets (Where Used), and through the right-click menu, the ability to copy selected or all component parameter data (technical details) in a tab-delimited format, and resetting favorites.

When connected to an Altium 365 Workspace, note that the component's Where Used functionality is not supported with the Altium Designer Standard Subscription. As such, the Where Used drop-down will not display any data with this level of access to Altium 365.

When browsing the components in a connected Altium 365 Workspace and if any issues regarding the health of the selected component are found, an indication of it will be presented by the (for errors) or (for fatal errors) icon in the Component issues line above the component parameter list. The number at the right of the icon indicates the number of found issues. Click the down arrow at the right of the number to see the short descriptions of the issues.

An example of library health issues found.
An example of library health issues found.

Your Workspace library health can be explored in more detail through the Library Health dashboard page accessible from the Altium 365 Workspace browser interface. See Library Health Dashboard to learn more.

You may use the custom filtering feature to further refine filtering in the Components panel. The feature is available by clicking the filter () icon in the header, then selecting (Custom). This will open the Filter Editor dialog, which allows you to define the condition, operator, value, operator type, etc., for which you want to filter results.

Where Used

The Where Used drop-down tracks where a particular component is located. You may select the Project, Managed Sheets, or All buttons to view the particular project, managed sheet, or both, in which the given component has been used.

Component Data Caching

When using the Components panel, the data for Workspace components are cached to the local machine from the Workspace. This provides an offline access mode for Workspace components when Altium Designer is not connected to the Workspace, and therefore allows normal component browsing and placement, etc. Note that Filters are not enabled in this mode.

This condition is indicated by the 'Offline mode – cached data is being used' warning text in the lower bar of the panel’s component list pane. The cache builds up component data over time and may be cleared (for all Workspaces) using the Clear Cache option that is available under Known Servers in the Data Management – Servers page of the Preferences dialog.

Caching behavior will only present cached components from the currently connected Workspace(s), such as Altium 365 Workspace, meaning certain cached data may be disabled. This behavior may be managed from the Data Management – Servers page of the Preferences dialog.

Part Choices List

Edit the Part Choices List associated with a Workspace component by selecting the Operations » Create/Edit PCL option from the entry’s right-click menu.

Use the following Edit Part Choices dialog’s button to open the Add Part Choices dialog, which will automatically search for part manufacturers by the selected component's Name parameter. Deselect the predefined search term to manually search for alternatives – functionally, the dialog is a modal version of the Manufacturer Part Search panel.

Part Choice entries in the list can be ranked by selecting an appropriate star icon level, where the list will automatically be reordered with the highest-ranked manufacturer choice at the top.

A Part Choices List is carried with the component wherever its data is applied, such as in a Schematic design, BOM document, Output Report, and so on.

Components Panel Right-click Menu

The right-click pop-up menu for the panel provides the following commands:

  • Place [ComponentName/FootprintName/SimulationModelName] – use to place the currently selected component or simulation model onto the active schematic document or currently selected footprint onto the active PCB document.
  • Find Similar Components – use to open the Find Similar Components dialog to set up search criteria to find components similar to the selected component.
  • Navigate to [ComponentName] – use to open the chosen Workspace component in the Explorer panel, where you may access detailed Item information and manage the revision and lifecycle settings for the Items well as where-used and supply chain detail, amongst other options.
  • Edit – click to edit the selected Workspace component through the Single Component Editor or selected domain model (symbol, footprint, or simulation model) in its editor. If the current component type is different from the template that is currently being used, the Change component type dialog will open. Use the dialog to change the component type of the selected component.
  • Create – click to open the Create new component dialog to select the type of component when adding a new component.
  • Delete – click to delete the selected component(s) from your connected Workspace.
  • Operations – use to access a drop-down menu of additional functions for Workspace components as described below.
    Submit Request – use to access the active part request process definitions. If no active process definitions are available for the Part Requests process theme, the Submit Request button will be grayed out (not available). You may need to sign out of the Workspace and back in again or restart Altium Designer to refresh. Note that this option is only available with Altium Designer Enterprise Subscription (and connected to either an Altium 365 Workspace, or an Enterprise Server Workspace).
    • Download – click to download the selected component(s) to a zipped Integrated Library Package.
    • Clone – click to clone (copy) the selected component. The component editor opens in the Single Component Editor mode.
    • Change Component Type – use to open the Choose component type dialog, from where you may alter the current component's type to one of the other existing defined types in the list. The dialog displays information regarding any component template associated with a component type and the folder within the connected Workspace into which components of that type can be found/saved. Click the  button to manage the list of available Component Types on the Data Management – Component Types page of the Preferences dialog.
      When connected to an Altium 365 Workspace, note that Component Templates are not supported with the Altium Designer Standard Subscription. As such, this functionality will not be available with this level of access to Altium 365, and the Template column will not be shown.
    • Change State – use to change the revision state of the selected component(s). After using the command, the Batch state change dialog opens, which allows you to change the revision state of the component(s).
      When connected to an Altium 365 Workspace, note that configuration and use of lifecycle definitions is not supported with the Altium Designer Standard Subscription. As such, the Change State command will not be available in the right-click menu with this level of access to Altium 365.
    • Create/Edit PCL – use to access the Edit Part Choices dialog, where you may create or edit the part choices list associated with the Workspace component.
    • Full Item History – use to access a detailed view for the currently selected component, opened as a new tabbed view within Altium Designer. The Item View provides a highly detailed view of the Revision and Lifecycle history of a specific Item, as well as showing all of the elements that make up that Item. The view also includes a Timeline. Use the Timeline to examine the exact time and date of any change made to the Revision level or Lifecycle State of that Item and who made the change.
  • Refresh – click to quickly refresh the panel. The current component selection will be saved.

Compare Feature

The Compare feature allows you to compare the parameters of two selected components (parts). This feature is accessed by selecting two components in the grid region with the icon enabled (blue). The Selected Component Details region opens to the right of the grid region. The upper region (region 1 in the image below) displays an image, the name, description, and price of the selected components side-by-side. Click the Datasheet button to open the manufacturer's datasheet (if available) for the associated component. Click the Place button to place the component in the design space. The component will appear floating in the design space; click to place the component in the desired location. You can continue to place additional components or right-click or Esc to leave placement mode and return to the Components panel.

The lower region (region 2 in the image below) displays a side-by-side view of the components' parameters, with differences highlighted in red text for easy comparison.

The Compare feature is also available when the Components panel is in compact mode, though works a tad differently. This feature is accessed by selecting two components in the grid region. The Selected Component Details region opens below the grid region. The upper region displays the name, price, and view of the components' parameters, with differences highlighted in red text for easy comparison. The lower region displays a side-by-side view of the components' Symbols and Models.

The Compare feature and functionality also is available in the Manufacturer Part Search panel.

Editing Component Symbols and Footprints

The symbol and footprint of a given component can be hidden within the Models section of the Details pane, which is accessed by clicking Info button on the upper right. Once hidden, the symbol and footprint will be replaced with clickable links that revert the hidden items to their original view. Also included is the ability to scale the size of the displayed models. For both the symbols and footprints, click and drag the lower perimeter of the model area to resize the image.

Note that ability to hide and rescale the model views is also available in the Details pane of the Manufacturer Part Search panel.

For a Schematic Library (*.SchLib) file being browsed in the Components panel, the symbol and footprint of the selected component can be edited using the button at the bottom-right of the model preview.

The ability to edit a footprint is made available when accessing the Components, as long as valid and linked footprints are already present.

Component Selection Dialogs

The search engine and view used in the Components panel is also applied in other Altium Designer applications where a component choice is made. The component search functionality is included in these (modal) dialogs, along with an OK confirmation button and minor variations in the available action commands. The dialog is typically called Component Search.

Generic Components

To expedite the process of laying out the early stages of a design, the concept of standard, basic Generic Components is available. Generic components can quickly be placed in a design without the need to find and choose a specific manufacturer part from the available component sources. Generic components are intended as placeholders that are easily replaced by a suitable component later in the design process – they also can be considered as virtual or parametric components.

When connected to an Altium 365 Workspace, note that the Generic Components functionality is not supported with the Altium Designer Standard Subscription. As such, this functionality will not be available with this level of access to Altium 365.

To learn more about generic component creation, refer to the Creating Generic Components page.

Access and Placement

When Altium Designer is connected to a Workspace, the available Generic Components can be accessed from the panel where they are exposed when the All option is selected in the Categories pane – or from the top drop-down menu when the panel is in its compact mode. Click on the button within a Generic Component tile to attach the component to the cursor for placement in the active schematic document. Selecting the tile itself will open that component type category in the panel.

Placing a Generic Component from the Components panel
Placing a Generic Component from the Components panel

Since Generic Components must not be used in a final design, they will cause an ERC violation – Generic Component – when placed in a schematic. The level of that violation – a Fatal Error by default – is determined in the Violations Associated with Components section of the Error Reporting settings in the Project Options dialog (Project » Project Options).

Select a placed Generic Component to access its properties in the Properties panel, which provides only those settings and parameters that are relevant to this type of component. The available parameters are determined by the related Component Template (Resistors in the example shown here). Parameter values can be manually entered, or selected from a drop-down menu list that offers values sourced from all the available components of that type.

Specifying parameters of a Generic Component. Here is shown selecting parameter values from the drop-downs. Hover the cursor over the image to see the result.
Specifying parameters of a Generic Component. Here is shown selecting parameter values from the drop-downs. Hover the cursor over the image to see the result.

Replacing a Generic Component

When a design has progressed to the point where a Generic Component can be replaced with a specific physical component, invoke the Replace Component dialog by selecting the button in the Properties panel. Note this also can be done from the Item Manager or through the project's ActiveBOM document.

Parameter values that have been applied to the Generic Component (here, power and resistance values) are automatically used as search terms in the Replace Generic Component dialog, allowing you to choose a suitable replacement component from the filtered results – in the example case here, two component entries fit the search criteria.

Replacing a Generic Component through the Properties panel. Hover the cursor over the image to see the result.
Replacing a Generic Component through the Properties panel. Hover the cursor over the image to see the result.

Note that the component replacement logic also supports multiple selections. When a number of generic components are selected for replacement via the Properties panel, the manufacturer component chosen in the Replace Generic Component dialog will replace all of those selected components.

Manufacturer Part Search Panel

The fundamental design task of searching for and choosing the most suitable component parts for PCB designs can be performed in a single, advanced panel available from within Altium Designer – the Manufacturer Part Search panel. As a replacement for the Part Search panel, the Manufacturer Part Search panel offers a sophisticated search feature based on categories and parametric filtering that allows you to zero in on the exact manufactured components you need, and also select a preferred supplier of that physical part based on cost and availability.

Manufacturer Part Search Panel Access

To open the Manufacturer Part Search panel, select View » Panels » Manufacturer Part Search from the main menu or the Manufacturer Part Search option from the button menu at the lower right of the main screen. When vertically docked, use the  to toggle the panel layout between full screen (wide) mode and its narrow docked mode.

The Manufacturer Part Search panel in its normal mode. Hover the cursor over the image to see the panel in its compact mode.
The Manufacturer Part Search panel in its normal mode. Hover the cursor over the image to see the panel in its compact mode.

The panel harnesses the manufacturer and supplier data resources of the Altium Parts Provider service to source the most pertinent and up-to-date component data. A selected manufactured part can be saved to a connected Workspace or downloaded as a file-based library, or its parameters and datasheets added to an existing part in the design space. The preferred supplier(s) of that manufactured part may also be selected and added, as Supplier Link parameters, to an existing design part.

Each listed manufacturer part in the panel is associated with a colored stripe tag that indicates its fundamental suitability for use, based on the part's deduced Lifecycle state – for example, a component flagged as Obsolete (red) is not recommended over one rated for Volume Production (green). Hover over a colored stripe to see its Manufacturer Lifecycle state.

► See Interpreting Lifecycle in BOM Management for more information.

If you are not signed in to your AltiumLive account, you can first sign in or register from this panel. Clicking Sign in will provide access to the Sign In dialog from which you can sign in to your Altium account using your AltiumLive credentials (username and password). If you have not yet created an AltiumLive account, click register to open the browser-based interface as presented through Altium 365 where you can register for Altium 365 or view and make changes to your Workspace if you already own one.

Use the controls in the panel to sign in to your Altium account or to register a new one.
Use the controls in the panel to sign in to your Altium account or to register a new one.

Manufacturer and Supplier Data

The panel’s advanced search engine allows it to be used in a straightforward search mode, by entering a query in the main Search field, or in its advanced parametric mode by progressively refining the search criteria using component type category choices and smart Filters – or indeed, by using both capabilities together.

Click the icon to show or hide the Filters pane, and use the selection options in the categories drop-down menu () to restrict the list to a particular component type.

When using the parametric search options, which is ideal for researching suitable manufactured parts for a design, the panel's filter options will dynamically adapt to the most relevant parameter choices based on the existing category/filters selections. This allows you to quickly narrow the listed choices to the most suitable manufactured parts, which in turn are ordered by a combination of model availability, supplier stocks and price. Note that multiple options may be selected for a given (checkbox-based) filter attribute, and the filters also include unit-aware (text to number) search options for specifying a range of acceptable parameter values.

Use the provided categories and filters to quickly refine the component list.
Use the provided categories and filters to quickly refine the component list.

If desired, you can enable the ComponentPartSearch.PerformanceMetrics Value option in the Advanced Settings dialog to display search times at the bottom of the Manufacturer Part Search panel.

The currently selected filter options are shown above the parts list and may be removed (via their associated X icon) to modify the active search filtering. Similarly, individual choices in the Filters list may be removed by unchecking an entry or deselecting an option button.

The  symbol next to a component entry means that there are models assigned to this component. To restrict the listing to those components that have associated model data, select the Yes option for the Has Model parameter in the Filters pane.

A selected manufacturer part in the list is summarized by its column data, where all available parameter columns are active by default.  Within the component listing, the content that is included may be managed by:

  • setting the component listing sort order – click a column heading to sort the component listing by that column data. Click the heading again to reverse the sort order.
  • setting the order of the displayed columns – drag and drop a column heading to a new position.
  • specifying which parameter columns are shown – right-click in a column header and choose Select Columns to open the Select Columns dialog, then toggle a parameter column’s visibility and move its positional order with the Up/Down buttons.
  • filtering the listing by a specific column entry – select the  icon in a column header to display a list of its unique parameter entries, then select one or more entries to constrain the listed components to those that include the specified parameter (eg: the Case/Package code). Select the All option to reset the filter.

Based on the data of any part in the panel, a new component can be created in your connected Workspace – that effectively means that any listed component can be saved to your Workspace. Use one of the following controls to save a component to your connected Workspace:

  • the  button;
  • the Save to My Workspace (when connected to an Altium 365 Workspace) / Save to My Server (when connected to an Altium Enterprise Workspace) command of the  button menu;
  • the Save to My Workspace / Save to My Server command of the component entry's right-click menu;
  • the  button that appears on the component entry's image when the mouse cursor hovers over the entry.

Parts with associated models are ready for use in designs and may be attained by downloading the selected component(s) to a zipped Integrated Library Package – select the Download as File Library command from the  button menu or the component entry's right-click menu.

Parts located through the panel are saved to your Workspace and then reused in designs as Workspace Library components. Alternatively, a part may be placed in an active design directly from the panel using the Place option in the right-click menu or button menu. Note that with this approach, however, the placed component’s data source will be the Altium Content Vault rather than your own Workspace.

If a component was placed on a schematic sheet from the Manufacturer Part Search panel, you can save it to the connected Workspace by selecting the Part Actions » Save to My Workspace / Save to My Server command from the placed component's right-click menu.

Note that in earlier versions of the software, the Save to My Workspace command was called Acquire, and the Download to File Library command was called Download.

Supplier data

Each part entry in the list also includes a link to the online manufacturer's data, and a link to a tabular list of supplier choices – again ordered by their price/availability suitability.

The panel provides supplier data for available components.
The panel provides supplier data for available components.

The supplier entries provide a snapshot of the current (live) stock level, pricing and supplier part number. To view the supplier data, click the SPNs link located in the Manufacturer Part column after selecting a part. Right-click on a supplier cell to add the associated Supplier Link to a component part in the schematic editor, via the mouse cursor (Add Supplier Link to Part). The alternative Add Supplier Link and Parameters to Part option also adds all parameters for that manufacturer component to the schematic part.

Use the panel’s button (top right) to set supplier data options such as specifying the displayed Currency and restricting the supplier cells to those that contain valid data. When the Exclude invalid SPNs option is checked, only cells that show suitable Stock levels and up-to-date data are included.

When a Schematic Library is the active document, drag and drop a Supplier cell onto an entry in the SCH Library panel, or onto the editor space, to add that component Supplier Link. Alternatively, right-click on the Supplier cell to add the link and/or the part parameters to the component selected in the SCH Library panel, or choose the Import Into option to add that component data as a new library entry.

Manufacturer Part Search Panel Right-click Menu

  • Save to My Workspace / Save to My Server – use to save the selected component(s) to a connected Workspace.
  • Download as File Library – use to download the selected component(s) to a zipped Integrated Library Package. Select multiple part entries to download those parts in a single session.
  • Place - use to place a part in the active design.
  • Submit Request – use to access the active part request process definitions. If no active process definitions are available for the Part Requests process theme, the Submit Request button will be grayed out (not available). You may need to sign out of the Workspace and back in again or restart Altium Designer to refresh. Note that this option is only available with Altium Designer Enterprise Subscription (and connected to either an Altium 365 Workspace, or an Enterprise Server Workspace).
  • Add Supplier Link To – use to add the selected Supplier Link to a component part in the schematic editor (when a schematic document is currently active) or to the component currently selected in the SCH Library panel (when a schematic library document is currently active).
  • Add Supplier Link And Parameters To – use to add the selected Supplier Link and all parameters for that manufacturer component to a component part in the schematic editor (when a schematic document is currently active) or to the component currently selected in the SCH Library panel (when a schematic library document is currently active).
  • Import Into – when a schematic library document is currently active, use to add the selected component data as a new library entry.
  • Refresh – use to refresh the panel's contents. 
  • Copy – use to copy all or selected parameter data as a tab-delimited text list.
  • Copy With Header – use to copy and paste the selected component into an external spreadsheet such as Microsoft Excel.
  • Select Columns – use to open the Select columns dialog to choose which columns to show or hide in the panel.
  • Preferences – click to open the Data Management - Parts Providers page of the Preferences dialog to configure parts providers.

Part Details

Full details of the selected manufacturer part, including models if available, are presented in the panel’s Details section pane – on the right in the panel’s full-screen mode. Use the panel's  button (top right) to toggle the visibility of the Details pane.

The information and options presented in this section depend on the available component data, where a part may be saved to your connected Workspace, saved as an integrated library package or placed in the design (the  button menu), and datasheets viewed from the menu or from the pane's Datasheets list.

The  drop-down menu offers options to save the component to a connected Workspace (via the Create new component dialog and Component Editor in its Single Component Editing mode) or download the component locally as an Integrated Library Package in a zip archive. Alternatively, a new Part Request can be created.

Further options in the part Details section include:

  • Add selected parameters to a schematic component part using mouse cursor targeting (drag and drop, or from right-click menu).
  • Copy all or selected parameter data as a tab delimited text list – right-click menu options.
  • View alternative part suggestions in a list ordered by a suitability rating (Alternatives), where each entry links to its online part data.
  • Select multiple component entries to enable the data comparison feature, where the parameter differences between the selected parts are highlighted as red text.

Alternatives

With Altium Designer Pro/Enterprise Subscription and a connected Altium 365 Workspace, drop-in component replacements and alternatives can easily be found by leveraging the partnership with IHS Markit® Parts Intelligence. This data includes manufacturer lifecycles, part alternates, component parameters (technical), and datasheets within the Manufacturer Part Search panel. If you have Altium Designer Standard Subscription, your data source is Octopart. Component replacement is often performed when a component is obsolete or no longer recommended.

Once the alternative component is found, it may be copied and compared against the component being replaced. To directly replace the component, you may use the Components panel.

Data Sources

The search engine behind the Manufacturer Part Search panel will source parts data from the Altium Parts Provider service and where possible, access matching schematic, PCB and Sim models from the Altium Content Vault.  The match between a part listed in the Manufacturer Part Search panel and models from the content server is based on the manufacturer name and the manufacturer part number. In a Workspace, this is determined by the Part Choices associated with a Workspace library component.

Parts data may also be sourced from a local company parts database if this has been configured as a Custom Database Parts Provider in a connected Workspace.

In the example shown below, models from the Altium Content Vault are sourced by the panel because that particular LED component can be found in the content server, based on its Part Choices entry. All other data is sourced live from the Altium Parts Provider, giving you the latest Manufacturer and Supplier information for the selected component.

The selected component has assigned models as indicated by its associated symbol.

Parameter data

When a component part is saved to a Workspace/integrated library from the Manufacturer Part Search panel, the component data (both models and parameters) are sourced from the Altium Content Vault. In practice, the found component is matched to an Altium component, which will include its parameters when placed.

As an adjunct to this, the panel offers a rich source of parameter data with each part entry, courtesy of the Altium Parts Provider service – see the parameter list in the selected part Details section. These parameters represent the current manufacturer data for that part, and therefore relevant, up-to-date information that can be added to a component in a Workspace/integrated library or board design.

For example, use the right-click menu in the panel's parameters list to add selected parameters to a schematic component, or choose the Add Supplier Link and Parameters to Part option (as outlined above) when adding supplier data to a component. Note that parameters sourced from the panel are added to the schematic component's existing parameters.

Part Search dialogs

The search engine and view used in the Manufacturer Part Search panel are also applied in other Altium Designer applications where component data is sourced. The Part Search functionality is included in these (modal) dialogs, along with an OK confirmation button and minor variations in the available action commands.

Manufacturer Part Choices:

Supplier Links:

Compare Feature

The Compare feature allows you to compare the parameters of two selected parts. This feature is accessed by selecting two parts in the grid region with the  icon enabled (blue). The Selected Part Details region opens to the right of the grid region. The upper region (region 1 in the image below) displays the selected parts side-by-side. Click the Datasheet button to open the manufacturer's datasheet (if available) for the associated component. 

The lower region (region 2 in the image below) displays a side-by-side view of the components' parameters, with differences highlighted in red text for easy comparison.

The Compare feature and functionality is also available in the Components panel
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: