部品の検索と配置

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

概略

この記事では、Altium DesignerのComponentsパネルを使用して、Workspaceやデータベースライブラリ、ファイルベースのライブラリからコンポーネントを検索、確認、管理、配置する方法を説明します。カテゴリ別の参照、クエリによる直接検索、Workspaceコンポーネントのパラメトリックフィルタリングなど、さまざまな検索方法を紹介するとともに、Manufacturer Part Searchパネル、コンポーネントエディタ、Explorerパネルといった関連ツールとの連携についても解説します。また、回路図ドキュメントやPCBドキュメントからパネルを開く方法、コンポーネントのカテゴリが決まる仕組み、ワークフローを効率化するための各種操作や表示設定についても説明します。適切な部品を見つけ、設計に効率よく配置するための手順を把握したい方は、ぜひこのままお読みください。

- カテゴリ、検索クエリ、パラメータベースのフィルタを使用して、Componentsパネルでコンポーネントを検索する方法を学びます。
- Workspace、ファイルベースのライブラリ、データベースライブラリ、Manufacturer Part Searchパネルの検索結果など、コンポーネントの取得元について理解します。
- コンポーネントの配置方法に加え、詳細の表示、コンポーネントの編集、ライブラリの管理、コンポーネントリストの整理に役立つ、パネルの主な機能を確認します。
AIでさらに深掘り:

電子機器設計の中核をなすのはコンポーネントです。 最終的に基板にはんだ付けするコンポーネントは、各設計領域で表現、つまりモデル化する必要があります。回路図ではシンボル、シミュレーターではSPICEモデル、基板ではフットプリント、機械設計者に渡すファイルでは3D STEPモデルとして表現します。

詳しくは、コンポーネントとライブラリの構築と管理をご覧ください。

Altium DesignerのComponentsパネルは、Workspace内外のすべてのコンポーネントを操作できる強力なインターフェースを提供します。 カテゴリを指定し、検索フィールドにクエリ(コンポーネント名の全体または一部、値など)を入力するシンプルな検索モードで、必要なコンポーネントを検索できます。また、Workspaceコンポーネントに対して、目的のコンポーネントパラメーターを指定するフィルターベースのパラメトリック(ファセット)検索も利用できます。さらに、このパネルには、単一コンポーネント編集モードのComponent EditorでWorkspaceコンポーネントを編集するオプション、コンポーネントを保存元のWorkspaceで表示するオプション、コンポーネントの作成や複製、選択したコンポーネントのPart ChoicesやTypeの編集などのコンポーネント管理機能もあります。 コンポーネントを回路図に配置するには、ドラッグするか、コンポーネントの右クリックメニューからPlace コマンドを使用します。

もちろん独自のコンポーネントを作成することもできますが、Altium Designerには、実際に製造されている部品を検索できる強力なManufacturer Part Searchパネルも用意されています。 Workspaceがあれば、それらの部品をWorkspaceに保存し、Componentsパネルからアクセスできます。このプロセスでは、単一コンポーネント編集モードのComponent Editorを使用して新しいWorkspaceコンポーネントを作成し、Workspaceに保存します。

Componentsパネルからは、Altium Designerで利用可能なWorkspaceコンポーネント、データベースおよびファイルベースのライブラリコンポーネントに直接アクセスできます。

このパネルは、接続されたWorkspaceと、開いているライブラリまたはインストール済みライブラリからコンポーネントを取得します。選択したコンポーネントの詳細情報(パラメーター、モデル、Part Choices、サプライヤーデータなど)の表示やコンポーネントの比較に加え、Workspaceコンポーネントでは、目的のコンポーネントパラメーターを指定するフィルターベースのパラメトリック検索も利用できます。

通常モードのComponentsパネル

コンパクトモードのComponentsパネル

 

Componentsパネルは、Manufacturer Part Searchパネルと同じ基本的な検索エンジン機能と表示形式を使用します。Manufacturer Part SearchパネルがAltium Parts Providerサービスを活用してコンポーネントメーカーやサプライヤーのデータ検索に重点を置いているのに対し、Componentsパネルには、接続されたWorkspace、データベース、およびファイルベースのライブラリから取得した、すぐに配置できるコンポーネントが表示されます。

Workspaceコンポーネントについては、各コンポーネントの最新リビジョンのみがパネルに表示されます。
コンポーネントを操作する機能の多くはComponentsパネルから利用できますが、Explorerパネルも使用できます。基本的に、前者は後者で利用できる機能のうち、コンポーネント管理に特化した一部の機能を提供します。コンポーネント自体に関する機能の中には、引き続きExplorerパネルからしか実行できないものもあります(編集せずにデータシートを追加する、状態を変更する、コンポーネントやモデルを一括削除するなど)。ただし、これらは通常とは異なる特殊なケースや、管理作業、Workspaceの構成作業の一環として使用する機能です。コンポーネントは、コンテンツタイプの1つにすぎないことを覚えておいてください。Explorerパネルは、Workspaceがサポートするあらゆるコンテンツタイプを扱う際に、その真価を発揮します。たとえば、コンポーネントと密接に関わるコンポーネントテンプレートの作成と管理は、Explorerパネル内でのみ実行できます(Library Importerを使用してライブラリをインポートする際にテンプレートを作成する場合を除きます)。

Componentsパネルへのアクセス

Componentsパネルを開くには、メインメニューからView » Panels » Componentsを選択するか、メイン画面右下のボタンメニューからComponentsオプションを選択します。レスポンシブデザインにより、パネルのレイアウトは、全画面の通常モード()と、Categories/Filtersオプションがメニューに折りたたまれるコンパクトモード()の間で動的に切り替わります。

回路図ドキュメント内では、キーボードショートカットP, Pを使用してComponentsパネルを開きます。 メインメニューの Place » Part コマンド、回路図エディターの設計スペースの右クリックメニューにある Place » Part コマンド、またはActive BarのPartボタン()も使用できます。

PCBドキュメント内では、キーボードショートカットP, Cを使用してComponentsパネルを開きます。メインメニューの Place » Component コマンド、PCBエディターの設計スペースの右クリックメニューにある Place » Component コマンド、またはActive BarのComponentコマンド()も使用できます。

現在のAltium DesignerセッションでComponentsパネルを初めて起動したときにWorkspaceに接続している場合は、次のコントロールを利用できます。

  • Use Existing Components – クリックすると、パネル上部のドロップダウンで現在選択されているコンポーネントタイプを参照できます。

  • Delete Existing Components – クリックすると、Delete Existing Componentsダイアログが開き、続いてWorkspaceのSettingsのData Cleanupページが開きます。ここで、削除するコンテンツタイプを選択できます。

  • Import Library – クリックすると、Windows標準のOpenダイアログが開きます。ローカルフォルダーまたはネットワークフォルダーに保存されたデータベースライブラリまたはファイルベースのライブラリを選択してください。ライブラリファイルを開くと、選択したライブラリが読み込まれた状態でシンプルモードのLibrary Importerが起動します。

  • Create Component – クリックすると、Create New Componentダイアログが開き、続いて単一コンポーネント編集モードのComponent Editorが、新しいコンポーネントを定義できる状態で開きます。

パネルのCategoriesペイン(コンパクトモードではドロップダウンメニュー)には、Allカテゴリ項目の下に利用可能なすべてのWorkspaceコンポーネントと、利用可能なライブラリが表示されます。通常モードでは、Categoriesリストアイコンまたは«アイコンをクリックして列の表示を折りたたんだり展開したりできます。また、右上のボタンを使用して、コンポーネントのDetailsペインの表示を切り替えられます。Categoriesペイン内を参照する際は、キーボードショートカットUp/DownおよびPgUp/PgDnでリスト内を移動できます。キーボードショートカットLeft/Rightを使用すると、個々の枝を展開したり折りたたんだりできます。

WorkspaceコンポーネントのCategoriesによるグループ分けは、各コンポーネントに関連付けられたComponent Typeパラメーターに基づきます。たとえば、コンポーネントのComponent TypeがResistorに設定されている場合、そのコンポーネントは、格納されているWorkspaceフォルダーに関係なく、ComponentsパネルのResistorカテゴリーに表示されます。

コンポーネントのタイプをその場で指定または変更するには、そのエントリーを右クリックし、コンテキストメニューからOperations » Change Component Typeオプションを選択して、コンポーネントタイプの選択ダイアログを開きます。

コンポーネントのTypeパラメーターは、次のタイミングで設定されます。

コンポーネントタイプは、PreferencesダイアログのData Management – Component Typesページで管理(作成、編集、削除)します。このダイアログのTemplatesボタンをクリックするとEdit Templatesダイアログが開き、各コンポーネントタイプに関連付けるコンポーネントテンプレートを指定または変更できます。

NOTE: コンポーネントが表示されるCategoryは、そのComponent Typeパラメーターによって決まり、格納されているWorkspaceフォルダーとは関係ありません。そのため、Explorerパネルでコンポーネントを別のフォルダーに移動しても、その変更はComponentsパネルには反映されません。

操作メニュー

操作メニューのオプションでは、ファイルベースのライブラリーの環境設定、検索、およびコンポーネントモデルコレクションの表示設定を行えます。これらのオプションにアクセスするには、パネル右上の操作メニューのボタンを選択します。

  • Create Component – 選択するとCreate new componentダイアログが開き、続いてコンポーネントエディターが単一コンポーネント編集モードで開き、新しいコンポーネントを定義できる状態になります。
  • Import Library – 選択するとWindows標準のOpenダイアログが開き、ローカルまたはネットワークフォルダーに保存されているデータベースライブラリーまたはファイルベースのライブラリーを選択できます。ライブラリーファイルを開くと、選択したライブラリーが読み込まれた状態で、Library Importerがシンプルモードで起動します。
  • Clean-up Library – 選択するとDelete Existing Componentsダイアログが開き、続いてWorkspaceのSettingsのData Cleanupページが開きます。このページで、削除するコンテンツの種類を選択できます。
  • Models – 選択すると、Categoriesの一覧にライブラリーモデルコレクションのエントリーが含まれます。この閲覧モードで追加されるエントリーには、接続先のWorkspaceから取得したシンボル、フットプリント、シミュレーションモデルのコレクション、およびインストール済みのPCBフットプリントライブラリー(*.PcbLib)が含まれます。
  • File-based Libraries Preferences – 選択するとAvailable File-based Librariesダイアログが開きます。このダイアログでは、現在のプロジェクトへのデータベースライブラリーおよびファイルベースのライブラリーの追加や削除、ライブラリーのインストール、ライブラリー検索パスの指定を行えます。詳細については、 ファイルベースおよびデータベースライブラリーでのコンポーネント検索 ページの 使用可能なデータベースライブラリーとファイルベースのライブラリーの管理セクションを参照してください。
  • File-based Library Search – 選択するとFile-based Libraries Searchダイアログが開きます。コンポーネントがどのデータベースライブラリーまたはファイルベースのライブラリーに含まれているかわからない場合や、そもそも利用可能かどうか不明な場合に、このダイアログで検索できます。 詳細については、 ファイルベースおよびデータベースライブラリーでのコンポーネント検索 ページの データベースライブラリーとファイルベースのライブラリーでのコンポーネント検索セクションを参照してください。
  • Refresh – クリックするとパネルがすぐに更新されます。現在のコンポーネントの選択状態は保持されます。

コンポーネント一覧

コンポーネント一覧のグリッド内では、次の操作で一覧の内容を管理できます。

  • コンポーネント一覧の並べ替え順序の設定 – 列見出しをクリックすると、その列のデータに基づいてコンポーネント一覧が並べ替えられます。見出しをもう一度クリックすると、並べ替え順序が逆になります。

  • 表示する列の順序の設定 – 列見出しを新しい位置にドラッグ&ドロップします。

  • 表示するパラメーター列の指定 – 列ヘッダーを右クリックし、Select Columnsを選択してSelect Columnsダイアログを開きます。このダイアログで、パラメーター列の表示/非表示と表示順序を設定できます。

    Select columnsダイアログ
    Select columnsダイアログ

    • このダイアログには、Componentsパネルに表示できるすべての列が一覧表示されます。 項目に が表示されている場合、その列はComponents パネルに表示されます。項目に が表示されている場合、 その列はnot Componentsパネルに表示されません。記号をクリックすると、表示/非表示を切り替えられます。

    • 列ヘッダーバーの /アイコンをクリックして、すべての列の表示を制御することもできます。表示されている列と非表示の列が混在している場合は、 アイコンが表示されます。

    • 2番目の列のヘッダーバーにカーソルを合わせ、 アイコンをクリックするとドロップダウンが開き、表示する列を選択できます。

    •  / ボタンを使用すると、選択した項目を一覧内で上下に移動できます。移動できるのは、表示()に設定されている項目のみです。これにより、Componentsパネルに表示される列の順序が決まります。

  • 列のデータによる一覧のグループ化 – 列ヘッダーを右クリックしてEnable Columns Groupingオプションを選択し、列ヘッダー(例:Footprint)を一覧上部のグループ化領域にドラッグします。一覧のエントリーは、指定したグループ化対象列の各固有のパラメーター値(例:フットプリントの種類)ごとにまとめられます。

    Groupingを使用して一覧のコンポーネントをまとめる場合、扱えるエントリー数の上限は10,000件です。

  • 特定の列の値による一覧のフィルタリング – 列ヘッダーのを選択すると、その列の固有のパラメーター値が一覧表示されます。値を選択すると、指定したパラメーター(例:フットプリントのタイプコード)を含むコンポーネントだけが表示されます。フィルターをリセットするには、Allオプションを選択します。選択した列のフィルタリング条件をさらに絞り込むには、(Custom)を選択してFilter Editorダイアログを開きます。

列の表示

Componentsパネルの内容は、さまざまな方法で表示できます。各列の名前(名前、説明、フットプリント)を右クリックすると、コンポーネントの表示方法に応じて次のオプションを選択できます。

  • Best Fit – Name列とDescriptions列の内容を詰めて配置し、列間の余分な空白をなくします。

  • Best Fit All Columns – すべての列の内容を詰めて配置し、列間の余分な空白をなくします。

  • Clear Sorting – 列の並べ替えを解除します。

  • Enable Columns Grouping – 列ヘッダーを特定の列に沿ってドラッグし、Name、Description、Footprint 列の順序を変更できます。

  • Select Columns – Select Columns ダイアログを開き、このセクションに表示する他の列を選択できます。

  • Apply Column Visibility to Child Categories – 選択したカテゴリに子カテゴリがある場合、このコマンドを使用すると、親カテゴリの列の表示設定を子カテゴリに適用できるようになります。このコマンドは、子カテゴリが存在する場合にのみ使用できます。

コンポーネントの検索と機能

コンポーネントの検索

Components パネルで使用可能なコンポーネントを検索するには、Search フィールドに語句を入力するか、パネルの Categories および Filters の選択項目を使用して、必要なコンポーネントに一覧を絞り込みます。これらは併用することもできます。フィルターは Workspace コンポーネントでのみサポートされます。また、Manufacturer Part Search パネルと同様に、Components パネルは単位を認識する(テキストを数値に変換する)検索フィルターをサポートしています。検索機能は、入力された検索条件に応じて結果に優先順位を付けます。

Search 機能を使用すると、有効な Search 文字列を選択し、編集または追記できます。

「有効な」検索文字列をクリックすると、Search フィールドに入力されます。Search フィールドで、その検索を再利用または編集できます。

Search フィールドでは、文字列内でアスタリスク(*)を使用したワイルドカード検索もサポートされています。

一覧のコンポーネントを右クリックし、Find Similar Components を選択して開く Find Similar Components ダイアログでは、選択したコンポーネントに基づいて検索条件を定義できます。

最終的な検索結果は、選択したコンポーネントの種類(Workspace コンポーネントか、それ以外のコンポーネントか)、および Workspace への接続状態によって異なります。たとえば、Workspace コンポーネントでは、Workspace 以外のコンポーネントよりも多くのパラメーターが表示されることがよくあります。選択したコンポーネントと同じ、または異なるコンポーネントやパラメーターを絞り込んで取得するには、ドロップダウンで Same、Any、Different を選択します。

コンポーネントの配置

選択したコンポーネントを回路図に配置するには、ドラッグ&ドロップ、右クリックのコンテキストメニューからの Place の選択、Details ペインの ボタンの使用、目的のコンポーネントのエントリのダブルクリック、または Enter ホットキーの使用という方法があります。

パネルからコンポーネントを配置するには、次の方法を使用できます。

  • Component Details ペインの Place ボタンをクリックします。カーソルが自動的に回路図シート内に移動し、コンポーネントがカーソルに追従して表示されます。位置を決めてクリックすると配置されます。コンポーネントを配置すると、同じコンポーネントの別のインスタンスがカーソルに表示されます。右クリックすると配置モードを終了します。

    Components panel, placing from component details pane

  • コンポーネントを右クリックし、コンテキストメニューから Place を選択します。コンポーネントがカーソルに追従して表示されるので、位置を決めてクリックして配置します。パネルが設計スペース上にフローティング表示されている場合は、回路図を見ながらコンポーネントを配置できるよう、パネルがフェード表示されます。コンポーネントを配置すると、同じコンポーネントの別のインスタンスがカーソルに表示されます。右クリックすると配置モードを終了します。

  • Click, Hold&Drag – パネルのグリッド領域からコンポーネントをクリックして回路図シートにドラッグします。このモードでは、マウスボタンを押したままにする必要があります。ボタンを放すと、コンポーネントが配置されます。コンポーネントを配置した後は、別のコンポーネントや別のコマンドを自由に選択できます。

    ドラッグ&ドロップでは、コンポーネントのインスタンスが1つ配置されます。複数のインスタンスを配置する必要がある場合は、Place コマンド/ボタンを使用するか、コンポーネントのエントリをダブルクリックします。

コンポーネントの配置は非常に簡単です。ただし、操作を始める前に、コンポーネントの配置先となる回路図シート(または PCB ドキュメント)が Altium Designer で開かれ、アクティブなドキュメントになっていることを確認してください。複数のウィンドウでドキュメントを開いている場合は、アクティブな回路図ドキュメントを含むウィンドウにフォーカスがあることも確認してください。

Altium Designer を複数のウィンドウで使用している場合、Components パネルまたは Explorer パネルが、対象の回路図を含まないウィンドウに何らかのモードでドッキングされていると、Place コマンドはグレー表示されたままになります。これは、ドッキングされたパネル内をクリックすると、そのパネルが接続されているウィンドウにフォーカスが移るためです。一方、パネルをフローティング表示にすると、必要な Altium ウィンドウ(対象の回路図がアクティブになっているウィンドウ)にフォーカスを合わせることができ、パネル内で操作している間も、そのウィンドウにフォーカスが維持されます。

マルチパートコンポーネントの配置

配置するコンポーネントに複数のパートがある場合、パネルの Models 領域にあるシンボルのプレビュー画像の下で選択したパートが最初に配置されます。

マルチパートコンポーネントのパートを配置した後は、そのパートを選択して Properties パネルの Part ドロップダウンを使用することで、同じコンポーネントの別のパートに変更できます。また、メインメニューの Edit » Increment Part Number コマンド、またはパートの右クリックメニューの Part Actions » Increment Part Number コマンドを使用して、次の使用可能なパートに切り替えることもできます。

Altium Designerでは、定義された標準および代替の表示モードを使用することで、単一のコンポーネントだけでマルチパートコンポーネントを単一のシンボル(すべてのサブパート)または複数のシンボル(各サブパートに1つずつ)として表示できます(例を表示)。

  • マルチパートコンポーネントの表示モード(標準または代替)に空のサブパートがある場合、それらのサブパートは配置時に省略されます (例を表示)。

  • マルチパートコンポーネントの1つのサブパートにのみプリミティブが定義されている場合、そのサブパートを回路図シートに配置すると、デジグネーターの接尾辞は非表示になります(例を表示)。

  • 現在選択されている表示モードでサブパートにプリミティブがない場合、または 現在選択されているサブパートに対して表示モードにプリミティブがない場合、コンポーネントのPropertiesパネルにあるModeドロップダウンのPartの該当項目はグレー表示されます()。ドロップダウンでそのような項目を選択すると、警告アイコンが 表示されます()。

  • コンポーネントにプリミティブのないサブパートがあり、それらのサブパートが回路図に配置されていない場合、設計の検証を実行してもコンポーネント内の未使用サブパート違反は発生しません。

コンポーネントの絞り込み

Workspaceコンポーネントを表示している場合、Filtersペインには、現在の検索と利用可能なパラメーターに基づいて選択されたフィルターオプションが表示されます。一覧表示されたコンポーネントをパラメーターで絞り込むことで、特定のコンポーネントや種類を見つけるための追加オプションを利用できます。Categoriesペインの上にあるボタンからFiltersペインを開きます。パネルがコンパクトモードの場合は、ボタンをクリックすると、Filtersがパネルの拡張領域としてポップアウト表示されます。

フィルターはWorkspaceコンポーネントでのみサポートされることに注意してください。ペイン内のFilter Searchフィールドを使用して、特定のパラメーターフィルターを検索できます。

Javascript ID: Pnl_Components_Filter
  • パネルのFiltersのパラメーター検索機能は、WorkspaceコンポーネントをホストするWorkspaceから適切なコンポーネントパラメーターデータが渡されることを前提としています。そのため、ソフトウェアが古いAltiumサーバー製品に接続されている場合、フィルター機能が無効になることがあります。以前のサーバーバージョンでフィルターを有効にするには、Advanced SettingsダイアログでComponentSearch.LegacyAFS.Filtersオプションを有効にします。

  • パラメーターを Filters ペインに表示するには、選択したカテゴリのコンポーネントで、そのパラメーターに少なくとも2つの異なる値が使用されている必要があります。また、Filtersペインに表示されるのは、最もよく使用されるパラメーター(接続先のWorkspace内のすべてのコンポーネントタイプにわたって、より多くのコンポーネントで使用されているもの)のうち、最大100個のみであることにも注意してください。次のパラメーター(または次の名前で始まるパラメーター)は、常にペインの先頭に表示されます: Power、Value、Resistance、Res、Capacitance、Case、Package、Tolerance、RoHS、Lead。

パネルのFiltersオプションは、特定のパラメータータイプをFavoritesとして選択することで、ニーズに合わせて調整できます。選択したタイプは、現在のコンポーネントカテゴリのリストの先頭に移動します。パラメーターフィルター名の右側にマウスポインターを合わせ、アイコンをクリックすると、そのフィルターをお気に入りに設定できます。お気に入りのフィルター設定は、コンポーネントカテゴリごとに適用・保存されます。

Workspaceコンポーネントの場合、右クリックメニューには、Component Editorでコンポーネントを編集するオプション(Edit)や、コンポーネントの作成と複製、選択したコンポーネントの部品候補とタイプの編集など、コンポーネント管理機能を実行するオプション(Operations)があります。

 
 
 
 
 

コンポーネントのDetailsペインで利用できる追加情報のオプションには、モデル画像の表示、オンラインデータシートの表示(References)、サプライヤーの最新情報(Part Choices)、Workspaceプロジェクト、管理対象シート、再利用ブロックでの部品の使用箇所の確認(Where Used)があります。また、右クリックメニューから、選択したコンポーネントパラメーターデータ(技術詳細)またはそのすべてをタブ区切り形式でコピーしたり、お気に入りとして設定されたパラメーターをデフォルトの5つのパラメーターにリセットしたりできます。

接続されたAltium 365 Workspace内のコンポーネントを参照しているときに、選択したコンポーネントの健全性に関する問題が見つかると、コンポーネントのパラメーターリストの上にあるComponent issues行に、(エラーの場合)または(致命的なエラーの場合)アイコンが表示されます。アイコンの右側の数字は、検出された問題の数を示します。数字の右側にある下矢印をクリックすると、各問題の簡単な説明を確認できます。

検出されたライブラリの健全性に関する問題の例。
検出されたライブラリの健全性に関する問題の例。

Workspaceライブラリの健全性は、Altium 365 WorkspaceのブラウザーインターフェースからアクセスできるLibrary Healthダッシュボードページで、さらに詳しく確認できます。詳細については、ライブラリ健全性ダッシュボードを参照してください。

カスタムフィルタリング機能を使用すると、Componentsパネルでの絞り込みをさらに細かく設定できます。 ​​​​​​

この機能は、次の手順で使用できます。

  1. ヘッダーのフィルター()アイコンをクリックして、Filterドロップダウンを表示します。

  2. ここでは、Filter Value(デフォルト)を選択するか、ユーザー定義のFilter Ruleを設定して絞り込むことができます。リストから値を選択すると、その値は自動的に式に変換されます(変換後に編集することもできます)。

  3. Filter Rulesを選択して独自のフィルターを定義する場合は、最初のドロップダウンから演算子を選択し、

  4. 次に、2番目のドロップダウンでフィルター値を選択または入力します。

  5. 現在のフィルターは結果リストの下に表示されます。ボタンをクリックすると、Filter Editorダイアログが開き、フィルターを編集できます。

使用箇所

ComponentsパネルでWorkspaceコンポーネントを選択すると、その最新リビジョンが現在使用されている箇所の情報がWhere Used領域に表示されます。この領域には、次の対象についてクイックフィルター情報が表示されます。

  • Projects – コンポーネントが使用されているWorkspaceプロジェクト。プロジェクトがWorkspaceに保存されると、情報がonly表示されます。

  • Managed Sheets – コンポーネントが使用されている管理対象の回路図シート。 

  • Reuse Blocks – 接続されたWorkspaceのライブラリの一部として保存されている再利用ブロック。

選択したコンポーネントを使用するエンティティがWorkspace内に存在する場合にのみ、タブが表示されることに注意してください。

コンポーネントがWorkspaceプロジェクトのすべての設計バリアントで使用されているわけではない場合、Where Used領域のプロジェクト項目には、そのコンポーネントが使用されているバリアントの数とプロジェクトのバリアント総数、およびコンポーネントが使用されているバリアントのリスト()が表示されます。

コンポーネントデータのキャッシュ

Componentsパネルを使用すると、WorkspaceコンポーネントのデータがWorkspaceからローカルマシンにキャッシュされます。これにより、Altium DesignerがWorkspaceに接続されていない場合でも、Workspaceコンポーネントにオフラインでアクセスできるため、通常どおりコンポーネントの参照や配置などを行えます。

現在のAltium Designerセッションで初めてComponentsパネルを開いた際にオフラインモードになっている場合は、パネルに警告が表示されます。また、キャッシュされたコンポーネントデータを引き続き使用するか、キャッシュを消去するかを選択するためのコントロールも表示されます。

Use Cached Dataをクリックすると、キャッシュされたコンポーネントを使用できます。この状態は、パネルのコンポーネントリストペインの下部バーにOffline mode – cached data is being usedという警告テキストで示されます。このモードではFiltersは有効にならないことに注意してください。

キャッシュにはコンポーネントデータが徐々に蓄積されます。PreferencesダイアログのData Management – Serversページで、Known Serversの下にあるClear Cacheオプションを使用すると、いつでもすべてのWorkspaceのキャッシュを消去できます。

キャッシュから表示されるのは、Altium 365 Workspaceなど、現在接続されているWorkspaceのコンポーネントのみです。このため、一部のキャッシュデータは無効になる場合があります。この動作は、PreferencesダイアログのData Management – Serversページで管理できます。

部品候補リスト

Workspaceコンポーネントに関連付けられた部品候補リストを編集するには、その項目の右クリックメニューからOperations » Create/Edit Part Choicesオプションを選択します。

続いて表示されるEdit Part Choicesダイアログのボタンを使用して、Add Part Choicesダイアログを開きます。このダイアログでは、選択したコンポーネントのNameパラメーターに基づき、メーカー部品が自動的に検索されます。あらかじめ設定された検索語の選択を解除すると、代替品を手動で検索できます。機能面では、このダイアログはManufacturer Part Searchパネルのモーダル版です。

部品候補リストでは、適切な星アイコンのレベルを選択して順位を付けることができます。リストは自動的に並べ替えられ、最も高い順位のメーカー部品候補が先頭に表示されます。

部品候補は、回路図設計、BOMドキュメント、出力レポートなど、コンポーネントデータが適用されるあらゆる場所でコンポーネントに引き継がれます。

Componentsパネルでコンポーネントを選択すると、DetailsペインのPart Choices領域に部品候補リストが表示されます。関連する部品候補の基本情報(在庫、単価の中央値、メーカーのライフサイクル)も、Detailsペインの上部で確認できます。関連する色付きの帯は、判定されたライフサイクル状態に基づき、その部品が使用に適しているかどうかの目安を示します。たとえば、Obsolete(赤)と表示されたコンポーネントは、Volume Production(緑)と評価されたものに比べて推奨されません。色付きの帯にカーソルを合わせると、メーカーのライフサイクル状態を確認できます。

SiliconExpertまたはZ2Dataの連携機能を使用している場合、Detailsペインの上部に追加のデータやコントロールが表示されることがあります。 詳細については、SiliconExpertからの部品データの取得 および Z2Dataからの部品データの取得の各ページを参照してください。

Workspaceで部品選択のリビジョン管理機能を有効にしている場合、 Operations » Create/Edit Part Choices オプションを選択すると、Edit Part Choicesダイアログではなく、コンポーネントエディターが開きます(単一コンポーネント編集モードまたは一括コンポーネント編集モード)。部品選択に必要な変更を加え、コンポーネントを次のリビジョンとしてWorkspaceに保存してください。

Componentsパネルの右クリックメニュー

このパネルの右クリックポップアップメニューには、以下のコマンドがあります。

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – 現在選択されているコンポーネントまたはシミュレーションモデルをアクティブな回路図ドキュメントに配置するか、現在選択されているフットプリントをアクティブなPCBドキュメントに配置します。

  • Find Similar Components – Find Similar Componentsダイアログを開き、選択したコンポーネントに類似するコンポーネントを検索するための条件を設定します。

  • Navigate to [ComponentName] – 選択したWorkspaceコンポーネントをExplorerパネルで開きます。このパネルでは、アイテムの詳細情報へのアクセス、アイテムのリビジョンやライフサイクル設定の管理、使用先やサプライチェーンの詳細の確認などができます。

  • Edit – クリックすると、選択したWorkspaceコンポーネントをコンポーネントエディター(単一コンポーネント編集モードまたは一括コンポーネント編集モード)で編集するか、選択したドメインモデル(シンボル、フットプリント、シミュレーションモデル)を対応するエディターで編集できます。現在のコンポーネントタイプが、現在使用しているテンプレートと異なる場合、Change component typeダイアログが開きます()。このダイアログを使用して、選択したコンポーネントのコンポーネントタイプを変更します。

  • Create – クリックするとCreate new componentダイアログが開き、新しいコンポーネントを追加する際にコンポーネントのタイプを選択できます。

  • Delete – クリックすると、選択したコンポーネントを接続先のWorkspaceから削除します。

  • Operations – 以下で説明するWorkspaceコンポーネント用の追加機能のドロップダウンメニューを開きます。

    • Submit Request – 有効な部品リクエストプロセス定義にアクセスします。Part Requestsプロセステーマに有効なプロセス定義がない場合、Submit Requestボタンはグレー表示され、使用できません。表示を更新するには、Workspaceからサインアウトして再度サインインするか、Altium Designerを再起動する必要がある場合があります。

    • Download – 選択したコンポーネントを、コンパイル済みの統合ライブラリ (*.IntLib)として、ソースライブラリパッケージ(*.LibPkg)およびライブラリファイルとともにZIP形式でダウンロードします。 複数のコンポーネントエントリを選択すると、それらを一度にダウンロードできます。

    • Make a copy – クリックすると、選択したコンポーネントをコピーします。コンポーネントエディターがSingle Component Editorモードで開きます。

    • Change Component Type – Choose component typeダイアログ()を開き、現在のコンポーネントのタイプを、リスト内の定義済みの別のタイプに変更できます。このダイアログには、コンポーネントタイプに関連付けられたコンポーネントテンプレートの情報と、そのタイプのコンポーネントの保存先となる接続先Workspace内のフォルダーが表示されます。 ボタンをクリックすると、PreferencesダイアログのData Management – Component Typesページで、使用可能なコンポーネントタイプのリストを管理できます。

    • Change State – 選択したコンポーネントのリビジョン状態を変更します。このコマンドを実行すると、Batch state changeダイアログが開き、コンポーネントのリビジョン状態を変更できます。

    • Create/Edit Part Choices – Edit Part Choicesダイアログを開き、Workspaceコンポーネントに関連付けられた部品選択リストを作成または編集できます。

      Workspaceで部品選択のリビジョン管理機能を有効にしている場合、 このコマンドを選択すると、コンポーネントエディターが単一コンポーネント編集モードまたは一括コンポーネント編集モードで開きます。
    • Full Item History – 現在選択されているコンポーネントの詳細ビューを、Altium Designer内の新しいタブ付きビューとして開きます。アイテムビューには、特定のアイテムのリビジョンとライフサイクルの履歴が詳細に表示されるほか、そのアイテムを構成するすべての要素が表示されます。このビューにはタイムラインも含まれます。タイムラインを使用すると、そのアイテムのリビジョンレベルまたはライフサイクル状態が変更された正確な日時と、変更したユーザーを確認できます。

  • Refresh – クリックすると、パネルをすばやく更新します。現在のコンポーネントの選択は保持されます。

コンポーネント比較機能

Compare機能を使用すると、選択した2つのコンポーネント(部品)のパラメーターを比較できます。この機能にアクセスするには、アイコンが有効(青色)な状態で、グリッド領域内の2つのコンポーネントを選択します。グリッド領域の右側に Selected Component Details領域が開きます。上部領域(下図の領域1)には、選択したコンポーネントの画像、名前、説明、価格が並べて表示されます。Datasheetボタンをクリックすると、対応するコンポーネントのメーカーのデータシートが開きます(利用可能な場合)。Placeボタンをクリックすると、コンポーネントを設計スペースに配置できます。コンポーネントは設計スペース内でカーソルに追従した状態で表示されます。目的の位置でクリックして配置してください。続けてコンポーネントを追加配置することも、右クリックまたはEscで配置モードを終了してComponentsパネルに戻ることもできます。

下部領域(下図の領域2)には、コンポーネントのパラメーターが並べて表示されます。相違点は赤い文字で強調表示されるため、簡単に比較できます。

Compare機能は、Componentsパネルがコンパクトモードの場合にも使用できますが、動作が少し異なります。この機能にアクセスするには、グリッド領域内の2つのコンポーネントを選択します。グリッド領域の下にSelected Component Details領域が開きます。上部領域には、コンポーネントの名前、価格、パラメーターが表示されます。相違点は赤い文字で強調表示されるため、簡単に比較できます。下部領域には、コンポーネントのSymbolsとModelsが並べて表示されます。

Compare機能は、Manufacturer Part Searchパネルでも使用できます。

コンポーネントのシンボルとフットプリントの編集

コンポーネントのシンボルとフットプリントは、DetailsペインのModelsセクション内で非表示にできます。このペインには、右上のInfo buttonをクリックしてアクセスします。非表示にすると、シンボルとフットプリントはクリック可能なリンクに置き換えられ、そのリンクをクリックすると元の表示に戻ります。また、表示されるモデルのサイズを調整することもできます。シンボルとフットプリントのどちらも、モデル領域の下端をクリックしてドラッグすると、画像のサイズを変更できます。

モデルビューの非表示とサイズ調整は、Manufacturer Part SearchパネルのDetailsペインでも行えます。

Componentsパネルで回路図ライブラリ(*.SchLib)ファイルを参照している場合、モデルプレビューの右下にあるボタンを使用して、選択したコンポーネントのシンボルとフットプリントを編集できます。

Componentsにアクセスした際、有効でリンク済みのフットプリントがすでに存在していれば、フットプリントを編集できます。

コンポーネント選択ダイアログ

Componentsパネルで使用される検索エンジンと表示は、部品を選択する他のAltium Designerアプリケーションでも使用されます。これらの(モーダル)ダイアログには部品検索機能に加え、OK確認ボタンが用意されており、使用できる操作コマンドには多少の違いがあります。このダイアログは通常、Component Searchと呼ばれます。

汎用部品へのアクセスと配置

この機能はオープンベータ段階であり、詳細設定ダイアログでComponentSearch.GenericComponentsオプションを有効にすると使用できます。

設計初期のレイアウト作業を迅速に進めるため、標準的で基本的なGeneric Components という概念が用意されています。汎用部品は、利用可能な部品ソースから特定のメーカー部品を探して選択することなく、設計にすばやく配置できます。汎用部品は、設計プロセスの後の段階で簡単に適切な部品に置き換えられるプレースホルダーとして使用することを目的としています。仮想部品またはパラメトリック部品と考えることもできます。

汎用部品の作成について詳しくは、 汎用部品の作成 ページを参照してください。

Altium DesignerがWorkspaceに接続されている場合、利用可能な汎用部品にはパネルからアクセスできます。CategoriesペインでAllオプションを選択すると表示されます。パネルがコンパクトモードの場合は、上部のドロップダウンメニューから選択できます。汎用部品のタイル内にあるボタンをクリックすると、部品がカーソルに追従し、アクティブな回路図ドキュメントに配置できるようになります。部品を回路図に配置すると、シンボルのピン、線、境界線のプリミティブ、つまり外形が赤色で表示され、汎用部品が使用されていることを示します。Componentsパネルでタイル自体を選択すると、その部品タイプのカテゴリがパネルに開きます。

Componentsパネルからの汎用部品の配置
Componentsパネルからの汎用部品の配置

汎用部品は最終的な設計で使用してはならないため、回路図に配置するとERC違反(汎用部品)が発生します。この違反のレベル(デフォルトはFatal Error)は、Project Optionsダイアログ(Project » Project Options)のエラーレポート設定にある部品に関連する違反セクションで設定します。

配置済みの汎用部品を選択すると、Propertiesパネルでそのプロパティにアクセスできます。このパネルには、このタイプの部品に関連する設定とパラメーターのみが表示されます。使用できるパラメーターは、関連する部品テンプレート(ここに示す例ではResistors)によって決まります。パラメーター値は手動で入力することも、同じタイプの利用可能なすべての部品から取得した値が表示されるドロップダウンメニューの一覧から選択することもできます。

汎用部品のパラメーターの指定 – ドロップダウンからのパラメーター値の選択。

汎用部品のパラメーターの指定 – 結果。

 

ジャンパー部品のサポート

ワイヤーリンクとも呼ばれるジャンパーを使用すると、配線をジャンパー部品に置き換えることができます。これは、片面基板の設計を成功させるうえで欠かせない要素となることがよくあります。Altium Designerでは、Jumperという特別な部品タイプにより、ジャンパー部品の使用をサポートしています。

ジャンパーのフットプリントをPCBに直接配置することから始めることもできますが、回路図から始めるワークフローを推奨します。詳しくは、ジャンパー部品の操作ページを参照してください。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents