보드에서 개체별 킵아웃으로 작업하기
개요
- 객체별 Keepout의 개념과 Altium Designer에서의 동작 방식, PCB 레이아웃에서 활용할 위치를 이해합니다.
- 특정 객체 유형만 제한하도록 Keepout을 설정하여 라우팅, 구리 배치 및 비아 동작을 더욱 유연하게 제어하는 방법을 알아봅니다.
- PCB Editor와 PCB Library Editor에서 Track 및 Arc Keepout을 비롯한 Keepout 객체를 배치하고 편집하는 기본 방법을 살펴봅니다.
PCB 설계에서 Keepout는 구리 객체가 교차할 수 없도록 레이아웃에 배치하는 사용자 정의 영역 또는 경계입니다. 일반적으로 폴리곤 푸어 및 인터랙티브 라우팅과 같은 자동 구리 배치 작업에 사용되는 영역을 제어하기 위해 사용되며, Keepout은 구리 객체를 수동으로 배치할 때도 배치할 수 없는 위치를 나타냅니다.
설계 레이아웃에서 지정된 ‘진입 금지’ 영역인 Keepout 객체는 기존 클리어런스 제약 조건 Rule을 사용하여 라우팅을 제어하고 배치 위반을 감지합니다. 하지만 다른 배치 객체와 달리 Net에 할당할 수 없으며, 생성된 Output이나 인쇄물에 표시되지 않습니다. 가장 간단히 말해, Keepout은 전역 클리어런스 Rule에 따라 다른 구리 객체가 해당 영역과 교차하지 못하도록 하는 ‘간섭’ 객체로 작동합니다. Keepout 객체는 Keep-out 레이어에 배치하여 모든 신호 레이어에 적용하거나, 특정 신호 레이어에 배치하여 해당 레이어의 객체에만 적용할 수 있습니다.
Altium Designer는 Object Specific Keepouts 지원을 통해 Keepout을 생성하고 적용할 수 있습니다. 배치된 Keepout 객체는 Track, 구리 영역, 비아, 패드 등 적용할 객체 유형을 지정하도록 구성할 수 있으므로 Keepout의 유연성과 효율성이 크게 향상됩니다.

PCB 설계에 배치된 다양한 유형의 Keepout 객체.
PCB 및 PCB 라이브러리 Editor에서 Keepout 객체는 교차 해칭으로 표시됩니다. Keep-Out 레이어에 배치된 Keepout 객체(모든 신호 레이어에 적용)는 Keep-Out 레이어 색상으로 표시되며, 특정 신호 레이어에 배치된 Keepout(해당 신호 레이어에만 적용)은 해당 신호 레이어의 색상으로 표시됩니다.
Keepout은 라우팅이 불가능한 보드 영역(전기적으로 민감한 영역 또는 고전압 영역 등), 피듀셜 및 테스트 포인트와 같은 특정 노출 구리 위치, 또는 기구적으로 호환되지 않는 영역(장착 홀이나 PCB 모서리 등)을 정의하는 데 적합합니다. 객체별 Keepout은 구성이 가능하므로 특정 Keepout Restrictions이 할당된 경우 다른 객체 위에 배치할 수도 있습니다. 예를 들어 비아만 제한하도록 설정하면 기존 구리 영역(예: 폴리곤 푸어) 위에 Keepout을 배치하여 자동 비아 스티칭의 범위를 제어할 수 있습니다.
객체별 Keepout은 PCB Editor 및 PCB 라이브러리 Editor에 배치할 수 있습니다.
PCB Keepout 객체의 배치 및 편집에 대한 자세한 내용은 아래의 접이식 섹션을 참조하십시오.
Track Keepout
Track은 기본 설계 객체입니다. 설계 작업에 사용되는 표준 Track 외에도 Track Keepout이라는 두 번째 유형의 Track을 사용할 수 있습니다. Track Keepout은 레이어별 Keepout 객체 또는 모든 레이어에 적용되는 Keepout으로 배치하여, 예를 들어 배치나 라우팅을 막는 장벽으로 사용할 수 있습니다. 표준 Track과 Track Keepout의 차이점은 레이어별 Keepout 유형의 채우기 객체가 Gerber 또는 ODB++와 같은 출력 생성에 포함되지 않는다는 점입니다. Keepout 영역은 Keepout 색상의 외곽선으로 식별할 수 있습니다.
Track Keepout 배치 명령을 실행하면 커서가 십자 모양으로 바뀌고 Track Keepout 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter 키를 눌러 첫 번째 Track Keepout 세그먼트의 시작점을 고정합니다.
- 커서를 움직여 Track Keepout 세그먼트를 정의한 다음 클릭하거나 Enter 키를 눌러 첫 번째 세그먼트의 끝점을 고정합니다. 이 끝점은 다음 연결 세그먼트의 시작점이기도 합니다.
- 계속해서 커서 위치를 지정한 다음 클릭하거나 Enter 키를 눌러 연결된 Track Keepout 세그먼트를 정의하는 일련의 꼭짓점을 고정합니다.
- 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 현재 연결된 Track Keepout 세그먼트의 배치를 마칩니다.
배치 중에 수행할 수 있는 추가 작업은 다음과 같습니다.
- 숫자 키패드의 * 키를 눌러 사용 가능한 신호 레이어를 차례로 전환합니다. 또는 Shift+Ctrl+Wheel Roll 조합을 사용하여 라우팅 레이어 간에 이동할 수 있습니다. 마우스 휠을 한 칸씩 돌릴 때마다 사용 가능한 다음(또는 이전) 신호 레이어로 이동합니다.
- 숫자 키패드의 + 및 - 키를 눌러 설계에서 현재 표시되는 모든 레이어를 순방향 및 역방향으로 차례로 전환합니다.
Keepout Track 세그먼트를 배치할 때는 다섯 가지 코너 모드를 사용할 수 있으며, 이 중 네 가지에는 코너 방향 하위 모드도 있습니다. 배치 중에는 다음 작업을 수행할 수 있습니다.
- Shift+Spacebar 키를 눌러 사용 가능한 다섯 가지 코너 모드를 차례로 전환합니다.
- Spacebar 키를 눌러 두 가지 코너 방향 하위 모드 사이를 전환합니다.
- Arc 코너 모드에서는 , 또는 . 키를 길게 눌러 Arc를 줄이거나 늘립니다. 키를 누를 때 Shift 키를 함께 누르고 있으면 Arc 크기 조정 속도가 빨라집니다.
- 1 단축키를 눌러 클릭당 세그먼트 하나를 배치하는 모드와 클릭당 세그먼트 두 개를 배치하는 모드 사이를 전환합니다. 첫 번째 모드에서 속이 빈 Track 세그먼트는 미리보기 세그먼트라고 합니다.
- Backspace 키를 눌러 마지막 꼭짓점을 제거합니다.
그래픽 편집 방법을 사용하면 설계 공간에서 배치된 Track Keepout 객체를 직접 선택하고 크기, 모양 또는 위치를 그래픽 방식으로 변경할 수 있습니다.
Track Keepout을 선택하면 다음 편집 핸들을 사용할 수 있습니다.
- 끝점 핸들을 클릭하여 Track의 끝점 위치를 변경합니다.
- 중앙 핸들을 클릭하고 드래그하여 Track의 모양을 변경합니다.
Track Keepout 속성

Properties 패널의 Keepout - Track 모드.
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 원점을 기준으로 한 Track Keepout 기준점의 현재 X(수평) 좌표입니다. 이 값을 편집하여 Track Keepout의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 Track Keepout 기준점의 현재 Y(수직) 좌표입니다. 이 값을 편집하여 Track Keepout의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오.
속성
- Component – 이 필드는 선택한 Track Keepout이 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, Parent PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component을 선택합니다. Parent 컴포넌트의 Properties 패널의 컴포넌트 모드를 여는 링크입니다.
- Restricted for Layer - 드롭다운을 사용하여 제한할 레이어를 선택합니다.
- Width - Track Keepout의 현재 너비를 표시합니다. 이 필드를 편집하여 Track Keepout 너비를 0.001mil~10000mil 범위 내에서 변경합니다.
- Start (X/Y) - 현재 원점을 기준으로 Track Keepout 시작점의 현재 X/Y 좌표를 표시합니다.
- End (X/Y) - 현재 원점을 기준으로 Track Keepout 끝점의 현재 X/Y 좌표를 표시합니다.
- Length - Track Keepout의 현재 길이를 표시합니다. 이 필드를 편집하여 Track Keepout 길이를 0.001mil~10000mil 범위 내에서 변경합니다.
Keepout 제한
이 Region에서 Keepout으로 제한할 객체 유형을 선택합니다. 객체 유형의 선택을 해제하면 해당 클리어런스 Rule이 적용되지 않으므로, Keepout은 해당 유형의 객체가 침범하는 것을 허용합니다(진입이 제한되지 않음). 선택 가능한 항목은 다음과 같습니다.
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Arc Keepout

하단 레이어의 Keepout Arc 두 개: 왼쪽은 완전한 원 형태의 Keepout Arc이고, 오른쪽은 편집을 위해 선택된 Keepout Arc입니다.
Arc Keepout은 기본 설계 객체입니다. 기본적으로 모든 레이어에 배치할 수 있는 원형 Track 세그먼트입니다. 컴포넌트 Outline 정의나 곡선 라우팅과 같은 설계 작업에 사용하는 표준 Arc 외에도 Keepout Arc라고 하는 두 번째 유형의 Arc를 사용할 수 있습니다. Keepout Arc는 Signal 레이어에 배치하여 레이어별 장벽 또는 진입 금지 Region을 만들 수 있습니다. 또한 Keepout 레이어에 배치할 수도 있으며, 이 경우 모든 Signal 레이어에 적용됩니다. 표준 Arc와 Keepout Arc의 차이점은 레이어별 Keepout 유형의 Arc가 Gerber 또는 ODB++와 같은 Output 생성에 포함되지 않는다는 점입니다. Keepout Arc는 Keepout 색상의 Outline으로 식별할 수 있습니다.
Arc의 배치 방식은 실행하기로 선택한 배치 방법에 따라 달라집니다. 다음 네 가지 Arc 배치 방법이 지원됩니다.
- Place arc by center – 이 방법을 사용하면 Arc의 중심을 시작점으로 삼아 Arc 객체를 배치할 수 있습니다.
- Place arc by edge – 이 방법을 사용하면 Arc의 가장자리를 시작점으로 삼아 Arc 객체를 배치할 수 있습니다. Arc 각도는 90°로 고정됩니다.
- Place arc by edge (any angle) – 이 방법을 사용하면 Arc의 가장자리를 시작점으로 삼아 Arc 객체를 배치할 수 있습니다. Arc 각도는 임의의 값으로 지정할 수 있습니다.
- Place full circle arc – 이 방법을 사용하면 360°(완전한 원) Arc를 배치할 수 있습니다.
Placing a Keepout Arc Starting at the Center
명령을 실행하면 커서가 십자 모양으로 바뀌고 Keepout Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter 키를 눌러 Keepout Arc의 중심점을 고정합니다.
- 커서를 이동하여 Keepout Arc의 반지름을 조정한 다음 클릭하거나 Enter 키를 눌러 설정합니다.
- 커서를 이동하여 Keepout Arc의 시작점을 조정한 다음 클릭하거나 Enter 키를 눌러 고정합니다.
- 커서를 이동하여 Keepout Arc 끝점의 위치를 변경한 다음 클릭하거나 Enter 키를 눌러 고정하고 Keepout Arc 배치를 완료합니다.
- Keepout Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
Placing a Keepout Arc Starting at the Edge
명령을 실행하면 커서가 십자 모양으로 바뀌고 Keepout Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter 키를 눌러 Keepout Arc의 시작점을 고정합니다.
- 커서를 이동하여 Keepout Arc 끝점의 위치를 변경한 다음 클릭하거나 Enter 키를 눌러 고정하고 Keepout Arc 배치를 완료합니다.
- Keepout Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
Placing a Keepout Arc Starting at the Edge (any angle)
명령을 실행하면 커서가 십자 모양으로 바뀌고 Keepout Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter 키를 눌러 Keepout Arc의 시작점을 고정합니다.
- 커서를 이동하여 Keepout Arc의 반지름을 조정한 다음 클릭하거나 Enter 키를 눌러 중심점을 고정합니다.
- 커서를 이동하여 Keepout Arc 끝점의 위치를 변경한 다음 클릭하거나 Enter 키를 눌러 고정하고 Keepout Arc 배치를 완료합니다.
- Keepout Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
Placing a Full Circle Keepout Arc
명령을 실행하면 커서가 십자 모양으로 바뀌고 Keepout Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter 키를 눌러 Keepout Arc의 중심점을 고정합니다.
- 커서를 이동하여 Keepout Arc의 반지름을 조정한 다음 클릭하거나 Enter 키를 눌러 설정하고 Keepout Arc 배치를 완료합니다.
- Keepout Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
모든 방법(완전한 원 형태의 Arc 제외)에서 Keepout Arc의 끝점을 정의하기 전에 Spacebar 키를 누르면 Arc를 반대 방향으로 그릴 수 있습니다.
그래픽 편집 방법을 사용하면 설계 공간에서 배치된 Arc 객체를 직접 선택하고 크기, 모양 또는 위치를 그래픽 방식으로 변경할 수 있습니다.
Keepout Arc 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.

선택된 Keepout Arc
- A을 클릭하고 드래그하여 반지름을 조정합니다.
- B을 클릭하고 드래그하여 끝점(시작 및 끝 각도)을 조정합니다.
-
편집 핸들에서 떨어진 Arc의 아무 지점이나 클릭한 다음 드래그하여 위치를 변경합니다. 또는 Arc의 중심점을 클릭하고 드래그합니다. 드래그하는 동안 Arc를 회전하거나 대칭 이동할 수 있습니다.
- Spacebar을 누르면 Arc가 반시계 방향으로 회전하고, Shift+Spacebar을 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – General 페이지에 정의된 Rotation Step 값에 따라 이루어집니다.
- X 또는 Y 키를 누르면 Arc가 각각 X축 또는 Y축을 기준으로 대칭 이동합니다.
Arc Keepout 속성

Properties 패널의 Keepout - Arc 모드입니다.
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 Arc Keepout 기준점의 현재 X(수평) 좌표입니다. 값을 편집하여 Arc Keepout의 X 위치를 변경할 수 있습니다. 미터법 또는 야드파운드법 단위로 값을 입력할 수 있으며, 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 Arc Keepout 기준점의 현재 Y(수직) 좌표입니다. 값을 편집하여 Arc Keepout의 Y 위치를 변경할 수 있습니다. 미터법 또는 야드파운드법 단위로 값을 입력할 수 있으며, 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
속성
- Component – 이 필드는 선택한 Arc Keepout이 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, 상위 PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트의 Properties 패널의 컴포넌트 모드가 열립니다.
- Restricted Layer - 이 필드는 Arc Keepout이 현재 할당된 제한 레이어를 표시합니다. 레이어를 변경하려면 필드를 클릭하고 드롭다운 목록에서 레이어를 선택합니다.
- Width - 이 필드는 Arc Keepout 선의 폭을 표시합니다. 필요한 경우 다른 폭 값을 입력합니다.
- Radius - 이 필드는 중심점에서 Arc Keepout 선의 중심까지 측정한 Arc의 반지름을 표시합니다. 필요한 경우 다른 반지름 값을 입력합니다.
- Start Angle - 이 필드는 제1사분면(평면 기하학)의 X축을 기준으로 측정한 Arc Keepout의 시작 각도를 표시합니다. 필요한 경우 다른 시작 각도 값을 입력합니다.
- End Angle - 이 필드는 Arc Keepout의 끝 각도를 표시합니다. 필요한 경우 다른 끝 각도 값을 입력합니다.
Keepout 제한
이 영역에서 Keepout으로 제한할 객체 유형을 선택합니다. 객체 유형의 선택을 해제하면 해당 클리어런스 Rule이 적용되지 않아 해당 유형의 객체가 Keepout 영역을 침범할 수 있습니다(배제되지 않음). 선택 가능한 항목은 다음과 같습니다.
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Region Keepout

Region Keepout
Region Keepout은 기본 설계 객체입니다. 설계 작업에 사용되는 표준 Region 외에 Region Keepout이라는 두 번째 유형의 Region을 사용할 수 있습니다. Region Keepout은 특정 레이어 전용 Keepout 객체 또는 모든 레이어에 적용되는 Keepout으로 배치하여 배치나 라우팅을 차단하는 용도로 사용할 수 있습니다. 표준 Region과 Keepout Region의 차이점은 특정 레이어 전용 Keepout 유형의 채우기가 Gerber 또는 ODB++ 등의 출력 생성에 포함되지 않는다는 점입니다. Keepout Region은 Keepout 색상으로 표시되는 외곽선으로 구분할 수 있습니다.
Region Keepout 배치 명령(Place » Keepout » Solid Region)을 실행하면 커서가 십자 모양으로 바뀌고 Region Keepout 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 커서를 원하는 위치에 놓고 클릭하여 Region Keepout의 시작 꼭짓점을 고정합니다.
- 커서를 이동하여 두 번째 꼭짓점을 배치할 준비를 합니다. 기본적으로 클릭할 때마다 두 개의 모서리가 배치되며, 그 사이의 코너 형상은 사용자가 정의합니다.
- 마우스를 계속 이동하고 클릭하여 추가 꼭짓점을 배치합니다.
- 마지막 꼭짓점을 배치한 후 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 Region Keepout을 닫고 배치를 완료합니다. 소프트웨어가 시작점과 마지막으로 배치한 점을 연결하여 형상을 자동으로 완성하므로 Region을 수동으로 닫을 필요가 없습니다.
- 추가 Region Keepout을 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
그래픽 편집 방식을 사용하면 설계 공간에서 배치된 객체를 직접 선택하여 크기, 형상 또는 위치를 그래픽으로 변경할 수 있습니다.

선택된 Region Keepout
Move Region Vertices
Region Keepout에는 Region의 형상을 편집하는 데 사용하는 두 가지 유형의 점, 즉 "핸들"이 있습니다.
- Full Handles - Region Keepout의 코너에 위치합니다.
- Empty Handles - 채워진 핸들로 생성된 선분의 중심에 위치합니다.
각 코너 또는 각 모서리의 중심에 있는 핸들이나 꼭짓점을 이동하여 기존 Region Keepout의 형상을 변경할 수 있습니다.
Region Keepout의 형상을 수정하려면 다음과 같이 합니다.
-
클릭하고 Region Keepout을 선택하면 해당 Region Keepout의 꼭짓점이 강조 표시되고 커서가 십자 모양으로 바뀝니다.
- Click 채워진 핸들에서 이 작업을 수행하면 해당 코너가 이동합니다.
- Click 모서리를 따라 이 작업을 수행하면 모서리 전체가 이동합니다.
- Click 빈 핸들에서 이 작업을 수행하면 변 전체가 이동합니다(Track 및 Arc의 경우).
- Ctrl+Click 빈 핸들에서 이 작업을 수행하면 해당 모서리가 두 개의 모서리로 분할됩니다. Ctrl 키는 이동을 시작할 때만 누르고 있으면 됩니다. 그런 다음 Shift+Spacebar 단축키를 사용하여 모드(Arc, 마이터, 임의 각도)를 순환할 수 있습니다.
- '임의 각도' 배치 모드에서 원치 않는 꼭짓점이 생성되었거나 추가 꼭짓점을 제거하려면 클릭하고 Ctrl 가운데의 채워진 핸들을 잡습니다. 핸들 위에 X 아이콘이 나타나며, 모서리를 드래그하면 해당 모서리의 꼭짓점이 하나로 줄어듭니다.
Modify Region Border
꼭짓점 편집 외에도 Modify Region Border 명령을 사용하여 폴리곤의 형상을 손쉽게 변경할 수 있습니다. 이 명령은 원하는 폴리곤을 마우스 오른쪽 버튼으로 클릭한 다음 Polygon Actions » Modify Polygon Border을 선택하여 실행합니다. 명령을 실행하면 커서가 십자 모양으로 바뀝니다. 클릭할 때마다 새 꼭짓점이 추가됩니다. Region Keepout 배치 중과 마찬가지로 Shift+Spacebar 단축키를 사용하여 코너 형상을 변경할 수 있습니다.
Region Keepout 속성

Properties 패널의 Keepout - Region 모드입니다.
속성
- Component – 이 필드는 선택한 Region Keepout이 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, 상위 PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트에 대한 Properties 패널의 컴포넌트 모드가 열립니다.
- Restricted for Layer - 드롭다운을 사용하여 Region Keepout이 위치한 레이어를 선택합니다.
- Arc Approximation - 완벽한 Arc로부터의 최대 편차를 입력합니다.
- Area - 배치된 객체의 총면적입니다.
- Locked (Properties 패널만 해당) - 활성화하면 Region Keepout이 잠깁니다.
Outline 꼭짓점
이 영역은 현재 선택한 Region 객체의 개별 꼭짓점을 수정하는 데 사용됩니다. 기존 꼭짓점의 위치를 수정하거나, 필요에 따라 새 꼭짓점을 추가하거나 삭제할 수 있습니다. 꼭짓점 사이의 Arc 연결을 정의할 수 있으며, 꼭짓점 정보를 CSV 형식 파일로 내보내거나 해당 파일에서 가져오는 기능도 지원됩니다.
-
Vertices Grid - 현재 Region에 정의된 모든 꼭짓점을 다음 항목으로 나열합니다.
- Index - 꼭짓점에 할당된 인덱스입니다(편집 불가).
- X - 꼭짓점의 X(수평) 좌표입니다. 클릭하여 편집합니다.
- Y - 꼭짓점의 Y(수직) 좌표입니다. 클릭하여 편집합니다.
- Arc Angle (Neg = CW) - 이 꼭짓점과 다음 꼭짓점을 연결하는 Arc의 각도입니다. 기본적으로 꼭짓점은 직선 모서리로 연결되며, 이 필드는 비어 있습니다. 클릭하여 편집한 다음 필요한 Arc 각도를 입력합니다. 양수 값을 입력하면 Arc가 반시계 방향으로 그려집니다. 시계 방향으로 Arc를 그리려면 음수 값을 입력합니다.
-
Add - 클릭하여 새 꼭짓점을 추가합니다. 새 꼭짓점은 현재 포커스가 있는 꼭짓점 항목 아래에 추가되며, 초기 X,Y 좌표는 포커스가 있는 항목과 동일합니다.
을 클릭하면 현재 선택한 꼭짓점이 삭제됩니다.
Keepout 제한 사항
이 영역에서 Keepout으로 제한할 객체 유형을 선택합니다. 객체 유형의 선택을 해제하면 해당 클리어런스 Rule이 적용되지 않으므로 Keepout은 해당 유형의 객체가 영역을 침범하도록 허용합니다(진입을 제한하지 않음). 선택 가능한 항목은 다음과 같습니다.
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Fill Keepout
Fill Keepout은 모든 레이어에 배치할 수 있는 기본 설계 객체입니다. 컴포넌트 Outline 정의와 같은 설계 작업에 사용하는 표준 Fill 외에도 Fill Keepout이라는 두 번째 유형의 Fill을 사용할 수 있습니다. Fill Keepout은 특정 레이어에만 적용되는 Keepout 객체 또는 모든 레이어에 적용되는 Keepout으로 배치하여, 예를 들어 배치나 라우팅을 차단하는 데 사용할 수 있습니다. 표준 Fill과 Keepout Fill의 차이점은 특정 레이어에 적용되는 Keepout 유형의 Fill이 Gerber 또는 ODB++ 등의 Output 생성에 포함되지 않는다는 것입니다. Keepout Fill은 Outline이 Keepout 색상으로 표시되어 구분할 수 있습니다.
Fill Keepout 배치 명령을 실행하면 커서가 십자선으로 바뀌고 Fill Keepout 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter을 눌러 Fill Keepout의 첫 번째 모서리를 고정합니다.
- 커서를 이동하여 Fill Keepout의 크기를 조정한 다음 클릭하거나 Enter을 눌러 대각선 반대편 모서리를 고정하고 Fill Keepout 배치를 완료합니다.
- 계속해서 Fill Keepout을 추가로 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 배치 모드를 종료합니다.
그래픽 편집 방식에서는 설계 공간에서 배치된 객체를 직접 선택하고 크기, 모양 또는 위치를 그래픽 방식으로 변경할 수 있습니다.
Fill Keepout 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.

선택된 Fill Keepout
- 모서리 핸들을 클릭한 상태로 드래그하여 Fill Keepout의 수직 및 수평 크기를 동시에 조정합니다.
- 측면, 상단 및 하단 핸들을 클릭한 상태로 드래그하여 Fill Keepout의 수직 및 수평 크기를 각각 조정합니다.
- 가운데 핸들을 클릭한 상태로 드래그하여 Fill Keepout을 중심점 기준으로 회전합니다.
-
Fill Keepout에서 편집 핸들이 아닌 곳을 클릭한 상태로 드래그하여 위치를 변경합니다. 드래그하는 동안 Fill Keepout을 회전하거나 대칭 이동할 수 있습니다.
- Spacebar을 누르면 Fill Keepout이 반시계 방향으로 회전하고, Shift+Spacebar을 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – 일반 페이지에서 정의한 Rotation Step 값에 따라 이루어집니다.
- X 또는 Y 키를 누르면 Fill Keepout이 X축 또는 Y축을 기준으로 대칭 이동합니다.
Fill Keepout 속성

Properties 패널의 Keepout - Fill 모드입니다.
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 Fill Keepout 기준점의 현재 X(수평) 좌표입니다. 편집하여 Fill Keepout의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 Fill Keepout 기준점의 현재 Y(수직) 좌표입니다. 편집하여 Fill Keepout의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Rotation - 0도(3 o'clock 수평 방향)를 기준으로 반시계 방향으로 측정한 Fill Keepout의 회전 각도(도 단위)입니다. 편집하여 Fill Keepout의 회전을 변경합니다. 최소 각도 분해능은 0.001°입니다.
속성
- Component – 이 필드는 선택한 Fill Keepout이 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, 상위 PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트에 대한 Properties 패널의 컴포넌트 모드가 열립니다.
- Restricted for Layer - 드롭다운을 사용하여 제한할 레이어를 선택합니다.
- Area - 배치된 객체의 면적을 표시합니다.
- Length - Fill Keepout의 현재 길이를 표시합니다. 이 필드를 편집하여 길이를 0.001mil~10000mil 범위 내에서 변경할 수 있습니다.
- Width - Fill Keepout의 현재 너비를 표시합니다. 이 필드를 편집하여 너비를 0.001mil~10000mil 범위 내에서 변경할 수 있습니다.
Keepout 제한 사항
이 Region에서 Keepout으로 제한할 객체 유형을 선택합니다. 객체 유형의 선택을 해제하면 해당 클리어런스 Rule이 적용되지 않으므로 해당 유형의 객체는 Keepout 영역을 침범할 수 있습니다(배제되지 않음). 선택 가능한 항목은 다음과 같습니다.
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Keepout 배치
Place » Keepout 메뉴에서 Editor 설계 공간에 Keepout을 배치할 수 있으며, 지정한 Keepout 스타일(Track, Fill, Region 또는 Arc)이 현재 활성 레이어에 배치됩니다. Keepout의 속성을 선택하여 Physical 특성, 레이어 또는 객체 유형 제한 사항을 편집합니다. 관련 Keepout 속성은 다음과 같습니다.
- Restricted for Layer – Keepout 레이어를 설정합니다. 이에 따라 구리 객체가 제한되는(배제되는) 보드 레이어가 결정됩니다. 모든 레이어에 적용되는 Keepout의 경우 Keep-Out Layer을 선택합니다.
- Keepout Restrictions – Keepout으로 제한할 객체 유형을 결정합니다. 객체 유형의 선택을 해제하면 해당 클리어런스 Rule이 적용되지 않으므로 해당 유형의 객체는 Keepout 영역을 침범할 수 있습니다(배제되지 않음).
아래 이미지의 두 Keepout Fill에는 서로 다른 레이어 및 객체 제한 사항이 적용되어 있습니다. 왼쪽의 Top 레이어 Keepout Fill은 스루홀(TH) Pad를 허용하면서 다른 모든 객체 유형은 제한하고, 오른쪽의 Keep-Out 레이어는 Track만 허용합니다.

PCB의 서로 다른 레이어에 배치하고 서로 다른 객체 유형의 배치를 제한하도록 구성한 두 Keepout Fill의 예.
Keepout은 유연성이 뛰어나 PCB 레이아웃을 제어하는 다양한 작업에 활용할 수 있습니다. Keepout은 겹쳐 배치하거나 Top 또는 Bottom과 같은 임의의 Signal 레이어에 할당할 수 있고 특정 객체를 배제하도록 구성할 수도 있으므로, 예를 들어 비아 스티칭 및 폴리곤 푸어를 정밀하게 제어하는 데 사용할 수 있습니다.
폴리곤 푸어 제어
아래 PCB 레이아웃 예에서는 고전압이 발생할 가능성이 있는 Region의 다중 레이어 Pad 주위에 Keepout Fill을 추가했습니다. 이 영역은 이후 추가할 접지 연결 폴리곤 푸어와 충분히 전기적으로 절연되어야 합니다. Keepout Fill은 Top 레이어로 설정되어 있으며 구리 객체만 제한하도록 구성되어 있습니다. 따라서 폴리곤 푸어, Fill 및 Region은 배제하지만 기존 Track과 Pad 등은 허용합니다. 즉, 클리어런스 위반 Rule은 '구리'로 분류된 객체에만 적용됩니다.

Keep-Out 레이어에 배치하고 구리 객체에만 적용되도록 구성한 Keepout Fill.
위와 같이 Keepout을 배치하면 Signal 레이어(이 경우 Top 및 Bottom 레이어)에 배치된 폴리곤 푸어가 세 Keepout 영역을 모두 피하도록 할 수 있습니다. 그러나 해당 영역과 관련된 Top 레이어의 pads에는 Top 레이어 푸어로부터 충분한 클리어런스가 확보되지 않습니다.
이 경우 Top 레이어에 Keepout을 추가하여 폴리곤 푸어가 관련된 모든 Pad로부터 적절한 거리를 유지하도록 할 수 있습니다. 아래 이미지에서는 Top 레이어에 Keepout Fill 두 개를 추가했으며, 명확하게 볼 수 있도록 싱글 레이어 모드로 표시했습니다. 표시된 Keepout 영역은 겹치는 두 Fill 대신 하나의 Region으로도 만들 수 있습니다.

Top 레이어에 배치하고 구리 객체에만 적용되도록 구성한 Keepout Fill.
최종적으로 레이아웃에 폴리곤 푸어를 추가하면, 배치된 Keepout들이 푸어를 제어하여 해당 Region 주위에 레이어별로 서로 다른 클리어런스 형상을 만듭니다. 이 예에서는 Custom Keepout 클리어런스 Rule(아래 참조)로 인해 Keepout 관련 클리어런스가 일반 객체의 클리어런스보다 큽니다.
아래와 같이 싱글 레이어 3D 모드로 레이아웃을 보면 Keepout들이 폴리곤 푸어에 미치는 영향을 명확하게 확인할 수 있습니다. 왼쪽은 Top 레이어, 오른쪽은 Bottom 레이어입니다.

싱글 레이어 3D 모드로 표시한 PCB의 Top 레이어(왼쪽)와 Bottom 레이어(오른쪽).
비아 스티칭 제어
다중 레이어 구리 영역에 비아 객체를 제한하도록 구성한 Keepout 형상을 적용하면 자동 비아 스티칭(Tools » Via Stitching/Shielding)의 범위를 제어할 수 있습니다. Keepout 형상은 임의의 레이어 또는 구리 영역 레이어 중 하나에 설정할 수 있으며, 해당 레이어 사이의 비아가 '배제'(제한)되도록 합니다.
아래 예에서는 레이아웃의 왼쪽 위와 왼쪽 아래 모서리에 Keepout 형상을 추가했습니다. 이 형상들은 비아 객체를 제한하도록 구성되어 있어 자동 비아 스티칭 시 해당 경계 안에 비아가 배치되지 않습니다.

비아에만 적용되도록 구성한 Keepout Region.
비아 스티칭은 일반적으로 기존 Track, Pad 및 비아를 피할 뿐만 아니라, 해당 클리어런스 Rule에 따라 Keepout 형상도 피합니다.
컴포넌트의 Keepout
PCB Library Editor에서 컴포넌트 풋프린트에 Keepout을 추가하는 방법은 PCB Editor 설계 공간에서 Keepout을 추가하는 방법과 동일합니다.
아래 컴포넌트 풋프린트에 추가된 Keepout은 Track을 제외한 모든 객체를 제한하도록 구성되어 있습니다. 따라서 해당 컴포넌트를 사용하는 레이아웃에서 Net 연결은 허용하면서 다른 객체 유형이 가까이 배치되는 것은 제한합니다.

PCB Library Editor에서 컴포넌트 풋프린트에도 Keepout 객체를 추가할 수 있습니다.
Keepout 작업
Altium Designer의 객체별 Keepout 구현은 모든 관련 기능에 반영되어 있으며, 쿼리(따라서 설계 Rule), PCB List Panel, 가져온 PCB 설계 문서 및 이전 버전의 PCB 설계 문서와도 호환됩니다.
Keepout 클리어런스 Rule
다른 기본 객체와 마찬가지로, 현재 전기적 클리어런스 Rule이 Keepout의 클리어런스 제약 조건을 결정합니다. Design » Rules을 참조하세요. Keepout에 다른 클리어런스 제약 조건이 필요한 경우, IsKeepOut 속성 검사를 Custom 쿼리로 적용하여 전용 Rule을 생성합니다.
Custom Keepout 클리어런스 Rule의 우선순위가 기존(전역) 클리어런스 Rule보다 높게 설정되어 있는지 확인하세요. 아래 예에서는 기본 클리어런스 Rule(Clearance)의 클리어런스 제약 조건 거리보다 두 배 큰 거리를 적용한 Keepout용 Rule(Clearance_Keepout)이 생성되어 있습니다. 보드 레이아웃의 일부에 표시된 것처럼, 두 패드 사이에 배선된 Track은 Top 레이어 Region(왼쪽)보다 Keepout Region(오른쪽)에서 더 큰 간격을 유지합니다.

Keepout 객체용 클리어런스 Rule을 추가로 생성할 수 있습니다.
프리미티브 객체를 Keepout으로 변환
Signal 레이어에 있는 기존 프리미티브 객체는 Convert Primitives to Keepouts 명령(Tools » Convert » Convert Selected Primitives to Keepout)을 사용하여 동일한 레이어의 Keepout으로 변환할 수 있습니다.

프리미티브 객체를 이에 상응하는 Keepout 객체로 변환할 수 있으며, 그 반대도 가능합니다.
Panel을 통한 접근
보드 설계의 객체별 Keepout은 PCB List 및 PCB Filter Panel을 통해 접근할 수 있습니다.
PCB Filter Panel에서는 IsKeepOut 쿼리 키워드를 사용하여 설계 내 Keepout 객체를 찾고 필요에 따라 선택할 수 있습니다.

PCB Filter Panel을 사용하여 설계 내 Keepout 객체를 찾을 수 있습니다.
PCB List Panel을 사용하면 선택한 유형의 Keepout 객체를 나열하고 선택 및 편집할 수 있습니다. 예를 들어 아래 List Panel 이미지에는 Keepout Fill이 표시되어 있습니다. 비교를 위해 일반 Top 레이어 Fill도 목록의 마지막에 표시되어 있습니다. 설계에 포함된 Fill(또는 Region과 같은 다른 유형의 객체)이 all Keepout으로 지정되어 있으면, PCB List Panel에 Keepout 객체의 모든 제한 속성이 표시됩니다.

PCB List Panel을 사용하여 선택한 유형의 Keepout 객체를 나열하고 선택 및 편집할 수 있습니다.
PCB 설계 Import
Altium Designer는 Import Wizard(File » Import Wizard)가 제공하는 자동 변환 기능을 사용하여 다양한 다른 설계 도구의 설계 파일을 Import할 수 있습니다. 다른 설계 도구의 PCB 설계 파일에 포함된 Keepout 유형 객체(일부는 객체별로 지정됨)는 가능한 경우 Wizard에 의해 객체별 Keepout으로 변환됩니다.
Wizard의 Keepout 변환 프로세스는 Mentor® Graphics Pads™ 및 Cadence® Allegro™와 같은 널리 사용되는 ECAD 시스템의 보드 설계와 호환됩니다. IDF Export 과정에서도 Keepout이 올바르게 해석됩니다.



