Praca ze ścieżkami i łukami
W skrócie
- Dowiedz się, jak umieszczać, edytować, przenosić i ponownie trasować segmenty ścieżek w edytorze PCB za pomocą podstawowych poleceń i skrótów.
- Poznaj sposób, w jaki trasowanie interaktywne uwzględnia sieci, warstwy, tryby prowadzenia narożników, rozwiązywanie kolizji i obowiązujące reguły projektowe.
- Zobacz, jak określana i dostosowywana jest szerokość ścieżek oraz jak preferencje i reguły wpływają na dostępne szerokości.
Praca ze ścieżkami
Segment ścieżki to linia prosta o określonej szerokości. Ścieżki służą do definiowania linii prostych w obszarze projektowania PCB. Umieszcza się je na warstwie sygnałowej, aby tworzyć połączenia elektryczne między padami komponentów. Ścieżki umieszczone na warstwie nieelektrycznej nazywane są liniami i służą jako uniwersalne elementy rysunkowe do tworzenia obrysów komponentów, instrukcji, granic obszarów zabronionych itp. Ścieżki są również wykorzystywane w złożonych obiektach projektowych, takich jak wymiary i współrzędne.

Obiekty ścieżek służą do prowadzenia połączeń i rysowania linii ogólnego przeznaczenia. Na powyższym obrazie widoczne są cztery umieszczone segmenty ścieżek oraz kolejny w trakcie umieszczania.
Choć ścieżki i linie są w rzeczywistości tym samym obiektem, różnią się sposobem działania oprogramowania podczas ich umieszczania, dlatego dostępne są dla nich różne polecenia. Po uruchomieniu polecenia umieszczania ścieżki, takiego jak Interactive Routing, oprogramowanie monitoruje miejsce kliknięcia i automatycznie przejmuje nazwę sieci istniejącego obiektu (np. pada) znajdującego się w tym miejscu. Sprawdza również wszystkie obowiązujące reguły projektowe i przestrzega ich. Po uruchomieniu polecenia umieszczania linii (Place » Line) takie monitorowanie nie jest wykonywane.
Ścieżki można umieszczać zarówno w edytorze PCB, jak i w edytorze bibliotek PCB. Niezależnie od użytego polecenia (prowadzenia połączeń/umieszczania ścieżek lub umieszczania linii), podstawowy sposób umieszczania jest taki sam. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania ścieżek. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter, aby ustalić punkt początkowy pierwszego segmentu ścieżki. Jeśli uruchomione jest polecenie prowadzenia połączeń i rozpoczniesz umieszczanie, klikając istniejący obiekt, ścieżka przejmie nazwę sieci tego obiektu. Podczas prowadzenia połączeń szerokość będzie określana przez obowiązującą regułę projektową Szerokość ścieżek; ustawienie to można nadpisać za pomocą niektórych opcji interaktywnego prowadzenia połączeń, opisanych bardziej szczegółowo poniżej.
- Przesuń kursor, aby określić segment ścieżki, a następnie kliknij lub naciśnij Enter , aby ustalić punkt końcowy pierwszego segmentu, który jest jednocześnie punktem początkowym następnego połączonego segmentu.
- Kontynuuj ustawianie kursora, a następnie klikaj lub naciskaj Enter , aby ustalać kolejne wierzchołki definiujące ciąg połączonych segmentów ścieżki.
- Kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć bieżący ciąg połączonych segmentów ścieżki.
Podczas umieszczania można również wykonywać następujące czynności:
- Naciskaj klawisz * na klawiaturze numerycznej, aby przełączać się między dostępnymi warstwami sygnałowymi. Możesz też użyć kombinacji Shift+Ctrl+Wheel Roll , aby przechodzić między warstwami prowadzenia połączeń; każdy skok kółka myszy przełączy na następną (lub poprzednią) dostępną warstwę sygnałową.
- Naciskaj klawisze + i - na klawiaturze numerycznej, aby przechodzić do przodu i do tyłu przez wszystkie warstwy aktualnie widoczne w projekcie.
Podczas umieszczania segmentów ścieżek dostępnych jest pięć trybów narożników, z których cztery mają również warianty kierunku narożnika. Podczas umieszczania:
- Naciskaj Shift+Spacebar, aby przełączać się między dostępnymi trybami narożników.
- Naciśnij Spacebar, aby przełączyć się między dwoma wariantami kierunku narożnika.
- W jednym z trybów narożników łukowych przytrzymaj klawisz , lub . , aby zmniejszyć lub powiększyć łuk. Dodatkowo przytrzymaj klawisz Shift, aby przyspieszyć zmianę rozmiaru łuku.
- Użyj skrótu klawiaturowego 1, aby przełączać się między umieszczaniem jednego segmentu na kliknięcie (pokazanym na pierwszych pięciu obrazach poniżej) a umieszczaniem dwóch segmentów na kliknięcie (pokazanym na ostatnim obrazie poniżej). W pierwszym trybie segment ścieżki wyświetlany jako pusty obrys nazywany jest segmentem wyprzedzającym.
- Naciśnij klawisz Backspace, aby usunąć ostatni wierzchołek.



Naciskaj Shift+Spacebar, aby przełączać się między pięcioma dostępnymi trybami narożników; naciśnij Spacebar, aby zmienić kierunek narożnika; użyj skrótu 1, aby przełączyć się między umieszczaniem jednego a dwóch segmentów.
Graficzna metoda edycji pozwala wybrać umieszczony obiekt ścieżki bezpośrednio w obszarze projektowania i graficznie zmienić jego rozmiar, kształt lub położenie.
Po zaznaczeniu obiektu ścieżki dostępne są następujące uchwyty edycji:
- Kliknij i przeciągnij A , aby zmienić położenie punktów końcowych ścieżki.
- Kliknij i przeciągnij B , aby zmienić kształt ścieżki.
Edytor PCB zawiera zaawansowane algorytmy przemieszczania segmentów ścieżek na płytce, które pozwalają zachować układ połączeń. Takie przesuwanie segmentów ścieżek można uruchomić interaktywnie: kliknij najpierw segment ścieżki, aby go zaznaczyć, a następnie, gdy pojawi się specjalny kursor, kliknij i przytrzymaj przycisk myszy, aby przesunąć segment. Możesz też od razu kliknąć segment ścieżki, przytrzymać przycisk myszy i przesunąć go. Sposób przesuwania można skonfigurować za pomocą opcji Dragging na stronie Edytor PCB — interaktywne prowadzenie połączeń w oknie dialogowym Preferences. Opcje te pozwalają przypisać ścieżce działanie Przenieś, co jest przydatne, gdy chcesz swobodnie przemieszczać pojedynczy segment ścieżki.

Sposób przesuwania ścieżek można kontrolować za pomocą opcji przeciągania ustawianych w preferencjach.
Jeśli za pomocą tych opcji przypisano działanie Move, podczas przemieszczania segment ścieżki można obracać lub odbijać lustrzanie.
Interaktywne prowadzenie połączeń i obowiązujące reguły projektowe
Podczas interaktywnego prowadzenia połączeń oprogramowanie domyślnie zapewnia umieszczanie segmentów ścieżek zgodnie z obowiązującymi regułami projektowymi dotyczącymi parametrów elektrycznych i prowadzenia połączeń. Oznacza to, że nie pozwoli umieścić nowego segmentu ścieżki w sposób naruszający wymagania względem istniejącego segmentu należącego do innej sieci; zamiast tego przytnie segment tak, aby spełniał reguły projektowe. Ten sposób interaktywnego prowadzenia połączeń określany jest jako tryb Routing Conflict Resolution. Domyślnym trybem jest Stop at First Obstacle (bieżący tryb jest wyświetlany na pasku stanu). Naciskaj Shift+R, aby przełączać się między dostępnymi trybami.
Termin applicable design rules oznacza wszystkie reguły mające zastosowanie do umieszczanego obiektu. Mechanizm reguł projektowych działa w oparciu o system, w którym dokładnie określasz, do jakich obiektów ma się odnosić każda reguła. Podczas umieszczania mechanizm reguł projektowych jest odpytywany w celu ustalenia reguły o najwyższym priorytecie, która ma zastosowanie w danej sytuacji. Reguły obowiązujące podczas interaktywnego prowadzenia połączeń obejmują:
- Odstęp elektryczny
- Szerokość ścieżek
- Typ przelotek
Poniższa animacja przedstawia prowadzenie połączeń w praktyce. Połączenie sieci GND jest prowadzone zgodnie ze zdefiniowaną i obowiązującą regułą projektową dotyczącą szerokości ścieżek. Zauważ, że gdy kursor znajdzie się nad przelotką należącą do sieci +12V, ścieżka zostaje automatycznie przycięta, aby zapewnić zgodność z obowiązującą regułą projektową Ograniczenie odstępu elektrycznego.

Podczas interaktywnego prowadzenia połączeń obowiązujące reguły projektowe dotyczące szerokości ścieżek i odstępów są automatycznie przestrzegane.
Jak określana jest szerokość ścieżki
O ile mechanizm reguł nie jest wyłączony, nadrzędną zasadą działania oprogramowania jest zapewnienie, że szerokość prowadzonej ścieżki zawsze mieści się w zakresie dopuszczonym przez obowiązującą regułę projektową szerokości ścieżek (Routing Width). Typowym podejściem jest dopuszczenie dla danej sieci zakresu szerokości zapewniającego elastyczność przy prowadzeniu ścieżki przy jednoczesnym spełnieniu wymagań dotyczących obciążalności prądowej tej sieci. W tym celu reguła projektowa Routing Width udostępnia ustawienia Min, Preferred i Max w edytorze reguł i ograniczeń PCB. Można je skonfigurować tak, aby dopuszczały zakres szerokości, lub nadać im tę samą wartość, aby wymusić określoną szerokość. Szerokość można również skonfigurować na podstawie impedancji oraz określić inny zakres dla każdej warstwy sygnałowej.

Domyślna reguła projektowa Routing Width jest stosowana do wszystkich sieci na nowej płytce PCB.
Jako projektant masz do dyspozycji kilka opcji ułatwiających wybór najodpowiedniejszej szerokości ścieżki przy rozpoczynaniu trasowania. Konfiguruje się je na stronie Edytor PCB — Trasowanie interaktywne w oknie dialogowym Preferences, jak pokazano poniżej.

Opcje Interactive Routing Width Sources określają szerokość używaną przy rozpoczynaniu trasowania.
Zwróć uwagę, że na ilustracji opcja Track Width Mode jest ustawiona na Rule Preferred. Oznacza to, że ta szerokość zostanie użyta, gdy trasowanie rozpocznie się na istniejącym obiekcie sieci, takim jak pad. Jeśli jednak trasowanie rozpocznie się na istniejącej ścieżce, opcja Pickup Track Width From Existing Routes zastąpi ustawienie Track Width Mode i dopasuje nową szerokość do szerokości istniejącej ścieżki.
Podczas trasowania możesz również użyć skrótu Shift+W, aby otworzyć okno dialogowe umożliwiające wybór innej szerokości, lub nacisnąć Tab, aby otworzyć Properties panel i wpisać nową wartość Width . Wybrana lub wprowadzona wartość musi mieścić się między ustawieniami Min i Max zdefiniowanymi w obowiązującej regule. W przeciwnym razie zostanie automatycznie ograniczona do najbliższej z tych wartości.
Skróty trasowania interaktywnego
Podczas trasowania dostępnych jest wiele skrótów. Na przykład możesz nacisnąć Shift+R, aby przełączać dostępne tryby rozwiązywania konfliktów, lub Backspace, aby usunąć ostatnio umieszczony wierzchołek (narożnik). Aby wyświetlić listę skrótów podczas trasowania, naciśnij Shift+F1. Zostanie wyświetlone menu dostępnych skrótów interaktywnych. Wybierz odpowiedni skrót lub naciśnij Esc, aby zamknąć menu i użyć odpowiedniej kombinacji klawiszy.

Podczas trasowania interaktywnego naciśnij Shift+F1, aby wyświetlić menu dostępnych skrótów interaktywnych
Przesuwanie ścieżki
Podmenu Edit » Move oraz menu poleceń przesuwania w Active Bar zawierają szereg poleceń umożliwiających zmianę położenia lub kształtu ścieżki.
Ponowne trasowanie
To polecenie umożliwia ręczne ponowne trasowanie istniejącej ścieżki na płytce. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się monit o wybranie ścieżki. Umieść kursor nad odpowiednią ścieżką, a następnie kliknij lub naciśnij Enter. Działanie tej funkcji zależy od tego, czy opcja Preserve Angle When Dragging jest włączona na stronie Edytor PCB — Trasowanie interaktywne w oknie dialogowym Preferences:
- Preserve Angle Dragging enabled — ścieżka zostanie podzielona, a nowy segment zostanie dodany w celu zachowania połączeń prostopadłych lub ukośnych. Przesuń kursor, aby przesunąć ten segment w wymagane miejsce, a następnie kliknij, aby zatwierdzić jego położenie. W tym momencie kliknij prawym przyciskiem myszy lub naciśnij Esc , w przeciwnym razie nowy segment zostanie podzielony przez dodanie kolejnego segmentu. Użyj skrótu klawiaturowego Shift+R, aby przełączać opcje określające sposób postępowania z przeszkodami podczas przeciągania (Ignore Obstacles, Avoid Obstacles lub Avoid Obstacles (Snap Grid)). Jeśli włączony jest jeden z trybów unikania przeszkód, podczas przeciągania przestrzegane są reguły, co uniemożliwia przeciągnięcie segmentu w położenie naruszające te reguły.
- Preserve Angle Dragging disabled — oba końce segmentu ścieżki zostaną unieruchomione i będzie można poprowadzić między nimi nowe segmenty. Kliknij lub naciśnij Enter, aby umieścić nowy segment ścieżki. Kontynuuj umieszczanie nowych segmentów w ramach ponownego trasowania lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby zakończyć.
Kontynuuj ponowne trasowanie kolejnych ścieżek lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść.
Podział ścieżki
To polecenie umożliwia utworzenie wierzchołka (punktu podziału) w segmencie ścieżki. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się monit o wybranie ścieżki. Umieść kursor nad odpowiednim segmentem ścieżki w miejscu, w którym chcesz wstawić punkt podziału, a następnie kliknij lub naciśnij Enter. Zostanie wstawiony wierzchołek, dzielący pierwotny segment na dwa.
Przesuń wierzchołek w wymagane miejsce, a następnie kliknij lub naciśnij Enter , aby zatwierdzić jego położenie. Połączone z nim segmenty ścieżki zachowują się zgodnie z ustawieniem opcji Preserve Angle When Dragging na stronie Edytor PCB — Trasowanie interaktywne w oknie dialogowym Preferences:
- Preserve Angle When Dragging włączona — kąty względem sąsiednich segmentów ścieżki zostają zachowane, co pozwala utrzymać styl trasowania.
- Preserve Angle When Dragging wyłączona — dwa oddzielne segmenty ścieżki będą rozciągać się elastycznie, dostosowując się do przesunięcia bez zachowania dotychczasowego stylu trasowania.
Kontynuuj dzielenie kolejnych segmentów ścieżek lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść.
Przeciąganie końca ścieżki
To polecenie umożliwia ręczną zmianę położenia lub przeciąganie końca poprowadzonego segmentu ścieżki. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się monit o wybranie obiektu. Umieść kursor nad ścieżką, a następnie kliknij lub naciśnij Enter. Kursor przeskoczy do najbliższego końca segmentu ścieżki, a koniec ścieżki zostanie do niego przyłączony. Przesuń koniec ścieżki w żądane miejsce, a następnie kliknij lub naciśnij Enter, aby zatwierdzić jego położenie.
- Jeśli koniec wybranego segmentu ścieżki jest wierzchołkiem niepołączonym z żadnymi innymi segmentami ścieżek, przesuń go w żądane miejsce.
- Jeśli koniec wybranego segmentu ścieżki jest wierzchołkiem, do którego są podłączone dwa segmenty ścieżek, podłączone segmenty będą się elastycznie rozciągać podczas przesuwania wierzchołka.
- Jeśli koniec segmentu ścieżki jest połączony z polem lutowniczym komponentu, przesunięcie końca spowoduje odłączenie go od tego pola. Po zmianie położenia końca zostanie wyświetlona linia połączenia logicznego między końcem ścieżki a polem lutowniczym, pod warunkiem że opcja Smart Track Ends jest włączona na stronie PCB Editor – General w oknie dialogowym Preferences.
- Jeśli koniec segmentu ścieżki jest połączony z niezależnym polem lutowniczym, pole zostanie dołączone do kursora i będzie gotowe do zmiany położenia. Wszystkie ścieżki podłączone do pola będą się odpowiednio elastycznie rozciągać.
- Jeśli koniec segmentu ścieżki jest połączony z przelotką, przelotka zostanie dołączona do kursora i będzie gotowa do zmiany położenia. Wszystkie ścieżki podłączone do przelotki będą się odpowiednio elastycznie rozciągać.
Kontynuuj przeciąganie kolejnych końców ścieżek lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby zakończyć.
Przesuwanie i zmiana długości ścieżek
To polecenie służy do przesuwania punktów końcowych wielu zaznaczonych segmentów ścieżek, co powoduje zmianę ich długości. Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się monit o wskazanie punktu końcowego ścieżki. Aby przesunąć ścieżki lub zmienić ich długość:
- Umieść kursor na punkcie końcowym jednego z zaznaczonych segmentów, a następnie kliknij lub naciśnij Enter.
- Przesuń kursor; długości wszystkich zaznaczonych segmentów ścieżek będą się dynamicznie zmieniać, przy zachowaniu pierwotnych odległości i kątów między nimi. Drugi koniec każdego segmentu będzie się elastycznie rozciągać, aby zachować dotychczasowe połączenie lub położenie.
- Gdy segmenty znajdą się w żądanym miejscu, kliknij lub naciśnij Enter , aby zatwierdzić położenie i zakończyć tryb przesuwania.
- Aby anulować operację, kliknij prawym przyciskiem myszy lub naciśnij Esc.
Podczas przesuwania segmentów dostępne są następujące dodatkowe funkcje:
- Naciśnij klawisz Tab , aby przełączać położenie kursora między punktami końcowymi poszczególnych zaznaczonych segmentów ścieżek.
- Przytrzymaj klawisz Alt podczas przesuwania, aby ograniczyć ruch do określonego kierunku, zależnego od początkowego kierunku ruchu. Możliwe są kierunki poziomy, pionowy oraz pod kątem 45 stopni.
- Naciśnij dwukrotnie Spacebar , aby szybko wyrównać wszystkie punkty końcowe segmentów ścieżek w poziomie lub w pionie. Ponownie naciśnij szybko dwukrotnie Spacebar, aby przywrócić poprzednie długości.
Przecinanie ścieżek
Narzędzie do przecinania ścieżek umożliwia łatwe dzielenie jednego lub większej liczby segmentów ścieżek na dwie części. Może ono przecinać ścieżki na bieżącej warstwie sygnałowej lub na wszystkich widocznych warstwach sygnałowych. Aby uruchomić narzędzie, wybierz polecenie Edit » Slice Tracks z menu głównych.
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i pojawi się monit o wskazanie punktu początkowego cięcia. Dodatkowo zostanie zastosowane filtrowanie, dzięki któremu w obszarze roboczym będą widoczne tylko obiekty ścieżek. Będą to wszystkie ścieżki na wszystkich widocznych warstwach sygnałowych lub tylko ścieżki na bieżącej warstwie sygnałowej, zależnie od aktualnych ustawień narzędzia do przecinania ścieżek. Aby przeciąć jedną lub więcej ścieżek:
- Umieść kursor w wybranym miejscu, a następnie kliknij lub naciśnij Enter, aby ustalić punkt początkowy cięcia.
- Przesuń kursor przez punkt ścieżki lub ścieżek, w którym chcesz wykonać cięcie — przebieg cięcia jest wskazywany linią, a przewidywane miejsca przecięcia są przedstawiane graficznie.
- Kliknij lub naciśnij Enter, aby ustalić punkt końcowy linii cięcia.
- Kontynuuj przecinanie kolejnych segmentów ścieżek lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby zakończyć tryb przecinania.
Po wybraniu początkowego punktu cięcia, podczas przesuwania „linii cięcia”, można wykonywać następujące dodatkowe czynności:
- Naciśnij klawisz B, aby przełączać między przecinaniem ścieżek tylko na bieżącej warstwie sygnałowej a przecinaniem ścieżek na wszystkich widocznych warstwach sygnałowych.
- Naciśnij Spacebar, aby przełączać kąt cięcia między przyrostami co 45 stopni a dowolnym kątem.
- Naciśnij klawisz N, aby przełączać położenie ostrza między lewą stroną, prawą stroną a środkiem.
- Naciśnij klawisz /, aby zaznaczyć wszystkie przecięte ścieżki.
- Naciśnij klawisz „,”, aby zaznaczyć przecięte ścieżki po lewej stronie linii cięcia.
- Naciśnij klawisz „.”, aby zaznaczyć przecięte ścieżki po prawej stronie linii cięcia.
- Naciśnij klawisz M, aby nie zaznaczać żadnych przeciętych ścieżek.
-
Naciśnij klawisz Tab, aby otworzyć okno dialogowe Slicer Properties, w którym można na bieżąco zmieniać właściwości narzędzia do przecinania ścieżek.

Okno dialogowe Slicer Properties
Przekształcanie ścieżek w ścieżki ze ściętymi narożnikami
Ścinanie narożników ścieżek pod kątem 90 stopni to technika stosowana w celu ograniczenia odbić powodowanych przez narożniki ścieżek pracujących w zakresie częstotliwości mikrofalowych. Można stosować łuki, ale ich promień powinien wynosić co najmniej trzykrotność szerokości ścieżki. Alternatywą jest ścinanie narożników, polegające na odcięciu zewnętrznego wierzchołka narożnika. Ponieważ obiekty ścieżek w Altium Designer mają zaokrąglone końce, nie można ich użyć do utworzenia ściętego narożnika. Aby utworzyć taki narożnik, zaznaczone segmenty ścieżek są zastępowane obiektami regionów.
Zaznacz wszystkie segmenty ścieżek, których narożniki mają zostać ścięte, a następnie wybierz polecenie Tools » Convert » Convert Selected Tracks to Chamfered Path z menu głównego. Otworzy się okno dialogowe Convert Tracks to Chamfered Path. Skonfiguruj w nim parametry ścięcia, a następnie kliknij OK. Każda para zaznaczonych segmentów ścieżek tworzących kąt 90 stopni zostanie zastąpiona połączeniem ze ściętym narożnikiem, a oryginalne segmenty każdej pary zostaną przekształcone w pojedynczy obiekt pełnego regionu miedzi.

Każdy narożnik zaznaczonych ścieżek tworzący kąt prosty zostanie ścięty o określoną wartość.
Do skonfigurowania ścięcia służą następujące opcje w oknie dialogowym:
- Chamfer - wielkość fragmentu zewnętrznego narożnika, który ma zostać odcięty, wyrażona jako procent istniejącej długości przekątnej narożnika.
- Inside Chamfer - ilość materiału, który ma zostać dodany do wewnętrznego narożnika, wyrażona jako procent istniejącej długości przekątnej narożnika.
How big should the Chamfer be?
Procentowe ścięcie określa odciętą część przekątnej między wewnętrznym a zewnętrznym narożnikiem nieściętego zakrętu.
Douville i James wyznaczyli eksperymentalnie optymalne ścięcie dla szerokiego zakresu geometrii linii mikropaskowych. Stwierdzili, że dobre przybliżenie optymalnego procentowego ścięcia opisuje wzór
Przy warunku
i stałej dielektrycznej podłoża
.
Wzór ten jest całkowicie niezależny od
. Rzeczywisty zakres parametrów, dla którego Douville i James przedstawili wyniki badań, wynosi
oraz
. Według autorów współczynnik fali stojącej napięcia (VSWR) jest lepszy niż 1,1 (tj. poziom odbicia jest niższy niż −26 dB) dla każdego procentowego ścięcia odbiegającego od wartości obliczonej ze wzoru o nie więcej niż 4% pierwotnej wartości
. Przy minimalnej wartości
równej 0,25 procentowe ścięcie wynosi 98,4%, co oznacza, że pasek jest niemal całkowicie przecięty.
Właściwości ścieżki
Informacje o sieci
Ta sekcja zawiera informacje o sieci, do której należy ścieżka, a także o parze różnicowej i/lub sygnale xSignal, jeśli sieć do nich należy. W stosownych przypadkach wyświetlane są informacje o klasie. Podawane są również wartości Delay, Length, Max Current i Resistance.
Więcej informacji o sieciach znajdziesz na stronie Techniki rozmieszczania i edycji obiektów PCB.
Położenie
-
(X/Y)
- X (pierwsze pole) – bieżąca współrzędna X (pozioma) punktu odniesienia ścieżki względem bieżącego początku układu współrzędnych obszaru projektowego. Edytuj ją, aby zmienić położenie ścieżki w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż bieżące jednostki domyślne, podaj je wraz z wartością.
- Y (drugie pole) – bieżąca współrzędna Y (pionowa) punktu odniesienia ścieżki względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie ścieżki w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż bieżące jednostki domyślne, podaj je wraz z wartością.
Właściwości
- Component – to pole jest wyświetlane w edytorze PCB tylko wtedy, gdy zaznaczona ścieżka stanowi część komponentu PCB. Zawiera ono oznaczenie komponentu nadrzędnego. Kliknij łącze Component, aby otworzyć tryb Component panelu Properties dla komponentu nadrzędnego.
- Net – służy do wyboru sieci dla ścieżki. Lista rozwijana zawiera wszystkie sieci aktywnego projektu płytki. Pamiętaj, że jeśli umieszczanie obiektu rozpoczyna się w miejscu istniejącego obiektu, który jest już połączony z siecią, właściwość Net nowego obiektu zostaje automatycznie ustawiona na tę sieć. Wybierz No Net, aby określić, że ścieżka nie jest połączona z żadną siecią. Właściwość Net obiektu podstawowego jest używana przez narzędzie sprawdzania reguł projektowych do określenia, czy obiekt PCB został umieszczony zgodnie z regułami. Możesz też kliknąć ikonę Assign Net , aby wybrać obiekt w obszarze projektowym — sieć tego obiektu zostanie przypisana do zaznaczonych ścieżek.
- Layer – użyj listy rozwijanej, aby wybrać warstwę, na której znajduje się ścieżka.
- Width – wyświetla bieżącą szerokość ścieżki. Edytuj to pole, aby zmienić szerokość ścieżki w zakresie od 0,001 mil do 10000 mil.
- Start (X/Y) – wyświetla bieżące współrzędne X/Y punktu początkowego ścieżki względem bieżącego początku układu współrzędnych.
- End (X/Y) – wyświetla bieżące współrzędne X/Y punktu końcowego ścieżki względem bieżącego początku układu współrzędnych.
-
Length – wyświetla bieżącą długość ścieżki. Edytuj to pole, aby zmienić długość ścieżki w zakresie od 0,001 mil do 10000 mil.
Rozszerzenie maski pasty
- Rule/Manual – wybierz żądaną konfigurację rozszerzenia maski pasty. Wybierz Rule, aby rozszerzenie maski pasty dla ścieżki odpowiadało wartości określonej w odpowiedniej regule projektowej rozszerzenia maski pasty. Wybierz Manual, aby zastąpić odpowiednią regułę projektową i określić wartość rozszerzenia maski pasty dla ścieżki. Następnie możesz włączyć odpowiednie pole i wprowadzić żądaną wartość.
Rozszerzenie maski lutowniczej
- Rule/Manual – wybierz żądaną konfigurację rozszerzenia maski lutowniczej. Wybierz Rule, aby rozszerzenie maski lutowniczej dla ścieżki odpowiadało wartości określonej w odpowiedniej regule projektowej rozszerzenia maski lutowniczej. Wybierz Manual, aby zastąpić odpowiednią regułę projektową i określić wartość rozszerzenia maski lutowniczej dla ścieżki. Następnie możesz włączyć odpowiednie pole i wprowadzić żądaną wartość.
Praca z łukami
Łuk jest podstawowym obiektem projektowym. Jest to zasadniczo kołowy odcinek ścieżki, który można umieścić na dowolnej warstwie. Łuki mają wiele zastosowań w projektowaniu PCB. Można ich na przykład używać do definiowania obrysów komponentów na warstwach opisowych lub do oznaczania obrysu płytki, krawędzi wycięć itp. na warstwie mechanicznej. Mogą również służyć do tworzenia zakrzywionych ścieżek podczas trasowania interaktywnego. Łuki mogą być otwarte lub zamknięte, tworząc okrąg (często nazywany łukiem pełnego okręgu).

Dwa umieszczone łuki: po lewej łuk pełnego okręgu, po prawej łuk zaznaczony do edycji.
Łuki można umieszczać zarówno w edytorze PCB, jak i w edytorze bibliotek PCB. Dostępne są cztery tryby umieszczania łuków (środek, krawędź, dowolny kąt i pełny okrąg). Sposób umieszczania łuku zależy od wybranej metody:
-
Place arc by center – ta metoda umożliwia umieszczenie łuku z wykorzystaniem jego środka jako punktu początkowego.
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuków. Umieszczanie odbywa się przez wykonanie następujących czynności:
- Kliknij lub naciśnij Enter, aby ustalić środek łuku.
- Przesuń kursor, aby dostosować promień łuku, a następnie kliknij lub naciśnij Enter, aby go ustawić.
- Przesuń kursor, aby dostosować punkt początkowy łuku, a następnie kliknij lub naciśnij Enter, aby go ustalić.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku.
- Kontynuuj umieszczanie kolejnych łuków lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
-
Place arc by edge – ta metoda umożliwia umieszczenie łuku z wykorzystaniem jego krawędzi jako punktu początkowego. Kąt łuku jest stały i wynosi 90°.
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuków. Umieszczanie odbywa się przez wykonanie następujących czynności:
- Kliknij lub naciśnij Enter, aby ustalić punkt początkowy łuku.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku.
- Kontynuuj umieszczanie kolejnych łuków lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
-
Place arc by edge (any angle) – ta metoda umożliwia umieszczenie łuku z wykorzystaniem jego krawędzi jako punktu początkowego. Kąt łuku może mieć dowolną wartość.
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuków. Umieszczanie odbywa się przez wykonanie następujących czynności:
- Kliknij lub naciśnij Enter, aby ustalić punkt początkowy łuku.
- Przesuń kursor, aby dostosować promień łuku, a następnie kliknij lub naciśnij Enter, aby ustalić jego środek.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku.
- Kontynuuj umieszczanie kolejnych łuków lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
-
Place full circle arc – ta metoda umożliwia umieszczenie łuku o kącie 360° (pełnego okręgu).
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuków. Umieszczanie odbywa się przez wykonanie następujących czynności:
- Kliknij lub naciśnij Enter, aby ustalić środek łuku.
- Przesuń kursor, aby dostosować promień łuku, a następnie kliknij lub naciśnij Enter, aby go ustawić i zakończyć umieszczanie łuku.
- Kontynuuj umieszczanie kolejnych łuków lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Dodatkowe czynności, które można wykonać podczas umieszczania:
- W przypadku wszystkich metod (z wyjątkiem łuków pełnego okręgu) naciśnij Spacebar przed określeniem punktu końcowego łuku, aby łuk był rysowany w przeciwnym kierunku.
- Naciśnij klawisz L, aby przenieść łuk na drugą stronę płytki – pamiętaj, że jest to możliwe tylko przed ustaleniem punktu początkowego lub środka łuku.
- Naciśnij klawisze + i - (na klawiaturze numerycznej) lub użyj skrótów Shift+Ctrl+Wheelroll, aby przełączać się w przód i wstecz między wszystkimi widocznymi warstwami projektu i szybko zmieniać warstwę umieszczania.
Graficzna metoda edycji umożliwia zaznaczenie umieszczonego łuku bezpośrednio w obszarze projektowym oraz graficzną zmianę jego rozmiaru, kształtu lub położenia.
Po zaznaczeniu łuku dostępne są następujące uchwyty edycyjne:

Zaznaczony łuk
- Kliknij i przeciągnij A, aby dostosować promień.
- Kliknij i przeciągnij B, aby dostosować punkty końcowe (kąt początkowy i końcowy).
-
Kliknij w dowolnym miejscu łuku poza uchwytami edycyjnymi, a następnie przeciągnij, aby zmienić jego położenie. Możesz też kliknąć i przeciągnąć środek łuku. Podczas przeciągania łuk można obracać lub odbijać lustrzanie:
- Naciśnij Spacebar, aby obrócić łuk przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Obrót odbywa się zgodnie z wartością Rotation Step, zdefiniowaną na stronie Edytor PCB – Ogólne w oknie dialogowym Preferences.
- Naciśnij klawisz X lub Y, aby wykonać odbicie lustrzane łuku względem osi X lub Y.
Właściwości łuku
Informacje o sieci
Ten obszar zawiera informacje o sieci, do której należy łuk, a także o parze różnicowej i/lub sygnale xSignal, jeśli sieć do nich należy. W stosownych przypadkach wyświetlane są informacje o klasach. Podawane są również wartości Delay, Length, Max Current i Resistance.
Więcej informacji o sieciach znajdziesz na stronie Techniki rozmieszczania i edycji obiektów PCB.
Położenie
-
(X/Y)
- X (pierwsze pole) – to pole pokazuje bieżącą współrzędną X środka łuku względem aktualnego początku układu współrzędnych. Edytuj wartość w polu, aby zmienić położenie łuku względem aktualnego początku układu współrzędnych. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli wprowadzana wartość ma jednostki inne niż aktualnie domyślne, podaj je razem z wartością. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w przestrzeni projektowej nie zaznaczono żadnych obiektów) i są używane, jeśli nie podano jednostki.
- Y (drugie pole) – to pole pokazuje bieżącą współrzędną Y środka łuku względem aktualnego początku układu współrzędnych. Edytuj wartość w polu, aby zmienić położenie łuku względem aktualnego początku układu współrzędnych. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli wprowadzana wartość ma jednostki inne niż aktualnie domyślne, podaj je razem z wartością. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w przestrzeni projektowej nie zaznaczono żadnych obiektów) i są używane, jeśli nie podano jednostki.
Właściwości
- Component – to pole jest wyświetlane w edytorze PCB tylko wtedy, gdy zaznaczony łuk stanowi część komponentu PCB, i pokazuje oznaczenie komponentu nadrzędnego. Kliknij łącze Component, aby otworzyć tryb Komponent panelu Właściwości dla komponentu nadrzędnego.
- Net – służy do wyboru sieci dla łuku. Lista rozwijana zawiera wszystkie sieci aktywnego projektu płytki. Pamiętaj, że jeśli umieszczanie obiektu rozpoczyna się w miejscu istniejącego obiektu, który jest już połączony z siecią, właściwość Net nowego obiektu jest automatycznie przypisywana do tej sieci. Wybierz No Net, aby określić, że łuk nie jest połączony z żadną siecią. Właściwość Netobiektu podstawowego jest używana przez narzędzie do sprawdzania reguł projektowych w celu określenia, czy obiekt PCB jest umieszczony zgodnie z regułami. Możesz też kliknąć ikonę Assign Net , aby wybrać obiekt w przestrzeni projektowej — sieć tego obiektu zostanie przypisana do zaznaczonych łuków.
- Layer – to pole pokazuje warstwę, do której łuk jest obecnie przypisany. Łuki można przypisywać do dowolnej dostępnej warstwy. Aby zmienić przypisaną warstwę, kliknij pole i wybierz warstwę z listy rozwijanej.
- Width – to pole pokazuje szerokość linii łuku. W razie potrzeby wprowadź inną wartość szerokości.
- Radius – to pole pokazuje promień łuku mierzony od jego środka do środka linii łuku. W razie potrzeby wprowadź inną wartość promienia.
- Start Angle – to pole pokazuje kąt początkowy łuku mierzony od osi X w pierwszej ćwiartce (geometria płaska). W razie potrzeby wprowadź inną wartość kąta początkowego.
- End Angle – to pole pokazuje kąt końcowy łuku. W razie potrzeby wprowadź inną wartość kąta końcowego.
- Propagation Delay – to pole pokazuje czas propagacji sygnału wzdłuż tej ścieżki.
Rozszerzenie maski pasty lutowniczej
- Rule – wybierz tę opcję, aby rozszerzenie maski pasty lutowniczej dla łuku było zgodne z wartością określoną w obowiązującej regule projektowej Rozszerzenie maski pasty lutowniczej. Po wybraniu tej opcji pole powiązanej wartości rozszerzenia zostanie wyłączone.
- Manual – wybierz tę opcję, aby zastąpić obowiązującą regułę projektową i określić wartość rozszerzenia maski pasty lutowniczej dla łuku w polu poniżej.
Rozszerzenie maski lutowniczej
- Rule – zaznacz to pole wyboru, aby rozszerzenie maski lutowniczej dla łuku było zgodne z wartością określoną w obowiązującej regule projektowej Rozszerzenie maski lutowniczej. Po wybraniu tej opcji pole powiązanej wartości rozszerzenia zostanie wyłączone.
- Manual – zaznacz to pole wyboru, aby zastąpić obowiązującą regułę projektową i określić wartość rozszerzenia maski lutowniczej dla łuku w polu poniżej.
Tworzenie obrysów zaznaczonych obiektów za pomocą ścieżek i łuków
Polecenie Tools » Outline Selected Objects z menu głównego umożliwia utworzenie obrysu ze ścieżek i łuków wokół zaznaczonych niezależnych obiektów podstawowych w projekcie. Ta funkcja może być szczególnie przydatna, jeśli chcesz elektrycznie odizolować krytyczne sieci, łącząc obrys z masą. Po uruchomieniu polecenia wokół obiektów zostanie utworzony obrys ze ścieżek i/lub łuków. Ścieżki i łuki obrysu są umieszczane z szerokością 8 mil, a właściwość Net jest ustawiana na No Net.
Uwzględniane są reguły projektowe dotyczące odstępów, szerokości i zwarć, więc naruszenia odstępów zostaną zgłoszone przez narzędzie do sprawdzania reguł projektowych.
Praca z prostokątami
Prostokąt można umieścić na dowolnej warstwie. Prostokąty o różnych rozmiarach można łączyć, aby pokryć obszary o nieregularnych kształtach, a także łączyć je z segmentami ścieżek lub łuków.
Prostokąty można również umieszczać na warstwach nieelektrycznych. Na przykład umieść prostokąt na warstwie Keep-Out, aby wyznaczyć obszar wykluczony z automatycznego trasowania. Umieść prostokąt na warstwie płaszczyzny zasilania, maski lutowniczej lub maski pasty lutowniczej, aby utworzyć wycięcie w tej warstwie.

Umieszczony prostokąt
Prostokąty można umieszczać zarówno w edytorze PCB, jak i w edytorze bibliotek PCB w następujący sposób:
- Edytor PCB — dostępne są następujące metody dostępu:
- Wybierz Place » Rectangle z menu głównego.
- Kliknij przycisk Rectangle w menu rozwijanym na Active Bar u góry obszaru projektowania. (Kliknij i przytrzymaj przycisk Active Bar, aby uzyskać dostęp do innych powiązanych poleceń. Po użyciu polecenia stanie się ono pierwszą pozycją w tej sekcji Active Bar.)
- Kliknij prawym przyciskiem myszy w obszarze projektowania, a następnie kliknij Place » Rectangle w menu kontekstowym.
-
Edytor bibliotek PCB — dostępne są następujące metody dostępu:
- Wybierz Place » Rectangle z menu głównego.
- Kliknij przycisk Rectangle w menu rozwijanym na Active Bar u góry obszaru projektowania. (Kliknij i przytrzymaj przycisk Active Bar, aby uzyskać dostęp do innych powiązanych poleceń. Po użyciu polecenia stanie się ono pierwszą pozycją w tej sekcji Active Bar.)
- Kliknij prawym przyciskiem myszy w obszarze projektowania, a następnie wybierz Place » Rectangle z menu kontekstowego.
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i przejdziesz do trybu umieszczania prostokątów. Aby umieścić prostokąt, wykonaj następujące czynności:
- Kliknij lub naciśnij Enter, aby ustalić położenie pierwszego narożnika prostokąta.
- Przesuń kursor, aby dostosować rozmiar prostokąta, a następnie kliknij lub naciśnij Enter, aby ustalić położenie narożnika po przekątnej i zakończyć umieszczanie prostokąta.
- Kontynuuj umieszczanie kolejnych prostokątów albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z trybu umieszczania.
Podczas umieszczania można wykonywać następujące dodatkowe czynności:
- Naciśnij klawisz Tab, aby wstrzymać umieszczanie i uzyskać dostęp do trybu Prostokąt w panelu Properties , w którym można na bieżąco zmieniać jego właściwości. Kliknij przycisk pauzy wyświetlany w obszarze projektowania , aby wznowić umieszczanie.
- Naciskaj spację , aby przełączać się między różnymi trybami narożników. Wybierz Rectangle dla narożników prostych, Fillet dla narożników zaokrąglonych lub Chamfer dla narożników ściętych.
- Naciskaj klawisze + i - (na klawiaturze numerycznej), aby przechodzić do przodu i do tyłu przez wszystkie widoczne warstwy projektu i szybko zmieniać warstwę umieszczania.
- Naciśnij i przytrzymaj klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, zależnie od początkowego kierunku ruchu.
Graficzna metoda edycji pozwala zaznaczyć umieszczony prostokąt bezpośrednio w obszarze projektowania i graficznie zmienić jego rozmiar, kształt lub położenie.
Po zaznaczeniu prostokąta dostępne są następujące uchwyty edycji.
Zaznaczony prostokąt
- Kliknij i przeciągnij narożniki (A), aby zmienić rozmiar prostokąta jednocześnie w kierunku pionowym i poziomym.
- Kliknij i przeciągnij środki boków (B), aby zmienić rozmiar prostokąta osobno w kierunku pionowym lub poziomym.
-
Kliknij dowolne miejsce prostokąta poza uchwytami edycji i przeciągnij go, aby zmienić jego położenie. Podczas przeciągania można obracać prostokąt lub tworzyć jego odbicie lustrzane:
- Naciśnij Spacebar, aby obrócić prostokąt w kierunku przeciwnym do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Obrót odbywa się zgodnie z wartością Rotation Step zdefiniowaną na stronie Edytor PCB – Ogólne w oknie dialogowym Preferences.
- Naciśnij klawisz X lub Y, aby utworzyć odbicie lustrzane prostokąta względem osi X lub Y.
Właściwości prostokąta

Tryb Rectangle panelu Properties.
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia prostokąta względem bieżącego początku układu współrzędnych obszaru projektowania. Edytuj to pole, aby zmienić położenie prostokąta w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych. Jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia prostokąta względem bieżącego początku układu współrzędnych. Edytuj to pole, aby zmienić położenie wypełnienia w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych. Jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Rotation — kąt obrotu prostokąta (w stopniach), mierzony przeciwnie do ruchu wskazówek zegara od położenia zerowego (pozioma oś 3 o'clock). Edytuj to pole, aby zmienić obrót prostokąta. Minimalna rozdzielczość kątowa wynosi 0,001°.
Właściwości
-
Corner Mode — użyj listy rozwijanej, aby wybrać tryb narożników prostokąta spośród następujących opcji:
- Rectangle — określa, że umieszczony prostokąt będzie miał proste narożniki.
- Fillet — określa, że umieszczony prostokąt będzie miał zaokrąglone narożniki.
- Chamfer — określa, że umieszczony prostokąt będzie miał ścięte narożniki.
- Track Width — wyświetla bieżącą szerokość ścieżki. Edytuj to pole, aby zmienić szerokość ścieżki w zakresie od 0,001 mil do 10000 mil.
- Fillet/Chamfer Size — opcja dostępna tylko wtedy, gdy z listy rozwijanej Corner Mode wybrano Fillet lub Chamfer albo gdy podczas umieszczania wybrano tryb zaokrąglania lub fazowania.
- Layer — warstwa, do której obecnie przypisany jest prostokąt. Prostokąty można przypisywać do dowolnej dostępnej warstwy. Użyj listy rozwijanej, aby wybrać inną warstwę.
- Width — wyświetla szerokość (w osi X) zaznaczonego prostokąta.
- Height — wyświetla wysokość (w osi Y) zaznaczonego prostokąta.
-
- kliknij tę ikonę, aby zachować dotychczasowe proporcje X do Y prostokąta.


