Designing for Printed Electronics
W skrócie
- Dowiedz się, czym jest elektronika drukowana, czym różni się od tradycyjnej produkcji PCB i dlaczego ma znaczenie dla przyszłości projektowania produktów.
- Zobacz, jak Altium Designer odwzorowuje elektronikę drukowaną za pomocą przebiegów drukowania, lokalnych obszarów nieprzewodzących, konfiguracji stosu warstw i definicji materiałów.
- Poznaj obecny proces projektowania i jego ograniczenia, w tym obsługę płaskich podłoży, generowanie standardowych danych wyjściowych oraz trasowanie ścieżek w projekcie elektroniki drukowanej.
Projektowanie elektroniki drukowanej
Ekscytującym kierunkiem rozwoju projektowania i wytwarzania produktów elektronicznych jest możliwość drukowania obwodu elektronicznego bezpośrednio na podłożu, takim jak wypraska z tworzywa sztucznego, która staje się częścią produktu.
Te slajdy przedstawiają widoki 2D i 3D przykładowego projektu elektroniki drukowanej. (Ilustracja dzięki uprzejmości „csi entwicklungstechnik”, przedstawiająca projekt wykorzystujący technologię TactoTek® In-Mold Structural Electronics). |
Ta technika realizacji obwodów na powierzchni jest określana jako Printed Electronics. Chociaż termin Printed Electronics nie opisuje precyzyjnie tej technologii, ponieważ drukowanie nie jest jedyną techniką wykorzystywaną do jej realizacji, jest on powszechnie przyjęty w branży i będzie używany na tej stronie.
Obecnie rozwijanych jest wiele metod wytwarzania elektroniki drukowanej, w tym: druk 3D z użyciem tuszów przewodzących; techniki tłoczenia umożliwiające tworzenie zarówno przewodników, jak i prostych elementów obwodu, takich jak tranzystory; oraz techniki osadzania laserowego, które pozwalają tworzyć ścieżki przewodzące w bardzo małej skali i z niezwykle wysoką precyzją.
Elektronika drukowana stanie się kluczową technologią, umożliwiającą integrację elektroniki z produktami na nowych rynkach. Pozwala ona ściśle powiązać obwód z produktem. Od elastycznego czujnika mocowanego bezpośrednio na ciele po wypraskę w kształcie opuszki palca z wieloma czujnikami, która pozwala dłoni robota trzymać miękki plastikowy kubek podczas nalewania do niego płynu — elektronika drukowana umożliwi opracowywanie innowacyjnych rozwiązań w wielu segmentach rynku.
Technologia
Pod względem what zapewnianych przez tę technologię zasada pozostaje taka sama — elementy elektroniczne są łączone za pomocą ścieżek przewodzących, tworząc obwód elektroniczny realizujący użyteczną funkcję. Różni się natomiast sposób budowania obwodu.
Technologia wytwarzania tradycyjnych płytek PCB, oparta na warstwach, to reductive process. Każda warstwa przewodząca ma początkowo postać ciągłego arkusza materiału przewodzącego, takiego jak miedź, który jest następnie wytrawiany tak, aby pozostała jedynie miedź tworząca wymagane ścieżki przewodzące. Jest to również proces wieloetapowy, ponieważ poszczególne warstwy przewodzące są łączone naprzemiennie z warstwami izolacji, a następnie poddawane różnym procesom wiercenia i metalizacji.
Elektronika drukowana to additive process, a ścieżki sygnałowe są drukowane bezpośrednio na podłożu. Jeśli kolejna ścieżka sygnałowa musi przecinać istniejącą ścieżkę, w wymaganym miejscu drukowany jest niewielki fragment izolacji. Działa on jak miniaturowy mostek, umożliwiając nadrukowanie nowej ścieżki sygnałowej nad istniejącą bez ich elektrycznego połączenia. Na przykład w projekcie wykorzystującym technologię DuPont InMold obwód jest najpierw drukowany na płaskim podłożu z tworzywa sztucznego, które następnie jest poddawane termoformowaniu i formowaniu wtryskowemu w celu uzyskania ostatecznego kształtu produktu.
Dzięki elektronice drukowanej tradycyjne sztywne podłoże płytki drukowanej z włókna szklanego nie jest już potrzebne. Zamiast tego obwód powstaje bezpośrednio jako część produktu, a przewodniki ostatecznie odwzorowują kształt i kontury jego powierzchni. Ze względu na mniejsze zużycie materiałów i mniejszą ilość odpadów elektronika drukowana w wielu przypadkach stanie się bardziej opłacalnym rozwiązaniem niż tradycyjna płytka PCB.
Projektowanie elektroniki drukowanej w Altium Designer
Poza podłożem, na którym drukowany jest projekt, produkt wykonany w technologii elektroniki drukowanej nie ma fizycznych warstw — ścieżki przewodzące są drukowane bezpośrednio na podłożu. Tam, gdzie projekt wymaga krzyżowania się ścieżek, drukowany jest niewielki fragment materiału dielektrycznego, wychodzący poza obszar skrzyżowania na tyle, aby zapewnić wymagany poziom izolacji pomiędzy poszczególnymi sygnałami.
Pliki wyjściowe wymagane do sterowania procesem drukowania są generowane w standardowym formacie wyjściowym, takim jak Gerber.
Dane wyjściowe będą zawierać osobny plik dla:
- Każdego przebiegu drukowania materiału przewodzącego — zasadniczo odpowiada on warstwie miedzi ze ścieżkami w tradycyjnej płytce PCB.
- Każdego przebiegu drukowania dielektryka — ponieważ fragmenty dielektryka są drukowane, ich kształty są również określane w pliku wyjściowym, takim jak plik Gerber.
Definiowanie stosu warstw
Jak zatem zdefiniować te liczne przebiegi drukowania w edytorze PCB? W elektronice drukowanej każdy przebieg drukowania wymaga pliku wyjściowego, dlatego zamiast myśleć o szeregu warstw miedzi oddzielonych warstwami dielektryka, należy traktować je jako zestaw przebiegów drukowania, z których każdy tworzy warstwę tuszu przewodzącego albo nieprzewodzącego.
Aby utworzyć projekt elektroniki drukowanej, najpierw utwórz nową płytkę PCB, wybierając File » New » PCB z menu głównego.
Konfigurowanie nowej płytki jako projektu elektroniki drukowanej odbywa się w Menedżerze stosu warstw. Wybierz Design » Layer Stack Manager z menu głównego, aby otworzyć Layer Stack Manager. Użyj listy rozwijanej
, a następnie wybierz Printed Electronics lub wybierz Tools » Features » Printed Electronics z menu głównego.
Nowa płytka PCB domyślnie ma dwie warstwy miedzi oddzielone warstwą dielektryka.
Po włączeniu funkcji Printed Electronics warstwa dielektryka pomiędzy dwiema warstwami miedzi znika. Dlaczego? Ponieważ elektronika drukowana wymaga pliku wyjściowego dla każdej warstwy, a warstwy dielektryka nie są używane do generowania plików wyjściowych, więc nie są stosowane.
Po włączeniu funkcji Printed Electronics warstwa dielektryka zostaje usunięta.
Zamiast niej dodawane są warstwy nieprzewodzące. Na tych warstwach można ręcznie lub automatycznie definiować kształty dielektryczne, zwane łatkami, wszędzie tam, gdzie ścieżki sygnałowe na warstwach przewodzących muszą się krzyżować.

Non-Conductive można wstawiać pomiędzy warstwy Conductive i definiować na nich łatki dielektryczne.
Kliknij warstwę prawym przyciskiem myszy, aby wstawić warstwę powyżej lub poniżej, przenieść warstwę w górę lub w dół albo usunąć warstwę. W elektronice drukowanej nie używa się warstw dolnej maski lutowniczej ani dolnego nadruku; zostały one usunięte.
Po dodaniu warstw ustaw właściwości materiału dla każdej z nich.
Użyj przycisku z wielokropkiem, aby wybrać materiał dla każdej drukowanej warstwy.
Wybór materiału
Materiały używane zarówno w tradycyjnych projektach PCB, jak i w projektach elektroniki drukowanej wybiera się w bibliotece materiałów Menedżera stosu warstw.
Gdy Menedżer stosu warstw jest otwarty, użyj polecenia Tools » Material Library, aby otworzyć okno dialogowe Altium Material Library.
- Okno dialogowe Altium Material Library zawiera materiały zarówno dla warstw przewodzących, jak i nieprzewodzących.
- W bibliotece można definiować nowe materiały — kliknij przycisk New u dołu okna dialogowego. Materiały zdefiniowane przez użytkownika można zapisywać w bibliotece materiałów użytkownika i z niej wczytywać.
- Aby wybrać materiał dla określonej warstwy, kliknij przycisk wielokropka w komórce Material tej warstwy w menedżerze stosu warstw. Otworzy się okno dialogowe Select Material, wyświetlające wyłącznie materiały odpowiednie dla danego typu warstwy. Wybierz wymagany materiał i kliknij OK.
Panel właściwości
Gdy w dokumencie stosu warstw aktywna jest karta Printed Electronics Stackup, panel Properties umożliwia edycję i konfigurację właściwości warstw w stosie warstw projektu elektroniki drukowanej.
-
Layer
- Name – nazwa warstwy.
- Manufacturer – producent warstwy.
-
Material – materiał warstwy. Może być wstępnie zdefiniowany w oknie dialogowym Altium Material Library (Tools » Material Library) w polu Constructions lub zdefiniowany przez użytkownika w stosie warstw. Kliknij
, aby otworzyć okno dialogowe Select Material i wybrać żądany materiał dla aktualnie zaznaczonej warstwy w stosie warstw.
- Thickness – grubość warstwy sygnałowej.
- Dk – stała dielektryczna (w elektromagnetyzmie oznaczana również jako εr). Określa względną przenikalność elektryczną materiału izolacyjnego, czyli jego zdolność do magazynowania energii elektrycznej w polu elektrycznym. Do celów izolacyjnych lepszy jest materiał o niższej stałej dielektrycznej, natomiast w zastosowaniach RF pożądana może być wyższa stała dielektryczna. Ponadto im niższa względna stała dielektryczna, tym bardziej właściwości materiału są zbliżone do właściwości powietrza. Parametr ten ma kluczowe znaczenie dla spełnienia wymagań dotyczących impedancji określonych linii transmisyjnych.
- Df – współczynnik strat dielektrycznych. Określa skuteczność materiału izolacyjnego, wskazując tempo utraty energii dla określonego rodzaju drgań, np. mechanicznych, elektrycznych lub elektromechanicznych. Innymi słowy, jest to właściwość materiału opisująca, jaka część przesyłanej energii jest przez niego pochłaniana. Im większy tangens kąta strat, tym większe pochłanianie energii przez materiał. Właściwość ta bezpośrednio wpływa na tłumienie sygnałów o dużej szybkości.
- Frequency – częstotliwość, przy której badany jest materiał i której odpowiadają wartości Dk / Df. Częstotliwość jest również pobierana z danych referencyjnych materiału.
- Description – wprowadź opis zawierający istotne informacje.
- Color – wymagany kolor maski lutowniczej. Kliknij, aby otworzyć listę rozwijaną i ustawić lub zmienić kolor.
- Solid – nie dotyczy
- Material Frequency – nie dotyczy
- GlassTransTemp – temperatura zeszklenia (znana również jako TG), czyli temperatura, przy której żywica przechodzi ze stanu szklistego w stan amorficzny, zmieniając swoje właściwości mechaniczne, np. współczynnik rozszerzalności.
- Note – wprowadź wszelkie istotne uwagi dotyczące warstwy.
- Comment – wprowadź wszelkie niezbędne komentarze dotyczące warstwy.
-
Board
- Library Compliance – po włączeniu tej opcji bieżące właściwości każdej warstwy, dla której wybrano materiał z biblioteki materiałów, są porównywane z wartościami w definicji tego materiału w bibliotece.
- Layers – liczba warstw przewodzących.
- Dielectrics – liczba warstw dielektrycznych.
- Conductive Thickness – suma grubości wszystkich warstw sygnałowych i płaszczyzn (wszystkich warstw miedzianych lub przewodzących).
- Dielectric Thickness – grubość warstw dielektrycznych.
- Total Thickness – całkowita grubość gotowej płytki.
- Other
Roughness – pokazuje chropowatość warstw przewodzących.
- Model Type – preferowany model obliczania wpływu chropowatości powierzchni (więcej informacji o poszczególnych modelach można znaleźć w artykułach poniżej). Dotyczy wszystkich warstw miedzianych w stosie.
- Surface Roughness – wartość chropowatości powierzchni (dostępna u producenta). Wprowadź wartość od 0 do 10 µm; wartość domyślna wynosi 0,1 µm.
- Roughness Factor – określa oczekiwany maksymalny wzrost strat w przewodniku spowodowany chropowatością. Wprowadź wartość od 1 do 100; wartość domyślna wynosi 2.
Prowadzenie połączeń sieci
- Połączenia sieci w projekcie elektroniki drukowanej prowadzi się tak samo jak na tradycyjnej płytce PCB, za pomocą polecenia Interactive Routing.
- Przejścia między warstwami przewodzącymi wykonuje się za pomocą klawiszy + i - na klawiaturze numerycznej lub skrótu Ctrl+Shift+Wheelroll.
- Podczas zmiany warstwy w trakcie prowadzenia ścieżki dodawana jest przelotka, której właściwości określa obowiązująca reguła projektowa Routing Via Style.
Czy przelotki są potrzebne?
Oprogramowanie musi umieścić przelotkę, aby zachować ciągłość połączeń sieci podczas prowadzenia ścieżek, a także zarządzać połączeniami, gdy przebieg ścieżek jest modyfikowany przez ich rozpychanie lub przeciąganie. Przelotki nie są potrzebne do łączenia warstw — oprogramowanie zakłada, że nakładające się ścieżki na różnych warstwach są połączone.
Zwiększanie grubości ścieżki
W razie potrzeby można zwiększyć grubość ścieżki, na przykład w celu wykonania struktury takiej jak antena drukowana. W tym celu umieszcza się wiele ścieżek jedna nad drugą, na różnych warstwach przewodzących.
Dodawanie kształtów dielektrycznych
Po poprowadzeniu połączeń sieci kolejnym krokiem jest utworzenie obszarów dielektrycznych niezbędnych do odizolowania skrzyżowań ścieżek należących do różnych sieci. Kształty dielektryczne definiuje się na warstwach nieprzewodzących. Można je definiować ręcznie lub tworzyć automatycznie za pomocą Dielectric Shapes Generator.
Generator kształtów dielektrycznych
Oprogramowanie zawiera również automatyczny Dielectric Shapes Generator. Jego działanie opiera się na tym, że najpierw należy poprowadzić wszystkie wymagane ścieżki na warstwach przewodzących, umieszczając przelotki w miejscach przejścia między warstwami.
Po zakończeniu prowadzenia ścieżek uruchom polecenie Tools » Printed Electronics » Generate Dielectric Patterns, aby otworzyć okno dialogowe Dielectric Shapes Generator. Po uruchomieniu generator kształtów dielektrycznych usunie wszystkie kształty na warstwach docelowych, a następnie utworzy je ponownie. Jeśli jakieś kształty zostały zdefiniowane ręcznie, zablokuj je przed uruchomieniem Dielectric Shapes Generator.
Opcje i elementy sterujące okna dialogowego generatora kształtów dielektrycznych
-
Mode - wybierz żądany tryb:
- Generate - wybierz, aby wygenerować nowe obszary dielektryczne dla wszystkich włączonych warstw wskazanych w sekcji Layers .
- Remove - wybierz, aby przed dodaniem własnych kształtów generator usunął wszystkie istniejące kształty wykryte na warstwach wskazanych w sekcji Layers .
-
Layers - generator zidentyfikuje wszystkie skrzyżowania i doda obszary dielektryczne zgodnie z ustawieniami w tej sekcji okna dialogowego.
- Select Dielectric Layer - użyj listy rozwijanej, aby wybrać warstwę dielektryczną. Jeśli wybrano All , generator wyszukuje skrzyżowania na dowolnej parze warstw przewodzących i umieszcza obszar izolacyjny na warstwie dielektrycznej znajdującej się między tymi dwiema warstwami przewodzącymi. Jeśli nie wybrano żadnej warstwy dielektrycznej, obszary dielektryczne zostaną utworzone dla wszystkich skrzyżowań między wszystkimi warstwami na odpowiednich warstwach dielektrycznych. Użyj Layer(s) Above i Layer(s) Below , aby wybrać dwie warstwy przewodzące, między którymi generator ma wyszukiwać skrzyżowania. Jeśli znajdzie obiekt na Layer(s) Above, który krzyżuje się z obiektem na Layer(s) Below, wygeneruje obszar izolacyjny między nimi i umieści go na warstwie określonej w sekcji Select Dielectric Layer . Opcje Layer(s) Above i Layer(s) Below są niedostępne, jeśli w sekcji Mode wybrano Remove .
-
Dielectric Shape Expansion
- Auto - w tym trybie obszar dielektryczny jest automatycznie powiększany, aby spełnić wymagania odpowiedniej reguły projektowej dotyczącej minimalnego odstępu (Clearance Constraint).
- Manual - w tym trybie generator tworzy obszar odpowiadający kształtowi wyznaczonemu przez krzyżujące się obiekty, a następnie powiększa go o podaną odległość. Na przykład w tym trybie, jeśli dwie ścieżki na różnych warstwach znajdują się zbyt blisko siebie i naruszają wymagany odstęp, obszar izolacyjny nie zostanie umieszczony.
- Fill Gaps between dielectrics less than <xx> - podaj wartość, jeśli chcesz wypełnić przerwy między obszarami dielektrycznymi mniejsze niż określona wartość. Można to wykorzystać do łączenia sąsiadujących obszarów dielektrycznych w większe obszary.
Łączność sieci i sprawdzanie reguł projektowych
Sprawdzanie DRC w trybie online nie jest obsługiwane, gdy stos warstw jest skonfigurowany dla elektroniki drukowanej, ze względu na odmienną logikę określania warunków naruszeń — na przykład krzyżujące się sieci na różnych warstwach są oznaczane jako zwarcie. Po zakończeniu trasowania i zdefiniowaniu obszarów izolacyjnych kliknij przycisk Run Design Rule Check w oknie dialogowym Design Rule Checker (Tools » Design Rule Check), aby uruchomić wsadowe sprawdzanie DRC.
Uwagi dotyczące łączności sieci i sprawdzania reguł projektowych:
- Gdy sieć musi przejść na inną warstwę przewodzącą, wstaw przelotkę. Zapewni to prawidłową obsługę segmentów ścieżek podczas przeciągania lub rozpychania tras.
- Stykające się lub krzyżujące się ścieżki na różnych warstwach są uznawane za połączone. Jeśli należą do tej samej sieci, nie jest zgłaszane przerwanie sieci; jeśli należą do różnych sieci, zgłaszane jest zwarcie.
- Do odizolowania stykających się lub krzyżujących się ścieżek wymagany jest obszar dielektryczny umieszczony na warstwie nieprzewodzącej. Obszar dielektryczny można umieścić ręcznie lub za pomocą Dielectric Shape Generator. Musi on wystawać poza krawędzie krzyżujących się ścieżek na tyle, aby spełnić wymagania odpowiedniej reguły projektowej dotyczącej minimalnego odstępu.
- W projektach elektroniki drukowanej sprawdzanie reguł projektowych pod kątem zwarć, naruszeń odstępów i niepoprowadzonych sieci działa w sposób opisany poniżej.
Reguła projektowa dotycząca zwarć
W projekcie elektroniki drukowanej skrzyżowania różnych sieci na różnych warstwach są oznaczane jako zwarcia. Skrzyżowania te izoluje się przez umieszczenie obszaru dielektrycznego na warstwie nieprzewodzącej.
Reguła projektowa dotycząca odstępów
Odstępy między sieciami są sprawdzane na wszystkich warstwach, a nie tylko w obrębie tej samej warstwy.
Niepoprowadzona sieć
Przejścia między warstwami nie wymagają przelotki — analizator sieci rozpozna, że sieć nie jest przerwana.





