Planowanie obszarów sztywnych i elastycznych — tryb zaawansowany

W skrócie

W tym artykule wyjaśniamy, jak planować i rozmieszczać sztywne oraz elastyczne obszary płytki w Altium Designer w zaawansowanym trybie projektowania sztywno-elastycznego (Advanced Rigid-Flex). Porównujemy go również z trybem standardowym, aby ułatwić zrozumienie, kiedy potrzebny jest zaawansowany sposób pracy. Omawiamy definiowanie obszarów płytki, sprawdzanie, z którego trybu projektowania sztywno-elastycznego korzysta dana płytka PCB, pracę w trybie planowania płytki (Board Planning Mode), a także precyzyjne umieszczanie i edytowanie obszarów, nadawanie im nazw oraz przypisywanie stosów warstw. Zwracamy też uwagę na najważniejsze zasady umieszczania obszarów, skróty i właściwości, które mają znaczenie podczas projektowania bardziej złożonych płytek sztywno-elastycznych. Jeśli szukasz praktycznego przewodnika, który pomoże Ci pewniej konfigurować zaawansowane obszary płytki sztywno-elastycznej i nimi zarządzać, czytaj dalej.

- Poznasz różnice między standardowym trybem projektowania sztywno-elastycznego (Standard Rigid-Flex) a trybem zaawansowanym (Advanced Rigid-Flex) oraz dowiesz się, jak wpływają one na sposób tworzenia i definiowania obszarów płytki.
- Zobaczysz, jak umieszczać i edytować obszary płytki (Board Regions) w trybie planowania płytki (Board Planning Mode), w tym nadawać im nazwy, przypisywać stosy warstw oraz korzystać z prowadnic i przyciągania, aby zapewnić precyzję.
- Poznasz przydatne skróty, tryby umieszczania i ustawienia właściwości, które usprawniają pracę nad złożonymi projektami sztywno-elastycznych płytek PCB.
Zagłęb się w temat dzięki AI:

W oprogramowaniu Altium do projektowania PCB dostępne są dwa tryby projektowania sztywno-giętkiego. Oryginalny, czyli standardowy tryb, określany jako Rigid-Flex, obsługuje proste projekty sztywno-giętkie. Jeśli projekt ma bardziej złożone wymagania, takie jak nakładające się obszary giętkie, należy użyć trybu Advanced Rigid-Flex (znanego również jako rigid-flex 2.0). Tryb wybiera się w menu Tools w menedżerze stosu warstw.

Podstawowa różnica między tymi trybami polega na tym, że w trybie oryginalnym kształt płytki jest dzielony na oddzielne obszary przez umieszczenie linii podziału, która pozostaje obiektem określającym, gdzie kończy się jeden obszar płytki, a zaczyna drugi. W trybie zaawansowanym każdy obszar płytki jest umieszczany osobno, a przecięcie większego obszaru powoduje utworzenie dwóch oddzielnych obiektów obszaru. W trybie zaawansowanym o miejscu styku dwóch sąsiadujących obszarów płytki decydują ich krawędzie, a nie obecność linii podziału. Z tego powodu w trybie Advanced Rigid-Flex nie występuje obiekt linii podziału.

► Dowiedz się więcej o projektowaniu sztywno-giętkiej płytki PCB

Menu View udostępnia trzy tryby pracy edytora PCB z łatwymi do zapamiętania skrótami, które umożliwiają szybkie przełączanie między nimi:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Domyślnie podczas przełączania między widokami 2D i 3D zachowywane są osobne ustawienia powiększenia i orientacji dla każdego trybu widoku. Aby podczas przełączania zachować tę samą lokalizację i orientację płytki, naciśnij Ctrl+Alt+2 lub Ctrl+Alt+3 zamiast 2 lub 3.

Właśnie otwarto płytkę PCB i zastanawiasz się, czy używa ona standardowego, czy zaawansowanego trybu sztywno-giętkiego?

Możesz to sprawdzić, otwierając menedżer stosu warstw. Możesz też przełączyć się do trybu planowania płytki (skrót 1) i przyjrzeć się aktywnemu paskowi:

Standardowy tryb Rigid-Flex
Tryb Advanced Rigid-Flex

Umieszczanie obszaru płytki

Obszar płytki jest obiektem wielokątnym umieszczanym przy użyciu standardowych technik umieszczania obiektów wielokątnych. Kształt płytki musi być precyzyjnie zdefiniowany, dlatego ważne jest, aby tworzące ją obszary były utworzone dokładnie zgodnie z wymaganiami. Poniższy film przedstawia tworzenie obszarów płytki przez wyrównywanie ich krawędzi do wcześniej umieszczonych prowadnic przestrzeni projektowej. Zaletą tej techniki jest możliwość precyzyjnego określenia położenia prowadnic przez edycję ich współrzędnych w panelu Properties.

Wstępnie zdefiniowane prowadnice obszaru roboczego służą jako odniesienie podczas umieszczania obszarów płytki.

Obszary płytki umieszcza się i modyfikuje w Board Planning Mode:

  1. Wybierz View » Board Planning Mode (lub użyj skrótu 1), aby przejść do Board Planning Mode. Domyślny istniejący obszar płytki zostanie wyświetlony jako zielony prostokąt.
  2. Wybierz Place » Board Region, aby umieścić nowy obszar (lub kliknij przycisk na Active Bar).
  3. Ustaw kursor i kliknij, aby ustalić położenie początkowego wierzchołka obszaru płytki. Obszar płytki jest obiektem wielokątnym, podobnie jak obszar lub wielokąt, i jest umieszczany (oraz edytowany) w taki sam sposób.
  4. Przesuń kursor, aby umieścić drugi wierzchołek. Domyślnie każde kliknięcie powoduje umieszczenie dwóch krawędzi z narożnikiem o kształcie określonym przez użytkownika pomiędzy nimi. Naciśnij Spacebar, aby przełączyć kierunek narożnika. Więcej informacji o zmianie trybów narożników znajdziesz w sekcji Placement Modes poniżej.
  5. Kontynuuj przesuwanie myszy i klikaj, aby umieszczać wierzchołki, tworząc krawędzie potrzebne do zdefiniowania ogólnego kształtu obszaru płytki.
  6. Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zamknąć i zakończyć definiowanie kształtu płytki. Nie trzeba ręcznie zamykać kształtu płytki — oprogramowanie zrobi to automatycznie, łącząc ostatni umieszczony punkt z punktem początkowym.
  7. Każdy obszar płytki ma nazwę, która jednoznacznie go identyfikuje. Wprowadź odpowiednią nazwę w polu Name w trybie obszaru płytki panelu właściwości (aby wyświetlić właściwości obszaru płytki w panelu, należy zaznaczyć go w przestrzeni projektowej).
  8. Każdy obszar płytki musi mieć przypisany stos warstw. Nowo utworzonemu obszarowi płytki zostaje przypisany domyślny stos warstw o nazwie Board Layer Stack. Przypisz wymagany stos warstw w trybie Board Region panelu Properties. Stosy warstw definiuje się i nadaje im nazwy w menedżerze stosu warstw.
  9. Jeśli docelowa płytka PCB wymaga wielu obszarów płytki, kontynuuj definiowanie kolejnych obszarów.
  • Każdy obszar ma etykietę zawierającą jego nazwę oraz nazwę przypisanego do niego stosu warstw w formacie Region Name - Layer Stack Name. Nazwę obszaru płytki nadaje się w trybie Board Region panelu Properties, a nazwę stosu warstw — w menedżerze stosu warstw.
  • Można umieścić dowolną liczbę obszarów płytki, aby uzyskać wymagany kształt płytki. Obszary płytki mogą się nakładać. Należy pamiętać, że nie określa to odległości, na jaką jeden obszar wchodzi w sąsiedni — parametr ten definiuje się w konfiguracji stosu warstw w menedżerze stosu warstw.
  • Obszar płytki jest obiektem wielokątnym. Aby zmodyfikować jego kształt, kliknij go raz, aby go zaznaczyć, a następnie kliknij i przeciągnij krawędź lub uchwyt edycji. Dowiedz się więcej o edycji obiektu wielokątnego. Pamiętaj, że w trybie zaawansowanym obszary płytki są edytowane interaktywnie, dlatego w menu Design w trybie planowania płytki nie ma już poleceń edycji.
  • Aby usunąć obszar płytki, zaznacz go, a następnie naciśnij klawisz Delete na klawiaturze. Zawsze musi istnieć co najmniej jeden obszar płytki, dlatego nie można usunąć ostatniego.
  • Obszary płytki można nie tylko rysować, lecz także tworzyć z obiektów podstawowych — więcej informacji znajdziesz w sekcji Konwersja między podstawowymi obiektami rysunkowymi 2D a obiektami definiującymi płytkę na tej stronie.
  • Podczas umieszczania lub edycji obszaru płytki ruch kursora jest ograniczany przez ustawienia przyciągania, które obejmują: bieżącą siatkę przyciągania, dostępne obiekty przyciągania, obecność prowadnic obszaru roboczego oraz ustawienia przyciągania do osi. Skorzystaj z tych funkcji, aby uzyskać wymagany kształt.

    ► Dowiedz się więcej o zasadach działania przyciągania.

Dodatkowo możesz nacisnąć klawisz Tab, aby wstrzymać umieszczanie i uzyskać dostęp do trybu obszaru płytki w Properties panelu, w którym można na bieżąco zmieniać jego właściwości. Aby wznowić umieszczanie, kliknij przycisk pauzy wyświetlany nad przestrzenią projektową ().

Placement Modes

Podczas ponownego definiowania kształtu płytki dostępnych jest pięć trybów narożników, z których cztery mają również podtryby kierunku narożnika. Podczas ponownego definiowania:

  • Naciskaj Shift+Spacebar, aby przełączać kolejno pięć dostępnych trybów narożników.
  • Naciśnij Spacebar, aby przełączyć między dwoma podtrybami kierunku narożnika.
  • W jednym z trybów narożników łukowych przytrzymaj  klawisz, aby zmniejszyć łuk, lub klawisz , aby go powiększyć. Przytrzymaj klawisz Shift podczas naciskania, aby przyspieszyć zmianę rozmiaru łuku.
  • Naciśnij klawisz skrótu 1, aby przełączać się między umieszczaniem dwóch krawędzi a jednej krawędzi na kliknięcie. W drugim trybie krawędź przerywana jest nazywana segmentem wyprzedzającym (jak pokazano na ostatnim obrazie w poniższym zestawie).
  • Naciśnij klawisz Backspace, aby usunąć ostatni wierzchołek.

Naciśnij Shift+Spacebar, aby przełączać się między pięcioma dostępnymi trybami narożników. Naciśnij klawisz skrótu 1, aby przełączać się między umieszczaniem dwóch krawędzi a jednej krawędzi. 
 
 
Naciśnij Shift+Spacebar, aby przełączać się między pięcioma dostępnymi trybami narożników. Naciśnij klawisz skrótu 1, aby przełączać się między umieszczaniem dwóch krawędzi a jednej krawędzi.

Tworzenie obszaru płytki z bryły 3D

Obszary płytki można również tworzyć z obiektów brył 3D za pomocą polecenia Create Board Region from 3D Body w trybie 3D. Procedura jest następująca:

  1. Upewnij się, że płytka jest wyświetlana w widoku 3D (jeśli nie, użyj skrótu klawiaturowego 3, aby szybko przełączyć się do tego trybu).
  2. Wybierz polecenie Design » Board Shape » Create Board Region from 3D body z menu głównego.
  3. Umieść kursor nad modelem 3D, którego chcesz użyć do utworzenia obszaru płytki PCB, i kliknij lub naciśnij Enter. Model stanie się przezroczysty.
  4. Przesuwaj kursor nad modelem 3D, aby znaleźć odpowiednią ścianę. Gdy pod kursorem znajdzie się płaska powierzchnia, stanie się ona nieprzezroczysta i zostanie otoczona cienkim niebieskim obramowaniem.
  5. Po znalezieniu odpowiedniej ściany kliknij lub naciśnij Enter — zostanie utworzony nowy obszar płytki (zastępujący wcześniej zdefiniowany obszar płytki w przestrzeni projektowej).
  6. Pojawi się okno dialogowe Board Outline Creation Successful potwierdzające pomyślne utworzenie obszaru. W tym oknie można ukryć część modelu i wyłączyć ją ze sprawdzania DRC. Dostępne są również opcje zmiany wysokości modelu w celu wyrównania ściany z górną lub dolną powierzchnią albo pozostawienia położenia bez zmian.
Aby zdefiniować obszar płytki, obrys wybranej ściany musi być wyrównany z płytką PCB. 

Tworzenie obszaru wycięcia w płytce

Aby utworzyć wewnętrzne wycięcie w płytce, umieść obszar wycięcia w płytce (Place » Define Board Cutout lub kliknij przycisk na Active Bar). Wycięcie w płytce również jest obiektem wielokątnym, więc proces jego umieszczania jest taki sam jak w przypadku obszaru płytki. Poniższe obrazy przedstawiają obszar płytki z dwoma wycięciami, które po wyprodukowaniu płytki staną się otworami.

Wycięcie umieszczone w obszarze płytki staje się otworem w gotowej płytce. Wycięcie umieszczone w obszarze płytki staje się otworem w gotowej płytce.

Dzielenie obrysu płytki na obszary

Istniejący obszar płytki można podzielić na dwa obszary przez jego przecięcie. Operację tę wykonuje się, gdy edytor PCB znajduje się w trybie Board Planning Mode.

Płytka została podzielona na trzy obszary płytki za pomocą polecenia Slice Region.

Aby podzielić obszar płytki:

  1. Wybierz View » Board Planning Mode (lub naciśnij skrót 1), aby przejść do Board Planning Mode.
  2. Wybierz Design » Slice Board Region (lub kliknij przycisk  na pasku Active Bar), aby przejść do trybu Slice Board Region.
  3. Po wybraniu polecenia zostaje włączony tryb podziału, podobny do trybu umieszczania ścieżek. Zaczynając poza obszarem przeznaczonym do podziału, klikaj, aby umieszczać kolejne wierzchołki definiujące linię podziału. Podczas definiowania podziału naciskaj Shift+Spacebar, aby przełączać tryby narożników; naciskaj Spacebar, aby przełączać między początkowym i końcowym trybem narożnika, a klawiszem Backspace usuwaj ostatnio umieszczony narożnik. Umieść koniec linii podziału poza krawędzią obszaru płytki. Po zakończeniu definiowania podziału kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć polecenie.
  4. Zostanie otwarte okno dialogowe z informacją o liczbie wielokątów (obszarów), które zostaną podzielone, oraz liczbie wielokątów (obszarów), które zostaną utworzone. Kliknij Yes, aby potwierdzić ich utworzenie.

Każdy nowo utworzony obszar może odziedziczyć jeden lub więcej komponentów znajdujących się w pierwotnym obszarze. Jeśli komponenty te należą do klasy komponentów, dla każdego nowego obszaru zostanie utworzona nowa klasa, a przynależność komponentów zostanie odpowiednio zaktualizowana.

Tworzenie obszarów płytki na podstawie zaznaczonych obiektów

W zależności od kształtu płytki wygodniejsze może być zbudowanie jej kształtu przez utworzenie wielu obszarów płytki. Jak wspomniano powyżej, obszary można umieszczać interaktywnie lub tworzyć przez odwzorowanie obrysu zdefiniowanego za pomocą ścieżek i łuków. Poniższy film przedstawia definiowanie trzech obszarów płytki na podstawie zaznaczonych obiektów. Na filmie widać, że ten sam obiekt służy do definiowania przylegających krawędzi w miejscach styku obszarów, co zapewnia ich dokładne pozycjonowanie.

Popularną metodą jest zdefiniowanie obrysów obszarów za pomocą ścieżek i łuków, a następnie utworzenie obszarów płytki na podstawie zaznaczonych obrysów.

Konwersja między podstawowymi obiektami rysunkowymi 2D a obiektami definiującymi płytkę

Popularną metodą definiowania kształtu płytki oraz potrzebnych w nim obszarów płytki jest zaimportowanie rysunku z mechanicznego programu CAD. Można na przykład zaimportować rysunek mechaniczny z pliku DWG, uzyskując zestaw linii (ścieżek) na warstwie mechanicznej, które definiują: kształt płytki, obszary w obrębie tego kształtu, a w przypadku projektu sztywno-elastycznego — linie określające położenie linii zgięcia w obszarach elastycznych.

Oprogramowanie udostępnia szereg poleceń ułatwiających tworzenie obiektów definiujących płytkę (obszar, wycięcie, linia zgięcia) na podstawie podstawowych obiektów rysunkowych 2D, a także odpowiadające im polecenia konwersji obiektów definiujących płytkę z powrotem na podstawowe obiekty rysunkowe.

Obiekt Z zaznaczonych podstawowych obiektów rysunkowych 2D Z obiektów projektu płytki
Obszar płytki Create Board Region from Selected Objects
(podmenu Design » Board Shape)
Explode Region to Free Primitives
Wycięcie w płytce Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Linia zgięcia Convert Selected Line to Bend Line Explode Bend Line

Uwagi:

  • Polecenia konwersji w obu kierunkach są dostępne w podmenu Tools » Convert odpowiedniego trybu View (z wyjątkiem polecenia Create Board Region from Selected Objects, które znajduje się w podmenu Design » Board Shape).
  • Aby przekonwertować podstawowe obiekty rysunkowe 2D na obiekty definiujące płytkę, przełącz widok na 2D Layout Mode.
    • Przed uruchomieniem polecenia należy zaznaczyć obiekty podstawowe.
    • Aby utworzyć obszar lub wycięcie, obiekty podstawowe muszą tworzyć zamknięty kształt. Więcej informacji o wymaganiach dotyczących tego kształtu znajduje się w poniższej ramce z ostrzeżeniem.
  • Aby przekonwertować obiekty definiujące płytkę na obiekty rysunkowe 2D, przełącz widok na Board Planning Mode.
    • Polecenia te nie wymagają wcześniejszego zaznaczenia obiektów, ale jeśli obiekt jest już zaznaczony, zostaną zastosowane do niego.
    • Jeśli istnieje wiele obszarów płytki, obszar znika po rozbiciu go na obiekty podstawowe. Jeśli istnieje tylko jeden obszar płytki, obiekty podstawowe zostaną utworzone, a wybrany obszar płytki pozostanie (zawsze musi istnieć co najmniej jeden obszar płytki).
    • Obiekty rysunkowe 2D są tworzone na warstwie mechanicznej typu Board Shape. Jeśli na płytce nie ma warstwy tego typu, zostanie dodana warstwa mechaniczna z typem warstwy ustawionym na Board Shape. Dowiedz się więcej o warstwach mechanicznych i typach warstw.
    • Choć nie ma osobnego polecenia ponownego grupowania rozbitego obiektu, można w tym celu użyć polecenia Undo.
Wszystkie polecenia tworzące kształt wielokątny na podstawie obrysu zbudowanego z linii (ścieżek) i łuków próbują rozpoznać kształt, podążając wzdłuż osi zaznaczonych obiektów. Jeśli współrzędne końca jednego segmentu ścieżki lub łuku nie pokrywają się dokładnie ze współrzędnymi początku następnego segmentu, algorytm identyfikacji granicy nie zadziała i zostanie wyświetlony komunikat wskazujący miejsce problemu. Następnie program zaproponuje użycie algorytmu śledzenia obrysu. Należy pamiętać, że algorytm ten podąża wzdłuż zewnętrznych krawędzi ścieżek i łuków, więc uzyskany kształt będzie nieco inny niż kształt utworzony na podstawie ich osi. Wybierz tę opcję tylko wtedy, gdy projekt dopuszcza skutki tej różnicy.

Modyfikowanie obszarów płytki

W standardowym trybie sztywno-elastycznym miejsce styku dwóch sąsiadujących obszarów płytki określała ruchoma niebieska linia podziału. W zaawansowanym trybie sztywno-elastycznym to rozwiązanie nie jest stosowane — każdy obszar jest osobnym, zamkniętym wielokątem. Dzięki temu każdy obszar można dowolnie dostosowywać za pomocą standardowych technik edycji kształtów wielokątnych. Należy pamiętać, że nie wszystkie polecenia edycji wielokątów są dostępne podczas modyfikowania obszaru płytki; dotyczy to między innymi poleceń dodawania i odejmowania wielokątów.

Jeśli po zmianie kształtu obszar płytki nakłada się na sąsiedni obszar, oprogramowanie przyjmie, że w części wspólnej obowiązuje obszar o największej liczbie warstw.

O czym należy pamiętać podczas edycji obiektu wielokątnego:

  • Podczas przeciągania wierzchołka lub krawędzi wielokąta dostępne są trzy tryby zmiany kształtu: przesuwanie, załamywanie i zakrzywianie — naciskaj Shift+Spacebar podczas przeciągania, aby przełączać te tryby. Bieżący tryb jest wyświetlany na pasku stanu oraz na wyświetlaczu Heads-Up.
  • Przyciąganie kursora zależy od bieżących ustawień, które obejmują aktualną siatkę przyciągania, obiekty dostępne do przyciągania, obecność prowadnic obszaru roboczego oraz ustawienia przyciągania do osi — korzystaj z tych funkcji, aby uzyskać wymagany kształt. Dowiedz się więcej o zasadach działania przyciągania.

Przypisywanie stosu warstw i edycja nazwy obszaru płytki

Related page: Definiowanie stosu warstw

Nowo utworzona płytka zawiera jeden obszar o nazwie Default Layer Stack Region. Do tego obszaru zostanie przypisany domyślny stos warstw o nazwie Board Layer Stack.

Po podzieleniu kształtu płytki na wiele obszarów każdemu nowemu obszarowi również przypisywany jest domyślny stos warstw. Po zdefiniowaniu wymaganych stosów warstw w menedżerze stosu warstw można przypisać stos do każdego obszaru oraz nadać mu opisową nazwę.

W każdym obszarze wyświetlana jest etykieta zawierająca jego nazwę i nazwę przypisanego do niego stosu warstw w formacie Region Name - Layer Stack Name. Jeśli dla wybranego stosu warstw włączono elastyczność, zostanie to również wskazane przez (flex). Elastyczność stosu włącza się w Layer Stack Manager.

Aby przypisać stos warstw i nadać nazwę obszarowi:

  1. Wybierz View » Board Planning Mode lub naciśnij skrót klawiaturowy 1, aby przejść do Board Planning Mode.
  2. Kliknij kartę Multi-Layer u dołu obszaru roboczego, aby ustawić ją jako aktywną warstwę (jeśli karta warstwy nie jest widoczna, naciśnij L, aby otworzyć panel View Configuration i włączyć jej wyświetlanie).
  3. Kliknij dwukrotnie obszar płytki, aby otworzyć okno dialogowe Board Region, lub kliknij obszar płytki jednokrotnie i otwórz panel Properties. Jeśli obszar nie zostaje zaznaczony, a okno dialogowe się nie otwiera, upewnij się, że filtr zaznaczania nie wyklucza obszarów.
  4. Przypisz stos warstw, wybierając wymagany stos z listy rozwijanej Layer stack.
  5. Zmień Name zgodnie z potrzebami.

Nazwa obszaru płytki i przypisany do niego stos warstw są wyświetlane w geometrycznym środku tego obszaru. Jeśli przypisany stos jest skonfigurowany jako elastyczny, wyświetlane jest również oznaczenie (Flex).
Nazwa obszaru płytki i przypisany do niego stos warstw są wyświetlane w geometrycznym środku tego obszaru. Jeśli przypisany stos jest skonfigurowany jako elastyczny, wyświetlane jest również oznaczenie (Flex).

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents