Układanie płytki drukowanej
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Jak skonfigurować edytor PCB i dokument PCB, w tym preferencje, siatki i jednostki.
- Jak definiować i edytować kształt płytki, ustawiać początek układu współrzędnych oraz zarządzać wyświetlaniem warstw podczas pracy w edytorze PCB.
- Jak Altium Designer organizuje warstwy produkcyjne i nieelektryczne oraz gdzie skonfigurować stos warstw i typy przelotek.
Wewnątrz każdego urządzenia elektronicznego znajduje się płytka drukowana, czyli PCB. Obecnie elementy są tak małe, że ich wymiary mierzy się w ułamkach milimetra, a nie w centymetrach. Ścieżki, niegdyś mające szerokość 10 mil i rozmieszczone w dużych odstępach, stały się cienkimi jak włos liniami o szerokości 2 lub 3 mil, ułożonymi bardzo blisko siebie. Wzrost szybkości sygnałów sprawił również, że połączenia na PCB przestały być prostymi miedzianymi przewodnikami przenoszącymi energię elektryczną, a zaczęły zachowywać się jak szybkie linie transmisyjne, co wymaga stosowania odpowiednich technik projektowania. Wymagania mechaniczne również stały się bardziej złożone. Kompaktowe, nietypowo ukształtowane nowoczesne urządzenia elektroniczne wymagają równie kompaktowych płytek drukowanych o nietypowych kształtach, często wykonywanych jako konstrukcje sztywno-elastyczne — płytki te mogą mieć zakrzywione krawędzie i wycięcia, co wymaga starannego rozmieszczenia elementów.
Technologie projektowania PCB firmy Altium pozwalają sprostać tym wyzwaniom. Edytor PCB w Altium Designer umożliwia tworzenie, edytowanie i weryfikowanie projektów PCB.
Konfigurowanie edytora PCB
Kategoria PCB Editor w oknie dialogowym Preferences (dostępnym po kliknięciu ikony
w prawym górnym rogu obszaru projektowego) zapewnia dostęp do stron preferencji wpływających na działanie edytora PCB. Preferencje te można otworzyć w dowolnym momencie, aby dostosować ustawienia do potrzeb.

Użyj kategorii PCB Editor w Preferences programu Altium Designer, aby skonfigurować edytor PCB.
Dowiedz się więcej o preferencjach PCB: Preferencje edytora PCB.
Konfigurowanie dokumentu PCB
Aby rozpocząć projektowanie układu PCB, dodaj nowy dokument PCB do projektu PCB. W tym celu kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie Add New to Project » PCB z menu kontekstowego. W obszarze projektowym pojawi się domyślny dokument PCB.

Nowo utworzony dokument PCB będzie aktywnym dokumentem w obszarze projektowym.
Opcje dokumentu PCB konfiguruje się w panelu Properties, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt. Główne opcje konfiguruje się na karcie General tego panelu:
-
Ustawienia siatki (sekcja Grid Manager) — skonfiguruj opcje domyślnej siatki globalnej lub w razie potrzeby dodaj kolejne siatki (kartezjańskie i biegunowe). Siatki zapewniają precyzyjne przesuwanie i rozmieszczanie obiektów.
- Jednostki (sekcja Other) — wybierz preferowane jednostki miary (mm lub mils) dla dokumentu.

Skonfiguruj opcje dokumentu PCB w panelu Properties.
Dowiedz się więcej o konfigurowaniu dokumentu PCB: Konfiguracja środowiska PCB.
Definiowanie kształtu płytki i początku układu współrzędnych
Kształt płytki, określany również jako jej obrys, wyznacza zewnętrzne granice płytki. Domyślnie płytka jest prostokątem o wymiarach 6000 x 4000 mil (152,4 x 101,6 mm). Edytor PCB udostępnia szereg narzędzi pozwalających zdefiniować kształt płytki zgodnie z wymaganiami.
Nowy kształt płytki można zdefiniować interaktywnie w następujący sposób:
-
Przejdź do trybu planowania płytki w edytorze, wybierając polecenie View » Board Planning Mode z menu głównego.
-
Wybierz polecenie Design » Redefine Board Shape z menu głównego.
-
Ustaw kursor i kliknij, aby umieścić pierwszy wierzchołek obrysu płytki.
-
Przesuń kursor w miejsce drugiego wierzchołka i kliknij, aby go umieścić.
-
Kontynuuj przesuwanie myszy i klikanie, aby umieścić kolejne wierzchołki.
-
Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy, aby zamknąć obrys i zakończyć definiowanie kształtu płytki. Nie trzeba ręcznie zamykać obrysu, ponieważ edytor PCB automatycznie uzupełni kształt, łącząc punkt początkowy z ostatnio umieszczonym punktem.
Zamiast definiować kształt od nowa, można też edytować istniejący kształt w następujący sposób:
- Przejdź do trybu planowania płytki w edytorze, wybierając polecenie View » Board Planning Mode z menu głównego.
- Wybierz polecenie Design » Edit Board Shape z menu głównego.
-
Kliknij i przytrzymaj bok lub wierzchołek obrysu płytki, a następnie przeciągnij go, aby go przesunąć.
- Zakończ tryb edycji, klikając w dowolnym miejscu obszaru projektowego (na obrysie płytki lub poza nim).
Użyj polecenia View » 2D Layout Mode z menu głównego, aby wrócić do trybu projektowania 2D w edytorze.
Dowiedz się więcej o dostępnych technikach definiowania kształtu płytki: Definiowanie kształtu płytki.
Konfigurowanie wyświetlania warstw
Oprócz warstw używanych do produkcji płytki, takich jak warstwy sygnałowe, płaszczyzny zasilania, warstwy maski i warstwy opisowe, edytor PCB obsługuje również wiele innych warstw nieelektrycznych. Warstwy często dzieli się na następujące grupy:
-
Electrical Layers — obejmuje 128 warstw sygnałowych i 16 wewnętrznych warstw płaszczyzn zasilania.
-
Component Layers — warstwy używane przy projektowaniu elementów, w tym Overlay (warstwa opisowa), Solder (maska lutownicza) i Paste (pasta lutownicza). Jeśli obiekt zostanie umieszczony na jednej z tych warstw we wzorcu obudowy elementu w edytorze bibliotek, po przeniesieniu elementu z górnej na dolną stronę płytki wszystkie obiekty znajdujące się na warstwie elementu zostaną przeniesione na odpowiadającą jej warstwę pary. Dotyczy to również obiektów na zdefiniowanych przez użytkownika parach warstw elementów (sparowanych warstwach mechanicznych).
-
Mechanical Layers — oprogramowanie obsługuje nieograniczoną liczbę warstw mechanicznych ogólnego przeznaczenia, używanych do takich zadań projektowych jak wymiarowanie, przedstawianie szczegółów wykonawczych, instrukcji montażu itp. W razie potrzeby wybrane warstwy tego typu można uwzględnić na wydrukach i w generowanych plikach Gerber. Warstwy mechaniczne można również łączyć w pary; wówczas zachowują się one jak warstwy elementów. Sparowane warstwy elementów służą między innymi do rozmieszczania modeli 3D, punktów kleju i obszarów selektywnego złocenia na złączach krawędziowych.
-
Other Layers – obejmują one warstwę Keep-Out (służącą do definiowania obszarów zabronionych obowiązujących na wszystkich warstwach miedzi), warstwę Multi-Layer (używaną dla obiektów obecnych na wszystkich warstwach sygnałowych, takich jak pady i przelotki), warstwę Drill Drawing (służącą do umieszczania informacji o wierceniu, takich jak tabela otworów) oraz warstwę Drill Guide (służącą do wyświetlania znaczników wskazujących położenie i rozmiary otworów).
Warstwy miedzi dodaje się do projektu i usuwa z niego w menedżerze stosu warstw (Layer Stack Manager), omówionym w następnej sekcji. Wszystkie pozostałe warstwy włącza się i konfiguruje w panelu View Configuration.

Dwie zakładki panelu View Configuration
Oprócz ustawień widoczności i kolorów warstw panel View Configuration zapewnia również dostęp do innych ustawień wyświetlania, w tym:
-
Koloru i widoczności System Colors, takich jak kolor zaznaczenia lub widoczność linii połączeń.
-
Sposobu wyświetlania poszczególnych typów obiektów (pełny lub szkicowy) oraz ich przezroczystości (sekcja Object Visibility).
-
Różnych opcji widoku, takich jak wyświetlanie Origin Marker, nazw Pad Net oraz Pad Numbers (sekcja Additional Options).
-
Stopnia przygaszenia widoku podczas przyciemniania lub maskowania obiektów (sekcja Mask and Dim Settings).
-
Tworzenia zestawów warstw, które umożliwiają szybkie przełączanie aktualnie widocznych warstw za pomocą elementu sterującego
(sekcja Layers).
-
Tworzenia i wybierania konfiguracji widoku, służących do wstępnego ustawiania wszystkich właściwości warstw, takich jak kolor, widoczność, przezroczystość obiektów itp. (sekcja General Settings).
Kilka uwag dotyczących warstw:
-
Aktualnie włączone warstwy są przedstawione jako szereg zakładek u dołu obszaru projektowania PCB, jak pokazano na poniższej ilustracji. Kliknij zakładkę prawym przyciskiem myszy, aby uzyskać dostęp do często używanych poleceń wyświetlania warstw.
-
Podczas umieszczania obiektów na PCB należy zwrócić uwagę na to, na której warstwie zostaną umieszczone. Obiekty są umieszczane na bieżącej warstwie, wskazywanej przez aktywną zakładkę warstwy u dołu obszaru projektowania. Na powyższej ilustracji aktywną warstwą jest Top Layer.
-
Aby zmienić aktywną warstwę:
-
Kliknij zakładkę warstwy u dołu obszaru projektowania lub
-
Naciskaj klawisze numeryczne + lub -, aby przechodzić kolejno przez wszystkie warstwy, lub
-
Naciskaj klawisz numeryczny *, aby przechodzić kolejno przez warstwy sygnałowe, lub
-
Użyj skrótów Ctrl+Shift+Mouse Wheel.
-
-
W złożonym projekcie pomocne może być wyświetlanie tylko warstwy, nad którą aktualnie pracujesz; ten sposób wyświetlania jest określany jako Single Layer Mode. Aby włączyć lub wyłączyć tryb pojedynczej warstwy, naciśnij skrót Shift+S. Ustawienia Available Single Layer Modes konfiguruje się na stronie Edytor PCB – wyświetlanie Board Insight w oknie dialogowym Preferences. Każde naciśnięcie Shift+S powoduje przejście do następnego włączonego trybu pojedynczej warstwy.
Dowiedz się więcej o konfigurowaniu widoku PCB: Twój widok PCB.
Definiowanie stosu warstw
PCB jest projektowana i wykonywana jako stos warstw zdefiniowany w menedżerze stosu warstw (Layer Stack Manager) (Design » Layer Stack Manager). Layer Stack Manager otwiera się w edytorze dokumentów tak samo jak arkusz schematu, PCB i inne typy dokumentów. Funkcje są podzielone między zakładki wyświetlane u dołu Layer Stack Manager. Główne operacje konfiguracyjne wykonuje się na zakładkach Stackup i Via Types.
Zakładka Stackup zawiera szczegółowe informacje o warstwach produkcyjnych. Na tej zakładce dodaje się, usuwa i konfiguruje warstwy.
|
Aby dodać warstwę, w obszarze tabeli wybierz warstwę, nad którą lub pod którą ma zostać dodana nowa warstwa, kliknij przycisk Add u góry Layer Stack Manager i skorzystaj z wyświetlonego menu podręcznego. Aby usunąć warstwę, zaznacz ją w obszarze tabeli i kliknij przycisk Delete. Aby wybrać materiał warstwy z biblioteki materiałów, zaznacz odpowiednią warstwę w obszarze tabeli i kliknij przycisk Modify. Właściwości zdefiniowane dla wybranego materiału zostaną zastosowane do warstwy. Właściwości aktualnie zaznaczonej warstwy można również edytować bezpośrednio w obszarze tabeli lub w panelu Properties. |
Zakładka Via Types służy do definiowania dopuszczalnych zakresów warstw w osi Z dla przelotek używanych w projekcie.
|
Domyślny typ przelotki przelotowej jest zawsze obecny w projekcie PCB. Aby dodać kolejny typ przelotki (ślepą, zagrzebaną lub mikroprzelotkę), kliknij przycisk Add u góry Layer Stack Manager, a następnie, po zaznaczeniu typu przelotki w obszarze tabeli, wybierz warstwy, które ten typ przelotki łączy, z list rozwijanych First layer i Last layer w panelu Properties. Aby usunąć dodany typ przelotki, zaznacz go w obszarze tabeli i kliknij przycisk Delete. |
Użyj polecenia File » Save to PCB w Layer Stack Manager, aby zastosować zmiany na PCB.
Dowiedz się więcej o Layer Stack Manager: Definiowanie stosu warstw, Definiowanie przelotek ślepych, zagrzebanych i mikroprzelotek.
Konfigurowanie reguł projektowych
Reguły projektowe monitorują i sprawdzają projekt pod kątem różnych wymagań, takich jak odstępy między obiektami miedzianymi, szerokości ścieżek, długości sieci itp. Wszystkie reguły projektowe tworzą razem zestaw instrukcji, których przestrzega edytor PCB.
Reguły projektowe definiuje się i zarządza nimi w oknie dialogowym PCB Rules and Constraints Editor, otwieranym przez wybranie polecenia Design » Rules z menu głównego.
Okno dialogowe PCB Rules and Constraints Editor składa się z dwóch części:
- Po lewej stronie okna dialogowego znajduje się drzewo zawierające dostępne kategorie reguł, typy reguł w każdej kategorii oraz poszczególne reguły każdego typu, które są obecnie zdefiniowane.
- Po prawej stronie okna dialogowego wyświetlane są informacje dotyczące elementu aktualnie wybranego w drzewie. Na przykład wybranie pojedynczej reguły powoduje wyświetlenie jej ustawień.
Reguły projektowe mają trzy grupy ustawień, opisane poniżej i pokazane na kolejnych ilustracjach:
- Główne atrybuty reguły – tutaj można nadać regule znaczącą nazwę i dodać opcjonalny komentarz.
- Zakres reguły – określa konkretne obiekty w projekcie, których dotyczy reguła. W zależności od typu reguły należy zdefiniować jeden zakres (dla reguły jednoargumentowej, która określa wymagane zachowanie obiektu) lub dwa zakresy (dla reguły dwuargumentowej, która określa interakcję między dwoma obiektami).
- Ograniczenia reguły – konkretne ograniczenia określone przez regułę.
|
Reguły typu Width są regułami jednoargumentowymi. Dla reguły jednoargumentowej należy zdefiniować jeden zakres (Where the Object Matches). Reguły typu Clearance są regułami dwuargumentowymi. Dla reguły dwuargumentowej należy zdefiniować dwa zakresy (Where the First Object Matches i Where the Second Object Matches). |
Aby utworzyć nową regułę, kliknij prawym przyciskiem myszy żądany typ reguły w drzewie okna dialogowego i wybierz polecenie New Rule z menu kontekstowego. Nowa reguła zostanie dodana do drzewa w wybranej kategorii. Wybierz pozycję reguły w drzewie, aby ją edytować.
Jeśli istnieje wiele reguł tego samego typu dotyczących tych samych obiektów, edytor PCB korzysta z priorytetów reguł, aby zastosować odpowiednią regułę o najwyższym priorytecie. Kliknij przycisk Priorities u dołu okna dialogowego PCB Rules and Constraints Editor, aby otworzyć okno dialogowe Edit Rule Priorities i zmienić priorytety zgodnie z potrzebami. 1 oznacza najwyższy priorytet. Po dodaniu nowej reguły (za pomocą polecenia New Rule) otrzymuje ona najwyższy priorytet.
Dowiedz się więcej o pracy z regułami projektowania PCB i poszczególnych typach reguł: Definiowanie, określanie zakresu i zarządzanie regułami projektowania PCB, Typy reguł projektowania PCB.
Rozmieszczanie komponentów
Po przeniesieniu danych projektowych ze schematów projektu PCB do dokumentu PCB (za pomocą polecenia Design » Update PCB Document z menu głównego edytora schematów i następującego po nim procesu wykonywania ECO) domyślne footprinty komponentów użytych na schematach zostaną umieszczone w dowolnych miejscach w dokumencie PCB. Pola lutownicze komponentów zostaną połączone liniami połączeń zgodnie z sieciami (połączonymi wyprowadzeniami komponentów) zdefiniowanymi na schematach.

Płytka PCB po aktualizacji na podstawie schematów.
Podstawowe sposoby określania położenia komponentu na PCB:
- Aby przenieść komponent w żądane miejsce, Click, Hold&Drag następnie zwolnij przycisk myszy, aby go umieścić.
- Aby obrócić komponent, naciśnij Spacebar podczas jego przeciągania.
- Aby przenieść komponent na drugą stronę płytki, naciśnij L podczas jego przeciągania.
Linie połączeń są automatycznie ponownie optymalizowane podczas przesuwania komponentu. Korzystaj z nich, aby ułatwić orientowanie i rozmieszczanie komponentów oraz zmniejszyć liczbę skrzyżowań linii połączeń.
Dowiedz się więcej o połączeniach na PCB i rozmieszczaniu komponentów: Zrozumienie połączeń na płytce PCB, Rozmieszczanie komponentów.
Trasowanie płytki
Trasowanie to proces prowadzenia ścieżek, łuków i przelotek na płytce w celu połączenia pól lutowniczych komponentów. Edytor PCB oferuje narzędzia, w tym narzędzia do trasowania interaktywnego, które ułatwiają prowadzenie połączeń na płytce.
Ponieważ narzędzia do trasowania działają na podstawie reguł, przed rozpoczęciem trasowania należy skonfigurować reguły projektowe. Główne reguły projektowe używane podczas trasowania interaktywnego to:
- Reguła Clearance (kategoria Electrical) – określa, jak blisko innych obiektów na płytce mogą znajdować się ścieżki trasowanej sieci.
- Reguła Width (kategoria Routing) – określa szerokość ścieżek trasowanej sieci.
- Reguła Routing Via Style (kategoria Routing) – określa średnicę i rozmiar otworu przelotek umieszczanych podczas zmiany warstw w trakcie trasowania.
Zaleca się również ustawienie siatki przyciągania odpowiedniej do trasowania.
Do trasowania pojedynczego połączenia służy narzędzie Interactive Routing. Proces przebiega następująco:
-
Wybierz polecenie Route » Interactive Routing z menu głównego.
-
Kliknij pole lutownicze komponentu, od którego chcesz rozpocząć trasowanie.
-
Ustaw kursor, a następnie kliknij w obszarze projektowym, aby umieścić ścieżki do pozycji kursora. Kontynuuj wyznaczanie przebiegu ścieżki.
-
Kliknij docelowy pad, aby zakończyć prowadzenie połączenia. Połączenie zostanie automatycznie zwolnione, a tryb interaktywnego prowadzenia ścieżek pozostanie aktywny, umożliwiając rozpoczęcie kolejnego połączenia.
-
Kliknij prawym przyciskiem myszy, aby wyjść z trybu interaktywnego prowadzenia ścieżek.
Uwagi dotyczące interaktywnego prowadzenia ścieżek:
-
Gdy podczas interaktywnego prowadzenia ścieżek zbliżysz kursor do pada, zostanie on automatycznie przyciągnięty do jego środka. Jest to działanie funkcji przyciągania do punktów charakterystycznych obiektów, która przyciąga kursor do punktu charakterystycznego najbliższego obiektu elektrycznego.
Dowiedz się więcej: Praca z systemem przyciągania kursora.
-
Podczas interaktywnego prowadzenia ścieżek możesz korzystać z następujących skrótów:
-
Tab – wstrzymuje prowadzenie ścieżek i otwiera panel Properties, w którym można skonfigurować opcje interaktywnego prowadzenia ścieżek. Po zakończeniu kliknij przycisk
w obszarze projektowania, aby powrócić do trybu interaktywnego prowadzenia ścieżek.
-
Shift+Spacebar – przełącza style narożników: ścieżka 45°, linia 45°/90° z łukiem, dowolny kąt itd.
-
Spacebar – przełącza kierunek narożnika.
-
Shift+R – przełącza dostępne tryby rozwiązywania kolizji podczas prowadzenia ścieżek: omijanie przeszkód, przesuwanie przeszkód, ignorowanie przeszkód itd.
-
Ctrl+Shift+Wheel Scroll – przełącza na kolejną dostępną warstwę sygnałową i wstawia przelotkę.
-
Shift+F1 – wyświetla listę skrótów interaktywnego prowadzenia ścieżek.
-
-
Podczas prowadzenia ścieżek ich segmenty są wyświetlane na różne sposoby (jak pokazano na poniższych ilustracjach):
-
Solid – segment został umieszczony.
-
Hatched – segmenty kreskowane są proponowane, ale jeszcze niezatwierdzone; zostaną umieszczone po kliknięciu.
-
Hollow – jest to tzw. segment wyprzedzający, który pozwala określić, gdzie powinien kończyć się ostatni proponowany segment. Ten segment not umieszczany po kliknięciu, chyba że kolejne kliknięcie zakończy prowadzenie połączenia. W takiej sytuacji włącza się opcja Automatically Terminate Routing, która zastępuje domyślne działanie segmentu wyprzedzającego. Tryb segmentu wyprzedzającego można włączać i wyłączać podczas prowadzenia ścieżek za pomocą skrótu
1.

Segmenty wypełnione są już umieszczone, kreskowane są proponowane, ale jeszcze niezatwierdzone, a segment wyświetlany jako obrys jest segmentem wyprzedzającym. -
-
Bardzo przydatną funkcją, która pomaga ocenić ilość miejsca dostępnego do prowadzenia ścieżek, jest wyświetlanie granic odstępu wokół wszystkich obiektów należących do innych sieci Użyj skrótu
Ctrl+W, aby włączać i wyłączać wyświetlanie granic odstępu. Gdy funkcja jest włączona i prowadzisz połączenie danej sieci, wokół wszystkich obiektów innych sieci wyświetlana jest granica odstępu określona przez obowiązującą regułę odstępu elektrycznego. Podczas prowadzenia ścieżek nie można przekroczyć tej granicy. -
Podczas prowadzenia ścieżek wiele przydatnych informacji, w tym nazwa sieci i bieżące ustawienie szerokości, jest dostępnych w nakładce informacyjnej Heads-Up oraz na pasku stanu
-
Zamiast prowadzić ścieżkę aż do docelowego pada, możesz nacisnąć
Ctrl+Click, aby użyć funkcji Auto-Complete i zlecić mechanizmowi prowadzenia ścieżek próbę poprowadzenia całego połączenia. Automatyczne dokończenie działa w następujący sposób:-
Wybiera najkrótszą trasę, która nie zawsze jest najlepsza, ponieważ należy uwzględniać również miejsce na pozostałe, jeszcze niepoprowadzone połączenia. W trybie przesuwania przeszkód automatyczne dokończenie może przesuwać istniejące ścieżki, aby dotrzeć do celu.
-
W przypadku dłuższych połączeń trasa automatycznego dokończenia może nie zawsze być dostępna, ponieważ jest wyznaczana odcinek po odcinku i pełne wyznaczenie trasy między padem początkowym a docelowym może nie być możliwe.
-
Możesz też użyć automatycznego dokończenia (
Ctrl+Click) bezpośrednio na padzie lub linii połączenia.
-
Nie istnieje jeden jedyny sposób poprowadzenia ścieżek na płytce, więc nieuniknione jest, że zechcesz zmienić ich przebieg. Edytor PCB udostępnia funkcje i narzędzia, które w tym pomagają. Istnieją dwa podejścia: ponowne poprowadzenie lub zmiana położenia.
-
Reroute – wybierz polecenie Route » Interactive Routing i rozpocznij prowadzenie ścieżki w dowolnym punkcie istniejącej trasy, aby zmienić przebieg połączenia. Funkcja usuwania pętli automatycznie usunie zbędne segmenty ścieżek (i przelotki), gdy zamkniesz pętlę i klikniesz prawym przyciskiem myszy, aby zakończyć.
-
Rearrange –
Click, Hold&Dragumożliwia interaktywne przesuwanie lub przeciąganie segmentów ścieżek po płytce.
Dowiedz się więcej o prowadzeniu ścieżek na PCB: Prowadzenie ścieżek na PCB.
Umieszczanie poligonów
Aby pokryć warstwę sygnałową PCB dużym obszarem miedzi, można użyć wypełnienia poligonowego. Wypełnienie poligonowe automatycznie omija istniejące obiekty, łącząc się tylko z obiektami należącymi do tej samej sieci co poligon. Odstępy i właściwości połączeń są określane przez obowiązujące reguły projektowe odstępów i stylu połączenia z poligonem.
Aby umieścić wypełnienie poligonowe:
- Wybierz polecenie Place » Polygon Pour z menu głównego.
-
Podczas umieszczania możesz nacisnąć klawisz Tab, aby otworzyć panel Properties i skonfigurować właściwości umieszczanego poligonu: sieć, warstwę, tryb wypełnienia itd. Po zakończeniu kliknij przycisk
w obszarze projektowania, aby powrócić do trybu umieszczania.
- Ustaw kursor i kliknij, aby wyznaczyć pierwszy wierzchołek wypełnienia poligonowego.
-
Przesuń kursor w miejsce drugiego wierzchołka i kliknij, aby go umieścić.
- Przesuwaj dalej mysz i klikaj, aby umieszczać kolejne wierzchołki.
- Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy, aby zamknąć poligon i zakończyć umieszczanie wypełnienia. Nie trzeba ręcznie zamykać kształtu poligonu, ponieważ edytor PCB zrobi to automatycznie, łącząc punkt początkowy z ostatnim umieszczonym punktem.
- Kontynuuj umieszczanie kolejnych wypełnień poligonowych lub kliknij prawym przyciskiem myszy, aby wyjść z trybu umieszczania.
Po zmodyfikowaniu wypełnienia poligonowego (np. zmianie jego kształtu lub właściwości) należy ponownie je przeliczyć, aby uwzględnić zmiany. Aby ponownie przeliczyć wypełnienie poligonu, zaznacz poligon i kliknij przycisk Repour u góry panelu Properties.
Dowiedz się więcej o wypełnieniach poligonowych: Poligony na warstwach sygnałowych.
Sprawdzanie reguł projektowych
Edytor PCB udostępnia funkcje sprawdzania reguł projektowych (DRC), które pozwalają sprawdzić, czy projekt jest zgodny z włączonymi regułami projektowymi.
Sprawdzanie reguł projektowych konfiguruje się w oknie dialogowym Design Rule Checker otwieranym za pomocą polecenia Tools » Design Rule Check z menu głównego.
-
Kliknij pozycję Report Options w drzewie po lewej stronie okna dialogowego, aby skonfigurować dodatkowe opcje dostępne podczas wsadowego sprawdzania DRC.
-
Kliknij pozycję Rules to Check lub pozycję odpowiadającą określonej kategorii reguł, aby wyświetlić w oknie dialogowym listę typów reguł i włączyć poszczególne typy dla sprawdzania DRC w czasie rzeczywistym lub w trybie wsadowym, zgodnie z potrzebami:
-
DRC w czasie rzeczywistym – sprawdzanie jest wykonywane na bieżąco podczas projektowania.
-
Wsadowe DRC – sprawdzanie jest wykonywane jako proces wsadowy po kliknięciu przycisku Run Design Rule Check w oknie dialogowym, a wyniki są wyświetlane w panelu Messages oraz w opcjonalnie generowanym raporcie.
-
Podczas sprawdzania DRC w czasie rzeczywistym lub w trybie wsadowym wykryte naruszenia reguł są sygnalizowane w obszarze projektowym (za pomocą specjalnych oznaczeń graficznych naruszeń lub nakładki naruszeń). Poniżej przedstawiono kilka przykładów naruszeń w obszarze projektowym:

Ścieżki naruszające regułę szerokości. Naruszenie jest sygnalizowane zarówno przez specjalne oznaczenia graficzne, jak i nakładkę naruszeń.

Ścieżka naruszająca regułę anten sieci. Naruszenie jest sygnalizowane przez specjalne oznaczenia graficzne.
Sposób wyświetlania naruszeń różnych typów reguł w obszarze projektowym można skonfigurować na stronie Edytor PCB – wyświetlanie naruszeń DRC w oknie dialogowym Preferences.
Na podstawie informacji o skali naruszenia można zdecydować, jak najlepiej je usunąć. Na przykład, jeśli minimalna szerokość paska maski lutowniczej jest ustawiona na 0,25 mm, a rzeczywista szerokość wynosi 0,24 mm, sytuacja nie jest aż tak zła i być może można dostosować ograniczenie, aby zaakceptować tę wartość. Jeśli jednak rzeczywista szerokość wynosi 0,02 mm, prawdopodobnie nie da się rozwiązać problemu przez zmianę ograniczenia.
-
Szczegóły znajdują się w panelu Messages. Wartość rzeczywista jest podawana wraz z wartością wymaganą (na przykład 0.017mm < 0.254mm).
-
Możesz również kliknąć naruszenie prawym przyciskiem myszy i otworzyć podmenu Violations, aby sprawdzić, które ograniczenie zostało naruszone i w jakich warunkach występuje naruszenie
-
Edytor PCB zawiera również przydatne narzędzia pomiarowe, które umożliwiają pomiar odległości między dwoma punktami, pomiar wybranych obiektów (długości wybranych ścieżek i łuków) oraz pomiar odległości między dwoma obiektami podstawowymi. Więcej informacji znajdziesz na stronie Pomiar odległości na PCB.
Panel PCB Rules And Violations to doskonałe narzędzie do lokalizowania naruszeń i analizowania warunków ich występowania. Domyślnie na liście Rule Classes wyświetlana jest pozycja [All Rules]. Po ustaleniu interesującego Cię typu reguły wybierz odpowiednią klasę reguł, aby w dolnej części panelu były wyświetlane tylko jej naruszenia. Panel zawiera szczegółowe informacje o typie naruszenia, zmierzonej wartości, ograniczeniu oraz obiektach naruszających regułę. Wykryte naruszenia dla wybranej klasy reguł lub konkretnej reguły są również wyświetlane w sekcji Violations panelu. Kliknij pozycję naruszenia, aby wyróżnić je w obszarze projektowym zgodnie z ustawieniem w górnej części panelu: Mask/Dim/Normal, Select, Zoom. Kliknij naruszenie dwukrotnie, aby otworzyć okno dialogowe Violation Details.
Sprawdzanie DRC można również uruchomić dla wszystkich reguł, reguł określonego typu lub konkretnej reguły, klikając prawym przyciskiem myszy odpowiednią pozycję w panelu PCB Rules And Violations i wybierając polecenie Run DRC.

Uruchamiaj DRC bezpośrednio z panelu PCB Rules And Violations. Tutaj pokazano uruchamianie DRC dla wszystkich zdefiniowanych reguł odstępu.
Dowiedz się więcej o DRC: Sprawdzanie reguł projektowych (DRC).















).
).


).