Trabalhando com Rooms em uma PCB
Num relance
- Você aprenderá o que é uma room em uma PCB e como ela é usada para controlar o posicionamento de objetos e os requisitos de projeto em uma área definida da placa.
- Você conhecerá os principais métodos para criar rooms no editor de PCB, incluindo o posicionamento interativo, a criação a partir de componentes selecionados e a criação por meio de restrições de projeto.
- Você entenderá como os objetos de room e as restrições do tipo Room Definition trabalham em conjunto no Altium Designer, incluindo sua aplicação no PCB Rules and Constraints Editor e no Constraint Manager.
Resumo
Uma sala é uma área definida em uma das camadas de superfície da PCB. Uma sala é usada para definir requisitos de projeto nessa área da placa, como: these components must be in this area, ou, route these nets this width, ou, use routing vias of this size.
Uma sala é posicionada como outros objetos poligonais, com formato retangular ou poligonal.
Além de existir como uma forma X-Y nomeada na placa, cada sala se torna automaticamente uma restrição de projeto Room Definition nomeada As configurações da restrição Room Definition definem: os objects aos quais a sala se aplica, se esses objetos devem ser mantidos inside or outside da sala e a layer à qual a sala se aplica.
Além do requisito simples de keep these objects in (or out) que a restrição Room Definition especifica diretamente, a sala também pode ser usada para definir uma área da placa em que outras restrições de projeto são aplicadas. Por exemplo, o roteamento sob um BGA pode precisar ter uma largura específica , ou o roteamento de pares diferenciais sob um BGA pode exigir a aplicação de um perfil de impedância específico
Disponibilidade
As salas só podem ser posicionadas/criadas no Editor de PCB. Use os seguintes métodos para criar salas:
-
Selecione o comando desejado no submenu Design » Rooms e, em seguida, defina interativamente o formato da sala (se você selecionou um comando Place) ou crie a sala automaticamente (se você selecionou um comando Create).
-
Adicione uma nova restrição de projeto Room Definition, edite a nova restrição de sala e clique no botão Define para definir interativamente o formato da sala poligonal.
-
Crie uma sala com base em um contorno fechado (selecionado) formado por um conjunto de trilhas/arcos, usando o comando Tools » Convert » Create Room from Selected Primitives.
-
Crie salas automaticamente durante a sincronização do projeto do esquemático com a PCB. Saiba mais sobre salas geradas automaticamente (incluindo como desativá-las).
Criação de uma sala
O procedimento usado para criar uma sala no documento de PCB depende de você estar posicionando ou criando a sala interativamente e do método específico de posicionamento/criação escolhido.
Há diferentes técnicas disponíveis para posicionar ou criar uma sala.
Posicionamento interativo de salas
Salas de formato retangular ou poligonal podem ser posicionadas nas camadas superior ou inferior do projeto. Observe que, embora possam ser posicionadas com qualquer camada ativa, a camada à qual se aplicam é atribuída como parte da restrição de projeto Room Definition.
Sala retangular
Após iniciar o comando Design » Rooms » Place Rectangular Room, o cursor mudará para uma cruz e você entrará no modo de posicionamento de salas. O posicionamento é realizado por meio da seguinte sequência de ações:
-
Clique ou pressione Enter para fixar o primeiro canto da sala.
-
Para editar as propriedades da restrição Room Definition associada durante o posicionamento, pressione a tecla Tab .
-
Mova o cursor para ajustar o tamanho da sala e clique ou pressione Enter para fixar o canto diagonalmente oposto e concluir o posicionamento da sala.
-
Continue posicionando outras salas ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Sala poligonal
Após iniciar o comando Design » Rooms » Place Polygonal Room, o cursor mudará para uma cruz e você entrará no modo de posicionamento de salas. O posicionamento é realizado por meio da seguinte sequência de ações:
-
Posicione o cursor e clique para fixar o ponto inicial da sala.
-
Posicione o cursor e clique para fixar uma série de vértices que definem o formato poligonal da sala.
-
Após posicionar o último vértice, clique com o botão direito do mouse ou pressione Esc para concluir o posicionamento da sala. Não é necessário fechar o polígono, pois o software completará automaticamente a forma conectando o ponto inicial ao último ponto posicionado.
-
Continue posicionando outras salas poligonais ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Com base nos componentes selecionados
Se os componentes já estiverem posicionados na placa e você quiser criar uma nova sala que se ajuste ao posicionamento deles, use um dos três comandos Create xxx Room from selected components. Salas de formato não ortogonal, ortogonal e retangular podem ser criadas automaticamente usando um desses comandos, com base nos componentes atualmente selecionados no espaço de projeto. Em todos os casos, o método de criação é o mesmo:
-
Selecione todos os componentes para os quais deseja criar a sala. Para selecionar os componentes da PCB a partir do esquemático, execute o comando Tools » Cross Select Mode e selecione os componentes no esquemático.
-
No Editor de PCB, inicie o comando de criação correspondente (Design » Rooms » Create xxx Room from selected components). Uma classe de componentes que inclui os componentes selecionados será criada automaticamente (a menos que já exista uma).
-
O tipo de room escolhido é então criado, com a regra de projeto Room Definition dessa room automaticamente associada à classe de componentes criada.
-
A room será dimensionada adequadamente para acomodar todos os componentes da seleção, com base nos retângulos de seleção dos componentes.
-
Se você clicar e arrastar para mover essa room, todos os componentes da classe de componentes associada também serão movidos.
Uma room ortogonal é criada a partir dos componentes da PCB selecionados, que foram selecionados no esquemático.
Adicionando uma restrição de projeto Room Definition
Uma nova room também pode ser criada definindo uma nova restrição no PCB Rule and Constraints Editor ou no Constraint Manager.
Qual abordagem está sendo usada para definir as restrições de projeto?
O Altium Designer oferece suporte a duas abordagens distintas para definir restrições de projeto: o Gerenciador de restrições e o Editor de regras e restrições da PCB.
O PCB Rule and Constraints Editor foi a interface inicialmente desenvolvida para definir restrições no editor de PCB. Se o PCB Rule and Constraints Editor for usado, o projetista define: what objects the constraint (rule) applies to e how those objects are to be constrained. Essa abordagem é poderosa porque permite ao projetista especificar com precisão os objetos aos quais deseja aplicar restrições; elas podem ser aplicadas a tudo (por exemplo, a todas as redes) ou a um objeto específico na placa (um determinado pad). Esse método flexível de selecionar os objetos de projeto é implementado por meio de um mecanismo de regras baseado em uma linguagem de consulta.
O Constraint Manager traz uma abordagem centrada em objetos para a tarefa de definir as restrições. O projetista trabalha a partir da perspectiva dos objetos, aplicando as diversas restrições elétricas e físicas necessárias ao projeto em uma interface semelhante a uma planilha, com os objetos sendo destacados no editor gráfico à medida que são selecionados no Constraint Manager. Isso permite ao projetista configurar e examinar facilmente todos os requisitos de um objeto, por exemplo: esta classe de redes deve ser roteada com esta largura, com este espaçamento, usando esta via de roteamento e este estilo de conexão de polígono. Você também pode exigir que essa classe de redes seja roteada nestas camadas, com estas impedâncias. Essa visualização centrada em objetos não é possível no PCB Rule and Constraints Editor. Por fim, o software converte as restrições centradas em objetos no mesmo formato das regras definidas no PCB Rule and Constraints Editor; alterne para a visualização All Rules após abrir as restrições a partir do editor de PCB para visualizá-las.
Esta página da documentação mostra imagens das restrições conforme definidas tanto na caixa de diálogo PCB Rule and Constraints Editor quanto no Constraint Manager. Observe que os termos constraint e rule são usados de forma intercambiável.
Adicionando uma nova restrição de projeto Room Definition
No Editor de regras e restrições da PCB
Para cada room posicionada ou criada, uma restrição de projeto Room Definition associada é criada automaticamente. O inverso também é verdadeiro: se você adicionar uma nova regra desse tipo, o objeto de room correspondente aparecerá no espaço de projeto. Observe que isso também se aplica à exclusão: se você excluir uma room no editor gráfico, a restrição será excluída automaticamente; ou, se você excluir a restrição de projeto, o objeto gráfico será excluído.
Se a restrição de room estiver sendo definida a partir do PCB Rules and Constraint Editor, será criado um objeto de room padrão de 5 por 5 polegadas, a 1 polegada da origem absoluta (no canto inferior esquerdo do espaço de edição). Observe que o marcador de origem exibe a origem relativa definida pelo usuário, que pode ser posicionada em qualquer lugar do espaço de edição.
Quando uma nova restrição de room é adicionada, uma room padrão é definida no espaço de edição.
Depois de adicionar a restrição, você pode retornar ao espaço de edição e editar a room graficamente. Como alternativa, quando estiver no PCB Rules and Constraints Editor , você poderá editar a restrição de room e clicar no botão Define para definir o formato de forma interativa. Como uma room define uma área na placa, é mais comum posicioná-la de forma interativa e deixar que a restrição de projeto seja criada automaticamente.
Saiba mais sobre como adicionar uma nova restrição no Editor de regras e restrições da PCB.
No Gerenciador de restrições
Para criar uma nova restrição de confinamento (room) no Constraint Manager: , alterne para a visualização All Rules, selecione Room Definition na categoria Placement e, em seguida, clique com o botão direito na lista Advanced Rules e selecione Add Advanced Rule no menu de contexto, conforme mostrado abaixo.
Uma nova restrição de room pode ser adicionada no Gerenciador de restrições.
Nesta etapa, o objeto de room ainda não existe no espaço de edição gráfica. Agora você deve clicar no botão Define (que leva você ao editor de PCB) e definir o formato da room. Depois disso, tanto a restrição de room quanto o objeto de room existirão, e as restrições poderão ser salvas.
-
Se a restrição de room for usada para restringir os objetos ao interior (ou ao exterior) dessa área da placa, a próxima etapa será configurar o Object Match e as demais configurações de restrição na parte inferior do Constraint Manager. Continue lendo para saber mais.
-
Se a restrição de room for usada como definição de área em outro tipo de restrição, como a largura de roteamento, consulte a seção Definindo restrições dentro de uma room para saber mais.
Saiba mais sobre como adicionar uma nova restrição no Gerenciador de restrições.
O que é uma restrição de room?
Como mencionado anteriormente, uma room é uma área definida em uma das camadas superficiais da PCB, usada para definir requisitos de projeto nessa área da placa.
Todas as restrições de projeto têm dois elementos principais:
-
what objects this constraint applies to e
-
how those objects are to be constrained
Se a restrição de room for definida em uma área da placa onde não há componentes, o critério Object Match (the objects this constraint applies to) assumirá o valor padrão False, o que significa que essa restrição não se aplica a nenhum objeto. Edite esse critério conforme necessário.
A definição de room recém-criada. Observe que o escopo da regra é False, o que significa que ela não se aplica a nenhum objeto.
Restringindo uma classe de componentes
Uma maneira comum de usar uma restrição de sala é definir a localização de uma classe de componentes, limitando essa classe de componentes a uma área específica da placa.
A classe de componentes Encoder está restrita à sala chamada Room-Encoder, na camada superior da placa.
A imagem acima mostra como a classe de componentes Encoder está restrita within à sala Room-Encoder, na Top side da placa no PCB Rules and Constraints Editor (essencialmente da mesma forma que no Constraint Manager Depois que os componentes são atribuídos a uma sala, eles se movem quando a sala é movida. Para mover uma sala sem mover os componentes, desative temporariamente a regra de definição de sala associada.
Saiba mais sobre a restrição de projeto de definição de sala.
O editor de PCB inclui diversas ferramentas poderosas para trabalhar com salas. Leia mais na seção Trabalhando com salas desta página.
Além de ser uma restrição de projeto por si só (definição de sala), uma sala também pode ser usada como um objeto para limitar o escopo de outra restrição de projeto a uma área da placa, como largura, espaçamento ou estilo de via. Esse assunto é abordado na seção Definindo restrições dentro de uma sala desta página.
Criadas durante a sincronização do projeto do esquemático para a PCB
À medida que o projeto é transferido do esquemático para a PCB, você tem a opção de criar uma sala contendo os componentes de cada folha do esquemático. Em um projeto hierárquico de vários níveis, isso pode ter pouca utilidade, mas, em um projeto plano de grande porte, ter uma sala para cada folha pode ser útil na hora de posicionar os componentes na placa.
A guia Geração de classes da caixa de diálogo Project Options inclui opções para gerar salas para cada folha do projeto Se a opção Generate Rooms estiver marcada, uma sala será criada para essa folha e uma classe com todos os componentes dessa folha será atribuída a essa sala quando o comando Design » Update for executado. Observe que os componentes de cada folha são adicionados a uma classe de componentes, portanto a opção Generate Rooms exige que a opção Component Class correspondente também esteja habilitada.
Na PCB, cada restrição de sala é criada com o escopo InComponentClass('<SheetSymbolDesignator>'). Uma sala não será criada se a folha não contiver componentes. Quando o esquemático é transferido inicialmente para a PCB, os componentes de cada classe de componentes são organizados em uma fileira e, em seguida, uma sala é criada ao redor dessa classe de componentes, conforme mostrado na imagem abaixo.
Desmarque as caixas de seleção Generate Rooms na caixa de diálogo Project Options se as salas geradas automaticamente não forem necessárias.
A PCB após a sincronização inicial do projeto — uma sala foi criada para cada folha, com a classe de componentes dessa folha atribuída a ela.
Saiba mais sobre a geração automática de salas, classes de componentes e classes de redes a partir do projeto esquemático.
Para saber mais sobre a sincronização do projeto, consulte a página Mantendo os esquemáticos e a PCB sincronizados .
A partir de trilhas e arcos selecionados
Um objeto de sala pode ser definido usando um contorno fechado formado por objetos de trilha e/ou arco selecionados. Para isso, selecione todas as primitivas de trilha e arco que compõem o contorno fechado no espaço de projeto e escolha o comando Tools » Convert » Create Room from Selected Primitives nos menus principais. A apresentação de slides abaixo demonstra as etapas envolvidas.
|
Foram posicionadas trilhas em uma camada mecânica para definir o espaço da placa disponível para os componentes Encoder. Execute o comando Tools » Convert » Create Room from Selected Primitives para criar uma definição de sala com o mesmo formato. A caixa de diálogo Edit Room Definition é exibida para que os parâmetros da restrição possam ser definidos. A classe de componentes Para ajustar o formato da sala, clique para selecioná-la e execute o comando Design » Rooms » Edit Polygonal Verticies, depois clique em um vértice ou em uma borda para alterar o formato da sala. |
Editando uma sala
O formato X-Y da sala e sua localização na placa podem ser modificados interativamente. Observe que existem dois processos diferentes para editar uma sala interativamente: com base em seu retângulo de seleção (descrito na seção Alterando o tamanho e a localização) ou com base em seus vértices de edição de formato (descrito na seção Alterando o formato).
Além de acessar os comandos pelo submenu Design » Rooms, você também pode acessar comandos de sala específicos do contexto clicando com o botão direito do mouse em uma sala posicionada e selecionando o submenu Room Actions.
Clique com o botão direito do mouse em uma sala para acessar comandos específicos de sala.
Alterando o tamanho e a localização
Ao clicar uma vez em uma sala para selecioná-la, as seguintes alças de edição ficam disponíveis — independentemente de a sala ter sido originalmente posicionada como uma sala retangular ou poligonal:
As alças de edição aparecem quando você clica para selecionar uma sala.
Alterar o tamanho da sala
-
Arrastar as alças dos cantos (A) redimensiona a sala horizontal e verticalmente ao mesmo tempo.
-
Arrastar uma alça de borda (B) redimensiona o objeto nessa direção (horizontal ou vertical).
-
A sala pode ser girada ou invertida enquanto é arrastada pressionando:
-
Spacebar para girar o objeto no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor do Incremento de rotação definido na página Editor de PCB - Geral da caixa de diálogo Preferences.
-
X ou Y para inverter o objeto ao longo do eixo X ou Y.
-
L para inverter o objeto para o outro lado da placa. Se a sala tiver componentes associados, esses componentes serão invertidos junto com ela.
-
Mover uma sala
Clique em uma sala e arraste-a para movê-la para um novo local. Um objeto de sala também pode ser movido usando o comando Design » Rooms » Move Room nos menus principais ou o comando Room Actions » Move Room no menu de contexto da sala. Após iniciar o comando, o cursor mudará para uma cruz e você entrará no modo de movimentação de salas — clique na sala para movê-la.
Ao clicar em uma sala para movê-la:
-
A sala ficará presa ao cursor. O ponto pelo qual a sala é segurada depende da configuração atual de Object Snap Options , com o cursor se ajustando ao mais próximo dos pontos de ajuste habilitados (pad de componente, referência de componente ou vértice da sala).
-
Mova a sala para a posição desejada e clique ou pressione Enter para confirmar o posicionamento.
-
Continue movendo outras salas ou clique com o botão direito ou pressione Esc para sair.
-
Se houver componentes na sala que está sendo movida, guias dinâmicas de alinhamento verdes poderão ser exibidas durante a movimentação pressionando as teclas Shift ou Ctrl. Use Shift para manter o ajuste à grade ativa; use Ctrl para desativar temporariamente a grade e alinhar a um objeto existente fora dela.
-
Se a sala contiver objetos sem rede e/ou objetos bloqueados, a caixa de diálogo Room containing No Net/Locked Objects será aberta. Use essa caixa de diálogo para determinar se esses objetos devem ou não ser movidos junto com a sala e clique em OK. Para que essa caixa de diálogo apareça, a opção Ask when moving rooms containing No Net/Locked Objects deve estar habilitada na página PCB Editor - General da caixa de diálogo Preferences

A caixa de diálogo Room containing No Net / Locked Objects
Caixa de diálogo Sala contendo objetos sem rede/bloqueados |
|
| No Net Objects | Habilite para mover os objetos sem rede junto com a sala. |
| Locked Objects | Habilite para mover os objetos bloqueados junto com a sala. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Habilite esta opção para salvar as configurações selecionadas e continuar usando-as pelo restante da sessão de PCB. A caixa de diálogo não será aberta novamente até que uma nova sessão seja iniciada. |
Alterar a forma
A forma do contorno de uma sala é modificada executando o comando Edit Polygonal Room Vertices. O comando é acessado pelo submenu Design » Rooms ou pelo submenu de contexto Room Actions, disponível ao clicar com o botão direito.
Ao executar o comando, as alças de edição do contorno da forma poligonal da sala são exibidas. Você pode então:
-
Clicar em uma alça A e mover o cursor para mover esse vértice. Clique novamente no novo local para posicionar o vértice.
-
Ao mover uma alça A, pressione a tecla Delete no teclado para remover esse vértice da sala.
-
Clicar em B ou ao longo de uma borda (entre as alças) e mover o cursor para deslizar essa borda. Pressione Shift+Spacebar enquanto move a borda para alternar entre os modos de comportamento da borda disponíveis (deslizar borda, quebrar borda, curvar borda).
-
Ctrl+Click B ou Ctrl+Click ao longo de uma borda e mover o cursor para adicionar um vértice a essa borda e movê-lo. Clique novamente no novo local para posicionar o vértice. Na prática, o novo vértice se torna um vértice A, e novos vértices B são adicionados entre ele e os vértices A originais.
-
Para acessar uma alça fora da grade, mantenha a tecla Ctrl pressionada para desativar temporariamente o ajuste à grade.
-
Continue modificando a forma da sala conforme necessário ou clique com o botão direito ou pressione Esc para parar. A exibição da sala será atualizada de acordo com a nova forma do contorno.
Este comando pode ser usado independentemente de a sala de destino estar bloqueada ou não.
Dividir uma sala
Há comandos disponíveis para slice graficamente um objeto de sala já posicionado em duas ou mais salas separadas. O processo de divisão é semelhante ao posicionamento de uma linha e inclui os mesmos modos de canto (na verdade, a largura do objeto de corte é a largura de linha padrão atual). Observe que os objetos usados para exibir o trajeto de corte não são objetos que estão sendo posicionados; eles são mostrados apenas para exibir esse trajeto e são removidos quando o processo de divisão é concluído. Além disso, não é necessário começar o corte exatamente na borda de uma sala; é mais fácil começar um pouco fora da sala e também terminar um pouco fora dela.
Há dois comandos de divisão disponíveis. O processo de definição do caminho de divisão é o mesmo para ambos; eles diferem na forma como tratam os componentes presentes na room que está sendo dividida. As diferenças entre os comandos são explicadas após a descrição do processo de divisão.
|
Clique com o botão direito em uma room para acessar os comandos Slice no menu Room Actions. Foram definidas duas divisões usando o processo descrito abaixo. Foram criadas três rooms. |
O processo de divisão
Após iniciar um comando Slice:
-
O cursor muda para uma cruz, e é solicitado que você selecione um ponto inicial para a divisão.
-
Posicione o cursor logo fora da room que deseja dividir e clique ou pressione Enter. Agora você está no modo de divisão (essencialmente, o modo de posicionamento de linhas).
-
Mova o cursor para dentro da room para definir a primeira aresta de divisão e clique ou pressione Enter para fixar a extremidade dessa aresta.
-
Continue movendo o cursor e clicando para definir uma série de vértices que determinam a forma da divisão.
-
Após posicionar o último vértice (logo fora da room), clique com o botão direito ou pressione Esc para concluir o posicionamento dessa divisão.
-
Agora você pode iniciar outra divisão da room ou clicar com o botão direito ou pressionar Esc para sair do modo de divisão.
-
Será aberta uma caixa de diálogo de confirmação, informando em quantas rooms a room original será dividida. Clique em Yes para aplicar as divisões feitas ou em No para descartá-las. Os novos objetos room resultantes serão atualizados de acordo, e as regras de definição de room correspondentes serão criadas e associadas.
-
Durante a divisão, pressione:
-
Shift+Spacebar para alternar entre os modos de canto.
-
Spacebar para alternar a direção do canto.
-
Cada aresta de divisão requer um ponto inicial e um ponto final.
-
Se o modo de posicionamento da divisão incluir um canto, pressione o atalho 1 para alternar entre posicionar uma aresta por clique ou duas arestas por clique.
-
Backspace para remover a última aresta de divisão posicionada.
-
Reajuste de uma room existente
Outra abordagem para modificar a forma de uma room existente é instruir o software a reajustar a room ao redor da classe de componentes atribuída a ela. O submenu Room Actions do menu de contexto e o submenu Design » Rooms incluem os três comandos de ajuste de room, conforme mostrado na apresentação de slides.
|
Se você alterar o posicionamento dos componentes em uma room, use um dos três comandos Wrap para atualizar a forma da room. O comando Wrap Non-Orthogonal posiciona as arestas da room de modo a unir os pontos extremos dos contornos dos componentes. O comando Wrap Orthogonal posiciona arestas verticais e horizontais da room ao redor dos contornos dos componentes. O comando Wrap Rectangular posiciona a menor room retangular que engloba os contornos dos componentes. |
Edição no painel Properties
O objeto room é peculiar por ser, ao mesmo tempo, um objeto e uma restrição de projeto.
Edição pelo painel Properties
As propriedades do objeto room, incluindo a localização e a forma no espaço de edição, podem ser editadas no painel Properties quando a room está selecionada. O painel pode ser exibido pelo botão Panels de painéis, no canto inferior direito do espaço de projeto, ou pelo comando View » Panels » Properties.
O painel Properties pode ser usado para editar as propriedades gráficas de uma room.
| Name | O nome atual da room (e da regra de definição de room associada). Ele pode ser alterado conforme necessário. Além de ajudar a identificar cada room, o nome pode ser usado para especificar uma room em uma regra de projeto. |
| (X/Y) (dois campos) | A posição X e Y atual do primeiro vértice da room, em relação à origem atual. Edite o valor no campo para alterar a posição da room em relação à origem atual. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais. As unidades padrão (métricas ou imperiais) são exibidas na barra de status e definidas na região Other do painel Properties (quando não há objetos selecionados no espaço de projeto). Esses valores só podem ser editados se a opção X/Y estiver desbloqueada ( o ícone |
Vértices do contorno |
|
| Vertices Grid | Lista todos os pontos de vértice definidos atualmente para a room, na ordem em que foram definidos durante seu posicionamento. Segmentos de reta são usados para conectar um ponto de vértice ao seguinte. Se preferir uma conexão em arco, insira um valor para o Arc Angle desejado. O valor é inserido no campo associado ao ponto de vértice de origem, e o arco vai desse vértice até o vértice seguinte, abaixo na lista. Clique com o botão direito para Copy / Paste ou Import / Export to CSV. |
| Index | O índice atribuído ao vértice (não editável, baseado na ordem em que os vértices foram posicionados durante a definição da room). |
| X | A coordenada X (horizontal) do vértice. Clique para editar. |
| Y | A coordenada Y (vertical) do vértice. Clique para editar. |
| Arc Angle (Neg = CW) | O ângulo de um arco desenhado para conectar este ponto de vértice ao próximo. Por padrão, as conexões são segmentos de reta e este campo permanece em branco. Clique para editar e insira o ângulo de arco desejado. A inserção de um valor positivo resultará em um arco desenhado no sentido anti-horário. Para desenhar um arco no sentido horário, insira um valor negativo. |
Como trabalhar com rooms
O software inclui diversos recursos para ajudar você a trabalhar com rooms e com os objetos dentro delas. Isso inclui comandos para: organizar as rooms em uma grade; mover as rooms para a grade de ajuste atual; e, em um projeto que inclui seções repetidas de circuitos, copiar o posicionamento e o roteamento de uma room para outra.
Você também pode usar uma room para restringir outras restrições de projeto a uma área da placa, exigindo, por exemplo, que nessa room as redes sejam roteadas com largura e espaçamento específicos, ou que os pares diferenciais sejam roteados com um perfil de impedância específico.
Um mixer de 8 canais: o primeiro canal de entrada foi posicionado e roteado e, em seguida, replicado nos outros sete canais de entrada usando o comando Copy Room Format.
Definição de restrições dentro de uma room
Além de restringir os objetos para que fiquem dentro ou fora de uma room (conforme discutido na seção Restrição de projeto de definição de room), uma room também pode ser usada como restrição de área em outras restrições de projeto. Por exemplo, a restrição de largura de roteamento pode exigir que o roteamento sob um BGA seja criado com larguras diferentes, ou a restrição de espaçamento elétrico pode exigir espaçamentos diferentes em uma área específica da placa.
A largura de roteamento e os espaçamentos são ajustados automaticamente dentro da room, de acordo com as configurações em Room Definition.
Isso é feito adicionando as restrições Routing Width e Electrical Clearance mostradas na apresentação de slides abaixo.
No Constraint Manager
Quando uma restrição de room é adicionada na visualização All Rules do Constraint Manager, esse objeto de room também fica disponível na visualização Physical. Usando essa visualização, você pode definir rapidamente restrições baseadas em área que devem ser aplicadas dentro da room, incluindo: largura de roteamento, espaçamento elétrico, estilo de via de roteamento, propriedades dos pares diferenciais, estreitamento do roteamento e estilo de conexão de polígonos. A apresentação de slides abaixo mostra as restrições para a placa do vídeo acima.
|
Dentro desta room, todos os objetos de roteamento devem ter uma largura dentro do intervalo especificado. Dentro desta room, todos os objetos de roteamento devem manter pelo menos este espaçamento em relação a objetos pertencentes a outras redes. Dentro desta room, todos os objetos de roteamento devem manter pelo menos este espaçamento elétrico. Dentro desta room, todos os pares diferenciais devem ser roteados usando o perfil de impedância |
No PCB Rules and Constraint Editor
Para obter o mesmo resultado no PCB Rules and Constraint Editor, crie uma consulta que defina a área da room. A detecção dos objetos na room pode ser feita de duas maneiras: selecionando objetos que estejam completamente dentro da room (usando a palavra-chave WithinRoom) ou selecionando objetos que toquem a room (usando a palavra-chave TouchesRoom). A apresentação de slides abaixo demonstra as mesmas propriedades de largura de roteamento, espaçamento elétrico, estilo de via de roteamento e pares diferenciais mostradas na apresentação de slides Constraint Manager anterior.
Organização das rooms selecionadas
Para organizar as rooms selecionadas no espaço de projeto, use o comando Design » Rooms » Arrange Rooms. Selecione as rooms desejadas e execute o comando para abrir a caixa de diálogo Arrange Rooms.
A caixa de diálogo Arrange Rooms.
Especifique como deseja organizar as rooms e em que ordem elas devem ser posicionadas. Você também pode especificar a posição inicial — inserindo as coordenadas X-Y na caixa de diálogo ou clicando na área de trabalho — bem como o espaçamento entre rooms adjacentes. Após clicar em OK, as rooms selecionadas serão movidas para suas posições.
Colunas/Linhas |
|
| Columns | O número de colunas usadas para posicionar as rooms. Edite este campo conforme necessário. |
| Rows | O número de linhas usadas para posicionar as rooms. Edite este campo conforme necessário. Se houver mais rooms do que cabe na organização personalizada de linhas e colunas, mais linhas serão adicionadas na parte superior. |
Ordenar por |
|
| SortBy | Exibe a ordem de classificação escolhida, ou seja, os critérios usados para distinguir a primeira room da seguinte. As opções disponíveis são detalhadas abaixo. |
| Channel Name | Ordena as rooms alfanumericamente, com base no nome do canal. Saiba mais sobre projetos multicanais. |
| Room Area | Ordena as rooms com base em sua área. |
| Room Component Count | Ordene as rooms com base no número de componentes que contêm. |
| Room Width | Ordene as rooms pelo tamanho em X (horizontal). |
| Room Height | Ordene as rooms pelo tamanho em Y (vertical). |
| Sort in Ascending order | Habilite para ordenar as rooms em ordem crescente (da menor para a maior), de acordo com os critérios atuais de SortBy. Se esta opção estiver desabilitada, a ordem será decrescente (da maior para a menor). |
Posição |
|
| Origin X | Define a posição X (horizontal) onde começará o posicionamento das rooms. Edite este campo para alterar a coordenada X, que pode ser definida em mm ou mil. Para especificar as unidades ao inserir um número, adicione o sufixo mm ou mil ao valor. As unidades padrão (métricas ou imperiais) são determinadas pela configuração Units no painel Propriedades e são usadas quando nenhuma unidade é especificada. |
| Origin Y | Define a posição Y (vertical) onde começará o posicionamento das rooms. Edite este campo para alterar a coordenada Y, que pode ser definida em mm ou mil. Para especificar as unidades ao inserir um número, adicione o sufixo mm ou mil ao valor. As unidades padrão (métricas ou imperiais) são determinadas pela configuração Units no painel Propriedades e são usadas quando nenhuma unidade é especificada. |
| Select Origin Using Mouse | Se habilitada, será solicitado que você defina manualmente a origem para a organização das rooms. A opção deve estar desabilitada para editar Origin X e Origin Y. |
| X-Spacing | Define a distância X (horizontal) a ser deixada entre rooms adjacentes. |
| Y-Spacing | Define a distância Y (vertical) a ser deixada entre rooms adjacentes. |
| Auto Spacing | Se habilitada, as rooms são organizadas com espaçamentos X (horizontal) e Y (vertical) iguais. A opção deve estar desabilitada para editar X-Spacing e Y-Spacing. |
| Place On Grid | Habilite para forçar a organização das rooms em alinhamento com a grade de ajuste atual da PCB. |
Movendo rooms para a grade
Para mover cada uma das rooms selecionadas para o ponto mais próximo na grade de ajuste atual, use o comando Design » Rooms » Move Rooms to Grid. Após executar o comando, uma caixa de diálogo de confirmação será aberta, perguntando se você deseja mover os objetos junto com as rooms selecionadas. Clique em Yes para mover as rooms e os objetos contidos nelas para o ponto mais próximo na grade de ajuste, ou clique em No para mover apenas as rooms.
Copiando formatos de rooms
Um dos recursos mais poderosos das rooms é a capacidade de copiar a forma, o posicionamento e o roteamento de uma room para outras rooms que contenham um conjunto idêntico de componentes. O comando é particularmente útil durante o layout de um projeto multicanal, permitindo que o posicionamento e o roteamento feitos em um canal sejam propagados para todos os outros canais.
Para copiar o formato de uma room para outras rooms:
-
Clique em Design » Rooms » Copy Room Formats nos menus principais.
-
A barra de status solicitará que você escolha uma room de origem. Posicione o cursor sobre a room de origem e clique ou pressione Enter.
-
A barra de status solicitará que você escolha uma room de destino. Posicione o cursor sobre a room para a qual deseja copiar a formatação e clique ou pressione Enter. Se você pretende aplicar a formatação a várias rooms, esse segundo clique pode ser em qualquer uma delas.
-
A caixa de diálogo Confirm Channel Format Copy será aberta. Use as opções para definir a cópia de formato desejada. Por padrão, a cópia de formato será aplicada de Source Room para Destination Room selecionados. Para copiar da room de origem para cada uma das rooms na classe de canais detectada, habilite a opção Apply to Specified Channels e confirme se as caixas de seleção Copy necessárias estão marcadas para as rooms de destino.
-
Clique em OK na caixa de diálogo para atualizar as rooms de destino.
-
Você pode continuar selecionando outras rooms de destino ou clicar com o botão direito para concluir.
Rooms |
|
| Source Room | O nome da room de origem (que representa o canal do esquemático), cujo posicionamento de componentes e roteamento serão copiados. |
| Destination Room | Este campo contém o nome da room de destino (que representa o canal do esquemático), à qual serão aplicados o posicionamento e o roteamento copiados. Se o projeto for multicanal e os canais de origem e destino pertencerem à mesma classe de canais, a cópia de formato será aplicada aos canais habilitados na região Channel Class da caixa de diálogo Observe que o canal de origem (room) e o canal de destino (room) devem pertencer à mesma classe de canais se você quiser copiar a formatação de um canal de origem (room) para outros canais (rooms). |
Opções |
|
| Copy Component Placement | Copie o posicionamento dos componentes da room de origem para as rooms de destino. |
| Copy Designator and Comment Formatting | Copie o formato do designador e do comentário da room de origem para a room de destino. |
| Copy Routed Nets | Copie o layout do roteamento (trilhas/arcos & vias usados para rotear as redes) da room de origem para a room de destino. |
| Copy Room Size/Shape | Copie a forma da room de origem e aplique-a à room de destino. Se a opção Copy Room Orientation estiver habilitada na caixa de diálogo, a forma da room de destino será alterada em relação ao seu ponto inicial (inferior esquerdo), ou seja, o ponto inferior esquerdo da room de destino permanecerá inalterado. |
| Copy Room Orientation | Copie a orientação da room. O Altium Designer detecta a orientação das rooms (pelo ângulo de rotação do componente com o maior número de pinos ou, se houver mais de um componente com o mesmo número máximo de pinos, pelo componente de maior área) e a utiliza para girar a room de destino. |
| Copy Selected Objects Only | Copie a formatação dos objetos selecionados da room de origem para a room de destino. |
Opções para objetos em contato |
|
| Copy All Objects Touching the Room | Inclua objetos (exceto componentes, trilhas/arcos de roteamento e vias) que estejam total ou parcialmente contidos na sala. Esta opção deve estar habilitada para copiar objetos com e sem rede atribuída, como regiões, polígonos e áreas de exclusão, de uma sala para outra. |
| Exclude NoNet Objects | Exclua objetos que não tenham uma rede atribuída. |
Somente totalmente contidos / Contidos e em contato |
|
| Fully Enclosed Objects Only | Se a opção Copy All Objects Touching the Room estiver habilitada, habilite esta opção para copiar apenas objetos totalmente contidos. |
| Enclosed & Touching Objects | Se a opção Copy All Objects Touching the Room estiver habilitada, habilite esta opção para copiar tanto os objetos contidos quanto os que estejam em contato com a sala. |
Correspondência de componentes entre canais |
|
| Match Components by Channel Offsets | Cada componente de um canal repetido recebe um deslocamento de canal durante a transferência do projeto do esquemático para a PCB. Use o deslocamento de canal para identificar o mesmo componente em cada canal. |
| Match Components by Source Designator | Como alternativa, use o designador de origem (do esquemático) para identificar os componentes correspondentes em cada canal. |
Remover conexões afetadas |
|
| Whole connections | Após o processamento da cópia do formato do canal, o software precisa saber como remover as conexões afetadas. Se esta opção for selecionada, as conexões afetadas dentro e fora da sala serão removidas. |
| Touching parts of connections only | Se esta opção for selecionada, somente as conexões afetadas que tocam a sala serão removidas. |
| Contained parts of connections only | Se esta opção for selecionada, somente as conexões afetadas dentro da sala serão removidas. |
Classe de canais |
|
| Channel Class | Quando um projeto multicanal é transferido do esquemático para a PCB, os circuitos repetidos (canais) são identificados como uma classe de canais na caixa de diálogo Object Class Explorer do editor de PCB Essa classe de canais é usada para identificar a quais canais a cópia do formato deve ser aplicada. Se a região Channel Class da caixa de diálogo estiver vazia, verifique se a classe de canais está definida corretamente na caixa de diálogo Object Class Explorer (Design » Classes). Se nenhuma classe de canais for identificada, o comando de cópia será aplicado apenas da sala de origem para a sala de destino. |
| Channel Members | Esta lista contém os canais, cada um identificado pelo nome de sua sala. Se a sala de origem fizer parte de uma classe de canais definida, a classe e todos os seus membros serão listados. São exibidos a camada (lado da placa em que a sala foi posicionada) e o número de componentes em cada canal. Cada canal inclui uma caixa de seleção usada para controlar se a cópia do formato deve ser aplicada a ele. Essa caixa de seleção fica disponível quando a opção Apply To Specified Channel é habilitada. |
| Apply To Specified Channel | O comportamento padrão é copiar o formato de Source Room para todos os canais da classe de canais à qual a sala de origem (canal) pertence. Quando esta opção é habilitada, a caixa de seleção Copy de cada canal fica disponível, permitindo selecionar quais canais da classe receberão a cópia do formato. |
Ocultar salas
As salas de um determinado documento podem ser exibidas, ocultadas ou exibidas em modo de rascunho globalmente usando as opções da aba View Options do painel Configuração de visualização.
Ajuste o controle deslizante Visibilidade de objetos para Salas para esmaecê-las ou ocultá-las na área de edição.
).

).
)
).
).
).




)
).








).