Trabalhando com trilhas e arcos
Num relance
- Aprenda a posicionar, editar, mover e rerotear segmentos de trilha no editor de PCB usando os principais comandos e atalhos.
- Entenda como o roteamento interativo responde às redes, às camadas, aos modos de canto, à resolução de conflitos e às regras de projeto aplicáveis.
- Veja como a largura de roteamento é determinada e ajustada, incluindo como as preferências e as regras influenciam as larguras que você pode usar.
Trabalhando com trilhas
Um segmento de trilha é uma linha reta com uma largura definida. Use trilhas para definir uma linha reta no espaço de projeto da PCB. As trilhas são inseridas em uma camada de sinal para formar as interconexões elétricas, ou o roteamento, entre os pads dos componentes. As trilhas inseridas em uma camada não elétrica são chamadas de Linhas, sendo usadas como elementos de desenho de uso geral para criar contornos de componentes, informações instrutivas, limites de áreas de exclusão etc. As trilhas também são usadas em objetos de projeto agrupados, como cotas e coordenadas.

Os objetos de trilha são usados para roteamento e para desenhar linhas de uso geral. Há quatro segmentos de trilha inseridos na imagem acima e outro em processo de inserção.
Embora trilhas e linhas sejam, na verdade, o mesmo objeto, a diferença está no comportamento do software durante sua inserção, motivo pelo qual existem comandos diferentes. Quando um comando de inserção de trilha é executado, como Interactive Routing, o software monitora o local do clique e adota automaticamente o nome da rede de um objeto existente (como um pad) nesse local. Ele também monitora e respeita todas as regras de projeto aplicáveis. Quando um comando de inserção de linha é executado (Place » Line), esses comportamentos de monitoramento não ocorrem.
As trilhas podem ser inseridas tanto no editor de PCB quanto no editor de bibliotecas de PCB. Independentemente do comando usado (roteamento/trilha ou inserção de linha), o comportamento básico de inserção é o mesmo. Após iniciar o comando, o cursor mudará para uma cruz e você entrará no modo de inserção de trilhas. A inserção é realizada por meio da seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do primeiro segmento de trilha. Se um comando de inserção do tipo roteamento estiver sendo executado e você clicar em um objeto existente para iniciar a inserção, a trilha adotará o nome da rede desse objeto. Para o roteamento, a largura será determinada pela regra de projeto Largura de roteamento aplicável; isso pode ser substituído por determinadas opções de roteamento interativo, descritas com mais detalhes abaixo.
- Mova o cursor para definir o segmento de trilha e clique ou pressione Enter para fixar o ponto final desse primeiro segmento, que também é o ponto inicial do próximo segmento conectado.
- Continue posicionando o cursor e clicando ou pressionando Enter para fixar uma série de vértices que definem a sequência de segmentos de trilha conectados.
- Clique com o botão direito do mouse ou pressione Esc para encerrar a sequência atual de segmentos de trilha conectados.
Outras ações que podem ser realizadas durante a inserção incluem:
- Pressione a tecla * no teclado numérico para percorrer as camadas de sinal disponíveis. Como alternativa, use a combinação Shift+Ctrl+Wheel Roll para percorrer as camadas de roteamento; cada passo da roda do mouse mudará para a próxima camada de sinal disponível (ou para a anterior).
- Pressione as teclas + e - no teclado numérico para percorrer, para frente e para trás, todas as camadas atualmente visíveis no projeto.
Durante a inserção de segmentos de trilha, há cinco modos de canto disponíveis, quatro dos quais também possuem submodos de direção do canto. Durante a inserção:
- Pressione Shift+Spacebar para percorrer os modos de canto disponíveis.
- Pressione Spacebar para alternar entre os dois submodos de direção do canto.
- Em qualquer um dos modos de canto em arco, mantenha pressionada a tecla , ou . para diminuir ou aumentar o arco. Mantenha a tecla Shift pressionada enquanto pressiona essas teclas para acelerar o redimensionamento do arco.
- Pressione a tecla de atalho 1 para alternar entre inserir um segmento por clique (mostrado nas primeiras cinco imagens abaixo) ou dois segmentos por clique (mostrado na última imagem abaixo). No primeiro modo, o segmento de trilha sem preenchimento é chamado de segmento de antecipação.
- Pressione a tecla Backspace para remover o último vértice.



Pressione Shift+Spacebar para percorrer os cinco modos de canto disponíveis, pressione Spacebar para alternar a direção do canto e pressione o atalho 1 para alternar a inserção entre um ou dois segmentos.
O método de edição gráfica permite selecionar um objeto de trilha já inserido diretamente no espaço de projeto e alterar seu tamanho, formato ou posição graficamente.
Quando um objeto de trilha é selecionado, as seguintes alças de edição ficam disponíveis:
- Clique e arraste A para reposicionar os pontos finais da trilha.
- Clique e arraste B para alterar o formato da trilha.
O editor de PCB inclui algoritmos sofisticados para mover segmentos de trilha na placa de modo que a disposição do roteamento possa ser mantida. Esse deslizamento dos segmentos de trilha pode ser acionado interativamente clicando primeiro para selecionar o segmento e, em seguida, clicando e mantendo o botão pressionado quando o cursor especial aparecer para deslizar o segmento, ou clicando e mantendo o botão pressionado sobre um segmento de trilha e deslizando-o. O comportamento de deslizamento pode ser configurado usando as opções Dragging na página Editor de PCB - Roteamento interativo da caixa de diálogo Preferences. Essas opções permitem atribuir a ação Mover a uma trilha, o que é útil se você quiser mover livremente um segmento de trilha individual.

Controle o comportamento de deslizamento das trilhas com as opções de arraste definidas nas Preferências.
Se a ação Move for atribuída por meio dessas opções, o segmento de trilha poderá ser girado ou espelhado durante a movimentação.
Roteamento interativo e as regras de projeto aplicáveis
Durante o roteamento interativo, o comportamento padrão do software é garantir que os segmentos de trilha sejam inseridos de acordo com as regras de projeto elétricas e de roteamento aplicáveis. Isso significa que o software não permitirá a inserção de um novo segmento de trilha que viole as regras em relação a um segmento de trilha existente pertencente a uma rede diferente; em vez disso, ele limitará o segmento de trilha para atender às regras de projeto. Esse comportamento de roteamento interativo é conhecido como modo Routing Conflict Resolution. O modo padrão é Stop at First Obstacle (o modo atual é exibido na barra de status). Pressione Shift+R para percorrer os modos disponíveis.
O termo applicable design rules significa todas as regras que se aplicam ao objeto que está sendo inserido. O mecanismo de regras de projeto funciona com um sistema no qual você define exatamente a quais objetos deseja aplicar cada regra. Durante a inserção, o mecanismo de regras de projeto é consultado para determinar a regra de maior prioridade aplicável à situação atual de inserção. As regras aplicáveis durante o roteamento interativo incluem:
- Distância de isolamento elétrico
- Largura de roteamento
- Estilo de via de roteamento
A animação abaixo demonstra o roteamento em ação. A rede GND está sendo roteada de acordo com uma regra de projeto de Largura de roteamento definida e aplicável. Observe que, quando o cursor é movido sobre a via associada à rede +12V, o traçado é automaticamente limitado para garantir o cumprimento da regra de projeto Restrição de distância de isolamento elétrico aplicável.

As regras de projeto aplicáveis de largura de roteamento e distância de isolamento são respeitadas automaticamente durante o roteamento interativo.
Como a largura de roteamento é determinada
A menos que o mecanismo de regras esteja desativado, o comportamento prioritário do software é sempre garantir que a largura de roteamento esteja dentro do intervalo permitido pela regra de projeto de Largura de Roteamento aplicável. Uma abordagem comum é permitir o uso de um intervalo de larguras para uma rede para oferecer flexibilidade ao acomodar o roteamento sem deixar de atender aos requisitos de condução de corrente dessa rede. Para isso, a regra de projeto de Largura de Roteamento possui as configurações Min, Preferred e Max no Editor de Regras e Restrições da PCB, que podem ser configuradas para permitir um intervalo de larguras ou definidas com o mesmo valor para exigir uma largura específica. A largura também pode ser configurada com base em uma impedância e pode ter um intervalo diferente especificado para cada camada de sinal.

A regra de projeto padrão de Largura de Roteamento é aplicada a todas as redes de uma nova PCB.
Como projetista, você dispõe de várias opções que ajudam a selecionar a largura de roteamento mais adequada ao iniciar o roteamento. Essas opções são configuradas na página Editor de PCB — Roteamento Interativo da caixa de diálogo Preferences, conforme mostrado abaixo.

As opções Interactive Routing Width Sources determinam qual largura é usada quando você inicia um roteamento.
Observe que Track Width Mode está definido como Rule Preferred na imagem. Isso indica que, quando o roteamento começa em um objeto de uma rede existente, como um pad, essa é a largura que será usada. No entanto, se o roteamento começar em uma trilha existente, a opção Pickup Track Width From Existing Routes substituirá Track Width Mode e definirá a nova largura para corresponder à largura existente.
Como projetista, você também pode pressionar o atalho Shift+W durante o roteamento para acessar uma caixa de diálogo na qual é possível selecionar uma largura diferente, ou pressionar Tab para abrir Properties panel e inserir um novo valor de Width . O valor escolhido ou inserido deve estar entre as configurações Min e Max definidas na regra aplicável. Caso contrário, ele será automaticamente ajustado para o limite mais próximo.
Atalhos de Roteamento Interativo
Durante o roteamento, há vários atalhos disponíveis. Por exemplo, você pode pressionar Shift+R para alternar entre os modos de resolução de conflitos disponíveis ou pressionar Backspace para excluir o último vértice (canto) colocado. Para exibir uma lista de atalhos durante o roteamento, pressione Shift+F1. Um menu de atalhos interativos disponíveis será exibido; selecione o atalho desejado ou pressione Esc para fechar o menu e usar a sequência de teclas do atalho.

Durante o roteamento interativo, pressione Shift+F1 para exibir um menu de atalhos interativos disponíveis
Movendo uma Trilha
O submenu Edit » Move e o menu de comandos de movimentação em Active Bar incluem vários comandos que podem ser usados para alterar a posição ou a forma de uma trilha.
Refazer Roteamento
Este comando permite refazer manualmente o roteamento de uma trilha existente na placa. Após iniciar o comando, o cursor mudará para uma mira e você será solicitado a escolher uma trilha. Posicione o cursor sobre a trilha desejada e clique ou pressione Enter. O funcionamento desse recurso depende de a opção Preserve Angle When Dragging estar ou não habilitada na página Editor de PCB - Roteamento Interativo da caixa de diálogo Preferences:
- Preserve Angle Dragging enabled - a trilha será dividida com a adição de um novo segmento para manter as conexões ortogonais/diagonais. Mova o cursor para deslizar esse segmento conforme necessário e clique para posicioná-lo. Clique com o botão direito ou pressione Esc nesse ponto; caso contrário, esse novo segmento será dividido com a adição de mais um segmento. Use o atalho de teclado Shift+R para alternar entre as opções que controlam como os obstáculos devem ser tratados durante o arraste (Ignore Obstacles, Avoid Obstacles ou Avoid Obstacles (Snap Grid)). Se um dos modos Evitar Obstáculos estiver habilitado, as regras serão respeitadas durante o arraste, impedindo que você arraste um segmento para uma posição que cause uma violação.
- Preserve Angle Dragging disabled - ambas as extremidades do segmento de trilha ficarão fixas, e você poderá colocar novos segmentos de trilha entre elas. Clique ou pressione Enter para colocar um novo segmento de trilha. Continue colocando novos segmentos de trilha para refazer o roteamento ou clique com o botão direito ou pressione Esc para parar.
Continue refazendo o roteamento de outras trilhas ou clique com o botão direito ou pressione Esc para sair.
Dividir Trilha
Este comando permite criar um vértice (ou uma divisão) em um segmento de trilha. Após iniciar o comando, o cursor mudará para uma mira e você será solicitado a selecionar uma trilha. Posicione o cursor sobre o segmento de trilha desejado, no ponto específico em que deseja inserir uma divisão, e clique ou pressione Enter. Um vértice será inserido, dividindo efetivamente o segmento original em dois.
Mova o vértice para a posição desejada e clique ou pressione Enter para posicioná-lo. Os segmentos de trilha conectados se comportam de acordo com a configuração da opção Preserve Angle When Dragging na página Editor de PCB - Roteamento Interativo da caixa de diálogo Preferences:
- Preserve Angle When Dragging habilitada - os ângulos em relação aos segmentos de trilha adjacentes são preservados, mantendo o estilo de roteamento.
- Preserve Angle When Dragging desabilitada - os dois segmentos de trilha individuais se ajustarão elasticamente para acomodar o movimento sem manter o estilo de roteamento existente.
Continue dividindo outros segmentos de trilha ou clique com o botão direito ou pressione Esc para sair.
Arrastar Extremidade da Trilha
Este comando permite reposicionar manualmente ou arrastar a extremidade de um segmento de trilha roteado. Após iniciar o comando, o cursor mudará para uma mira e você será solicitado a selecionar um objeto. Posicione o cursor sobre uma trilha e clique ou pressione Enter. O cursor irá para a extremidade mais próxima do segmento de trilha, e essa extremidade ficará presa ao cursor. Mova a extremidade da trilha para a posição desejada e clique ou pressione Enter para posicioná-la.
- Se a extremidade do segmento de trilha escolhido for um vértice ao qual nenhum outro segmento de trilha está conectado, mova o vértice para a posição desejada.
- Se a extremidade do segmento de trilha escolhido for um vértice ao qual dois segmentos de trilha estão conectados, os segmentos conectados se ajustarão elasticamente à medida que o vértice for movido.
- Se a extremidade do segmento de trilha estiver conectada a um pad de componente, movê-la a desconectará do pad. Após reposicionar a extremidade, uma linha de conexão lógica será exibida entre a extremidade da trilha e o pad, desde que a opção Smart Track Ends esteja habilitada na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Se a extremidade do segmento de trilha estiver conectada a um pad livre, o pad ficará preso ao cursor para ser reposicionado. Todas as trilhas conectadas ao pad se ajustarão elasticamente de acordo com o movimento.
- Se a extremidade do segmento de trilha estiver conectada a uma via, a via ficará presa ao cursor para ser reposicionada. Todas as trilhas conectadas à via se ajustarão elasticamente de acordo com o movimento.
Continue arrastando outras extremidades de trilhas ou clique com o botão direito ou pressione Esc para sair.
Mover / Redimensionar trilhas
Este comando é usado para mover as extremidades de vários segmentos de trilha selecionados, redimensionando-os. Após iniciar o comando, o cursor mudará para uma cruz e você deverá escolher uma extremidade de trilha. Para mover/redimensionar as trilhas:
- Posicione o cursor sobre a extremidade de um dos segmentos selecionados e clique ou pressione Enter.
- Mova o cursor; todos os segmentos de trilha selecionados serão redimensionados dinamicamente mantendo as distâncias e os ângulos originais entre si. A outra extremidade de cada segmento se ajustará elasticamente para manter sua conexão/localização existente.
- Quando os segmentos estiverem na posição desejada, clique ou pressione Enter para confirmar o posicionamento e sair do modo de movimentação.
- Para cancelar a operação, clique com o botão direito ou pressione Esc.
Ao mover os segmentos, os seguintes controles adicionais estão disponíveis:
- Pressione a tecla Tab para alternar a posição do cursor entre as extremidades de cada segmento de trilha selecionado.
- Mantenha a tecla Alt pressionada durante o movimento para restringi-lo a uma direção específica conforme a direção inicial do movimento. São possíveis direções horizontais, verticais e em ângulo de 45 graus.
- Pressione Spacebar duas vezes para alinhar rapidamente todas as extremidades dos segmentos de trilha entre si no plano horizontal ou vertical. Pressione Spacebar duas vezes rapidamente de novo para retornar ao dimensionamento anterior.
Cortar trilhas
A ferramenta de corte de trilhas oferece um mecanismo simples para dividir um ou mais segmentos de trilha em dois e pode cortar trilhas na camada de sinal atual ou em todas as camadas de sinal visíveis. Para acessar a ferramenta, escolha o comando Edit » Slice Tracks nos menus principais.
Após iniciar o comando, o cursor mudará para uma cruz e você deverá escolher um ponto inicial para o corte. Além disso, um filtro será aplicado para exibir apenas objetos de trilha na área de trabalho. Serão exibidas todas as trilhas de todas as camadas de sinal visíveis ou apenas as trilhas da camada de sinal atual, dependendo da configuração ativa da ferramenta de corte de trilhas. Para cortar uma ou mais trilhas:
- Posicione o cursor e clique ou pressione Enter para fixar o ponto inicial do corte.
- Mova o cursor sobre o ponto da trilha, ou das trilhas, onde deseja realizar o corte — o caminho da ferramenta de corte é indicado por uma linha com os possíveis cortes representados visualmente.
- Clique ou pressione Enter para fixar o ponto final do trajeto da ferramenta de corte.
- Continue cortando outros segmentos de trilha ou clique com o botão direito ou pressione Esc para sair do modo de corte.
As ações adicionais que podem ser realizadas — após escolher o ponto inicial de ancoragem do corte e durante o movimento da “linha de corte” — são:
- Pressione a tecla B para alternar entre cortar trilhas apenas na camada de sinal atual ou em todas as camadas de sinal visíveis.
- Pressione Spacebar para alternar o ângulo de corte entre incrementos de 45 graus ou qualquer ângulo.
- Pressione a tecla N para alternar o lado da lâmina de corte entre Esquerda, Direita e Centro.
- Pressione a tecla / para selecionar todas as trilhas cortadas.
- Pressione a tecla "," para selecionar as trilhas cortadas à esquerda da ferramenta de corte.
- Pressione a tecla "." para selecionar as trilhas cortadas à direita da ferramenta de corte.
- Pressione a tecla M para que nenhuma trilha cortada fique selecionada.
-
Pressione a tecla Tab para acessar a caixa de diálogo Slicer Properties, na qual as propriedades da ferramenta de corte de trilhas podem ser alteradas durante a operação.

A caixa de diálogo Slicer Properties
Conversão de trilhas em um caminho chanfrado
O chanfro de cantos de roteamento de 90 graus é uma técnica usada para reduzir as reflexões causadas pelo canto em uma trilha que opera em frequências de micro-ondas. É possível usar arcos, mas eles devem ter um raio de pelo menos 3 vezes a largura da trilha. O chanfro (também chamado de corte em meia-esquadria) é uma alternativa na qual a ponta externa do canto é cortada. Como os objetos de trilha do Altium Designer têm extremidades arredondadas, eles não podem ser usados para criar um canto chanfrado. Para criar o canto chanfrado, os segmentos de trilha selecionados são substituídos por objetos de região.
Selecione todos os segmentos de trilha a serem chanfrados e, em seguida, selecione o comando Tools » Convert » Convert Selected Tracks to Chamfered Path nos menus principais. A caixa de diálogo Convert Tracks to Chamfered Path será aberta. Use esta caixa de diálogo para configurar o chanfro e clique em OK. Cada par de segmentos de trilha selecionados (com ângulos indesejados de 90 graus) será substituído por um canto chanfrado, e os segmentos de trilha originais de cada par serão convertidos em um único objeto de região sólida (de cobre).

As trilhas selecionadas serão chanfradas na medida especificada em cada canto de ângulo reto.
Use as seguintes opções na caixa de diálogo para configurar o chanfro:
- Chamfer - porção do canto externo que será cortada, ou chanfrada, expressa como uma porcentagem da distância diagonal existente do canto.
- Inside Chamfer - quantidade de material a ser adicionada ao canto interno como uma porcentagem da distância diagonal existente do canto.
How big should the Chamfer be?
A porcentagem de chanfro é a fração removida da diagonal entre os cantos interno e externo da curva sem chanfro.
O chanfro ideal para uma ampla variedade de geometrias de microfita foi determinado experimentalmente por Douville e James. Eles constataram que uma boa aproximação para a porcentagem ideal de chanfro é dada por
Sujeita a
e com a constante dielétrica do substrato
.
Esta fórmula é totalmente independente de
. A faixa real de parâmetros para a qual Douville e James apresentam evidências é
e
. Eles relatam uma ROE (VSWR) melhor que 1,1 (ou seja, uma perda de retorno melhor que −26 dB) para qualquer porcentagem de chanfro que esteja dentro de 4% (do
original) do valor fornecido pela fórmula. No valor mínimo de
de 0,25, a porcentagem de chanfro é de 98,4%, de modo que a faixa é quase totalmente cortada.
Propriedades da trilha

O modo Track do painel Properties.
Informações da rede
Esta região fornece informações sobre a rede à qual a trilha pertence, bem como sobre o par diferencial e/ou xSignal, caso essa rede faça parte deles. As informações de classe são exibidas quando pertinente. Os valores de Delay, Length, Max Current e Resistance também são fornecidos.
Consulte a página Técnicas de posicionamento e edição de PCB para saber mais sobre as informações da rede.
Localização
-
(X/Y)
- X (primeiro campo) – a coordenada X (horizontal) atual do ponto de referência da trilha em relação à origem atual do espaço de projeto. Edite para alterar a posição X da trilha. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Y (segundo campo) – a coordenada Y (vertical) atual do ponto de referência da trilha em relação à origem atual. Edite para alterar a posição Y da trilha. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
Propriedades
- Component – este campo é exibido no editor de PCB somente quando a trilha selecionada faz parte de um componente de PCB e mostra o designador do componente de PCB ao qual ela pertence. Selecione o link clicável Component para abrir o modo Component do painel Properties para esse componente.
- Net – use para escolher uma rede para a trilha. Todas as redes do projeto de placa ativo serão exibidas na lista suspensa. Observe que, se o posicionamento do objeto começar no mesmo local de um objeto existente que já esteja conectado a uma rede, a propriedade Net do novo objeto será automaticamente atribuída a essa rede. Selecione No Net para especificar que a trilha não está conectada a nenhuma rede. A propriedade Net de uma primitiva é usada pelo verificador de regras de projeto para determinar se um objeto de PCB está posicionado de acordo com as regras. Como alternativa, você pode clicar no ícone Assign Net para escolher um objeto no espaço de projeto — a rede desse objeto será atribuída às trilhas selecionadas.
- Layer – use a lista suspensa para selecionar a camada na qual a trilha está localizada.
- Width – exibe a largura atual da trilha. Edite este campo para alterar a largura da trilha dentro da faixa de 0,001 mil a 10000 mil.
- Start (X/Y) – exibe a coordenada X/Y atual do ponto inicial da trilha em relação à origem atual.
- End (X/Y) – exibe a coordenada X/Y atual do ponto final da trilha em relação à origem atual.
-
Length – exibe o comprimento atual da trilha. Edite este campo para alterar o comprimento da trilha dentro da faixa de 0,001 mil a 10000 mil.
Expansão da máscara de pasta
- Rule/Manual – selecione a configuração desejada para a expansão da máscara de pasta. Selecione Rule para que a expansão da máscara de pasta da trilha siga o valor definido na regra de projeto Expansão da máscara de pasta aplicável. Selecione Manual para substituir a regra de projeto aplicável e especificar o valor de expansão da máscara de pasta da trilha. Em seguida, você poderá habilitar e inserir a medida desejada.
Expansão da máscara de solda
- Rule/Manual – selecione a configuração desejada para a expansão da máscara de solda. Selecione Rule para que a expansão da máscara de solda da trilha siga o valor definido na regra de projeto Expansão da máscara de solda aplicável. Selecione Manual para substituir a regra de projeto aplicável e especificar o valor de expansão da máscara de solda da trilha. Em seguida, você poderá habilitar e inserir a medida desejada.
Trabalhando com arcos
Um arco é um objeto primitivo de projeto. Essencialmente, é um segmento circular de trilha que pode ser colocado em qualquer camada. Os arcos podem ter diversas aplicações no layout de PCB. Por exemplo, podem ser usados para definir contornos de componentes nas camadas de serigrafia ou, em uma camada mecânica, para indicar o contorno da placa, as bordas de recortes e assim por diante. Também podem ser usados para criar trajetos curvos durante o roteamento interativo. Os arcos podem ser abertos ou fechados para criar um círculo (frequentemente chamado de arco de círculo completo).

Dois arcos posicionados; à esquerda, um arco de círculo completo e, à direita, um arco selecionado para edição.
Os arcos estão disponíveis para posicionamento tanto no Editor de PCB quanto no Editor de bibliotecas de PCB. Há quatro modos de posicionamento de arco disponíveis (Centro, Borda, Qualquer ângulo e Círculo completo). A forma de posicionar um arco depende do método de posicionamento que você escolheu:
-
Place arc by center – este método permite posicionar um objeto de arco usando o centro do arco como ponto inicial.
Após executar o comando, o cursor mudará para uma cruz e você entrará no modo de posicionamento de arco. O posicionamento é realizado pela seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto central do arco.
- Mova o cursor para ajustar o raio do arco e, em seguida, clique ou pressione Enter para defini-lo.
- Mova o cursor para ajustar o ponto inicial do arco e, em seguida, clique ou pressione Enter para fixá-lo.
- Mova o cursor para alterar a posição do ponto final do arco e, em seguida, clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco.
- Continue posicionando outros arcos ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
-
Place arc by edge – este método permite posicionar um objeto de arco usando a borda do arco como ponto inicial. O ângulo do arco é fixado em 90°.
Após executar o comando, o cursor mudará para uma cruz e você entrará no modo de posicionamento de arco. O posicionamento é realizado pela seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do arco.
- Mova o cursor para alterar a posição do ponto final do arco e, em seguida, clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco.
- Continue posicionando outros arcos ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
-
Place arc by edge (any angle) – este método permite posicionar um objeto de arco usando a borda do arco como ponto inicial. O ângulo do arco pode ter qualquer valor.
Após executar o comando, o cursor mudará para uma cruz e você entrará no modo de posicionamento de arco. O posicionamento é realizado pela seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do arco.
- Mova o cursor para ajustar o raio do arco e, em seguida, clique ou pressione Enter para fixar o ponto central.
- Mova o cursor para alterar a posição do ponto final do arco e, em seguida, clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco.
- Continue posicionando outros arcos ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
-
Place full circle arc – este método permite posicionar um arco de 360° (círculo completo).
Após executar o comando, o cursor mudará para uma cruz e você entrará no modo de posicionamento de arco. O posicionamento é realizado pela seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto central do arco.
- Mova o cursor para ajustar o raio do arco e, em seguida, clique ou pressione Enter para defini-lo e concluir o posicionamento do arco.
- Continue posicionando outros arcos ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Outras ações que podem ser realizadas durante o posicionamento:
- Para todos os métodos (exceto arcos de círculo completo), pressione Spacebar antes de definir o ponto final do arco para desenhar o arco no sentido oposto.
- Pressione a tecla L para inverter o arco para o outro lado da placa – observe que isso só é possível antes de fixar o ponto inicial ou central do arco.
- Pressione as teclas + e - (no teclado numérico) ou use os atalhos Shift+Ctrl+Wheelroll para percorrer, para a frente e para trás, todas as camadas visíveis do projeto e mudar rapidamente a camada de posicionamento.
O método de edição gráfica permite selecionar um objeto de arco posicionado diretamente no espaço de projeto e alterar graficamente seu tamanho, formato ou localização.
Quando um objeto de arco é selecionado, as seguintes alças de edição ficam disponíveis:

Um arco selecionado
- Clique e arraste A para ajustar o raio.
- Clique e arraste B para ajustar os pontos das extremidades (ângulos inicial e final).
-
Clique em qualquer ponto do arco longe das alças de edição e, em seguida, arraste para reposicioná-lo. Como alternativa, clique e arraste o ponto central do arco. Durante o arraste, o arco pode ser girado ou espelhado:
- Pressione Spacebar para girar o arco no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor de Rotation Step, definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione as teclas X ou Y para espelhar o arco em relação ao eixo X ou Y.
Propriedades do arco
Informações da rede
Esta região fornece informações sobre a rede à qual o arco pertence, bem como sobre o par diferencial e/ou xSignal, caso essa rede faça parte deles. As informações de classe são exibidas quando aplicável. Também são fornecidos os valores de Delay, Length, Max Current e Resistance.
Consulte a página Técnicas de posicionamento e edição de PCB para saber mais sobre as informações da rede.
Localização
-
(X/Y)
- X (primeiro campo) - este campo mostra a posição X atual do centro do arco em relação à origem atual. Edite o valor no campo para alterar a posição do arco em relação à origem atual. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais. As unidades padrão (métricas ou imperiais) são determinadas pela configuração Units na região Other do painel Properties no modo Board (acessado quando nenhum objeto está selecionado no espaço de projeto) e são usadas se a unidade não for especificada.
- Y (segundo campo) - este campo mostra a posição Y atual do centro do arco em relação à origem atual. Edite o valor no campo para alterar a posição do arco em relação à origem atual. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais. As unidades padrão (métricas ou imperiais) são determinadas pela configuração Units na região Other do painel Properties no modo Board (acessado quando nenhum objeto está selecionado no espaço de projeto) e são usadas se a unidade não for especificada.
Propriedades
- Component – este campo é exibido no editor de PCB somente quando o arco selecionado faz parte de um componente de PCB e mostra o designador do componente de PCB ao qual pertence. Selecione o link clicável Component para abrir o modo Componente do painel Propriedades para esse componente.
- Net – use para escolher uma rede para o arco. Todas as redes do projeto de placa ativo serão exibidas na lista suspensa. Observe que, se o posicionamento do objeto começar no mesmo local de um objeto existente que já esteja conectado a uma rede, a propriedade Net do novo objeto será automaticamente atribuída a essa rede. Selecione No Net para especificar que o arco não está conectado a nenhuma rede. A propriedade Net de uma primitiva é usada pelo Verificador de Regras de Projeto para determinar se um objeto de PCB está posicionado de acordo com as regras. Como alternativa, você pode clicar no ícone Assign Net para escolher um objeto no espaço de projeto — a rede desse objeto será atribuída aos arcos selecionados.
- Layer - este campo exibe a camada à qual o arco está atribuído atualmente. Os arcos podem ser atribuídos a qualquer camada disponível. Para alterar a camada atribuída, clique no campo e selecione uma camada na lista suspensa.
- Width - este campo exibe a largura da linha do arco. Insira um valor diferente para a largura, se necessário.
- Radius - este campo exibe o raio do arco, medido do ponto central até o centro da linha do arco. Insira um valor diferente para o raio, se necessário.
- Start Angle - este campo exibe o ângulo inicial do arco, medido a partir do eixo X no primeiro quadrante (geometria plana). Insira um valor diferente para o ângulo inicial, se necessário.
- End Angle - este campo exibe o ângulo final do arco. Insira um valor diferente para o ângulo final, se necessário.
- Propagation Delay - este campo exibe o tempo que um sinal leva para se propagar ao longo dessa rota.
Expansão da máscara de pasta
- Rule - selecione para que a expansão da máscara de pasta do arco siga o valor definido na regra de projeto Expansão da máscara de pasta aplicável. O valor de expansão associado será desabilitado se esta opção for escolhida.
- Manual - selecione para substituir a regra de projeto aplicável e especificar o valor de expansão da máscara de pasta do arco no campo abaixo.
Expansão da máscara de solda
- Rule - marque a caixa de seleção para que a expansão da máscara de solda do arco siga o valor definido na regra de projeto Expansão da máscara de solda aplicável. O valor de expansão associado será desabilitado se esta opção for escolhida.
- Manual - marque a caixa de seleção para substituir a regra de projeto aplicável e especificar o valor de expansão da máscara de solda do arco no campo abaixo.
Contornando objetos selecionados com trilhas e arcos
O comando Tools » Outline Selected Objects dos menus principais pode ser usado para inserir um contorno de trilhas e arcos ao redor das primitivas livres selecionadas no projeto. Esse recurso pode ser particularmente útil se você quiser isolar eletricamente redes críticas conectando o contorno a um ponto de terra. Após executar o comando, os objetos serão contornados com trilhas e/ou arcos. As trilhas e os arcos do contorno são inseridos com uma largura de 8 mil e a propriedade Net definida como No Net.
As regras de projeto de espaçamento, largura e curto-circuito do projeto são respeitadas, portanto as violações de espaçamento serão sinalizadas pelo Verificador de Regras de Projeto.
Trabalhando com retângulos
Um retângulo pode ser inserido em qualquer camada. Retângulos de tamanhos variados podem ser combinados para cobrir áreas de formato irregular e também podem ser combinados com segmentos de trilha ou arco.
Os retângulos também podem ser inseridos em camadas não elétricas. Por exemplo, insira um retângulo na camada Keep-Out para definir uma área proibida para o roteamento automático. Insira um retângulo em uma camada de plano de alimentação, máscara de solda ou máscara de pasta para criar uma área vazia nessa camada.

Um retângulo inserido
Os retângulos podem ser inseridos tanto no editor de PCB quanto no editor de bibliotecas de PCB das seguintes maneiras:
- Editor de PCB - estão disponíveis os seguintes métodos de acesso:
- Escolha Place » Rectangle nos menus principais.
- Clique no botão Rectangle no menu suspenso da Active Bar localizada na parte superior da área de projeto. (Clique e mantenha pressionado um botão Active Bar para acessar outros comandos relacionados. Depois que um comando for usado, ele se tornará o primeiro item dessa seção da Active Bar.)
- Clique com o botão direito na área de projeto e clique em Place » Rectangle no menu de contexto.
-
Editor de Bibliotecas de PCB - estão disponíveis os seguintes métodos de acesso:
- Escolha Place » Rectangle nos menus principais.
- Clique no botão Rectangle no menu suspenso da Active Bar localizada na parte superior da área de projeto. (Clique e mantenha pressionado um botão Active Bar para acessar outros comandos relacionados. Depois que um comando for usado, ele se tornará o primeiro item dessa seção da Active Bar.)
- Clique com o botão direito na área de projeto e selecione Place » Rectangle no menu de contexto.
Após iniciar o comando, o cursor mudará para uma mira e você entrará no modo de posicionamento de retângulos. O posicionamento é realizado por meio da seguinte sequência de ações:
- Clique ou pressione Enter para fixar o primeiro canto do retângulo.
- Mova o cursor para ajustar o tamanho do retângulo e clique ou pressione Enter para fixar o canto diagonalmente oposto e concluir o posicionamento do retângulo.
- Continue posicionando outros retângulos ou clique com o botão direito ou pressione Esc para sair do modo de posicionamento.
Outras ações que podem ser realizadas durante o posicionamento:
- Pressione a tecla Tab para pausar o posicionamento e acessar o modo Retângulo do painel Properties , no qual suas propriedades podem ser alteradas em tempo real. Clique no botão de pausa sobreposto à área de projeto para retomar o posicionamento.
- Pressione a Barra de espaço para alternar entre os vários modos de canto. Selecione Rectangle para cantos retos, Fillet para cantos arredondados ou Chamfer para cantos inclinados/angulados.
- Pressione as teclas + e - (no teclado numérico) para percorrer, para frente e para trás, todas as camadas visíveis do projeto e alterar rapidamente a camada de posicionamento.
- Pressione e mantenha pressionada a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
O método de edição gráfica permite selecionar um objeto retângulo posicionado diretamente na área de projeto e alterar graficamente seu tamanho, sua forma ou sua localização.
Quando um objeto retângulo é selecionado, ficam disponíveis as seguintes alças de edição.
Um retângulo selecionado
- Clique e arraste os cantos (A) para redimensionar o retângulo nas direções vertical e horizontal simultaneamente.
- Clique e arraste os centros dos lados (B) para redimensionar o retângulo nas direções vertical e horizontal separadamente.
-
Clique em qualquer ponto do retângulo distante das alças de edição e arraste para reposicioná-lo. Durante o arraste, o retângulo pode ser girado ou espelhado:
- Pressione Spacebar para girar o retângulo no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor de Rotation Step definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione as teclas X ou Y para espelhar o retângulo ao longo do eixo X ou Y.
Propriedades do Retângulo

O modo Rectangle do painel Properties.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do retângulo, relativa à origem atual da área de projeto. Edite para alterar a posição X do retângulo. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) - a coordenada Y (vertical) atual do ponto de referência do retângulo, relativa à origem atual. Edite para alterar a posição Y do preenchimento. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Rotation - o ângulo de rotação do retângulo (em graus), medido no sentido anti-horário a partir de zero (a 3 o'clock horizontal). Edite para alterar a rotação do retângulo. A resolução angular mínima é de 0,001°.
Propriedades
-
Corner Mode - use o menu suspenso para selecionar o modo de canto desejado para o retângulo entre as seguintes opções:
- Rectangle - especifica que o retângulo posicionado terá cantos retos.
- Fillet - especifica que o retângulo posicionado terá cantos arredondados.
- Chamfer - especifica que o retângulo posicionado terá cantos inclinados ou angulados.
- Track Width - exibe a largura atual da trilha. Edite este campo para alterar a largura da trilha no intervalo de 0,001mil a 10000mil.
- Fillet/Chamfer Size - esta opção está disponível apenas quando Fillet ou Chamfer é selecionado no menu suspenso Corner Mode ou se o modo de arredondamento ou chanfro foi escolhido durante o posicionamento.
- Layer - a camada à qual o retângulo está atualmente atribuído. Retângulos podem ser atribuídos a qualquer camada disponível. Use o menu suspenso para selecionar outra camada.
- Width - exibe a largura (eixo X) do Retângulo selecionado.
- Height - exibe a altura (eixo Y) do Retângulo selecionado.
-
- clique neste ícone para manter a proporção existente entre X e Y do retângulo.

