Utilisation des couches mécaniques
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez quand utiliser une couche mécanique individuelle plutôt qu’une paire de couches de composants, notamment pour les informations qui concernent une seule face ou les deux faces de la carte.
- Apprenez à ajouter, configurer et gérer les couches mécaniques dans le panneau View Configuration, notamment leurs noms, leurs numéros, leur visibilité et leurs types.
- Comprenez comment les types de couches prédéfinis et les paramètres des bibliothèques de PCB influencent la création automatique et la correspondance des couches dans votre conception de carte.
Même la carte la plus simple nécessite des détails de conception au-delà des pistes et des pastilles qui constituent le circuit. Il peut s’agir des dimensions de la carte, de détails de fabrication, des zones d’encombrement des composants ou encore de leurs modèles 3D. Dans Altium Designer, ces informations complémentaires sont définies sur les couches mécaniques.
Couches mécaniques et paires de couches de composants
Si les informations à inclure sur une couche mécanique ne concernent pas une face particulière de la carte, par exemple des notes de fabrication détaillant l’ordre des couches, un individual mechanical layer est ajouté.
Si les informations sont nécessaires sur les deux faces de la carte, par exemple les zones d’encombrement des composants, deux couches mécaniques sont attribuées : l’une contient les détails de la zone d’encombrement lorsque le composant est placé sur la face supérieure de la carte ; l’autre contient l’image miroir de cette même zone lorsque le composant est retourné sur la face inférieure de la carte. Dans ce cas, une paire de couches mécaniques est ajoutée en tant que Component Layer Pair. Lorsque des couches mécaniques sont ajoutées en tant que paire de couches de composants, elles s’affichent dans la section Component Layer Pairs du panneau View Configuration, comme illustré ci-dessous. Les Mechanical Layers individuelles apparaissent en dessous.

Plusieurs paires de couches de composants définies par l’utilisateur ont été ajoutées.
| Display of Layer Pairs | Dans l’espace de conception, les deux couches d’une paire de couches de composants s’affichent dans des onglets de couche distincts, avec les noms Top <LayerPairName> et Bottom <LayerPairName> |
| In the Library editor | Dans l’éditeur de bibliothèques PCB, les objets de conception supplémentaires nécessaires à l’empreinte d’un composant sont placés sur la couche supérieure de la paire de couches de composants. Lorsque le composant est retourné sur la face inférieure de la carte pendant le routage du PCB (raccourci L pendant le déplacement d’un composant), le contenu de la couche supérieure de la paire est automatiquement reproduit en miroir sur la couche inférieure. |
| Automatic layer creation | Si un type de couche est attribué à une couche mécanique ou à une paire de couches de composants définie dans la bibliothèque PCB, cette couche mécanique ou cette paire de couches est automatiquement créée sur le PCB lorsqu’un composant utilisant ces couches est placé. Si le PCB possède déjà une couche mécanique ou une paire de couches de ce type, le contenu de ces couches est associé aux couches correspondantes. |
| Layers without a Layer Type |
Pour les couches mécaniques ou les paires de couches définies dans la bibliothèque PCB auxquelles aucun type de couche n’est attribué, des couches mécaniques individuelles sont créées sur le PCB. Dans ce cas, prédéfinissez la couche mécanique ou la paire de couches sur le PCB en utilisant les mêmes numéros de couche avant de placer le composant, car le logiciel utilise la correspondance par numéro de couche s’il ne parvient pas à établir une correspondance par type de couche. |
Ajout de couches mécaniques à la conception
Les couches mécaniques sont ajoutées, modifiées et supprimées dans le panneau View Configuration, comme illustré ci-dessous. Leur visibilité et leur couleur sont également configurées dans ce panneau. Utilisez le bouton
en bas à droite de l’espace de conception, puis sélectionnez View Configuration, ou appuyez sur la touche de raccourci L pour afficher le panneau.
Faites un clic droit n’importe où dans la zone Layers du panneau pour afficher le menu contextuel, qui propose les commandes Add Component Layer Pair (une paire de couches mécaniques) et Add Mechanical Layer (une couche mécanique individuelle).
Les couches mécaniques individuelles ou les paires de couches mécaniques sont ajoutées à l’aide du menu contextuel du panneau View Configuration.
Ajout d’une couche mécanique individuelle
Lorsque vous sélectionnez la commande Add Mechanical Layer dans le menu contextuel du panneau View Configuration pour ajouter une couche mécanique individuelle, la boîte de dialogue Edit Layer s’ouvre.
Configurez la nouvelle couche mécanique.
Boîte de dialogue Edit Layer |
|
| Layer Name | Le nom de la couche peut être défini par l’utilisateur ou attribué par le système si un type prédéfini est choisi dans la liste déroulante Layer Type. Si un type de couche prédéfini est sélectionné, puis qu’un nom personnalisé est saisi dans ce champ, le type de couche attribué apparaît entre parenthèses à côté du nom personnalisé dans le panneau View Configuration. |
| Layer Number | Numéro de la couche mécanique en cours de configuration ; le prochain numéro de couche disponible est proposé. Si un autre numéro est sélectionné alors qu’il est déjà utilisé, une icône d’avertissement apparaît Un numéro de couche inutilisé doit être attribué pour continuer. |
| Layer Type | Le type de couche peut rester non attribué (N/A), ou vous pouvez sélectionner un type dans la liste. Les types de couches disponibles sont décrits ci-dessous. |
Types de couches mécaniques disponibles
| Assembly Notes | Souvent utilisé pour préciser l’ordre de montage des composants et/ou des instructions d’assemblage importantes. |
| Board | Utilisez cette couche pour les instructions ou les détails relatifs à la carte. |
| Board Shape | Utilisez cette couche pour le contour général de la carte (forme de la carte). |
| Dimensions | Utilisé pour définir les détails dimensionnels nécessaires à la carte. |
| Fab Notes | Utilisé pour préciser les notes de fabrication importantes. |
| Route Tool Path | Utilisé pour indiquer la couche contenant les informations de fraisage mécanique. Notez qu’un nom personnalisé n’est pas autorisé pour ce type de couche |
| Sheet | Utilisez cette couche pour définir la bordure extérieure du modèle de dessin du document. Consultez les détails dans la section Représentation et paramètres de la feuille ci-dessous. |
| V Cut | Permet de définir les détails des rainures en V. Les rainures en V servent à séparer les circuits imprimés en pratiquant une rainure en « V » sur les faces supérieure et inférieure du circuit, tout en laissant une épaisseur minimale de matériau pour maintenir les cartes du panneau ensemble. |
Ajout d’une paire de couches de composants
Lorsque vous sélectionnez la commande Add Component Layer Pair dans le menu contextuel accessible par clic droit du panneau View Configuration, la boîte de dialogue Edit Layers Pair s’ouvre.
Boîte de dialogue Edit Layers Pair |
|
| Layer Name | Il peut s’agir d’un nom de couche défini par l’utilisateur ou attribué par le système si un type prédéfini est choisi dans la liste déroulante Layer Type. Si un type de couche prédéfini est sélectionné, puis qu’un nom personnalisé est saisi dans ce champ, le type de couche attribué apparaît entre parenthèses à côté du nom personnalisé dans le panneau View Configuration. |
| Layer Number | Numéros des couches mécaniques en cours de configuration. Les prochains numéros de couche disponibles sont proposés. Si un autre numéro est sélectionné et qu’il est déjà utilisé, une icône d’avertissement apparaît Un numéro de couche inutilisé doit être attribué pour continuer. |
| Layer Type | Le type de couche peut ne pas être attribué (N/A), ou vous pouvez sélectionner un type dans la liste. Les types de couches disponibles sont décrits ci-dessous. |
Types de paires de couches de composants disponibles
| Assembly | Permet de dessiner ou de détailler les données d’assemblage du composant. Cette couche peut être incluse dans une vue d’assemblage de carte Draftsman, puis sélectionnée comme Geometry Source pour les composants dans la boîte de dialogue Component Display Properties de Draftsman. En savoir plus sur Draftsman. |
| Coating | Permet de définir les zones du composant nécessitant un revêtement de protection. |
| Component Center | Permet d’indiquer le centre géométrique du composant, afin de fournir, dans la documentation d’assemblage, un repère visuel de la position utilisée par la machine de placement des composants. |
| Component Outline | Permet de définir le contour du corps du composant, qui représente la surface occupée par le composant sur la carte. |
| Courtyard | Permet de définir l’espace nécessaire au placement d’un composant. En général, la zone d’encombrement (Courtyard) englobe le composant et ses pastilles, avec une marge de dégagement appropriée le contour vert correspond à la zone d’encombrement). En savoir plus sur la création d’empreintes personnalisées. La forme définie sur la couche Courtyard est également utilisée pour la sélection des composants, pour définir la surface du composant et pour la détection des collisions lorsque le composant ne comporte aucun corps 3D. |
| Designator | Utilisez cette couche pour placer la chaîne spéciale .Designator. Cette paire de couches peut ensuite être incluse dans les plans d’assemblage nécessitant l’affichage du repère du composant. En savoir plus sur les chaînes spéciales. |
| Dimensions | Permet de définir les détails de cotation nécessaires pour les composants. |
| Glue Points | Permet de définir les points de colle des composants. |
| Gold Plating | Permet de définir les exigences de dorure sélective des composants. |
| Value | Utilisez cette couche pour placer la chaîne spéciale .Comment. Cette paire de couches peut ensuite être incluse dans les plans d’assemblage nécessitant l’affichage de la valeur du composant. En savoir plus sur les chaînes spéciales. |
| 3D Body | Utilisez cette couche pour le modèle mécanique 3D du composant. En savoir plus sur le placement de corps 3D. |
| Die | Utilisez cette couche pour les pastilles et les corps 3D de la puce lors de la création d’un composant Chip-on-Board. En savoir plus sur le câblage par fils. |
| Wire Bonding | Utilisez cette couche pour les fils de connexion lors de la création d’un composant Chip-on-Board ou directement dans un document PCB. En savoir plus sur le câblage par fils. |
Avantage de l’attribution d’un type de couche
Une méthode courante pour gérer l’utilisation des couches mécaniques consiste à attribuer un numéro de couche dédié à chaque fonction mécanique requise. Cette méthode exige que tous les concepteurs respectent le même schéma d’attribution et de numérotation des couches. Elle peut également poser des difficultés lorsque les composants proviennent de sources externes qui ne respectent pas ce même schéma. Si un schéma différent a été utilisé, les objets de conception doivent être déplacés de leur couche mécanique actuelle vers la couche mécanique attribuée à cette fonction.
Ce problème est résolu en attribuant une propriété Layer Type. Lorsqu’un composant est placé depuis une bibliothèque dans l’éditeur PCB, copié d’une bibliothèque à une autre ou créé par IPC Footprint Wizard, les attributions de types de couches existantes sont automatiquement mises en correspondance, quels que soient les numéros des couches mécaniques attribués à ces types. Les objets sont déplacés vers les couches appropriées en fonction de leur type de couche. Si le logiciel ne parvient pas à établir une correspondance par type de couche, il utilise alors le numéro de couche.
Pour les couches mécaniques individuelles comme pour les paires de couches de composants, vous pouvez sélectionner un type de couche dans une liste de types prédéfinis. Les images ci-dessous présentent la liste des types de couches disponibles. Vous pouvez accéder aux boîtes de dialogue illustrées ci-dessous en effectuant un clic droit sur une couche individuelle, puis en sélectionnant la commande Edit Layer ou Add Component Layer dans le menu.

Sélectionnez le type de couche dans la liste de types prédéfinis ; les couches mécaniques individuelles sont présentées à gauche et les paires de couches de composants à droite.
Attribution d’un nom aux couches auxquelles un type de couche est attribué
Lorsqu’un type de couche est attribué, la propriété Nom de couche est automatiquement modifiée pour correspondre au type de couche. Si nécessaire, vous pouvez remplacer ce nom en saisissant un nom personnalisé. Lorsqu’une couche possède un nom personnalisé et un type de couche attribué, les deux sont affichés, le type de couche figurant entre parenthèses, comme illustré ci-dessous pour la paire de couches GP (Gold Plating).
Le type de couche est utilisé pour nommer la couche ; ce nom peut être remplacé si nécessaire.
Type de couche Route Tool Path
Il existe une exception au comportement de nommage décrit ci-dessus lorsqu’un type de couche est attribué : aucun nom personnalisé n’est autorisé lorsque Layer Type est défini sur Route Tool Path. En effet, les anciennes versions du logiciel utilisent le nom de la couche Route Tool Path pour identifier la couche contenant les informations de fraisage (également appelées informations rout). Le fait d’imposer le nom de cette couche garantit que la conception continuera à fonctionner correctement dans une version antérieure.
Le type de couche Route Tool Path sert à identifier la couche contenant les informations de fraisage mécanique. Une méthode courante d’utilisation de cette couche consiste à placer des pistes et des arcs le long du bord extérieur de la carte pour définir la trajectoire et la largeur d’usinage. Des sections pleines sont conservées pour maintenir la carte dans le panneau, puis une série de petits trous est placée dans chaque section pleine pour créer des perforations (souvent appelées « morsures de souris »), permettant de détacher la carte du panneau une fois le processus d’assemblage terminé.
Lorsque la carte est affichée en mode 3D, les objets détectés sur la couche Route Tool Path sont représentés sous forme de rainures fraisées dans la carte, comme illustré ci-dessous.

Les objets détectés sur la couche Route Tool Path servent à visualiser la carte fraisée en mode d’affichage 3D.
Utilisez la boîte de dialogue Line/Arc Primitives from Board Shape pour tracer le contour extérieur de la carte à l’aide de pistes et d’arcs (voir ci-dessous). Activez l’option Route Tool Outline dans la boîte de dialogue pour placer les objets à l’extérieur du contour de la carte plutôt que de les centrer sur son bord. Certains concepteurs préfèrent ajouter les informations de fabrication lorsqu’ils utilisent la fonction Embedded Board Array pour créer un panneau d’assemblage, plutôt que d’inclure ces détails dans le fichier de la carte elle-même.
En savoir plus sur la mise en panneau des cartes à l’aide d’un réseau de cartes intégré
Définition du type de couche dans l’éditeur de bibliothèques PCB
Si un type de couche est attribué à une couche mécanique ou à une paire de couches de composant définie dans la bibliothèque PCB, cette couche mécanique ou cette paire de couches est automatiquement créée sur le PCB lorsqu’un composant utilisant ces couches est placé. Si le PCB possède déjà une couche mécanique ou une paire de couches de ce type, le contenu de ces couches est associé aux couches correspondantes.
Dans la mesure du possible, il est recommandé de modifier la bibliothèque source et d’attribuer des types de couches. Lorsqu’une empreinte de composant est placée (ou copiée) depuis une bibliothèque, les couches mécaniques et les paires de couches de composant de ces types sont automatiquement créées dans la carte (ou la bibliothèque) cible si elles n’existent pas. Si ces types de couches existent déjà dans la carte (ou la bibliothèque) cible, le contenu des couches est automatiquement associé à la couche appropriée.
En savoir plus sur la gestion des exigences particulières propres aux couches dans l’éditeur de bibliothèques PCB
Utilisation des couches mécaniques
Les couches mécaniques sont ajoutées, modifiées, supprimées et affichées à partir du panneau View Configuration dans l’éditeur PCB. Elles ne sont ni affichées ni modifiées dans le Layer Stack Manager.
Affichage
Configurez la visibilité des couches dans le panneau View Configuration et enregistrez les groupes de couches fréquemment utilisés sous forme d’ensembles de couches personnalisés.
| Controlling layer visibility | Cliquez sur l’icône de visibilité à côté du nom de la couche pour activer ou désactiver l’affichage de cette couche mécanique. Vous pouvez également cliquer sur le nom de la couche pour la sélectionner, puis appuyer sur Spacebar (cela active ou désactive l’affichage des deux couches d’une paire de couches de composant). |
| Include in Single Layer Mode | Les couches mécaniques disposent d’une fonction d’affichage supplémentaire : elles peuvent être configurées pour rester visibles lorsque l’affichage est en mode monocouche. Maintenez |
| Include in 3D View Mode | Les couches mécaniques peuvent également être incluses dans l’affichage 3D lorsque l’option Colors - By Layer est activée dans les paramètres 3D. Activez cette option dans l’onglet View Options du panneau View Configuration lorsque la carte est affichée en mode Vue 3D. Les couches mécaniques actuellement configurées comme visibles seront incluses |
Modification et suppression
Pour modifier les paramètres d’une paire de couches de composant ou d’une couche mécanique existante, double-cliquez directement sur son entrée dans le panneau View Configuration (ou cliquez avec le bouton droit sur l’entrée souhaitée et choisissez Edit Layer dans le menu contextuel). Effectuez les modifications nécessaires dans la boîte de dialogue Edit Layers Pair / Edit Layer. La visibilité et la couleur des couches mécaniques sont configurées directement dans le panneau View Configuration.
Pour supprimer une couche, cliquez avec le bouton droit sur la couche souhaitée et sélectionnez Delete Layer. Selon l’utilisation de la couche, trois cas peuvent se présenter :
| Nothing on the layer | Si aucune primitive n’est placée sur la couche, celle-ci est supprimée immédiatement lorsque vous sélectionnez Delete Layer (sans confirmation). |
| Contains unlocked primitives | Si la couche contient des primitives non verrouillées, une fenêtre contextuelle vous demande de confirmer la suppression. |
| Contains locked primitives | Si la couche contient des primitives verrouillées, par exemple des primitives appartenant à un composant, une fenêtre d’erreur s’affiche pour vous avertir que l’action ne peut pas être effectuée. |
Exportation et importation
La structure des couches mécaniques et des paires de couches de composant ajoutées à un PCB peut être reproduite dans un autre PCB en exportant cet ensemble dans un fichier depuis le document PCB source, puis en important ce fichier dans le document PCB cible.
Exportation / importation des couches
-
Dans le document PCB source contenant la structure souhaitée de couches mécaniques et de paires de couches de composant, utilisez la commande Tools » Export Mechanical Layers des menus principaux. Dans la boîte de dialogue Export Mechanical Layers qui s’ouvre, définissez le nom et le répertoire du fichier
*.stackupqui contiendra les données relatives à la structure des couches mécaniques. -
Dans le document PCB cible, utilisez la commande Tools » Import Mechanical Layers des menus principaux, puis sélectionnez le fichier
*.stackupenregistré dans la boîte de dialogue Import Mechanical Layers qui s’ouvre. La structure des couches mécaniques et des paires de couches de composant ajoutée est visible dans le panneau View Configuration.
Copie / collage du contenu des couches
Notez que les commandes d’importation et d’exportation transfèrent la structure des couches mécaniques et des paires de couches de composant, mais pas le contenu de ces couches.
Pour copier le contenu :
-
D’une seule couche mécanique, utilisez la commande Edit » Select » All on Layer lorsque la couche souhaitée est la couche active dans le PCB source, puis utilisez la procédure standard de copier-coller pour reproduire ces données dans le PCB cible.
-
Pour plusieurs couches mécaniques, configurez la visibilité des couches dans le panneau View Configuration afin de n’afficher que les couches mécaniques requises, puis tracez un rectangle de sélection par intersection (de droite à gauche) autour de toutes les primitives requises dans le PCB source. Utilisez ensuite la procédure standard de copier-coller pour reproduire ces données dans le PCB cible.
Paramètres de présentation et de sortie
Les couches mécaniques sont souvent utilisées pour détailler les informations à inclure dans les impressions ou les fichiers de fabrication générés. Il peut s’agir de modèles de dessin, d’instructions de fabrication, d’instructions d’assemblage, etc. Si nécessaire, cela peut être réalisé directement dans l’éditeur de PCB.
Les informations de documentation relatives à la production de la carte peuvent être incluses sur les couches mécaniques, si nécessaire.
Ces tâches de documentation peuvent également être réalisées dans Draftsman, un environnement d’édition graphique avancé et flexible permettant de créer des documents de production pour les conceptions de cartes. Doté d’un ensemble d’outils de dessin dédiés, le système de dessin Draftsman offre une approche interactive pour réunir des plans de fabrication et d’assemblage avec des modèles personnalisés, des annotations, des cotes, des repères et des notes.
En savoir plus sur Draftsman
Présentation et paramètres de la feuille
L’image ci-dessus montre un fond blanc qui s’ajuste exactement aux objets de dessin placés pour représenter le modèle de feuille. Ce fond est créé en ajoutant une couche mécanique dont le Layer Type est défini sur Sheet, puis utilisée pour définir la bordure extérieure du modèle de dessin du document.
La taille de ce fond blanc est définie par le Sheet Settings, qui peut être personnalisé dans le panneau Properties lorsqu’aucun élément n’est sélectionné dans l’espace d’édition. Les valeurs X/Y du coin inférieur gauche de la feuille, ainsi que les paramètres Width et Height, peuvent être configurés manuellement. Lorsque l’option Get Size From Sheet Layer est activée, le fond de la feuille est automatiquement calculé à partir du rectangle englobant l’ensemble des objets placés sur la couche mécanique de type Sheet.
La taille du fond de la feuille peut être définie automatiquement à partir des objets placés sur la couche de type Sheet.
La couleur et la visibilité du fond de la feuille sont configurées dans la section System Colors du panneau View Configuration. Cliquez sur le bouton de couleur pour modifier la couleur de Sheet Line et de Area Color. Basculez entre
/
pour afficher ou masquer la feuille.
Inclusion des couches mécaniques dans les sorties
Les couches mécaniques servent à une grande variété de tâches et détaillent les informations utilisées lors de la conception, de la fabrication et de l’assemblage de la carte, ainsi que pour la documentation du produit. Pour répondre à tous ces besoins, les couches mécaniques peuvent être exclues ou incluses dans tous les types de sorties basées sur les couches, notamment les impressions et la génération de fichiers de sortie.
Sorties imprimées
Toutes les couches présentes dans la conception, y compris les couches mécaniques, peuvent être incluses dans la définition d’une impression de PCB. Les impressions sont configurées en ajoutant les couches requises et en définissant leur ordre dans la boîte de dialogue Print.

Des plans de fabrication et d’assemblage très détaillés peuvent être créés en plaçant des objets sur les couches mécaniques.
En savoir plus sur la préparation des sorties PCB 2D pour l’impression
Sorties générées
Toutes les sorties de fabrication, telles que Gerber et ODB++, permettent d’inclure des couches mécaniques en tant que Layer to Plot de sortie, ou de les ajouter comme détails à chaque couche tracée. La sortie est générée lors de l’exécution du générateur de sortie configuré, par exemple un générateur de sortie ODB dans un fichier de configuration OutputJob (*.OutJob).

Les couches mécaniques peuvent être tracées séparément ou ajoutées à tous les tracés si nécessaire.
En savoir plus sur la préparation de votre conception pour la fabrication
).
).



).