Lavorare con i modelli di pad e via

A colpo d'occhio

Questo articolo spiega come Altium Designer utilizza i modelli di pad e via per migliorare il riutilizzo, la coerenza e la gestione nei progetti PCB. Scoprirai come vengono creati automaticamente i modelli locali in una scheda, come rendere disponibili le librerie esterne di modelli di pad e via e come il pannello PCB Pad Via Templates funge da punto centrale per visualizzare, posizionare, filtrare e gestire le definizioni di questi modelli. L'articolo illustra inoltre come i modelli rimangono collegati alle librerie di origine, quali effetti ha questo collegamento sulla modifica e dove è possibile applicare i modelli durante il flusso di lavoro di progettazione. Continua a leggere per scoprire come questi strumenti possono aiutarti a lavorare in modo più efficiente e con maggiore controllo.

- Scopri la differenza tra i modelli locali di pad e via e quelli memorizzati nelle librerie esterne di pad e via, e come vengono utilizzati in un progetto PCB.
- Impara a utilizzare il pannello PCB Pad Via Templates per posizionare i modelli, consultare le librerie disponibili, filtrare gli elenchi dei modelli e verificare quali sono già utilizzati nella scheda corrente.
- Comprendi come vengono generati i nomi dei modelli, in che modo il collegamento alle librerie influisce sulla possibilità di modificarli e dove è possibile applicarli nelle regole di progettazione e nei flussi di lavoro PCB.
Approfondisci con l'IA:
 

Insieme agli oggetti Pista, i pad e i via sono elementi fondamentali di tutti i progetti di circuiti stampati. Ogni pad e via può essere configurato come oggetto personalizzato durante o dopo il posizionamento.

Pad e via in 3D 
Pad e via in 3D

Per migliorare le funzionalità di riutilizzo e gestione dei pad e dei via nei progetti PCB, Altium Designer supporta anche la creazione automatizzata di modelli di pad e via, le librerie di modelli di pad e via e diversi pannelli dedicati alla loro gestione.

Il concetto di modelli di pad e via che possono essere raccolti in una libreria è simile a quello delle librerie di footprint PCB, sebbene sia un po' più semplice. La libreria di modelli di pad e via non memorizza pad e via veri e propri, ma definizioni preconfigurate che vengono applicate a un'istanza di pad o via durante il posizionamento. Le librerie di modelli di pad e via salvate possono essere caricate e utilizzate per posizionare istanze di pad e via predefiniti in qualsiasi progetto PCB o footprint PCB.

Per saperne di più sulla creazione di librerie di pad e via, consulta la pagina Creazione di modelli e librerie di pad e via.

Come accennato, i modelli esistenti possono essere salvati nelle librerie di modelli di pad e via ed è possibile creare nuovi modelli. I modelli di queste librerie sono disponibili per l'uso tramite il pannello PCB Pad Via Templates. Nel pannello sono elencati anche i modelli locali, rendendolo la risorsa centrale per lavorare con le librerie di modelli di pad e via.

Il pannello PCB Pad Via Templates

Il pannello PCB Pad Via Templates è un pannello specializzato che elenca sia i modelli di pad/via memorizzati nel documento PCB corrente (locali), sia quelli disponibili nelle librerie di pad e via installate o incluse nel progetto corrente (librerie disponibili).

Fai clic sul pulsante in basso a destra nell'area di progettazione, quindi scegli PCB Pad Via Templates per aprire il pannello.

Il pannello svolge la duplice funzione di consentire l'accesso ai modelli locali e a quelli delle librerie.
Il pannello svolge la duplice funzione di consentire l'accesso ai modelli locali e a quelli delle librerie.

I due concetti di libreria presentati nel pannello possono essere riassunti come segue:

  • Available Pad/Via Template Libraries – librerie di pad e via caricate o installate (raccolte di modelli di pad/via basate su file). Questa sezione del pannello elenca i modelli contenuti nella libreria di pad e via attualmente selezionata.
  • Local Pad & Via Library – il termine collettivo per i modelli di pad/via utilizzati nel progetto della scheda corrente, inclusi quelli provenienti o aggiunti da una libreria di pad e via. Questa sezione del pannello elenca i modelli applicati ai pad/via nel progetto della scheda corrente.

La libreria locale di pad e via

Le voci elencate nella sezione inferiore Local Pad & Via Library del pannello rappresentano le configurazioni di pad/via (modelli) utilizzate e salvate nel progetto della scheda corrente. Un'anteprima del modello selezionato viene mostrata nella parte inferiore della sezione.

I modelli elencati qui sono modelli di pad e via salvati all'interno del file PCB e non sono contenuti in una vera e propria “libreria” definita separatamente. Un modello selezionato può essere riutilizzato nella scheda corrente come nuova istanza di pad o via trascinandolo sul layout oppure selezionando Place dal menu contestuale del pannello, accessibile con un clic destro.

Posizionamento di un'istanza di un modello di pad locale.
Posizionamento di un'istanza di un modello di pad locale.

Librerie di file di modelli di pad e via disponibili

La sezione superiore del pannello, Available Pad/Via template Libraries, viene utilizzata per lavorare con le librerie di file di modelli di pad e via.

Un modello della libreria selezionata può essere posizionato nel PCB trascinandolo dal pannello oppure tramite il menu contestuale accessibile con un clic destro. Poiché il pad/via viene posizionato da una libreria di file di modelli esterna, le sue proprietà non possono essere modificate nel PCB, come si può vedere nell'immagine del pannello Properties riportata di seguito, sulla destra. Per modificare le proprietà di un pad/via basato su una libreria, è necessario scollegarne il modello; per maggiori informazioni, consulta la sezione Scollegamento di un modello da una libreria.

I modelli nella libreria di pad e via attiva, Preferred.PvLib in questo esempio. Le proprietà di un'istanza posizionata del pad selezionato sono mostrate nella seconda immagine. Nota che le proprietà fisiche, come la forma del pad e la dimensione del foro, non possono essere modificate. 
I modelli nella libreria di pad e via attiva, Preferred.PvLib in questo esempio. Le proprietà di un'istanza posizionata del pad selezionato sono mostrate nella seconda immagine. Nota che le proprietà fisiche, come la forma del pad e la dimensione del foro, non possono essere modificate.

Quando un modello di pad o via basato su file viene posizionato nel progetto di una scheda, rimane collegato al modello della libreria di origine e al nome della libreria di origine. Poiché tale origine è un file esterno, le proprietà fisiche del pad o via che utilizza quel modello non possono essere modificate, proteggendo l'integrità del modello di origine nel file della libreria esterna. Per modificare un modello di pad o via basato su file, è possibile scollegarlo; per maggiori informazioni, consulta la sezione Scollegamento di un modello da una libreria.

Il menu a discesa nella parte superiore del pannello consente di selezionare quale libreria disponibile è attiva; nell'immagine seguente è ExampleViaLib.PvLib. Il pulsante  consente di aprire la finestra di dialogo Available Libraries, in cui è possibile aggiungere e rimuovere file di librerie di modelli. Le librerie disponibili sono illustrate di seguito. Utilizza il campo Filter per visualizzare solo i modelli il cui Name inizia con quella stringa.

Utilizza il campo Filter per filtrare rapidamente l'elenco dei modelli.
Utilizza il campo Filter per filtrare rapidamente l'elenco dei modelli.

Rendere disponibili le librerie di modelli di pad e via

Il termine Available Libraries indica le librerie di modelli di pad e via i cui modelli sono disponibili per l'uso nel progetto della scheda corrente. Sono incluse sia le librerie di modelli aggiunte al progetto corrente, sia quelle installate in Altium Designer. Entrambi i tipi possono essere consultati e gestiti nella finestra di dialogo Available Libraries; fai clic sul pulsante  nella parte superiore del pannello PCB Pad Via Templates per aprire la finestra di dialogo.

Installa una libreria di pad e via esterna oppure utilizza la scheda Project per aggiungere una libreria esistente al progetto corrente.
Installa una libreria di pad e via esterna oppure utilizza la scheda Project per aggiungere una libreria esistente al progetto corrente.

  • La scheda Project della finestra di dialogo elenca tutti i file PvLib inclusi nel progetto e dispone anche di pulsanti per aggiungere o rimuovere librerie dal progetto.
  • La scheda Installed elenca tutte le librerie di modelli di pad e via attualmente disponibili in questa installazione di Altium Designer e, quindi, disponibili per tutti i progetti PCB. Nota che, per una libreria installata, puoi controllarne la disponibilità per l'uso abilitando o disabilitando l'opzione Activated associata. In questo modo non è necessario rimuovere e aggiungere nuovamente le librerie.

Utilizzo di un modello nel progetto

I modelli elencati nel pannello PCB Pad Via Templates possono essere utilizzati nel progetto della scheda corrente nei seguenti modi:

  • Posizionamento – posiziona un pad o via locale o di una libreria di modelli direttamente dal pannello.
  • Selezione nel menu a discesa Template – nel pannello Properties quando sono selezionati pad o via. Utilizza questo approccio per fare in modo che i pad o via selezionati utilizzino un modello diverso.
  • Come vincolo di una regola – un modello di pad e via può essere selezionato come vincolo nella regola di progettazione Routing Via Style (mostrata di seguito).
  • Come ambito di applicazione di una regola – le seguenti parole chiave di query possono essere utilizzate per definire l'ambito di applicazione di una regola di progettazione (ad esempio, la regola di progettazione Testpoint Style):
  • Per la cucitura/schermatura con via: selezionare il Via Template desiderato nella finestra di dialogo Add Stitching to Net o nella finestra di dialogo Add Shielding to Net.

Utilizzare i modelli di via nella regola di progettazione Routing Via Style oppure quando si aggiunge una cucitura con via a una net.
Utilizzare i modelli di via nella regola di progettazione Routing Via Style oppure quando si aggiunge una cucitura con via a una net.

Il modello di pad/via e la sua denominazione

Per ogni pad o via univoco inserito nel progetto di una scheda, viene automaticamente creato, denominato e memorizzato nel file della scheda un modello di pad/via. Il modello memorizza la configurazione di base del pad/via, incluse dimensioni, forma, tipo di padstack, informazioni sulla maschera per pasta saldante, sulla solder mask e sul foro, e così via. Alla configurazione viene assegnato automaticamente un nome conforme agli standard IPC (in particolare, alle convenzioni di denominazione dei padstack IPC-7251/7351). Ogni pad e via utilizzato nel progetto fa riferimento al proprio modello, come si può vedere nel pannello Properties, illustrato di seguito.

Il sistema di denominazione IPC si basa sul sistema metrico, in cui un'unità equivale a un centesimo di millimetro (10-5 metri, 10µm). Ad esempio, il modello di un pad circolare da 1,5 mm con un foro da 0,8 mm viene denominato c150h80, dove c indica una forma circolare (rotonda) e h precede la dimensione del foro. Un pad denominato r155_125 è un pad rettangolare a montaggio superficiale di dimensioni 1,55 mm x 1,25 mm; un pad denominato s160h100 è invece un pad quadrato a foro passante di dimensioni 1,6 mm, con un foro da 1,0 mm. I nomi dei modelli di pad con forma personalizzata hanno il prefisso u. Vengono aggiunte ulteriori combinazioni di lettere e numeri interi per le proprietà specificate della maschera per pasta saldante e della solder mask.

Per osservare questo comportamento, esaminare le proprietà di un pad o via esistente nel relativo pannello Properties, facendo doppio clic sull'oggetto oppure selezionandolo e scegliendo Properties dal menu contestuale aperto con il pulsante destro del mouse.

Il nome del modello di pad o via generato automaticamente, mostrato nel pannello Properties.
Il nome del modello di pad o via generato automaticamente, mostrato nel pannello Properties.

Notare il nome Template assegnato nella sezione Pad/Via Template del pannello. In conformità alle linee guida IPC, il nome deriva dalle proprietà di base del pad/via, come dimensioni, forma, foro e configurazione della maschera per pasta saldante e della solder mask. Se queste proprietà vengono modificate, il nome del modello cambia per riflettere la nuova configurazione. Come prevedibile, la relazione tra le proprietà di un pad o via e il nome del relativo modello è meno evidente quando si utilizzano unità imperiali anziché metriche.

Individuare un pad o via nell'area di progettazione PCB

Ogni volta che nel progetto PCB viene inserito un pad o via con dimensioni univoche utilizzando il menu Place o il Active Bar, nel file della scheda viene automaticamente creato un nuovo modello di pad/via. Questi modelli sono denominati modelli <Local>. Per il PCB corrente, l'elenco di tutti i modelli di pad e via utilizzati può essere esaminato nel pannello PCB quando è impostato sulla modalità Pad & Via Templates.

Il pannello PCB nella modalità Pad &amp; Via Templates
Il pannello PCB nella modalità Pad & Via Templates

La modalità Pad & Via Templates offre un controllo avanzato sui modelli di pad e via utilizzati nel documento PCB corrente. In questa modalità, il pannello è suddiviso in tre sezioni:

  • Library Name
  • Templates
  • Pads/Vias

Nome della libreria

Questo elenco mostra le istanze dei modelli di pad e via presenti nel progetto come una raccolta di librerie virtuali e fisiche. Queste filtrano i modelli inclusi nell'elenco della sezione inferiore del pannello e sono organizzate come segue:

  • All – mostra tutti i modelli di pad e via, inclusi quelli utilizzati dalle librerie di pad e via.
  • Pads – mostra tutti i pad, sia locali sia basati su libreria.
  • Vias – mostra tutti i via, sia locali sia basati su libreria.
  • Local – mostra tutti i modelli di pad e via applicati alla scheda, ma non quelli aggiunti dalle librerie di pad/via.
  • Pad & Via Libraries – mostra solo i modelli di pad e via applicati dalla libreria di pad/via selezionata.

Modelli

Questa sezione fornisce un elenco di tutti i modelli di pad/via utilizzati nel progetto PCB corrente. Le colonne includono l'origine del modello Library Name (locale o nome della libreria di pad/via) e il numero di istanze di pad/via per ciascun modello (Count).

Quando la sezione Library Name del pannello è impostata su una specifica libreria di pad/via, la sezione Template può mostrare voci con un Count pari a zero istanze. Questo indica che il modello non è attualmente utilizzato da alcun pad/via nel layout della scheda, ma è utilizzato nel progetto, ad esempio come impostazione predefinita per pad/via o per definire il vincolo di una regola di progettazione come Routing Via Style.

È possibile salvare un numero qualsiasi dei modelli elencati in una libreria di pad/via separata. Per farlo, selezionare più modelli utilizzando le tecniche standard Shift+Click e Ctrl+Click, quindi fare clic sul pulsante Save as Library. La libreria verrà aggiunta automaticamente al progetto e potrà essere salvata con il nome file *.PvLib desiderato utilizzando File » Save As dal pannello Projects. Per ulteriori informazioni sulla creazione di una libreria di modelli di pad/via, consultare la pagina Creazione e modifica di una libreria di modelli di pad/via.

La sezione Templates consente inoltre di inserire nel progetto PCB un modello basato su una libreria di pad/via utilizzando il pulsante Place. Per abilitare questa funzione, selezionare la libreria di pad/via desiderata nella sezione superiore Library Name del pannello.

Il pulsante Place può essere utilizzato per inserire il modello di pad/via selezionato se questo si trova in una libreria di modelli di pad/via. Per inserire un pad/via locale, utilizzare il pannello PCB Pad Via Templates, come descritto di seguito.

Pad/Via

Questa sezione del pannello contiene le singole istanze di pad/via del modello selezionato nella sezione Templates sovrastante.

Quando viene selezionata un'istanza di pad/via, l'oggetto viene evidenziato graficamente nell'area di progettazione, secondo le opzioni standard di evidenziazione, zoom e selezione situate nella parte superiore del pannello PCB. I pad o via selezionati possono quindi essere modificati per utilizzare un modello diverso nel pannello Properties, scegliendo il modello desiderato dal menu a discesa Template.

Ogni istanza elencata in questa sezione è accompagnata da una casella indicatrice Changed, che viene selezionata quando il modello di origine della libreria collegata differisce da quello utilizzato nel pad o via locale, ovvero quando la libreria di pad/via di origine è stata aggiornata. L'indicatore Changed viene selezionato anche se il tipo di padstack del pad/via locale viene modificato, ad esempio quando un'istanza di pad viene modificata localmente da multistrato a singolo strato.

In tutti i casi, la versione locale del pad o via può essere aggiornata (o ripristinata) al modello corrente della libreria di pad/via di origine utilizzando il pulsante del pannello PCB Pad Via Templates Update.

Attività di modifica e gestione dei modelli di pad e via

Questa sezione illustra le varie situazioni in cui è necessario modificare i modelli di pad o via.

Applicare un modello diverso a pad/via esistenti

In alcuni casi potresti voler applicare un modello diverso a pad o via esistenti (ad esempio, per ridurre il numero di tipi di via utilizzati in un progetto). In questa situazione, utilizza la modalità Pad & Via Templates del pannello PCB per individuare e selezionare i pad/via da modificare. Puoi quindi modificare i pad o via selezionati affinché utilizzino un modello diverso nel pannello Properties, scegliendo il modello desiderato nel menu a discesa Template.

Applicazione di un modello diverso.
Applicazione di un modello diverso.

Scollegare un modello da una libreria

Non è possibile modificare le proprietà di pad/via che utilizzano un modello di una libreria di modelli basata su file: se fosse possibile, l'istanza locale non corrisponderebbe più al modello di libreria a cui fa riferimento. Per modificare un pad o via che fa riferimento a un modello di libreria, è necessario scollegare il modello.

Fai clic sul pulsante Linked button, click to copy the template from the file library to the local library and reference the local template per scollegare un modello. Quando fai clic su questo pulsante, viene creata una copia del modello nella libreria locale e le istanze selezionate del pad/via vengono associate al modello locale. Nota che, se il pulsante Linked button, click to copy the template from the file library to the local library and reference the local template è disattivato, significa che il modello è già locale.

Fai clic per scollegare il modello dalla libreria basata su file. Il modello viene copiato nella libreria locale e viene utilizzata tale copia.
Fai clic per scollegare il modello dalla libreria basata su file. Il modello viene copiato nella libreria locale e viene utilizzata tale copia.

Se il pad/via da scollegare aveva un nome personalizzato definito nella libreria di modelli di pad e via, questo nome viene rimosso e al modello locale viene applicata la convenzione di denominazione standard IPC.

Aggiungere un modello di libreria alla libreria locale

Se necessario, è possibile aggiungere un modello di libreria alla libreria locale. Per farlo, fai clic con il pulsante destro del mouse sul nome del modello e seleziona Add to Internal Library dal menu contestuale, oppure trascina il modello dall'area Pad/Via Library del pannello e rilascialo in uno spazio vuoto dell'area Local Pad & Via Library.

Aggiungi un modello di pad/via alla libreria locale utilizzando il menu contestuale o tramite trascinamento.
Aggiungi un modello di pad/via alla libreria locale utilizzando il menu contestuale o tramite trascinamento.

I modelli di libreria di pad/via inutilizzati possono essere rimossi dalla libreria locale facendo clic sul pulsante Removed Unused Pad/Via.

Questa operazione equivale a posizionare un pad/via basato su un modello di una libreria di pad e via e poi eliminarlo dalla scheda, registrando così il modello come disponibile localmente. Per replace un modello locale, anziché aggiungerne uno all'elenco locale, vedi Sostituire un modello locale di seguito.

Aggiornare dalla libreria di pad e via

Se un modello di pad/via è stato aggiornato nella libreria ed è già stato utilizzato nel progetto di una scheda, fai clic sul pulsante Update nel pannello PCB Pad Via Templates per aggiornare il modello di pad/via nel progetto. L'aggiornamento verrà applicato automaticamente a tutte le istanze di pad/via che utilizzano quel modello nella scheda.

Un pad/via che utilizza un modello aggiornato nella libreria può essere aggiornato nel progetto PCB utilizzando il pulsante Update nel pannello PCB Pad Via Templates.
Un pad/via che utilizza un modello aggiornato nella libreria può essere aggiornato nel progetto PCB utilizzando il pulsante Update nel pannello PCB Pad Via Templates.

Quando viene avviato un aggiornamento, si apre la finestra di dialogo Update Pads/Vias on Board, che elenca i dettagli delle modifiche rilevate che verranno applicate.

I modelli di pad/via che risultano diversi dalla versione nella libreria di origine possono essere aggiornati dalla libreria al progetto PCB.
I modelli di pad/via che risultano diversi dalla versione nella libreria di origine possono essere aggiornati dalla libreria al progetto PCB.

La finestra di dialogo offre tre opzioni per controllare il processo di aggiornamento:

  • Update locked objects – forza l'aggiornamento del modello di un oggetto pad/via, indipendentemente dal suo stato di blocco.
  • Update free objects – aggiorna solo i modelli di pad/via applicati a pad e via liberi.
  • Update component objects – aggiorna solo i modelli di pad/via applicati ai pad e via utilizzati nei componenti.

Questo comportamento di sincronizzazione è definito dalla proprietà Library dei pad e via, visibile nel pannello Properties quando si visualizzano le proprietà di un pad o via selezionato. La presenza di differenze tra la versione locale del modello e il modello di origine è indicata nella colonna Changed dell'area Pads/Vias nella modalità Pad & Via Templates del pannello PCB.

Anche se il nome del modello è cambiato nella libreria di pad e via di origine, il collegamento al pad/via a cui è applicato nel progetto PCB viene mantenuto tramite il riferimento GUID del modello, memorizzato nei dati di progetto della scheda.

L'area inferiore della finestra di dialogo elenca i pad/via da aggiornare. Per ciascuno vengono riportate informazioni, tra cui Type, Description, Library, Template e Action. Inoltre, puoi scegliere di contrassegnare ogni pad/via come Locked e/o In Component. Quando sono abilitate, queste opzioni rendono l'oggetto soggetto ai controlli presenti nell'area superiore della finestra di dialogo.

Sostituire un modello locale

Un modello di pad/via basato su una libreria può anche replace un modello locale, aggiornando i pad o via sulla scheda che utilizzano tale modello locale.

Per farlo, trascina il modello di libreria desiderato dall'area Pad/Via Library del pannello all'area Local Pad & Via Library del pannello, ma in questo caso rilascialo on top of la voce del modello locale esistente. Tutte le istanze di pad/via liberi o appartenenti a componenti che utilizzano il modello verranno aggiornate alla configurazione del nuovo modello di libreria.

Nell'animazione seguente, nota che i pad dei componenti C1 e C2 cambiano fisicamente assumendo il tipo definito dal modello di libreria rilasciato, passando da r110_100 a s120.

Rilascia un modello di libreria sopra la voce di un modello locale per sostituirlo in tutte le istanze del progetto.
Rilascia un modello di libreria sopra la voce di un modello locale per sostituirlo in tutte le istanze del progetto.

Rimuovere pad/via inutilizzati

Poiché i nomi dei modelli elencati nella libreria locale derivano dai pad e via presenti nel layout PCB corrente, se tutte le istanze di una particolare configurazione locale di pad/via vengono eliminate dalla scheda, il modello corrispondente verrà rimosso dall'elenco locale.

Tuttavia, se un pad o via posizionato proviene da una libreria di pad e via, il suo modello verrà mantenuto nell'elenco locale anche quando tutte le istanze di quel pad/via sono state rimosse dalla scheda. Le istanze dei modelli della libreria di pad e via che non sono più necessarie possono essere rimosse dal record del «database» locale tramite il pulsante Remove Unused Pad/Via. Si aprirà la finestra di dialogo Update Templates from Library, da cui potrai scegliere quali modelli di pad e via rimuovere dalla libreria locale di pad e via. Utilizza il pulsante Templates  o il menu contestuale per selezionare/deselezionare tutti i modelli nell'elenco o invertire la selezione.

La finestra di dialogo Update Templates from Library
La finestra di dialogo Update Templates from Library

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents