Lavorare con piste e archi
A colpo d'occhio
- Impara a posizionare, modificare, spostare e reindirizzare i segmenti di pista nell'editor PCB utilizzando i comandi e le scorciatoie principali.
- Comprendi come lo sbroglio interattivo gestisce le net, i layer, le modalità degli angoli, la risoluzione dei conflitti e le regole di progettazione applicabili.
- Scopri come viene determinata e regolata la larghezza delle piste, incluso il modo in cui le preferenze e le regole influenzano le larghezze utilizzabili.
Lavorare con le piste
Un segmento di pista è una linea retta di larghezza definita. Le piste consentono di definire una linea retta nello spazio di progettazione PCB. Vengono posizionate su un layer di segnale per realizzare le interconnessioni elettriche, o routing, tra i pad dei componenti. Le piste posizionate su un layer non elettrico sono chiamate linee e vengono utilizzate come elementi di disegno generici per creare contorni dei componenti, informazioni operative, delimitazioni delle aree di keepout, ecc. Le piste vengono utilizzate anche in oggetti di progettazione raggruppati, come quote e coordinate.

Gli oggetti pista vengono utilizzati per il routing e per disegnare linee generiche. Nell'immagine sopra sono presenti quattro segmenti di pista già posizionati e un altro in fase di posizionamento.
Sebbene piste e linee siano in realtà lo stesso oggetto, la differenza risiede nel comportamento del software durante il loro posizionamento, motivo per cui esistono comandi diversi. Quando viene eseguito un comando di posizionamento delle piste, come Interactive Routing, il software monitora la posizione del clic e adotta automaticamente il nome della net di un oggetto esistente (ad esempio un pad) situato in quel punto. Inoltre, verifica e rispetta tutte le regole di progettazione applicabili. Quando viene eseguito un comando di posizionamento delle linee (Place » Line), queste verifiche non vengono effettuate.
Le piste possono essere posizionate sia nell'editor PCB sia nell'editor delle librerie PCB. Indipendentemente dal comando utilizzato (routing/posizionamento di piste o posizionamento di linee), il comportamento di base durante il posizionamento è lo stesso. Dopo aver avviato il comando, il cursore assume la forma di un mirino e si accede alla modalità di posizionamento delle piste. Il posizionamento si esegue con la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il punto iniziale del primo segmento di pista. Se è in esecuzione un comando di posizionamento di tipo routing e si fa clic su un oggetto esistente per iniziare il posizionamento, la pista adotterà il nome della net di quell'oggetto. Per il routing, la larghezza sarà determinata dalla regola di progettazione Larghezza di routing applicabile; questa può essere ignorata da alcune opzioni di routing interattivo, descritte più dettagliatamente di seguito.
- Spostare il cursore per definire il segmento di pista, quindi fare clic o premere Enter per fissare il punto finale di questo primo segmento, che è anche il punto iniziale del segmento collegato successivo.
- Continuare a posizionare il cursore, quindi fare clic o premere Enter per fissare una serie di vertici che definiscono la sequenza di segmenti di pista collegati.
- Fare clic con il pulsante destro del mouse o premere Esc per terminare la sequenza corrente di segmenti di pista collegati.
Durante il posizionamento è possibile eseguire anche le seguenti azioni:
- Premere il tasto * sul tastierino numerico per scorrere i layer di segnale disponibili. In alternativa, utilizzare la combinazione Shift+Ctrl+Wheel Roll per scorrere i layer di routing; ogni scatto della rotellina del mouse passa al layer di segnale disponibile successivo (o precedente).
- Premere i tasti + e - sul tastierino numerico per scorrere avanti e indietro tutti i layer attualmente visibili nel progetto.
Durante il posizionamento dei segmenti di pista sono disponibili cinque modalità di angolo, quattro delle quali dispongono anche di sottomodalità per la direzione dell'angolo. Durante il posizionamento:
- Premere Shift+Spacebar per scorrere le modalità di angolo disponibili.
- Premere Spacebar per passare da una sottomodalità di direzione dell'angolo all'altra.
- In una delle modalità di angolo ad arco, tenere premuto il tasto , o . per ridurre o ingrandire l'arco. Tenere premuto anche il tasto Shift per accelerare il ridimensionamento dell'arco.
- Premere il tasto di scelta rapida 1 per alternare il posizionamento di un segmento per clic (mostrato nelle prime cinque immagini di seguito) e di due segmenti per clic (mostrato nell'ultima immagine di seguito). Nella prima modalità, il segmento di pista rappresentato con il solo contorno è detto segmento di anteprima.
- Premere il tasto Backspace per rimuovere l'ultimo vertice.



Premere Shift+Spacebar per scorrere le cinque modalità di angolo disponibili, premere Spacebar per invertire la direzione dell'angolo e premere il tasto di scelta rapida 1 per alternare il posizionamento di uno o due segmenti.
Il metodo di modifica grafica consente di selezionare un oggetto pista posizionato direttamente nello spazio di progettazione e di modificarne graficamente dimensioni, forma o posizione.
Quando si seleziona un oggetto pista, sono disponibili le seguenti maniglie di modifica:
- Fare clic e trascinare A per riposizionare le estremità della pista.
- Fare clic e trascinare B per modificare la forma della pista.
L'editor PCB include algoritmi sofisticati per spostare i segmenti di pista sulla scheda preservando la disposizione del routing. Questo scorrimento dei segmenti di pista può essere attivato in modo interattivo facendo prima clic per selezionare il segmento e poi facendo clic e tenendo premuto quando appare il cursore speciale per far scorrere il segmento, oppure facendo clic e tenendo premuto direttamente su un segmento di pista e facendolo scorrere. Il comportamento di scorrimento può essere configurato utilizzando le opzioni Dragging nella pagina PCB Editor - Interactive Routing della finestra di dialogo Preferences. Queste opzioni consentono di assegnare l'azione di spostamento a una pista, utile per poter spostare liberamente un singolo segmento di pista.

Controllare il comportamento di scorrimento delle piste tramite le opzioni di trascinamento impostate nelle preferenze.
Se tramite queste opzioni viene assegnata l'azione Move, il segmento di pista può essere ruotato o specchiato durante lo spostamento.
Routing interattivo e regole di progettazione applicabili
Durante il routing interattivo, il comportamento predefinito del software garantisce che i segmenti di pista vengano posizionati nel rispetto delle regole di progettazione elettriche e di routing applicabili. Ciò significa che il software non consentirà di posizionare un nuovo segmento di pista che violi le regole rispetto a un segmento esistente appartenente a una net diversa; limiterà invece il segmento di pista in modo da rispettare le regole di progettazione. Questo comportamento del routing interattivo è noto come modalità Routing Conflict Resolution. La modalità predefinita è Stop at First Obstacle (la modalità corrente è visualizzata sulla barra di stato). Premere Shift+R per scorrere le modalità disponibili.
Il termine applicable design rules indica tutte le regole applicabili all'oggetto in fase di posizionamento. Il motore delle regole di progettazione funziona con un sistema che consente di definire con precisione gli oggetti a cui applicare ciascuna regola. Durante il posizionamento, il motore delle regole di progettazione viene interrogato per determinare la regola con la priorità più alta applicabile alla situazione corrente. Le regole applicabili durante il routing interattivo includono:
- Distanza di isolamento elettrico
- Larghezza di routing
- Stile dei via di routing
L'animazione seguente mostra il routing in azione. La net GND viene sbrogliata nel rispetto di una regola di progettazione relativa alla larghezza di routing definita e applicabile. Si noti che, quando il cursore viene spostato sul via associato alla net +12V, il percorso viene automaticamente limitato per garantire il rispetto della regola di progettazione Vincolo di distanza di isolamento elettrico applicabile.

Durante il routing interattivo, le regole di progettazione applicabili relative alla larghezza di routing e alla distanza di isolamento vengono rispettate automaticamente.
Come viene determinata la larghezza di routing
A meno che il motore delle regole non sia disabilitato, il comportamento prioritario del software è garantire sempre che la larghezza delle piste rientri nell'intervallo consentito dalla regola di progettazione Routing Width applicabile. Un approccio comune consiste nel consentire l'uso di un intervallo di larghezze per una net, in modo da offrire flessibilità nel posizionamento del percorso pur soddisfacendo i requisiti di portata di corrente della net. A tale scopo, la regola di progettazione Routing Width dispone delle impostazioni Min, Preferred e Max nel PCB Rules and Constraints Editor, che possono essere configurate per consentire un intervallo di larghezze oppure impostate sullo stesso valore per richiedere una larghezza specifica. La larghezza può anche essere configurata in funzione dell'impedenza ed è possibile specificare un intervallo diverso per ciascun layer di segnale.

La regola di progettazione Routing Width predefinita viene applicata a tutte le net di un nuovo PCB.
Come progettista, hai a disposizione diverse opzioni che possono aiutarti a selezionare la larghezza delle piste più appropriata quando inizi lo sbroglio. Queste opzioni si configurano nella pagina PCB Editor — Interactive Routing della finestra di dialogo Preferences, come mostrato di seguito.

Le opzioni Interactive Routing Width Sources determinano la larghezza utilizzata quando inizi a tracciare un percorso.
Nota che nell'immagine Track Width Mode è impostato su Rule Preferred. Ciò indica che, quando il percorso inizia su un oggetto esistente della net, ad esempio un pad, verrà utilizzata questa larghezza. Tuttavia, se il percorso inizia su una pista esistente, l'opzione Pickup Track Width From Existing Routes avrà la precedenza su Track Width Mode e imposterà la nuova larghezza in modo che corrisponda a quella esistente.
Come progettista, durante lo sbroglio puoi anche premere la scorciatoia Shift+W per accedere a una finestra di dialogo in cui selezionare una larghezza diversa, oppure premere Tab per aprire Properties panel e digitare un nuovo valore di Width . Il valore scelto o immesso deve essere compreso tra le impostazioni Min e Max definite nella regola applicabile. In caso contrario, viene automaticamente limitato al più vicino di questi due valori.
Scorciatoie per lo sbroglio interattivo
Durante lo sbroglio sono disponibili diverse scorciatoie. Ad esempio, puoi premere Shift+R per scorrere le modalità di risoluzione dei conflitti disponibili, oppure Backspace per eliminare l'ultimo vertice (angolo) posizionato. Per visualizzare un elenco delle scorciatoie durante lo sbroglio, premi Shift+F1. Viene visualizzato un menu delle scorciatoie interattive disponibili; seleziona quella desiderata oppure premi Esc per chiudere il menu e utilizzare la sequenza di tasti della scorciatoia.

Durante lo sbroglio interattivo, premi Shift+F1 per visualizzare un menu delle scorciatoie interattive disponibili
Spostamento di una pista
Il sottomenu Edit » Move e il menu dei comandi di spostamento in Active Bar includono diversi comandi che consentono di modificare la posizione o la forma di una pista.
Ritraccia percorso
Questo comando consente di ritracciare manualmente le piste esistenti sulla scheda. Dopo aver avviato il comando, il cursore assume la forma di un mirino e viene richiesto di scegliere una pista. Posiziona il cursore sulla pista desiderata, quindi fai clic oppure premi Enter. Il funzionamento di questa funzione dipende dall'attivazione o meno dell'opzione Preserve Angle When Dragging nella pagina PCB Editor - Interactive Routing della finestra di dialogo Preferences:
- Preserve Angle Dragging enabled - la pista viene suddivisa con l'aggiunta di un nuovo segmento per mantenere le connessioni ortogonali/diagonali. Sposta il cursore per far scorrere questo segmento come desiderato, quindi fai clic per posizionarlo. A questo punto, fai clic con il pulsante destro del mouse oppure premi Esc , altrimenti il nuovo segmento verrà suddiviso con l'aggiunta di un ulteriore segmento. Usa la scorciatoia da tastiera Shift+R per scorrere le opzioni che controllano la gestione degli ostacoli durante il trascinamento (Ignore Obstacles, Avoid Obstacles o Avoid Obstacles (Snap Grid)). Se è attiva una delle modalità Avoid Obstacles, durante il trascinamento vengono rispettate le regole, impedendo di trascinare un segmento in una posizione che causi una violazione.
- Preserve Angle Dragging disabled - entrambe le estremità del segmento di pista vengono ancorate e puoi quindi tracciare nuovi segmenti tra di esse. Fai clic oppure premi Enter per posizionare un nuovo segmento di pista. Continua a posizionare nuovi segmenti per ritracciare il percorso oppure fai clic con il pulsante destro del mouse o premi Esc per interrompere.
Continua a ritracciare altre piste oppure fai clic con il pulsante destro del mouse o premi Esc per uscire.
Dividi pista
Questo comando consente di creare un vertice (o punto di suddivisione) in un segmento di pista. Dopo aver avviato il comando, il cursore assume la forma di un mirino e viene richiesto di selezionare una pista. Posiziona il cursore sul segmento desiderato, nel punto esatto in cui vuoi inserire la suddivisione, quindi fai clic oppure premi Enter. Viene inserito un vertice, che divide il segmento originale in due.
Sposta il vertice nella posizione desiderata, quindi fai clic oppure premi Enter per posizionarlo. Il comportamento dei segmenti di pista collegati dipende dall'impostazione dell'opzione Preserve Angle When Dragging nella pagina PCB Editor - Interactive Routing della finestra di dialogo Preferences:
- Preserve Angle When Dragging attivata - gli angoli rispetto ai segmenti di pista adiacenti vengono preservati, mantenendo lo stile di sbroglio.
- Preserve Angle When Dragging disattivata - i due singoli segmenti di pista si adattano elasticamente allo spostamento, senza mantenere lo stile di sbroglio esistente.
Continua a suddividere altri segmenti di pista oppure fai clic con il pulsante destro del mouse o premi Esc per uscire.
Trascina estremità pista
Questo comando consente di riposizionare manualmente o trascinare l'estremità di un segmento di pista già tracciato. Dopo aver avviato il comando, il cursore assume la forma di un mirino e viene richiesto di selezionare un oggetto. Posiziona il cursore su una pista, quindi fai clic oppure premi Enter. Il cursore si sposta sull'estremità più vicina del segmento di pista, che rimane agganciata al cursore. Sposta l'estremità della pista nella posizione desiderata, quindi fai clic oppure premi Enter per posizionarla.
- Se l'estremità del segmento di pista scelto è un vertice a cui non sono collegati altri segmenti di pista, spostare il vertice nella posizione desiderata.
- Se l'estremità del segmento di pista scelto è un vertice a cui sono collegati due segmenti di pista, i segmenti collegati si adatteranno elasticamente durante lo spostamento del vertice.
- Se l'estremità del segmento di pista è collegata a un pad di un componente, spostandola verrà scollegata dal pad. Dopo aver riposizionato l'estremità, verrà visualizzata una linea di connessione logica tra l'estremità della pista e il pad, purché l'opzione Smart Track Ends sia abilitata nella pagina PCB Editor – General della finestra di dialogo Preferences.
- Se l'estremità del segmento di pista è collegata a un pad libero, il pad verrà agganciato al cursore, pronto per essere riposizionato. Tutte le piste collegate al pad si adatteranno elasticamente di conseguenza.
- Se l'estremità del segmento di pista è collegata a un via, il via verrà agganciato al cursore, pronto per essere riposizionato. Tutte le piste collegate al via si adatteranno elasticamente di conseguenza.
Continuare a trascinare altre estremità delle piste oppure fare clic con il pulsante destro del mouse o premere Esc per uscire.
Spostamento / ridimensionamento delle piste
Questo comando consente di spostare i punti finali di più segmenti di pista selezionati, ridimensionandoli di fatto. Dopo aver avviato il comando, il cursore assumerà la forma di un mirino e verrà richiesto di scegliere un punto finale di una pista. Per spostare/ridimensionare le piste:
- Posizionare il cursore sul punto finale di uno dei segmenti selezionati, quindi fare clic o premere Enter.
- Spostare il cursore; tutti i segmenti di pista selezionati verranno ridimensionati dinamicamente, mantenendo le distanze e gli angoli originali tra loro. L'altra estremità di ciascun segmento si adatterà elasticamente per mantenere la connessione/posizione esistente.
- Quando i segmenti si trovano nella posizione desiderata, fare clic o premere Enter per confermare il posizionamento e uscire dalla modalità di spostamento.
- Per annullare l'operazione, fare clic con il pulsante destro del mouse o premere Esc.
Durante lo spostamento dei segmenti, sono disponibili i seguenti comandi aggiuntivi:
- Premere il tasto Tab per spostare ciclicamente il cursore tra i punti finali di ciascun segmento di pista selezionato.
- Tenere premuto il tasto Alt durante lo spostamento per vincolarlo a una direzione specifica, in base alla direzione iniziale dello spostamento. Sono possibili le direzioni orizzontale, verticale e a 45 gradi.
- Premere due volte Spacebar per allineare rapidamente tutti i punti finali dei segmenti di pista in orizzontale o in verticale. Premere di nuovo Spacebar due volte rapidamente per ripristinare le dimensioni precedenti.
Taglio delle piste
Lo strumento Track Slicer offre un metodo semplice per dividere in due uno o più segmenti di pista e può tagliare le piste sul layer di segnale corrente o su tutti i layer di segnale visibili. Per accedere allo strumento, scegliere il comando Edit » Slice Tracks dai menu principali.
Dopo aver avviato il comando, il cursore assumerà la forma di un mirino e verrà richiesto di scegliere il punto iniziale del taglio. Inoltre, viene applicato un filtro per mostrare solo gli oggetti pista nell'area di lavoro. Verranno mostrate tutte le piste su tutti i layer di segnale visibili oppure solo quelle sul layer di segnale corrente, a seconda della configurazione attiva di Track Slicer. Per tagliare una o più piste:
- Posizionare il cursore, quindi fare clic o premere Enter per fissare il punto iniziale del taglio.
- Spostare il cursore attraverso il punto della pista, o delle piste, in cui si desidera effettuare il taglio: il percorso dello strumento è indicato da una linea, con un'anteprima visiva dei tagli previsti.
- Fare clic o premere Enter per fissare il punto finale del percorso di taglio.
- Continuare a tagliare altri segmenti di pista oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di taglio.
Dopo aver scelto il punto di ancoraggio iniziale del taglio e durante lo spostamento della «linea di taglio», è possibile eseguire le seguenti azioni aggiuntive:
- Premere il tasto B per passare dal taglio delle piste sul solo layer di segnale corrente al taglio delle piste su tutti i layer di segnale visibili e viceversa.
- Premere Spacebar per alternare l'angolo di taglio tra incrementi di 45 gradi e un angolo qualsiasi.
- Premere il tasto N per alternare il lato della lama di taglio tra sinistra, destra e centro.
- Premere il tasto / per selezionare tutte le piste tagliate.
- Premere il tasto "," per selezionare le piste tagliate a sinistra dello strumento.
- Premere il tasto "." per selezionare le piste tagliate a destra dello strumento.
- Premere il tasto M per non selezionare alcuna pista tagliata.
-
Premere il tasto Tab per accedere alla finestra di dialogo Slicer Properties, dalla quale è possibile modificare al volo le proprietà di Track Slicer.

La finestra di dialogo Slicer Properties
Conversione delle piste in un percorso smussato
La smussatura degli angoli di instradamento a 90 gradi è una tecnica utilizzata per ridurre le riflessioni causate dall'angolo in un percorso a frequenze di microonde. È possibile utilizzare archi, ma questi devono avere un raggio pari ad almeno 3 volte la larghezza della pista. La smussatura (detta anche taglio a mitra) è un'alternativa in cui viene tagliata la punta esterna dell'angolo. Poiché gli oggetti pista di Altium Designer hanno estremità arrotondate, non possono essere utilizzati per creare un angolo smussato. Per creare l'angolo smussato, i segmenti di pista selezionati vengono sostituiti con oggetti regione.
Seleziona tutti i segmenti di pista da smussare, quindi seleziona il comando Tools » Convert » Convert Selected Tracks to Chamfered Path dai menu principali. Si aprirà la finestra di dialogo Convert Tracks to Chamfered Path. Utilizza questa finestra di dialogo per configurare la smussatura, quindi fai clic su OK. Ogni coppia di segmenti di pista selezionata (con angoli a 90 gradi da correggere) verrà sostituita con un raccordo smussato e i segmenti di pista originali di ciascuna coppia verranno convertiti in un unico oggetto regione piena (di rame).

Le piste selezionate verranno smussate della quantità specificata in corrispondenza di ogni angolo retto.
Utilizza le seguenti opzioni nella finestra di dialogo per configurare la smussatura:
- Chamfer - porzione dell'angolo esterno da tagliare, o smussare, espressa come percentuale della distanza diagonale dell'angolo esistente.
- Inside Chamfer - quantità di materiale da aggiungere all'angolo interno espressa come percentuale della distanza diagonale dell'angolo esistente.
How big should the Chamfer be?
La percentuale di smussatura è la frazione asportata della diagonale tra l'angolo interno e quello esterno della curva non smussata.
La smussatura ottimale per un'ampia gamma di geometrie di microstriscia è stata determinata sperimentalmente da Douville e James. Secondo i loro risultati, una buona approssimazione della percentuale di smussatura ottimale è data da
A condizione che
e con la costante dielettrica del substrato
.
Questa formula è del tutto indipendente da
. L'intervallo effettivo dei parametri per il quale Douville e James presentano dati sperimentali è
e
. Riportano un VSWR migliore di 1,1 (ovvero una riflessione inferiore a −26 dB) per qualsiasi percentuale di smussatura che si discosti da quella fornita dalla formula di non più del 4% (del valore originale di Al valore minimo di
pari a 0,25, la percentuale di smussatura è del 98,4%, quindi la striscia risulta quasi completamente tagliata.
Proprietà della pista

La modalità Track del pannello Properties.
Informazioni sulla net
Questa sezione fornisce informazioni sulla net a cui appartiene la pista, nonché sulla coppia differenziale e/o sull'xSignal di cui la net fa eventualmente parte. Le informazioni sulla classe vengono mostrate ove applicabile. Vengono inoltre forniti i valori Delay, Length, Max Current e Resistance.
Consulta la pagina Tecniche di posizionamento e modifica del PCB per saperne di più sulle informazioni relative alle net.
Posizione
-
(X/Y)
- X (primo campo) – la coordinata X (orizzontale) corrente del punto di riferimento della pista rispetto all'origine corrente dello spazio di progettazione. Modifica il valore per cambiare la posizione X della pista. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore in unità diverse da quelle predefinite correnti.
- Y (secondo campo) – la coordinata Y (verticale) corrente del punto di riferimento della pista rispetto all'origine corrente. Modifica il valore per cambiare la posizione Y della pista. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore in unità diverse da quelle predefinite correnti.
Proprietà
- Component – questo campo viene mostrato nell'editor PCB solo quando la pista selezionata fa parte di un componente PCB e visualizza il designatore del componente PCB a cui appartiene. Seleziona il collegamento cliccabile Component per aprire la modalità Component del pannello Properties per il componente a cui appartiene.
- Net – consente di scegliere una net per la pista. Tutte le net del progetto della scheda attiva saranno elencate nell'elenco a discesa. Nota che, se il posizionamento di un oggetto inizia nella stessa posizione di un oggetto esistente già collegato a una net, la proprietà Net del nuovo oggetto viene automaticamente assegnata a quella net. Seleziona No Net per specificare che la pista non è collegata ad alcuna net. La proprietà Net di una primitiva viene utilizzata dal controllo delle regole di progettazione per determinare se un oggetto PCB è posizionato correttamente. In alternativa, puoi fare clic sull'icona Assign Net per scegliere un oggetto nello spazio di progettazione: la net di tale oggetto verrà assegnata alle piste selezionate.
- Layer – utilizza l'elenco a discesa per selezionare il layer su cui si trova la pista.
- Width – visualizza la larghezza corrente della pista. Modifica questo campo per cambiare la larghezza della pista nell'intervallo da 0,001 mil a 10000 mil.
- Start (X/Y) – visualizza le coordinate X/Y correnti del punto iniziale della pista rispetto all'origine corrente.
- End (X/Y) – visualizza le coordinate X/Y correnti del punto finale della pista rispetto all'origine corrente.
-
Length – visualizza la lunghezza corrente della pista. Modifica questo campo per cambiare la lunghezza della pista nell'intervallo da 0,001 mil a 10000 mil.
Espansione della maschera per pasta saldante
- Rule/Manual – selezionare la configurazione desiderata per l'espansione della maschera per pasta saldante. Selezionare Rule affinché l'espansione della maschera per pasta saldante della pista segua il valore definito nella regola di progettazione Espansione della maschera per pasta saldante applicabile. Selezionare Manual per ignorare la regola di progettazione applicabile e specificare il valore di espansione della maschera per pasta saldante della pista. Sarà quindi possibile abilitare e inserire la misura desiderata.
Espansione della maschera di saldatura
- Rule/Manual – selezionare la configurazione desiderata per l'espansione della maschera di saldatura. Selezionare Rule affinché l'espansione della maschera di saldatura della pista segua il valore definito nella regola di progettazione Espansione della maschera di saldatura applicabile. Selezionare Manual per ignorare la regola di progettazione applicabile e specificare il valore di espansione della maschera di saldatura della pista. Sarà quindi possibile abilitare e inserire la misura desiderata.
Lavorare con gli archi
Un arco è un oggetto di progettazione primitivo. Si tratta essenzialmente di un segmento di pista circolare che può essere posizionato su qualsiasi layer. Gli archi possono avere diversi utilizzi nel layout PCB. Ad esempio, possono essere utilizzati per definire i contorni dei componenti sui layer di serigrafia, oppure su un layer meccanico per indicare il contorno della scheda, i bordi delle aperture e così via. Possono inoltre essere utilizzati per creare percorsi curvi durante lo sbroglio interattivo. Gli archi possono essere aperti oppure chiusi per creare un cerchio (spesso definito arco a cerchio completo).

Due archi posizionati: a sinistra un arco a cerchio completo, a destra un arco selezionato per la modifica.
Gli archi possono essere posizionati sia nell'Editor PCB sia nell'Editor delle librerie PCB. Sono disponibili quattro modalità di posizionamento degli archi (Centro, Bordo, Angolo qualsiasi e Cerchio completo). Il modo in cui viene posizionato un arco dipende dal metodo di posizionamento scelto:
-
Place arc by center – questo metodo consente di posizionare un oggetto arco utilizzando il centro dell'arco come punto iniziale.
Dopo aver avviato il comando, il cursore assume la forma di un mirino e si entra nella modalità di posizionamento degli archi. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il centro dell'arco.
- Spostare il cursore per regolare il raggio dell'arco, quindi fare clic o premere Enter per impostarlo.
- Spostare il cursore per regolare il punto iniziale dell'arco, quindi fare clic o premere Enter per fissarlo.
- Spostare il cursore per modificare la posizione del punto finale dell'arco, quindi fare clic o premere Enter per fissarlo e completare il posizionamento dell'arco.
- Continuare a posizionare altri archi oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
-
Place arc by edge – questo metodo consente di posizionare un oggetto arco utilizzando il bordo dell'arco come punto iniziale. L'angolo dell'arco è fisso a 90°.
Dopo aver avviato il comando, il cursore assume la forma di un mirino e si entra nella modalità di posizionamento degli archi. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il punto iniziale dell'arco.
- Spostare il cursore per modificare la posizione del punto finale dell'arco, quindi fare clic o premere Enter per fissarlo e completare il posizionamento dell'arco.
- Continuare a posizionare altri archi oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
-
Place arc by edge (any angle) – questo metodo consente di posizionare un oggetto arco utilizzando il bordo dell'arco come punto iniziale. L'angolo dell'arco può assumere qualsiasi valore.
Dopo aver avviato il comando, il cursore assume la forma di un mirino e si entra nella modalità di posizionamento degli archi. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il punto iniziale dell'arco.
- Spostare il cursore per regolare il raggio dell'arco, quindi fare clic o premere Enter per fissare il centro.
- Spostare il cursore per modificare la posizione del punto finale dell'arco, quindi fare clic o premere Enter per fissarlo e completare il posizionamento dell'arco.
- Continuare a posizionare altri archi oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
-
Place full circle arc – questo metodo consente di posizionare un arco di 360° (cerchio completo).
Dopo aver avviato il comando, il cursore assume la forma di un mirino e si entra nella modalità di posizionamento degli archi. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il centro dell'arco.
- Spostare il cursore per regolare il raggio dell'arco, quindi fare clic o premere Enter per impostarlo e completare il posizionamento dell'arco.
- Continuare a posizionare altri archi oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
Durante il posizionamento è possibile eseguire anche le seguenti azioni:
- Per tutti i metodi (esclusi gli archi a cerchio completo), premere Spacebar prima di definire il punto finale dell'arco per disegnare l'arco nella direzione opposta.
- Premere il tasto L per ribaltare l'arco sull'altro lato della scheda; questa operazione è possibile solo prima di fissare il punto iniziale/centrale dell'arco.
- Premere i tasti + e - (sul tastierino numerico) oppure utilizzare le scorciatoie Shift+Ctrl+Wheelroll per scorrere avanti e indietro tutti i layer visibili del progetto e cambiare rapidamente il layer di posizionamento.
Il metodo di modifica grafica consente di selezionare un oggetto arco posizionato direttamente nell'area di progettazione e modificarne graficamente le dimensioni, la forma o la posizione.
Quando si seleziona un oggetto arco, sono disponibili le seguenti maniglie di modifica:

Un arco selezionato
- Fare clic e trascinare A per regolare il raggio.
- Fare clic e trascinare B per regolare i punti estremi (angoli iniziale e finale).
-
Fare clic in un punto qualsiasi dell'arco lontano dalle maniglie di modifica, quindi trascinare per riposizionarlo. In alternativa, fare clic sul centro dell'arco e trascinarlo. Durante il trascinamento, l'arco può essere ruotato o specchiato:
- Premi Spacebar per ruotare l'arco in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. La rotazione avviene in base al valore di Rotation Step, definito nella pagina Editor PCB – Generale della finestra di dialogo Preferences.
- Premi i tasti X o Y per specchiare l'arco lungo l'asse X o Y.
Proprietà dell'arco

La modalità Arc di Properties.
Informazioni sulla net
Questa sezione fornisce informazioni sulla net a cui appartiene l'arco, nonché sulla coppia differenziale e/o sull'xSignal di cui la net fa eventualmente parte. Le informazioni sulla classe vengono mostrate ove pertinente. Sono inoltre riportati i valori di Delay, Length, Max Current e Resistance.
Consulta la pagina Tecniche di posizionamento e modifica dei PCB per maggiori informazioni sulle net.
Posizione
-
(X/Y)
- X (primo campo) - questo campo mostra la posizione X corrente del centro dell'arco rispetto all'origine corrente. Modifica il valore nel campo per cambiare la posizione dell'arco rispetto all'origine corrente. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore espresso in unità diverse da quelle predefinite. Le unità predefinite (metriche o imperiali) sono determinate dall'impostazione Units nella sezione Other del pannello Properties in modalità Board (accessibile quando nessun oggetto è selezionato nello spazio di progettazione) e vengono utilizzate se l'unità non è specificata.
- Y (secondo campo) - questo campo mostra la posizione Y corrente del centro dell'arco rispetto all'origine corrente. Modifica il valore nel campo per cambiare la posizione dell'arco rispetto all'origine corrente. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore espresso in unità diverse da quelle predefinite. Le unità predefinite (metriche o imperiali) sono determinate dall'impostazione Units nella sezione Other del pannello Properties in modalità Board (accessibile quando nessun oggetto è selezionato nello spazio di progettazione) e vengono utilizzate se l'unità non è specificata.
Proprietà
- Component – questo campo viene mostrato nell'editor PCB solo quando l'arco selezionato fa parte di un componente PCB e visualizza il designatore del componente PCB a cui appartiene. Seleziona il collegamento Component per aprire la modalità Componente del pannello Proprietà per il componente a cui appartiene.
- Net – consente di scegliere una net per l'arco. Tutte le net del progetto della scheda attiva sono elencate nell'elenco a discesa. Nota che, se il posizionamento dell'oggetto inizia nella stessa posizione di un oggetto esistente già collegato a una net, la proprietà Net del nuovo oggetto viene automaticamente assegnata a tale net. Seleziona No Net per specificare che l'arco non è collegato ad alcuna net. La proprietà Net di una primitiva viene utilizzata dal controllo delle regole di progettazione per determinare se un oggetto PCB è posizionato correttamente. In alternativa, puoi fare clic sull'icona Assign Net per scegliere un oggetto nello spazio di progettazione: la net di tale oggetto verrà assegnata agli archi selezionati.
- Layer - questo campo mostra il layer a cui è attualmente assegnato l'arco. Gli archi possono essere assegnati a qualsiasi layer disponibile. Per cambiare il layer assegnato, fai clic sul campo e seleziona un layer dall'elenco a discesa.
- Width - questo campo mostra la larghezza della linea dell'arco. Se necessario, inserisci un valore diverso per la larghezza.
- Radius - questo campo mostra il raggio dell'arco, misurato dal punto centrale al centro della linea dell'arco. Se necessario, inserisci un valore diverso per il raggio.
- Start Angle - questo campo mostra l'angolo iniziale dell'arco, misurato dall'asse X nel primo quadrante (geometria piana). Se necessario, inserisci un valore diverso per l'angolo iniziale.
- End Angle - questo campo mostra l'angolo finale dell'arco. Se necessario, inserisci un valore diverso per l'angolo finale.
- Propagation Delay - questo campo mostra il tempo impiegato da un segnale per propagarsi lungo tale percorso.
Espansione della maschera per pasta saldante
- Rule - seleziona questa opzione affinché l'espansione della maschera per pasta saldante dell'arco segua il valore definito nella regola di progettazione Espansione della maschera per pasta saldante applicabile. Se scegli questa opzione, il valore di espansione associato verrà disabilitato.
- Manual - seleziona questa opzione per ignorare la regola di progettazione applicabile e specificare il valore di espansione della maschera per pasta saldante per l'arco nel campo sottostante.
Espansione della maschera di saldatura
- Rule - seleziona la casella affinché l'espansione della maschera di saldatura dell'arco segua il valore definito nella regola di progettazione Espansione della maschera di saldatura applicabile. Se scegli questa opzione, il valore di espansione associato verrà disabilitato.
- Manual - seleziona la casella per ignorare la regola di progettazione applicabile e specificare il valore di espansione della maschera di saldatura per l'arco nel campo sottostante.
Creazione di contorni attorno agli oggetti selezionati con piste e archi
Il comando Tools » Outline Selected Objects dei menu principali può essere utilizzato per posizionare un contorno di piste e archi attorno alle primitive libere selezionate nel progetto. Questa funzionalità può essere particolarmente utile se desideri isolare elettricamente le net critiche collegando il contorno a un riferimento di massa. Dopo l'avvio del comando, gli oggetti verranno contornati con piste e/o archi. Le piste e gli archi del contorno vengono posizionati con una larghezza di 8 mil e la proprietà Net impostata su No Net.
Vengono rispettate le regole di progettazione relative a distanza di isolamento, larghezza e cortocircuito, pertanto le violazioni delle distanze di isolamento verranno segnalate dal controllo delle regole di progettazione.
Lavorare con i rettangoli
Un rettangolo può essere posizionato su qualsiasi layer. Rettangoli di varie dimensioni possono essere combinati per coprire aree di forma irregolare e possono anche essere combinati con segmenti di pista o di arco.
I rettangoli possono essere posizionati anche su layer non elettrici. Ad esempio, posiziona un rettangolo sul layer Keep-Out per designare un'area vietata allo sbroglio automatico. Posiziona un rettangolo su un layer del piano di alimentazione, della maschera di saldatura o della maschera per pasta saldante per creare un'apertura su tale layer.

Un rettangolo posizionato
I rettangoli possono essere posizionati sia nell'editor PCB sia nell'editor delle librerie PCB nei seguenti modi:
- Editor PCB - sono disponibili i seguenti metodi di accesso:
- Scegliere Place » Rectangle dai menu principali.
- Fare clic sul pulsante Rectangle nel menu a discesa sulla Active Bar situata nella parte superiore dell'area di progettazione. (Tenere premuto un pulsante Active Bar per accedere agli altri comandi correlati. Dopo essere stato utilizzato, un comando diventa la prima voce in quella sezione della Active Bar.)
- Fare clic con il pulsante destro del mouse nell'area di progettazione, quindi fare clic su Place » Rectangle nel menu contestuale.
-
Editor di librerie PCB - sono disponibili i seguenti metodi di accesso:
- Scegliere Place » Rectangle dai menu principali.
- Fare clic sul pulsante Rectangle nel menu a discesa sulla Active Bar situata nella parte superiore dell'area di progettazione. (Tenere premuto un pulsante Active Bar per accedere agli altri comandi correlati. Dopo essere stato utilizzato, un comando diventa la prima voce in quella sezione della Active Bar.)
- Fare clic con il pulsante destro del mouse nell'area di progettazione, quindi selezionare Place » Rectangle dal menu contestuale.
Dopo aver avviato il comando, il cursore assume la forma di un mirino e si accede alla modalità di posizionamento dei rettangoli. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fare clic o premere Enter per fissare il primo angolo del rettangolo.
- Spostare il cursore per regolare le dimensioni del rettangolo, quindi fare clic o premere Enter per fissare l'angolo diagonalmente opposto e completare il posizionamento del rettangolo.
- Continuare a posizionare altri rettangoli oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
Durante il posizionamento è possibile eseguire anche le seguenti azioni:
- Premere il tasto Tab per sospendere il posizionamento e accedere alla modalità Rettangolo del pannello Properties , in cui è possibile modificarne le proprietà al volo. Fare clic sul pulsante di pausa sovrapposto all'area di progettazione per riprendere il posizionamento.
- Premere la barra spaziatrice per scorrere le varie modalità degli angoli. Selezionare Rectangle per gli angoli retti, Fillet per gli angoli arrotondati oppure Chamfer per gli angoli smussati/inclinati.
- Premere i tasti + e - (sul tastierino numerico) per scorrere avanti e indietro tutti i layer visibili del progetto e cambiare rapidamente il layer di posizionamento.
- Tenere premuto il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.
Il metodo di modifica grafico consente di selezionare un oggetto rettangolo posizionato direttamente nell'area di progettazione e di modificarne graficamente dimensioni, forma o posizione.
Quando si seleziona un oggetto rettangolo, sono disponibili le seguenti maniglie di modifica.
Un rettangolo selezionato
- Fare clic e trascinare gli angoli (A) per ridimensionare il rettangolo contemporaneamente in direzione verticale e orizzontale.
- Fare clic e trascinare i punti centrali dei lati (B) per ridimensionare il rettangolo separatamente in direzione verticale e orizzontale.
-
Fare clic in un punto qualsiasi del rettangolo lontano dalle maniglie di modifica e trascinare per riposizionarlo. Durante il trascinamento, il rettangolo può essere ruotato o specchiato:
- Premere Spacebar per ruotare il rettangolo in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. La rotazione avviene in base al valore di Rotation Step definito nella pagina Editor PCB – Generale della finestra di dialogo Preferences.
- Premere i tasti X o Y per specchiare il rettangolo lungo l'asse X o Y.
Proprietà del rettangolo

La modalità Rectangle del pannello Properties.
Posizione
-
(X/Y)
- X (primo campo) - la coordinata X (orizzontale) corrente del punto di riferimento del rettangolo, rispetto all'origine corrente dell'area di progettazione. Modificare questo campo per cambiare la posizione X del rettangolo. Il valore può essere immesso in unità metriche o imperiali; specificare le unità quando si immette un valore con unità diverse da quelle predefinite correnti.
- Y (secondo campo) - la coordinata Y (verticale) corrente del punto di riferimento del rettangolo, rispetto all'origine corrente. Modificare questo campo per cambiare la posizione Y del riempimento. Il valore può essere immesso in unità metriche o imperiali; specificare le unità quando si immette un valore con unità diverse da quelle predefinite correnti.
- Rotation - l'angolo di rotazione del rettangolo (in gradi), misurato in senso antiorario a partire da zero (l'orizzontale 3 o'clock). Modificare questo campo per cambiare la rotazione del rettangolo. La risoluzione angolare minima è 0,001°.
Proprietà
-
Corner Mode - utilizzare il menu a discesa per selezionare la modalità desiderata per gli angoli del rettangolo tra le seguenti opzioni:
- Rectangle - specifica che il rettangolo posizionato avrà angoli retti.
- Fillet - specifica che il rettangolo posizionato avrà angoli arrotondati.
- Chamfer - specifica che il rettangolo posizionato avrà angoli smussati o inclinati.
- Track Width - visualizza la larghezza corrente della pista. Modificare questo campo per cambiare la larghezza della pista nell'intervallo da 0,001 mil a 10000 mil.
- Fillet/Chamfer Size - disponibile solo quando è selezionato Fillet o Chamfer nel menu a discesa Corner Mode oppure se durante il posizionamento è stata scelta la modalità raccordo o smusso.
- Layer - il layer a cui è attualmente assegnato il rettangolo. I rettangoli possono essere assegnati a qualsiasi layer disponibile. Utilizzare il menu a discesa per selezionare un layer diverso.
- Width - visualizza la larghezza (asse X) del rettangolo selezionato.
- Height - visualizza l'altezza (asse Y) del rettangolo selezionato.
-
- fai clic su questa icona per mantenere il rapporto X/Y esistente del rettangolo.
