제어 임피던스 라우팅
개요
- 반사와 링잉 같은 신호 무결성 문제가 무엇인지, 스위칭 속도가 빨라질수록 임피던스 제어 라우팅이 왜 더 중요해지는지 알아봅니다.
- Trace 길이가 문제가 되는 시점을 추정하는 경험 법칙을 비롯해, 설계에서 임피던스 제어를 고려해야 하는지 평가하는 방법을 살펴봅니다.
- 라우팅을 결정하기 전에 Altium Designer의 Signal Integrity 도구로 컴포넌트 임피던스 정합과 Net 분석을 수행하는 방법을 이해합니다.
소자의 스위칭 속도가 증가하면서 임피던스 제어 라우팅은 디지털 설계자에게 중요한 주제가 되었습니다. 이 페이지에서는 Signal 무결성 분석 엔진을 사용하여 컴포넌트의 임피던스를 정합하는 방법과 PCB Editor의 임피던스 제어 라우팅 기능을 소개합니다.
엔지니어링 분야에는 디지털 설계에 종사하는 전자 엔지니어는 두 부류뿐이라는 말이 있습니다. Signal 무결성 문제를 겪어 본 사람과 앞으로 겪게 될 사람입니다. 불과 몇 년 전만 해도 Signal 무결성은 전문가의 영역이었으며, 고속 설계에서만 고려하면 되는 문제였습니다. 하지만 당시 고속 설계에 사용되던 소자의 스위칭 속도는 더 이상 특별하지 않으며, 빠르게 일반적인 수준이 되고 있습니다. 집적 회로 기술의 발전으로 트랜지스터 크기가 작아질수록 스위칭 속도는 빨라집니다. 디지털 Signal의 무결성에 영향을 미치는 것은 바로 이 스위칭 속도입니다.
다행히 올바른 설계 원칙을 따르고 임피던스가 제어되는 보드로 설계를 구현하면 잠재적인 Signal 무결성 문제를 상당수 방지할 수 있습니다. 이를 위해서는 설계 도구에 특정 기능이 필요합니다. 링잉과 반사 문제가 발생할 가능성이 있는 네트를 감지하는 분석 도구와 올바른 라우팅 임피던스를 구현할 수 있는 보드 설계 도구가 필요합니다. Altium Designer의 PCB Editor는 이러한 기능을 제공합니다.
이 페이지에서는 Signal 무결성 문제의 원인과 보드에서 이러한 문제가 발생할 가능성을 파악하는 데 도움을 드립니다. 또한 잠재적인 SI 문제를 최소화하기 위해 적용해야 하는 두 가지 설계 방식인 컴포넌트 임피던스 정합과 임피던스 제어 라우팅을 설명합니다.
라우팅이 회로의 일부가 되는 시점
소자의 스위칭 속도가 증가할수록 인쇄 회로 기판 설계자와 제조업체에 대한 요구 사항도 늘어납니다. Signal의 스위칭 에지가 차지하는 길이가 이를 전달하는 PCB Trace의 길이보다 짧아지면, 해당 Trace를 회로의 일부로 취급해야 합니다. 이 Trace에는 임피던스가 있으며, 이를 characteristic impedance (Zo)라고 합니다.
이러한 추가 회로 요소의 영향을 관리하는 가장 좋은 방법은 전체 길이에 걸쳐 특성 임피던스가 일정하게 유지되도록 Trace 라우팅을 설계하는 것입니다. 이 기법을 controlled impedance routing이라고 합니다.
Trace 라우팅의 임피던스는 다음 요소에 의해 결정됩니다.
- Cross-sectional area of the trace - 폭, 높이(구리 두께), 에칭 공정 중 형성되는 Trace 가장자리의 경사에 따라 결정됩니다.
- Distance from the trace to the reference plane(s) - Signal 에너지의 귀환 경로는 Signal 경로만큼 중요합니다. 이 귀환 경로는 인접한 기준 평면에서 Signal 경로를 따라갑니다.
- Properties of the surrounding materials - Signal의 에너지는 Trace의 구리 내부에만 머무르지 않습니다. 표피 효과로 인해 Trace 주변의 유전체 물질을 따라서도 전달됩니다. 유전체 물질의 유전율은 유전체가 해당 에너지의 흐름에 얼마나 영향을 미치는지를 나타냅니다.

Simbeor 임피던스 계산기는 지정된 임피던스를 구현하는 데 필요한 폭을 계산합니다.
임피던스 제어 라우팅이 필요할까요?
임피던스 제어 라우팅까지 신경 써야 하는지 궁금하신가요?
이상적인 상황에서는 컴포넌트 출력 핀에서 나오는 모든 에너지가 PCB의 연결된 Track으로 결합되고, PCB 라우팅을 통해 반대쪽 부하의 입력 핀으로 전달된 후 해당 부하에 흡수됩니다. 에너지가 부하에 모두 흡수되지 않으면 남은 에너지가 PCB 라우팅으로 반사되어 소스 출력 핀으로 되돌아갈 수 있습니다. 이 반사 에너지는 원래 Signal과 상호 작용하며, 에너지의 극성에 따라 원래 Signal에 더해지거나 원래 Signal에서 차감되어 링잉을 일으킵니다. 링잉이 충분히 크면 Signal의 무결성에 영향을 미쳐 예측할 수 없는 잘못된 회로 동작을 유발합니다.
그렇다면 이런 현상이 발생할 가능성을 어떻게 알 수 있을까요? Signal이 부하 핀에 도달하기 전에 소스 핀이 에지 전환을 완료할 수 있다면, 설계가 반사 에너지의 영향을 받을 수 있는 조건이 성립합니다. SI 문제의 발생 가능성을 판단하는 데 흔히 사용하는 경험칙은 "상승 시간의 1/3" 법칙입니다. 이 법칙에 따르면 Trace의 전파 지연이 상승 시간의 1/3보다 길면 반사(링잉)가 발생할 수 있습니다. 소스 핀의 상승 시간이 1ns라면 전파 지연이 0.33ns를 초과하는 경로(FR4에서 약 2인치)는 전송선으로 간주해야 하며, Signal 무결성 문제가 발생할 수 있습니다. 사용하는 소자의 상승 시간이 이 정도이고 이와 같은 길이의 라우팅이 필요하다면 PCB에서 Signal 무결성 문제가 발생할 수 있습니다.
임피던스는 어떻게 제어하나요?
소스와 부하 사이에서 에너지가 반복적으로 반사되는 상황을 어떻게 방지할 수 있을까요? 임피던스를 정합하면 됩니다. 임피던스 정합을 통해 모든 에너지가 소스에서 라우팅으로, 이어서 라우팅에서 부하로 결합되도록 할 수 있습니다. 임피던스를 고려하여 보드를 라우팅하는 것을 임피던스 제어 라우팅이라고 합니다. 다시 말해, 임피던스가 관리되는 보드를 임피던스 제어 PCB라고 합니다.
임피던스 정합을 구현하는 데는 두 가지 별개의 요소가 있습니다. 첫 번째는 컴포넌트의 임피던스를 정합하는 것이고, 두 번째는 필요한 임피던스를 갖도록 보드를 라우팅하는 것입니다.
컴포넌트의 임피던스 정합
라우팅만으로는 임피던스 제어 PCB를 구현할 수 없습니다. 먼저 컴포넌트의 임피던스를 확인하고, 필요한 경우 정합해야 합니다.
보드 설계 프로세스를 시작하기 전에 필요한 추가 종단 컴포넌트를 포함할 수 있도록 설계 입력 단계에서 잠재적인 Signal 무결성 문제가 있는 네트를 감지하는 것이 이상적입니다. 출력 핀은 임피던스가 낮고 입력 핀은 임피던스가 높으므로, 임피던스를 정합하려면 설계에 종단 컴포넌트를 추가해야 할 가능성이 높습니다.
Schematic 입력 단계에서 설계의 Signal 무결성을 분석할 수 있습니다. Tools » Signal Integrity 명령을 실행하면 모든 컴포넌트에 Signal 무결성 모델이 할당되지 않았음을 나타내는 Errors or Warnings 대화 상자가 나타나는 경우가 많습니다. Signal 무결성 분석 엔진은 컴포넌트의 참조 지정자를 기반으로 Default 모델을 자동 선택합니다. Default 모델을 사용하려면 Continue을 클릭하고, 모델을 검토하고 변경하려면 Model Assignments을 클릭합니다. Signal Integrity Panel의 Model Assignments 버튼을 통해 언제든지 Signal Integrity Model Assignments 대화 상자에 액세스할 수 있습니다.
설계 분석
Tools » Signal Integrity 명령을 실행하면 설계가 분석되고, 아래와 같이 잠재적인 문제가 있는 Net이 Signal Integrity Panel에 표시됩니다.
설계 입력 과정에서 잠재적인 Signal 무결성 문제가 있는지 설계를 테스트합니다.
Panel에서 선택한 Net 하나 또는 여러 Net에 대해 반사 분석을 수행할 수 있습니다. 왼쪽에는 설계의 모든 Net에 대한 분석 결과가 표시됩니다. Net을 선택하고
버튼을 클릭하거나 Net 이름을 두 번 클릭하면 해당 Net이 Panel 오른쪽의 Net 필드로 이동합니다. 여기에서 다음을 포함하여 해당 Net에 대한 상세 분석을 수행할 수 있습니다.
- 해당 Net의 핀을 확인합니다. 한 번 클릭하면 Schematic의 해당 핀으로 크로스 프로빙할 수 있으며, 두 번 클릭하면 해당 핀에 할당된 모델을 확인하고 구성할 수 있습니다.
- 해당 Net에 대해 하나 이상의 이론적 종단 옵션을 활성화합니다.
- Net에 대해 반사 분석을 수행하여 Net의 각 핀에서 나타나는 동작을 보여 주는 파형 집합을 생성합니다.
Panel에서는 가능한 종단 구성과 값을 다양하게 시험할 수 있습니다. 위 이미지에 표시된 Signal Integrity Panel의 Termination 영역에는 Serial Res 옵션이 활성화되어 있습니다. 아래 Panel 섹션에는 직렬 종단 저항이 표시됩니다. 여기에서 반사 분석에 사용할 이론적 직렬 종단 저항의 최솟값과 최댓값을 정의합니다. 직접 값을 입력하려면 Suggest 확인란을 선택 해제하십시오.
결과 살펴보기
Reflection Waveforms 버튼을 클릭하면 해당 Net에 대해 정밀한 반사 분석이 수행되고, 결과가 새 파형 창(*.SDF)에 표시됩니다.
파형 창에는 다음이 포함됩니다.
- 분석 중인 각 Net의 차트. 창 하단의 탭을 클릭하여 차트 간에 전환할 수 있습니다.
- 각 차트에는 해당 Net의 각 핀에 대한 플롯이 포함되며, 해당 핀의 Signal 동작을 보여 줍니다.
아래 이미지는 이전 Panel 이미지에서 선택한 Net의 입력 핀에 대한 결과 그래프 두 개를 보여 줍니다. 첫 번째 그래프는 종단이 없는 Net의 입력 핀을 보여 줍니다. 두 번째 그래프에는 총 6회의 스윕이 표시됩니다. 하나는 원래의 종단되지 않은 Net에 대한 것이고, 나머지 5개는 소스 핀에 이론적 직렬 종단 저항을 추가한 경우입니다.
이론적 종단 저항을 Min = 20Ω에서 Max = 60Ω까지 단계적으로 변경하면서 반사 분석을 5회 수행했습니다(Sweep Steps 옵션 값 = 5). 5회의 분석 결과(첫 번째는 20Ω, 마지막은 60Ω)가 그래프 오른쪽에 나열됩니다. 각 레이블을 클릭하면 해당 결과가 강조 표시되고 오른쪽 하단에 이론적 종단 저항값이 표시됩니다. 이 Net에 40Ω의 직렬 종단 저항을 사용하면 오른쪽 이미지에서 선택된 그래프와 같은 결과를 얻을 수 있습니다.
왼쪽 그래프는 잠재적인 Signal 무결성 문제가 있는 Net의 반사 분석 결과를 보여 줍니다. 오른쪽 그래프는 동일한 Net에 약 40Ω의 이론적 직렬 종단 저항을 추가한 결과입니다.
라우팅 임피던스를 결정하는 요소는 무엇인가요?
임피던스가 제어된 PCB를 구현하는 두 번째 단계는 Track이 정해진 임피던스를 갖도록 보드를 라우팅하는 것입니다. 라우팅 경로의 치수와 PCB 제작에 사용되는 재료의 특성 등 여러 요소가 Signal 라우팅의 임피던스에 영향을 미칩니다.
PCB Editor에는 Simberian의 Simbeor® 전자기 Signal 무결성 엔진이 포함되어 있습니다. Simbeor의 모델 정확도는 3D 전파 해석을 위한 고급 알고리즘, 벤치마킹 및 실험적 검증을 통해 검증됩니다. Simbeor 엔진은 모든 최신 보드 구조와 재료를 지원합니다.
Simbeor 버전
Simbeor SFS
임피던스는 준정적 전자기장 해석기인 Simbeor SFS로 계산됩니다. Simbeor SFS는 모멘트법에 기반한 고급 준정적 2D 전자기장 해석기로, 수렴성 검증, 비교 및 측정을 통해 검증되었습니다. 이 해석기는 유전체와 도체의 경계를 메시로 분할하고 해당 방정식을 풀어 전신 방정식에 사용할 주파수 의존 RLGC 행렬을 구성합니다.
Simbeor SFS는 전파 해석기가 아닙니다. PCB 상호 연결에서 전파되는 파동은 준TEM 특성을 가지므로, 임피던스, 지연 또는 감쇠를 평가하는 데 전파 해석기는 필요하지 않습니다. 이러한 파동은 준정적 2D 전자기장 해석기로 추출한 RLGC 매개변수를 사용하여 정확하게 시뮬레이션할 수 있습니다.
Simbeor SFS 해석기의 고유한 특징은 도체 표면 거칠기 모델을 지원한다는 점입니다. 다층 도체 모델(도금)은 지원하지 않으며, 모든 도체에 동일한 표면 거칠기가 적용됩니다. 해석 결과에 마이크로스트립 선로에서 발생하는 고주파 분산(고주파에서 유전율이 더 높은 유전체에 전자기장이 더 집중되는 현상)이 포함되지 않으므로 이 해석기는 준정적 해석기입니다.
► Simberian 전자기 Signal 무결성 기술에 대해 자세히 알아보기
지원되는 PCB 구조
다음 PCB 구조의 임피던스를 계산할 수 있습니다.
- 마이크로스트립
- 대칭 스트립라인
- 비대칭 스트립라인
- 싱글 및 차동 코플래너 구조
- 서로 다른 유전 특성을 가진 여러 개의 인접 유전체 레이어.
임피던스 제어 라우팅을 위한 PCB 구성
임피던스 제어 라우팅은 특정 임피던스를 얻기 위해 배선 치수와 기판 재료의 특성을 구성하는 작업입니다. 이 작업은 PCB 편집기의 Layer Stack Manager에서 수행합니다. Layer Stack Manager,을 열려면 메인 메뉴에서 Design » Layer Stack Manager을 선택합니다. Layer Stack Manager은 회로도 시트, PCB 및 기타 문서 유형과 마찬가지로 문서 편집기에서 열립니다.
특정 임피던스를 얻는 데 필요한 트레이스 폭은 Layer Stack Manager의 Impedance 탭에서 구성하는 임피던스 프로파일의 일부로 계산됩니다.
계산에는 다음 정보가 사용됩니다.
- Impedance 탭에서 구성한 Target Impedance, Target Tolerance 및 Roughness의 값
-
Stackup 탭에서 정의한 다음 재료 설정:
- 신호 레이어의 두께,
- 주변 유전체 레이어의 두께(기준 평면까지의 거리),
- 유전체 재료의 특성(유전율 Dk 및 손실 계수 Df).
이러한 항목을 올바르게 구성하면 임피던스 계산기에 다음 값을 계산하는 데 필요한 정보가 충분히 제공됩니다.
- Trace 폭
- 계산된 임피던스(Z)
- 공통 모드 임피던스(Zcomm)
- 임피던스 편차(Z Deviation)
- 전파 지연(Tp)
- 단위 길이당 인덕턴스(p.u.l.)
- 단위 길이당 커패시턴스(p.u.l.)
아래와 같이 Layer Stack Manager에서 Impedance 탭을 선택하면 계산된 값이 Properties 패널의 Transmission Line 섹션에 표시됩니다.
최상위 레이어에 라우팅된 개별 네트에 대해 정의된 50Ω 임피던스 프로파일입니다. 이미지 위에 커서를 올리면 레이어 L3에 대한 동일한 프로파일의 설정이 표시됩니다(이미지 제공: FEDEVEL Open Source, www.fedevel.com).
레이어 적층 구성
Main page: 레이어 스택 정의
구리 및 유전체 제조 레이어는 Layer Stack Manager의 Stackup 탭에서 구성합니다.
- 이 탭에서 레이어를 추가, 제거 및 구성합니다. 리지드 플렉스 설계의 경우 이 탭에서 레이어를 활성화하거나 비활성화할 수도 있습니다.
-
현재 선택된 레이어의 속성은 그리드 또는 Properties 패널에서 직접 편집할 수 있습니다. 설계 공간 하단의
버튼을 클릭하여 패널을 활성화합니다.
- 레이어 그리드에서 마우스 오른쪽 버튼을 클릭하거나 Edit » Add Layer 명령을 사용하여 레이어를 추가합니다. 구리 레이어를 추가할 때 기존 인접 레이어도 구리 레이어인 경우 유전체 레이어도 함께 추가됩니다.
- Properties 패널의 Board 섹션에서 Stack Symmetry 옵션이 활성화되어 있으면 중앙 유전체 레이어를 중심으로 서로 대응하는 레이어가 쌍으로 추가됩니다.
- 레이어의 Material은 선택한 Material 셀에 직접 입력하거나 Select Material 대화 상자에서 선택할 수 있습니다. 줄임표 버튼을 클릭하면 대화 상자가 열립니다.
- 구리 레이어에는 표면 마감을 추가할 수 있습니다. Add Layer 하위 메뉴를 사용하여 현재 선택된 구리 레이어에 Surface Finish 레이어를 추가한 다음, 새 표면 마감 레이어의 줄임표 버튼을 클릭하여 마감 유형을 선택합니다.
- 마우스 오른쪽 버튼 클릭 메뉴 또는 Edit 메뉴를 사용하여 선택한 레이어를 같은 유형의 레이어 내에서 위나 아래로 이동할 수 있습니다.
- Properties 패널의 Board 영역에는 Stack Symmetry 및 Library Compliance을 적용하는 옵션이 포함되어 있습니다. 이에 대해서는 아래에서 자세히 설명합니다.
- Properties 패널의 Board 영역에는 현재 선택된 스택(다중 스택 리지드/플렉스 설계의 경우 하위 스택)의 요약 정보가 표시됩니다.
레이어 스택 고려 사항
임피던스를 제어하기 위한 기본 요구 사항은 각 신호 경로 아래에 신호 리턴 경로를 포함하는 것입니다. Simbeor SI 엔진은 평면 레이어와 폴리곤으로 덮인 신호 레이어를 모두 지원합니다. 이러한 리턴 경로 레이어는 기판 적층 전반에 분산 배치해야 합니다. 이상적으로는 임피던스 제어 라우팅이 적용된 각 신호 레이어에 하나 이상의 리턴 경로 레이어가 인접하도록 배치합니다. 인접한 리턴 경로 레이어는 신호 리턴 경로를 제공하며, 여기서는 자세히 다루지 않지만 해당 평면이 분배하는 DC 전압과 관계없이 이 역할을 수행합니다.
평면을 통해 흐르는 리턴 경로 전류는 신호 레이어의 배선과 동일한 물리적 경로를 따르려 하므로, 중요한 신호 배선 아래의 리턴 경로 레이어에 분할이나 컷아웃과 같은 불연속 요소가 생기지 않도록 하는 것이 중요합니다.
신호 레이어와 평면 레이어의 적절한 순서를 선택하는 것 외에도 다음을 포함한 각 레이어의 재료 특성을 정의해야 합니다.
- 구리 두께
- 유전체 두께
- 유전 상수
이러한 값과 배선 폭은 모두 최종 임피던스에 영향을 줍니다. 따라서 필요한 임피던스를 얻으려면 이 모든 값을 조정해야 합니다. 사용 가능한 구리 및 유전체 두께 값은 PCB 제조업체에서 제공하는 재료에 따라 제한될 수도 있다는 점을 기억하세요.
임피던스 프로파일 정의
Simbeor 엔진은 PCB 편집기의 Layer Stack Manager(Design » Layer Stack Manager)에 내장되어 있습니다. 임피던스 제어 라우팅을 위한 레이어 스택을 구성하려면 Layer Stack Manager's Impedance 탭으로 전환하여 임피던스 프로파일을 추가하고 구성합니다.
최상위 레이어에 라우팅된 개별 네트에 대해 정의된 50Ω 임피던스 프로파일입니다. 이미지 위에 커서를 올리면 레이어 L3에 대한 동일한 프로파일의 설정이 표시됩니다.
임피던스 프로파일 생성 및 구성 시 참고 사항:
- 위에 표시된 것처럼 Layer Stack Manager에서 Impedance 탭으로 전환합니다.
-
버튼(프로파일이 이미 정의되어 있는 경우
버튼)을 클릭하여 새 프로파일을 추가합니다.
- Properties 패널에서 필요한 임피던스의 Type, Target Impedance 및 Target Tolerance을 정의합니다. Description은 선택 사항이며, 임피던스 프로파일 이름이 표시되는 모든 위치에 함께 표시됩니다.
-
레이어 그리드는 두 영역으로 나뉩니다. 왼쪽에는 적층의 레이어가 표시되고, 오른쪽 임피던스 프로파일 영역에는 적층의 각 신호 레이어에 해당하는 레이어가 표시됩니다. 프로파일 영역의 레이어 체크박스를 사용하여 해당 레이어의 임피던스 계산을 활성화합니다. 위 이미지를 예로 들어 맨 왼쪽 열에 표시된 레이어 번호를 보면, 레이어
L1,L3,L10및L12의 레이어 체크박스가 선택되어 있어 임피던스 계산이 활성화되어 있습니다. - Profile Region에서 활성화된 레이어를 클릭하면 선택한 Signal 레이어의 임피던스를 계산하는 데 사용되는 레이어를 제외한 레이어 스택의 모든 레이어가 흐리게 표시됩니다(위 이미지 참조). Impedance Profile Region의 Top Ref 및 Bottom Ref 열에서 해당 레이어의 참조 레이어를 편집합니다. 참조 레이어의 레이어 Type 은(는)
Plane또는 Signal일 수 있습니다. 예를 들어, 위 이미지에서는 스택업의L10레이어가 임피던스 계산에 사용되도록 활성화되어 있으며, Top Ref은(는)Plane레이어인9-L9(으)로 설정되어 있고, Bottom Ref는 Signal 레이어인11-L11(으)로 설정되어 있습니다. 소프트웨어는 Signal 레이어가 참조 평면으로 사용되는 경우 해당 레이어에 전원 또는 접지 Net에 연결된 연속적인 구리 평면이 포함되어 있다고 가정합니다. - 이 임피던스로 라우팅할 다른 각 레이어의 Impedance Profile 확인란을 선택하고 참조 평면을 구성합니다. 위 이미지 위에 커서를 올리면 L3 레이어의 S50 임피던스 프로파일이 표시됩니다.
- 계산된 라우팅 Trace 폭이 제작을 의뢰할 수 없는 값인 경우 폭 및 간격 설정을 조정할 수 있습니다.
폭 및 간격 설정 조정
소프트웨어는 타겟 임피던스와 허용 오차를 기준으로 Trace 폭을 계산합니다. 계산된 Trace 폭이 0.0683mm처럼 제작을 의뢰할 수 없는 값이 되는 경우는 드물지 않습니다. 제조업체는 사용 가능한 재료 두께와 Trace 폭에 대해 구현 가능한 정밀도를 안내해 줍니다. 이후에는 원하는 값에서 시작하여 치수를 실제로 구현 가능한 값으로 조정하면서 계산된 임피던스 값에 미치는 영향을 확인하는 과정을 거치게 됩니다.
이러한 설정 테스트 및 조정 과정을 지원하기 위해 임피던스 계산기는 정방향 및 역방향 임피던스 계산을 지원합니다. Default 모드는 정방향입니다(임피던스를 입력하면 소프트웨어가 폭을 계산).
아이콘은 계산되는 변수를 나타냅니다.
타겟 임피던스가 50Ω이면 정방향으로 계산된 폭(W1)은 94.6µm입니다. 오른쪽 이미지는 폭(W1)을 95µm로 설정했을 때의 역방향 계산 결과를 보여줍니다.
계산 방향을 반대로 바꾸고 선택한 레이어에 대해 다양한 Trace 폭을 검토하려면 새 Width (W1) 값을 입력하고 키보드의 Enter를 누릅니다. 해당 폭으로 변경한 영향이 반영되도록 계산 값이 업데이트됩니다.
버튼을 클릭하면 계산기가 정방향 계산 모드로 돌아갑니다. Width (W2)에 새 값을 입력하면 Etch 값이 변경됩니다.
Differential Pair 전송선의 결과를 검토하려면 해당
버튼을 클릭하여 Trace Width 또는 Trace Gap 중 계산할 변수를 지정합니다. 다른 변수를 편집하여 Target Impedance을(를) 변경하거나, Target Impedance을(를) 변경하여 다른 변수에 미치는 영향을 확인합니다.
에칭 계수
PCB의 Signal Trace는 불필요한 구리를 에칭으로 제거하여 제작합니다. 에칭액은 표면의 구리부터 에칭하기 시작하므로 표면의 구리가 에칭액과 접촉하는 시간이 더 길어집니다. 그 결과 아래 이미지와 같이 완성된 Trace의 가장자리에 경사가 생기고, 완성된 Trace의 단면적이 줄어듭니다.
에칭 중 손실된 Trace 가장자리 구리의 면적(양쪽 가장자리) = X * Y
이 경사의 정도를 에칭 계수라고 하며, 다음과 같이 정의합니다.
Etch Factor = Y/X
Y = X인 경우 Etch Factor = 1
Properties Panel에 표시된 이미지를 참조하면 다음과 같습니다.
? 위에 커서를 올리면 수식이 표시됩니다.
에칭 계수의 표준 정의는 trace thickness / amount of over-etching의 비율로 지정하는 것입니다. 이에 따른 수식은 다음과 같습니다.
Etch Factor = T/[0.5(W1-W2)]
이 방식의 단점은 과도한 에칭이 없음을 지정하려면(즉, Trace 가장자리가 수직임을 의미) 에칭 계수에 inf(무한대) 값을 입력해야 한다는 점입니다. 에칭 정도를 더 간단히 지정할 수 있도록 수식을 역수 형태로 바꾸어, 0(0) 값을 입력하면 과도한 에칭이 없음을 나타내도록 했습니다.
Etch = [0.5(W1-W2)]/T
구리 방향
에칭 계수에 영향을 주는 또 다른 제조 요소는 구리의 방향입니다. PCB Trace는 유전체 기판에 적층된 연속적인 구리 시트에서 불필요한 구리를 에칭으로 제거하여 형성됩니다. 구리 방향은 구리가 해당 기판에서 돌출되는 방향을 정의합니다. 위쪽 또는 아래쪽 중 구리를 에칭하는 방향으로 생각할 수도 있습니다.
Trace Inverted 확인란을 클릭하면 구리 방향이 위쪽에서 아래쪽으로 전환됩니다.
도체 표면 거칠기
인쇄 회로 기판의 각 구리 레이어 표면에는 어느 정도의 거칠기가 있습니다. PCB 제조 과정에서는 구리와 유전체 레이어 사이의 접착력을 높이기 위해 구리 레이어의 표면을 처리하여 거칠기를 높입니다. 이 표면 거칠기는 10 GB/s 이상의 스위칭 속도에서 도체 임피던스에 큰 영향을 주는 요인이 됩니다. 광범위한 연구와 분석을 통해 업계 전문가들은 Surface Roughness 및 Roughness Factor 값에서 도출된 거칠기 보정 계수를 사용하여 표면 거칠기를 모델링할 수 있다는 결론을 내렸습니다.
Roughness 설정은 Properties Panel의 Layer Stack Manager 모드에서 사용할 수 있습니다. 이 매개변수는 전도성 레이어에만 사용됩니다.
거칠기:
-
Model Type - 표면 거칠기의 영향을 계산하는 데 사용할 모델입니다(다양한 모델에 대한 자세한 내용은 아래 문서 참조). 서브스택의 모든 구리 레이어에 적용됩니다.
-
Surface Roughness - 표면 거칠기 값입니다(제조업체에서 제공받을 수 있음). 0~10µm 사이의 값을 입력합니다. Default 값은 0.1µm입니다.
-
Roughness Factor - 거칠기 효과로 인해 예상되는 도체 손실의 최대 증가 정도를 나타냅니다. 1~100 사이의 값을 입력합니다. Default 값은 2입니다.
추가 참고 자료
- 인터커넥트의 신호 손실 및 분산에 대한 도체 거칠기의 영향을 분석하는 실용적인 방법론: Y. Shlepnev, C. Nwachukwu, DesignCon2012.
- 인터커넥트 도체 표면 거칠기 모델링을 위한 통합 접근법: Y. Shlepnev, 2017 IEEE 제26회 전자 패키징 및 시스템의 전기적 성능 학술대회(EPEPS2017)
동일 평면 전송선 구조 지원
Layer Stack Manager의 임피던스 계산기는 싱글 및 차동 동일 평면 구조를 지원합니다. 새 임피던스 프로파일을 생성한 다음, 임피던스 프로파일 Type 드롭다운 목록에서 Single-Coplanar 또는 Differential-Coplanar를 선택합니다.
동일 평면 구조 작업:
- 표준 싱글 및 차동 임피던스와 마찬가지로 각 변수의 값은 사용자가 정의한 Target Impedance 및 Target Tolerance 과 보드 레이어의 물리적 특성을 기반으로 자동 계산됩니다. 이렇게 자동 계산된 값은 Properties 패널의 Layer Stack Manager 모드에 있는 편집 상자에 새 값을 입력하여 조정할 수 있습니다.
- 동일 평면 구조로 라우팅할 신호 네트를 지정하려면 라우팅 폭(또는 차동 쌍 라우팅) 설계 규칙에서 Use Impedance Profile 옵션을 활성화하고 필요한 동일 평면 임피던스 프로파일을 선택합니다.
- 동일 평면 구조에는 신호 경로 양쪽에 기준 평면이 필요합니다. 이는 폴리곤을 배치하여 만들거나, 스티칭 비아가 추가된 경우 Add Shielding to Net 명령으로 만들 수 있습니다(자세한 내용은 아래 참조). 폴리곤을 배치하는 경우, 이 폴리곤과 신호 경로 사이의 간격은 Simbeor 임피던스 계산기가 결정한 Clearance (S) 값으로 정의됩니다(위와 아래 이미지의 Properties 패널에 표시됨). 기준 폴리곤과 신호 경로 사이의 클리어런스를 제어하도록 클리어런스 설계 규칙을 구성합니다(이미지 보기).
-
동일 평면 구조가 접지된 경우 신호 트레이스 양쪽을 따라 비아 펜스를 배치하는 것이 일반적입니다. PCB 편집기에서 Tools » Via Stitching/Shielding » Add Shielding to Net 명령을 사용하면 됩니다. 이 명령은 비아를 배치할 뿐만 아니라, Add shielding copper 옵션을 활성화하면 아래 오른쪽 이미지와 같이 신호 라우팅 주변에 비아 펜스를 덮는 폴리곤도 배치할 수 있습니다.
► 비아 차폐 자세히 알아보기
임피던스 계산기는 신호 특성과 클리어런스를 결정합니다(첫 번째 이미지). 해당 클리어런스를 비아 차폐의 거리 설정에 사용합니다.
레이어 재료 선택
임피던스 제어 설계에서는 레이어 스택업에 사용되는 재료를 선택하는 것이 매우 중요합니다.
예를 들어 PCB 제조에 가장 일반적으로 사용되는 재료는 양면에 동박을 접합한 유리 섬유 보강 에폭시 수지입니다. 유리 섬유 직물의 직조 밀도는 유전 상수 Dk(유전율)와 손실 탄젠트 Df의 값 및 균일성에 영향을 줍니다. 직조된 유리 섬유 직물은 수지로 둘러싸여 있으며, 사용된 수지의 비율도 재료의 성능에 중요합니다.
유리 섬유 직조 패턴은 매우 다양합니다. PCB 제조에 사용되는 유리 섬유 기반 재료의 특성을 예측하고 성능을 보장할 수 있도록 IPC는 직조에 관한 표준을 마련하고 있습니다.
IPC standard IPC-4412B: Specification for Finished Fabric Woven from "E" Glass for Printed Boards
재료 라이브러리
설계자는 Layer Stack Manager에서 재료 특성을 직접 편집하거나 Altium Material Library에서 재료를 선택할 수 있습니다.
전체 라이브러리는 Altium 재료 라이브러리 대화상자(Tools » Material Library)에서 확인하고 항목을 추가할 수 있습니다.
재료는 용도별 범주로 구성되어 있으며, 대화상자 왼쪽의 트리 구조를 통해 접근할 수 있습니다. 각 용도별 범주는 그 아래에서 기능별 범주로 세분화됩니다. 예를 들어 PCB layer material 범주에는 Conductive layer material, Dielectric layer material, 및 Surface Layer Material i가 있습니다.
재료 추가, 저장 및 불러오기
트리에서 특정 재료 범주를 선택하면 라이브러리에 새 재료를 추가할 수 있습니다. 외부 재료 라이브러리에 정의된 재료는 불러올 수 있으며(Load 버튼), Altium Material Library 대화상자에서 추가한 사용자 정의 재료는 사용자 라이브러리에 저장할 수도 있습니다(Save 버튼). 사용자 정의 재료만 저장됩니다.
재료에 Custom 속성 추가
라이브러리에 있는 재료(기본 및 사용자 정의 재료)에 Custom 속성을 추가할 수 있습니다. Custom 속성을 추가하려면 먼저 왼쪽 트리에서 해당 노드를 선택하여 속성을 추가할 재료를 지정한 다음,
버튼을 클릭하여 Material Library Settings 대화상자를 엽니다.
그런 다음 Altium Material Library 대화상자에서 선택한 재료에 필요한 값을 추가할 수 있습니다. 행을 선택하고 Edit 버튼을 클릭합니다.
속성 Panel
레이어 스택 문서의 Impedance 탭이 활성화되어 있으면 Properties 패널에서 임피던스 프로파일 요구 사항을 구성할 수 있습니다. 그런 다음 라우팅 폭 또는 차동 쌍 라우팅 설계 규칙에서 필요한 임피던스 프로파일을 선택할 수 있습니다.
-
Impedance Profile
- Description – 의미 있는 설명을 입력합니다. 이 필드는 선택 사항이며, 임피던스 프로파일 이름이 표시되는 모든 위치에 표시됩니다.
- Type – 드롭다운을 사용하여 임피던스 유형을 선택합니다. 선택 항목은 Single, Differential, Single-Coplanar 및 Differential-Coplanar입니다.
- Target Impedance – 달성하려는 임피던스를 입력합니다.
- Target Tolerance – 달성하려는 공차를 입력합니다. 제작업체와 협의하여 실제로 구현 가능한 공차 값을 확인해야 합니다.
-
Transmission Line
- Trace inverted – Properties Panel에 표시된 것처럼 Trace를 반전하려면 이 옵션을 활성화합니다. 이 옵션은 Stackup 탭이 활성화되어 있을 때 표시되는 Copper Orientation 옵션과 동일하며, 구리가 코어에 적층되는 방향을 정의합니다. 구리 방향은 구리가 해당 기판에서 돌출되는 방향을 나타냅니다. 위쪽 또는 아래쪽 중 구리가 에칭되는 방향으로 생각할 수도 있습니다.
-
Etch – 에칭 계수는
= T/[(W1-W2)/2]이며, Trace의 전체 단면적을 구리 두께의 제곱만큼 줄입니다. 제작 공정에서 발생하는 Etch에 대한 정보는 보드 제작업체에 문의하십시오.
-
Width (W1) / (W2) – W1은 라우팅하는 Trace의 폭이고, W2는 Etch 계수를 적용하여 에칭한 후 해당 Trace의 윗면 폭입니다. Trace 폭에는 정방향/역방향 계산 기능을 사용할 수 있습니다. Default는 입력한 Target Impedance을 기준으로 폭을 계산하는 방식입니다(정방향 계산). 이때 계산된 폭이 5.978처럼 제작업체에서 구현하기 어려운 값일 수 있으며, 제작업체는 6.0처럼 더 현실적인 값을 원할 수 있습니다. Width 필드에 6.0을 입력하고 키보드에서 Enter 키를 누르면 계산된 값(Impedance, Deviation 등)을 다시 계산할 수 있습니다.
버튼이 회색으로 바뀌고(비활성화됨) 역방향 계산 모드로 전환됩니다. 버튼을 클릭하여 활성화하면 다시 정방향 모드로 전환되고 Width (W1)은 계산된 값으로 되돌아갑니다. 이 기능을 사용하면 실제로 제작 가능한 폭 옵션을 검토할 수 있습니다. W2 값을 수동으로 입력하면 이에 맞게 에칭 계수가 업데이트됩니다.
- Impedance – 소프트웨어는 보드 제작에 사용되는 재료(구리, 코어 및 프리프레그)의 특성과 Trace의 단면적(Trace의 폭, 두께 및 에칭 계수로 결정됨)을 기준으로 임피던스를 계산합니다.
- Deviation – 원하는 값(타겟 임피던스)과 얻어진 값(계산된 임피던스) 사이의 차이를 나타냅니다. 소프트웨어는 보드 제작에 사용되는 재료(구리, 코어 및 프리프레그)의 특성과 Trace의 단면적(Trace의 폭, 두께 및 에칭 계수로 결정됨)을 기준으로 임피던스 편차(입력한 재료와 치수를 바탕으로 실제로 얻어지는 값)를 계산합니다.
- Delay – Signal이 송신측에서 수신측까지 이동하는 데 걸리는 시간입니다.
- Inductance – 임피던스 계산기는 Impedance 값을 사용하여 단위 길이당 인덕턴스를 계산합니다.
- Capacitance – 임피던스 계산기는 Impedance 값을 사용하여 단위 길이당 커패시턴스를 계산합니다.
-
Board
- Stack Symmetry – 중앙 유전체 레이어를 중심으로 서로 대응하는 레이어 쌍을 추가하려면 활성화합니다. 활성화하면 즉시 중앙 유전체 레이어를 기준으로 레이어 스택의 대칭 여부를 검사합니다. 중앙 유전체 기준 레이어에서 같은 거리에 있는 레이어 쌍 중 하나라도 서로 동일하지 않으면 스택이 대칭이 아님 대화 상자가 열립니다.
- Library Compliance – 활성화하면 재료 라이브러리에서 선택한 각 레이어의 현재 속성을 라이브러리에 정의된 해당 재료의 값과 비교하여 확인합니다.
- Substack – 현재 선택한 서브스택에 대한 정보(레이어, 유전체, 두께 등)입니다. 다른 서브스택으로 전환하면 현재 선택한 서브스택에 맞게 이 정보가 업데이트됩니다.
- Stack Name – 의미 있는 서브스택 이름을 입력합니다. 이 필드는 X/Y 스택업 Region에 레이어 서브스택을 할당할 때 유용합니다.
- Is Flex – 서브스택이 Flex인 경우 활성화합니다.
- Layers – 총 레이어 수입니다.
- Dielectrics – 총 유전체 수입니다.
- Conductive Thickness – 전도성 레이어의 두께입니다. 구리 Signal 레이어를 전도성 레이어라고 합니다.
- Dielectric Thickness – 유전체 레이어의 두께입니다.
- Total Thickness – 보드의 총 두께입니다.
- Other
-
Roughness – 전도성 레이어의 거칠기를 표시합니다.
- Model Type – 표면 거칠기의 영향을 계산하는 데 사용할 기본 모델입니다(다양한 모델에 대한 자세한 내용은 아래 문서 참조). 스택의 모든 구리 레이어에 적용됩니다(서브스택이어야 하나요?).
- Surface Roughness – 표면 거칠기 값입니다(제작업체에서 제공). 0~10µm 사이의 값을 입력합니다. Default는 0.1µm입니다.
- Roughness Factor – 거칠기 효과로 인해 예상되는 도체 손실의 최대 증가량을 나타냅니다. 1~100 사이의 값을 입력합니다. Default는 2입니다.
Design Rule 구성
라우팅 임피던스는 배선의 폭과 높이, 주변 유전체 재료의 특성에 따라 결정됩니다. 각 임피던스 프로파일을 생성할 때 Layer Stack Manager에 정의된 재료 특성을 기준으로 필요한 라우팅 폭이 계산됩니다. 재료 특성에 따라 라우팅 레이어가 바뀌면 폭도 달라질 수 있습니다. 라우팅 레이어를 변경할 때 폭도 변경해야 하는 이러한 요구 사항은 PCB Rule 및 제약 조건 Editor(Design » Rules)에서 구성한 해당 라우팅 Design Rule에 의해 자동으로 관리됩니다.
대부분의 보드 설계에서는 특정 Net 그룹을 제어 임피던스로 라우팅합니다. 일반적으로 아래 이미지와 같이 이러한 Net을 포함하는 Net 클래스 또는 Differential Pair 클래스를 생성한 다음, 이 클래스를 타겟으로 하는 라우팅 Rule을 생성합니다.
일반적으로 모든 레이어에 적용하려면 상단 제약 조건 설정에서, 레이어별로 적용하려면 레이어 Grid에서 Min, Max 및 Preferred Widths을 수동으로 정의합니다. 제어 임피던스 라우팅의 경우에는 대신 Use Impedance Profile 옵션을 활성화한 다음 드롭다운에서 필요한 임피던스 프로파일을 선택합니다. 이렇게 하면 Rule의 Constraints Region이 변경됩니다. 가장 먼저 눈에 띄는 변화는 사용 가능한 레이어 Region에 보드의 모든 Signal 레이어가 더 이상 표시되지 않는다는 점입니다. 이제 선택한 임피던스 프로파일에서 활성화된 레이어만 표시됩니다. Preferred Width 값(및 Differential Pair 간격)은 각 레이어에 대해 계산된 폭(및 간격)을 반영하도록 업데이트됩니다. 이러한 권장 값은 편집할 수 없지만 Min 및 Max 값은 편집할 수 있습니다. 이 값을 적절히 더 작거나 큰 값으로 설정합니다. 그런 다음 일반적인 방식으로 Net을 대화형으로 라우팅할 수 있습니다.
라우팅 너비 Design Rule
단면 Net의 라우팅 너비는 라우팅 너비 설계 Rule로 정의됩니다.
임피던스 프로파일 사용을 선택하면 사용 가능한 레이어와 권장 너비가 선택한 프로파일에 따라 결정됩니다.
Differential Pair 라우팅 Design Rule
Differential Pair의 라우팅은 Differential Pair 라우팅 설계 Rule로 제어됩니다.
Differential Pair의 경우 사용 가능한 레이어, 권장 너비 및 권장 간격이 선택한 프로파일에 따라 결정됩니다.
► Differential Pair 라우팅에 대해 자세히 알아보기
리턴 경로 Design Rule
리턴 경로의 단절이나 폭이 좁아지는 부분은 리턴 경로 설계 Rule로 감지할 수 있습니다. 리턴 경로 설계 Rule은 Rule의 대상 신호 위나 아래에 지정된 참조 레이어에서 신호 리턴 경로가 연속적으로 이어지는지 확인합니다. 리턴 경로는 참조 신호 레이어 또는 평면 레이어에 배치된 필, 영역 및 폴리곤 포어로 생성할 수 있습니다.
리턴 경로 레이어는 Return Path 설계 Rule에서 선택한 Impedance Profile에 정의된 참조 레이어입니다. 이러한 레이어를 검사하여 신호 경로를 따라 지정된 Minimum Gap(신호 가장자리 바깥쪽으로 확보해야 하는 너비)이 존재하는지 확인합니다. High Speed Rule 범주에 새 Return Path 설계 Rule을 추가합니다.
리턴 경로 레이어는 선택한 Impedance Profile에 정의되며, 경로 너비(신호 가장자리 바깥쪽 너비)는 Minimum Gap로 정의됩니다.
아래 이미지는 Minimum Gap 설정이 0.1mm인 경우 신호 NetX에서 감지된 리턴 경로 오류를 보여줍니다. Preferences 대화 상자에서 DRC Violation Display Style가 위반 오버레이는 표시하지 않고 위반 세부 정보만 표시하도록 설정하면 리턴 경로 오류를 더 쉽게 찾을 수 있습니다(이미지 보기). 이렇게 하면 위반이 발생한 객체 전체가 아니라 Rule을 충족하지 못한 정확한 위치가 강조 표시됩니다.
► Altium Designer의 고속 설계에 대해 자세히 알아보기
요구 임피던스에 맞춘 Net 라우팅
기판을 라우팅하고 레이어를 변경하면 소프트웨어가 지정된 임피던스를 구현하는 데 필요한 크기로 Track 너비를 자동 조정합니다. 이러한 대화형 임피던스 제어 라우팅은 임피던스 제어 PCB 설계 작업을 크게 간소화합니다.
배선 길이 튜닝
고속 설계 라우팅의 핵심 과제 두 가지는 배선의 임피던스를 제어하고 중요 Net의 길이를 일치시키는 것입니다. 임피던스 제어 라우팅은 출력 핀에서 나가는 신호가 대상 입력 핀에서 올바르게 수신되도록 보장합니다. 배선 길이를 일치시키면 타이밍이 중요한 신호가 대상 핀에 동시에 도달하도록 할 수 있습니다. 배선 길이 튜닝 및 길이 일치는 Differential Pair 라우팅에서도 필수적인 요소입니다.
Differential Pair의 길이를 일치시키기 위해 라우팅에 아코디언 패턴이 추가되었습니다.
Interactive Length Tuning 및 Interactive Diff Pair Length Tuning 명령(Route 메뉴)은 설계의 가용 공간, Rule 및 장애물에 따라 진폭이 가변적인 파형 패턴(아코디언)을 삽입할 수 있도록 하여 Net 또는 Differential Pair의 길이를 동적으로 최적화하고 제어하는 수단을 제공합니다.
라우팅된 기판의 신호 무결성 테스트
설계 입력 단계에서 가정한 라우팅 길이와 라우팅 임피던스를 사용하여 Net을 테스트한 것과 마찬가지로, 라우팅이 완료되면 기판에서 이 과정을 반복하여 잠재적인 임피던스 불일치와 반사 문제를 확인해야 합니다. PCB 편집기의 Tools 메뉴에서 Signal Integrity 명령을 실행합니다. PCB는 프로젝트의 일부이므로 Layer Stack Manager에 정의된 재료 특성과 치수, 기판에 배선된 실제 너비를 사용하여 신호 무결성 테스트에 사용할 임피던스를 계산합니다.
지정된 임피던스 구현
올바른 임피던스를 구현하기 위해 치수를 반복적으로 조정하는 과정 외에도, 제작된 PCB의 최종 임피던스에 영향을 미치는 다른 요인이 있습니다. 여기에는 PCB에 사용되는 유전체 재료의 균일성과 안정성, 에칭 공정의 일관성과 품질이 포함됩니다. 임피던스 제어 PCB가 필요한 경우 PCB 제조업체와 이에 대해 논의해야 합니다. 일부 제조업체는 원하는 적층 구조를 제공하면 Track 형상에 대한 조언을 제공할 수 있습니다. 또한 많은 제조업체가 제작하는 각 패널에 임피던스 테스트 쿠폰을 포함할 수 있으며, 이를 사용하여 기판에서 구현된 실제 임피던스를 측정할 수 있습니다.
추가 참고 자료 및 리소스
이 문서에서는 신호 무결성과 임피던스 제어 PCB 설계의 기초를 소개합니다. 다음 링크를 통해 자세한 내용을 알아보고 업계에서 인정받는 전문가들이 개발한 리소스를 활용해 보세요.




