Planejamento de regiões rígidas e flexíveis - Modo avançado

Num relance

Este artigo explica como planejar e posicionar regiões rígidas e flexíveis da placa no Altium Designer usando o modo Rígido-Flexível Avançado, com uma comparação clara com o modo padrão para que você entenda quando o fluxo de trabalho avançado é necessário. Ele mostra como as regiões da placa são definidas, como identificar qual modo rígido-flexível uma PCB está usando, como trabalhar no Modo de Planejamento da Placa e como posicionar, nomear, atribuir empilhamentos de camadas e editar regiões com precisão. Também destaca os principais comportamentos de posicionamento, atalhos e propriedades das regiões que são importantes ao criar layouts rígido-flexíveis mais complexos. Se você quer um guia prático para configurar e gerenciar regiões de placas rígido-flexíveis avançadas com mais confiança, continue lendo.

- Você aprenderá a diferença entre o modo Rígido-Flexível Padrão e o modo Rígido-Flexível Avançado, e como isso muda a maneira como as regiões da placa são criadas e definidas.
- Você verá como posicionar e editar Regiões da Placa no Modo de Planejamento da Placa, incluindo a atribuição de nomes e empilhamentos de camadas e o uso de guias e do ajuste por atração para obter precisão.
- Você conhecerá atalhos, modos de posicionamento e configurações de propriedades úteis que ajudam a trabalhar com mais eficiência em layouts complexos de PCBs rígido-flexíveis.
Aprofunde-se com a IA:

Há dois modos de projeto rígido-flexível disponíveis no software de projeto de PCB da Altium. O modo original, ou padrão, chamado Rigid-Flex, oferece suporte a projetos rígido-flexíveis simples. Se o seu projeto tiver requisitos rígido-flexíveis mais complexos, como regiões flexíveis sobrepostas, será necessário usar o modo Advanced Rigid-Flex (também conhecido como rigid-flex 2.0). O modo é escolhido no menu Tools do Gerenciador de Empilhamento de Camadas.

A diferença fundamental entre os modos é que, no modo original, o formato da placa é dividido em regiões separadas pela inserção de uma Linha de Divisão, que permanece como um objeto que define onde uma região da placa termina e outra começa. No modo avançado, cada região da placa é inserida separadamente ou, se uma região maior for recortada, ela se torna dois objetos de região separados. No modo avançado, as bordas das regiões adjacentes da placa definem onde essas duas regiões se encontram, e não a presença de uma Linha de Divisão. Por causa dessa diferença, não há objeto Linha de Divisão quando a placa está no modo Advanced Rigid-Flex.

► Saiba mais sobre Como projetar uma PCB rígido-flexível

O menu View tem três modos de trabalho do editor de PCB com atalhos fáceis de lembrar, permitindo alternar rapidamente entre:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

O comportamento padrão ao alternar entre os modos de visualização 2D e 3D é manter configurações separadas de zoom e orientação para cada modo. Se quiser ver a mesma posição e orientação da placa ao alternar, pressione Ctrl+Alt+2 ou Ctrl+Alt+3, em vez de 2 ou 3.

Você acabou de abrir uma PCB e quer saber se ela está usando o modo rígido-flexível padrão ou o avançado?

Você pode abrir o Gerenciador de Empilhamento de Camadas para verificar. Como alternativa, mude para o Modo de Planejamento da Placa (atalho 1) e observe a Barra Ativa:

Modo Rigid-Flex padrão
Modo Advanced Rigid-Flex

Como inserir uma Região da Placa

Uma Região da Placa é um objeto poligonal inserido usando as técnicas padrão de inserção de objetos poligonais. O formato da placa deve ser definido com precisão, por isso é importante que as regiões que compõem a placa sejam criadas exatamente conforme necessário. O vídeo abaixo demonstra a criação de Regiões da Placa alinhando suas bordas com guias do espaço de projeto previamente posicionadas. A vantagem dessa técnica é que a posição das guias do espaço de projeto pode ser definida com precisão editando suas coordenadas no painel Properties.

Guias predefinidas do espaço de trabalho são usadas como referência para a inserção das Regiões da Placa.

As Regiões da Placa são inseridas e modificadas em Board Planning Mode:

  1. Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode. A Região da Placa existente por padrão será exibida como um retângulo verde.
  2. Selecione Place » Board Region para inserir uma nova região (ou clique no botão na Active Bar).
  3. Posicione o cursor e clique para fixar o vértice inicial da Região da Placa. A Região da Placa é um objeto poligonal, como uma Região ou um Polígono, e segue o mesmo processo de inserção (e edição).
  4. Mova o cursor para posicionar o segundo vértice. O comportamento padrão é inserir 2 bordas a cada clique, com um formato de canto definido pelo usuário entre elas; pressione Spacebar para alternar a direção do canto. Consulte a seção Placement Modes abaixo para obter mais detalhes sobre como alterar os modos de canto.
  5. Continue movendo o mouse e clicando para inserir vértices, criando as bordas necessárias para definir o formato geral da Região da Placa.
  6. Após inserir o último vértice, clique com o botão direito do mouse ou pressione Esc para fechar e concluir a definição do formato da placa. Não é necessário fechar manualmente o formato da placa, pois o software o completará automaticamente conectando o último ponto inserido ao ponto inicial.
  7. Cada Região da Placa recebe um nome para identificá-la de forma exclusiva. Insira um nome adequado no campo Name no modo Região da Placa do painel Propriedades (a Região da Placa deve estar selecionada no espaço de projeto para que suas propriedades sejam exibidas no painel).
  8. Cada Região da Placa deve ter um empilhamento de camadas atribuído. Quando uma nova Região da Placa é criada, ela recebe o empilhamento de camadas padrão, chamado Board Layer Stack. Atribua o empilhamento de camadas necessário no modo Board Region do painel Properties. Os empilhamentos de camadas são definidos e nomeados no Gerenciador de Empilhamento de Camadas.
  9. Se a PCB final exigir várias Regiões da Placa, continue definindo regiões adicionais.
  • Cada região exibe um rótulo com o nome da região e o nome do empilhamento de camadas atribuído a ela no formato Region Name - Layer Stack Name. A Região da Placa recebe seu nome no modo Board Region do painel Properties, e o Empilhamento de Camadas recebe seu nome no Gerenciador de Empilhamento de Camadas.
  • É possível inserir qualquer quantidade de Regiões da Placa para compor o Formato da Placa desejado. As Regiões da Placa podem se sobrepor; observe que isso não define a distância que uma região avança sobre a região vizinha. Essa distância é definida como parte da configuração do empilhamento de camadas no Gerenciador de Empilhamento de Camadas.
  • Uma Região da Placa é um objeto poligonal. Para modificar seu formato, clique uma vez para selecioná-la e, em seguida, clique e arraste uma borda ou alça de edição. Saiba mais sobre como editar um objeto poligonal. Observe que, no modo avançado, como as Regiões da Placa são editadas interativamente, não há mais comandos de edição no menu Design no Modo de Planejamento da Placa.
  • Para remover uma Região da Placa, selecione-a e pressione a tecla Delete no teclado. Deve haver sempre pelo menos uma Região da Placa; não será possível excluir a última.
  • Além de serem desenhadas, as Regiões da Placa também podem ser criadas a partir de primitivas — saiba mais na seção Conversão entre primitivas de desenho 2D e objetos de definição da placa desta página.
  • Durante a inserção ou edição de uma Região da Placa, o cursor é limitado pelas configurações de ajuste do cursor, que incluem: a Grade de Ajuste atual, os Objetos disponíveis para Ajuste, a presença de Guias do Espaço de Trabalho e as configurações de Ajuste aos Eixos — use esses recursos para ajudar a obter o formato desejado.

    ► Saiba mais sobre Como funciona o comportamento de ajuste.

Além disso, você pode pressionar a tecla Tab para pausar a inserção e acessar o modo Região da Placa do Properties painel, onde suas propriedades podem ser alteradas durante a operação. Clique no botão de pausa sobreposto ao espaço de projeto () para retomar a inserção.

Placement Modes

Ao redefinir o formato da placa, há cinco modos de canto disponíveis, quatro dos quais também têm submodos de direção do canto. Durante a redefinição:

  • Pressione Shift+Spacebar para alternar entre os cinco modos de canto disponíveis.
  • Pressione Spacebar para alternar entre os dois submodos de direção do canto.
  • Quando estiver em qualquer um dos modos de canto em arco, mantenha pressionada a  para reduzir ou a tecla para ampliar o arco. Mantenha a tecla Shift pressionada enquanto pressiona para acelerar o redimensionamento do arco.
  • Pressione a tecla de atalho 1 para alternar entre posicionar duas arestas por clique ou uma aresta por clique. No segundo modo, a aresta tracejada é chamada de segmento de antecipação (como mostrado na última imagem do conjunto abaixo).
  • Pressione a tecla Backspace para remover o último vértice.

Pressione Shift+Spacebar para percorrer os cinco modos de canto disponíveis; pressione o atalho 1 para alternar o posicionamento entre duas arestas ou uma aresta. 
 
 
Pressione Shift+Spacebar para percorrer os cinco modos de canto disponíveis; pressione o atalho 1 para alternar o posicionamento entre duas arestas ou uma aresta.

Criar uma região da placa a partir de um corpo 3D

As regiões da placa também podem ser criadas a partir de objetos de corpo 3D usando o comando Create Board Region from 3D Body no modo 3D. O procedimento é o seguinte:

  1. Certifique-se de que está visualizando a placa em 3D (caso contrário, use o atalho de teclado 3 para mudar rapidamente para esse modo).
  2. Escolha o comando Design » Board Shape » Create Board Region from 3D body nos menus principais.
  3. Posicione o cursor sobre o modelo 3D que deseja usar para gerar a região da placa para a PCB e clique ou pressione Enter. O modelo ficará transparente.
  4. Mova o cursor sobre o modelo 3D para localizar uma face. Quando uma superfície plana for encontrada sob o cursor, ela ficará opaca com uma borda azul fina.
  5. Quando a face apropriada for encontrada, clique ou pressione Enter - a nova região da placa será criada (substituindo a região da placa definida anteriormente no espaço de projeto).
  6. A caixa de diálogo Board Outline Creation Successful será exibida confirmando a criação bem-sucedida. Essa caixa de diálogo permite ocultar a peça do modelo e excluí-la da verificação DRC. Ela também oferece opções para modificar a altura do modelo para alinhar a face à superfície superior, à superfície inferior ou não alterar a posição.
O contorno da placa da face selecionada deve estar alinhado com a PCB para definir a região da placa. 

Criar uma região de recorte da placa

Para criar um recorte interno na placa, posicione uma região de recorte da placa (Place » Define Board Cutout, ou clique no botão em Active Bar). Um recorte da placa também é um objeto poligonal e, portanto, tem o mesmo processo de posicionamento da própria região da placa. As imagens abaixo mostram uma região da placa com dois recortes, que se tornam aberturas na placa quando ela é fabricada.

Um recorte posicionado em uma região da placa se torna uma abertura na placa acabada. Um recorte posicionado em uma região da placa se torna uma abertura na placa acabada.

Dividir o contorno da placa em regiões

Você pode dividir uma região da placa existente em duas regiões fazendo um corte nela. Isso é feito quando o editor de PCB está em Board Planning Mode.

A placa foi dividida em três Regiões da Placa usando o comando Dividir Região.

Para dividir uma Região da Placa:

  1. Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode.
  2. Selecione Design » Slice Board Region (ou clique no botão  na Barra Ativa) para entrar no modo Dividir Região da Placa.
  3. Ao selecionar o comando, você entra no modo de divisão, que é semelhante ao modo de posicionamento de trilhas. Começando fora da região a ser dividida, clique para fixar uma série de vértices que definem a linha de divisão. Ao definir a divisão, pressione Shift+Spacebar para alternar entre os modos de canto; pressione Spacebar para alternar entre os modos de canto Inicial e Final e use a tecla Backspace para remover o último canto posicionado. Posicione o final da linha de divisão além da borda da Região da Placa. Quando terminar de definir a divisão, clique com o botão direito do mouse ou pressione Esc para encerrar o comando.
  4. Uma caixa de diálogo de confirmação é aberta, informando o número de polígonos (regiões) que serão divididos pela sua ação e o número de polígonos (regiões) que serão criados. Clique em Yes para confirmar a criação.

Cada nova região criada pode herdar um ou mais componentes contidos na região original. Quando esses componentes pertencem a uma classe de componentes, uma nova classe será criada para cada nova região, e seus membros serão atualizados de acordo.

Criar Regiões da Placa a partir de objetos selecionados

Dependendo do formato da sua placa, pode ser mais eficiente construir seu formato criando várias Regiões da Placa. Conforme mencionado acima, as regiões podem ser posicionadas interativamente ou criadas traçando um contorno definido por objetos de trilha e arco. O vídeo abaixo demonstra a definição de três Regiões da Placa a partir de objetos selecionados. No vídeo, observe que o mesmo objeto é usado para definir as bordas adjacentes onde as regiões se tocam, garantindo que essas regiões sejam posicionadas com exatidão.

Uma abordagem comum é definir o contorno das regiões usando trilhas e arcos e, em seguida, criar as Regiões da Placa a partir dos contornos selecionados.

Converter entre primitivas de desenho 2D e objetos de definição da placa

Uma abordagem comum para definir o Formato da Placa e as Regiões da Placa necessárias nesse formato é importar um desenho de um software de CAD mecânico. Por exemplo, você pode importar detalhes mecânicos de um arquivo DWG, obtendo um conjunto de linhas (trilhas) em uma camada mecânica que definem: o formato da placa, as regiões dentro desse formato e, para um projeto rígido-flexível, linhas que definem a localização das linhas de dobra nas regiões flexíveis.

O software inclui vários comandos para ajudar a criar objetos de definição da placa (Região, Recorte, Linha de Dobra) a partir de primitivas de desenho 2D, além de comandos correspondentes para converter objetos de definição da placa de volta em primitivas de desenho.

Objeto A partir de primitivas de desenho 2D selecionadas A partir de objetos de projeto da placa
Região da Placa Create Board Region from Selected Objects
(submenu Design » Board Shape)
Explode Region to Free Primitives
Recorte da Placa Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Linha de Dobra Convert Selected Line to Bend Line Explode Bend Line

Observações:

  • Os comandos para ambas as direções estão disponíveis no submenu Tools » Convert do modo View correspondente (exceto o comando Criar Região da Placa a partir de Objetos Selecionados, que está no submenu Design » Board Shape).
  • Para converter primitivas de desenho 2D em objetos de definição da placa, altere a visualização para 2D Layout Mode.
    • As primitivas devem ser selecionadas antes de executar o comando.
    • As primitivas devem formar uma figura fechada para criar uma Região ou um Recorte. Consulte a caixa de aviso abaixo para saber mais sobre os requisitos dessa figura.
  • Para converter objetos de definição da placa em objetos de desenho 2D, altere a visualização para Board Planning Mode.
    • Esses comandos não exigem que os objetos sejam selecionados previamente, mas atuarão no objeto selecionado se já houver um.
    • Se houver várias Regiões da Placa, a Região desaparecerá quando for decomposta em primitivas. Se houver apenas uma Região da Placa, as primitivas serão criadas e a Região da Placa escolhida permanecerá (sempre deve haver uma Região da Placa).
    • Os objetos de desenho 2D são criados na camada mecânica Formato da Placa. Se não houver uma camada desse Tipo de Camada na placa, uma camada mecânica será adicionada com seu Tipo de Camada definido como Formato da Placa. Saiba mais sobre Camadas Mecânicas e Tipos de Camada.
    • Embora não exista um comando específico para reagrupar um objeto decomposto, você pode usar o comando Undo para fazer isso.
Todos os comandos que criam uma forma poligonal com base em um contorno construído com linhas (trilhas) e arcos tentarão identificar a forma seguindo a linha central dos objetos selecionados. Se as coordenadas da extremidade de um segmento de trilha/arco não coincidirem exatamente com as coordenadas do próximo segmento de trilha/arco, o algoritmo de identificação do contorno falhará, e uma mensagem será exibida mostrando o local da falha. Em seguida, será oferecida a opção de usar um algoritmo de traçado. Observe que o algoritmo de traçado segue a borda externa dos objetos de trilha/arco, de modo que a forma será ligeiramente diferente daquela criada a partir das linhas centrais. Escolha essa opção somente se o seu projeto puder aceitar o impacto dessa diferença.

Modificar as Regiões da Placa

Quando a PCB é configurada para usar o modo rígido-flexível padrão, o local onde duas regiões adjacentes se encontram é definido por uma linha divisória azul móvel. Essa abordagem não é usada no modo rígido-flexível avançado; em vez disso, cada região é uma forma poligonal fechada e independente. Por ser uma forma poligonal, cada região pode ser ajustada conforme necessário usando as técnicas padrão de edição de formas poligonais. Observe que nem todos os comandos de edição de polígonos estão disponíveis para modificar uma Região da Placa, incluindo os comandos de adição e subtração de polígonos.

Se você alterar o formato de uma Região da Placa e ela se sobrepuser a uma região adjacente, o software assumirá que a região com o maior número de camadas é a que existe nessa área de sobreposição.

Pontos a lembrar sobre a edição de um objeto poligonal:

  • Ao clicar e arrastar um vértice ou uma borda do polígono, há três modos de alteração de forma disponíveis: deslizamento, quebra e curvatura. Pressione Shift+Spacebar para alternar entre os modos enquanto arrasta. O modo atual é exibido na barra de status e no visor Heads-Up.
  • O comportamento de ajuste do cursor é controlado pelas configurações atuais de ajuste do cursor, que incluem a Grade de Ajuste atual, os Objetos para Ajuste disponíveis, a presença de Guias da Área de Trabalho e as configurações de Ajuste aos Eixos. Use esses recursos para obter a forma desejada. Saiba mais em Entender o comportamento de ajuste.

Atribuir um empilhamento de camadas e editar o nome da Região da Placa

Related page: Definir o empilhamento de camadas

Quando uma nova placa é criada, ela possui uma única região, chamada Default Layer Stack Region. A essa região será atribuído o empilhamento de camadas padrão chamado Board Layer Stack.

Ao dividir o contorno de uma placa em várias regiões, cada nova região também recebe o empilhamento de camadas padrão. Depois que os empilhamentos de camadas necessários forem definidos no Gerenciador de empilhamento de camadas, será possível atribuir um empilhamento a cada região e também dar a ela um nome significativo.

Cada região exibe um rótulo que mostra seu nome e o nome do empilhamento de camadas atribuído a ela no formato Region Name - Layer Stack Name. Se o empilhamento de camadas selecionado estiver habilitado como flexível, isso também será indicado por (flex). A configuração de flexibilidade de um empilhamento é habilitada no Layer Stack Manager.

Para atribuir um empilhamento de camadas e nomear uma região:

  1. Selecione View » Board Planning Mode ou pressione o atalho 1 para entrar no Board Planning Mode.
  2. Clique na aba Multi-Layer na parte inferior da área de trabalho para torná-la a camada ativa (se a aba da camada não estiver visível, pressione L para abrir o painel Configuração de visualização e habilitá-la).
  3. Clique duas vezes na região da placa para abrir a caixa de diálogo Board Region, ou clique uma vez na região da placa e abra o painel Properties. Se a região não for selecionada e a caixa de diálogo não abrir, certifique-se de que o Filtro de seleção não esteja excluindo regiões.
  4. Atribua o empilhamento de camadas selecionando o empilhamento desejado na lista suspensa Layer stack.
  5. Edite o Name conforme necessário.

O nome da região da placa e o empilhamento de camadas atribuído são exibidos no centro geométrico dessa região. (Flex) também é exibido quando o empilhamento atribuído está configurado como flexível.
O nome da região da placa e o empilhamento de camadas atribuído são exibidos no centro geométrico dessa região. (Flex) também é exibido quando o empilhamento atribuído está configurado como flexível.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents