ActiveRoute

Sơ lược

Bài viết này giải thích cách ActiveRoute trong Altium Designer giúp tăng tốc đi dây PCB bằng cách kết hợp tự động hóa với khả năng kiểm soát của người thiết kế, thay vì dựa vào trình đi dây tự động truyền thống. Bài viết trình bày ActiveRoute là gì, không phải là gì, những lợi ích chính mà công cụ này mang lại, cũng như cách sử dụng bảng PCB ActiveRoute để chọn các net, xác định đường dẫn hướng đi dây, chọn lớp, bật các chức năng làm mượt đường mạch, tinh chỉnh và hoán đổi chân, đồng thời điều chỉnh cách thức đi dây. Nếu bạn muốn hiểu rõ hơn cách đi dây nhanh hơn, gọn gàng hơn và tuân thủ quy tắc thiết kế mà vẫn kiểm soát được toàn bộ quá trình, hướng dẫn này sẽ giúp bạn biết nên bắt đầu từ đâu. Hãy đọc tiếp để khám phá cách ActiveRoute có thể cải thiện quy trình làm việc của bạn.

- Hiểu sự khác biệt giữa ActiveRoute và trình đi dây tự động, cũng như lý do ActiveRoute phù hợp hơn với việc đi dây có định hướng, chất lượng cao cho các net được chọn.
- Tìm hiểu các tính năng chính của ActiveRoute, bao gồm đường dẫn hướng đi dây, đi dây trên nhiều lớp, làm mượt đường mạch, tinh chỉnh, kiểm soát đoạn uốn lượn và hoán đổi chân.
- Xem cách sử dụng bảng PCB ActiveRoute để cấu hình và chạy ActiveRoute theo các quy tắc thiết kế và mục tiêu đi dây của bạn.
Tìm hiểu sâu hơn với AI:

Concept image showing routing

Một trong những giai đoạn tốn nhiều thời gian nhất khi thiết kế bo mạch là đi dây cho các net. Trong khi hệ thống quy tắc xử lý các ràng buộc thiết kế như độ rộng đường mạch, kích thước via, khoảng cách cách điện, v.v., người thiết kế vẫn phải bố trí hàng nghìn đoạn đường mạch cần thiết để đi dây hoàn chỉnh cho bo mạch.

Các công cụ đi dây tự động có thể giảm bớt gánh nặng này nhưng thường được xem là chưa đáp ứng yêu cầu vì:

  • Chúng không xét đến một cách chính xác vô số ràng buộc thiết kế tinh tế mà người thiết kế áp dụng theo bản năng khi đi dây.

  • Việc cấu hình đầy đủ mất quá nhiều thời gian, đến mức trực tiếp đi dây tương tác cho bo mạch thường hiệu quả hơn.

  • Quá trình chỉnh sửa sau khi đi dây có thể kéo dài và khó khăn đến mức đi dây tương tác cho bo mạch thường hiệu quả hơn.

Mục tiêu lý tưởng của việc đi dây PCB là nhanh chóng tạo ra kết quả chất lượng cao, đáp ứng các quy tắc thiết kế, dưới sự kiểm soát của người thiết kế. Đây là thách thức mà ActiveRoute hướng tới giải quyết.

Improving the Completed Routes

Bổ trợ nhưng hoạt động độc lập với ActiveRoute là các tính năng Glossing và Retrace. Bạn có thể dùng chúng để cải thiện chất lượng của mọi đường dây hiện có, bất kể chúng được tạo ra bằng cách nào.

Glossing được bật theo mặc định và sẽ chạy khi ActiveRoute hoàn tất — bạn có thể tắt tính năng này trong bảng PCB ActiveRoute nếu cần. Glossing cũng có bộ tùy chọn riêng, bao gồm khả năng bo cong các góc đường dây.

► Tìm hiểu thêm về Làm mượt & đi lại các đường dây hiện có

ActiveRoute là gì?

ActiveRoute là công nghệ đi dây tương tác tự động, cung cấp các thuật toán đi dây hiệu quả cho nhiều net, được áp dụng cho những net hoặc kết nối cụ thể mà bạn chọn. ActiveRoute còn cho phép người thiết kế xác định tương tác một lộ trình đi dây, hay Guide, qua đó xác định the river mà các đường dây mới sẽ đi theo.

Các tính năng chính của ActiveRoute giúp phương pháp này vượt trội đáng kể so với việc kết hợp đi dây tương tác thông thường và đi dây tự động bao gồm:

  • Tự động tối ưu hóa các đường thoát dây khỏi mảng chân/via — công đoạn tốn nhiều thời gian nhất khi đi dây thủ công.
  • Hiệu suất cao — mỗi net tín hiệu được đi dây trong < 1 giây.
  • Tuân thủ các quy tắc thiết kế về độ rộng, khoảng cách cách điện, lớp, cấu trúc liên kết và vùng bố trí theo net và lớp net, có xét đến mức độ ưu tiên.
  • Đi dây đồng thời trên nhiều lớp và phân bố các đường dây trên những lớp đó.
  • Route Guide trực quan giúp người thiết kế định hướng vị trí đặt đường dây.
  • Sử dụng phương pháp River Route để đạt tỷ lệ hoàn thành cao mà không cần via.
  • Có thể đi dây xuyên qua các vùng đổ đồng polygon và đổ lại chúng (nếu tùy chọn đổ lại được bật).
  • Hỗ trợ cả net đơn đầu và net cặp vi sai.
  • Hoàn thiện bằng công cụ làm mượt mạnh mẽ, giúp giảm thêm số góc và rút ngắn đường dây.

ActiveRoute không phải là gì

ActiveRoute không phải là công cụ đi dây tự động. Đây là công cụ đi dây tương tác có định hướng, tập trung vào việc đi dây gọn gàng, chất lượng cao cho một tập hợp net được chọn. Hãy sử dụng ActiveRoute giống như khi thực hiện đi dây tương tác: chọn các net cần đi dây, bật các lớp mà bạn muốn đi dây cho những net đó, cân nhắc lộ trình chúng nên đi theo rồi tiến hành đi dây.

Nếu chọn tất cả các net trên bo mạch và chạy ActiveRoute, rất có thể bạn sẽ thất vọng. ActiveRoute không phải là công cụ đi dây tự động; nó không thể đặt via và không có các chiến lược đi dây cho net nguồn.

Bảng PCB ActiveRoute

ActiveRoute tuân theo các tiêu chí và giới hạn do quy tắc thiết kế PCB xác định, nên để sử dụng, bạn chỉ cần chọn các kết nối hoặc net cần đi dây rồi chạy công cụ. Công cụ có một số tính năng điều khiển riêng được cấu hình trong bảng PCB ActiveRoute. Bảng PCB ActiveRoute được dùng để cấu hình và vận hành các tính năng của ActiveRoute, bao gồm: thực hiện ActiveRoute tương tác; xác định Route Guide và khoảng cách giữa các đường dây bên trong; bật tự động tinh chỉnh chiều dài; và bật tự động hoán đổi chân. Bạn nên mở bảng PCB ActiveRoute trước khi khởi chạy ActiveRoute.

Để mở bảng PCB ActiveRoute khi PCB là tài liệu đang hoạt động: 

  • Nhấp vào nút  Panels button, click to enable the display of workspace panels available in the current editor ở góc dưới bên phải của không gian làm việc, sau đó chọn mục menu PCB ActiveRoute.

  • Nhấp vào View » Panels » PCB ActiveRoute.

Để sử dụng các chức năng ActiveRoute trong Altium Designer, bạn phải cài đặt tiện ích mở rộng phần mềm ActiveRoute . Bạn có thể cài đặt hoặc gỡ bỏ tiện ích này theo cách thủ công.

Để biết thêm thông tin về cách quản lý tiện ích mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Sử dụng bảng PCB ActiveRoute để điều khiển quá trình ActiveRoute.Sử dụng bảng PCB ActiveRoute để điều khiển quá trình ActiveRoute.

Bảng PCB ActiveRoute được dùng để:

  • Bật các lớp tín hiệu mà ActiveRoute có thể sử dụng để đi dây cho các kết nối.
  • Thực hiện ActiveRoute trên các kết nối đã chọn.
  • Bật một lượt Glossing sau khi ActiveRoute hoàn tất.
  • Xác định Route Guide.
    • Cấu hình khoảng cách giữa các đường mạch mà bạn muốn sử dụng trong Route Guide.
  • Cấu hình và bật tính năng tinh chỉnh chiều dài cho các đường dây do ActiveRoute đặt.
  • Cấu hình tùy chọn Meander, cho phép ActiveRoute xác định lộ trình đi dây dài hơn, có thể giúp tăng tỷ lệ hoàn thành.
  • Cấu hình và bật tính năng hoán đổi chân. ActiveRoute có thể hoán đổi chân trong khi đi dây để giúp cải thiện chất lượng đường dây.
ActiveRoute hoạt động trên các kết nối đã chọn; một số điều khiển trong bảng chỉ được kích hoạt khi có kết nối được chọn.

Nội dung bảng PCB ActiveRoute được sắp xếp thành các phần có thể thu gọn, được mở và đóng bằng biểu tượng ► bên cạnh tiêu đề mỗi phần. Thông tin về các điều khiển thuộc tính bên dưới được sắp xếp theo các phần tương ứng, và mỗi phần thu gọn đều được mở/đóng theo cùng cách này.

Các tính năng bổ sung của ActiveRoute

ActiveRoute là công cụ đi dây tương tác tự động, có cách sử dụng đơn giản và trực quan: chọn các kết nối rồi nhấn Shift+A để ActiveRoute đi dây cho chúng theo các quy tắc thiết kế. ActiveRoute có một số tính năng và tùy chọn điều khiển khác, giúp người thiết kế kiểm soát tốt hơn một số chức năng và khả năng của công cụ.

Trong đó có:

  • Xác định lộ trình đi dây và khoảng cách giữa các đường mạch bằng cách đặt Route Guide.
  • Cho phép lộ trình đi dây dài hơn bằng tùy chọn điều khiển Meander.
  • Tự động cân bằng chiều dài các đường dây bằng chức năng tinh chỉnh chiều dài.
  • Cho phép hoán đổi chân để đơn giản hóa việc đi dây.

Hãy cùng tìm hiểu chi tiết hơn về từng tính năng này.

Xác định lộ trình bằng Route Guide

Một trong những mục tiêu chính của ActiveRoute là tìm phương án đi dây có tổng chiều dài ngắn nhất, nhưng đây có thể không phải là lộ trình mong muốn cho mọi nhóm kết nối. Route Guide cung cấp cho người thiết kế một công cụ để phác thảo lộ trình cụ thể mà họ muốn các kết nối đã chọn đi theo, ngay cả khi đó không phải là đường ngắn nhất.

  • Defining the Route Guide - trước tiên, chọn các kết nối cần đi dây trong đường dẫn hướng, nhấp vào  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along nút trong bảng PCB ActiveRoute, sau đó nhấp để xác định vị trí bắt đầu của đường dẫn hướng rồi tiếp tục di chuyển chuột và nhấp để xác định lộ trình. Sau khi xác định xong lộ trình, nhấp vào nút ActiveRoute để đi dây các kết nối đã chọn theo lộ trình đó. Tham khảo mục Xác định đường dẫn hướng đi dây ở phần sau của trang này để biết thêm chi tiết.

Tránh đặt các điểm cuối của đường dẫn hướng đi dây lên các pad mà bạn muốn đi dây. Chất lượng đi dây tại vị trí thoát khỏi pad sẽ tốt hơn nếu các pad không nằm bên trong đường dẫn hướng đi dây.

  • Changing the Route Guide Width - trong khi đặt đường dẫn hướng đi dây, có thể tăng hoặc giảm độ rộng của đường dẫn hướng bằng cách nhấn các phím  Keyboard Up arrow key hoặc  Keyboard Down arrow key. Độ rộng mặc định là tổng các giá trị độ rộng+khoảng hở theo quy tắc thiết kế áp dụng cho các kết nối đã chọn, chia cho số lớp, rồi nhân với 1,3. Nhấn phím Backspace để lùi lại đường dẫn hướng nếu bạn cần xác định một lộ trình khác.
  • The Route Guide color - được xác định bởi các lớp được phép sử dụng cho ActiveRoute của các kết nối đã chọn. Nếu chỉ bật một lớp, đường dẫn hướng sẽ được vẽ bằng màu của lớp đó; nếu bật nhiều lớp, đường dẫn hướng sẽ được vẽ bằng màu mặc định của đường dẫn hướng đi dây.
  • The track spacing within the Route Guide - theo mặc định, ActiveRoute bố trí khoảng cách giữa các đường mạch theo quy tắc thiết kế, chứ không cố gắng giãn các đường mạch ra hoặc sử dụng toàn bộ không gian có sẵn trong đường dẫn hướng đi dây. Để giãn các đường mạch trong đường dẫn hướng đi dây, hãy sử dụng tính năng Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây, như mô tả ở phần sau của trang này.

Video minh họa việc đặt đường dẫn hướng đi dây, với độ rộng được thay đổi tương tác trong khi đặt.
Video minh họa việc đặt đường dẫn hướng đi dây, với độ rộng được thay đổi tương tác trong khi đặt.

Độ rộng đường dẫn hướng đi dây

Độ rộng mặc định là tổng các giá trị độ rộng+khoảng hở theo quy tắc thiết kế áp dụng cho các kết nối đã chọn, chia cho số lớp, rồi nhân với 1,3. 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • Đường dẫn hướng được mở rộng theo hệ số mặc định là 1,3 để đảm bảo các đường mạch có đủ chỗ và có thể đi vòng qua các vật cản, chẳng hạn như via, trên lộ trình. Độ rộng này là giới hạn cứng khi đi dây; nếu không đủ chỗ cho các đường mạch thì chúng sẽ không được đặt.
  • Trong khi đặt đường dẫn hướng, có thể tăng/giảm độ rộng bằng cách nhấn các phím  Keyboard Up arrow key hoặc  Keyboard Down arrow key trên bàn phím. Kích thước tối thiểu sử dụng hệ số nhân 1,0; kích thước tối đa sử dụng hệ số nhân 10,0.

Chỉnh sửa đường dẫn hướng

Đường dẫn hướng đi dây là một tập hợp các đoạn mạch được đặt trên một lớp cơ khí.

  • Các đoạn mạch được khóa theo mặc định. Nếu mở khóa, bạn có thể thay đổi hình dạng đường dẫn hướng bằng các kỹ thuật kéo đoạn mạch tiêu chuẩn.
  • Để xóa đường dẫn hướng, nhấp đúp vào bất kỳ đoạn nào để chọn rồi nhấn phím Delete.

Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây

Sử dụng tính năng Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây, bạn có thể yêu cầu ActiveRoute giãn các đường mạch theo chiều rộng của đường dẫn hướng. Dùng thanh trượt để chọn giá trị khoảng cách hoặc nhập giá trị vào ô chỉnh sửa. Kích thước đường dẫn hướng đi dây sẽ tự động được điều chỉnh để tính đến thiết lập này. Để thực hiện điều đó, bạn phải cấu hình thiết lập Track-Track Space in Route Guide trước khi đặt đường dẫn hướng đi dây. Bạn có thể tiếp tục điều chỉnh độ rộng của đường dẫn hướng trong khi đặt bằng cách nhấn các phím  Keyboard Up arrow key và  Keyboard Down arrow key.

Sử dụng tính năng Khoảng cách giữa các đường mạch để giãn các đường mạch trong đường dẫn hướng đi dây.
Sử dụng tính năng Khoảng cách giữa các đường mạch để giãn các đường mạch trong đường dẫn hướng đi dây.

Cho phép các đường mạch đi vòng

ActiveRoute cố gắng đi dây các kết nối đã chọn theo lộ trình ngắn nhất có thể, hay nói cách khác là hạn chế tối đa việc đi vòng. Nếu tỷ lệ hoàn thành của ActiveRoute thấp hơn mong đợi, tùy chọn Meander cho phép bạn tăng mức độ đi vòng mà ActiveRoute được phép sử dụng, qua đó có thể giúp tăng tỷ lệ hoàn thành. Thiết lập Meander tối đa mặc định là 100%, nghĩa là các đường mạch được phép có tổng chiều dài là Manhattan Length + 100% of Manhattan Length. Dùng thanh trượt để chọn mức độ đi vòng hoặc nhập tỷ lệ phần trăm vào ô chỉnh sửa.

Lưu ý rằng thiết lập đi vòng sẽ bị bỏ qua khi sử dụng đường dẫn hướng đi dây vì đường dẫn hướng đi dây được dùng để xác định một lộ trình có thể làm tăng đáng kể mức độ đi vòng. 

Tinh chỉnh chiều dài đường mạch

ActiveRoute có thể tinh chỉnh chiều dài cho các kết nối đang được đi dây hoặc cho các đường mạch hiện có đã chọn. ActiveRoute sẽ cố gắng đáp ứng quy tắc thiết kế Khớp chiều dài đã chọn.

Để cấu hình ActiveRoute tinh chỉnh chiều dài:

  • Bật hộp kiểm Tune Selected trong vùng Action của bảng.

  • Bật quy tắc thiết kế Khớp chiều dài cần dùng trong vùng Tune của bảng.

  • Cấu hình các thiết lập Max Amplitude và Min Space cần dùng (đơn đầu hoặc cặp vi sai) trong vùng Tune của bảng.

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

Hiện tại, chỉ có kiểu tinh chỉnh Đường vát góc với mức vát góc khoảng 20%. Các đoạn uốn lượn do ActiveRoute đặt cũng không phải là các Union. Khả năng tinh chỉnh chiều dài của ActiveRoute vẫn đang được phát triển, đồng thời các kiểu tinh chỉnh khác và các Union dạng uốn lượn đang được đánh giá.

► Để tìm hiểu thêm về các thiết lập Tinh chỉnh chiều dài của ActiveRoute, hãy tham khảo mục Tinh chỉnh chiều dài trên trang bảng PCB ActiveRoute.

► Để tìm hiểu thêm về cách tinh chỉnh chiều dài các đường mạch hiện có bằng các hình dạng uốn lượn có thể điều chỉnh, hãy tham khảo bài viết Tinh chỉnh chiều dài.

Hoán đổi chân

Phần mềm bao gồm một hệ thống hoán đổi chân và phần tử mạnh mẽ, được liên kết giữa trình biên tập sơ đồ nguyên lý và trình biên tập PCB. ActiveRoute có thể truy cập các thiết lập hoán đổi chân và hoán đổi chân trong khi đi dây nếu việc đó giúp giảm tổng chiều dài đường mạch và cải thiện chất lượng đi dây.

Để sử dụng tính năng hoán đổi chân:

  • Trước khi có thể thực hiện bất kỳ thao tác hoán đổi chân nào (tương tác hoặc bằng ActiveRoute), dự án phải được biên dịch (menu Project) mỗi lần mở.
  • Để cấu hình và quản lý các thiết lập hoán đổi chân cho linh kiện, hãy chạy lệnh Tools » Pin/Part Swapping » Configure để mở hộp thoại Configure Swapping Information in Components.
  • Bật tùy chọn Pin Swap Routing trong vùng Action của bảng PCB ActiveRoute.
  • Bật các linh kiện cần dùng trong vùng Pin Swap của bảng PCB ActiveRoute.

Để tìm hiểu thêm về tính năng hoán đổi chân, hãy tham khảo Hoán đổi chân, cặp chân và phần tử.

Thiết lập để sử dụng ActiveRoute

ActiveRoute có thể sử dụng tính năng Gloss (Route » Gloss Selected), tính năng này sẽ tự động chạy trong quá trình ActiveRoute nếu được bật trong bảng PCB ActiveRoute .

Nguyên nhân phổ biến nhất khiến ActiveRoute không thành công là không đủ không gian để bố trí đường mạch, do đó, điều quan trọng là phải đảm bảo các quy tắc độ rộng và khoảng hở được cấu hình chính xác.

Thực hiện ActiveRoute

Để thực hiện ActiveRoute:

Nâng cao kỹ năng sử dụng

  1. Một yếu tố quan trọng để sử dụng thành thạo ActiveRoute là nắm vững các phím tắt. Những tổ hợp phím bạn sẽ sử dụng thường xuyên nhất gồm:

    • Alt+Click - để chọn một đường kết nối riêng lẻ.
    • Alt+Click&Drag - để chọn các kết nối trong một vùng, kéo từ phải sang trái để chọn tất cả các kết nối chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các kết nối nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các kết nối khác trong cùng (các) net. Thanh trạng thái sẽ hiển thị số lượng kết nối vừa chọn cho đến khi con trỏ di chuyển lên đối tượng khác.
    • Ctrl+Click&Drag - để chọn các pad trong một linh kiện, kéo từ phải sang trái để chọn tất cả các pad chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các pad nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các đối tượng đi dây khác trong cùng (các) net. Tiếp tục nhấn Tab để lần lượt chuyển qua tất cả các trạng thái chọn có thể có.
    • Click&Drag - để chọn các đoạn đường mạch hiện có, kéo từ phải sang trái để chọn tất cả các đường mạch chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các đường mạch nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các đối tượng đi dây khác trong cùng (các) net. Tiếp tục nhấn Tab để lần lượt chuyển qua tất cả các trạng thái chọn có thể có.
    • Kết hợp thêm Shift để giữ nguyên các đối tượng đang chọn trong khi thực hiện thao tác chọn khác.
    • Shift+A để chạy ActiveRoute cho các đối tượng đang chọn.
    • Ctrl+Alt+G - để làm mượt các đường mạch đang chọn.
  2. Các thao tác chọn chỉ áp dụng cho các đối tượng đang hiển thị (ngoại trừ Ctrl+A):

    • Nhấn Shift+S để chuyển vào (hoặc thoát khỏi) chế độ một lớp, để chỉ hiển thị lớp cần quan tâm.
    • Nếu thiết kế sử dụng các vùng bố trí linh kiện (room), bạn có thể khóa chúng ngay trong phần định nghĩa ở Quy tắc thiết kế, hoặc ẩn chúng để tránh chọn/di chuyển nhầm trong các thao tác Nhấp&Kéo. Có thể ẩn các room trong thẻ View Options của bảng Cấu hình hiển thị.
  3. Đi dây thoát cho các pad SMD. ActiveRoute không chuyển lớp, vì vậy bạn cần đi dây thoát cho các pad SMD. Để đẩy nhanh quá trình đi dây thoát:

    • Trong khi đi dây một kết nối, nhấn phím tắt / (trên bàn phím số) để đặt một via và kết thúc thao tác đi dây kết nối này. Sử dụng phím tắt 2 nếu bạn không có bàn phím số (đặt via mà không tạm dừng).
    • Sao chép và dán phần đi dây thoát hiện có; trình biên tập PCB sẽ tự động cập nhật tên net. Có thể thực hiện thao tác này cho nhiều phần đi dây thoát cùng lúc.
  4. Giữ nguyên các phần đi dây thoát hiện có. ActiveRoute sẽ sửa đổi các phần đi dây thoát nếu tìm thấy giải pháp tốt hơn; hãy khóa chúng nếu bạn không muốn chúng bị thay đổi. Cách dễ nhất để khóa các phần đi dây thoát là chọn các đường mạch và via của chúng (sử dụng Selection Filter ở đầu bảng Properties để hỗ trợ quá trình này), nhấn F11 để mở bảng Properties, rồi chọn hộp kiểm Locked. Thao tác này sẽ khóa tất cả các đối tượng đang chọn cùng một lúc.

  5. Nếu bạn sử dụng Route Guide và thấy tỷ lệ hoàn thành thấp, có thể có quá nhiều vật cản dọc theo đường dẫn và cần tăng chiều rộng của Guide. Nhấn phím mũi tên Up để mở rộng Guide trong khi đặt.

  6. Khi ActiveRoute hoàn tất, tính năng làm mượt sẽ được áp dụng (nếu được bật trong bảng PCB ActiveRoute). Để xem các đường mạch ở trạng thái ngay khi ActiveRouting hoàn tất, nhấn Ctrl+Z một lần để hoàn tác bước làm mượt. Có thể sử dụng lệnh Gloss (Route » Gloss Selected) để làm mượt đường mạch và cải thiện cách đường mạch nối vào pad cho mọi phần đi dây, không chỉ các phần được đi bằng ActiveRoute. Chất lượng đường mạch nối vào pad cho các cặp vi sai được đặc biệt chú trọng. Để tìm hiểu thêm về tính năng làm mượt, hãy tham khảo trang Làm mượt & Đi lại các đường mạch hiện có.

  7. Nếu ActiveRoute không hoạt động, nguyên nhân thường là do các quy tắc chưa được cấu hình đúng. Lý do phổ biến nhất khiến ActiveRoute thất bại là không đủ không gian để bố trí (các) đường mạch. Hãy kiểm tra xem các quy tắc có phù hợp hay không; ví dụ, các giá trị quy tắc mặc định trong tệp PCB mới có thể quá lớn đối với thiết kế dạng BGA mật độ cao.

  8. ActiveRoute tuân thủ các quy tắc đi dây được cấu hình về chiều rộng, khoảng hở, khoảng cách giữa hai đường trong cặp vi sai, theo lớp, theo room và theo lớp đối tượng. ActiveRoute không đi dây bằng cung tròn hoặc các đoạn đường mạch có góc tùy ý.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents