ActiveRoute
Sơ lược
- Hiểu sự khác biệt giữa ActiveRoute và trình đi dây tự động, cũng như lý do ActiveRoute phù hợp hơn với việc đi dây có định hướng, chất lượng cao cho các net được chọn.
- Tìm hiểu các tính năng chính của ActiveRoute, bao gồm đường dẫn hướng đi dây, đi dây trên nhiều lớp, làm mượt đường mạch, tinh chỉnh, kiểm soát đoạn uốn lượn và hoán đổi chân.
- Xem cách sử dụng bảng PCB ActiveRoute để cấu hình và chạy ActiveRoute theo các quy tắc thiết kế và mục tiêu đi dây của bạn.
Một trong những giai đoạn tốn nhiều thời gian nhất khi thiết kế bo mạch là đi dây cho các net. Trong khi hệ thống quy tắc xử lý các ràng buộc thiết kế như độ rộng đường mạch, kích thước via, khoảng cách cách điện, v.v., người thiết kế vẫn phải bố trí hàng nghìn đoạn đường mạch cần thiết để đi dây hoàn chỉnh cho bo mạch.
Các công cụ đi dây tự động có thể giảm bớt gánh nặng này nhưng thường được xem là chưa đáp ứng yêu cầu vì:
-
Chúng không xét đến một cách chính xác vô số ràng buộc thiết kế tinh tế mà người thiết kế áp dụng theo bản năng khi đi dây.
-
Việc cấu hình đầy đủ mất quá nhiều thời gian, đến mức trực tiếp đi dây tương tác cho bo mạch thường hiệu quả hơn.
-
Quá trình chỉnh sửa sau khi đi dây có thể kéo dài và khó khăn đến mức đi dây tương tác cho bo mạch thường hiệu quả hơn.
Mục tiêu lý tưởng của việc đi dây PCB là nhanh chóng tạo ra kết quả chất lượng cao, đáp ứng các quy tắc thiết kế, dưới sự kiểm soát của người thiết kế. Đây là thách thức mà ActiveRoute hướng tới giải quyết.
ActiveRoute là gì?
ActiveRoute là công nghệ đi dây tương tác tự động, cung cấp các thuật toán đi dây hiệu quả cho nhiều net, được áp dụng cho những net hoặc kết nối cụ thể mà bạn chọn. ActiveRoute còn cho phép người thiết kế xác định tương tác một lộ trình đi dây, hay Guide, qua đó xác định the river mà các đường dây mới sẽ đi theo.
Các tính năng chính của ActiveRoute giúp phương pháp này vượt trội đáng kể so với việc kết hợp đi dây tương tác thông thường và đi dây tự động bao gồm:
- Tự động tối ưu hóa các đường thoát dây khỏi mảng chân/via — công đoạn tốn nhiều thời gian nhất khi đi dây thủ công.
- Hiệu suất cao — mỗi net tín hiệu được đi dây trong < 1 giây.
- Tuân thủ các quy tắc thiết kế về độ rộng, khoảng cách cách điện, lớp, cấu trúc liên kết và vùng bố trí theo net và lớp net, có xét đến mức độ ưu tiên.
- Đi dây đồng thời trên nhiều lớp và phân bố các đường dây trên những lớp đó.
- Route Guide trực quan giúp người thiết kế định hướng vị trí đặt đường dây.
- Sử dụng phương pháp River Route để đạt tỷ lệ hoàn thành cao mà không cần via.
- Có thể đi dây xuyên qua các vùng đổ đồng polygon và đổ lại chúng (nếu tùy chọn đổ lại được bật).
- Hỗ trợ cả net đơn đầu và net cặp vi sai.
- Hoàn thiện bằng công cụ làm mượt mạnh mẽ, giúp giảm thêm số góc và rút ngắn đường dây.
Bảng PCB ActiveRoute
ActiveRoute tuân theo các tiêu chí và giới hạn do quy tắc thiết kế PCB xác định, nên để sử dụng, bạn chỉ cần chọn các kết nối hoặc net cần đi dây rồi chạy công cụ. Công cụ có một số tính năng điều khiển riêng được cấu hình trong bảng PCB ActiveRoute. Bảng PCB ActiveRoute được dùng để cấu hình và vận hành các tính năng của ActiveRoute, bao gồm: thực hiện ActiveRoute tương tác; xác định Route Guide và khoảng cách giữa các đường dây bên trong; bật tự động tinh chỉnh chiều dài; và bật tự động hoán đổi chân. Bạn nên mở bảng PCB ActiveRoute trước khi khởi chạy ActiveRoute.
Để mở bảng PCB ActiveRoute khi PCB là tài liệu đang hoạt động:
-
Nhấp vào nút
ở góc dưới bên phải của không gian làm việc, sau đó chọn mục menu PCB ActiveRoute.
-
Nhấp vào View » Panels » PCB ActiveRoute.
Sử dụng bảng PCB ActiveRoute để điều khiển quá trình ActiveRoute.
Bảng PCB ActiveRoute được dùng để:
- Bật các lớp tín hiệu mà ActiveRoute có thể sử dụng để đi dây cho các kết nối.
- Thực hiện ActiveRoute trên các kết nối đã chọn.
- Bật một lượt Glossing sau khi ActiveRoute hoàn tất.
-
Xác định Route Guide.
- Cấu hình khoảng cách giữa các đường mạch mà bạn muốn sử dụng trong Route Guide.
- Cấu hình và bật tính năng tinh chỉnh chiều dài cho các đường dây do ActiveRoute đặt.
- Cấu hình tùy chọn Meander, cho phép ActiveRoute xác định lộ trình đi dây dài hơn, có thể giúp tăng tỷ lệ hoàn thành.
- Cấu hình và bật tính năng hoán đổi chân. ActiveRoute có thể hoán đổi chân trong khi đi dây để giúp cải thiện chất lượng đường dây.
Nội dung bảng PCB ActiveRoute được sắp xếp thành các phần có thể thu gọn, được mở và đóng bằng biểu tượng ► bên cạnh tiêu đề mỗi phần. Thông tin về các điều khiển thuộc tính bên dưới được sắp xếp theo các phần tương ứng, và mỗi phần thu gọn đều được mở/đóng theo cùng cách này.
Thao tác
Đây là các tùy chọn chính dùng để điều khiển ActiveRoute.
-
ActiveRoute - nhấp vào nút
trong bảng để thực hiện ActiveRoute trên các kết nối đã chọn. ActiveRoute sẽ cố gắng đi dây cho các kết nối đã chọn hoặc, nếu pad hay via được chọn, cho tất cả các kết nối trong những net đó. Tham khảo trang ActiveRoute để tìm hiểu thêm về Các kỹ thuật chọn.
-
Route Guide - đường dẫn định hướng là lộ trình do người dùng xác định, trong đó ActiveRoute sẽ đi dây cho các kết nối đã chọn. Một trong những mục tiêu chính của ActiveRoute là tìm tập hợp đường dây có tổng chiều dài ngắn nhất, nhưng đây có thể không phải là lộ trình mong muốn đối với mọi tập hợp kết nối. Route Guide cung cấp cho người thiết kế công cụ để phác thảo lộ trình cụ thể mà họ muốn các kết nối đã chọn đi theo. Màu của Route Guide được xác định bởi các lớp được cho phép sử dụng khi chạy ActiveRoute cho các kết nối đã chọn — nếu chỉ bật một lớp, đường dẫn sẽ được vẽ bằng màu của lớp đó; nếu bật nhiều lớp, đường dẫn sẽ được vẽ bằng màu Route Guide mặc định.
-
Để xác định Route Guide, trước tiên hãy chọn các kết nối cần đi dây bên trong đường dẫn, rồi nhấp vào
trong bảng điều khiển, sau đó nhấp để xác định vị trí bắt đầu của đường dẫn hướng, rồi tiếp tục di chuyển chuột và nhấp để xác định lộ trình. Sau khi xác định lộ trình, nhấp vào nút ActiveRoute để đi dây các kết nối đã chọn theo lộ trình đó.
-
Trong khi đặt Route Guide, có thể tăng hoặc giảm độ rộng của đường dẫn hướng bằng cách nhấn các phím
hoặc
. Độ rộng mặc định bằng tổng các giá trị độ rộng+khoảng hở theo quy tắc thiết kế áp dụng cho các kết nối đã chọn, chia cho số lớp, rồi nhân với 1,3. Nhấn phím Backspace để lùi lại các đoạn của đường dẫn hướng nếu cần xác định một lộ trình khác.
- ActiveRoute sẽ cố gắng bố trí khoảng cách giữa các đường dây theo quy tắc thiết kế, chứ không cố giãn các đường dây hoặc sử dụng toàn bộ không gian có sẵn trong Route Guide. Để giãn các đường dây trong Route Guide, hãy sử dụng tính năng Khoảng cách giữa các đường mạch trong Route Guide, như được mô tả ở phần sau trên trang này.
-
Để xác định Route Guide, trước tiên hãy chọn các kết nối cần đi dây bên trong đường dẫn, rồi nhấp vào
-
Tune Selected - khi bật tùy chọn này, quy tắc Matched Lengths áp dụng có mức ưu tiên cao nhất và được bật trong phần Tune của bảng điều khiển sẽ được sử dụng.
-
Pin Swap Routing – trình chỉnh sửa PCB hỗ trợ hoán đổi chân; bật tùy chọn này để cho phép ActiveRoute hoán đổi chân trong quá trình đi dây. Ngoài việc bật tùy chọn này, bạn cũng phải bật các linh kiện cần thiết trong phần Pin Swap của bảng điều khiển, như mô tả bên dưới. Để tìm hiểu thêm về hệ thống hoán đổi chân, hãy tham khảo trang Hoán đổi chân, cặp và phần linh kiện.
-
Gloss Results – bật tùy chọn này để tự động làm mượt kết quả đi dây của ActiveRoute. Bạn cũng có thể làm mượt các đường dây hiện có đã chọn bằng cách chạy lệnh Route » Gloss Selected (Ctrl+Alt+G). Tham khảo trang Làm mượt & đi lại các đường dây hiện có để tìm hiểu thêm.
Các lớp
ActiveRoute có thể đi dây đồng thời trên nhiều lớp. Mặc dù không thể đặt via để chuyển lớp, ActiveRoute có thể phân bổ các kết nối và net trên các lớp có sẵn. Các lớp có sẵn được cấu hình trong phần Layers của bảng điều khiển.
- Show Signal Layers Only – theo mặc định, tất cả các lớp tín hiệu và lớp plane có sẵn đều được hiển thị; bật tùy chọn này để chỉ hiển thị các lớp tín hiệu.
- List of Layers – bật các lớp tín hiệu mà ActiveRoute có thể đi dây trên đó. ActiveRoute sẽ phân bổ các kết nối trên các lớp tín hiệu có sẵn. Lưu ý rằng ActiveRoute không đặt via để chuyển lớp.
Điều khiển
Các tùy chọn điều khiển này được dùng để giảm mức độ ưu tiên của ActiveRoute đối với việc bố trí khoảng cách giữa các đường mạch nhằm đáp ứng quy tắc thiết kế về khoảng hở áp dụng, đồng thời cho phép sử dụng lộ trình ít trực tiếp hơn để hoàn tất một kết nối.
- Track-Track Space in Route Guide – tùy chọn điều khiển này dùng để chỉ định khoảng cách mà ActiveRoute sẽ cố gắng giãn các kết nối đang được đi dây dọc theo Route Guide (từ tâm đường mạch này đến tâm đường mạch kia). Phải thiết lập giá trị này trước khi xác định Route Guide để độ rộng của đường dẫn hướng được tính toán chính xác, phù hợp với khoảng cách đã chọn. Dùng thanh trượt để chọn giá trị hoặc nhập khoảng cách vào ô chỉnh sửa.
-
Meander % Over Manhattan Length – ActiveRoute cố gắng đi dây các kết nối đã chọn theo đường ngắn nhất có thể, hay nói cách khác là uốn lượn ít nhất. Nếu tỷ lệ hoàn tất của ActiveRoute thấp hơn dự kiến, việc tăng mức uốn lượn cho phép có thể giúp cải thiện tỷ lệ này. Giá trị Meander tối đa mặc định là 100%, nghĩa là các đường dây được phép có tổng chiều dài là
Manhattan Length + 100% of Manhattan Length. Dùng thanh trượt để chọn giá trị hoặc nhập tỷ lệ phần trăm vào ô chỉnh sửa. Lưu ý rằng thiết lập mức uốn lượn bị bỏ qua khi sử dụng Route Guide, vì Route Guide được dùng để xác định một lộ trình có thể làm tăng đáng kể mức uốn lượn.
Tinh chỉnh
ActiveRoute có thể tinh chỉnh chiều dài cho các kết nối đang được đi dây hoặc cho các đường dây hiện có đã chọn.
-
Match Length Rules for Selected – tất cả các quy tắc thiết kế Matched Lengths đã xác định được liệt kê tại đây. Bật quy tắc mà ActiveRoute sẽ sử dụng cho các kết nối đã chọn.
-
Single Ended – các thuộc tính của đoạn uốn zíc zắc dùng để tinh chỉnh tín hiệu đơn đầu.
- Max Amplitude - biên độ tối đa cho phép của đoạn uốn zíc zắc. Biên độ tự động giảm khi gặp vật cản như pad, via hoặc đường mạch hiện có, nhằm đảm bảo duy trì khoảng hở theo quy tắc thiết kế.
- Min Space - khoảng cách mép đến mép tối thiểu giữa các vị trí cắt đường tâm của dạng uốn zíc zắc.
-
Differential Pair - các thuộc tính của đoạn uốn zíc zắc dùng để tinh chỉnh các cặp vi sai.
- Max Amplitude - biên độ tối đa cho phép của đoạn uốn zíc zắc đối với đường phía ngoài của cặp vi sai. Biên độ tự động giảm khi gặp vật cản bố trí, nhằm đảm bảo duy trì khoảng hở theo quy tắc thiết kế.
- Min Space - khoảng cách mép đến mép tối thiểu giữa các vị trí cắt đường tâm của dạng uốn zíc zắc đối với đường phía trong của cặp vi sai.
Hoán đổi chân
Các chân tương đương về chức năng trong một linh kiện có thể được cấu hình để cho phép hoán đổi; chọn lệnh Tools » Pin/Part Swapping » Configure để thực hiện việc này. Trước khi có thể hoán đổi chân (tương tác hoặc bằng ActiveRoute), dự án phải được biên dịch (menu Project) mỗi lần mở.
- Components with Pin Swap Enabled – tất cả các linh kiện được bật chức năng hoán đổi chân sẽ được liệt kê tại đây; hãy bật những linh kiện mà bạn muốn cho phép hoán đổi tự động trong quá trình chạy ActiveRoute.
Các tính năng bổ sung của ActiveRoute
ActiveRoute là công cụ đi dây tương tác tự động, có cách sử dụng đơn giản và trực quan: chọn các kết nối rồi nhấn Shift+A để ActiveRoute đi dây cho chúng theo các quy tắc thiết kế. ActiveRoute có một số tính năng và tùy chọn điều khiển khác, giúp người thiết kế kiểm soát tốt hơn một số chức năng và khả năng của công cụ.
Trong đó có:
- Xác định lộ trình đi dây và khoảng cách giữa các đường mạch bằng cách đặt Route Guide.
- Cho phép lộ trình đi dây dài hơn bằng tùy chọn điều khiển Meander.
- Tự động cân bằng chiều dài các đường dây bằng chức năng tinh chỉnh chiều dài.
- Cho phép hoán đổi chân để đơn giản hóa việc đi dây.
Hãy cùng tìm hiểu chi tiết hơn về từng tính năng này.
Xác định lộ trình bằng Route Guide
Một trong những mục tiêu chính của ActiveRoute là tìm phương án đi dây có tổng chiều dài ngắn nhất, nhưng đây có thể không phải là lộ trình mong muốn cho mọi nhóm kết nối. Route Guide cung cấp cho người thiết kế một công cụ để phác thảo lộ trình cụ thể mà họ muốn các kết nối đã chọn đi theo, ngay cả khi đó không phải là đường ngắn nhất.
-
Defining the Route Guide - trước tiên, chọn các kết nối cần đi dây trong đường dẫn hướng, nhấp vào
nút trong bảng PCB ActiveRoute, sau đó nhấp để xác định vị trí bắt đầu của đường dẫn hướng rồi tiếp tục di chuyển chuột và nhấp để xác định lộ trình. Sau khi xác định xong lộ trình, nhấp vào nút ActiveRoute để đi dây các kết nối đã chọn theo lộ trình đó. Tham khảo mục Xác định đường dẫn hướng đi dây ở phần sau của trang này để biết thêm chi tiết.
-
Changing the Route Guide Width - trong khi đặt đường dẫn hướng đi dây, có thể tăng hoặc giảm độ rộng của đường dẫn hướng bằng cách nhấn các phím
hoặc
. Độ rộng mặc định là tổng các giá trị độ rộng+khoảng hở theo quy tắc thiết kế áp dụng cho các kết nối đã chọn, chia cho số lớp, rồi nhân với 1,3. Nhấn phím Backspace để lùi lại đường dẫn hướng nếu bạn cần xác định một lộ trình khác.
- The Route Guide color - được xác định bởi các lớp được phép sử dụng cho ActiveRoute của các kết nối đã chọn. Nếu chỉ bật một lớp, đường dẫn hướng sẽ được vẽ bằng màu của lớp đó; nếu bật nhiều lớp, đường dẫn hướng sẽ được vẽ bằng màu mặc định của đường dẫn hướng đi dây.
- The track spacing within the Route Guide - theo mặc định, ActiveRoute bố trí khoảng cách giữa các đường mạch theo quy tắc thiết kế, chứ không cố gắng giãn các đường mạch ra hoặc sử dụng toàn bộ không gian có sẵn trong đường dẫn hướng đi dây. Để giãn các đường mạch trong đường dẫn hướng đi dây, hãy sử dụng tính năng Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây, như mô tả ở phần sau của trang này.

Video minh họa việc đặt đường dẫn hướng đi dây, với độ rộng được thay đổi tương tác trong khi đặt.
Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây
Sử dụng tính năng Khoảng cách giữa các đường mạch trong đường dẫn hướng đi dây, bạn có thể yêu cầu ActiveRoute giãn các đường mạch theo chiều rộng của đường dẫn hướng. Dùng thanh trượt để chọn giá trị khoảng cách hoặc nhập giá trị vào ô chỉnh sửa. Kích thước đường dẫn hướng đi dây sẽ tự động được điều chỉnh để tính đến thiết lập này. Để thực hiện điều đó, bạn phải cấu hình thiết lập Track-Track Space in Route Guide trước khi đặt đường dẫn hướng đi dây. Bạn có thể tiếp tục điều chỉnh độ rộng của đường dẫn hướng trong khi đặt bằng cách nhấn các phím
và
.

Sử dụng tính năng Khoảng cách giữa các đường mạch để giãn các đường mạch trong đường dẫn hướng đi dây.
Cho phép các đường mạch đi vòng
ActiveRoute cố gắng đi dây các kết nối đã chọn theo lộ trình ngắn nhất có thể, hay nói cách khác là hạn chế tối đa việc đi vòng. Nếu tỷ lệ hoàn thành của ActiveRoute thấp hơn mong đợi, tùy chọn Meander cho phép bạn tăng mức độ đi vòng mà ActiveRoute được phép sử dụng, qua đó có thể giúp tăng tỷ lệ hoàn thành. Thiết lập Meander tối đa mặc định là 100%, nghĩa là các đường mạch được phép có tổng chiều dài là Manhattan Length + 100% of Manhattan Length. Dùng thanh trượt để chọn mức độ đi vòng hoặc nhập tỷ lệ phần trăm vào ô chỉnh sửa.
Lưu ý rằng thiết lập đi vòng sẽ bị bỏ qua khi sử dụng đường dẫn hướng đi dây vì đường dẫn hướng đi dây được dùng để xác định một lộ trình có thể làm tăng đáng kể mức độ đi vòng.
Tinh chỉnh chiều dài đường mạch
ActiveRoute có thể tinh chỉnh chiều dài cho các kết nối đang được đi dây hoặc cho các đường mạch hiện có đã chọn. ActiveRoute sẽ cố gắng đáp ứng quy tắc thiết kế Khớp chiều dài đã chọn.
Để cấu hình ActiveRoute tinh chỉnh chiều dài:
-
Bật hộp kiểm Tune Selected trong vùng Action của bảng.
-
Bật quy tắc thiết kế Khớp chiều dài cần dùng trong vùng Tune của bảng.
-
Cấu hình các thiết lập Max Amplitude và Min Space cần dùng (đơn đầu hoặc cặp vi sai) trong vùng Tune của bảng.
Hoán đổi chân
Phần mềm bao gồm một hệ thống hoán đổi chân và phần tử mạnh mẽ, được liên kết giữa trình biên tập sơ đồ nguyên lý và trình biên tập PCB. ActiveRoute có thể truy cập các thiết lập hoán đổi chân và hoán đổi chân trong khi đi dây nếu việc đó giúp giảm tổng chiều dài đường mạch và cải thiện chất lượng đi dây.
Để sử dụng tính năng hoán đổi chân:
- Trước khi có thể thực hiện bất kỳ thao tác hoán đổi chân nào (tương tác hoặc bằng ActiveRoute), dự án phải được biên dịch (menu Project) mỗi lần mở.
- Để cấu hình và quản lý các thiết lập hoán đổi chân cho linh kiện, hãy chạy lệnh Tools » Pin/Part Swapping » Configure để mở hộp thoại Configure Swapping Information in Components.
- Bật tùy chọn Pin Swap Routing trong vùng Action của bảng PCB ActiveRoute.
- Bật các linh kiện cần dùng trong vùng Pin Swap của bảng PCB ActiveRoute.
Thiết lập để sử dụng ActiveRoute
1. Tạo các lớp net
ActiveRoute yêu cầu các net phải được chọn. Việc có các lớp net có thể hỗ trợ đáng kể cho quá trình lựa chọn khi có nhiều net cần đi dây bằng ActiveRoute. Tham khảo mục Các kỹ thuật lựa chọn ở phần sau của bài viết này để tìm hiểu thêm về những cách hiệu quả nhất để chọn kết nối.
2. Tạm ẩn các polygon hiện có
ActiveRoute có thể đi dây xuyên qua các polygon hiện có nếu tùy chọn Repour Polygons after Modification được bật trên trang PCB Editor - General của hộp thoại Preferences. Ngoài ra, có thể tạm ẩn các polygon (không hiển thị nhưng vẫn được giữ lại trong thiết kế) bằng lệnh Tools » Polygon Pours » Shelve Polygons.
3. Cấu hình các quy tắc thiết kế
- Khoảng hở – ActiveRoute tuân thủ các quy tắc thiết kế về khoảng hở áp dụng, theo thứ tự ưu tiên của chúng.
- Độ rộng đường dây – ActiveRoute sử dụng thiết lập Preferred của các quy tắc độ rộng áp dụng. Tương tự như khi đi dây tương tác, để thay đổi độ rộng trong một vùng, chẳng hạn khi đường dây đi bên dưới BGA, hãy xác định một Room áp dụng quy tắc thiết kế độ rộng với giá trị độ rộng ưu tiên (Preferred) nhỏ hơn. Nếu bạn không thể đi dây thủ công với độ rộng ưu tiên, ActiveRoute cũng không thể làm được.
- Cặp vi sai – ActiveRoute có thể đi dây các cặp vi sai. Hãy đảm bảo các cặp vi sai được xác định chính xác (kiểm tra trong chế độ Differential Pairs Editor của bảng PCB), đồng thời xác nhận rằng các quy tắc đi dây cặp vi sai được cấu hình đúng (các giá trị Preferred được sử dụng).
- Đường vào pad – ActiveRoute cố gắng sử dụng đường đi trực tiếp nhất vào/ra pad, tuân thủ các quy tắc mà không tạo ra góc nhọn. ActiveRoute tuân thủ các quy tắc SMT to Corner và SMT Pad Entry nhưng không phải lúc nào cũng đặt đường mạch vào giữa pad (như bộ đi dây tương tác thực hiện khi quy tắc SMT to Corner được bật). ActiveRoute có các thuật toán đặc biệt dành cho pad của cặp vi sai, tập trung vào việc duy trì liên kết giữa hai đường trong cặp mà vẫn đảm bảo sự gọn gàng.
4. Cấu hình cấu trúc liên kết của net
ActiveRoute sẽ tuân theo cách bố trí các đường kết nối. Nếu bạn có một nhóm net cần cấu trúc liên kết cụ thể, chẳng hạn cấu trúc fly-by của DDR3/4, bạn có thể xác định thứ tự từ-đến bằng xSignals. xSignals Multi-Chip Wizard (Design » xSignals » Run xSignals Wizard) có thể tạo xSignals cho các thiết kế sử dụng tín hiệu kiểu DDR3/4 và USB 3.0. Ngoài ra, có thể xác định cách bố trí đường kết nối điểm-điểm cho một net bằng cách tạo các From-To trong chế độ From-To Editor của bảng PCB.
5. Tạo fanout cho thiết kế
ActiveRoute không đặt via, vì vậy bạn phải tạo fanout cho BGA, đầu nối và các linh kiện rời sử dụng chân SMT (ngoại trừ những chân sẽ được đi dây trên các lớp ngoài).
6. Đi dây nguồn và mass
ActiveRoute dành cho các net tín hiệu; nó bỏ qua các net được gán cho mặt phẳng nguồn và các net có hơn 20 chân (được xem là các net nguồn). Nếu muốn sử dụng ActiveRoute trên một thiết kế đã hoàn thành trước đó, hãy xóa các đường dây tín hiệu nhưng giữ lại đường dây nguồn, mass và các fanout.
7. Bật các lớp đi dây cần thiết
Bật các lớp đi dây cần thiết trong bảng PCB ActiveRoute. Nội dung này được trình bày chi tiết hơn bên dưới.
Thực hiện ActiveRoute
Để thực hiện ActiveRoute:
1. Chọn các kết nối cần đi dây
Sử dụng các kỹ thuật được mô tả trên trang Các chiến lược chọn đối tượng đi dây để chọn các kết nối/net cần đi dây. Có thể chọn trực tiếp các kết nối hoặc chọn thông qua một đối tượng đi dây, chẳng hạn như chân, đường mạch, via hoặc linh kiện. Thanh trạng thái sẽ hiển thị số lượng kết nối vừa chọn cho đến khi con trỏ di chuyển lên một đối tượng khác.
- Khi các kết nối được chọn, chúng sẽ được đi dây với độ rộng ưu tiên (Preferred) được xác định trong quy tắc thiết kế độ rộng đường dây áp dụng.
- Khi chọn đường dây hiện có, kết nối gắn với đường mạch đã chọn sẽ được đi dây bằng độ rộng của đường mạch đó.
- Khi chọn các pad của linh kiện, tất cả kết nối từ các pad đã chọn sẽ được đi dây theo thiết lập Preferred của quy tắc.
2. Bật các lớp để ActiveRoute đi dây
Trong bảng PCB ActiveRoute, bật các lớp mà các kết nối đã chọn sẽ được đi dây trên đó. ActiveRoute sẽ phân bố các đường dây trên những lớp này.
Nếu không có lớp nào được chọn, ActiveRoute sẽ đi dây trên lớp đang hoạt động (Active Layer), tức là tab được chọn ở cuối cửa sổ chính của trình chỉnh sửa PCB.
Bảng PCB ActiveRoute cho phép bạn chọn các lớp để đi dây, tạo Route Guide và khởi chạy ActiveRoute.
3. Xác định Route Guide nếu cần
Để đặt Route Guide:
- Chọn các kết nối bạn muốn đi dây dọc theo Route Guide. Thanh trạng thái sẽ hiển thị số lượng kết nối vừa chọn cho đến khi con trỏ di chuyển lên một đối tượng khác.
- Nhấp vào nút Route Guide trong bảng PCB ActiveRoute.
- Con trỏ sẽ có vẻ như đang holding tất cả các kết nối đã chọn, cho biết nhóm kết nối này phải đi qua Guide. Di chuyển con trỏ đến vị trí bắt đầu phù hợp, ở một trong hai đầu của đường đi bạn muốn xác định.
- Nhấp để xác định vị trí bắt đầu của Guide, chừa đủ không gian để các kết nối đầu vào đi vào đầu cong của Guide.
- Guide được đặt tương tự như một đường mạch rất rộng. Di chuyển con trỏ đến vị trí góc rẽ đầu tiên mà Guide cần đi qua rồi nhấp để xác định góc đó.
- Tiếp tục quá trình xác định đường đi này, dừng cách vị trí kết thúc của các đường kết nối một khoảng để chừa không gian cho các kết nối đi ra khỏi Guide đến pad/via/đầu đường mạch đích.
- Nhấn phím Up Arrow để mở rộng Guide hoặc phím Down Arrow để thu hẹp Guide.
- Nhấn Backspace để xóa góc Guide vừa đặt.
- Nhấp chuột phải để thoát khỏi chế độ đặt Guide.
Mỗi lần chỉ có thể xác định một Route Guide.
4. Chạy ActiveRoute
Để chạy ActiveRoute, bạn có thể:
- Chọn lệnh Route » ActiveRoute.
-
Nhấp vào nút ActiveRoute (
) trên Active Bar.
- Nhấp vào nút ActiveRoute trong bảng PCB ActiveRoute.
- Sử dụng phím tắt Shift+A.
5. Theo dõi tiến trình và kiểm tra phản hồi
- Thanh trạng thái của trình biên tập PCB hiển thị tiến trình ActiveRoute.
- Bảng Messages báo cáo tỷ lệ hoàn thành.
Nâng cao kỹ năng sử dụng
-
Một yếu tố quan trọng để sử dụng thành thạo ActiveRoute là nắm vững các phím tắt. Những tổ hợp phím bạn sẽ sử dụng thường xuyên nhất gồm:
- Alt+Click - để chọn một đường kết nối riêng lẻ.
- Alt+Click&Drag - để chọn các kết nối trong một vùng, kéo từ phải sang trái để chọn tất cả các kết nối chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các kết nối nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các kết nối khác trong cùng (các) net. Thanh trạng thái sẽ hiển thị số lượng kết nối vừa chọn cho đến khi con trỏ di chuyển lên đối tượng khác.
- Ctrl+Click&Drag - để chọn các pad trong một linh kiện, kéo từ phải sang trái để chọn tất cả các pad chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các pad nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các đối tượng đi dây khác trong cùng (các) net. Tiếp tục nhấn Tab để lần lượt chuyển qua tất cả các trạng thái chọn có thể có.
- Click&Drag - để chọn các đoạn đường mạch hiện có, kéo từ phải sang trái để chọn tất cả các đường mạch chạm vào vùng chọn, hoặc từ trái sang phải để chỉ chọn các đường mạch nằm hoàn toàn trong hình chữ nhật chọn. Nhấn Tab để mở rộng vùng chọn, bao gồm các đối tượng đi dây khác trong cùng (các) net. Tiếp tục nhấn Tab để lần lượt chuyển qua tất cả các trạng thái chọn có thể có.
- Kết hợp thêm Shift để giữ nguyên các đối tượng đang chọn trong khi thực hiện thao tác chọn khác.
- Shift+A để chạy ActiveRoute cho các đối tượng đang chọn.
- Ctrl+Alt+G - để làm mượt các đường mạch đang chọn.
-
Các thao tác chọn chỉ áp dụng cho các đối tượng đang hiển thị (ngoại trừ Ctrl+A):
- Nhấn Shift+S để chuyển vào (hoặc thoát khỏi) chế độ một lớp, để chỉ hiển thị lớp cần quan tâm.
- Nếu thiết kế sử dụng các vùng bố trí linh kiện (room), bạn có thể khóa chúng ngay trong phần định nghĩa ở Quy tắc thiết kế, hoặc ẩn chúng để tránh chọn/di chuyển nhầm trong các thao tác Nhấp&Kéo. Có thể ẩn các room trong thẻ View Options của bảng Cấu hình hiển thị.
-
Đi dây thoát cho các pad SMD. ActiveRoute không chuyển lớp, vì vậy bạn cần đi dây thoát cho các pad SMD. Để đẩy nhanh quá trình đi dây thoát:
- Trong khi đi dây một kết nối, nhấn phím tắt / (trên bàn phím số) để đặt một via và kết thúc thao tác đi dây kết nối này. Sử dụng phím tắt 2 nếu bạn không có bàn phím số (đặt via mà không tạm dừng).
- Sao chép và dán phần đi dây thoát hiện có; trình biên tập PCB sẽ tự động cập nhật tên net. Có thể thực hiện thao tác này cho nhiều phần đi dây thoát cùng lúc.
-
Giữ nguyên các phần đi dây thoát hiện có. ActiveRoute sẽ sửa đổi các phần đi dây thoát nếu tìm thấy giải pháp tốt hơn; hãy khóa chúng nếu bạn không muốn chúng bị thay đổi. Cách dễ nhất để khóa các phần đi dây thoát là chọn các đường mạch và via của chúng (sử dụng Selection Filter ở đầu bảng Properties để hỗ trợ quá trình này), nhấn F11 để mở bảng Properties, rồi chọn hộp kiểm Locked. Thao tác này sẽ khóa tất cả các đối tượng đang chọn cùng một lúc.
-
Nếu bạn sử dụng Route Guide và thấy tỷ lệ hoàn thành thấp, có thể có quá nhiều vật cản dọc theo đường dẫn và cần tăng chiều rộng của Guide. Nhấn phím mũi tên Up để mở rộng Guide trong khi đặt.
-
Khi ActiveRoute hoàn tất, tính năng làm mượt sẽ được áp dụng (nếu được bật trong bảng PCB ActiveRoute). Để xem các đường mạch ở trạng thái ngay khi ActiveRouting hoàn tất, nhấn Ctrl+Z một lần để hoàn tác bước làm mượt. Có thể sử dụng lệnh Gloss (Route » Gloss Selected) để làm mượt đường mạch và cải thiện cách đường mạch nối vào pad cho mọi phần đi dây, không chỉ các phần được đi bằng ActiveRoute. Chất lượng đường mạch nối vào pad cho các cặp vi sai được đặc biệt chú trọng. Để tìm hiểu thêm về tính năng làm mượt, hãy tham khảo trang Làm mượt & Đi lại các đường mạch hiện có.
-
Nếu ActiveRoute không hoạt động, nguyên nhân thường là do các quy tắc chưa được cấu hình đúng. Lý do phổ biến nhất khiến ActiveRoute thất bại là không đủ không gian để bố trí (các) đường mạch. Hãy kiểm tra xem các quy tắc có phù hợp hay không; ví dụ, các giá trị quy tắc mặc định trong tệp PCB mới có thể quá lớn đối với thiết kế dạng BGA mật độ cao.
-
ActiveRoute tuân thủ các quy tắc đi dây được cấu hình về chiều rộng, khoảng hở, khoảng cách giữa hai đường trong cặp vi sai, theo lớp, theo room và theo lớp đối tượng. ActiveRoute không đi dây bằng cung tròn hoặc các đoạn đường mạch có góc tùy ý.