ActiveRoute
En un coup d'œil
- Comprenez en quoi ActiveRoute diffère d’un autorouteur et pourquoi il est mieux adapté au routage guidé de haute qualité de nets sélectionnés.
- Découvrez les principales fonctionnalités d’ActiveRoute, notamment les guides de routage, le routage multicouche, le lissage, l’ajustement des longueurs, le contrôle des méandres et la permutation des broches.
- Découvrez comment utiliser le panneau PCB ActiveRoute pour configurer et exécuter ActiveRoute en fonction de vos règles de conception et de vos objectifs de routage.
L’une des phases les plus chronophages de la conception d’un circuit imprimé est le routage des nets. Si le système de règles gère les contraintes de conception, telles que les largeurs, les dimensions des vias, les espacements, etc., c’est au concepteur qu’il revient de placer les milliers de segments de piste nécessaires au routage complet d’une carte.
Les routeurs automatiques peuvent alléger cette tâche, mais ils sont généralement jugés insuffisants pour les raisons suivantes :
-
Ils ne prennent pas correctement en compte la multitude de contraintes de conception subtiles qu’un concepteur humain applique instinctivement lors du routage.
-
Leur configuration complète prend tellement de temps qu’il est souvent plus efficace de commencer directement le routage interactif de la carte.
-
Les retouches peuvent être si longues et difficiles qu’il est souvent plus efficace de router la carte de manière interactive.
Le Graal du routage de circuits imprimés consiste à produire rapidement des résultats de haute qualité, conformes aux règles de conception, sous le contrôle du concepteur. C’est le défi qu’ActiveRoute entend relever.
Qu’est-ce qu’ActiveRoute ?
ActiveRoute est une technologie de routage interactif automatisé qui propose des algorithmes efficaces de routage de plusieurs nets, appliqués aux nets ou aux connexions que vous sélectionnez. ActiveRoute permet également au concepteur de définir de manière interactive un chemin de routage, ou guide, qui définit ensuite the river le long duquel les nouvelles pistes seront tracées.
Les principales fonctionnalités d’ActiveRoute qui rendent cette approche nettement plus performante qu’une combinaison de routage interactif classique et de routage automatique sont les suivantes :
- Optimisation automatique des pistes de sortie des matrices de broches/vias : l’aspect le plus chronophage du routage manuel.
- Hautes performances : chaque net de signal est routé en moins d’une seconde.
- Respect des règles de conception relatives à la largeur, à l’espacement, aux couches, à la topologie et aux zones de placement (rooms), par net et par classe de nets, en tenant compte des priorités.
- Routage simultané sur plusieurs couches et répartition des pistes entre ces couches.
- Guide de routage intuitif permettant au concepteur d’orienter le placement des pistes.
- Utilisation d’une approche de routage en faisceau pour obtenir des taux d’achèvement élevés sans recourir à des vias.
- Possibilité de router à travers des plans polygonaux et de recalculer leur remplissage (si l’option correspondante est activée).
- Prise en charge des nets à signal asymétrique et des paires différentielles.
- Finalisation par un puissant outil de lissage qui réduit encore le nombre d’angles et raccourcit le routage.
Le panneau PCB ActiveRoute
ActiveRoute respecte les critères et les restrictions définis par les règles de conception du circuit imprimé. Pour l’utiliser, il suffit donc de sélectionner les connexions ou les nets concernés et de le lancer. Il dispose toutefois de plusieurs commandes spécifiques, configurables dans le panneau PCB ActiveRoute. Le panneau PCB ActiveRoute sert à configurer et à utiliser les différentes fonctionnalités proposées par ActiveRoute, notamment : exécuter un routage interactif avec ActiveRoute ; définir un guide de routage et l’espacement des pistes à l’intérieur de celui-ci ; activer l’ajustement automatique des longueurs ; et activer la permutation automatique des broches. Il est vivement recommandé d’ouvrir le panneau PCB ActiveRoute avant de démarrer ActiveRoute.
Pour ouvrir le panneau PCB ActiveRoute lorsqu’un circuit imprimé est le document actif :
-
Cliquez sur le bouton
en bas à droite de l’espace de travail, puis sélectionnez l’option de menu PCB ActiveRoute.
-
Cliquez sur View » Panels » PCB ActiveRoute.
Utilisez le panneau PCB ActiveRoute pour contrôler le processus ActiveRoute.
Le panneau PCB ActiveRoute permet de :
- Activer les couches de signal sur lesquelles ActiveRoute peut router les connexions.
- Exécuter un routage avec ActiveRoute sur les connexions sélectionnées.
- Activer une passe de lissage après l’exécution d’ActiveRoute.
-
Définir un guide de routage.
- Configurer l’espacement entre les pistes à utiliser dans le guide de routage.
- Configurer et activer l’ajustement des longueurs des pistes placées par ActiveRoute.
- Configurer l’option Meander, qui permet à ActiveRoute de définir un chemin de routage plus long, ce qui peut contribuer à augmenter le taux d’achèvement.
- Configurer et activer la permutation des broches. ActiveRoute peut permuter les broches pendant le routage afin d’améliorer la qualité de celui-ci.
Le contenu du panneau PCB ActiveRoute est organisé en sections repliables qui s’ouvrent et se ferment à l’aide de l’icône ► associée au titre de chaque section. Les informations sur les commandes des propriétés présentées ci-dessous sont organisées selon les mêmes sections, et chaque section repliable s’ouvre et se ferme de la même manière.
Action
Voici les principales options permettant de contrôler ActiveRoute.
-
ActiveRoute - cliquez sur le bouton
du panneau pour exécuter un routage avec ActiveRoute sur les connexions sélectionnées. ActiveRoute tente de router les connexions sélectionnées ou, si des pastilles ou des vias sont sélectionnés, toutes les connexions des nets correspondants. Consultez la page ActiveRoute pour en savoir plus sur les techniques de sélection.
-
Route Guide - un guide de routage est un chemin défini par l’utilisateur, à l’intérieur duquel ActiveRoute doit router les connexions sélectionnées. L’un des principaux objectifs d’ActiveRoute est de trouver l’ensemble de pistes dont la longueur totale est la plus courte, ce qui ne correspond pas nécessairement au chemin souhaité pour chaque ensemble de connexions. Le guide de routage fournit au concepteur un outil lui permettant d’esquisser le chemin précis qu’il souhaite faire suivre aux connexions sélectionnées. La couleur du guide de routage est déterminée par les couches disponibles pour le routage des connexions sélectionnées avec ActiveRoute : si une seule couche est activée, le guide est tracé dans la couleur de cette couche ; si plusieurs couches sont activées, il est tracé dans la couleur par défaut du guide de routage.
-
Pour définir un guide de routage, sélectionnez d’abord les connexions à router à l’intérieur du guide, puis cliquez sur
bouton dans le panneau, puis cliquez pour définir le point de départ du guide et continuez à déplacer la souris et à cliquer pour définir le chemin. Une fois le chemin défini, cliquez sur le bouton ActiveRoute pour router les connexions sélectionnées le long de ce chemin.
-
Pendant le placement du guide de routage, vous pouvez l’élargir ou le rétrécir en appuyant sur les touches
ou
. La largeur par défaut correspond à la somme des largeurs et des espacements définis par les règles de conception applicables aux connexions sélectionnées, divisée par le nombre de couches, puis multipliée par 1,3. Appuyez sur la touche Backspace pour revenir en arrière dans le tracé du guide si vous devez définir un autre chemin.
- ActiveRoute tente d’espacer les pistes conformément aux règles de conception ; il ne cherche pas à les répartir sur toute la largeur du guide de routage ni à utiliser tout l’espace disponible. Pour répartir les pistes dans un guide de routage, utilisez la fonction Espacement piste à piste dans le guide de routage, décrite plus loin sur cette page.
-
Pour définir un guide de routage, sélectionnez d’abord les connexions à router à l’intérieur du guide, puis cliquez sur
-
Tune Selected - lorsque cette option est activée, la règle d’égalisation des longueurs applicable de priorité la plus élevée, activée dans la section Ajustement du panneau, est appliquée.
-
Pin Swap Routing – la permutation des broches est prise en charge dans l’éditeur de PCB. Activez cette option pour autoriser ActiveRoute à permuter les broches pendant le routage. Outre cette option, les composants concernés doivent également être activés dans la section Pin Swap du panneau, comme décrit ci-dessous. Pour en savoir plus sur le système de permutation des broches, consultez la page Permutation des broches, des paires et des sous-composants.
-
Gloss Results – activez cette option pour lisser automatiquement les résultats d’ActiveRoute. Le lissage peut également être appliqué à des pistes existantes sélectionnées ; pour cela, exécutez la commande Route » Gloss Selected (Ctrl+Alt+G). Consultez la page Lissage et retraçage des pistes existantes pour en savoir plus.
Couches
ActiveRoute peut router sur plusieurs couches simultanément. Bien qu’il ne puisse pas placer de vias pour changer de couche, il peut répartir les connexions et les nets sur les couches disponibles. Les couches disponibles sont configurées dans la section Couches du panneau.
- Show Signal Layers Only – par défaut, toutes les couches de signal et de plan disponibles sont affichées. Activez cette option pour afficher uniquement les couches de signal.
- List of Layers – activez les couches de signal sur lesquelles ActiveRoute peut router les signaux. ActiveRoute répartira les connexions sur les couches de signal disponibles. Notez qu’ActiveRoute ne place pas de vias pour changer de couche.
Contrôle
Ces commandes permettent d’assouplir les contraintes d’ActiveRoute concernant l’espacement des pistes selon la règle de conception d’isolement applicable, et de l’autoriser à emprunter un chemin moins direct pour réaliser une connexion.
- Track-Track Space in Route Guide – cette commande indique à ActiveRoute l’espacement à viser entre les connexions routées le long du guide de routage (de centre de piste à centre de piste). Ce réglage doit être effectué avant de définir le guide de routage, afin que sa largeur puisse être calculée correctement en fonction de cet espacement. Utilisez le curseur pour sélectionner une valeur ou saisissez une distance dans le champ de saisie.
-
Meander % Over Manhattan Length – ActiveRoute tente de router les connexions sélectionnées selon le chemin le plus court possible, autrement dit en limitant au maximum les détours. Si le taux de réalisation d’ActiveRoute est inférieur à vos attentes, augmenter la quantité de détours autorisée peut contribuer à l’améliorer. La valeur maximale par défaut du paramètre Détour est de 100 %, ce qui signifie que les pistes peuvent avoir une longueur totale de
Manhattan Length + 100% of Manhattan Length. Utilisez le curseur pour sélectionner une valeur ou saisissez un pourcentage dans le champ de saisie. Notez que le paramètre de détour est ignoré lors de l’utilisation du guide de routage, car celui-ci sert à définir un chemin susceptible d’augmenter considérablement les détours.
Ajustement
ActiveRoute peut ajuster la longueur des connexions en cours de routage ou de pistes existantes sélectionnées.
-
Match Length Rules for Selected – toutes les règles de conception d’égalisation des longueurs définies sont répertoriées ici. Activez la règle qu’ActiveRoute doit utiliser pour les connexions sélectionnées.
-
Single Ended – propriétés du motif en accordéon à utiliser pour ajuster les signaux asymétriques.
- Max Amplitude - amplitude maximale autorisée du motif en accordéon. L’amplitude est automatiquement réduite en présence d’obstacles, tels que des pastilles, des vias ou des pistes existantes, afin de respecter les espacements imposés par les règles de conception.
- Min Space - espacement minimal bord à bord entre les passages par zéro du motif en accordéon.
-
Differential Pair - propriétés du motif en accordéon à utiliser pour ajuster les paires différentielles.
- Max Amplitude - amplitude maximale autorisée du motif en accordéon pour le conducteur extérieur de la paire différentielle. L’amplitude est automatiquement réduite en présence d’obstacles au placement, afin de respecter les espacements imposés par les règles de conception.
- Min Space - espacement minimal bord à bord entre les passages par zéro du motif en accordéon pour le conducteur intérieur de la paire différentielle.
Permutation des broches
Les broches fonctionnellement équivalentes d’un composant peuvent être configurées comme permutables. Pour cela, sélectionnez la commande Tools » Pin/Part Swapping » Configure. Avant de pouvoir effectuer une permutation de broches (de manière interactive ou avec ActiveRoute), le projet doit être compilé (menu Project) à chaque ouverture.
- Components with Pin Swap Enabled – tous les composants pour lesquels la permutation des broches est activée sont répertoriés ici. Activez ceux que vous souhaitez rendre disponibles pour la permutation automatique lors d’un routage avec ActiveRoute.
Fonctionnalités supplémentaires d’ActiveRoute
ActiveRoute est un routeur interactif automatisé, simple et intuitif à utiliser : sélectionnez les connexions, puis appuyez sur Shift+A pour les router avec ActiveRoute conformément aux règles de conception. ActiveRoute comprend plusieurs autres fonctionnalités et commandes qui offrent au concepteur un contrôle accru sur certaines fonctions et possibilités.
Parmi celles-ci :
- Définir le chemin de routage et l’espacement des pistes en plaçant un guide de routage.
- Autoriser un chemin de routage plus long à l’aide du réglage Détour.
- Égaliser automatiquement les longueurs des pistes grâce à l’ajustement des longueurs.
- Autoriser la permutation des broches pour simplifier le routage.
Examinons chacune de ces fonctionnalités plus en détail.
Définir le chemin à l’aide du guide de routage
L’un des principaux objectifs d’ActiveRoute est de trouver l’ensemble de pistes dont la longueur totale est la plus courte, ce qui ne correspond pas nécessairement au chemin souhaité pour chaque groupe de connexions. Le guide de routage fournit au concepteur un outil lui permettant d’esquisser un chemin précis que les connexions sélectionnées devront suivre, même si ce chemin n’est pas le plus court.
-
Defining the Route Guide - sélectionnez d’abord les connexions à router à l’intérieur du guide, puis cliquez sur
bouton dans le panneau PCB ActiveRoute, puis cliquez pour définir le point de départ du guide et continuez à déplacer la souris et à cliquer pour définir le parcours. Une fois le parcours défini, cliquez sur le bouton ActiveRoute pour router les connexions sélectionnées le long de ce parcours. Reportez-vous à la section Définir un guide de routage plus loin sur cette page pour en savoir plus.
-
Changing the Route Guide Width - lors du placement du guide de routage, vous pouvez élargir ou rétrécir le guide en appuyant sur les touches
ou
. La largeur par défaut correspond à la somme des valeurs de largeur et d'espacement définies par les règles de conception applicables aux connexions sélectionnées, divisée par le nombre de couches, puis multipliée par 1,3. Appuyez sur la touche Backspace pour revenir en arrière dans le tracé du guide si vous devez définir un autre parcours.
- The Route Guide color - déterminée par les couches disponibles pour le routage ActiveRoute des connexions sélectionnées. Si une seule couche est activée, le guide est tracé dans la couleur de cette couche ; si plusieurs couches sont activées, il est tracé dans la couleur par défaut du guide de routage.
- The track spacing within the Route Guide - par défaut, ActiveRoute espace les pistes conformément aux règles de conception, sans chercher à les répartir ni à utiliser tout l'espace disponible dans le guide de routage. Pour répartir les pistes dans un guide de routage, utilisez la fonctionnalité Espacement entre pistes dans le guide de routage, décrite plus loin sur cette page.

Vidéo montrant le placement d'un guide de routage, dont la largeur est modifiée de manière interactive pendant le placement.
Espacement entre pistes dans le guide de routage
La fonctionnalité Espacement entre pistes dans le guide de routage permet de demander à ActiveRoute de répartir les pistes sur toute la largeur du guide de routage. Utilisez le curseur pour sélectionner une valeur d'espacement ou saisissez une valeur dans le champ de saisie. Le guide de routage sera automatiquement dimensionné pour tenir compte de ce paramètre. Pour cela, vous devez configurer le paramètre Track-Track Space in Route Guide avant de placer le guide de routage. Vous pouvez également ajuster la largeur du guide de routage pendant son placement en appuyant sur les touches
et
.

Utilisez la fonctionnalité Espacement entre pistes pour répartir les pistes dans le guide de routage.
Autoriser les détours de routage
ActiveRoute tente de router les connexions sélectionnées en suivant le parcours le plus court possible, autrement dit en limitant au maximum les détours. Si le taux de réalisation d'ActiveRoute est inférieur à vos attentes, le réglage des détours vous permet d'augmenter les détours autorisés pour ActiveRoute, ce qui peut contribuer à améliorer ce taux. Par défaut, le réglage maximal des détours est de 100 %, ce qui signifie que les pistes peuvent avoir une longueur totale de Manhattan Length + 100% of Manhattan Length. Utilisez le curseur pour sélectionner une valeur de détour ou saisissez un pourcentage dans le champ de saisie.
Notez que le réglage des détours est ignoré lorsqu'un guide de routage est utilisé, car celui-ci est destiné à définir un parcours susceptible d'augmenter considérablement les détours.
Ajustement des longueurs de pistes
ActiveRoute peut ajuster la longueur des connexions en cours de routage ou des pistes existantes sélectionnées. ActiveRoute tentera de respecter la règle de conception de correspondance des longueurs sélectionnée.
Pour configurer l'ajustement des longueurs dans ActiveRoute :
-
Cochez la case Tune Selected dans la zone Action du panneau.
-
Activez la règle de conception de correspondance des longueurs souhaitée dans la zone Tune du panneau.
-
Configurez les paramètres Max Amplitude et Min Space souhaités (signal asymétrique ou paire différentielle) dans la zone Tune du panneau.
Permutation des broches
Le logiciel comprend un puissant système de permutation des broches et des unités, assurant la liaison entre les éditeurs de schémas et de PCB. ActiveRoute peut accéder aux paramètres de permutation des broches et permuter les broches pendant le routage si cela réduit la longueur totale des pistes et améliore la qualité du routage.
Pour utiliser la permutation des broches :
- Avant de pouvoir effectuer une permutation de broches (de manière interactive ou avec ActiveRoute), le projet doit être compilé (menu Project) à chaque ouverture.
- Pour configurer et gérer les paramètres de permutation des broches des composants, exécutez la commande Tools » Pin/Part Swapping » Configure afin d'ouvrir la boîte de dialogue Configure Swapping Information in Components.
- Activez l'option Pin Swap Routing dans la zone Action du panneau PCB ActiveRoute.
- Activez les composants souhaités dans la zone Pin Swap du panneau PCB ActiveRoute.
Préparation à l'utilisation d'ActiveRoute
1. Créer des classes de nets
ActiveRoute nécessite que les nets soient sélectionnés. Les classes de nets peuvent grandement faciliter la sélection lorsqu'un grand nombre de nets doivent être routés avec ActiveRoute. Reportez-vous à la section Techniques de sélection plus loin dans cet article pour découvrir les meilleures méthodes de sélection des connexions.
2. Mettre en réserve les polygones existants
ActiveRoute peut router à travers les polygones existants si l’option Repour Polygons after Modification est activée sur la page Éditeur PCB - Général de la boîte de dialogue Preferences. Vous pouvez également mettre les polygones en réserve (les rendre invisibles tout en les conservant dans la conception) à l’aide de la commande Tools » Polygon Pours » Shelve Polygons.
3. Configurer les règles de conception
- Isolements – ActiveRoute respecte les règles de conception d’isolement applicables, en les appliquant par ordre de priorité.
- Largeurs de routage – Il utilise le paramètre Preferred des règles de largeur applicables. Comme pour le routage interactif, pour modifier les largeurs dans une zone, par exemple lorsque le routage passe sous un BGA, définissez une Room qui applique une règle de largeur avec une largeur préférée plus faible. Si vous ne pouvez pas effectuer le routage manuellement avec la largeur préférée, ActiveRoute ne le pourra pas non plus.
- Paires différentielles – ActiveRoute peut router des paires différentielles. Assurez-vous que les paires différentielles sont correctement définies (vérifiez dans le mode Éditeur de paires différentielles du panneau PCB) et que les règles de routage des paires différentielles sont correctement configurées (les valeurs Preferred sont utilisées).
- Entrée sur les pastilles – ActiveRoute tente d’utiliser le chemin le plus direct pour entrer dans une pastille ou en sortir, tout en respectant les règles et sans créer d’angles aigus. Il respecte les règles SMT vers angle et Entrée sur pastille SMT, mais ne centre pas toujours la piste dans la pastille (contrairement au routeur interactif lorsque la règle SMT vers angle est activée). Il intègre des algorithmes spécifiques aux pastilles de paires différentielles, qui privilégient le couplage de la paire tout en conservant un tracé soigné.
4. Configurer la topologie des nets
ActiveRoute suit la disposition des lignes de connexion. Si un ensemble de nets nécessite une topologie spécifique, par exemple une topologie fly-by DDR3/4, vous pouvez définir l’ordre des connexions de point à point à l’aide des xSignals. L’assistant xSignals Multi-Chip (Design » xSignals » Run xSignals Wizard) peut créer des xSignals pour les conceptions utilisant une signalisation de type DDR3/4 et USB 3.0. Vous pouvez également définir la disposition des lignes de connexion point à point d’un net en créant des From-Tos dans le mode Éditeur From-To du panneau PCB.
5. Effectuer le fanout de la conception
ActiveRoute ne place pas de vias. Vous devez donc créer les fanouts des BGA, des connecteurs et des composants discrets utilisant des broches SMT (à l’exception des broches à router sur les couches externes).
6. Router l’alimentation et la masse
ActiveRoute est destiné aux nets de signal ; il ignore les nets affectés aux plans d’alimentation et ceux qui comportent plus de 20 broches (considérés comme des nets d’alimentation). Si vous souhaitez utiliser ActiveRoute sur une conception déjà terminée, supprimez le routage des signaux, mais conservez le routage de l’alimentation et de la masse, ainsi que les fanouts.
7. Activer les couches de routage requises
Activez les couches de routage requises dans le panneau PCB ActiveRoute. Vous trouverez plus de détails ci-dessous.
Exécuter un routage avec ActiveRoute
Pour effectuer un routage avec ActiveRoute :
1. Sélectionner les connexions à router
À l’aide des techniques décrites sur la page Stratégies de sélection du routage, sélectionnez les connexions ou les nets à router. Vous pouvez sélectionner les connexions directement ou en sélectionnant un objet de routage, tel qu’une broche, une piste, un via ou un composant. La barre d’état affiche le nombre de connexions qui viennent d’être sélectionnées jusqu’à ce que le curseur passe sur un autre objet.
- Lorsque des connexions sont sélectionnées, elles sont routées à la largeur préférée définie dans la règle de conception de largeur de routage applicable.
- Lorsqu’un routage existant est sélectionné, la connexion reliée à la piste sélectionnée est routée avec la largeur de cette piste.
- Lorsque des pastilles de composants sont sélectionnées, toutes les connexions issues de ces pastilles sont routées avec la largeur préférée définie dans la règle.
2. Activer les couches à utiliser par ActiveRoute
Dans le panneau PCB ActiveRoute, activez les couches sur lesquelles les connexions sélectionnées doivent être routées. ActiveRoute répartit le routage sur ces couches.
Si aucune couche n’est sélectionnée, le routage s’effectue sur la couche active, qui correspond à l’onglet sélectionné en bas de la fenêtre principale de l’éditeur PCB.
Le panneau PCB ActiveRoute permet de sélectionner les couches à utiliser pour le routage, de créer un guide de routage et de lancer ActiveRoute.
3. Définir un guide de routage, si nécessaire
Pour placer un guide de routage :
- Sélectionnez les connexions à router le long du guide de routage. La barre d’état affiche le nombre de connexions qui viennent d’être sélectionnées jusqu’à ce que le curseur passe sur un autre objet.
- Cliquez sur le bouton Route Guide dans le panneau PCB ActiveRoute.
- Le curseur semble alors holding toutes les connexions sélectionnées, ce qui indique que cet ensemble de connexions doit passer par le guide. Déplacez le curseur vers un point de départ approprié, à l’une des extrémités du chemin à définir.
- Cliquez pour définir le point de départ du guide, en laissant suffisamment d’espace pour que les connexions entrantes puissent rejoindre son extrémité incurvée.
- Le guide se place comme une piste très large. Déplacez le curseur jusqu’à l’emplacement du premier angle du guide, puis cliquez pour définir cet angle.
- Poursuivez ainsi la définition du chemin, en vous arrêtant à une certaine distance de l’extrémité des lignes de connexion afin de laisser suffisamment d’espace pour que les connexions puissent sortir du guide et rejoindre leurs pastilles, vias ou extrémités de pistes cibles.
- Appuyez sur la touche Up Arrow pour élargir le guide ou sur la touche Down Arrow pour le rétrécir.
- Appuyez sur Backspace pour supprimer le dernier angle du guide.
- Faites un clic droit pour quitter le mode de placement du guide.
Un seul guide de routage peut être défini à la fois.
4. Exécuter ActiveRoute
Pour exécuter ActiveRoute, vous pouvez :
- Sélectionner la commande Route » ActiveRoute.
-
Cliquer sur le bouton ActiveRoute (
) dans Active Bar.
- Cliquer sur le bouton ActiveRoute dans le panneau PCB ActiveRoute.
- Utiliser le raccourci Shift+A.
5. Suivre la progression et consulter les résultats
- La barre d'état de l'éditeur PCB affiche la progression d'ActiveRoute.
- Le panneau Messages indique les taux d'achèvement.
Améliorer votre maîtrise
-
Pour bien maîtriser ActiveRoute, il est essentiel de se familiariser avec les raccourcis. Les séquences de touches que vous utiliserez le plus souvent sont les suivantes :
- Alt+Click - pour sélectionner une ligne de connexion individuelle.
- Alt+Click&Drag - pour sélectionner des connexions dans une zone, faites glisser de droite à gauche pour sélectionner toutes les connexions touchées, ou de gauche à droite pour sélectionner uniquement celles qui sont entièrement comprises dans le rectangle de sélection. Appuyez sur Tab pour étendre la sélection aux autres connexions du ou des mêmes nets. La barre d'état affiche le nombre de connexions qui viennent d'être sélectionnées jusqu'à ce que le curseur passe sur un autre objet.
- Ctrl+Click&Drag - pour sélectionner les pastilles d'un composant, faites glisser de droite à gauche pour sélectionner toutes les pastilles touchées, ou de gauche à droite pour sélectionner uniquement celles qui sont entièrement comprises dans le rectangle de sélection. Appuyez sur Tab pour étendre la sélection aux autres objets de routage du ou des mêmes nets. Appuyez plusieurs fois sur Tab pour parcourir tous les états de sélection possibles.
- Click&Drag - pour sélectionner des segments de piste existants, faites glisser de droite à gauche pour sélectionner toutes les pistes touchées, ou de gauche à droite pour sélectionner uniquement celles qui sont entièrement comprises dans le rectangle de sélection. Appuyez sur Tab pour étendre la sélection aux autres objets de routage du ou des mêmes nets. Appuyez plusieurs fois sur Tab pour parcourir tous les états de sélection possibles.
- Ajoutez Shift pour conserver la sélection actuelle tout en effectuant une autre sélection.
- Shift+A pour router la sélection actuelle avec ActiveRoute.
- Ctrl+Alt+G - pour lisser la sélection actuelle.
-
Les actions de sélection ne s'appliquent qu'aux objets visibles (sauf pour Ctrl+A) :
- Appuyez sur Shift+S pour activer ou désactiver le mode monocouche afin de n'afficher que la couche qui vous intéresse.
- Si la conception utilise des zones de placement, celles-ci peuvent être verrouillées dans leur définition au sein des règles de conception, ou masquées pour éviter qu'elles ne soient sélectionnées ou déplacées lors des opérations de cliquer-glisser. Les zones de placement peuvent être masquées dans l'onglet View Options du panneau Configuration de l'affichage.
-
Effectuez l'échappement des pastilles CMS. ActiveRoute ne change pas de couche ; vous devez donc effectuer l'échappement des pastilles CMS. Pour accélérer cette opération :
- Pendant le routage d'une connexion, utilisez le raccourci / (pavé numérique) pour placer un via et terminer le routage de cette connexion. Utilisez le raccourci 2 si vous ne disposez pas d'un pavé numérique (place un via sans interrompre le routage).
- Copiez et collez un échappement existant ; l'éditeur PCB met automatiquement à jour les noms des nets. Cette opération peut être effectuée pour plusieurs échappements.
-
Préservez les échappements existants. ActiveRoute modifie les échappements s'il trouve une meilleure solution ; verrouillez-les si vous ne souhaitez pas qu'ils soient modifiés. Le moyen le plus simple de verrouiller les échappements consiste à sélectionner leurs pistes et leurs vias (utilisez Selection Filter en haut du panneau Properties pour faciliter cette opération), à appuyer sur F11 pour ouvrir le panneau Properties, puis à cocher la case Locked. Tous les objets sélectionnés sont ainsi verrouillés en une seule opération.
-
Si vous utilisez un guide de routage et constatez que le taux d'achèvement est faible, il se peut que le trajet comporte trop d'obstacles et que le guide doive être élargi. Appuyez sur la touche fléchée Up pour élargir le guide pendant son placement.
-
Lorsqu'ActiveRoute a terminé, il applique un lissage (si cette option est activée dans le panneau PCB ActiveRoute). Pour examiner les pistes telles qu'elles étaient à la fin du routage avec ActiveRoute, appuyez une fois sur Ctrl+Z pour annuler le lissage. La commande Gloss (Route » Gloss Selected) permet de lisser les pistes et d'améliorer les raccordements aux pastilles de n'importe quel routage, pas uniquement ceux réalisés avec ActiveRoute. Une attention particulière a été portée à la qualité des raccordements aux pastilles pour les paires différentielles. Pour en savoir plus sur le lissage, consultez la page Lissage et reprise des pistes existantes.
-
Si ActiveRoute ne fonctionne pas, c'est généralement parce que les règles ne sont pas correctement configurées. La cause d'échec la plus fréquente est un espace insuffisant pour faire passer la ou les pistes. Vérifiez que les règles sont adaptées : par exemple, les dimensions imposées par les règles par défaut d'un nouveau fichier PCB peuvent être trop grandes pour une conception haute densité de type BGA.
-
ActiveRoute respecte les règles de routage configurées pour les largeurs, les espacements et les écarts entre pistes des paires différentielles, par couche, par zone de placement et par classe. ActiveRoute ne route pas avec des arcs ni avec des pistes à angle quelconque.