Attribution des points de test sur la carte

En un coup d'œil

Cet article explique l’importance des points de test dans la fabrication des circuits imprimés et comment Altium Designer vous aide à les attribuer, aussi bien pour les tests de fabrication des cartes nues que pour les tests des cartes assemblées. Il présente les différences pratiques entre les stratégies de test de fabrication et d’assemblage, les contraintes de placement qui déterminent l’emplacement des points de test, ainsi que la manière de désigner des pastilles et des vias comme points de test, manuellement ou à l’aide du gestionnaire de points de test. Si vous souhaitez concevoir une carte plus facile à tester et mieux comprendre comment Altium Designer vous accompagne dans cette démarche, cet article vous donnera des bases solides. Poursuivez votre lecture pour planifier plus efficacement vos points de test.

- Comprenez la différence entre les tests de fabrication et les tests d’assemblage, ainsi que leur incidence sur le placement des points de test.
- Découvrez les principaux critères et contraintes qui définissent une bonne stratégie de points de test, notamment l’accès aux faces de la carte, les distances d’isolement, les exigences de grille et l’accessibilité des sondes.
- Découvrez comment Altium Designer permet d’attribuer des points de test manuellement et automatiquement grâce aux fonctionnalités des pastilles, des vias et du gestionnaire de points de test.
Approfondissez avec l'IA :

Les tests constituent une étape importante du processus de fabrication des circuits imprimés. Après sa fabrication, la carte est généralement testée pour vérifier l’absence de courts-circuits ou de circuits ouverts. Une fois tous ses composants montés, elle est souvent testée à nouveau pour vérifier l’intégrité du signal et le fonctionnement des dispositifs. Pour faciliter ce processus, il est particulièrement utile de prévoir sur la carte un ensemble de points — Testpoints — accessibles aux sondes des équipements de test pour effectuer les vérifications requises.

L’emplacement des points de test sur une carte dépend de facteurs tels que le type de test (test de fabrication de la carte nue, test en circuit de la carte assemblée, etc.) et la méthode de test (test automatisé à sondes mobiles ou à lit de clous, test manuel, etc.). Par exemple, lors des tests de fabrication d’une carte nue, aucun composant n’est monté : toutes les pastilles et tous les vias peuvent donc servir de points de test. En revanche, les emplacements utilisés pour les tests en circuit d’une carte assemblée seront presque toujours différents. Une fois les composants montés, les sondes ne peuvent plus nécessairement accéder à leurs pastilles, et certainement pas aux pastilles et aux vias situés sous un composant !

Altium Designer propose un système puissant pour gérer vos besoins en points de test et améliorer la testabilité de vos cartes. Il vous permet d’affecter séparément des points de test aux tests de fabrication de la carte nue et/ou aux tests en circuit de la carte assemblée, selon vos besoins. Les points de test peuvent être affectés manuellement ou de façon plus simple et automatisée à l’aide de la boîte de dialogue Testpoint Manager.

Définir votre stratégie de points de test

Avant de vous lancer dans l’affectation de pastilles et de vias comme emplacements de points de test, il est judicieux de prendre du recul pour réfléchir aux besoins. Voici quelques éléments à prendre en compte lors de la définition d’une stratégie d’intégration des points de test dans une conception :

  • Pour choisir la face de la carte sur laquelle les points de test seront autorisés, il convient de tenir compte des processus de test et des montages associés qui seront utilisés. Par exemple, les sondes accéderont-elles à la carte uniquement par la face inférieure, uniquement par la face supérieure ou par les deux faces ?
  • Un point de test situé sous un composant (sur la même face de la carte que ce dernier) est généralement utilisé lors des tests de la carte nue. Il faut en tenir compte lors de la planification des emplacements des points de test pour la carte assemblée.
  • Il est conseillé de placer tous les points de test sur une seule face de la carte, en utilisant des vias si nécessaire. En effet, un montage de test à double tête coûte plus cher qu’un montage à tête unique.
  • Plus la disposition de vos points de test est atypique et complexe, plus la configuration d’un montage permettant de tester la carte sera coûteuse. La meilleure approche consiste à élaborer une méthodologie favorisant une testabilité standardisée. Une stratégie de points de test bien rodée et adaptable permettra de tester différentes conceptions de manière efficace et économique.
  • Il convient d’examiner attentivement les éventuelles exigences de recouvrement des vias par le vernis épargne. Le recouvrement d’un via désigné comme point de test empêchera tout contact avec la sonde de test. Même un recouvrement partiel à l’aide d’un vernis épargne liquide photoimageable (LPI) entraînera des problèmes de contact, car le vernis liquide aura tendance à s’écouler par le trou du via. Un vernis épargne pelable peut certes servir à recouvrir temporairement ces vias, mais cette solution s’avère souvent assez coûteuse.
  • Consultez attentivement vos fabricants de circuits imprimés et vos prestataires d’assemblage afin de vous assurer que tous les paramètres de conception spécifiques sont pris en compte lors de la définition des points de test. Il peut notamment s’agir des distances d’isolement entre points de test ou entre points de test et composants, qui peuvent être plus strictes que les distances habituelles de placement et de routage.

Les sections suivantes examinent plus en détail les tests de fabrication et d’assemblage, notamment les contraintes et les considérations relatives aux points de test propres à chacun.

Tests de fabrication

Les tests de fabrication consistent à tester un circuit imprimé avant l’assemblage, alors qu’aucun composant n’a encore été monté sur la carte. C’est pourquoi on les appelle souvent tests de carte nue. Cette méthode utilise généralement un équipement à sondes mobiles pour effectuer des tests net par net. Le principe consiste à programmer deux sondes pour qu’elles fonctionnent de concert : l’une injecte une impulsion dans un net et l’autre détecte la présence ou l’absence de ce signal.

Deux scénarios de test courants pour les tests de fabrication d’une carte nue sont les suivants :

  1. Vérifier qu’une liaison en cuivre conçue pour être continue de bout en bout transmet un signal propre (avec une impédance inférieure au seuil maximal admissible), sans aucun circuit ouvert.
  2. Vérifier l’absence de courts-circuits entre les nets.

Tests d’assemblage

Les tests d’assemblage consistent à tester un circuit imprimé après l’assemblage, une fois que tous les composants spécifiés dans sa nomenclature (BOM) ont été montés sur la carte. C’est pourquoi on les appelle souvent tests en circuit ou tests électriques. Cette méthode utilise généralement un montage à lit de clous configuré manuellement, sans toutefois s’y limiter ! Selon le type de test effectué à l’aide du montage, la carte peut être alimentée ou non.

Deux scénarios de test courants pour les tests en circuit d’une carte assemblée sont les suivants :

  1. Placer simultanément une sonde sur un point de test dédié de chaque net (ou de chaque net à contrôler). Pour cela, une impulsion est injectée par chaque sonde individuellement, puis la réception du signal est détectée par toutes les autres sondes.
  2. Testez des composants ou des bus spécifiques pour vous assurer que le dispositif lui-même fonctionne correctement. Ces tests spécialisés peuvent être réalisés à l’aide de différentes méthodes de test. Dans le cas le plus simple, un dispositif à lit de clous peut être utilisé pour effectuer des tests entre les pastilles des composants.

Prise en charge des pastilles et des vias comme points de test

Altium Designer offre une prise en charge complète des points de test, vous permettant de spécifier les pastilles (traversantes ou CMS) et/ou les vias à utiliser comme emplacements de points de test lors des tests de fabrication et/ou d’assemblage. Une pastille ou un via est désigné comme point de test en définissant ses propriétés de point de test et en répondant à deux questions essentielles :

  • La pastille ou le via doit-il être utilisé comme point de test de fabrication et/ou d’assemblage ?
  • Sur quelle face de la carte la pastille ou le via doit-il être utilisé comme point de test : face supérieure, face inférieure ou les deux ?

Ces propriétés sont disponibles dans le panneau Properties, lorsqu’un objet pastille (voir Propriétés des pastilles) ou via (voir Propriétés des vias) est sélectionné dans l’espace de conception.

Une pastille ou un via sélectionné est désigné comme point de test à l’aide des options correspondantes disponibles dans le panneau Properties.Une pastille ou un via sélectionné est désigné comme point de test à l’aide des options correspondantes disponibles dans le panneau Properties.

Pour simplifier le processus et éviter de devoir définir manuellement les propriétés de point de test des pastilles et des vias, Altium Designer propose une méthode d’affectation automatique des points de test fondée sur les règles de conception définies et utilisant le Gestionnaire de points de test. Cette affectation automatique définit les propriétés de point de test appropriées pour chaque pastille ou via. Vous pouvez également spécifier manuellement les points de test, en intervenant individuellement sur chaque pastille ou via, afin de maîtriser entièrement la stratégie de points de test utilisée pour votre carte.
Lors de l’ouverture de conceptions de circuits imprimés créées avec une version du logiciel antérieure à la version Summer 09, toutes les options de point de test activées deviennent des options de point de test Fabrication activées.

Règles de conception des points de test

Les contraintes d’une conception de circuit imprimé doivent être mûrement réfléchies et mises en œuvre sous la forme d’un ensemble cohérent de règles de conception. Pour mettre en place une stratégie de points de test efficace, dans laquelle tous les points de test définis sont accessibles et utilisables pour les tests de carte nue et/ou les tests in situ, des contraintes doivent être établies. À cette fin, les types de règles suivants peuvent être définis dans le système de règles de conception de l’éditeur de circuits imprimés :

Accédez aux règles de ces types et définissez-les dans la boîte de dialogue de l’éditeur des règles et contraintes du circuit imprimé (Design » Rules).

Définissez des règles de conception distinctes pour déterminer quelles pastilles et/ou quels vias de la conception peuvent être utilisés comme points de test de fabrication et d’assemblage, ainsi que les équipotentielles qui nécessitent des points de test.Définissez des règles de conception distinctes pour déterminer quelles pastilles et/ou quels vias de la conception peuvent être utilisés comme points de test de fabrication et d’assemblage, ainsi que les équipotentielles qui nécessitent des points de test.

Les règles de style et d’utilisation des points de test sont identiques en matière de contraintes pour les deux modes de test (fabrication et assemblage). La règle de style définit essentiellement les contraintes qu’une pastille ou un via doit respecter pour pouvoir être retenu comme emplacement de point de test. La règle d’utilisation spécifie les équipotentielles qui nécessitent un point de test.

Contraintes par défaut des règles d’utilisation des points de test (en haut) et de style des points de test (en bas).Contraintes par défaut des règles d’utilisation des points de test (en haut) et de style des points de test (en bas).

Lors de la définition d’une règle de style, la portée de la règle peut être rapidement définie pour cibler précisément les objets pastille et/ou via à prendre en compte comme points de test, à l’aide des options disponibles dans la zone Rule Scope Helper.

Les règles de conception des points de test sont utilisées par le Gestionnaire de points de test, le routeur automatique, les processus de vérification des règles de conception (DRC) en ligne et par lots, ainsi que lors de la génération des sorties.

Des règles par défaut de style et d’utilisation des points de test de fabrication et d’assemblage sont disponibles. Vérifiez qu’elles répondent aux exigences de votre carte et modifiez-les si nécessaire. Si plusieurs règles du même type sont requises, utilisez leur priorité pour garantir que les règles dont la portée est la plus spécifique sont appliquées en premier, par exemple lors de l’exécution d’une DRC.

Pour que le Testpoint Manager puisse affecter correctement les points de test, il doit always exister au moins une règle de style de points de test correspondante dont la portée est All.
Lors de l’ouverture de conceptions de circuits imprimés ou de l’importation de règles de conception créées avec une version du logiciel antérieure à la version Summer 09, les règles de style des points de test deviennent des règles de style des points de test de fabrication, et les règles d’utilisation des points de test deviennent des règles d’utilisation des points de test de fabrication.

Gestion des points de test

L’attribution manuelle des points de test peut être une tâche minutieuse et laborieuse, d’autant plus sur une carte complexe comportant des centaines de composants, répartis sur ses deux faces. Pour simplifier la gestion des points de test dans vos conceptions de cartes, Altium Designer dote l’éditeur PCB d’un Testpoint Manager. Le Testpoint Manager vous permet d’attribuer automatiquement des points de test, pour les tests de fabrication sur carte nue et/ou les tests d’assemblage en circuit, en fonction des règles de conception définies. Cette attribution automatique définit, dans chaque cas, les propriétés de point de test appropriées pour la pastille ou le via.

Pour y accéder, choisissez la commande Tools » Testpoint Manager dans les menus principaux.

Gérez rapidement et efficacement vos exigences en matière de points de test de fabrication et d’assemblage à l’aide du Testpoint Manager.Gérez rapidement et efficacement vos exigences en matière de points de test de fabrication et d’assemblage à l’aide du Testpoint Manager.

Utilisez cette boîte de dialogue pour attribuer et supprimer automatiquement les points de test depuis un même emplacement pratique. La liste de tous les nets de la conception figure dans la zone Testpoint Net Status avec un état indiquant la couverture des points de test — Complete ou Incomplete — pour les tests de fabrication sur carte nue comme pour les tests d’assemblage en circuit. Cliquez sur les boutons Fabrication Testpoints ou Assembly Testpoints, ou faites un clic droit dans la grille pour accéder aux commandes d’attribution ou de suppression de ce type de point de test. Notez que vous pouvez sélectionner manuellement des nets dans la partie supérieure de la boîte de dialogue pour attribuer ou supprimer des points de test de manière sélective.

Que vous attribuiez des points de test à une partie ou à l’ensemble des nets d’une conception, le Testpoint Manager respecte les règles de style et d’utilisation définies pour les points de test de fabrication et d’assemblage. Pour afficher l’ordre de recherche des objets valides, cliquez sur le bouton Search Order.

Pour modifier cet ordre, faites un clic droit sur une entrée de la liste d’ordre de recherche et utilisez les commandes du menu contextuel ou les raccourcis Shift+Up Arrow et Shift+Down Arrow pour la déplacer vers le haut ou vers le bas de la liste.
Si un net possède un point de test attribué qui enfreint une règle de conception applicable aux points de test, il sera signalé Illegal dans la zone Testpoint Net Status de la boîte de dialogue Testpoint Manager. Utilisez la fonctionnalité de vérification des règles de conception de l’éditeur PCB pour vérifier la validité des points de test attribués.

La zone Status Summaries fournit un récapitulatif complet de l’état des points de test de la carte pour les deux modes de test. Cette zone est mise à jour à chaque opération d’attribution ou de suppression. Pour obtenir des informations plus détaillées, utilisez la zone Assignment Results. Celle-ci indique, par exemple, le nombre de pastilles et de vias des faces supérieure et inférieure concernés par une attribution ou une suppression, ainsi que les éventuels échecs.

Vérification de la validité des points de test

Les règles définies pour les points de test de fabrication et d’assemblage sont prises en compte par la fonction de vérification des règles de conception (DRC) de l’éditeur PCB. La vérification DRC en ligne et/ou par lots peut être activée pour les différents types de règles depuis la boîte de dialogue Design Rule Checker (Tools » Design Rule Check).

Incluez les règles de conception des points de test dans les processus DRC en ligne ou par lots.Incluez les règles de conception des points de test dans les processus DRC en ligne ou par lots.

Champs de requête relatifs aux points de test

Pour les différents points de test de fabrication et d’assemblage pouvant être attribués dans une conception, les mots-clés suivants permettent de cibler les points de test à l’aide d’expressions de requête logiques. Chacun d’eux est disponible dans la catégorie PCB Functions - Fields lors de l’utilisation de Query Helper :

  • IsAssyTestpoint - est un point de test d’assemblage.
  • IsFabTestpoint - est un point de test de fabrication.
  • IsTestpoint - est un point de test sur la face supérieure ou inférieure.
  • Testpoint - s’agit-il d’un point de test sur la face supérieure ou inférieure ?
  • TestpointAssy - s’agit-il d’un point de test d’assemblage ?
  • TestpointAssyBottom - s’agit-il d’un point de test d’assemblage sur la face inférieure ?
  • TestpointAssyTop - s’agit-il d’un point de test d’assemblage sur la face supérieure ?
  • TestpointBottom - s’agit-il d’un point de test sur la face inférieure ?
  • TestpointFab - s’agit-il d’un point de test de fabrication ?
  • TestpointFabBottom - s’agit-il d’un point de test de fabrication sur la face inférieure ?
  • TestpointFabTop - s’agit-il d’un point de test de fabrication sur la face supérieure ?
  • TestpointTop - s’agit-il d’un point de test sur la face supérieure ?

Créez des expressions logiques pour vos requêtes afin de cibler et de renvoyer les points de test de votre conception selon vos besoins. Voici quelques exemples d’expressions de requête logiques ciblant les points de test de fabrication et d’assemblage :

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    Cible toutes les pastilles qui sont des points de test d’assemblage.
  2. IsPad And (TestpointAssyTop = 'True')
    Cible toutes les pastilles qui sont des points de test d’assemblage sur la face supérieure.
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    Cible toutes les pastilles qui sont des points de test de fabrication.
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    Cible toutes les pastilles et tous les vias qui sont des points de test d’assemblage.
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    Cible toutes les pastilles et tous les vias qui sont des points de test de fabrication.

Génération de rapports de points de test

Altium Designer comprend des générateurs de rapports dédiés, respectivement, aux points de test de fabrication et d’assemblage. Ces deux générateurs utilisent les propriétés de point de test correspondantes des primitives de pastille et de via de la conception.

Un rapport de points de test de fabrication utilise uniquement les paramètres de point de test Fabrication des pastilles et des vias. Un rapport de points de test d’assemblage utilise uniquement les paramètres de point de test Assembly .

Les rapports peuvent être générés de deux façons :

  • Directement depuis le document PCB, à l’aide des commandes File » Fabrication Outputs » Test Point Report et File » Assembly Outputs » Test Point Report.
  • À l’aide de sorties correctement configurées, définies dans un fichier de configuration des tâches de sortie (*.OutJob).
Pour en savoir plus sur les fichiers de configuration des tâches de sortie, consultez Préparation des données de fabrication avec les tâches de sortie.

Ajoutez et configurez les sorties de rapports de points de test de fabrication et d’assemblage dans un fichier de configuration des tâches de sortie autonome et polyvalent. Une fois ces sorties définies, obtenez vos rapports d’un simple clic !Ajoutez et configurez les sorties de rapports de points de test de fabrication et d’assemblage dans un fichier de configuration des tâches de sortie autonome et polyvalent. Une fois ces sorties définies, obtenez vos rapports d’un simple clic !

Quelle que soit la méthode utilisée pour générer un rapport, les options du rapport sont définies dans la même boîte de dialogue. Pour un rapport de points de test de fabrication, il s’agit de la boîte de dialogue Fabrication Testpoint Setup. Pour un rapport de points de test d’assemblage, la boîte de dialogue Assembly Testpoint Setup est utilisée. Les options de rapport sont identiques dans ces deux boîtes de dialogue.

Définissez les options du rapport, notamment le format du fichier généré, dans la boîte de dialogue de configuration du rapport correspondante. 
Définissez les options du rapport, notamment le format du fichier généré, dans la boîte de dialogue de configuration du rapport correspondante.

Les paramètres définis dans une boîte de dialogue Testpoint Setup lors de la génération d’une sortie directement depuis le PCB sont distincts de ceux définis pour le même type de sortie dans un fichier de configuration des tâches de sortie. Dans le premier cas, les paramètres sont enregistrés dans le fichier de projet ; dans le second, ils sont enregistrés dans le fichier de tâches de sortie.
Les options de la zone Coordinate Positions d’une boîte de dialogue permettent d’exporter les positions des points de test, dans tous les formats de rapport, par rapport à l’origine absolue de la carte ou à son origine courante.
Tous les types de rapports de points de test prennent en charge les panneaux de cartes intégrés. Plusieurs fichiers de netlist IPC-D-356A sont produits lors de l’exportation depuis un document PCB contenant plusieurs panneaux de cartes intégrés.

Rôle du fichier de netlist IPC-D-356A

Le fichier de netlist IPC-D-356A est l’un des trois formats de sortie des rapports de points de test. Ce fichier est généralement utilisé pour les tests de fabrication sur carte nue. Le fichier IPC est post-traité pour produire des commandes qui pilotent un équipement de test à sondes mobiles.

Quels que soient les éléments spécifiquement identifiés comme emplacements de points de test dans un fichier IPC-D-356A, les fabricants de cartes peuvent généralement utiliser les données du fichier pour réaliser le type de test souhaité. Toutefois, selon les circonstances et le contenu du fichier, une intervention manuelle peut être nécessaire.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents