Y compris les détails de conception
En un coup d'œil
- Découvrez quelles informations de documentation peuvent être ajoutées dans l’éditeur de PCB ou l’éditeur de bibliothèques de PCB, et comment les couches mécaniques permettent de les organiser.
- Découvrez le contenu des tableaux d’empilage des couches et des tableaux de perçage, les endroits où ils peuvent être placés et la manière dont ils se mettent à jour ou reflètent la conception actuelle de la carte.
- Comprenez les principales options de placement, de déplacement, de redimensionnement et de propriétés qui déterminent l’apparence de ces éléments de documentation dans vos documents de sortie PCB.
Bon nombre des sorties que vous générez nécessitent des détails supplémentaires. Par exemple, le plan de fabrication doit comporter des cotes, le plan d’assemblage peut nécessiter une vue agrandie d’une zone spécifique de la carte, et le plan de fabrication doit inclure un tableau d’empilage des couches et un tableau de perçage. Ces types de détails peuvent être ajoutés dans l’éditeur PCB ou dans l’éditeur de bibliothèques PCB.
Couches de dessin à usage général
Dans l’éditeur PCB, les détails tels que les cotes et les instructions de fabrication et d’assemblage sont ajoutés sur les couches mécaniques. Le logiciel prend en charge un nombre illimité de couches mécaniques à usage général, qui sont activées dans le panneau View Configuration. Ces couches peuvent être nommées selon les besoins (cliquez avec le bouton droit sur le nom, puis sélectionnez Edit Layer) et incluses dans les impressions et les sorties de fabrication basées sur les couches.
Tableau d’empilage des couches

Un tableau d’empilage des couches peut être placé sur un document PCB, à côté de la conception elle-même. Il fournit un récapitulatif détaillé des empilages de couches de la carte et de l’affectation des groupes de couches.
Un tableau d’empilage des couches est un objet graphique tabulaire qui documente les couches, les matériaux, les épaisseurs et les constantes diélectriques utilisés dans la conception de PCB actuelle. Il est placé et positionné à côté de la conception de la carte dans l’espace de conception et comprend également une légende graphique et une carte des configurations indiquant l’empilage de couches utilisé dans chaque région de la carte. Un tableau d’empilage des couches reflète les configurations de couches définies via Layer Stack Manager et constitue un élément de documentation important pour les conceptions présentant une structure d’empilage complexe, comme les conceptions rigides-flexibles.
Le tableau d’empilage des couches est disponible dans l’éditeur PCB lorsque l’affichage de l’espace de conception est réglé sur le mode 2D normal (raccourci 2). Après le lancement de la commande de placement du tableau d’empilage des couches (Place » Layer Stack Table), le curseur prend la forme d’un réticule et vous passez en mode de placement du tableau d’empilage des couches. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez pour placer le tableau.
- L’éditeur reste en mode de placement du tableau d’empilage des couches, prêt à placer un autre tableau si nécessaire. Sinon, cliquez avec le bouton droit ou appuyez sur Esc pour quitter le mode de placement.
Les actions supplémentaires pouvant être effectuées pendant le placement, tant que le tableau d’empilage des couches suit encore le curseur et avant que son point central ne soit ancré, sont les suivantes :
- Appuyez sur la touche Alt pour limiter le déplacement à l’axe horizontal ou vertical, selon la direction initiale du déplacement.
- Appuyez sur Spacebar pour faire pivoter le tableau d’empilage des couches dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue par incréments de 90°.
Pour déplacer un tableau d’empilage des couches, cliquez dessus, maintenez le bouton enfoncé et faites-le glisser jusqu’à l’emplacement souhaité.

Sélectionnez un tableau d’empilage des couches et faites-le glisser pour le repositionner.
Propriétés du tableau d’empilage des couches

Le mode Layer Stack Table du panneau Properties.
Emplacement
-
(X/Y)
- X (premier champ) - coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de conception. Modifiez cette valeur pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Y (deuxième champ) - coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Rotation - angle de rotation de l’objet (en degrés), mesuré dans le sens antihoraire à partir de zéro (l’horizontale 3 o'clock). Modifiez cette valeur pour changer la rotation de l’objet. La résolution angulaire minimale est de 0,001°.
Propriétés
- Layer - couche à laquelle le tableau est actuellement affecté. Utilisez la liste déroulante pour sélectionner une autre couche.
- Alignment - utilisez la liste déroulante pour sélectionner l’alignement souhaité.
-
Units - utilisez la liste déroulante pour sélectionner
Metric (mm)ouImperial (mil). - Show Board Map - activez cette option pour afficher un contour de la carte indiquant comment les différents empilages de couches sont affectés aux régions de la carte. Utilisez le curseur pour modifier l’échelle du contour de carte affiché.
- Show Total Board Thickness - activez cette option pour afficher l’épaisseur totale de la carte sous la grille du tableau d’empilage des couches.
- Line Width - spécifiez l’épaisseur du trait du texte dans le tableau. Line Width influe sur l’épaisseur du trait du texte.
- Text Height - hauteur actuelle des caractères du texte. Spécifiez la hauteur du texte dans le tableau. Text Height influe également sur la taille du tableau. Si la hauteur du texte est augmentée, le tableau s’agrandit automatiquement.
Type de police
-
TrueType - utilisez ce champ pour choisir la police TrueType souhaitée. La liste déroulante Font contient les polices TrueType et OpenType (un sur-ensemble de TrueType) présentes dans le dossier
\Windows\Fonts. Notez que la liste ne comprend que les polices de base détectées dont le nom est unique. Utilisez les options B (bold) et I (Italic) pour mettre le texte en évidence. -
Stroke
-
Font - utilisez ce champ pour choisir la police de traits souhaitée. Les options disponibles sont :
-
Default- une police vectorielle simple prenant en charge le traçage à la plume et le phototraçage vectoriel. -
Serif- une police plus complexe qui ralentit la génération des sorties vectorielles, telles que les fichiers Gerber. -
Sans Serif- une police plus complexe qui ralentit la génération des sorties vectorielles, telles que les fichiers Gerber.
-
-
Font - utilisez ce champ pour choisir la police de traits souhaitée. Les options disponibles sont :
-
Stroke Width - affiche l’épaisseur de trait actuelle.
Colonnes
Utilisez cette zone pour spécifier les colonnes à afficher dans le tableau d’empilage des couches, l’alignement du texte dans chaque colonne et la largeur totale de chaque colonne.
- Caption - le titre de la colonne à afficher.
- Align - cliquez sur la cellule d’alignement correspondant à l’intitulé à aligner. Cliquez plusieurs fois pour parcourir les options d’alignement (à gauche, centré et à droite). Chaque clic dans le champ d’alignement modifie l’alignement du texte de cette colonne dans le tableau.
-
Width - cliquez dans le champ pour modifier la largeur de la colonne correspondant à l’intitulé sélectionné. Lorsque
Autoest spécifié, le système ajuste automatiquement la largeur de la colonne en fonction du texte qu’elle contient. Vous pouvez saisir la largeur souhaitée si nécessaire. - Add - utilisez la liste déroulante pour ajouter une colonne au tableau d’empilage des couches parmi les options disponibles. Dans la liste déroulante, cliquez sur l’intitulé à faire apparaître dans le tableau.
- Up - cliquez pour déplacer l’intitulé sélectionné d’une colonne vers la gauche dans le tableau. Cliquez plusieurs fois sur le bouton Up pour déplacer la colonne sélectionnée de plusieurs colonnes vers la gauche.
- Down - cliquez pour déplacer l’intitulé sélectionné d’une colonne vers la droite dans le tableau. Cliquez plusieurs fois sur le bouton Down pour déplacer la colonne sélectionnée de plusieurs colonnes vers la droite.
-
- cliquez pour supprimer l’intitulé sélectionné du tableau. Une demande de confirmation apparaît dans le tableau pour vous demander si vous souhaitez supprimer l’élément sélectionné. Cliquez sur Yes pour le supprimer ; No dans le cas contraire.
Tableau de perçage

Le tableau de perçage présente un récapitulatif en temps réel de tous les trous de perçage présents sur la carte
Un tableau de perçage (également appelé tableau du plan de perçage ou légende du plan de perçage) est un élément standard requis pour la fabrication d’un circuit imprimé. Il répertorie la taille et le nombre de trous pour chaque foret utilisé sur la carte. Chaque diamètre de perçage peut être représenté par un symbole, une lettre ou le diamètre réel du trou. Lorsqu’un plan de perçage est généré pour la carte, chaque emplacement de perçage est repéré par un symbole. Le tableau de perçage est mis à jour en temps réel : lorsque des objets comportant des trous, tels que des pastilles et des vias, sont placés ou supprimés dans la conception du PCB, le tableau est actualisé.
Un tableau de perçage ne peut être placé que dans l’éditeur PCB. Après le lancement de la commande, un tableau de perçage apparaît attaché au curseur. Positionnez le tableau à un emplacement approprié en dehors de la carte, puis cliquez ou appuyez sur Enter pour le placer.
Les actions supplémentaires suivantes sont possibles pendant le placement, tant que le tableau de perçage est encore attaché au curseur et avant qu’il ne soit ancré :
- Appuyez sur la touche Tab pour suspendre le placement et accéder au mode Tableau de perçage du panneau Properties , où vous pouvez modifier ses propriétés à la volée. Cliquez sur le bouton de pause superposé pour reprendre le placement.
- Appuyez sur la touche Alt pour contraindre le déplacement à l’axe horizontal ou vertical selon la direction initiale du mouvement.
Déplacer un tableau de perçage
Cliquez n’importe où dans le tableau de perçage et maintenez le bouton enfoncé, puis déplacez-le vers l’emplacement souhaité dans l’espace de conception de l’éditeur PCB.
Redimensionner un tableau de perçage de manière interactive
Les dimensions du tableau de perçage sont automatiquement définies en fonction du paramètre Text Height spécifié, du nombre de diamètres de trous différents (lignes) et du nombre de colonnes définies. Pour redimensionner le tableau de manière interactive, cliquez une fois pour le sélectionner, puis cliquez sur un sommet d’angle et maintenez le bouton enfoncé, avant de déplacer le curseur pour obtenir les dimensions souhaitées. Notez que le redimensionnement interactif du tableau augmente ou diminue également la taille de la police.
Changer de manière interactive la paire de couches à prévisualiser
Lorsque la carte comporte des paires de couches, la paire affichée est déterminée par l’option Layers Pairs du mode Drill Table du panneau Properties .
La paire de couches sélectionnée peut également être changée à l’aide des éléments suivants :
-
Menu contextuel de l’éditeur PCB : faites un clic droit sur le tableau de perçage, puis sélectionnez la paire de couches souhaitée dans le sous-menu Drill Table, comme illustré ci-dessous.

Faites un clic droit sur le tableau de perçage pour afficher une autre paire de couches -
Menu de sélection de la paire de couches, accessible via l’onglet de couche situé en bas de l’espace de conception, comme illustré ci-dessous.
Propriétés du tableau de perçage

Le mode Drill Table du panneau Properties
Actions
Refresh – cliquez sur le bouton pour mettre à jour le tableau de perçage avec les données actuelles des symboles de perçage du PCB.
Emplacement
-
(X/Y) – coordonnées X et Y actuelles du point de référence du tableau de perçage. Le point de référence est le coin inférieur gauche si Alignment =
Bottom, ou le coin supérieur gauche si Alignment =Top. - Rotation – angle de rotation du tableau de perçage, en degrés.
Propriétés
-
Layer Pairs – le tableau de perçage prend en charge les cartes multicouches utilisant le perçage par paires de couches. Utilisez la liste déroulante pour sélectionner une paire de couches définie dans l’onglet Types de vias du gestionnaire d’empilage des couches ou l’une des options suivantes :
- All Layer Pairs (Composite table) – affiche les informations pour toutes les paires de couches.
-
All Layer Pairs (Separate tables) – affiche les informations pour chaque paire de couches dans un tableau distinct.
- Top - Bottom – affiche uniquement les trous traversants.
- Counterhole Bottom – affiche uniquement les lamages et fraisures sur la face inférieure du PCB.
- Counterhole Top – affiche uniquement les lamages et fraisures sur la face supérieure du PCB.
- Text Height – affiche la hauteur du texte.
Type de police
-
TrueType – sélectionnez cette option pour utiliser les polices disponibles sur votre PC (dans le dossier \Windows\Fonts). Les polices TrueType prennent entièrement en charge Unicode. Par défaut, le logiciel établit un lien vers la police TrueType utilisée (elle n’est pas stockée dans le fichier PCB), ce qui signifie que cette même police doit être présente sur chaque PC vers lequel la conception est transférée. Vous pouvez également incorporer les polices TrueType utilisées dans le fichier PCB à l’aide des options de la page Éditeur PCB – Polices TrueType de la boîte de dialogue Preferences, où vous pouvez aussi sélectionner une Substitution Font à utiliser si une police non incorporée n’est pas disponible.
- Font – utilisez la liste déroulante pour sélectionner la police TrueType souhaitée. Utilisez B pour mettre le texte en gras ou I pour le mettre en italique.
-
Stroke
-
Font – utilisez la liste déroulante pour sélectionner la police vectorielle souhaitée. Les choix sont les suivants :
-
Default– une police vectorielle simple conçue pour le traçage à la plume et le phototraçage vectoriel. -
Sans Serif -
Serif
-
- Stroke Width – affiche l’épaisseur du trait.
-
Font – utilisez la liste déroulante pour sélectionner la police vectorielle souhaitée. Les choix sont les suivants :
- Show Footer – activez ou désactivez l’affichage du pied de tableau.
- Alignment – le tableau peut être construit de bas en haut (Bottom) ou de haut en bas (Top). Utilisez ce paramètre pour permettre de modifier la taille du tableau sans affecter les objets environnants dans l’espace de conception.
- Table Border Width – épaisseur des lignes constituant la bordure du tableau.
-
Drill Symbols – cliquez pour ouvrir la boîte de dialogue Drill Symbols, dans laquelle vous pouvez attribuer des symboles ou des lettres aux diamètres des trous.
Options et commandes de la boîte de dialogue Symboles de perçage
Grid Area
La grille affiche des informations détaillées sur l’association d’un symbole à un diamètre de trou. Vous pouvez la personnaliser en faisant glisser un en-tête de colonne pour modifier l’ordre des colonnes et en cliquant avec le bouton droit sur un en-tête de colonne, puis en cochant ou décochant la case correspondante pour afficher ou masquer la colonne.
Grouping
Cliquez sur le bouton Grouping pour définir les propriétés à utiliser pour attribuer les symboles aux perçages (trous). Les trous sont d’abord regroupés par diamètre, puis des symboles distincts leur sont attribués lorsqu’une option de regroupement permettant de les distinguer est activée. Par exemple, la conception peut comprendre une pastille ronde avec un trou de 1 mm et une autre pastille carrée avec un trou de 1 mm. Si Pad Shape n’est pas activé dans Grouping, le même symbole leur sera attribué. En revanche, si Pad Shape est activé dans Grouping, des symboles distincts leur seront attribués.
Graphic Symbol
Chaque emplacement de trou peut être représenté par un symbole, une lettre ou une chaîne de caractères indiquant le diamètre réel du trou. Ces options contrôlent le style et la taille des symboles :
-
Symbol - sélectionnez cette option pour utiliser un symbole à chaque emplacement de trou. Le logiciel comprend 15 styles de symboles prédéfinis, comme illustré ci-dessous. S’il existe plus de 15 diamètres de trous, des caractères alphabétiques sont automatiquement attribués.
- Character - sélectionnez cette option pour utiliser un caractère alphabétique à chaque emplacement de trou.
- Symbol Size - hauteur du symbole ou de la lettre affiché sur la couche de dessin de perçage. Notez que ce paramètre s’applique à tous les symboles et lettres utilisés sur le dessin de perçage.
Draw Symbols
Ces options contrôlent le style des symboles de perçage et les conditions de leur affichage :
- Show Symbols - affiche un symbole à chaque emplacement de trou.
- Show Hole Size - affiche le diamètre réel de perçage à chaque emplacement de trou sous forme de valeur numérique.
- Show Drill Symbols - par défaut, les symboles de perçage ne sont pas affichés sur la couche de dessin de perçage. Activez cette option pour les afficher.
-
-
– cliquez pour actualiser le tableau lorsque des modifications de la conception affectent le tableau de perçage. Notez que le tableau est automatiquement mis à jour lors de la génération des fichiers de sortie.
Unités
-
Primary Units – utilisez la liste déroulante pour définir les unités principales sur
Metric (mm)ouImperial (mil). -
Dual Units – utilisez la liste déroulante pour définir les unités secondaires sur
Metric (mm)ouImperial (mil). Utilisez
ou
pour afficher ou masquer (respectivement) ces unités dans l’espace de conception.
Précision
- Primary Precision – utilisez la liste déroulante pour définir la précision requise (nombre de chiffres après la virgule).
- Dual Precision – utilisez la liste déroulante pour définir la précision des unités secondaires (nombre de chiffres après la virgule).
Colonnes
- Grid – affiche tous les en-têtes de colonne (Caption) du tableau de perçage, le paramètre Align, qui repositionne le contenu dans la grille, le Width et le Order dans lequel les informations de chaque colonne sont affichées. Pour passer de l’ordre croissant à l’ordre décroissant et inversement, cliquez dans la colonne Order pour accéder à un menu déroulant, puis sélectionnez l’ordre souhaité : Asc – croissant ou Dsc – décroissant.
-
Edit Columns – cliquez pour ouvrir la boîte de dialogue Columns, qui permet d’ajouter de nouvelles colonnes au tableau de perçage ou de modifier les colonnes existantes.
La boîte de dialogue présente toutes les colonnes existantes, ainsi que les données associées (en lecture seule). Utilisez les boutons suivants sous la grille pour choisir les données à présenter dans le tableau :
- Add Column - permet d’ajouter une nouvelle colonne au tableau de perçage. Cliquez pour ouvrir un menu des colonnes disponibles. Les colonnes déjà utilisées ou non disponibles sont grisées dans le menu. Cette commande est également disponible dans le menu contextuel accessible par clic droit.
- Remove Column - cliquez pour supprimer la ou les colonnes sélectionnées. Notez qu’aucune boîte de dialogue de confirmation ne s’affiche ; la colonne est supprimée dès que vous cliquez sur le bouton. Cette commande est également disponible dans le menu contextuel accessible par clic droit.
- Change Header - cliquez pour ouvrir la boîte de dialogue Modifier l’en-tête de colonne, dans laquelle vous pouvez modifier le titre de la colonne sélectionnée. Cette commande (intitulée Change column header) est également disponible dans le menu contextuel accessible par clic droit.
Les commandes supplémentaires suivantes sont disponibles dans le menu contextuel accessible par clic droit :
-
Text Alignment - permet d’aligner le texte dans la colonne sélectionnée. Les choix possibles sont :
Left,CenteretRight. -
Set column width - permet de définir la largeur de la colonne sélectionnée. Les choix possibles sont :
Autosize(par défaut) etManual. Cliquez surManualpour ouvrir la boîte de dialogue Définir la largeur de colonne, dans laquelle vous pouvez saisir la largeur souhaitée.
Vue de conception

Placez une vue de conception pour afficher une zone spécifique de la carte. Dans cet exemple, l’échelle a été définie sur 200 %.
L’objet Vue de conception PCB est un instantané graphique de n’importe quelle zone rectangulaire de la carte actuelle ou d’une autre carte. Il peut être placé n’importe où dans l’espace de conception et mis à l’échelle à la taille souhaitée.
Une vue de conception ne peut être placée que dans l’éditeur PCB. Après le lancement de la commande de placement d’une vue de conception (Place » Design View), une vue de conception apparaît attachée au curseur. Positionnez-la à un emplacement approprié, puis cliquez ou appuyez sur Enter pour la placer.
Les actions supplémentaires suivantes peuvent être effectuées pendant le placement, tant que la vue de conception est encore attachée au curseur et avant qu’elle ne soit ancrée :
- Appuyez sur la touche Alt pour contraindre le déplacement à l’axe horizontal ou vertical, selon la direction initiale du mouvement.
Après avoir placé la vue de conception, vous pouvez définir l’affichage des couches souhaitées en procédant comme suit :
- Une fois la vue de conception sélectionnée dans l’espace de conception, ouvrez le panneau Propriétés en double-cliquant ou en faisant un clic droit, puis en choisissant Properties dans le menu contextuel.
- Utilisez le bouton Define dans le panneau Properties pour définir interactivement la zone d’intérêt.
-
Dans la section Layers du panneau Properties , cliquez sur l’icône
pour activer ou désactiver l’affichage des couches souhaitées. Lorsque leur affichage est activé dans le panneau Properties , les couches souhaitées affichent l’icône
.
Les vues de conception sont incluses dans les sorties imprimées et PDF. La vue de conception conserve ses propres paramètres de visibilité des couches dans la sortie, ce qui permet de la présenter comme souhaité dans la sortie imprimée/PDF. Notez que les primitives des couches utilisées dans la vue de conception continuent de respecter les paramètres d’affichage définis pour cette couche dans la boîte de dialogue Imprimer. Par exemple, si la sérigraphie supérieure est affichée dans la vue de conception et qu’elle est configurée pour afficher les pistes en mode brouillon pour cette sortie dans le fichier Output Job, les pistes de la sérigraphie supérieure dans la vue de conception seront également affichées en mode brouillon.
Une fois une vue de conception placée dans l’espace de conception, vous pouvez ajuster interactivement sa position, son échelle, sa taille et la zone affichée.
- Change the position – Click+Drag l’objet Vue de conception vers un nouvel emplacement dans l’espace de conception PCB.
- Adjusting the Scale – cliquez une fois pour sélectionner la vue de conception, puis Click+Drag sur une poignée d’angle pour agrandir la vue de conception (en faisant glisser vers l’extérieur) ou la réduire (en faisant glisser vers l’intérieur).
- Adjusting the View Size – cliquez une fois pour sélectionner la vue de conception, puis Ctrl+Click+Drag sur une poignée d’angle pour redimensionner la vue de conception.
- Changing the Focus – Ctrl+Click+Drag n’importe où dans la vue de conception pour faire glisser la zone actuellement affichée à l’intérieur de la fenêtre de la vue de conception.

Ctrl+Click+Drag pour faire glisser et ajuster la zone actuellement affichée dans la vue de conception.
Propriétés de la vue de conception

Le mode Design View du panneau Properties.
Emplacement
- (X/Y) - les coordonnées X et Y actuelles du point de référence de la vue de conception.
Propriétés
- This document - sélectionnez cette option pour spécifier les propriétés du document actuellement actif.
-
Specify document - sélectionnez cette option pour spécifier les propriétés d’un autre document. Une fois cette option sélectionnée, cliquez sur
dans le champ Document , puis recherchez le document souhaité.
-
Document - cliquez sur
pour rechercher et sélectionner le document souhaité lorsque Specify document est sélectionné.
- Mirrored - cliquez pour activer une image inversée (en miroir) de la zone de la carte dans la vue de conception.
- Scale - cliquez pour définir la taille de l’objet à l’aide d’un facteur multiplicateur.
- Title - saisissez le titre de la vue de conception.
- Text Height - saisissez la hauteur du texte du titre de la vue de conception.
- Font - utilisez la liste déroulante pour sélectionner la police souhaitée pour le titre. Utilisez la case de couleur pour ouvrir un sélecteur de couleur pour le texte du titre. Notez que la couleur doit contraster avec la couleur d’arrière-plan de l’espace de conception pour que le texte soit visible.
- Define - cliquez pour revenir à l’espace de conception avec un curseur en croix, puis cliquez et faites glisser pour définir la zone rectangulaire de la vue.
Couches
Cette zone présente la liste de toutes les couches de la carte et permet de configurer les couches à afficher dans la vue de conception.
-
Name - le nom de la couche. Utilisez le
ou
pour afficher ou masquer (respectivement) la couche répertoriée dans la vue de conception.
- Type - le type de couche.
Objet OLE

Une série d’objets OLE placés : une image, des cellules de feuille de calcul et du texte de document Word (de haut en bas)
La technologie de liaison et d’incorporation d’objets (OLE) de l’éditeur PCB permet d’incorporer dans une conception PCB des données fournies par des applications OLE Windows, tout en maintenant un lien actif avec l’application source. Dans de nombreux cas, cela permet de modifier les données incorporées au PCB depuis l’application qui les a créées.
Les objets OLE couramment placés dans un document PCB comprennent des documents Excel, des documents Word ou des objets graphiques provenant d’une application de traitement d’images compatible OLE. Les types de fichiers pris en charge comprennent des formats universels tels que les feuilles de calcul CSV et XLS, les documents texte DOC et RTF et les fichiers image BMP.
Les objets OLE peuvent être placés ou incorporés dans l’éditeur PCB. Après avoir lancé la commande Place » Object From File, choisissez le fichier souhaité dans la boîte de dialogue Choose File, puis cliquez pour placer l’objet dans l’espace de conception.
La fonction de collage intelligent d’Altium permet également de copier une sélection dans une application OLE et de la coller (Edit » Paste) dans le document PCB en tant qu’objet OLE. L’option de collage de texte (Edit » Paste Text) permet, si nécessaire, d’extraire les éléments textuels d’un objet OLE. Ceux-ci sont alors placés sous forme d’objets texte PCB.
Une fois placés, les objets incorporés peuvent être redimensionnés proportionnellement en faisant glisser leurs poignées de sélection tout en maintenant le bouton de la souris enfoncé. Pour les objets textuels tels que les documents Word et Excel, la taille et l’épaisseur du texte incorporé sont automatiquement ajustées aux nouvelles dimensions.
- Un objet OLE peut également être converti en un ensemble de primitives libres à l’aide de la commande Tools » Convert » Explode OLE Object to Free Primitives. L’objet est alors décomposé en objets région et/ou texte appropriés.
- Une option de conversion en primitives libres est également proposée si l’application OLE correspondante est introuvable lors d’une tentative de modification d’un objet OLE.
Propriétés de l’objet OLE

Le mode OLE Object du panneau Properties.
Emplacement
- (X/Y) - les coordonnées actuelles X (horizontale) et Y (verticale) du point de référence de l’objet par rapport à l’origine actuelle de l’espace de conception. Modifiez-les pour changer la position de l’objet.
- Rotation - l’angle de rotation de l’objet (en degrés), mesuré dans le sens antihoraire à partir de zéro (l’horizontale 3 o'clock). Modifiez-le pour changer la rotation de l’objet. La résolution angulaire minimale est de 0,001°.
Propriétés
- Layer - la couche à laquelle l’objet est actuellement affecté. Utilisez la liste déroulante pour sélectionner une autre couche.
- Edit Data - cliquez pour ouvrir l’objet (dans l’application associée) et effectuer les modifications nécessaires. Après avoir effectué les modifications et fermé l’application associée, dans le panneau Propriétés, cliquez sur Save pour enregistrer les modifications ou sur Cancel.
Cotes
Les éditeurs PCB et de bibliothèques PCB comprennent une gamme d’outils de cotation adaptés aux différentes exigences de conception.
| Objet de cotation | Description |
|---|---|
| Angular Dimension | Permet de coter des distances angulaires. |
| Baseline Dimension | Permet de coter les distances linéaires d’un ensemble de références par rapport à une référence de base unique. Le premier point choisi constitue la « base ». Tous les points suivants sont définis par rapport à ce premier point. Dans chaque cas, la valeur de la cote correspond donc à la distance entre chaque point de référence et la « base », mesurée dans les unités par défaut. Les références peuvent être des pistes, des arcs, des pastilles, des vias, des textes, des remplissages, des polygones ou des composants. |
| Center Dimension | Permet de marquer le centre d’un arc ou d’un cercle. |
| Leader Dimension | Permet d’étiqueter un objet, un point ou une zone. Trois types de lignes de repère sont disponibles : Automatique, Rond et Carré, selon que le texte de l’étiquette est entouré d’un cercle, d’un carré ou d’aucun cadre. Le pointeur peut être une flèche ou un point. |
| Linear Dimension | Permet de coter une distance linéaire. La valeur de la cote correspond à la distance entre les marqueurs de début et de fin (points de référence sélectionnés par l’utilisateur), mesurée dans les unités par défaut. Les références peuvent être des objets (pistes, arcs, pastilles, vias, textes, remplissages, polygones ou composants) ou des points dans l’espace libre. |
| Linear Diameter Dimension | Permet de coter le diamètre d’un arc ou d’un cercle plutôt que son rayon. La cote peut être placée à l’intérieur ou à l’extérieur. |
| Ordinate Dimension | Permet de coter les distances linéaires d’un ensemble d’objets par rapport à un objet de référence unique. Le premier objet choisi constitue la « base ». Tous les objets suivants sont définis par rapport à ce premier objet. Dans chaque cas, la valeur de la cote correspond donc à la distance entre chaque objet de référence et la « base », mesurée dans les unités par défaut. Les références peuvent être des pistes, des arcs, des pastilles, des vias, des textes, des remplissages, des polygones ou des composants. |
| Radial Dimension | Permet de coter le rayon d’un arc ou d’un cercle. La cote peut être placée à l’intérieur ou à l’extérieur. |
| Radial Diameter Dimension | Permet de coter le diamètre d’un arc ou d’un cercle plutôt que son rayon. La cote peut être placée à l’intérieur ou à l’extérieur, par rapport à la circonférence de l’arc ou du cercle. |
| Standard Dimension | Place les informations de cotation sur la couche PCB active. La valeur de la cote correspond à la distance entre les marqueurs de début et de fin, mesurée dans les unités par défaut. |
Les objets de cotation sont disponibles dans le sous-menu Place » Dimension des menus principaux. Lors de la cotation d’un objet, des points d’ancrage apparaissent et mettent en évidence les endroits où la cote peut être attachée. La barre d’état affiche des informations sur les actions à effectuer à chaque étape du processus. Le point le plus proche du curseur est celui qui sera utilisé et auquel la cote sera attachée si vous cliquez ou appuyez sur Enter.
La vidéo ci-dessous présente des exemples de placement de certaines cotes.
Les actions supplémentaires pouvant être effectuées pendant le placement sont les suivantes :
- Appuyez sur les touches + et - (du pavé numérique) pour parcourir toutes les couches visibles de la conception, respectivement vers l’avant et vers l’arrière, afin de changer rapidement de couche de placement.
- Lors du placement d'une cote à ligne de base, de centre, de diamètre linéaire, linéaire ou par coordonnées, appuyez sur Spacebar pour faire pivoter la cote dans le sens antihoraire ou sur Shift+Spacebar pour la faire pivoter dans le sens horaire. La rotation s'effectue selon la valeur de Rotation Step définie sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Lors du placement d'une cote standard, appuyez sur la touche L pour retourner la cote sur l'autre face de la carte. Notez que cela n'est possible qu'avant d'ancrer le point de départ de la cote.
La valeur d'une cote (le cas échéant) est automatiquement mise à jour lorsque ses points de départ ou d'arrivée sont déplacés. De même, si la position d'un objet auquel un point de référence de la cote est ancré change, la cote est mise à jour et s'allonge ou se raccourcit en conséquence. Pour une cote de rayon ou de diamètre, la valeur est automatiquement mise à jour lorsque le diamètre de l'arc ou du cercle de référence change.
Lorsque la ou les références auxquelles un objet de cotation est rattaché sont supprimées, une boîte de dialogue s'ouvre pour vous demander si la cote doit également être supprimée. Si elle n'est pas supprimée, elle reste dans l'espace de conception, mais sans référence.
Un objet de cotation peut être déplacé des façons suivantes :
- Selecting both the dimension object and the dimensioned object(s). L'ensemble peut être déplacé vers un nouvel emplacement par glisser-déposer, selon les besoins.
- Selecting a dimensioned object only. Le texte de la cote suit l'objet uniquement dans son plan d'alignement. Les lignes d'attache de la cote (ou, pour une cote de diamètre radial ou de rayon, sa flèche et sa queue) s'allongent ou se raccourcissent pour maintenir la relation entre la cote et l'objet coté. Pour une cote de centre ou une cote avec ligne de repère, le texte se déplace avec l'objet. Le segment de la cote avec ligne de repère (entre la flèche ou le point et le premier coude défini) s'allonge ou se raccourcit pour maintenir la relation entre la cote et l'objet coté.
- Selecting the dimension object only. Il est important de noter que la cote ne peut pas être déplacée seule si elle est référencée à un objet de conception. Pour déplacer uniquement la cote, vous devez d'abord la détacher du ou des objets qu'elle cote.
Lorsqu'un objet de cotation est sélectionné, des poignées d'édition permettent de modifier la cote placée directement dans l'espace de conception, en changeant graphiquement des propriétés telles que la position de son texte et de ses points de référence. Des exemples de poignées d'édition pour certaines cotes sont présentés ci-dessous.
|
Lorsqu'un objet de cotation linéaire est sélectionné, les poignées d'édition suivantes sont disponibles :
Lorsqu'un objet de cotation angulaire est sélectionné, les poignées d'édition suivantes sont disponibles :
Lorsqu'un objet de cotation radiale est sélectionné, les poignées d'édition suivantes sont disponibles :
Lorsqu'un objet de cotation par coordonnées est sélectionné, les poignées d'édition suivantes sont disponibles.
|
Les poignées situées sur les objets cotés (ou au plus près de ceux-ci), par exemple C et D pour une cote linéaire, ou C et E ainsi que D et F pour une cote angulaire, comme illustré ci-dessus, permettent de redéfinir les références : une fois détachée d'un objet de référence, la cote devient sans référence et peut être déplacée pour être rattachée à un autre point ou objet de référence. Lorsque vous faites glisser l'une des poignées d'édition d'une cote linéaire, par coordonnées ou à ligne de base sans référence, vous pouvez faire pivoter la cote.
Propriétés des objets de cotation
Les cotes disposent de diverses options de configuration, offrant un haut niveau de personnalisation des flèches et du texte. Ouvrez le panneau Properties pour un ou plusieurs objets de cotation sélectionnés afin de modifier leurs propriétés.
| Propriété | Objets concernés | Description |
|---|---|---|
Style |
||
| Width | Tous, sauf les cotes de centre et par coordonnées | Épaisseur actuelle de la ligne de cote. |
| Width (dans la zone Extension Line) | Cote angulaire Cote à ligne de base Cote linéaire Cote de diamètre linéaire Cote par coordonnées |
Épaisseur actuelle des lignes d'attache de la cote. |
| Gap | Cote angulaire Cote à ligne de base Cote avec ligne de repère Cote linéaire Cote de diamètre linéaire Cote par coordonnées |
|
| Offset | Cote angulaire Cote à ligne de base Cote linéaire Cote de diamètre linéaire |
Décalage actuel de la ligne de flèche par rapport à la ligne d'attache de la cote. |
| Text Gap | Tous, sauf les cotes de centre et standard |
|
| Leader Shape | Cote avec ligne de repère | Utilisez la liste déroulante pour définir la forme utilisée pour encadrer le texte de cote. Les options disponibles sont Automatic, Round et Square. Si Round ou Square est sélectionné, saisissez la valeur souhaitée pour Size. |
| Arrow Style | Cote avec ligne de repère | Utilisez la liste déroulante pour sélectionner le style de ligne de repère souhaité. Les choix sont Arrow ou Dot. Saisissez la valeur souhaitée pour Size. |
| Height | Cote standard | Hauteur actuelle de la ligne d’attache. |
| Arrow Size | Cote angulaire Cote en parallèle Cote linéaire Cote de diamètre linéaire Cote radiale Cote de diamètre radial |
Taille actuelle de la pointe de flèche. Cette taille correspond à la distance entre la pointe de la flèche et l’extrémité de ses branches. |
| Arrow Length | Cote angulaire Cote en parallèle Cote linéaire Cote de diamètre linéaire Cote radiale Cote de diamètre radial |
Longueur actuelle de la flèche. Notez que la valeur saisie dans ce champ n’est appliquée que lorsque Arrow Position (dans la zone Properties ) est défini sur Outside. |
Propriétés |
||
| Text | Cote avec ligne de repère | Saisissez le texte souhaité. |
| Layer | Toutes | Couche à laquelle la cote est actuellement affectée. Utilisez la liste déroulante pour sélectionner la couche souhaitée. Les cotes peuvent être affectées à n’importe quelle couche disponible. |
| Text Position | Toutes, sauf les cotes de centre et les cotes standard | Position actuelle du texte de cote. Utilisez la liste déroulante associée pour choisir l’une des options suivantes (les options disponibles dépendent du type d’objet de cote) :
|
| Arrow Position | Cote angulaire Cote en parallèle Cote linéaire Cote de diamètre linéaire Cote radiale Cote de diamètre radial |
Position actuelle des flèches de cote. Les options disponibles sont :
|
| Angular Step | Cote de diamètre radial | Réglage actuel du pas angulaire de la cote. Il s’agit du pas de rotation utilisé lors du placement de la partie fléchée de la cote. Lorsque vous déplacez la flèche autour du cercle ou de l’arc pendant le placement de la cote, le nombre et la position des points d’ancrage possibles de la cote sont déterminés par cette valeur de pas angulaire. |
| Text Height | Toutes, sauf les cotes de centre | Hauteur actuelle des caractères du texte de cote. La largeur des caractères utilisée pour afficher ou imprimer le texte est automatiquement proportionnelle à cette hauteur. Une hauteur minimale de 36mil (0.9mm) permet un phototraçage lisible du texte. |
| Rotation | Cote de centre Cote linéaire Cote de diamètre linéaire Cote à coordonnées |
Angle d’alignement de la cote, mesuré en degrés dans le sens antihoraire à partir de l’horizontale. |
| Size | Cote de centre | Longueur actuelle des lignes du réticule de la cote (ou diamètre du cercle qui les entoure). |
| Font Type | Toutes, sauf les cotes de centre |
|
Unités |
||
| Primary Units | Cote angulaire Cote à partir d’une référence Cote linéaire Cote de diamètre linéaire Cote ordonnée Cote radiale Cote de diamètre radial |
L’unité actuellement sélectionnée pour le calcul et l’affichage de la valeur de la cote.
|
| Value Precision | Cote angulaire Cote à partir d’une référence Cote linéaire Cote de diamètre linéaire Cote ordonnée Cote radiale Cote de diamètre radial |
Le réglage actuel du nombre de décimales à afficher pour la valeur de la cote. |
Valeur |
||
| Format | Toutes, sauf les cotes de centre et de repère |
Le réglage actuel du format du texte de cote. Utilisez la liste déroulante associée pour modifier le format selon vos besoins. Les options proposées dépendent du Unit choisi et sont présentées en fonction de la valeur réelle de la cote actuelle. De manière générale, les options disponibles sont les suivantes (les options disponibles dépendent du type d’objet de cote) :
|
| Prefix | Cote angulaire Cote à partir d’une référence Cote linéaire Cote de diamètre linéaire Cote ordonnée Cote radiale Cote de diamètre radial |
Le préfixe de la valeur de la cote. Pour une cote de diamètre linéaire ou de diamètre radial, ce champ contient le caractère fixe ø. |
| Suffix | Cote angulaire Cote à partir d’une référence Cote linéaire Cote de diamètre linéaire Cote ordonnée Cote radiale Cote de diamètre radial |
Le suffixe de la valeur de la cote. |
| Sample | Toutes, sauf les cotes de centre et de repère |
Ce champ présente un aperçu du texte de cote conformément au Format spécifié et aux éventuels Prefix et/ou Suffixdéfinis. |
| Start point (X/Y) | Cote standard | Le point de départ de la cote en X (première valeur) et en Y (deuxième valeur). |
| End point (X/Y) | Cote standard | Le point d’arrivée de la cote en X (première valeur) et en Y (deuxième valeur). |
Conversion des cotes en primitives
Les cotes sont des objets de conception groupés, c’est-à-dire qu’elles se composent d’un ou plusieurs segments de texte et de piste. Une cote peut être convertie en ses objets primitifs constitutifs à l’aide de la commande Tools » Convert » Explode Dimension to Free Primitives.


